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 Word for Windows 6.0

 Doc Err's
 Print Key Assignments Prints Only Reassignments of Keys

 Vertical Alignment in Section Doesn't Justify Without Breaks
 Word for Windows: Creating Multiple Tables of Contents
 WinWord Documentation Error: Spacing Before Setting
 WordBasic Error Using Caret for Exponentiation in Math Formula
 WinWord: Undocumented Key Codes for Macro Keyboard Assignments
 Word: Print Merge Does Not Include Tables or Graphics
 WinWord: Changing Templates Does Not Copy Styles or Margins
 ShowAll() Function Causes WordBasic Err=100: Syntax Error

 Format Print Merge Output with Switches or MERGEFIELD Keyword
 Pressing CTRL+N Indents to Custom Tab, Not to Default Tab Stop
 Cannot Assign Macro to PAGE UP, PAGE DOWN, HOME, or END Keys
 Undocumented MsgBox Type Arguments for Old Dialog Box Styles
 How to Cross Reference Sequence Fields
 Wrong Error Message Saving Template Using FileSaveAs Macro
 Error Message: The Custom Dictionary Is Not Available
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 Fields
 Cannot Create Index Entries from Footnotes in Word for Windows

 Updating Field Moves Insertion Point to Beginning of Field
 Including Excel Charts in WinWord Documents with DDE
 Field Not Updating and/or No Result
 WinWord: Multiple References to the Same Footnote

 Multiple Word Text in a Date-Time Picture Switch
 ASK and SET Return No Error with Invalid Bookmark
 EDITTIME Must Be in Minutes
 Cannot Format TIME or EDITTIME to Display Seconds
 WinWord Err Msg: Cannot Sort Fields in Selection
 INDEX and XE (Index Entry) Are Case Sensitive in WinWord
 'Index' Field \e or \l Switch Limited to Three Characters
 "if" Field Ignoring Nested "eq" Field in Word for Windows

 Printing a Page Border with PostScript in Word for Windows
 Can't Enter Text Inside Field Code Brackets in WinWord
 Can't Include an Excel Chart with an {include} Field
 Exclamation Marks Not Allowed in Calculated Selection
 Using the {print} Field with Dot-Matrix Printers and Winword
 Footnote References Renumbered in Word for Windows Tables
 WinWord: Reverse Print (White on Black) with LaserJet III
 Using the ASK Field with the IF Field in Word for Windows

 SKIPIF No Longer Functions Properly if Used With NEXT Field
 Underlining Superscripted Characters
 Keystrokes to Insert Page Number, Date, and Time in WinWord
 Example IF Fields for Print Merging in Word for Windows
 Using the Lock Result Switch in Word for Windows
 Formula in Table Produces Error in WinWord
 Macro to Designate Table of Contents Entry Automatically
 Utilities Renumber Command Deletes Abbreviations in WinWord
 Print Merge Even/Odd Records in WinWord Form Letters

 Using MERGEREC to Number Print Merge Records
 Using the {Autonum} Field Inside a WinWord Table Cell
 Table of Contents Left-Aligns Page Numbers
 Word for Windows: Suppressing Blank Spaces in Print Merge
 Word for Windows: Using the Ordinal Switch in a DATE Field
 Word for Windows: Creating Multiple Tables of Contents
 Setting Sequence Numbering Using a Bookmark in WinWord
 Button Fields Following Nonupdated Field Don't Work Correctly
 Nested Fields in IF Statement Always Update in WinWord
 WinWord: Paragraph Return Inserted Between Separate Indexes

 Control Panel Changes Insert Field Date and Time Instructions



 Placing Boxes Around Characters and Words
 Incorrect Merge Results with Conditional IF Statement
 Index Ignores Fields in Index Entry in Word for Windows
 Paragraph Inserted with Paste Linked Spreadsheet from Excel
 Automatic Paper Tray Switching on HP LaserJet in WinWord
 Placing Sequential Page Numbers in Columns on Same Page
 Maximum Page Number with PAGE Field in Word for Windows
 Cannot Insert Nested Formula with Insert Field Command

 WinWord: Revision Marks Not Displayed with Field Code Results
 Field Braces Not Ignored During Search in Word for Windows
 Making NUMPAGES Format Match PAGE Number Format in WinWord
 Paragraph Mark Always Inserted in Field With Table as Result
 Can't Access Record Selection Box in WinWord 2.0 Print Merge
 Internal Paste Link Doesn't Update When a New File is Saved
 Field to Print "Continued" in Word for Windows Footers
 SYMBOL Field Font Switches \f, \s, and \h in Word for Windows

 WinWord Outline View May Display Incorrect Number of Pages
 Edited MERGEFIELD Results Do Not Affect Fields in WinWord
 Err Msg: Word is Waiting for the Server to Release Object
 How to Use the MACROBUTTON Field in WinWord Documents
 AUTONUM Field Doesn't Work with IF Statement in WinWord
 Use of "AND" and "OR" with Print Merge Selection Rules
 WinWord: Dates Truncated in Statistics Section of Find File

 WinWord: Calculating Table Values Relative to Current Cell
 Numbering Columns or Creating Page Numbers for Folded Pages
 WinWord: Using Bookmarks in a Table of Contents
 WinWord: Test for Blank Argument Within an Expression Field
 WinWord: TC Field Displays Result
 WinWord: Updating Link Does Not Show Percentage Complete
 WinWord: No Error Message for Invalid OLE Field
 WinWord: Field to Insert Previous Month Based on Current Date

 WinWord: Simulating XOR Logic with Field Codes or WordBasic
 Automating Form Templates Without Using ASK or FILLIN Fields
 WinWord: Two Backslashes Appear in XE Field Before Colon (:)
 Word: Generating an Index with Nonnumeric Chapter Numbers
 Cannot Use \h Together with \* Format Switches in a Field
 WinWord: Updating Fields When File Is Locked for Annotations
 WinWord: Fields Split Over Two Lines in Outline View

 Superscript and Subscript Underline Misaligns in WinWord 2.0
 WinWord: NextField and UpdateField Do Not Update All Fields
 Word for Windows: Creating a Dot-Leader-Delimited Index
 WinWord: Framed & Embedded Object Resizes in Whole Page Zoom
 WinWord: PAGEREF Field with Special Bookmarks Produces Error
 WinWord: ASK Fields with Default Answers Prompt First
 Error Message: Cannot Obtain Data from Excel for <filename>



 WinWord: Referencing Expression Fields from Separate Tables
 WinWord: Insert Page Numbers Switches Header/Footer Option

 Update Source Key Does Not Update Non-WinWord Documents
 WinWord: Placing the Same Page Number on Left and Right Pages
 WinWord: SET and ASK Fields Do Not Work in Headers or Footers
 WinWord: Spelling Checker Updates Fields in Headers & Footers
 Extra Paragraph Mark Above INCLUDE Field at Top of Document
 Text Containing Fields Does Not Convert Correctly to Table
 Effect of \*MERGEFORMAT When Updating Link to Excel Sheet

 Error Updating Internal Link That Is Part of an External Link
 SYMBOL or AUTONUM Field Embedded Inside QUOTE Field Disappears
 Framed, Linked Excel Worksheet Duplicates Itself When Dragged
 Index Entry (XE) Field Truncates Text at Optional Hyphen
 Bullets and Symbols Blink in Normal and Page Layout Views
 Internal Link to Range Includes Entire Document When Updated
 "Error! Not a Valid Embedded Object" Embedding Excel Object

 Infinite Loop Spell Checking "RE: Testt" Using Grammar Checker
 Setting Up Different First Header/Footer for Even/Odd Pages
 WinWord: Bookmarked SEQ Field Returns Incorrect Value
 How to Use Wildcards to Perform Selective Print Merge
 SYMBOL Field May Not Print If Character Spacing is Condensed
 Word: Print Merge Does Not Include Tables or Graphics
 Creating All Odd- or All Even-Numbered Pages in a Document
 How to Apply Formatting to Results of Link to Excel Worksheet

 WinWord: How to Use Dates as Print Merge Selection Criteria
 WinWord: FILLIN Fields in Header Updated at Print or in Views
 WinWord: Use of ASK and FILLIN Fields and \o Switch
 Changing Excel Link Type Resets Table Alignment Formatting
 WinWord: Changing Page Numbering Format in "Page of Pages"
 Err Msg: Number Cannot Be Represented in Specified Format
 Format Print Merge Output with Switches or MERGEFIELD Keyword
 How to Send Printer Escape Codes from a WinWord Document
 Word: FILLIN Field Is Limited to 255 Characters

 Embedded Object Opens in MS Draw from Merged Document
 Extra Minus Signs (-) in Front of Negative Field Result
 Template Field Code Does Not Display "NORMAL.DOT" Template
 EQ Field Codes for Foreign Language Characters: Norwegian
 Cannot Insert Clipboard Contents Using ^c in Edit Replace
 Newline Character Appears As Pipe Character (|) in Dialog Box
 Index Entry Text Truncated Following Tab Character

 EQ, AUTONUM, and SYMBOL Fields Are Blank in Print Merge
 Using Expression Fields to Manipulate Page Numbering
 Macro to Remove Document Index Field Entries
 Numeric Format Switch for Thousands Separator and Dollar Sign
 SYMBOL Field Affects Word Wrapping and Nonbreaking Characters



 Data File Character Formatting Not Retained in Merged Document
 Lowercase Roman Numeral Page Numbers Are Uppercase in TOC
 TOC Field Incorrectly Includes Hidden AUTONUM Field

 How to Cross Reference Sequence Fields
 Conditional Alphanumeric Merge May Yield Incorrect Results
 "Bookmark Not Defined" Replaces Print Merge ASK Field Result
 Maximum Values for Field Format Switches
 Result of SEQ Field Is a Negative Number
 SET Fields Within IF Field Evaluate Incorrectly
 Second NUMWORDS Field Result Is Incorrect
 Page Numbering in "Page of Total Pages in Section" Format

 Err Msg in Place of REF Field Result: Bookmark Not Defined
 FILLIN Field Dialog Box Blank During Print Merge
 Missing Special Characters in Table of Contents
 IF Field Won't Display Table or Linked Graphic as Result
 Creating a Table of Contents That References Ranges of Pages
 Word Changes Alphabetic Chapter References to Numeric
 Expression / Formula Field Functions
 How to Merge Conditional Number of Records to the Same Page
 Error Referencing Bookmarked Heading 7 or Higher

 Blank Line Suppression When Using FILLIN field
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 Converting Files with Extended Characters in Filenames

 WinWord: Cell Line Layout Lost When Converting Table to Text
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 Formatting
 Applying a Style Overrides Existing Paragraph Formatting

 Column of Letters Displays Along Left Side Of WinWord Screen
 Functionality of Style Sheets in Word for Windows
 Applied Style's Character Formatting Changes Entire Paragraph

 Headers and Footers Do Not Wrap Around APOs in WinWord
 WinWord Msg: Save Changes to Style?
 Creating Borders and Tables of Text in Word for Windows
 Text in Table Appears in Columns in Word for Windows
 Changing Footnote Reference Styles in Word for Windows
 Using Tabs Within the Cell of a Table in Word for Windows
 Creating Side-by-Side Tables in Word for Windows
 Multiple Word Text in a Date-Time Picture Switch

 Renumbering Removes Leading Tabs in Word for Windows
 Utilities Renumber Overwrites Leading Paragraph Numbers
 EDITTIME Must Be in Minutes
 Cannot Format TIME or EDITTIME to Display Seconds
 Deleting a Table from a Word for Windows Document
 Removing Direct Character Formatting Using CTRL+SPACEBAR
 Table Cell Formatting with Borders Is Inconsistent
 Auto Outline Numbering and the "Chicago Manual of Style"
 Bold Formatting Lost in Outline Mode in Word for Windows

 Word for Windows: CTRL+H Does Not Toggle Hidden Text
 Large Selection Blanks Ribbon and Some Dialog Box Settings
 Glossary Items Lose Bold When Pasted into Bold Style
 Top Border of Paragraph Is Lost if Preceded by Two Page Breaks
 WinWord Err Msg: Indentation Too Large
 Merged Styles Not Retained with Some WinWord Documents
 Word for Windows: Creating Styles for Section Formatting

 Preventing Page Breaks in Word for Windows Tables
 Converting Files with Extended Characters in Filenames
 Border Above Doesn't Display in Page View in Word for Windows
 Centering a Table Horizontally on the Page in Word for Windows
 No Header in WinWord Print Preview When Using Bin Feeder
 Vertical Alignment in Section Doesn't Justify Without Breaks
 Using SHIFT+ENTER Within a Justified Paragraph
 Word for Windows 1.x Has 34 Automatic Styles
 Creating Side-By-Side Tables in Word for Windows



 Can't Toggle Case in Table with SHIFT+F3 or ChangeCase Macro
 Last Paragraph of Included File Acquires Different Formatting

 APO Moves to Next Page with Text Inserted Above
 WinWord: Underline Doesn't Work with Spaces at End of Line
 Placing Boxes Around Characters and Words
 Vertical Justification May Split Paragraph Box Borders
 Automatic Styles Cannot Be Deleted or Renamed in WinWord
 Tab After Hanging Indent Is Ignored in Word for Windows
 Word for Windows Returns Incorrect Number of Columns

 Continuous Section Breaks Become New Page Breaks in Landscape
 Tall Paragraph Mark Clipped If Text Characters Are Smaller
 Character Spacing Spin Box Selects Incorrect Value
 Shading Not Imported into Word for Windows 2.0 from Excel
 Colored Table Cell Border Bleeds into Next Cell in WinWord
 Paragraph Border Does Not Enclose Entire Paragraph in WinWord
 ANSI Characters 0 through 31 Do Not Display in WinWord
 Frame Around Shaded Paragraph Corrupts Formatting in WinWord

 Items Cannot Be Framed Within a Table in Word for Windows
 WinWord: Framed Items Overlap and Redraw Incorrectly
 WinWord Column Selection Lost After Formatting Characters
 Hidden Text to the Left of Selection Becomes Part of Selection
 Inserting a Frame Overwrites Border Information in WinWord
 Negative Indents Change to Zero with Numbered or Bulleted List
 Infinite Repagination Occurs with Header Text in Large Points

 WinWord Frame at the Top of a Column Moves to Previous Column
 WinWord Err Msg: Line Spacing Must Be at Least .01"
 WinWord: Removing Frame Does Not Remove Border
 WinWord: Colored Text Not Displaying on VGA Monochrome Monitor
 WinWord: Position Header Overrides Paragraph Formatting
 WinWord: Horizontal Frames Switch Sides on Consecutive Pages

 WinWord: Inserting a Page Break Within a Justified Paragraph
 WinWord: Cannot Use Edit Repeat Table Formatting with Ruler
 WinWord: Section Layout Displays Incorrect Name for the Break
 Paragraph Borders Are Erratic If Used with a Framed Object
 Narrow Page Width Crops Text Columns Display in WinWord
 Formatting Text to Default Font With Mouse Does Not Work
 WinWord: Search Text Not Found After Changing Measurement Unit

 WinWord: Page Setup Selects Additional Area of Table
 Underline Prints Broken Under Expanded Leader Tab in WinWord
 Frames Cannot Be Inserted Within Frames in Word for Windows
 WinWord: Use As Default Button Removes Bold Formatting
 WinWord: Setting Default Tab Stop to 0" Displays Incorrectly
 WinWord: Page Setup Orientation Overrides Print Setup Setting
 WinWord: Gap Appears in Border at Line Breaks in Print Preview
 Paragraph Indenting Produces Incorrect Results in Tables



 Removing Frame Doesn't Return Object to Its Original Location
 WinWord 2.0: Problems with DropCap Macro in NEWMACRO.DOC
 WinWord: Bottom Border Doesn't Display in Exact Height Frame
 WinWord: Text Not Vertically Centered with Large Header/Footer
 WinWord: Replace Command Doesn't Change Table Formatting
 WinWord: Deleting a Section Break and Maintaining Formatting
 WinWord: Different Indents Cause Improper Numbering Sequence

 Word for Windows: Paragraph Formatting Within Table Cells
 WinWord: Bullet Replaces Leading Number in Paragraph
 WinWord 2.0: Solid Black Line Extends Across Ruler
 WinWord Documentation Error: Spacing Before Setting
 Word for Windows: Tab Leader Extends Beyond Frame Border
 Word for Windows: Shading Extends to the Right-Hand Margin
 Paragraphs After Bullets & Numbering Retain Hanging Indent
 Word: Border Below or Above Does Not Display or Print

 Glossary Entry with Normal Style Doesn't Maintain Alignment
 WinWord 2.0: Compiled TOC Entry Acquires Extra Tab Stop
 WinWord: Search for Style Does Not Select Entire Paragraph
 Paragraph Formatting Affects DropCap Macro Results in WinWord
 Page Setup May Not Apply to Whole Document or Other Sections
 Status Bar Incorrect with SuppressTopSpacing=Yes in WinWord
 WinWord: Edit Replace Character Spacing Does Not Work
 Font Changes When Editing Word Object Embedded in Client App.

 Frame Above Top Margin Displaces Return Address on Envelope
 WinWord: Uneven Double Underline with Tab Character
 Methods for Finding and Replacing Text with Revision Marks
 EditReplace Fails to Replace Formatting After Prior Command
 Cannot Move Frames if Directly Under a Page or Column Break
 WinWord: Top Text Boundary Disappears in Page View

 Tab Positions Incorrect in Center and Right-Aligned Paragraphs
 WinWord: Cannot Find or Replace Styles in Empty Table Cells
 Cannot Use Tab Leader as Edit Find or Edit Replace Criteria
 Cannot Use Tab Alignment as Edit Find or Replace Criteria
 WinWord: Fonts in Table Appear to Have Superscript Formatting
 At Measurement on Status Bar Incorrect in Multiple Columns
 Bulleted List Does Not Align with Margin Using Unindent Button

 WinWord 2.0: Move with Text Frame Option Ignores Bottom Margin
 Line Spacing Changes if You Super/Subscript a SYMBOL Field
 WinWord: Black Box Inserted Into Black Section Creates Border
 Bullets and Numbering on Selection Resets Indent Information
 Font in Header Changes When Included in Another Document
 WinWord: Using Microsoft Graph to Create Vertical Text
 Word: Style List on Ribbon Shows Too Many Styles

 WinWord: Border Splits Over Page Break
 Word: Print Preview Does Not Display Background Shading



 Word for Windows: How to Create Crop Marks
 Continuous Section Break in Glossary Entry Causes Page Break
 Ruler Displays Incorrect Paragraph Formatting
 Pressing CTRL+N Indents to Custom Tab, Not to Default Tab Stop
 Cannot Use Spaces to Indent a Wrapped Line
 Line Spacing Before Causes Clipped Text in Column

 Text in One Section Overlaps Text in Next Section on Page
 Cannot Replace Hidden Paragraph Marks with Unhidden Formatting
 Change Case (SHIFT+F3) Does Not Work with All Caps Formatting
 Header Text Lost When Margin and From Edge Value the Same
 Underline Formatting Does Not Appear at End of Line
 Can't Remove Character Formats Using Ribbon or Shortcut Keys
 Edit Undo Formmatting Command Deletes or Modifies Bookmark

 How To Justify the Last Line of a Justified Paragraph
 WinWord Uses Wrong Page Size Setting with Windows NT
 Vertical Cell Alignment Not Supported in Word for Windows
 Footnotes and Endnotes Not Renumbered with Revision Marks On
 Page Setup Command Unavailable in Unprotected Section
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 WinWord: Center Vertical Alignment Causes Gap After Frame

 Insert Break, File Page Setup, and Format Columns Unavailable
 Borders Misalign in Framed, Indented Paragraphs
 Frame Formatting Changes Differently Based on Sizing Handle
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 Print Preview Incorrect with Shaded Frame on top of Border

 256-Color Bitmap Pastes into Word Smaller Than Expected
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 Changing Default Settings for Subscripts and Superscripts

 AutoClose Macro Is Executed Before Document Is Closed
 Word for Windows: Macro Language Doesn't Support END Command

 "Illegal Function Call" Error When Using a Dialog Box
 Using the OPEN Statement in Word for Windows Embedded BASIC
 Word for Windows Macro Language is Interpretive
 Accessing the Ruler from the Keyboard in Windows Word
 Macro to Change Printer Orientation for HP/PCL Driver
 Macro to Set Create Backup As Default in Word for Windows
 WinWord Menu Commands Unavailable If Locked for Annotations

 Word BASIC Date$() Function Defined
 Word BASIC Kill Statement Defined
 Word BASIC Shell Command Defined
 Using SendKeys with Dialog Boxes in Word for Windows
 SendKeys Key Code for a Space Character Undocumented
 Special Bookmarks in the WordBasic Macro Language
 Valid Word for Windows Macro Names
 UPDATE FIELD Key (F9) Updates Only Selected Fields

 Auto Outline Numbering and the "Chicago Manual of Style"
 WordBASIC InStr Function Is Case Sensitive
 MacroAssignToMenu Removing Separator Fails in Word Macro
 Word for Windows Not Responding to Message Quickly
 Incorrect Recording of FileFind Session in Word for Windows
 Assign To Key Limit Is Eight Keys for Single Macro in Winword
 SendKeys Not Sending All Keystrokes to Dialog Box in WinWord

 Ribbon and Ruler Commands Execute Embedded Super Macros Only
 Macro to Print Current Page in Word for Windows
 Must Specify as Integer When Calling External DLL
 Default$ Does Not Display Linefeed in WinWord InputBox
 File Find Print Option Uses Built-In Print Macro Only
 How to Use Percent, Caret, and Plus SendKeys in WinWord
 OnTime Macro Doesn't Execute Unless Word for Windows Has Focus



 WinWord: Overtype Command Doesn't Work When Recorded
 Cannot Select Radio Button with Mouse in User Dialog Box
 Auto Macros in Word for Windows
 Macro to Designate Table of Contents Entry Automatically
 WinWord: Undocumented WordBasic ExitWindows Command
 WordBASIC Macro to Run the Windows File Manager
 Word for Windows Macro to Insert Specified Dates

 Word for Windows Macro to Save Selection to New File
 Macro to Insert Filename with Path Information in WinWord
 Disabling the FastSave Option in Word for Windows
 NextPage and PrevPage Commands Do Not Work as Documented
 Recursive Functions in WordBasic
 Using AppActivate to Switch to Another Application
 Can't Toggle Case in Table with SHIFT+F3 or ChangeCase Macro
 Word for Windows: Using WordBasic to Print Out a DOS Directory

 Using RecordNextCommand Macro When Writing WinWord Macros
 Variable Assigned to Comments Field Limited to 127 Characters
 Button Fields Following Nonupdated Field Don't Work Correctly
 Supported Mathematical Operators in WordBasic
 Simulating a Macro Pause in Word for Windows
 Runnning Word for Windows Macro from Visual Basic Program
 Macros to Find the ANSI Value of Characters

 Recorded Macro to Print Merge to Printer Requires SendKeys
 Changing the Default Filename and Directory in File Open
 Displaying Values for Arrays and Dialog Box Variables
 Word Basic Int() Function Limitations and Work Around
 File Search Macro in Word for Windows
 \Cell Bookmark Does Not Select Correct Cell in WinWord
 WinWord: Sharing a Global Dimensioned Array with Other Macros
 No Prompt for Number of Columns in Word for Windows 2.0

 Style Shortcut Keys Not Reflected in Template
 Summary Info Statistics Values Not Recorded in WinWord Macro
 Creating Bullets When the Default Symbol Font Won't Print
 Macro to Insert a Bullet in WinWord If No Keypad Exists
 ANSI Characters 0 through 31 Do Not Display in WinWord
 Word for Windows: Macro to List Files
 Creating Special and Foreign Characters in Word for Windows
 Special WinWord BookMarks: EnvelopeAddress and EnvelopeReturn

 Deleting Key Assignments In Word for Windows 2.0
 Checking For Execute-Only Macro Status with IsExecuteOnly
 Custom Table Insertion with Text to Table in WinWord 2.0
 Context-Sensitive Help for Items Added to the Tool Bar
 Cannot Cancel Macro Description in Word for Windows 2.0
 Paragraph-Delimited Text Converts to 1-Column Table in WinWord
 AutoNew Macro Does Not Run When You Start Word for Windows



 Can't Exit Second Instance of WinWord Without a Global Save
 ANSI Carriage Return Doesn't Work in Macro Editing Window

 WinWord: Limitations on Pasting Text into Macro Descriptions
 Passing -1 Value to a Dialog Box in WordBasic
 WinWord: Envelope Macro Views SHIFT+ENTER Formatting Wrong
 EditClear Statement Deletes Footnote Reference or Field Code
 GetBookmark$() Used with EditGoto Returns Incorrect Value
 Using Shell Statement to Access MS-DOS Prompt from WinWord
 WinWord: Envelopes Don't Print with Reverse Print Order Option
 WinWord: Cannot Assign a Shortcut Key with the Numeric Keypad

 Word for Windows Macro to Print List of Found Files
 WinWord: FilePrintSetup Appears Twice in Recorded Macro
 Evaluating Which Button Was Pressed in a User-Defined Dialog
 WinWord: Avoiding Password Prompt Using FileNew Command
 WinWord: Searching for Multiple Extensions with File Find
 WinWord: Macro to Make Define the Default for Format Style
 WordBasic Error 504: Window Does Not Exist...Read-Only File

 WinWord 2.0: Problems with DropCap Macro in NEWMACRO.DOC
 WinWord: Simulating XOR Logic with Field Codes or WordBasic
 Automating Form Templates Without Using ASK or FILLIN Fields
 Macro to Create a Subdirectory in Word for Windows
 Macro Editing Commands Available When Template Is Read-Only
 WinWord: Macro to List File Format as 1.x, 2.0, or Other
 Word for Windows: Setting Column Width to Auto in Tables
 Word for Windows: How to Search in Help for Macro Commands
 Word for Windows: Glossary Management Macros
 Using Windows Calls to Create Dialog Boxes in Word for Windows

 How to Select the Current Page in a WinWord Document
 WordBASIC Err=514 Using the MacroCopy Statement
 WinWord: ToolsMacro .Run Does Not Follow Context Hierarchy
 WinWord: Bullet Replaces Leading Number in Paragraph
 Printing Multiple Pages with Single-Sheet Feed to a Dot Matrix
 Excel Dialog Box Pastes as Tabs and Numbers in WinWord
 SendKeys Does Not Work with Third-Key Characters
 Trapping WordBasic ERR=102 After Choosing Cancel Button
 Calling One Macro Routine or Function from Another Macro

 Variable with Underscore Character Truncated by Dialog Editor
 WinWord: NextField and UpdateField Do Not Update All Fields
 Word for Windows: Input Macro Command Truncates After a Comma
 Macro to Choose Local or Network Templates at File New Command
 WinWord: Macro to Print Style Name Next to Each Paragraph
 DDE with International Versions of Word for Windows
 WinWord 2.0: Compiled TOC Entry Acquires Extra Tab Stop
 Using MsgBox Statement to Display Multiple Lines of Text

 WordBasic: Determining the Current Page and Section Number



 Using Windows Calls to Write to a Private Text File
 Using Windows Calls to Read from a Private Text File
 Paragraph Formatting Affects DropCap Macro Results in WinWord
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 Incorrect Word Wrapping with the PostScript Printer Driver

 Using "And", "Or", "Attn" in an IF Statement in Print Merge
 SKIPIF No Longer Functions Properly if Used With NEXT Field

 Example IF Fields for Print Merging in Word for Windows
 Print Merge Even/Odd Records in WinWord Form Letters
 Using MERGEREC to Number Print Merge Records
 Word for Windows: Suppressing Blank Spaces in Print Merge
 Merged Cells in Header Record Causes Error in Print Merge
 Nested Fields in IF Statement Always Update in WinWord
 Recorded Macro to Print Merge to Printer Requires SendKeys
 Incorrect Merge Results with Conditional IF Statement
 Paragraph Mark Always Inserted in Field With Table as Result
 WinWord: Blank Lines Are Not Suppressed in Print Merge

 Comma is Selected in Blank Field in WinWord Data Document
 Can't Access Record Selection Box in WinWord 2.0 Print Merge
 Edited MERGEFIELD Results Do Not Affect Fields in WinWord
 Use of "AND" and "OR" with Print Merge Selection Rules
 WinWord: Print Merge Result Incorrect on Last Record
 Large Excel Sheet Becomes Tab- and Comma-Delimited for Merge
 WinWord 2.0: Avery Laser Label Information
 WinWord 2.0: Avery Dot-Matrix Label Information
 Printing Labels on the Toshiba 351 Causes Premature Form Feed
 WinWord: Print Merge Produces a Full Page of Labels

 How to Use Wildcards to Perform Selective Print Merge
 Incorrect Results Using Wildcards in Selective Print Merge
 Word: Print Merge Does Not Include Tables or Graphics
 WinWord: Word Returns to Main Document After Opening Data File
 WinWord: How to Use Dates as Print Merge Selection Criteria
 Comma in Quoted Text Causes Conversion to Two Columns in Table
 WinWord: Use of ASK and FILLIN Fields and \o Switch



 Print Merge Error Message: Syntax Error in Field Condition
 Print Merge Error Message with Field in Header or Footer

 Print Merge Error Using Linked Information As Data Document
 Embedded Object Opens in MS Draw from Merged Document
 Cannot Replace Next Page Section Break Followed by Table
 Typing Two-Digit Number in From Box Cancels Print Merge
 How to Save Disk Space when Using Inserted Objects
 EQ, AUTONUM, and SYMBOL Fields Are Blank in Print Merge
 Word Incompletely Sorts Table Column That Contains a Comma
 Print Merge Data Document Can Contain More Than 2000 Fields
 Data File Character Formatting Not Retained in Merged Document

 Cannot Specify Range When Attaching Microsoft Excel Data File
 Remove Attachments Unavailable in Print Merge Main Document
 Error Merging when Data File Is Microsoft Excel CSV or Text
 Conditional Alphanumeric Merge May Yield Incorrect Results
 "Bookmark Not Defined" Replaces Print Merge ASK Field Result
 Print Merge Helper Creates Single-Column Table
 Err Msg: Number of Fields Does Not Match Number of Records...
 Calculations with Print Merge Causes Errors

 Err Msg in Place of REF Field Result: Bookmark Not Defined
 FILLIN Field Dialog Box Blank During Print Merge
 Page Numbering Starts at 1 for Each Print Merged Document
 Main Document Header Prints on Envelope During Print Merge
 Cannot Remove Header File Attachment from Main Document
 Shortcut Key Combinations for Mail/Print Merge Tools
 Print Merge Err Msg: "Requested First Record Is Beyond End..."
 Main Document Header Prints on Envelope During Print Merge

 How to Merge Conditional Number of Records to the Same Page
 Blank Line Suppression When Using FILLIN field

 Printing
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 Tables

 Templates



 Word for Windows 6.0

 Doc Err's

 Fields

 File Conversions

 Formatting

 Frames

 Graphics

 Macros

 Mail merge

 Printing
 Manual Page Breaks Ignored When Document Is Printed
 Printing Color Text on a Non-Color Printer in Word for Windows

 Position Formatting Ignored When Printing from Outline View
 Using the ANSI Extended Character Set in Word for Windows
 Text Beyond Right Margin Even with Display As Printed On
 WinWord Margin Definitions: Inside, Outside, Gutter, Mirror
 Enlarging and Shrinking Font Size Using Hot Keys
 Correcting Line Spacing Offset by Superscripts and Subscripts

 3.6 Point Font on the HP Great Start Cartridge in Word
 Setting the Default Font in Word for Windows
 Printing a Page Border with PostScript in Word for Windows
 Using Word for DOS 5.00 Bitstream Fonts with Word for Windows
 Large Gaps Between Italic Capital and Small Capital Letters
 Using the {print} Field with Dot-Matrix Printers and Winword
 Print Key Assignments Prints Only Reassignments of Keys
 HP LaserJet Com-10 Error Messages When Printing Envelopes

 WinWord: Reverse Print (White on Black) with LaserJet III
 Columns Print Crookedly When Aligned Using Spaces in WinWord
 Incorrect Word Wrapping with the PostScript Printer Driver
 Word for Windows: Borders Don't Print on Plotters
 Statistics Update Not Available with Printer on None
 No Footer/Header on Even Page
 Macro to Print Current Page in Word for Windows
 Descenders Cut Off in Table Using Adobe Postscript Cartridge
 No Header in WinWord Print Preview When Using Bin Feeder
 Keystrokes to Insert Page Number, Date, and Time in WinWord

 Bin/Tray Selection on HP LaserJet IIP and IIIP
 HP LaserJet Cartridge Characters Cut in Half in WinWord



 Automatic Paper Tray Switching on HP LaserJet in WinWord
 Auto Line Spacing with Brother HL-8 Printer Driver
 WinWord: Creating Special Characters with Overstrike
 Printing to a File Repeatedly Prompts for Filename
 Accessing Character Sets Internal to Your Printer in WinWord

 WinWord Printer Setup Changes the Default Printer in Windows
 Creating Envelopes in WinWord 2.0 with an Okilaser 840 Printer
 Superscript or Subscript Text Displays Truncated in WinWord
 WinWord: Page Setup Orientation Overrides Print Setup Setting
 WinWord: Envelopes Don't Print with Reverse Print Order Option
 WinWord 2.0: Envelope Feeder Option Unavailable with ATM
 Scalable HP Fonts Show in Font Installer, Not in Applications

 Printing Multiple Pages with Single-Sheet Feed to a Dot Matrix
 WinWord: White Text with Black Shading Prints as Black Text
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 Table Runs into Margin in Word for Windows Print Preview
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Print Key Assignments Prints Only Reassignments of Keys
Article ID: Q65868
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

If you choose Print from the File menu and select Key Assignments in
the Print dialog box, Microsoft Word for Windows prints only those key
assignments that have been reassigned from their defaults.

Word for Windows currently does not have the ability to print default
key assignments.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 116

"Microsoft Word for Windows User's Reference," version 2.0, page 275

Additional reference words: w4wprint docerr 1.00 1.10 1.10a 2.00 2.00a 
6.00 wm_word 2.00a-CD 2.00b 2.00c 



Vertical Alignment in Section Doesn't Justify Without Breaks
Article ID: Q70027
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When you choose the Vertical Alignment option in the Format Section
dialog box in Word for Windows (Format Section Layout... in Word
for Windows 2.0), the Justify option will not justify the section
until a page break is inserted.  

This problem was corrected in Word version 6.0 for Windows.

More Information:

According to the description in Help, the Justify option under Format
Section should "expand the space between paragraphs to align the top
line with the top margin and the bottom line with the bottom margin."
However choosing the Justify option will not take effect or cause text
to look any different than the Top Vertical Alignment option until a
page break is inserted.

This behavior is very similar to justifying a paragraph of text in Word
for Windows. Word has no way of knowing how to justify the line
until a paragraph mark is inserted or the line wraps on its own. Word
for Windows has to know where the break is; either a paragraph mark, in
the case of paragraph justifying, or a page break, in the case of 
vertical section justifying.

Note: Choosing Center in the Vertical Alignment option for a section
will center a single column of text, but not multiple columns.

In Word for Windows 6.0, when you choose Page Setup from the File 
menu, select the Layout tab, and choose Vertical Alignment as Justified, 
the page will justify vertically without a page break inserted. 
Justification of text remains the same as described above in 2.0.

Reference(s):

"Microsoft Word for Windows User's Reference" page 315, 316.

Additional reference words: w4wformat
1.0 1.1 1.1a 1.00 1.10 1.10a 2.0 2.00



Word for Windows: Creating Multiple Tables of Contents
Article ID: Q72763
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows 1.0 and 2.0, you can create separate tables 
of contents for lists of figures, tables, photos, and so forth. 

Note: while the following information can be used in Word for Windows 6.0, 
the user interface for building multiple tables of contents has been 
substantially changed. For more information on creating separate tables of 
contents in version 6.0, look in Help under Tables.

Each TOC field after the first one must be entered using Insert Field or
CTRL+F9. Word for Windows cannot create two tables of contents in the
same document with the Insert Table of Contents command, even if you
give different heading levels for the second one. When you choose
Table of Contents from the Insert menu to create a second table of
contents, the following message will appear:

   Do you want to replace the existing table of contents?

If you choose not to replace the existing table of contents, the first
table of contents will be left intact.

More Information:

You can use heading paragraphs or TC fields to generate tables of
lists using the TOC field.

Creating Tables of Lists Using Heading Paragraphs
-------------------------------------------------

To create multiple tables of lists using heading paragraphs, assign a
different heading level to each list. For example, use heading 7 to
format the titles of tables, heading 8 to format the titles of photos,
heading 9 for figures, and so on. To create the tables of lists,
create a separate TOC field for each heading level. For example:

   {TOC \o 7-7}
   {TOC \o 8-8}
   {TOC \o 9-9}

In this example, the "\o" switch tells Word for Windows to create a
table of contents using heading paragraphs. The numbers in the fields
restrict the table of contents entries to paragraphs formatted with
that number heading level. You must include both the starting and
ending number for the heading level or the table will be created using



the designated level as well as all levels above it. For example, the
field {TOC \o 7} will pick up heading levels 7, 8, and 9, but {TOC \o
7-7} will pick up only level 7.

Creating Tables of Lists Using TC Fields
----------------------------------------

To create multiple tables of lists using TC fields, a list identifier
must be used in each of the TC fields. For example,

   {TC "Table 1" \f t}

is an entry for a list of tables. "Table 1" is the text that will
appear in the table of contents. The "\f" switch tells Word that the
following letter identifies the list for this entry to be collected
into. The list identifier can be any single letter.

To create a table of contents for the list of tables, use the field
{TOC \f t}. The "\f" switch in this field tells Word to compile the
table of contents using TC fields. If no identifier is given, Word
will compile all TC fields in the document.

When you use TC fields for the table of contents, you may also use the
"\l" switch to designate a level for a given list. This switch is
placed in the TC field. Each level is indented 0.5 inch from the
previous level. For example, the field {TC Table 1 \f t \l 3} will
cause Word to indent the table of tables 1 inch from the left margin.

NOTE: There is a documentation error in on-line help for Word for
Windows 2.0, 2.0a, 2.0a-CD, 2.0b, 2.0c , as well as the
printed fields documentation provided with the Word for Windows Macro
Development Kit.  In the help topic for the TOC field, the following
example is given:

"For example, if you want only heading 3 in your table, yourcode
should be {toc \p 3-3}."

The field should read {toc \o 3-3}.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 558-564

"Microsoft Word for Windows User's Reference," version 1.x, pages
109-111

Additional reference words: docerr w4wfield w4wfield 1.00 1.10 1.10a
2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00 wm_word



WinWord Documentation Error: Spacing Before Setting
Article ID: Q81281
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In the "Microsoft Word for Windows User's Guide," version 2.x, page
186 states that when you print a document, Word for Windows ignores
the Before setting if the paragraph is at the top of the page. This is
only partially true; Word does not ignore the Before setting on the first
paragraph of the document. For all other paragraphs that occur at the top
of a page the Before setting is ignored.

Steps to Reproduce Problem in Word version 2.x
----------------------------------------------

1. From the File menu, choose New, and choose the OK button.

2. Type some text and press Enter to create a paragraph. Repeat this until
multiple pages are created.

3. Select the document and from the Format menu, choose Paragraph.

4. Select 8li in the Before box.

5. From the File menu, choose Print, then choose the OK button.

Although the documentation indicates the first paragraph should print
at the top of the page, it prints on the eighth line of your document.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 186

Additional reference words: w4wformat
docerr 2.00



WordBasic Error Using Caret for Exponentiation in Math Formula
Article ID: Q87717
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

If you use the caret character (^) to perform exponentiation in a
Microsoft Word for Windows macro, the following error message is
generated:

   WordBASIC Err=100
   Syntax error

MORE INFORMATION
================

Page 31 of the "Using WordBasic" manual, written by WexTech Systems
and Microsoft, documents exponentiation in mathematical formulas using
the caret character within a WordBasic macro.

The example shown is as follows:

   CircleArea = pi*r^2

If you run a macro that contains this line, the WordBasic syntax error
occurs. There is no supported mathematical operator in WordBASIC for
exponential calculations. For more information, query on the following
words in the Microsoft Knowledge Base:

   exponents and supported and mathematical and operator and wordbasic

Workaround
----------

To perform a mathematical calculation that involves exponents, you can
use the ToolsCalculate() function. This functions returns a value to a
numeric variable. For example, to find the value of two to the eighth power
(2^8), use the following WordBASIC statement:

   x=ToolsCalculate("2^8")

 -or-

   Sub MAIN
   pi = 3.14159
   x = ToolsCalculate("2^2")
   CircleArea = pi * x
   Print circlearea



   End Sub

REFERENCES
==========

"Using WordBasic," by WexTech Systems and Microsoft, page 31

"Microsoft Word Developer's Tools Forum," page 113 (from the Macro
Developers Kit)

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b w4wmacro
 docerr doc err exponent exponentiate power calculate mdk wm_word 6.00



WinWord: Undocumented Key Codes for Macro Keyboard Assignments
Article ID: Q88207
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

This article lists undocumented key codes to which you can assign
macros in Microsoft Word for Windows. In versions 2.0, 2.0a, and
2.0a-CD of Word for Windows, you can use these additional key codes
with the Keycode argument of the WordBasic ToolsOptionsKeyboard
command. In versions 1.0, 1.1, and 1.1a of Word for Windows, you can
use these additional key codes with the MacroAssignToKey command.

These key codes are missing from the following documentation:

 - "Microsoft Word for Windows and OS/2 Technical Reference," pages
   217-219

 - "Microsoft Word for Windows Technical Reference," pages 73-75

 - "ToolsOptionsKeyboard" topic in the WordBasic Programming Language
   section of the Help menu in versions 2.0, 2.0a, and 2.0a-CD of Word
   for Windows

 - "Using WordBasic" by WexTech Systems, Inc. and Microsoft
   Corporation, pages 311-314.

MORE INFORMATION
================

The key codes listed below can only be assigned using a WordBasic
macro. You cannot assign macros to these key codes directly using the
menu commands in Word for Windows. If you type these key codes in the
Shortcut Key box, the following error message appears:

   The key name is not valid.

   Key Name                 Key Code
   --------                 --------
   Pause                     19     (Note: Not used as macro pause)
   Scroll Lock              145
   Semicolon (;)            186
   Equal Sign (=)           187
   Comma (,)                188
   Hypen (-)                189
   Period (.)               190
   Slash (/)                191
   Backquote (')            192



   Left Bracket ([)         219
   Backslash (\)            220
   Right Bracket (])        221
   Apostrophe (')           222

For example, to assign the semicolon key to the LaunchDialogEditor
macro, create the following macro:

Word 6.0
--------
   Sub MAIN
   ToolsCustomizeKeyboard .Category =1, .name = "LaunchDialogEditor",\
   .Keycode = 186, .add
   End Sub

Word 2.x
--------
   Sub MAIN
   ToolsOptionsKeyboard .Context = 1, .Name = "LaunchDialogEditor",\
   .KeyCode = 186, .Add
   End Sub

For information on using  key codes in combination with the ALT,
SHIFT and CTRL keys, refer to page 311 of the "Using WordBasic"
manual, or page 217 of the "Microsoft Word for Windows and OS/2
Technical Reference.

REFERENCES
==========

"Microsoft Word for Windows and OS/2 Technical Reference," pages
216-220

"Microsoft Word for Windows Technical Reference," pages 72-75

"Windows 3.1 Secrets," by Brian Livingston, pages 325-327

"Microsoft Word for Windows User's Guide," version 2.0, pages 721-723

"Using WordBasic" by WexTech Systems, Inc. and Microsoft Corporation,
pages 311-314.

Additional reference words: w4wmacro  errmsg err msg docerr
doc err wm_word 6.00



Word: Print Merge Does Not Include Tables or Graphics
Article ID: Q89314
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When you perform a print merge in Word for Windows, any table or
linked graphic that is the result of a conditional IF field is not
displayed in the resulting merged documents. To use tables or linked
graphics as the result of a conditional print merge statement, use the
appropriate method below.

This functionality was changed in Word version 6.0 for Windows.

Merging the Table or Graphic Directly
-------------------------------------

Use this method when you want to print only the table or graphic.

Define a glossary entry that contains the table or linked
graphic, then conditionally merge one of two glossaries.

1. Select the table you want to merge and choose Glossary from the
   Edit menu. Type "table" (or another appropriate name, without the
   quotation marks) as the glossary name and choose the Define button.

2. Select the text or field that you want to merge if the condition is
   false. Choose Glossary from the Edit menu. Type "false" (or another
   appropriate name, without the quotation marks) as the glossary name
   and choose the Define button.

3. Insert a field with the following syntax:

      {GLOSSARY {IF <CONDITION><OP>"<CONDITION>" "TRUE GLOSSARY NAME"
      "FALSE GLOSSARY NAME"}}

      For example:

      {GLOSSARY {IF {MERGEFIELD EMPLOYEES}>="100" "TABLE" "FALSE"}}

4. Select the field and press the F9 key before you perform the print
   merge the first time (it should only be necessary to update the
   field only once).

   Note: You must have a glossary defined for the false result or the
   error message

      Error! No glossary entry specified



   will appear in place of the field when you merge. If you want no
   result when the condition is false, define some hidden text as your
   false glossary (be sure you do not include a paragraph mark in the
   glossary entry).

Merging a Document That Contains a Table or Graphic
---------------------------------------------------

Use this method when the table or graphic is part of another document
you insert using an INCLUDE field.

Page 643 of the "Microsoft Word for Windows User's Guide" gives
instructions for including a document during a print merge. If the
included document contains tables and/or graphics, they do not display
in the resulting merged documents when you follow these instructions.

If you reverse the order of the nested fields so the IF conditional
field is nested within the INCLUDE field, Word for Windows displays
the tables and graphics correctly.

A field with the following syntax will allow Word to evaluate a
condition and include one of two documents. Either document may
contain tables or graphics.

   {INCLUDE {if <CONDITION><OP>"<CONDITION>" "TRUE FILENAME" "FALSE
   FILENAME"}}

Note: You must specify a file for Word to include, even when the
condition is false. If no file is specified for Word to import when
the condition is false, the following error message prints on the form
letter:

   Error! Filename Not Specified

The following are examples of the fields for versions 2.x and versions
1.x  of Word for Windows.

Word for Windows versions 2.0, 2.0a, 2.0a-CD, and 2.0b
------------------------------------------------------

   {INCLUDE {IF {MERGEFIELD order}>"100" "C:\\DIRNAME\\LETTER1.DOC"
   "C:\\DIRNAME\\LETTER2.DOC"}}

Using this field, Word for Windows includes the text in LETTER1.DOC if
the amount in the data field "order" is more than 100. If the amount
of the order is less than 100, Word will include LETTER2.DOC. Any
table or graphic in LETTER1.DOC or LETTER2.DOC will be correctly
displayed in the resulting merged documents.

Word for Windows versions 1.0, 1.1, and 1.1a
--------------------------------------------

   {INCLUDE {IF {REF order}>"100" C:\\DIRNAME\\LETTER1.DOC
   C:\\DIRNAME\\LETTER2.DOC}}

Reference(s):



"Microsoft Word for Windows User's Guide," version 2.0, pages 268-271,
639-645

Additional reference words: docerr 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD
w4wtable 2.00b w4wmerge w4wfield missing



WinWord: Changing Templates Does Not Copy Styles or Margins
Article ID: Q89486
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

There is a documentation error in the Microsoft Word for Windows 
version 2.0 Help topic titled "Attaching a template to a document." This 
topic incorrectly states that if you use the File Template command to 
attach a different template to your document, margin settings and styles 
change to those of the new template.

This topic should state that when you attach a different template to
your document, the styles and margin settings remain the same as those
of the original template. The template working environment (including
the menu commands, keyboard assignments, and glossaries) changes 
when you change the template attached, but the document itself does 
not change.

The Word for Windows version 6.0 Help topic titled "Attaching a different 
template to a document" correctly does not indicate that margin settings 
change when a different template it attached, but does not completely 
explain how styles can be automatically updated from the template.

MORE INFORMATION
================

For correct information about changing the template attached to a 
document in version 2.0 of Word for Windows, refer to pages 700-701 of 
the "Microsoft Word for Windows User's Guide."

Workaround
----------

To change elements of the document such as margins, page size, headers 
or footers to those of another template, create a new document based on 
the desired template. From the Insert menu, choose File. Select the 
original filename and choose the OK button. Using this method, your 
new document contains these elements of the new template.

To change only the styles in a document to those of another template in 
Word for Windows version 6.0, choose Templates from the File menu, 
attach the desired template and select the "Automatically Update 
Document Styles" option.

To change only the styles in your document in Word for Windows version 
2.0 to those of another document or template, you must merge the new 
styles from a different template or document. For information on merging 



styles from a template into a document, refer to pages 205-208 of the 
"Microsoft Word for Windows User's Guide."

Use the following steps to view this documentation error:

1. From the Help menu, choose Help Index.

2. Choose the Search button.

3. Type "templates" (without the quotation marks), then select
   "templates: attaching to documents." Choose the Show Topics button.

4. Select the "Attaching a template to a document" topic and choose
   the Go To button. The documentation errors occur in the first two
   paragraphs of this topic.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 205-208,
700-701

Additional reference words:   w4whelp w4wtemplate switch unavailable  wm_word 
docerr doc err 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.
00



ShowAll() Function Causes WordBasic Err=100: Syntax Error
Article ID: Q89767
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

The WordBasic function ShowAll() generates a syntax error, WordBasic
Err=100, when executed in a Word for Windows macro.

STATUS
======

Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
2.0a-CD, 2.0b, and 2.0c of Word for Windows. This problem was corrected
in version 6.0 of Word for Windows.

MORE INFORMATION
================

The functional form of the ShowAll() command has the following syntax:

   n = ShowAll()

where n is set to 0 (zero) if nonprinting characters are not displayed
and -1 if nonprinting characters are visible. This corresponds to the
All checkbox found in the View category of the Tools Options dialog
box.

WORKAROUND
==========

You can obtain the current status of the ShowAll option using the
following macro, which retrieves the value of the All option in the
Tools Options View dialog box:

   Sub Main
   Dim dlg As ToolsOptionsView
   GetCurValues dlg
   n = dlg.ShowAll
   End SUB

The value of n is 1 if All is checked and 0 if it is not checked.

REFERENCES
==========

"Using WordBasic," by WexTech Systems and Microsoft, pages 285-286



Additional reference words: 2.00 2.00a 2.00a-CD 2.00b w4wmacro
 docerr doc err word basic



Format Print Merge Output with Switches or MERGEFIELD Keyword
Article ID: Q91210
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you can format the results of a
MERGEFIELD field by applying character formatting to the MERGEFIELD
keyword. You can also format MERGEFIELD field results using a general
format switch (\*). General switch formatting overrides direct
formatting you apply to the MERGEFIELD field.

No menu command for initial letter capitalization or lowercase
character formatting exists in Word for Windows; therefore, you must
apply these formats using the FIRSTCAP and LOWER general switches.

More Information:

Print Merge Character Case Switches
-----------------------------------

             Syntax: {MERGEFIELD name \* upper}

             Syntax: {MERGEFIELD name \* lower}

             field.
             Syntax: {MERGEFIELD name \* firstcap}

             Syntax: {MERGEFIELD name \* caps}

Documentation Error
-------------------

Neither page 628 nor page 762 of the "Microsoft Word for Windows
User's Guide" describes the need to use the FIRSTCAP and LOWER general
formatting switches to apply these character formats to MERGEFIELD
output.

For more information on general switches, search for "Switches" using
the Help menu.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 628, 643,
762

"Microsoft Word for Windows User's Reference," version 1.x, pages
111-113



Additional reference words: w4wfont w4wfield pmh  6.00
docerr doc err print wm_word 2.00 2.00a 2.00a-CD 2.00b 2.00c 



Pressing CTRL+N Indents to Custom Tab, Not to Default Tab Stop
Article ID: Q94050
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, and 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When you press CTRL+N to apply indent paragraph formatting, Word for
Windows indents to the next tab stop, which may be a custom tab stop or a
default tab stop. In paragraphs that contain custom tab formatting, the
next tab stop might be a custom tab and not a default tab stop.

When you set a custom tab stop, Word deletes all default tabs to the left
of the custom tab stop. As a result, when you press CTRL+N, Word will
indent the paragraph to the custom tab stop. For example, if you set a
custom tab stop at 4 inches, Word deletes all incremental default tab stops
that occur before the 4-inch mark. If you then press CTRL+N, Word sets a
left indent at 4 inches instead of at the default .5-inch tab stop.

This behavior occurs with all tab stops (left, right, decimal, and center
alignment).

This problem was corrected in Word version 6.0 for Windows.

Workaround
----------

In paragraphs that contain custom tab stops, do not use CTRL+N to set
indent formatting to the default tab stops. Instead, select the paragraph
and apply the indent formatting by choosing Paragraph from the Format menu.
Select a From Left setting and choose the OK button.

More Information:

There is a documentation error on page 170 of "Microsoft Word for Windows
User's Guide," version 2.0. The heading at the top of the page incorrectly
reads as follows:

   To indent a paragraph to the next default tab stop...

Instead, it should read as follows:

   To indent a paragraph to the next tab stop...

Note: The online Help topic is correct.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 169-171



Additional reference words: w4wformat
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Cannot Assign Macro to PAGE UP, PAGE DOWN, HOME, or END Keys
Article ID: Q95579
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

You cannot assign a macro to the PAGE UP, PAGE DOWN, HOME, or END keys
in Word for Windows.

STATUS
======
 
Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows. NOTE: the command was renamed to
ToolsCustomzieKeyboard.
 
To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Although the above keys appear in the list of key codes in the
ToolsOptionsKeyboard Help topic, located in the WordBasic Programming
Language section of the Help Index, the keys do not function if you
assign them to a macro.

Note: The list of key codes also appears on pages 311-314 of the
"Using WordBasic" book, by WexTech and Microsoft.

For example, if you assign a macro to the PAGE UP key, the macro does
not run when you press PAGE UP, although the macro does run when you
select it in the Tools Macro dialog box and choose the Run button.

REFERENCES
==========

"Using WordBasic," by WexTech and Microsoft, pages 311-314

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 
w4wmacro pgup pgdn pageup pagedown keyboard



Undocumented MsgBox Type Arguments for Old Dialog Box Styles
Article ID: Q95617
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

This article describes several undocumented MsgBox Type arguments in
the Word for Windows WordBasic macro language. You can use these
arguments to create dialog boxes in the same style as those used in
Word version 1.1 for Windows.

More Information:

The numbers 4096 through 4101 are valid values for the Type argument.
These values display a variety of dialog boxes in Word version 1.1
style. Such dialog boxes have no control box and are stationary.

The following macro displays the result of each undocumented Type
argument:

Sub MAIN
For counter = 4096 To 4101
   Print Counter
   MsgBox "test", counter
Next counter
End Sub

MsgBox Syntax
-------------

   MsgBox Message$ [,Title$] [,Type]

For a list of documented Type arguments, see the MsgBox topic in the
WordBasic Programming Language section of the Help menu.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wmacro
docerr doc err documentation error omission missing old 6.00



How to Cross Reference Sequence Fields
Article ID: Q96944
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

This article describes how to create a cross-reference to a SEQ
(sequence) field in Word for Windows 2.0. The article also describes two
methods that do not work and shows why you should not use them to
create cross-references to SEQ fields.

Note: although the following methods can be used in Word 6.0, the
interface for creating numbered items and cross-references to them has 
been substantially changed. For more information on this process in Word 
6.0, see chapter 19 of the user's manual, or look in Help under Caption or 
Cross-Reference.

More Information:

To create a cross-reference to a SEQ field:

1. Select the SEQ field to which you want to create a cross-reference.

   IMPORTANT: Be sure you do not select any characters before or after
   the field. For example, select the following SEQ field, but do not
   include "Table " in the selection:

      Field                         Result
      -----                         ------

      Table {SEQ table}             Table 1

2. Insert a bookmark. For example, insert a bookmark named "CrossRef"
   (without the quotation marks). For information on inserting
   bookmarks, see page 741 of the "Microsoft Word for Windows User's
   Guide."

3. Position the insertion point where you want the cross-reference to
   appear.

4. Insert a SEQ field and include the Bookmark argument. To reference
   the SEQ field in the above example, insert the following SEQ field:

      Field                               Result
      -----                               ------

      Table {SEQ table CrossRef}          Table 1

For more information on SEQ field syntax, see the Sequence topic in



the Field Types and Instructions section of the Help menu.

Examples of the WRONG Ways to Create a Cross-Reference
======================================================

Do Not use the REF Field to Create a Cross-Reference to the SEQ Field
---------------------------------------------------------------------

Page 744 of "Microsoft Word for Windows User's Guide," incorrectly
describes a method where you use a REF field to create a
cross-reference to a SEQ field; if you use this method, Word inserts a
copy of the SEQ field. In other words, the REF field behaves as if you
inserted another SEQ field, thereby incrementing the sequence. As a
result, the REF field lists a nonexistent cross reference, and
subsequent SEQ fields are incorrectly incremented (that is, the result
of subsequent SEQ fields is one number too large). The following
example illustrates this behavior:

   Field                                 Result
   -----                                 ------

   Table {SEQ table}                     Table 1
   Table {SEQ table} --> Add the         Table 2
                         CrossRef
                         bookmark to
                         this field
   Table {SEQ table}                     Table 3
   Table {SEQ table}                     Table 4

   See Table {REF CrossRef}              See Table 5 --> Increments
                                                         sequence

   Table {SEQ table}                     Table 6     --> Should be 5
   Table {SEQ table}                     Table 7     --> Should be 6

If you lock the result of the REF field, the cross-reference is
correct, but Word increments the sequence anyway, so subsequent SEQ
fields are incorrectly incremented (the result of subsequent SEQ
fields is one number too large). The following example illustrates
this behavior:

   Field                                 Result
   -----                                 ------

   Table {SEQ table}                     Table 1
   Table {SEQ table} --> Add the         Table 2
                         CrossRef
                         bookmark to
                         this field
   Table {SEQ table}                     Table 3
   Table {SEQ table}                     Table 4

   See Table {REF CrossRef \!}           See Table 2 --> Correct
                                                         result

   Table {SEQ table}                     Table 6     --> Should be 5
   Table {SEQ table}                     Table 7     --> Should be 6



Incorrect Results If You Add Bookmark Name to Text and SEQ Field
----------------------------------------------------------------

There is a documentation error in the the Sequence topic in the Field
Types and Instructions section of the Help menu. The first sentence in
the following paragraph is misleading because it implies that you
should select the item you want to cross-reference instead of or in
addition to the SEQ field for that item:

   Cross-references
   ----------------

   To create an automatic cross-reference to an item you've labeled
   with a SEQ field, you assign a bookmark name to the item and then
   include that bookmark name in a SEQ field where you want the cross-
   reference to appear. Suppose you want to refer to the table showing
   African sales. First, you add a bookmark name -- for example,
   african_sales -- to the SEQ field you've created for the table....

If you select the text before the SEQ field in addition to or instead
of the SEQ field, the cross-reference displays the result of the
previous SEQ field instead. This happens because Word includes
everything after the first SEQ field and before the second SEQ field
as part of the first sequence. For example, if you create a cross
reference to Table 2 by adding a bookmark to the second instance of
"Table {SEQ table}" below, the cross-reference lists "Table 1" (the
previous SEQ field) instead of "Table 2."

   Field                               Result
   -----                               ------

   Table {SEQ table}                   Table 1
   Table {SEQ table}                   Table 2
   <---bookmark---->

   Table {SEQ table CrossRef}          Table 1

To create a correct cross-reference, do not not select any text
preceding or following the SEQ field.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 562-564,
744

Additional reference words: w4wfield 2.00 2.00a 2.00a-CD 2.00b 2.00c
w4whelp 



Wrong Error Message Saving Template Using FileSaveAs Macro
Article ID: Q97115
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

If you save a template using the FileSaveAs macro command in a format
other than Document Template (*.dot), Word for Windows returns the
following error message in Word versions 2.0, 2.0a, 2.0a-cd, 2.0b, and
2.0c:

   You cannot save an open document in another format to the same
   location.

   and the following error message in Word versions 1.x:

   Cannot write foreign format over open document.

These are not the messages that should appear. The message that should
display instead is:

   Command not available.

After this message appears, the FileSaveAs macro should stop.

STATUS
======

Microsoft has confirmed this to be a problem in Word for Windows
versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 2.0a-cd, 2.0b, and 2.0c. This 
problem  was corrected in Word for Windows version 6.0.

In Word for Windows version 6.0, the following error message appears:

Microsoft Word Err=1058
You cannot save a template file to non-template format.
(filename)

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 702-703

"Microsoft Word for Windows User's Reference," version 1.x, page 410

Additional reference words: w4wmacro docerr 1.00 1.10 1.10a 2.00 2.00a
2.00a-cd 2.00b 2.00c w4wtemplate



Error Message: The Custom Dictionary Is Not Available
Article ID: Q104691
-------------------------------------------------------------------
The information in this article applies to:

  - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
    2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
SUMMARY
=======
 
This article describes three possible causes for the following error
message in Word for Windows:
 
   The Custom dictionary is not available.
 
This error message can occur for the following reasons. (The first two
are documented in online Help, but the third is undocumented.)
 
 - The custom dictionary file is not in text file format.
 
 - Another application is using the custom dictionary file.
 
   NOTE: For more information about the above two causes, search for 
   "error messages" using the Help menu.
 
 - The custom dictionary file may be damaged.
 
MORE INFORMATION
================
 
If your custom dictionary file is damaged, you may need to re-create
it using the following steps:
 
1. Choose the New button on the Standard toolbar (on the
    toolbar in Word 2.0) to create a new document.
 
2. From the Insert menu, choose File.
 
3. Select the custom dictionary file, located in the <Windows>\MSAPPS\PROOF 
   subdirectory (where <Windows> is the name of your Windows
   directory), and then choose OK.
 
   NOTE: Custom dictionary files have a .DIC filename extension.
 
4. If prompted, convert the file from Text Only.
 
5. From the File menu, choose Save.
 
6. Type a filename, with a .DIC extension.
 
7. In the Save File As Type box, select Text Only and then choose OK.
 



8. Close the file. 

Your re-created custom dictionary file is now ready to use.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00 wm_word 
w4wproof docerr



Cannot Create Index Entries from Footnotes in Word for Windows
Article ID: Q36413
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, you cannot use the Insert Index Entry
command when the current selection is within a footnote window. You
can insert an XE field entry (to designate an index entry) within the
footnote window. However, the entry is ignored when the index is
built, and Word returns the message "No index entries found."

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Additional reference words: w4wfield 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c



Updating Field Moves Insertion Point to Beginning of Field
Article ID: Q37849
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
---------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, updating a field or the result of a
field while the insertion point is positioned in the middle of the
field may cause the insertion point to move to an unexpected position.

If the field code itself is displayed and Field Codes is not chosen on
the View menu, when you update the field using the F9 key, the field
result displays and the insertion point moves to the beginning of the
result regardless of where it was positioned previously. If the field
code is displayed as a result of Field Codes being selected on the
View menu, then updating the field does not affect the position of the
insertion point.

If the result of a field code is displayed (rather than the field code
itself), when you update the field with the F9 key, the insertion point
moves to the end of the result regardless of where it was positioned
previously.

In all cases, if the insertion point is positioned at the beginning of
the field code, it remains in this position even after updating the
field with the F9 key.

Additional reference words: 6.00 w4wfield 1.00 1.10 1.10a 2.00 2.00a wm_word 



Including Excel Charts in WinWord Documents with DDE
Article ID: Q41309
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Use the following steps to perform a DDE link of an Excel chart in
Microsoft Word for Windows

1. From the Chart menu in Excel, choose Select Chart.

2. From the Edit menu, choose Copy.

3. Switch to Word for Windows by pressing ALT+TAB.

4. Position the insertion point where you want to place the chart.

Word for Windows Versions 6.0 and 2.0
-------------------------------------

5. From the Edit menu, choose Paste Special.
  
6. In the Data Type list, select the desired format, then choose the
   Paste Link button.

Word for Windows Version 1.x
----------------------------
 
5. From the Edit menu, choose Paste Link.

6. In the Paste Link dialog box, select the Auto Update option if you
   want Word to automatically update the chart whenever it is changed in
   Excel. If Auto Update is not selected, it is necessary to select the
   chart and recalculate it (by pressing F9) for new charts to appear.

More Information:

After you place the chart in the Word document, you can scale or crop
it.
 
If you use the above procedure, Word inserts one of the following
fields into the document:

Word for Windows Version 6.0
----------------------------

 Data Type       Field Inserted in Document
  ---------      --------------------------

  Picture        {LINK ExcelChart "Sheet1 Chart 1" "Chart" \a \p}
  Chart Object   {LINK ExcelChart "Sheet1 Chart 1" "Chart" \a}



Word for Windows Version 2.0
----------------------------

  Data Type      Field Inserted in Document
  ---------      --------------------------
   
  Picture        {LINK ExcelChart "Sheet1 Chart 1" \* mergeformat \p \a}
  Chart Object   {EMBED ExcelChart \s \* mergeformat}

Word for Windows Version 1.x
----------------------------

   Auto Update    Field Inserted in Document
   -----------    ---------------------------- 

   Selected       {ddeauto Excel "Sheet1 Chart 1" Chart \* mergeformat}
   Not selected   {dde Excel "Sheet1 Chart 1" Chart \* mergeformat}

Additional reference words: w4wfield  1.0 1.1 1.1a 2.0 1.00 1.10 1.10a
2.00 2.00a 2.0a 6.00 wm_word



Field Not Updating and/or No Result
Article ID: Q46344
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

Non-DDE fields do not update automatically when their source
information changes. Any field entered using the CTRL+F9 key is not
evaluated when it is entered. A field entered using the Field option
from the Insert menu is initially evaluated when it is entered.

To update a field, do the following:

1. Select the entire field, including the enclosing brackets.

2. Press the F9 key.

A field cannot update unless the information it displays is available.
Certain fields are not updated until the information they return
becomes available. In most cases, these fields update themselves as
the appropriate information becomes available.

Examples of fields that do not initially update are Printdate,
Lastsavedby, and Revnum.

Additional reference words: 6.00 w4wfield 2.00 2.0 wm_word 



WinWord: Multiple References to the Same Footnote
Article ID: Q47476
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------
Summary:

You can number more than one footnote or endnote with the same number in 
Word for Windows by using the Footnote Reference field.

More Information:

Scientific journals generally require that all references
to a source have the same footnote number. They also require that the
footnote be printed only once for each source. 

In Word 6.0, to refer to another footnote or endnote, 

1. Place the cursor where you want the cross-reference to appear.

2. From the Insert menu, choose Cross-Reference.

3. From the Reference Type box, select Footnote or Endnote. Choose
   the footnote or endnote you want to refer to, and click Insert.

4. If you want the cross-reference to be superscripted like the original
   footnote, 

a. Show Field Codes by highlighting the cross-referenced item
   and pressing Shift+F9
   A field similar to the following appears:

{NOTEREF _Ref0123456789}
b. Place the cursor between the final number and the closing brace
c. Press the spacebar once, and type "\f" (without the quotation   

         marks)

In Word 2.0 and 1.0, you can create references to the original footnote
by using the Footnote Reference field. Follow these steps:

1. Insert the original footnote by choosing Insert Footnote. Select the
   Auto-Numbered Reference check box in the footnote dialog box.

2. Enter the footnote, return to the document pane, and highlight the
   footnote reference mark.

3. Choose Insert Bookmark, type a unique name, and press ENTER or
   choose the OK button.

4. In the text where you want the second occurrence of the footnote
   reference, press CTRL+F9 to insert the field braces and then type

      ftnref <bookmarkname>



   where <bookmarkname> is the name you assigned the footnote reference
   mark in step 3.

5. Highlight the results of the field, and then choose Character from
   the Format menu. Apply a superscript to the number.

You can insert multiple references to the same footnote by repeating
step 4.

When you use automatically numbered references and something causes
the reference marks to be renumbered (such as inserting a new footnote
between two existing footnotes), any additional reference marks are
updated if you do one of the following:

 - Move to each ftnref field and press F9.

   -or-

 - Print the document.

Additional reference words: 1.00 1.10 1.10a w4wfield 2.00 2.00a 2.00a-CD 
2.00b 2.00c  6.00 wm_word cross reference



Multiple Word Text in a Date-Time Picture Switch
Article ID: Q48919
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

The correct syntax to include multiple word text in a date-time or a
numeric picture switch is to place the text within single quotation
marks within the numeric picture or date-time picture.

According to the fields reference, text can be entered as part of a
date-time or numeric picture switch by enclosing the text in single
quotation marks, as follows:

   'text'

The entire date-time picture or numeric picture must be enclosed
within double quotation marks if literal text is used. The following
are examples:

   {date \@ " 'it is' dddd"}
   {= 0 \# "0;-0;'null value'"}

Additional reference words: 6.00 w4wformat custom format w4wfield 1.0
1.1 wm_word 1.1a 1.00 1.10 1.10a 2.0 2.00



ASK and SET Return No Error with Invalid Bookmark
Article ID: Q48920
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

ASK and SET fields are not result fields, so if an invalid bookmark
name or some other error causes the field to be improperly evaluated,
the field will not display an error. Errors are normally displayed as
the last results of the field; however, because no result is
displayed, no indication of the error is given.

An error can usually be detected in the field that uses the bookmark
name that is defined in the SET or ASK statement. If the ASK or SET
field has an error, the result field that references the bookmark will
indicate that the bookmark is not defined.

Additional reference words: w4wfield 2.00 2.00a 2.00a-CD 2.00b 2.00c  
6.00 wm_word



EDITTIME Must Be in Minutes
Article ID: Q49188
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

The EDITTIME field always returns the number of minutes the document
has been open. This time includes any time previous to the current
session that the document was open.

The EDITTIME field cannot be formatted using a date-time picture
switch.

The following field displays the edittime in the hh:mm format:

   {=int({edittime}/60)}:{={={edittime}-({=int({edittime}/60)}*60)}}

Note: All {} are field braces created by using the Insert Field key
(CTRL+F9), not the brace keys on the keyboard.

Additional reference words: 6.00 w4wformat w4wfield 1.0 1.1 1.1a 1.00
1.10 wm_word 1.10a 2.0 2.00



Cannot Format TIME or EDITTIME to Display Seconds
Article ID: Q49459
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

There are two fields in Word for Windows that return a time-related
result:

1. EDITTIME returns the number of minutes the current document has
   been open for editing since it was created.

2. TIME returns the current time of day.

You cannot format the result of a field to include seconds or partial
seconds using a Word for Windows date-time picture switch. The
smallest unit of time that Word for Windows can return or display is
minutes.

Additional reference words: 6.00 w4wformat w4wfield 2.0 2.00 wm_word 



WinWord Err Msg: Cannot Sort Fields in Selection
Article ID: Q51129
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

The Word version 2.0 and 6.0 for Windows error:

   Word cannot sort fields in the selection

or Word version 1.x for Windows error:

   Cannot sort fields in selection

can occur when using the Sort Text command from the Table menu in 6.0
or the Sort command from the Tools menu in version 2.0 or the
Utilities menu in version 1.x for one of two reasons:

1. The current selection contains a field whose result contains more
   than one paragraph. You must unlink the field, then try to sort
   again.

   To unlink or break the link between a field and its source of data,
   highlight the field and use the Unlink Field key (CTRL+SHIFT+F9).

   -or-

2. The column selection contains only part of a field in one of the
   lines. Try to put the whole field on one line and make sure the
   column selection is as large as the field.

Additional reference words: w4wfield w4werror wm_word
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00



INDEX and XE (Index Entry) Are Case Sensitive in WinWord
Article ID: Q57203
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:
 
If you manually insert the XE (Index Entry) field ,{xe ...}, the
character case in the argument list affects the resulting index. Below
is an example of the situation.
 
The following two example fields produce two different results:

1. {xe "Tuxedo:see black"}
   {xe "tuxedo:see penguin"}
  
   After choosing Index from the Insert menu, the results appear as
   follows:

      Tuxedo
              see black,1
      tuxedo
              see penguin,1

2. {xe "Tuxedo:see black"}
   {xe "Tuxedo:see penguin"}
 
   After choosing Index from the Insert menu, the results appear as
   follows:

      Tuxedo
             see black,1
             see penguin,1

More Information:
 
This behavior is caused by the case of the character "t" in the words
"tuxedo" and "Tuxedo". Word for Windows interprets the words as
different; therefore Word builds two different entries.
  
Note that the braces {} were entered using the CTRL+F9 key
combination.

Additional reference words: w4wfield 1.0 1.1 1.1a 1.00 1.10 1.10a 2.0
2.00 6.00 wm_word



'Index' Field \e or \l Switch Limited to Three Characters
Article ID: Q62469
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

In Microsoft Word for Windows, if you use the INDEX field with the \e
switch, there is an upper limit of three contiguous characters that
you can use to separate the index from the page number. The default
character is a blank space.

Similarly, if you use the \l switch with the INDEX field to specify a
page number separator, Word imposes a limit of three characters. The
default character is a blank space.

If you specify more than three characters to use with either switch,
Word will use only the first three.
 
In the following example, periods are used to separate the index from
the page number, and a semicolon separates the page numbers:

   {index \e "..." \l ";"}

REFERENCES
==========

"Microsoft Word for Windows Technical Reference," page 170

"Microsoft Word for Windows and OS/2 Technical Reference," page 359

Additional reference words: 6.00 w4wfield seperater separater 1.00
1.10 wm_word 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



"if" Field Ignoring Nested "eq" Field in Word for Windows
Article ID: Q64550
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Using an equation field as a test result in an "if" field will result in
an erroneous result.

For example, insert the following field:

   {if y=x {eq \x(X)} {reference}}

The "eq" field will make an X with a box. If y=x, then an X with a box
will be the result. If y<>x, then the result would be whatever is in the
bookmark reference.

If you update the "eq" field or the "reference" field before you
update the "if" field, you get the results you would expect. However,
once you update the outside field (if x=y), the "{equation)" field
will result as a blank space.

Microsoft has confirmed this to be a problem in Word for Windows
version 1.00. We are researching this problem and will post new
information here as it becomes available.

Additional reference words: w4wfield 6.00 wm_word
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 



Printing a Page Border with PostScript in Word for Windows
Article ID: Q64703
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

The following field code may be used to print a page border on a
PostScript printer:

   {print \p page "clippath 2 setlinewidth stroke"}

This particular code will use the last rectangular clipping path set
by Microsoft Word for Windows and print a solid line around the path
with a width (2 point) set by the Setlinewidth command.

Note: This example will work best for full page borders when the
document has no text or has graphics formatted as absolute positioned
objects (APO). You must include this sample field on each page that
you want to print a border on. The field can be inserted anywhere on
the page -- even in a table.

Reference(s):

"Microsoft Word for Windows User's Reference." (Document Number OB
14328-0990) Page 104.

Additional reference words: w4wfield w4wprint 1.00 1.10 1.10a 2.00 6.00 
wm_word 2.00a 2.00a-CD 2.00b 2.00c 



Can't Enter Text Inside Field Code Brackets in WinWord
Article ID: Q64708
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

Entering text inside field code brackets while in overtype mode in
Word for Windows is not possible. Attempting to do so will cause the
computer to "beep," signifying the rejection of that action.

To check to see if the keyboard is in overtype mode, turn on the
status bar and look for "OVR" to be displayed in the right-hand
section of the status bar. If "OVR" is displayed, press the INS key to
toggle it into the off position.

When field codes are entered in Word for Windows 6.0, two spaces are placed 
between the field code markers.  When in overtype mode you can enter one 
character before Word will "beep."

REFERENCES
==========

"Microsoft Word for Windows User's Reference." (Document Number OB
14328-0990) Pages 180 and 338.

Additional reference words: w4wfield insert 2.0 2.00 2.00a 2.00b 2.00c
6.00 wm_word



Can't Include an Excel Chart with an {include} Field
Article ID: Q64710
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

It is not possible to include a Microsoft Excel chart (.XLC extension)
into a Microsoft Word for Windows document using the {include} field.
However, it is possible to include an Excel spreadsheet (.XLS
extension) into a Word for Windows document.

WORKAROUND
==========

The following is a method to place an Excel chart into Word for
Windows:

1. Select the chart in Excel (from the Chart menu, choose Select
   Chart).

2. From the Edit menu, choose Copy.

3. After opening Word for Windows, position your insertion point where
   you want the chart to appear. From the Edit menu, choose Paste to
   insert the chart.

For best results, size the chart in Excel before inserting it into
Word for Windows. Sizing can also be done in Word for Windows by
selecting the chart and dragging the handles or by opening the Format
menu, and choosing Picture.

REFERENCES
==========

"Microsoft Word for Windows User's Reference." (Document Number OB
14328-0990) page 201.

Additional reference words: 6.00 w4wfield 2.0 2.00 wm_word 



Exclamation Marks Not Allowed in Calculated Selection
Article ID: Q65718
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

When using Calculate from the Utilities menu, the selection cannot
contain any exclamation marks. 

Microsoft Word for Windows uses exclamation marks to indicate errors
in its field calculations and returns the message "!Syntax Error" if
it finds any exclamation marks in the selection that is being
calculated.

To calculate the selection, it is necessary to temporarily remove the
explanation marks before the calculation and replace them after the
calculation is complete.

Word for Windows 6.0 does not have Calculate on the Tools menu.
ToolsCalculate is still a Word command which can be assigned to a menu
or toolbar.  A "!Syntax Error" is still generated if the selection contains
an excalamation mark.

REFERENCES
==========

"Microsoft Word for Windows User's Reference" pages 27, 383.

Additional reference words: w4wfield  1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c 6.00 wm_word



Using the {print} Field with Dot-Matrix Printers and Winword
Article ID: Q65837
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

You can use the {print} field with a dot-matrix printer only if
the commands sent in the {print} field do not take the printer out
of graphics mode.

Note: Most commands sent to a dot-matrix printer through the {print}
field will take the printer out of graphics mode. For a list of
commands that will not take the printer out of graphics mode, consult
your printer owner's manual or contact the manufacturer.

For more information on the {print} field, refer to Page 104 of the
"Microsoft Word for Windows User's Reference" guide.

Additional reference words: w4wprint w4wfield 1.00 1.10 1.10a 2.00 6.00 
wm_word 2.00a 2.00a-CD 2.00b 2.00c 



Footnote References Renumbered in Word for Windows Tables
Article ID: Q65846
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When using footnotes in a table, it is possible that the numbering for
individual footnotes may change as new footnotes are added within the
table. This will occur anytime a footnote reference is inserted to the
right and above an existing footnote reference.

This renumbering is automatic and should not cause any problems unless
you make references to the original numbering by directly typing the
reference. When you refer to footnote references in a table, use the
field code FTNREF. This will always reflect the proper footnote
reference as additional footnotes are inserted into the table.

For example, insert the following field to create a cross reference to
a footnote:

   {FTNREF BookmarkName}

In the above example, BookmarkName is a bookmark that you place on the
footnote reference number in the document, not in the footnote pane.

Footnote reference numbering in tables is based on a top-down,
left-to-right scheme. This is because each cell of the table is
considered to be a paragraph. Since it is possible that the table may
be changed to text, the numbering of the footnotes must reflect the
ordering of the paragraphs after conversion to text.

Consider the following sample table. Each entry, ftx, represents the
order in which the footnote references are inserted.

|---------------------------------------------------------------|
|ft1            |ft4            |               |               |
|               |               |               |               |
|---------------------------------------------------------------|
|ft2            |               |               |               |
|               |               |               |               |
|---------------------------------------------------------------|
|               |ft5            |               |               |
|               |               |               |               |
|---------------------------------------------------------------|
|ft3            |               |               |               |
|               |               |               |               |
|---------------------------------------------------------------|

After entering ft3, your footnote reference area would be listed in



the following order, as expected:

   _____________
   1 this is the reference for ft1
   2 this is the reference for ft2
   3 this is the reference for ft3

When ft4 is inserted the numbering will change to the following:

   _____________
   1 this is the reference for ft1
   2 this is the reference for ft4
   3 this is the reference for ft2
   4 this is the reference for ft3

ft4 becomes reference 2 because it is in the row before ft2 and will
be the second paragraph of text when the table is converted to text.

After inserting ft5, the numbering will be as follows:

   _____________
   1 this is the reference for ft1
   2 this is the reference for ft4
   3 this is the reference for ft2
   4 this is the reference for ft5
   5 this is the reference for ft3

ft5 is also in a row above the cell containing ft3.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 749

Additional reference words: w4wfield 2.00a 2.00b 2.00a-cd 2.00c 2.00  
6.00 w4wtable wm_word



WinWord: Reverse Print (White on Black) with LaserJet III
Article ID: Q66093
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

You can use the Microsoft Word for Windows PRINT field to use the
reverse printing capabilities of the Hewlett-Packard (HP) LaserJet III
printer. This procedure requires the following steps:
 
1. Define and create a black rectangle.

2. Change the opaque mode of the graphic image.

3. Set the palette color to white for the image.

The following is an example:

   {print " *p300x220Y *c1500a600b*c0P *v0n1O *v1T"}
   Test Text
   {print  *v0T}

Note: Read the above as:

   CTRL+F9 print space quotation mark ALT+027 *p
   three zero zero x two two zero Y ALT+027 *c one five zero
   zero a six zero zero b * c zero P ALT+027 * v zero n one O
   ALT+027 *v one T endquote. Type the Test Text. CTRL+F9
   print space ALT+027 *v zero T.

The first character before the asterisk, is the screen representation
of the ALT+027 (ESC) character. The first section *p300x220Y sets the
cursor at the default margin position of Word for Windows (1.25 Left,
1.00 Top). The second section *c1500a600b draws a rectangle with the
dimensions of 1500 and 600 dots (at 300 dpi - 5 x 3). The *c0P fills
the rectangle with black. *v0n1O sets the transparency mode. The *v1T
sets the palette color to white. All characters after this code are
white until reset by the *v0T.

Chapter 12 of the "HP LaserJet III Technical Reference Manual"
discusses these commands in detail. For more information, contact
Hewlett-Packard's Personal Peripherals Assist Line at (208) 323-2551.

Reference(s):

"HP LaserJet III Technical Reference Manual," Chapter 12

Additional reference words: w4wprint w4wfield 1.0 1.1 1.1a 1.00 1.10 
6.00 wm_word 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 





Using the ASK Field with the IF Field in Word for Windows
Article ID: Q66974
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

To use the ASK field conditioned upon the value of another field,
include the IF statement inside the ASK field instead of including the
ASK statement in the IF field.

The following example asks if you are married, and asks your spouse's
name. It does not ask for your spouse's name if you are not married.
(The \*Firstcap switch is included so the response can be "yes" or
"Yes".)

   {Ask Married "Are you Married" \*Firstcap}
   {Ask {if {Married} = "Yes" SpouseName} "What is your Spouse's
   Name?"}

In the above example, the second ASK field has an IF statement that
determines if the bookmark "Married" is equal to "Yes." If it is, the
IF field has the value "SpouseName." If not, the field has no value.
The ASK field is not updated if it does not have a valid bookmark name
as the first element; therefore, it does not ask the question.

Additional reference words: w4wfield 2.00 2.00a 2.00a-CD 2.00b 2.00c 
6.00 conditional fillin wm_word



SKIPIF No Longer Functions Properly if Used With NEXT Field
Article ID: Q69319
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

The SKIPIF field successfully skips specified data records to create
individual documents for each data record. However, SKIPIF does not
work properly when combined with the NEXT field.

MORE INFORMATION
================

The SKIPIF field compares a data item against specified guidelines
made about a data record. If the comparison is TRUE, the present data
record is skipped, and Word for Windows does not print it. The next
record is selected and compared. If the comparison is FALSE, the data
record is printed, and Word for Windows moves on to check the next
record.

SKIPIF successfully skips specified data records to create individual
documents for each data record. The following example illustrates
this:

   {data c:\\winword\\mydoc.doc}{skipif {zip} = "98000"}{name}
   {street}
   {city}, {state}  {zip}

This example successfully skips data records that have a zip code of
98000 and prints each data record that does not have a 98000 zip code
on a new sheet of paper.

Because the SKIPIF field does not function properly with the NEXT
field, if you try to use the SKIPIF and NEXT fields to create a list
or address labels, Word for Windows does not print or skip data
records properly. The following example illustrates this:

   {data c:\\winword\\mydoc.doc}{skipif {zip} = "98000"}{name}
   {street}
   {city}, {state}  {zip}

   {next}{skipif {zip} = "98000"}{name}
   {street}
   {city}, {state}  {zip}

This example results in erratic placement of data records in your
document or an empty print merged document.



Additional reference words: 6.00 w4wmerge w4wfield skipif next wm_word 



Underlining Superscripted Characters
Article ID: Q69332
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Word for Windows, when you apply underscore character formatting to
a line that contains superscripted characters, the underscore moves up
with the superscripted characters. Although this behavior is by
design, it may not always be the desired effect. This article
describes several methods you can use to keep the underscore in line
with nonsuperscripted text.

This functionality was changed in Word version 6.0 for Windows.

More Information:

To underscore text containing superscripted characters, you can do the
following (in each example, x3 is x cubed, 3 is superscripted):

1. Use overstrike to underline as follows:

   a. Type and underscore text that is not superscripted.
   b. Place the insertion point at the location for the
      superscripted text.
   c. From the Insert menu, choose Field.
   d. Select Formula and then Overstrike.
   e. Insert the superscripted text and one underlined nonbreaking space
      for each superscripted character between the parentheses in the
      field to obtain:

         {eq \O (3,_)}.

      In this example, the three is formatted for superscript.

2. If there is no comma in the expression to be underscored, use the
   Formula Box command as follows:

   a. From the Insert menu, choose Field.
   b. Select Formula and then Box.
   c. Type the expression to be underlined in the field as follows:

         {eq \x \bo(x3)}

      In this example, the three is formatted for superscript.

3. If the superscripted text is on its own line, the text can be put
   into a table as follows:



   a. Highlight text.
   b. From the Insert menu, choose Table.
   c. Select 1 Column and 1 Row.
   d. From the Format menu, choose Table.
   e. Select Border Bottom Single.

4. A more complex solution using the Formula Displace command is as
   follows:

   a. Type and underscore the text preceding the superscripted text.
   b. From the Insert menu, choose Field.
   c. Select Formula and then Displace.
   d. Modify the field to read 

         {eq \d \fon \li()}

      where n is the point size for the superscripted text.

   e. Repeat step b and c.
   f. Modify this field to read 

         {eq \d \ban()}

      where n is the same point size used in the first field.

   g. Type and superscript the text to be superscripted and underlined.
   h. A sample end result for x3 (x cubed) would be

         x{eq \d \fo8 \li()}{eq \d \ba8()}3 

      where x is underscored and 3 is formatted for superscript and 
      8 point size.
   i. Another example: This formula underlines "text", which is
      formatted for superscript. Create the "_" characters, which
      are nonbreaking space characters with underline character
      formatting, by pressing CTRL+SHIFT+SPACEBAR. Select the
      characters and apply underline formatting (press CTRL+U).

         {eq text \d\ba18()______}

      Note: Adjust "text", "18" or "______" for your use.
      
Additional reference words: w4wfield 1.00 1.10 1.10a 2.00 2.00a w4wtable
2.00a-CD 2.00b high low raise lower 



Keystrokes to Insert Page Number, Date, and Time in WinWord
Article ID: Q70018
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When you are in the header/footer pane of a document, the Page Number,
Date of Printing, and Time of Printing fields may be inserted by using
keystrokes instead of using a mouse to select the Date, Time, and Page
icons on the header/footer icon bar.

The keystrokes to insert the fields are:

   ALT+SHIFT+P (inserts Page Number)
   ALT+SHIFT+D (inserts Date of Printing)
   ALT+SHIFT+T (inserts Time of Printing)

More Information:

These keystrokes may also be used in a document without activating
the header/footer.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 147 and 150.

Additional reference words: w4wprint w4wfield 1.00 1.10 1.10a 2.00 6.00 
wm_word 2.00a 2.00a-CD 2.00b 2.00c 



Example IF Fields for Print Merging in Word for Windows
Article ID: Q70131
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

The following are examples of IF statements for print merging and the
logic for each statement.

1. {if {party}="R" "Republican" "Democrat or Other"}

   If "party" is equal to "R", enter "Republican" (first option is
   positive). If it is not equal to "R", enter "Democrat" or "Other"
   (second option is negative).

2. {name}
   {if{party}<>"R" "" "Republican
   "}{City}

   If "party" is not equal to "R", enter nothing. If "party" is equal
   to "R", enter "Republican". This line will also suppress the blank
   line left by a non-R result.

3. {if{party}="R" "Republican" {if{party"="D" "Democrat"} {if
   {party} ="O" "Other"}}

   If "party" is equal to "R", enter "Republican". If "party" is "D",
   enter "Democrat". If "party" is equal to "O", enter "Other". If
   "party" is none of these, it will be blank.

4. {if{party}="R" "{party}epublican and family" {if{party}="D"
   "{party}emocrat and relatives" {if{party}="O" "{party}ther"}}}

   If "party" is equal to "R" then enter the value of "party" and
   "epublican and family". If "party" is equal to "D" then enter the
   value of "party" and "emocrat and relatives". If "party" is equal
   to "O" enter the value of "party" and "ther". If "party" is not
   "D", "R", or "O", it will be blank.

5. {if{party}="R" {if{name}="George Bush" {if{city}="Washington
   D.C." "President"}}}

   If "party" is equal to "R" and "name" is "George Bush" and "city"
   is "Washington  D.C.", enter "President". If all the conditions
   aren't met leave it blank.

Sample Data Document
--------------------

NAME,PARTY,CITY
George Bush,R,Washington D.C.



George McGovern,D,Rapid City
Gorgeous George,O,Hollywood
King George,K,London

Special Note: Field codes and bookmarks are not case sensitive; for
example, NAME would print merge to {naME}. However the results are
case sensitive. In these examples if the codes said {if {party}="r"
"Republican"} and the data document had the "r" capitalized (R), it
would be considered to be a non-r and print nothing.

Additional reference words: 6.00 w4wmerge w4wfield wm_word 



Using the Lock Result Switch in Word for Windows
Article ID: Q70734
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

The description of the lock result switch in the "Microsoft Word for
Windows User's Reference" does not include any examples of usage.

More Information:

Page 119 of the "Microsoft Word for Windows User's Reference"
describes the lock result switch that you can include in fields. The
switch prevents fields that are part of a result from being updated.
However, the documentation provides no examples of using the switch.
The lock result switch is represented by the exclamation point, and
can be used in a field as follows:

   {field \!}
 
where "field" is the field type. This switch locks the results of a
field in an included file from being updated to the results of the
main file. This is useful in situations where a file included in a
main document contains fields that would have different results in the
main document. These document-specific fields include TITLE, FILENAME,
KEYWORDS, COMMENTS, and SEQ fields.
 
If you include a document containing these fields in a main document,
these fields display the information associated with the main document
rather than the included file where you insert them. If the INCLUDE
FILENAME field in the main document contains the lock result switch
(that is, {include filename \!}), then the results of these fields
reflect the information associated with the included file. These
secondary "included" fields are locked, or associated only with the
included document when the lock result switch is added to the include
field in the main document.

Note: This switch does not prevent all fields from updating. The
INCLUDE field still updates in the main document, as do the TIME,
DATE, and equations fields. The switch only locks field results that
are specific to a particular document.

Reference(s):

"Microsoft Word for Windows User's Reference," page 119

"Microsoft Word for Windows Technical Reference," page 145

"Microsoft Word for Windows and OS/2 Technical Reference," page 334



Additional reference words: w4wfield statistics
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00 wm_word



Formula in Table Produces Error in WinWord
Article ID: Q70990
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If the result of a formula is too long (wide) to fit within a table
cell, "Error!" will display in the Word for Windows table cell.

Text that is typed within a cell will word wrap when the end of the
cell is reached. However, this is not true for the results of
formulas that are entered into table cells.

For example:

   {eq \F(10000,45345)}

If the width of the table cell is set to .5 inch, the above formula
will result in "Error!". If the width of the cell is increased to .75
inch with the Format Table command, the following fraction will
appear:

   10000
   -----
   45345

The width of the table cell needs to be wide enough to accommodate
the result of the entered formula.

Additional reference words: w4wfield w4wtable
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00 wm_word



Macro to Designate Table of Contents Entry Automatically
Article ID: Q70996
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

The following macro allows you to designate highlighted text as a
table of contents entry without removing the text from the body of the
document. You do not have to type the table of contents entry twice.

MORE INFORMATION
================

You can assign the following macro to a menu and/or a key sequence to
quickly designate text to be included in a table of contents:

   Sub MAIN
   a$ = Selection$()
   CharRight 1
   InsertFieldChars
   Insert "tc " + Chr$(34) + a$
   Insert Chr$(34)
   CharRight 1
   End Sub

When you have designated all of the table of contents entries with
this macro, choose Table Of Contents from the Insert menu and select
Use Table Entry Fields.

Table of Contents entries or TC fields are automatically formatted as
hidden text. To edit these entries, you must select either Show All or
Hidden Text. In Word 6.0, choose Options from the Tools menu, then 
choose Field Codes from the View tab. Mark the Hidden Text check box. In 
Word version 2.0 for Windows, choose Options from the
Tools menu. Select the View category and mark the Hiddent Text check
box. In Word version 1.0 for Windows, choose Preferences from the View
menuand mark the Show All check box.

Additional reference words: w4wmacro w4wfield 1.00 1.10 1.10a 2.0 2.00
wm_word



Utilities Renumber Command Deletes Abbreviations in WinWord
Article ID: Q71026
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

The Utilities Renumber command in Microsoft Word for Windows will 
automatically number paragraphs beginning with abbreviations such as 
"P.O." or "U.P.S." and delete the abbreviation.

More Information:

If your document contains paragraphs or single lines beginning with
abbreviations such as "P.O." or "U.P.S.", the Renumber command will
automatically number that paragraph or line, and the abbreviation will
be deleted.

Steps to Reproduce Problem
--------------------------

1. Type the following and press ENTER:

      Heading 1

2. Type the following and press ENTER:

      Heading 2

3. Type the following and press ENTER:

      P.O. Box 111

4. Type the following and press ENTER:

      U.P.S. Delivery

5. From the Utilities menu, choose Renumber.

6. Select All and Automatic. Your document will then look like:

      1.  Heading 1
      2.  Heading 2
      3.Box 111
      4.Delivery

(Not only does the Renumber command remove the abbreviation, but it
also does not insert spaces between the number and the text.)

Workaround



----------

Use the Renumber command in outline view (from the View menu, choose
Outline), showing only the heading levels you want automatically
renumbered; or manually insert the {autonum} fields in the paragraphs
you want automatically numbered.

Microsoft has confirmed this to be a problem in Word for Windows. We are 
researching this problem and will post new information here as it 
becomes available. 

Reference(s):

"Microsoft Word for Windows User's Reference," pages 92-93, 229-230.

Additional reference words: w4wfield 2.0 2.00 6.00
address number automatic wm_word



Print Merge Even/Odd Records in WinWord Form Letters
Article ID: Q71382
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

To print only the ODD records in a print merge, place a NEXT field
code at the end of the form letter.

The following is an example:

   {fname} {lname}
   {company}
   {street}
   {city}, {state} {zip}

   Dear {fname},

   Here are the things that you need for the party....

   Sincerely,

   Jane Doe
   {next}

To print EVEN records, insert a second DATA field at the beginning of
the document, or use the NEXT statement as described above. If you use
the NEXT statement, choose Print Merge from the File menu, then choose
to merge from records 2 through x.

MORE INFORMATION
================

Word for Windows Version 2.0
----------------------------

In Word for Windows 2.0, the NEXT statement performs the same
function; however, please note the following:

 - When you activate the field codes, the main document field codes
   appear differently from the codes appear in 1.x. For example,

      {MERGEFIELD name}{MERGEFIELD address}
 
 - When the field codes are not active, the main document field code 
   names appear as follows:

      (<<name>>  <<address>>)



Note: The chevron symbols ( << and >> ) appear smaller in Word for
Windows version 2.0.

REFERENCES
==========

"Using Word for Windows," Que Publishing

Additional reference words: 6.00 w4wmerge w4wfield 1.0 1.00 1.1 1.10
1.1a wm_word 1.10a 2.00 skip miss



Using MERGEREC to Number Print Merge Records
Article ID: Q71829
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

The MERGEREC field can be used to automatically number the records in
a Word for Windows print merge document.

MORE INFORMATION
================

The MERGEREC field can be used in the main document of a print merge
in Word for Windows to automatically number the records being merged.
This field updates with the Print Merge command (from the File menu,
choose Print Merge) and inserts the number of the current print merge
record into the merged document.

To use the MERGEREC field:

1. Press CTRL+F9 to insert field braces {} in the main document where
   the merged record number is to be placed.

2. Type the word MERGEREC. (This is not case sensitive.)

3. From the File menu, choose Print Merge. Choose either Print or New
   Document to print the merged document or display it on the screen.

If you are merging multiple records into a table (for example, to
print labels) a MERGEREC field should be placed in each cell of the
table following the NEXT or NEXTIF field. The NEXT or NEXTIF field
will increment the result of the MERGEREC field and number each record
in the table.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," page 102.

"Microsoft Word for Windows Technical Reference," page 173.

"Microsoft Word for Windows and OS/2 Technical Reference," page 364.

Additional reference words: 6.00 w4wmerge w4wfield wm_word 



Using the {Autonum} Field Inside a WinWord Table Cell
Article ID: Q72064
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When using the {autonum} field to number several paragraphs inside a
single cell in a table, each paragraph displays the same number.

More Information:

The {autonum} field is used to number paragraphs, incrementing each
new paragraph in sequence automatically. However, when the {autonum}
field is used to number individual paragraphs in a table cell, each
paragraph is numbered with the same number.

Steps to Reproduce Problem
--------------------------

1. Insert a table into a document with any number of rows and columns.

2. Type several paragraphs in one cell of the table. Insert the
   {autonum} field in front of each paragraph in the cell either 
manually
   or using the Utilities Renumber command (in version 1.x).

3. Display the result of the field codes. Note that each
   paragraph is numbered 1.

The same action performed outside a table cell, or with each paragraph
in a different cell produces the expected results of sequentially
numbered paragraphs. The cell is treated as a paragraph in the case of
the {autonum} field code, even though formatting each paragraph in a
cell separately is allowed.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 226-230

Additional reference words: w4wfield 1.00 1.10 1.10a 2.00 6.00
w4wtable wm_word



Table of Contents Left-Aligns Page Numbers
Article ID: Q72229
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When a table of contents (TOC) is inserted in Microsoft Word for
Windows, the page numbers will be displayed left aligned.

This problem was corrected in Word version 6.0 for Windows. To obtain 
new or updated Microsoft products, call Microsoft Consumer Sales at 
(800) 426-9400. If you are outside the United States, contact the 
Microsoft subsidiary for your area. To locate your subsidiary, call 
Microsoft International Customer Service at (206) 936-8661.

More Information:

When you insert a TOC that contains information for more than ten
pages, the page numbers referencing the table items display on the
right side of the left-aligned page. The page numbers do not line up
according to decimal point. For example:

   Computers...............................7
   Software................................8
        Microsoft Word for Windows.........8
   Printers................................9
        LaserJets..........................9
   Scanners................................10

More Information:

The "toc" styles that are applied within the table of contents [{toc}]
field are defined with left-aligned tabs with dotted leader characters
(...) selected.

To align the page numbers in a TOC by decimal position, edit the "toc"
styles (toc 1, toc 2, and so on), as follows:

1. From the Format menu, choose Styles, then Define.
2. Select the style to edit, (toc 1, toc 2, and so on).

3. Click the Tabs button.

4. Select the tab at position 5.75" and choose Decimal for Alignment.
   Choose OK.

5. Choose OK to accept the style change.

The TOC will now have decimal-aligned page numbers. For example:



   Computers...............................7
   Software................................8
        Microsoft Word for Windows.........8
   Printers................................9
        LaserJets..........................9
   Scanners...............................10

Reference(s):

"Microsoft Word for Windows User's Reference," pages 357-360.

Additional reference words: w4wfield 2.00 2.00a 2.00a-CD 2.00b 2.00c 



Word for Windows: Suppressing Blank Spaces in Print Merge
Article ID: Q72441
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When performing a print merge in Microsoft Word for Windows, a blank 
space displays and prints if one field on a line is blank. A common 
example of this situation is a line with three name fields, such as the 
following:

   {FNAME} {MI} {LNAME}
 
In a record where all three fields are filled, the merged record
spacing is correct, as in the following example:
 
   James R. Wood

In a record where the middle initial field {MI} is blank, an extra
space occurs in the merged record, as in the following example:

   Susan  Peterson
 
Note: There are two spaces between the {FNAME} and {LNAME} results.

More Information:

You can eliminate this extra space by using the following conditional
statement:

   {FNAME} {IF {MI} <> "" "{MI} "}{LNAME}

Note: To enter the field brackets ({}), choose Field from the Insert
menu (or press CTRL+F9).

Reference(s):

"Microsoft Word for Windows User's Reference," pages 97-98, and 200
"Microsoft Word for Windows and OS/2 Technical Reference," pages 41-42

Additional reference words: w4wmerge w4wfield 1.00 6.00
1.10 1.10a 2.00 2.00a 2.00b 2.00a-CD wm_word



Word for Windows: Using the Ordinal Switch in a DATE Field
Article ID: Q72571
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

To convert the number 15 to "15th" in a DATE field or another field
that displays a number in Microsoft Word for Windows, use the ordinal
switch (\*ordinal).

More Information:

The following three examples demonstrate the use of the ordinal
switch:

To display

   March 21st, 1991

enter the fields:

   {date\@ "MMMM"} {date \@ "d" \*ordinal}, {date \@ "YYYY"}

To display

   Tuesday the 21st, 1991

enter the following fields:

   {date \@ "dddd"} the {date \@ "d" \*ordinal}, {date \@ "YYYY"}

To display

   10th

enter the following field:

   {=\*ordinal 10}

If the "d" in the DATE field is used without the ordinal switch, as in
the following DATE field

   {date \@ "MMMM d, yyyy"}

the result will display:

   May 21, 1991

The "d" abbreviation in a DATE field will return the date as the one-



or two-digit number corresponding to the day of the month. In this
case, the "d" returns 21. Adding the ordinal switch (*\ordinal)
changes 21 to 21st.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 94, 113, 117, 118

Additional reference words: w4wfield 1.00 1.10 1.10a 2.00 6.00
th st Arabic wm_word



Word for Windows: Creating Multiple Tables of Contents
Article ID: Q72763
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows 1.0 and 2.0, you can create separate tables 
of contents for lists of figures, tables, photos, and so forth. 

Note: while the following information can be used in Word for Windows 6.0, 
the user interface for building multiple tables of contents has been 
substantially changed. For more information on creating separate tables of 
contents in version 6.0, look in Help under Tables.

Each TOC field after the first one must be entered using Insert Field or
CTRL+F9. Word for Windows cannot create two tables of contents in the
same document with the Insert Table of Contents command, even if you
give different heading levels for the second one. When you choose
Table of Contents from the Insert menu to create a second table of
contents, the following message will appear:

   Do you want to replace the existing table of contents?

If you choose not to replace the existing table of contents, the first
table of contents will be left intact.

More Information:

You can use heading paragraphs or TC fields to generate tables of
lists using the TOC field.

Creating Tables of Lists Using Heading Paragraphs
-------------------------------------------------

To create multiple tables of lists using heading paragraphs, assign a
different heading level to each list. For example, use heading 7 to
format the titles of tables, heading 8 to format the titles of photos,
heading 9 for figures, and so on. To create the tables of lists,
create a separate TOC field for each heading level. For example:

   {TOC \o 7-7}
   {TOC \o 8-8}
   {TOC \o 9-9}

In this example, the "\o" switch tells Word for Windows to create a
table of contents using heading paragraphs. The numbers in the fields
restrict the table of contents entries to paragraphs formatted with
that number heading level. You must include both the starting and
ending number for the heading level or the table will be created using



the designated level as well as all levels above it. For example, the
field {TOC \o 7} will pick up heading levels 7, 8, and 9, but {TOC \o
7-7} will pick up only level 7.

Creating Tables of Lists Using TC Fields
----------------------------------------

To create multiple tables of lists using TC fields, a list identifier
must be used in each of the TC fields. For example,

   {TC "Table 1" \f t}

is an entry for a list of tables. "Table 1" is the text that will
appear in the table of contents. The "\f" switch tells Word that the
following letter identifies the list for this entry to be collected
into. The list identifier can be any single letter.

To create a table of contents for the list of tables, use the field
{TOC \f t}. The "\f" switch in this field tells Word to compile the
table of contents using TC fields. If no identifier is given, Word
will compile all TC fields in the document.

When you use TC fields for the table of contents, you may also use the
"\l" switch to designate a level for a given list. This switch is
placed in the TC field. Each level is indented 0.5 inch from the
previous level. For example, the field {TC Table 1 \f t \l 3} will
cause Word to indent the table of tables 1 inch from the left margin.

NOTE: There is a documentation error in on-line help for Word for
Windows 2.0, 2.0a, 2.0a-CD, 2.0b, 2.0c , as well as the
printed fields documentation provided with the Word for Windows Macro
Development Kit.  In the help topic for the TOC field, the following
example is given:

"For example, if you want only heading 3 in your table, yourcode
should be {toc \p 3-3}."

The field should read {toc \o 3-3}.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 558-564

"Microsoft Word for Windows User's Reference," version 1.x, pages
109-111

Additional reference words: docerr w4wfield w4wfield 1.00 1.10 1.10a
2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00 wm_word



Setting Sequence Numbering Using a Bookmark in WinWord
Article ID: Q72767
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

You can use the {SET} statement to set the sequence numbering in a
{SEQ \r} statement in a Microsoft Word for Windows document.

More Information:

The \r switch used in a sequence field resets the sequence number to
the number following the \r. You can also use a bookmark with a
numeric value in this field. The SET variable is considered a bookmark
after the SET field is updated. (The field can be updated by pressing
F9 while the field is selected.) In the following example, the
bookmark {year} is set to 1992 at the beginning of the document. The
{SEQ} field starts the sequence number at {year}, which results in
1992.

It is important to remember that the variable {year} becomes a
bookmark that must be contained in field code brackets when used.
 
   Example                 Result
   -------                 ------
 
   {set year 1992}
   {SEQ yr \r{year}}       1992
   {SEQ yr}                1993
   {SEQ yr}                1994

Reference(s):

"Microsoft Word for Windows User's Reference," pages 106-107

Additional reference words: w4wfield 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 
2.00b 2.00c wm_word



Button Fields Following Nonupdated Field Don't Work Correctly
Article ID: Q73434
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, a MACROBUTTON field or a GOTOBUTTON
field will not work correctly when it directly follows any field that
has not been updated and is not displaying a result. The text of the
button field will appear in the document, but it will not perform the
function when you double-click it or when you press ALT+SHIFT+F9.

STATUS
======

This problem was corrected in Word version 6.0 for Windows.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. Insert the DATE field by pressing CTRL+F9 and typing "date"
   (without the quotation marks) between the field brackets.

2. Press the END key to move outside the DATE field.

3. Enter a MACROBUTTON field (or a GOTOBUTTON field) on the same line
   as the DATE field with no spaces or tabs between the two fields.

4. Select the two fields and toggle the field codes off with SHIFT+F9.

The button field text will appear but the DATE field will not display
a result. Double-clicking a MACROBUTTON will result in a beep.
Double-clicking a GOTOBUTTON may result in the insertion point moving
to the beginning of the document.

This behavior only occurs if there is a field directly in front
of the button field that is not displaying either the field code
or result. This can be corrected by doing any one of the
following:

1. Press F9 to display the result of the field that has not been
   updated.

   -or-



2. Press SHIFT+F9 to display the field code of the nonupdated field.

   -or-

3. Display both field codes and put a space, tab, or paragraph return
   between the fields.

Additional reference words: w4wfield w4wmacro



Nested Fields in IF Statement Always Update in WinWord
Article ID: Q74053
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

All fields nested within an IF statement are updated during the
evaluation of that IF statement, regardless of whether the IF
statement proves TRUE or FALSE. In the following example

   {IF test="yes" "{fillin "response one"}" "{fillin "response two"}"}

both fillin fields are updated, prompting you twice. Only one prints,
based on the result of the IF statement. This happens because Word for
Windows updates fields from the inside out. Both of the fillin fields
get updated before the IF statement test is performed. This
functionality is by design.

More Information:

This behavior can create challenges if you need to selectively perform
FILLIN or ASK statements during a print merge. You can do such tasks
by using a different logical structure than the one above. The
following example

   {fillin {if test = "yes" "response one" "response two"}}

prompts you with "response one" if test is "yes", and "response two"
if test is "no". This allows conditional fillin prompts without
getting multiple prompts.

Reference(s):

"Microsoft Word for Windows and OS/2 Technical Reference," page 335

Additional reference words: w4wfield w4wmerge 1.0 1.1 1.1a 2.0 1.00
1.10 1.10a 2.00 2.0a 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD wm_word 6.00



WinWord: Paragraph Return Inserted Between Separate Indexes
Article ID: Q74972
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you compile an index in several
parts (such as an index including a range of letters), Word inserts a
paragraph return between each of the separate parts. This occurs
whether or not you separate each of the index fields with a paragraph
return. Removing this paragraph mark deletes the entire index
reference.

More Information:

The "Microsoft Word for Windows User's Guide" recommends breaking up
an index that includes more than 4,000 entries into several parts.
This allows the updating of each part to be done one field at a time
and the computer's memory to be reused to update the next field. For
example, a complete index can be compiled from the following inserted
fields:

   {index \p a-f}
   {index \p g-r}
   {index \p s-z}

Note: To insert the field braces, press CTRL+F9.

These fields compile an entire index, with paragraph returns
automatically inserted between the result of each separate index
field. In the above example, a paragraph return is inserted between
the f and g entries of the index and between the r and s entries of
the index.

Note: Even if the fields are entered in the same paragraph (no
paragraph returns between fields), the index is still compiled with
paragraph returns between the individual parts.

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose Open, and choose the OK button.

2. Type the following lines of text:

      a index
      c index
      x index
      z index



3. Select each line of text individually WITHOUT the corresponding
   paragraph mark. From the Insert menu, select Index Entry. Accept the
   defaults in the dialog box, and choose the OK button.

4. From the Insert menu, choose Break, accept the default options, and
   choose the OK button.

6. Press CTRL+F9 to generate a pair of field code braces. Within the
   braces, type the INDEX field command, followed by the \p switch,
   followed by the range selection. It should appear as follows:

      {INDEX \p A-D}

7. Repeat the actions in step 6 to set up another index range for the
   remaining index entries. The result should appear as follows:

      {INDEX \p A-D}{INDEX \p E-Z}

8. Select these field codes, and press F9 to update them.

9. The result is a paragraph mark followed by the first index range
   and a second paragraph mark followed by the second index range.
   This occurs even though there are no paragraph marks involved with 
the
   index range entries.

Attempting to select either of these paragraph marks for deletion
fails. The paragraph marks are permanently associated with the index
range entries. You can work around this problem by manually inserting
the paragraph marks prior to updating the index range entries. If an
initial separation exists, the index range entry does not generate the
permanently associated paragraph marks. This should appear as follows:

   [ENTER]
   {INDEX \p A-D} [ENTER]
   {INDEX \p E-Z}

where [ENTER] refers to pressing the ENTER key prior to each index
field entry.

The results are exactly the same as described in step 9 above;
however, you can delete the paragraph marks to make the index range
entries contiguous. Be aware that updating again generates a new set
of index references that include the permanent paragraph marks.

Reference(s):

"Microsoft Word for Windows User's Guide," pages 567-569 

"Microsoft Word for Windows User's Reference," pages 165, 182

Additional reference words: w4wfield 2.00 brackets 2.00a 2.00a-CD
2.00b 6.00 wm_word



Control Panel Changes Insert Field Date and Time Instructions
Article ID: Q75109
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
 - Microsoft Windows for Workgroups version 3.11
--------------------------------------------------------------------

Summary:

The Microsoft Windows Control Panel International date and
time settings change the date and time instructions in the Microsoft
Word for Windows Insert Field dialog box.

More Information:

In Microsoft Word for Window, the Insert Field dialog box lists a
number of possible formats for displaying the date and time. The
Control Panel in Windows allows you to change the display
of the date and time in Windows. These changes affect the Instructions
list in the Insert Field dialog box for the date and time in Word for
Windows.

For example:

1. In Word for Windows, choose Field from the Insert menu and select
   Date in the Insert Field Type list box. Note the display of the
   optional instructions.

2. Choose Cancel to exit the dialog box.

3. Press the keyboard combination ALT+SPACEBAR and choose Run.

4. Choose Control Panel and OK.

5. Select the International icon and press ENTER.

6. Under Date Format, choose the Change button.

7. Change the Order and Separator used in the Short Date Format and
   choose OK.

8. Choose OK again and close the Control Panel.

9. In Word for Windows, choose Field from the Insert menu and select
   Date. Note that the short format dates (the dates displaying
   MMddyy) in the Instructions list box have changed to reflect the
   Control Panel Order and Separator options.

The time field instructions are affected only when the separator is
changed in the Control Panel.



For more information on changing the default time and the long date
format, query on the following words:

   default and time and date and format and w4wfield

Reference(s):

"Microsoft Windows User's Guide," version 3.0, pages 180-184

Additional reference words: w4wfield 2.0 2.00 6.00 wm_word



Placing Boxes Around Characters and Words
Article ID: Q75456
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, it is possible to put boxes around
individual letters, words, or combinations of words. Listed below are
various examples using the Equation formula field to place boxes
around characters and words.

More Information:

To put a box around an individual letter, word, or combination of
words, use the {eq} field with the \x switch. For example

   {eq \x (b) \x (o) \x (x)}

will give the following result:

   ----- ----- -----
   | b | | o | | x |
   ----- ----- -----

{eq \x (box)} will create the following result:

   -------
   | box |
   -------

You can combine more than one \x switch in a single line of text, but
the combined text and borders is limited to only one line of print. If
the entered text and borders exceeds the width of the paragraph or the
document margins, an error will display.

This field can be combined with paragraph borders and page borders to
get a nested border box effect as in the following example:

1. Insert one or more of the fields shown above.

2. Word 6.0: With the cursor still in the paragraph with the field, from 
   the Format menu select Borders and Shading and from the Borders 
   dialog choose Box 

   Word 2.0: With the cursor still in the paragraph with the field,      
   choose Border from the Format menu and click on Box to put a box      
   around the entire field. 

   Word 1.x: With the cursor still in the paragraph with the      



   field, choose Paragraph from the Format menu and choose Border     
   Box to put a box around the entire field.

The result will be a paragraph border around the border applied with a
field.

Box borders can also be nested as in the following example:

   {eq \x(\x(\x(example)))}

For more information on creating page borders, query on the
following words:

   adding and page and borders

Reference(s):

"Microsoft Word for Windows User's Reference," pages 139-140.

"Take Word for Windows to the Edge," (ISBN 1-56276-079-3) by Guy
Gallo, Ziff-Davis Press, page 338

Additional reference words: w4wformat 6.00 wm_word 
w4wfield



Incorrect Merge Results with Conditional IF Statement
Article ID: Q75623
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

When you use the Microsoft Word for Windows print merge feature, the
results may be incorrect when using a conditional IF statement.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this
problem and will post more information here in the Microsoft Knowledge
Base as it becomes available.

MORE INFORMATION
================

If the following three conditions are true, a print merge
may produce incorrect results:

1. The header contains a word that is also the first word of a field
   in a data record.

      Example:   name,honors,list,class
                      John,Dean List,Honors List,Math
                                     ^^^^^^^^^^^

2. This same data record contains a blank field for this header.

      Example:   name,honors,list,class
                       John,,Honors List,Math
                            ^

3. An IF condition is used for the field that contains data with the
   first word that is the same as a header.

      Example:   {if{list}<>"" "{list}<return>
                 "}

Steps to Reproduce Problem
--------------------------

1. Insert a table as follows:

      --------------------------------------------------



      |name|honors     |List       |Class      |teacher|
      |-------------------------------------------------
      |Twan|Dean's List|Honors List|Math       |Speller|
      --------------------------------------------------
      |Joe |           |Late List  |Honors Math|Tuck   |
      --------------------------------------------------
      |Mike|Class Clown|Honor Roll |           |Smart  |
      --------------------------------------------------

2. Save the file as DATA1.DOC.

3. From the File menu, choose New, then OK.

4. Create a form letter as follows:

      {data c:\\winword\\data1.doc}

      {name}
      {if{honors}<>"" "{honors}<return>
      "}{list}
      {if {class}<>"" "{class}<return>
      "}{teacher}

5. Save the file as MAIN1.DOC.

6. From the File menu, choose Print Merge, then choose Print or New
   Document to see the results.

   Desired Result
   --------------

      Page 1          Page 2          Page 3
      Twan            Joe                     Mike
      Dean's List                             Class Clown
      Honors List     Late List               Honor Roll
      Math                    Honors Math
      Speller                 Tuck                    Smart

   Actual Result
   -------------

      Page 1          Page2           Page 3
      Twan                    Joe                     Mike
      Dean's List     Late List               Honor Roll
      Honors List     Tuck                    Smart
      Math
      Speller

Both the Honors and Class merge fields are used in conditional IF
statements and produce no merge results under the above conditions,
even when the record contains data for these fields.

Additional reference words: w4wmerge w4wfield 2.0 2.00 2.0a 2.00a 2.0b
2.0a-CD 2.00b 2.00a-CD 2.00c 6.00



Index Ignores Fields in Index Entry in Word for Windows
Article ID: Q75625
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If a display field is inserted (nested) into an index entry in
Microsoft Word for Windows version 1.0 or 2.0, the field will not be 
included in the index entry of the compiled index. AUTONUM, EQ, and SYMBOL 
fields are display fields. 

This problem was corrected in Word version 6.0 for Windows. To obtain 
new or updated Microsoft products, call Microsoft Consumer Sales at 
(800) 426-9400. If you are outside the United States, contact the 
Microsoft subsidiary for your area. To locate your subsidiary, call 
Microsoft International Customer Service at (206) 936-8661.

More Information:

Fields in an XE field are ignored by the index. If the entire contents 
of the index entry is a field, the entire entry will be ignored. If 
the display field is midway through the index entry, the field and 
everything after it will be ignored.

Steps to Reproduce Problem
--------------------------
1.  Press CTRL+F9 to insert field characters.

2.  Type "XE" (without the quotation marks) and one space.

3.  Type a double-quotation mark.

4.  Press CTRL+F9 to insert nested field characters.

5.  Inside the nested field characters, type "eq \f(1,2)" (without 
    the quotation marks).

6.  Press the RIGHT ARROW key to move the insertion point between   
    the two closing braces of the nested field and XE field.

7.  Type " Of The Year" (without the quotation marks). Type a
    double-quotation mark.

8.  Position the insertion point on a line below the XE
    field.

9.  Press CTRL+F9 to insert field characters.

10. Inside the field characters, type "index" (without the 



    quotation mark).

11. Press CTRL+Keypad 5 to select the document, and press F9 to
    update all fields.

12. Open the View menu and make sure Field Codes is not chosen.
    Choose Preferences from the View menu and make sure Show All is
    not selected.

Result:

   Of The Year  1

Expected Result:

   1/2 Of The Year  1

This problem was corrected in Word version 6.0 for windows. To obtain 
new or updated Microsoft products, call Microsoft Consumer Sales at 
(800) 426-9400. If you are outside the United States, contact the 
Microsoft subsidiary for your area. To locate your subsidiary, call 
Microsoft International Customer Service at (206) 936-8661.Reference(s):
"Microsoft Word for Windows User's Reference," pages 164-167.
Additional reference words: w4wfield 2.00 2.00a 2.00a-CD 2.00b 2.00c 



Paragraph Inserted with Paste Linked Spreadsheet from Excel
Article ID: Q75717
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------
Summary:

If you bring a Microsoft Excel spreadsheet into a Microsoft Word for
Windows document using the Paste Link command, a blank paragraph is
inserted above the table. The paragraph mark cannot be selected or
deleted; however, the spacing can be reduced. The blank paragraph does
not appear if you bring the spreadsheet into Word for Windows using
the regular Paste command.

More Information:

Workaround
----------

To reduce the spacing around the inserted paragraph, use the following
steps:

1. Position the insertion point to the left of the paragraph mark.
   (You cannot select the mark only.)

2. From the Format menu, choose Paragraph.

3. Change line spacing from Auto to -0.04 li or -0.01".

Steps to Reproduce Problem
--------------------------

1. Create a spreadsheet in Excel.

2. Select a range of cells to insert into Word for Windows.

3. From the Edit menu, choose Copy.

4. Start Word for Windows. From the Edit menu, choose Paste Link.

5. Choose the OK button.

Note: If the field code is displaying rather than the desired
information, clear the Field Codes command on the View menu. In Word
1.x, also verify that the Show All option is not selected in the
Preferences dialog box.

A blank paragraph is inserted immediately above the table. This
paragraph is not present if the field code is displayed.

Reference(s):



"Microsoft Word for Windows User's Reference," version 1.x, pages
178-179

Additional reference words: 1.0 1.1 1.1a 2.0 2.0a 1.00 1.10 1.10a 2.00 
6.00 wm_word w4wtable 2.00a w4wfield



Automatic Paper Tray Switching on HP LaserJet in WinWord
Article ID: Q75758
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Word for Windows Version 6.0
----------------------------

To switch paper trays in Microsoft Word for Windows version 6.0,
choose Page Setup from the File menu, then choose the Paper Source
tab. You can select a paper source in the First Page and Other
Pages boxes. The options that appear in these boxes are those
available for the printer currently selected in the Print dialog
box. In the Apply To box, select the Whole Document or the This Point
Forward option. If you select This Point Forward, Word will force a
section break (which will also produce a page break).

Word for Windows Version 2.0
----------------------------

To switch paper trays in Microsoft Word for Windows version 2.0,
choose Page Setup from the Format menu, then choose the Paper Source
button. You can select a paper source in the First Page and Other
Pages boxes. The options that appear in these boxes are those
available for the printer currently selected in the Print Setup dialog
box. In the Apply To box, select the Whole Document or the This Point
Forward option. If you select This Point Forward, Word will force a
section break (which will also produce a page break).

Word for Windows Version 1.x
----------------------------

When you are printing a Word for Windows document, you can switch
paper trays automatically on a Hewlett-Packard (HP) LaserJet printer
by using the PRINT field and HP LaserJet escape codes.

More Information:

You can use the PRINT field, described on page 104 of the "Microsoft
Word for Windows User's Reference," to embed printer control codes in
a Word document. These codes go directly to the printer's processor.
Enter the PRINT field as the very first item on the first page (or
first of a series of pages) that you want to print from another tray.
To do this, use the following steps:

1. Press CTRL+F9, and type PRINT between the braces ({}).

2. Press the SPACEBAR once.



3. Type the escape character, 027, and type a double quotation mark.
   Enter the code used to switch trays, and another double quotation
   mark. The entire decimal code for Paper Feed Selection is as
   follows:

      027"&l#H"

   The result should appear as follows:

      {PRINT 027"&l#H"}

   where "#" is the numeric code of the feed option desired. The
   following is the list of the feed option numeric code and the
   corresponding feed option:

   Code    Feed Option
   ----    -----------

   0       page eject
   1       upper tray feed
   2       manual feed
   3       manual envelope feed
   4       lower tray
   6       envelope feeder (lower cassette on IIIP)

For example, the complete code to change the paper feed to manual is:

   {print 027"&l2H"}

The inserted fields will command the printer to print the following
pages from the bin specified by the numeric code of the feed option
inside the field.

This method was tested on the HP IIP and IIIsi, and the Panasonic
KX-P4450 and 4450i. The codes work as advertised with the HP printers;
however, the codes cause the Panasonic printers to print reversed.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 218-242

"Microsoft Word for Windows User's Reference," version 1.x, page 104

"The LaserJet Handbook" (Bennett & Randall, Brady Books, 1990, page
370

Additional reference words: w4wprint w4wfield 1.0 1.1 1.1a 1.00 1.10 
6.00 wm_word 1.10a 2.00



Placing Sequential Page Numbers in Columns on Same Page
Article ID: Q76479
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

To place sequential page numbers at the bottom of a section column in
Microsoft Word for Windows, the following field codes should be
included in a table within a footer.

More Information:

This article assumes the document has been formatted for a two-column
section. Whether you format the document with a first-page footer or
have two footers separated by a next-page section break, the first
footer should have a table, formatted in two columns. The table should
look as follows:

Word for Windows 2.x and 1.x
----------------------------

|---------------------------|--------------------------|
|  {page}                   |   {=sum([r1c1])+1}       |
|---------------------------|--------------------------|

The second and following pages should have a footer with a table
formatted in two columns. The table should look as follows

|---------------------------|--------------------------|
|  {=({page}*2-1)}          |   {=sum([r1c1])+1}       |
|---------------------------|--------------------------|

where all the curly brackets are inserted using CTRL+F9.

Word for Windows 6.0
--------------------

|---------------------------|--------------------------|
|   {page}                  |    {=sum(a1) +1}         |
|---------------------------|--------------------------|

The second and following pages should have a footer with a table
formatted in two columns. The table should look as follows

|---------------------------|--------------------------|
|   { {page}*2-1}           |    {=sum(a1) +1}         |
|---------------------------|--------------------------|



Reference(s):

"Microsoft Word for Windows User's Reference" pages 95-96, 103, 364.

Additional reference words: w4wfield 1.00 1.10 1.10a 2.0 2.00



Maximum Page Number with PAGE Field in Word for Windows
Article ID: Q77359
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Microsoft Word for Windows versions 1.0, 1.1, and 1.1a allow a maximum
Arabic page number of 5000; Word for Windows version 2.0 allows a
maximum Arabic page number of 32,767. With Roman numbering, the
maximum number is 3999 for all versions. Attempting to number pages
higher than the maximum using the PAGE field and the Header/Footer
command in Word for Windows version 1.x, or the Page Numbers command
in Word for Windows version 2.0 results in either an incorrect number
or no number.

More Information:

Workaround
----------

In Word version 2.0, use the following steps to number pages after
page 32,767:

1. On page 32,767, insert the following fields at the location where
you want the page number to appear:

   {SEQ page \r 32767}
   {SEQ pageX}

2. On each page following page 32,767, insert the following fields
at the location where you want the page number to appear:

   {SEQ pageX \h}
   {={SEQ pageX \c}+{SEQ page \c}-1}

   Note: You must add the result of two SEQ fields because the
   maximum result of a SEQ field is also 32,767.

In Word version 1.x, use the following steps to number pages after
page 5000:

1. Insert the following field on page 5001 at the location where you
want the page number to appear:

   {SEQ page \r 5001}

2. On each page following page 5001, insert the following field at the
location where you want the page number to appear:



   {SEQ page}
 
In all versions of Word, you cannot insert a SEQ field to start Roman
numbering at a value greater than 3999. The largest Roman numeral
supported by Word is 3999 (mmmcmxcix). If you insert a SEQ field with
a \r switch to start at a number greater than 3999, Word returns the
following error message:

   Error! Number can not be represented in specified format.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 103, 106-107

Additional reference words: w4wfield 1.00 1.10 1.10a 2.00 limit 6.00
2.0a 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD 2.00c wm_word



Cannot Insert Nested Formula with Insert Field Command
Article ID: Q77620
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

The Insert Field command does not allow recursion or the nesting of
multiple instructions or switches with the Instructions list box in
Microsoft Word for Windows. Additional instructions or switches must be 
nested manually. If you use the Insert Field command and choose to nest 
instructions using the Instructions list box and the Add button, the 
instructions are not nested.

Steps to Reproduce Problem
--------------------------

1. From the Insert menu, choose Field.

2. Select Formulas from the Insert Field Type list.

3. Select Fraction from the Instructions list.

4. Choose the Add button.

5. Position the insertion point in the Field Code box between the "("
   and the "," and select Radical from the Instructions list.

6. Choose the Add button.

The field code reads {eq \F(,) \R(,)} instead of {eq \F(\R(,),)}.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 88-119

Additional reference words: w4wfield recursive 1.00 1.10 6.00
1.10a 2.00 2.00a 2.00b 2.00a-CD wm_word



WinWord: Revision Marks Not Displayed with Field Code Results
Article ID: Q77650
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, certain field code results do not
display with revision marks when you activate Mark Revisions.

This problem was corrected in Word version 6.0 for Windows.

Steps to Reproduce Problem in Word for Windows version 2.0
----------------------------------------------------------
 
1. From the Tools menu, choose Revision Marks. Select the Mark
   Revisions check box, and choose the OK button.
 
2. Press CTRL+F9 to insert a field, and type the word "date" (without
   the quotation marks).
 
3. Press F9 to update the field. From the View menu, verify the Show
   All and Field Codes options are NOT chosen.
 
Note: The date displayed is underlined as expected when Mark Revisions
is selected.
 
4. Move the insertion point to another line in the document, press
   CTRL+F9 to insert another field, and type the word "autonum" (without
   the quotation marks).

The number "1" appears without a revision mark underline, even though
the field code itself appears to be underlined. Other field results in
version 2.0 that do not appear underlined include symbols inserted by
choosing Symbol from the Insert menu and any result of the Insert
Object command.
 
Steps to Reproduce Problem in Word for Windows version 1.x
----------------------------------------------------------
 
1. From the Utilities menu in version 1.0, 1.1 or 1.1a, choose
   Revision Marks, select Mark Revisions check box, and choose the OK
   button.

2. Press CTRL+F9 to insert a field, and type the word "date" (without
   quotation marks).
 
3. Press F9 to update the field. From the View menu, verify the Show
   All and Field Codes options are NOT chosen.
 



Note: The date displayed is underlined as expected when Mark Revisions
is selected.
 
4. Move the insertion point to another line in the document, press
   CTRL+F9 to insert another field, and type the word "autonum" (without
   the quotation marks).

The number "1" appears without a revision mark underline, even though
the field code itself appears to be underlined.

Microsoft has confirmed this to be a problem in Word for Windows
versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 2.0a-CD and 2.0b. This problem was 
corrected in Word version 6.0 for Windows.

Reference(s):

"Microsoft Word for Windows User's Reference" pages 85-118, 294-296

Additional reference words: w4wfield 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 
2.00b 2.00c 



Field Braces Not Ignored During Search in Word for Windows
Article ID: Q77681
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0  
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, if you search for items that are field
results and the search includes a character before the text of the
field result, Word cannot find the text. The field characters need to
be included in the search string.

MORE INFORMATION
================

The field characters or braces surrounding the field code are not
ignored even if they are turned off or hidden. When viewing the field
results, Word remembers that field characters surround the field
results. Therefore, when searching for text that includes characters
before the text contained in the field result, such as "^p", the
matching text is not found.

Steps to Reproduce Problem
--------------------------
 
1. In a Word for Windows document, type "See page number:" (without
   quotation marks).
  
2. With the insertion point positioned directly after "See page
   number:," insert a page field by pressing CTRL+F9 and typing "page"
   (without the quotation marks). The line should appear as follows:

   "See page number:{page}"
 
   Note: Verify there is no space between the colon and page field.

3. Select the page field and update it by pressing F9.
 
4. If "1" does not appear in place of the {page} field, press SHIFT+F9
   to toggle the field results.

5. From the Edit menu, choose Replace.
 
6. If you are using Word for Windows version 1.x, type ":1" (without
   the quotation marks) in the Search For box. Choose the OK button.
 
   If you are using Word for Windows version 2.0, type ":1" (without the
   quotation marks) in the Find What box. Choose the Find Next button.



7. The search text is not found, even though it appears on the screen.

Additional reference words: w4wfield 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD
2.00b 2.00c 6.00



Making NUMPAGES Format Match PAGE Number Format in WinWord
Article ID: Q77686
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you can use field switches to make the
results of a NUMPAGES field match the format of the PAGE field.

More Information:

With the Header/Footer command, you can set a page numbering format as
numeric, roman numerals (uppercase and lowercase), and alphabetic
(uppercase and lowercase). By default the NUMPAGES field inserts a
numeric value. You can control the format of the result by using field
switches. The following is a list of NUMPAGES fields with switches and
their corresponding results:
 
   {numpages}                      1
   {numpages \*roman}              i
   {numpages \*Roman}              I
   {numpages \*alphabetic}         a
   {numpages \*Alphabetic}         A

Reference(s):

"Microsoft Word for Windows User's Reference", p. 113

"Microsoft Word for Windows and OS/2 Technical Reference", pp. 326-328

Additional reference words: 1.00 1.10 1.10a 2.00 w4wfield 6.00
wm_word



Paragraph Mark Always Inserted in Field With Table as Result
Article ID: Q77825
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows versions 1.x and 2.x, any field that
displays a table as a result also displays a paragraph mark preceding
the table. The paragraph mark displays because although a field can be
inserted into the middle of a paragraph, a table cannot be contained
within a paragraph. The paragraph mark at the beginning of the field
prevents the table from inserting into the middle of the paragraph.

This paragraph mark cannot be deleted or modified.

Status:

This problem has been corrected in Word version 6.0 for Windows.

More Information:

This behavior makes it impossible to use DDE or DDEAUTO links to an
Excel file to create a data file for use in a Word for Windows print
merge.

For more information on print merge errors caused by DDE or DDEAUTO
links to Excel, query on the following words:

   valid and bookmark and name and dde

Additional reference words: w4wfield w4wmerge 1.00 1.10 1.10a 2.00 1.0
w4wtable 1.1 1.1a 2.0 2.0a 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD



Can't Access Record Selection Box in WinWord 2.0 Print Merge
Article ID: Q78228
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, if you perform a print merge with a
main document that is set up with a record selection rule and the
field name used in the rule no longer exists in the data document, you
cannot access the Record Selection dialog box to change this rule.

MORE INFORMATION
================

WORKAROUND
==========

To bring up the Record Selection dialog box, use one of the following
procedures:

 - Correct the data document by changing the modified field name back to
   the original name or by adding the modified field name to the existing
   field names.

 - If the wrong data file is attached, remove it from the main document by
   choosing Print Merge from the File menu and choosing Remove Attachments.
   Then choose Attach Data File, and select the correct data file to attach
   to the main document.

 - Select and copy all of the text from the current document
   (excluding the final paragraph mark) and paste it into a new document
   and re-attach the data file.

Steps to Reproduce Problem
--------------------------

1. Open or create a print merge main document in Word for Windows with
   the field names "name" and "address".

2. From the File menu, choose Print Merge. Choose the Merge button, and
   choose the Record Selection button.

3. From the Field Name box, select Name. From the Is box, select Equal To,
   and type "Bob" (without the quotation marks) in the Compare To box.

4. Choose the Add Rule button, then choose the OK button.

5. Choose the Close button to exit the Print Merge dialog box.



6. Change the Name field in the data document to "firstname."

7. Switch back to the main document and repeat step 2.

Choosing the Record Selection button now has no effect. The button flashes,
and the focus and default buttons return to the OK button. It does not
bring up the Record Selection dialog box to edit or remove the applied
rule. The data document must be edited to add the field name used in the
rule, or a data document that contains the field name used in the rule must
be attached to the main document.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," pages 609-630, 634, 670

Additional reference words: w4wmerge 2.00 pmh helper w4wfield 2.00a
2.00a-CD 2.00b



Internal Paste Link Doesn't Update When a New File is Saved
Article ID: Q78302
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

If you create a link between an unsaved document and a new document in
Microsoft Word for Windows version 2.x, and then save the first
document, the link is not updated to reflect the new filename.

STATUS
======
 
Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.
 
To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

WORKAROUND
==========
 
To update the link, select Links from the Edit menu, select the link
you want to update from the Links list box, and click the Change Link
button. In the Change Link dialog box, type the new filename in the
File Name box.

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New. Choose the OK button to create a
   new document (Document1) based on NORMAL.DOT.

2. Type some text in Document1.

3. Select the text. From the Edit menu, choose Copy to place the text
   on the Clipboard.

4. From the File menu, choose New. Then choose the OK button to create a
   second new document (Document2) based on NORMAL.DOT.
 
5. From the Edit menu, choose Paste Special. Select the Formatted Text
   option, then choose the Paste Link button.



6. From the View menu, choose Field Codes. This displays the INCLUDE
   field created by Word for Windows to establish the link to Document1.
   The field code should look similar to the following:

      {INCLUDE Document1 INTERN_LINK1 \* mergeformat}

   Note: The document number and intern_link number may be different,
   depending on how many documents or links have been previously
   established.

7. From the Window menu, choose Document1 from the list of filenames to
   switch back to the first document.

8. From the File menu, choose Save As. Type a filename in the File
   Name box, and choose the OK button.

9. From the Window menu, choose Document2 from the list of filenames
   to return to Document2. The INCLUDE field does not reflect the new
   filename for Document1. If you update the field by pressing F9 and
   turn off the Field Codes option, the error message "Error! Not a valid
   filename." displays instead of the original link text.

REFERENCES
==========
 
"Microsoft Word for Windows User's Guide," version 2.0, pages 682-684,
688-689

Additional reference words: 2.00 w4wfield 2.00a 2.0b 2.0a-CD 2.00b
2.00a-CD 



Field to Print "Continued" in Word for Windows Footers
Article ID: Q78313
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you can insert a field into the document 
footer to print "Continued" for all pages of a document except the last 
page. 

More Information:

To print the word "Continued" in a footer for all pages except the
last, follow these steps:

1. From the View menu, choose Header/Footer.

2. Select Footer and choose the OK button.
 
3. In the footer, press CTRL+F9 to insert field braces. Inside the
   braces, type "if " (without the quotation marks), press CTRL+F9 for
   another set of field braces, and type "numpages" (without the 
   quotation marks) inside the field braces.
 
4. Press the RIGHT ARROW key once to position the insertion point
   outside the closing brace of the NUMPAGES field. Type ">" (without
   the quotation marks), press CTRL+F9, and type "page" (without the
   quotation marks) inside these field braces.

5. Press the RIGHT ARROW key once to position the cursor outside the
   closing brace of the PAGE field. Type a space and "Continued" (with
   the quotation marks).

The field should appear as follows:

   {if {numpages}>{page} "Continued"}

Reference(s):

"Microsoft Word for Windows User's Guide", page 752

Additional reference words: w4wfield 2.00 2.00a 2.00a-CD 2.00b 2.00c  
6.00 wm_word



SYMBOL Field Font Switches \f, \s, and \h in Word for Windows
Article ID: Q78385
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows there are three switches that you can
use in the SYMBOL field to affect the font, point size, and line
spacing of the resulting symbol character.

MORE INFORMATION
================

Available Switches
------------------

\s  The \s switch indicates the font size. If the \s switch is not
    included in the field, the field result is formatted with the
    point size of the character formatting applied to the SYMBOL
    field.

\f  The \f switch indicates the font. If the \f switch is not included
    in the field, the field result is formatted with the font of the
    character formatting applied to the SYMBOL field.

\h  The \h switch tells Word not to adjust the line spacing. With
    this switch, a 24-point bullet character does not force the
    entire line to be spaced for this character. If the \h switch is
    not included in the field, the spacing of the entire line adjusts
    to account for the size of the bullet character.

If you insert a bullet by choosing Symbol from the Insert menu and
selecting the bullet character from the Symbol font set, the SYMBOL
field displays as {SYMBOL 183 \f "Symbol"} (where 183 is the ANSI code
for the bullet character).

When you insert a bullet by using the Bulleted List button on the tool
bar or by choosing Bullets and Numbering from the Tools menu, the
SYMBOL field displays as follows:

   {SYMBOL 183 \f "Symbol" \s 10 \h}

For more information on the SYMBOL field, search for "Symbol field"
using the Help menu.

REFERENCES
==========



"Microsoft Word for Windows User's Guide," version 2.0, pages 153-155,
521-528

Additional reference words: w4wfont toolbar 2.00 w4wfield



WinWord Outline View May Display Incorrect Number of Pages
Article ID: Q78423
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========
    
In Microsoft Word for Windows, when viewing a document longer than one
page in outline view, the NUMPAGES field in a header or footer may not
display the correct number of pages for the outline.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this
problem and will post more information here in the Microsoft Knowledge
Base as it becomes available.

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose Open.
  
2. If necessary, select the WINWORD directory from the Directories
   box. Select GRAPHICS.DOC from the File Name box, and choose the OK
   button.

3. From the View menu, choose Outline.

4. Click the "3" button on the outline bar, or press ALT+SHIFT+3 to display
   only heading levels 1-3.

5. From the File menu, choose Print Preview.
   
The number of pages shown in the header on page two is incorrect.
Although the document has nine pages, the outline displays only four.

MORE INFORMATION
================
 
Updating the NUMPAGES field should allow the header to represent the
correct number of pages in outline view, but the correct page number
does not always display on the screen. The correct number does print,
even if the display is incorrect.

REFERENCES
==========



"Microsoft Word for Windows User's Guide," version 2.0, pages 490, 510-514,
574

Additional reference words: 1.0 1.1 1.1a 1.00 1.10 1.10a 2.0 2.00
w4wfield footer wrong incorrect improper 2.0a 2.00a 2.0b 2.0a-CD 2.00b
2.00a-CD 6.00



Edited MERGEFIELD Results Do Not Affect Fields in WinWord
Article ID: Q78655
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======
In Microsoft Word for Windows, the results of a MERGEFIELD field 
typically display the name of the field from the data document. You can 
edit the displayed results of this field, but doing so does
not change the field itself.

STEPS TO REPRODUCE PROBLEM
==========================

Word version 6.0 for Windows
----------------------------

1. Type "mergefield hello" (without the quotation marks).

2. Select the above words, and press CTRL+F9.

3. Press the F9 key.
    
4. Turn off the field codes. To do this, from the Tools Options View 
   menu, look for an X next to Field Codes. If there is an X next to
   Field Codes, choose Field Codes to turn this option off.
   
5. Select the word "hello," but do not include the MERGEFIELD chevrons
   in your selection.
 
6. Press the DEL key and type the word "bye" (without the quotation
   marks).

7. Choose Field Codes from the Tools Options View menu to activate the 
   field codes.
 
With field codes active, the field reads {mergefield hello}. With
field codes turned off, the field result reads <<bye>>. To restore the
field to normal, select it, and press F9.
 
Word version 2.0 for Windows
----------------------------

1. Type "mergefield hello" (without the quotation marks).

2. Select the above words, and press CTRL+F9.

3. Press the F9 key.
    



4. Turn off the field codes. To do this, from the View menu, look for
   a check mark next to Field Codes. If there is a check mark next to
   Field Codes, choose Field Codes to turn this option off.
   
5. Select the word "hello," but do not include the MERGEFIELD chevrons
   in your selection.
 
6. Press the DEL key and type the word "bye" (without the quotation
   marks).

7. Choose Field Codes from the View menu to activate the field codes.
 
With field codes active, the field reads {mergefield hello}. With
field codes turned off, the field result reads <<bye>>. To restore the
field to normal, select it, and press F9.

Microsoft is researching this problem and will post more information
here as it becomes available.

Reference(s):
 
"Microsoft Word for Windows User's Guide," version 2.0, page 749

Additional reference words: w4wmerge w4wfield 2.00 2.00a-CD 2.00b 6.00 
wm_word 



Err Msg: Word is Waiting for the Server to Release Object
Article ID: Q78755
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Graph, version 3.0, 3.0a, 3.0b
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
  
Microsoft Word for Windows 2.x, returns the error message "Word is 
waiting for the Server to release object" when updating a Dynamic Data
Exchange (DDE) link if you do not press ENTER after modifying the cell
in Microsoft Excel for Windows.

Word version 6.0 does not return the error message. The following 
workaround works for both versions.

More Information:
   
Workaround
----------

This error message persists until you press the ENTER key in Microsoft
Excel. To work around this problem and escape the continuous loop,
follow the steps below: 
 
1. Press CTRL+ESC to activate the Windows Task List.
  
2. Select Excel from the list of applications, and choose the Switch
   To button.
  
3. In Excel, press the ENTER key to enter the contents of the cell.
  
4. Switch back to Word for Windows.
 
Steps to Reproduce Problem
--------------------------
  
1. In Excel, type "1" (without the quotation marks) in cell A1. Press
   ENTER.
  
2. From the Excel Edit menu, choose Copy.
  
3. Switch to Word for Windows version 2.0.
  
4. From the Word Edit menu, choose Paste Special.
  
5. Select the Formatted Text (RTF) option, and choose the Paste Link
   button.
 
6. Switch back to Excel.



 
7. Change the value in cell A1, and do NOT press ENTER.
 
8. Switch back to Word for Windows.
  
9. Select the DDE field code, and press F9 to update the field.
 
Reference(s):
 
"Microsoft Word for Windows User's Guide," version 2.0, pages 682-690
 
Additional reference words: w4wfield errmsg 2.00 2.00a 2.00a-CD  6.00
2.00b 2.00c wm_word



How to Use the MACROBUTTON Field in WinWord Documents
Article ID: Q78835
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

With the MACROBUTTON field in Microsoft Word for Windows, you can
create a button in your document that invokes a macro when you
double-click it. An example of this field is as follows:

   {MACROBUTTON macroName buttonText}

To insert the field braces, press CTRL+F9. MacroName is the name of
the macro you want the button to invoke, and buttonText is the text or
graphic you want to serve as the button in the document. If you use a
graphic to represent your button, the format is as follows in Word
versions 1.0 and 2.0:

   {MACROBUTTON macroName {import c:\\directory\\subdirectory\\file}}

Use this format in Word version 6.0:

   {MACROBUTTON macroName {includepicture
    c:\\directory\\subdirectory\\file}}

The import statement is a field code inserted within the MACROBUTTON
field telling the program to insert the referenced graphic file.

When you display the result of the MACROBUTTON field, either the text
or graphic that you specified as the buttonText argument displays.
Word automatically updates the field's result whenever you edit the
field. If you have a mouse, double-click the text or graphic returned
by the MACROBUTTON field to run the macro specified in the field's
macroName argument. If you don't have a mouse, use the keyboard to
select the text or graphic returned by the MACROBUTTON field, and
press ALT+SHIFT+F9 to run the specified macro.

For more information, query on the following words:

   wordbasic and macro and record

References:

"Word for Windows Companion," pages 750-751

Additional reference words: 1.00 1.10 1.10a w4wfield wm_word 2.00
2.00a 2.00a-CD 2.00b 2.00c  6.00



AUTONUM Field Doesn't Work with IF Statement in WinWord
Article ID: Q78935
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, using an IF statement in a field removes 
the numeric value that is created by a nested AUTONUM field.

More Information:
 
This problem also occurs if you nest an INCLUDE field within an IF
statement and the included file contains AUTONUM fields. You cannot
change this behavior because the IF field evaluation always produces
the result text. All nested fields are evaluated, and nested field
instructions are not preserved.

Steps To Reproduce Problem
--------------------------

1. Press CTRL+F9 to insert the field braces.
 
2. Type "if 1 = 1" (without the quotation marks). From the Insert
   menu, choose Field, and select Auto No. Choose the OK button.
 
3. Insert quotation marks around the nested AUTONUM field. The
   completed field should appear as follows:

      {if 1 = 1 "{autonum}"}
 
4. Select the entire field, and press F9. If field codes are
   displaying, press SHIFT+F9 to display the field results. This field
   returns no result.

Microsoft is researching this problem and will post new information
here as it becomes available.

Additional reference words: w4wfield gone missing numbers 2.00 6.00
2.00a 2.00b 2.00a-CD wm_word



Use of "AND" and "OR" with Print Merge Selection Rules
Article ID: Q79266
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======
 
With the Print Merge Helper (PMH) in Microsoft Word for Windows, you
can define "rules" that determine whether or not a specific record is
included in the print merge. It is important to understand the
difference between the English language meaning of "AND" and the
logical meaning of "AND" to use these rules effectively.

MORE INFORMATION
================
  
The English language meaning of "AND" is equivalent to the logical
meaning "OR." For example, suppose you have a data file that includes
a STATE field and you want to perform a print merge of the records for
the STATE fields of North Carolina and Washington. In English, you say
"Include the records for North Carolina AND for Washington."
Logically, however, the statement is written as "Include the records
where STATE is North Carolina OR STATE is Washington."
  
When you use a logical "AND," both conditions must be true in order
for the expression to be evaluated as true. If you write the statement
"to include the records where STATE is North Carolina AND STATE is
Washington," it is logically impossible for both conditions to be true
in the same record. The state cannot be both North Carolina and
Washington; it has to be one or the other. Below is a chart that
describes how logical "AND" and "OR" are evaluated.
 
   If X=A OR Y=B        If EITHER is true, the record is included.
   If X=A AND Y=B       If BOTH are true, the record is included.

REFERENCES
==========
 
"Microsoft Word for Windows User's Guide," version 2.0, pages 634, 670

Additional reference words: 2.00 w4wmerge w4wfield



WinWord: Dates Truncated in Statistics Section of Find File
Article ID: Q79579
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, if the default date format
is set to "MMMM d, yyyy" in the [Microsoft Word 2.0] section of the
WIN.INI file, dates appear truncated in the Statistics section within
the Find File dialog box. The year portion of the date is clipped from
the date. For example, the date January 20, 1992, appears in the
Statistics box as follows:

   January 20,

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. From the Tools menu, choose Options.

2. From the Category list, select WIN.INI, and set the default date
   format in the WIN.INI file to the following:

      DateFormat="MMMM d, yyyy"

3. From the File menu, choose Find File.

4. Choose the Options button, and select Statistics from the List File
   Names With box.

5. Choose the OK button.



Note that the dates that appear do not include years.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 491,
500-503, 806

Additional reference words: w4wfield 2.00 2.00a 2.00a-CD 2.00b



WinWord: Calculating Table Values Relative to Current Cell
Article ID: Q79586
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Word for Windows, you can use fields to calculate values in table
cells. You can also reference the cells relative to the cell
containing the field so that rows or columns can be deleted from or
added to the table without affecting the resulting calculation.

More Information:

The Expression field is used to perform mathematical calculations. For
example, if you have the following table

   --------------------------------
   |   1   |   2   |   3   |      |
   --------------------------------
   |   4   |   5   |   6   |      |
   --------------------------------

and you want to insert the row totals in the fourth column, you can
insert the following field in the last cell of each row:

   {=sum([rc-3:rc-1])}

Note: To create the field braces, press CTRL+F9.

This field calculates the sum of the values in the current row. To do
this, the field adds the values from two columns to the left of the
current column through the entire current row (one column to the left
of the current column). The references to the cells that you add are
relative to the cell containing the field.

This method allows you to add or delete rows and maintain a correct
sum; you can also add or delete columns without affecting the
calculation.

To total all cells in the current row except the row containing the
field total, insert the following field in the cell where you want the
total to appear:

   {=sum([c])-sum([rc])}

The advantage of this expression is that you do not need to modify it
if you add or delete columns from your table.

In Word for Windows 6.0, this feature can be accessed through the 



Table... Formula menu.  This gives the option to choose relative cells 
to the left, right, above, and below the current cell.  For more 
information, see the online help.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 306-308

"Microsoft Word for Windows User's Reference," version 1.x, pages
95-96

Additional reference words: w4wfield w4wtable 6.00 wm_word 
add subtract multiply divide  relation math
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Numbering Columns or Creating Page Numbers for Folded Pages
Article ID: Q79592
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you can number the columns on a
multiple-column page by inserting field codes in the document's header
or footer. Using this method, you can simulate the pagination of
folded pages (as for a brochure, pamphlet, booklet, leaflet, or program).

More Information:

You can achieve the numbering scheme diagrammed below by inserting the
following line at the left edge of your document's header or footer

   {={page}+{={page}-1}*1+0}

and the following line at the right edge of the header or footer:

   {={page}+{={page}-1}*1+1}

The results are as follows:

           page 1                    page 2
    -------------------       -------------------
   | pg 1    .    pg 2 |     | pg 3    .    pg 4 |
   |         .         |     |         .         |
   |         .         |     |         .         |
   |         .         |     |         .         |
   |         .         |     |         .         |
   |         .         |     |         .         |
   |         .         |     |         .         |
    -------------------       -------------------

You can use the following generic formula to simulate page numbering
for any number of columns:

   page + ((page-1) * n) + m

In this formula, "page" equals the current page field value, "n"
equals the number of columns - 1, "m" equals the column position - 1,
and the first column starts at zero. Insert the above formula in the
header or footer, positioning each formula at the desired location
above or below the appropriate column.

For two-column page numbering, use the following formula:

   {={page}+{={page}-1}*1+0}  1,3,5,...



   {={page}+{={page}-1}*1+1}  2,4,6,...

For three-column page numbering, use the following formula:

   {={page}+{={page}-1}*2+0}  1,4,7,...
   {={page}+{={page}-1}*2+1}  2,5,8,...
   {={page}+{={page}-1}*2+2}  3,6,9,...

For four-column page numbering, use the following formula:

   {={page}+{={page}-1}*3+0}  1,5,9,...
   {={page}+{={page}-1}*3+1}  2,6,10,...
   {={page}+{={page}-1}*3+2}  3,7,11,...
   {={page}+{={page}-1}*3+3}  4,8,12,...

If you want the numbering to start with 0 for the first column, make
the following changes:

1. In the first formula, change the starting value of "m" to equal the
   value of "n" used in that formula. Increase "m" by increments of 1 in
   each additional formula (as in the original formula examples).

2. From the View menu, choose Header/Footer. Choose the Page Numbers
   button. Change the Start At value to 0.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 421-431

"Microsoft Word for Windows User's Reference," version 1.x, pages
246-247

"Take Word for Windows to the Edge," (ISBN 1-56276-079-3) by Guy
Gallo, Ziff-Davis Press, page 362

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
6.00 wm_word w4wtable 2.00c w4wfield table same multiple



WinWord: Using Bookmarks in a Table of Contents
Article ID: Q79750
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you can use a bookmark as the text
argument in a table of contents entry (TC) field; this causes the
bookmark to become part of the table of contents.

More Information:

Note: You cannot insert the bookmark field by pressing CTRL+F9 in the
Field Code box of the Insert Field command; therefore, the following
procedure is more efficient than using the Insert Field command for
entering a table of contents entry that references a bookmark.

The following procedure outlines a method for displaying a bookmark in
a table of contents:

1. Press CTRL+F9 to insert field braces at the location in the
   document where you want the table of contents entry to appear.

2. Type "TC " (without the quotation marks) Be sure to press the
   SPACEBAR to create a space after TC.

3. Press CTRL+F9 to insert a second set of field braces, then type the
   bookmark name. The resulting TC field should appear as follows:

      {TC {bookmark_name}}

4. Add any additional TC field switches or instructions after the
   bookmark field.

For more information about the TC field, search for "Table of
Contents" using the Word for Windows version 2.0 Help menu.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 557-562,
758

"Microsoft Word for Windows User's Reference," version 1.x, pages 109,
358, 360, 373

Additional reference words: TOC w4wfield 1.00 1.10 1.10a 2.00 2.00a 
2.00a-CD 2.00b 2.00c wm_word 6.00



WinWord: Test for Blank Argument Within an Expression Field
Article ID: Q79770
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:
 
Using the ASK field combined with the AND function in Microsoft Word
for Windows can cause the following error message:

   Undefined Bookmark, BOOKMARKNAME   

More Information:
 
If you leave the dialog box is blank, the bookmark associated with the
ASK field does not return a value of zero (0); instead, the above
error message appears. The AND function is used to join two logical
expressions into a single complex expression. You must define both
bookmarks.

Steps to Reproduce Problem
--------------------------
    
1. From the File menu, choose New, and choose the OK button. Press
   CTRL+F9 to insert the field code braces, and enter the following 
   information:

      {Ask bookmarkname "Enter the number of boxes"}

   Press the END key, then press RETURN.
    
2. Press CTRL+F9 to insert a second set of braces, and insert the
   information below:

      {=and (bookmarkname > 2,bookmarkname < 12)}

3. Select both fields, and update them by pressing the F9 key.
 
4. Do not type anything in the dialog box that appears. Choose the
   OK button.
 
Word for Windows displays the following error message:
 
   Undefined Bookmark, BOOKMARKNAME
 
You must enter information in the dialog box; an empty dialog box does
not return the value "0."

Microsoft is researching this problem and will post new information
here as it becomes available.



Reference(s):

"Microsoft Word for Windows and OS/2 Technical Reference," page 338

"Word for Windows Companion," The Cobb Group, page 679

Additional reference words:  w4wfield
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00 wm_word



WinWord: TC Field Displays Result
Article ID: Q79907
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if a TC (Table of Contents Entry) field
contains an SEQ field with an \* Alphabetic switch, the TC field
displays the result of the SEQ field in the document.

This problem was corrected in Word version 6.0 for Windows. To obtain 
new or updated Microsoft products, call Microsoft Consumer Sales at 
(800) 426-9400. If you are outside the United States, contact the 
Microsoft subsidiary for your area. To locate your subsidiary, call 
Microsoft International Customer Service at (206) 936-8661.

More Information:

You can format the TC field as hidden by pressing CTRL+H or choosing
Character from the Format menu and selecting Hidden. If you format the
TC field as hidden, no result displays for the TC field, but the table
of contents entry displays correctly when compiled into the table of
contents.

Steps to Reproduce Problem
--------------------------

1. Create the braces (field characters) by pressing CTRL+F9. Insert
   the following field in a Word for Windows document:

      {tc "{seq appendix \* Alphabetic}"}

2. Select the entire field, and press F9 to update the field.

3. From the View menu, clear the check mark beside the Field Codes
   command.

4. From the Tools menu (in version 2.0), choose Options, select the
   View category, and clear the Hidden Text in the Nonprinting 
   Characters box. Choose the OK button. From the View menu (in version 
   1.x), choose Preferences, and clear the Hidden Text box. Choose the 
   OK button.

The letter "A" displays as the result of the TC field. If you remove
the Alphabetic field switch, no result displays.

Microsoft is researching this problem and will post new information
here as it becomes available.



For more information on the TC and SEQ fields in Word for Windows
version 2.0, search for "Table of Contents Entry field" and "Sequence
field" using the Help menu.

For more information on the \* Alphabetic field switch in Word for
Windows version 2.0, search for "Format switch" using the Help menu.

Reference(s):

"Microsoft Word for Windows User's Guide", version 2.0, pages 558,
563, 752, 754
 
"Microsoft Word for Windows User's Reference," version 1.x, pages 106-
107, 109, 113

Additional reference words: w4wfield 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 
2.00b 2.00c incorrect invalid visible



WinWord: Updating Link Does Not Show Percentage Complete
Article ID: Q79912
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you open a document that contains
automatic updating links, Word for Windows prompts you to update the
links. If you choose the Yes button, the status bar displays the
following message:

   Updating fields, X% complete. Press ESC to cancel.

However, if you select ONE link in a Word for Windows document and
press the F9 key to manually update the field, only an hourglass
displays; no progress bar (or percentage complete indicator in Word 1.x 
and 2.x) appears on the status bar.

More Information:

If you choose the Yes button to update automatic links in a document
and press ESC to cancel the update, the status bar displays that the
link was updated 100% even though it might not have been fully
updated.

Additional reference words: 1.00 1.10 1.10a 2.00 6.00
w4wfield embed dynamic data exchange object OLE DDE 2.0a 2.00a 2.0b
2.0a-CD 2.00b 2.00a-CD wm_word



WinWord: No Error Message for Invalid OLE Field
Article ID: Q80211
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows version 1.x and 2.x, no errormessage is 
displayed when an object linking and embedding (OLE) field code is 
invalid.

Word 6.0 will beep when an invalid EMBED field is used, but will not 
display an error message.

Workaround
----------

To find an invalid OLE field code, display field codes in your
document (from the View menu, choose Field Codes). If an OLE field
code is invalid, Word for Windows will display the following error
message in place of the OLE object:

   Error! Not a valid embedded object.

Choosing the Field Codes command again removes the check mark beside
Field Codes and allows you to see the results of the field codes.

More Information:

If you use an invalid dynamic data exchange (DDE) link, all versios of 
Word for Windows will generate the message "Remote Data Not Accessible." 
This error appears after you try to update the field by pressing the F9 
key. Updating an invalid OLE field does not produce a similar message.

Steps to Reproduce Problem
--------------------------

1. Start Microsoft Excel version 3.0 or later, open a spreadsheet, and
   copy a small selection of the spreadsheet to the Clipboard.

2. Start Word for Windows. From the Edit menu, choose Paste Special.
   In the Paste Special dialog box, select Excel Worksheet Object from
   the Data Type box. Choose the OK button.

3. From the View menu, choose Field Codes (unless a check mark already
   appears beside the command). The field code for the object you just
   inserted should look similar to the following:

      {EMBED ExcelWorksheet \s  \* mergeformat}



4. Remove "ExcelWorksheet" from the OLE field code.

5. Press F9 to update the field.

Note that no error message appears.

Additional reference words: 2.00 w4wfield 6.00 wm_word



WinWord: Field to Insert Previous Month Based on Current Date
Article ID: Q80507
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

To insert the previous month's date in a Microsoft Word for Windows
document, use the following field:

   {QUOTE {IF {DATE \@ M} = 1 12 {={DATE \@ M} - 1}}/1/92 \@ MMMM}

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 646,
752-753, 759-762

"Microsoft Word for Windows User's Reference," version 1.x, pages 85,
89-91, 94, 97-98, 105, 117-119

Additional reference words: 6.00 w4wfield 1.0 1.1 1.1a 2.0 1.x 1.00
1.10 wm_word 1.10a 2.00



WinWord: Simulating XOR Logic with Field Codes or WordBasic
Article ID: Q80510
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you can simulate the XOR logic by using
either field codes or the WordBasic macro language.

MORE INFORMATION
================

To reproduce the XOR operation in Word for Windows using a WordBasic
function, use the following formula:

   XOR=(Abs(test1 + test2 +... + testn) Mod 2) * - 1

For example:

   Sub MAIN
      a =(2 = 2)
      b =(2 = 3)
      c =(2 = 3)
      If XOR(a, b, c) Then

Print "XOR is True"
      Else

Print "XOR is False"
      End If
   End Sub

   Function XOR(a, b, c)
      XOR =  (Abs(a + b + c) Mod  2) * - 1
   End Function

The following is an explanation of how the function works:

1. The formula applies the ABS function to the sum the variables that
   return TRUE. Note: In Word for Windows, TRUE has the numerical value
   of negative one (-1), FALSE equals zero (0).

2. The MOD statement divides this sum by two (2) and returns the
   remainder, which is one (1) if an odd number of the tests are TRUE,
   and zero (0) if an even number of the tests are TRUE.

3. The remainder is multiplied by negative one. FALSE remains zero,
   but TRUE becomes negative one (-1) to conform to WordBasic notation.

You can create this type of logical structure in Word for Windows by



using field codes. In the following example, T=TRUE and F=FALSE. Note:
To insert the braces, press CTRL+F9.

   {IF {IF x ="T" "T" "F"} = {IF y ="T" "T" "F"} "F" "T"}

In the above example, the field on either side of the equal sign (=)
checks to see if the comparison is TRUE. If it is, the results are
TRUE; if not, the result is FALSE. The comparison of the two IF
statements yields TRUE if they are the same and FALSE if they are not.
The following table illustrates the values and the results:

   Statement 1       Statement 2      Results
   -----------       -----------      -------

       T                  T              F
       T                  F              T
       F                  T              T
       F                  F              F

You can also create this kind of logical structure in a Word for
Windows macro. In the following example, T=TRUE and F=FALSE. In
WordBasic, the IF statement is combined with the THEN and ELSE
statements. An example would be as follows:

   IF X$="T" THEN Test1$="T" ELSE Test1$="F"
   IF Y$="T" THEN Test2$="T" ELSE Test2$="F"
   IF Test1$=Test2$ THEN Results$="F" ELSE Results$="T"
   END IF

For more information on the If...Endif statement, search for
"WordBasic Programming Language" and "If...ElseIf...Else...End If"
using the Help menu.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 747-762,
774-776

"Microsoft Excel Function Reference," version 3.0, page 155

"GW-Basic Interpreter User's Guide," page 60

Additional reference words: 6.00 w4wfield w4wmacro 1.00 1.10 1.10a
2.00 wm_word 2.00a 2.00a-CD 2.00b 2.00c



Automating Form Templates Without Using ASK or FILLIN Fields
Article ID: Q80551
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, the normal procedure for automating
form templates is to use a series of ASK or FILLIN fields in
conjunction with an AutoNew macro. (For more information on this
procedure refer to the "Microsoft Word for Windows User's Guide,"
version 2.0, pages 480-484, or the "Microsoft Word for Windows User's
Reference," page 188.) With this procedure, responses are restricted
to a total character value of 255 per dialog box. If your automated
form requires greater response flexibility and/or the response dialog
boxes are not desired, the method below may prove effective.

Note: Word for Windows version 6.0 uses Form fields to get around the 
character restriction in Ask and Fillin fields.

To use blank fields to automate form templates, use the following
steps:

1. From the File menu, choose New, and choose the OK button.

2. Type the following information, pressing ENTER several times after
   each entry:

      Name:

      Address:

      Phone Number:
  
3. Press CTRL+F9 to create a set of field code braces for each entry.
   Your form should appear as follows:

      Name:  {}

      Address:  {}

      Phone Number:  {}
 
   Note: These braces are hidden unless you choose Field Codes from the
   View menu. As long as the braces do not contain any spaces or
   characters, they do not generate any error messages.
 
4. With the field code braces positioned after each question, you can
   use the F11 key to move quickly to each question. The SHIFT+F11 key



   combination moves your insertion point to the previous question.
 
5. From the File menu, choose Save As. Assign the new form template a
   name. In Word for Windows version 2.0, select Document Template
   (*.DOT) from the Save File as Type list, and choose the OK button. In
   Word for Windows version 1.x, choose the Options button, choose
   Document Template from the File Format list, and choose the OK 
   button.

MORE INFORMATION
================

You can further automate the above process by adding an AutoNew 
macro that alerts the user (with a message box) that the F11 and the
SHIFT+F11 keys are available for navigation within the form.
Additionally, you can use the insertion of bookmark names
corresponding to the empty field code braces to customize navigation
to individual questions. For example, in the above procedure, choose
Field Codes from the View menu to display the hidden braces. Select
the braces beside the Address field. From the Insert menu select
Bookmark. In the Bookmark Name field, type "Address" (without the
quotation marks) and choose the OK button. You can use the GoTo key
(F5) to position the insertion point at any specified question.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 480-84,
730, 742, 753-54

"Microsoft Word for Windows User's Reference," version 1.x, pages
19-20, 84-89, 188, 215

Additional reference words: w4wmacro w4wfield w4wtemplate
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 2.00c-cd



WinWord: Two Backslashes Appear in XE Field Before Colon (:)
Article ID: Q80764
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you create an index entry by
selecting text containing a colon (:) and choosing Index Entry from
the Insert menu, two backslashes (\\) display preceding the colon in
the resulting XE field. Only one backslash (\) displays before all
other punctuation marks.

This problem was corrected in Word version 6.0 for Windows.

More Information:

If you create an XE field using the Insert Index Entry command rather
than pressing CTRL+F9 and typing the field, the index entry text
appear as follows:

   {XE "This is an example\\:"}

The second backslash is unnecessary in Word for Windows version 2.0;
it does not affect the appearance of the index entry in your index. An
index entry can contain one, two, or even no backslashes before
punctuation and still behave correctly in version 2.0.

In version 1.x, if you create an index entry either by typing the XE
field or by typing text in the Index Entry dialog box and you do not
type at least one backslash before a colon, no page number appears the
index entry in your index. In version 2.0, the index entry and its
page number appear correctly in the index regardless of the existence
of the backslash.

Steps to Reproduce Problem
--------------------------

1. In a Word for Windows document, type a line with a colon in it.

2. Select the line. From the Insert menu, choose Index Entry. Choose
   the OK button.

3. From the View menu, choose Field Codes if it is not already
   selected.

The XE field contains two backslashes in front of the colon in your
index entry text. Microsoft is researching this problem and will post
new information here as it becomes available.



Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 541-545

"Microsoft Word for Windows User's Reference," version 1.x, pages 86,
89, 99, 111-112, 165-166

Additional reference words: 1.00 1.10 1.10a 1.0 1.1 1.1a 2.00 w4wfield
whack



Word: Generating an Index with Nonnumeric Chapter Numbers
Article ID: Q80919
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a_CD 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

Summary:

To create an index in Word that has nonnumeric chapter references, use
the following index entry:

   {XE "entry text" \t "{SEQ CHAPTER \c \* Alphabetic}-{PAGE}"}

Select this field, choose Character from the Format menu, and select
the Hidden check box under Style. Choose the OK button. Note: The
braces ({}) enclosing the field must be created by pressing CTRL+F9.

This functionality was changed in Word version 6.0 for Windows.

In addition, the chapters in the document must start with a field that
reads:

   {SEQ CHAPTER}

You will need to select the field and update it (press F9) for the
sequence and page numbers to appear in the index.

This field is needed to make the chapter numbers appear in the index.
However, you can include the \h switch inside the field if you do not
want to display the result of the field in the document.

Assuming that the above sample Index Entry (XE field) is on page 3 in
Chapter 6, the resulting index reads:

   entry text, F-3

Reference(s):

"Microsoft Word for Windows User's Guide," version 1.0, page 111

"Microsoft Word for Windows User's Reference," version 2.0, pages 540-
549

Additional reference words: w4wfield sequence sequential 1.00 1.10 2.00
2.00a non-numeric not numeric



Cannot Use \h Together with \* Format Switches in a Field
Article ID: Q81135
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, the \h switch does not work in
conjunction with the following format switches in fields:

   \*arabic
   \*ordinal
   \*roman
   \*alphabetic
   \*cardtext
   \*ordtext
   \*hex
   \*dollartext
 
If you use \h with any of the above formatting switches, the field
result is not hidden; however, removing the formatting switch does not
disrupt the formatting of any remaining fields in the series.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================
 
The \h switch is used to hide the result of a field. This is useful
when you do not want to display all numbers in a series or when you
initiate a sequence number to be referenced in a header or footer.
 
The \* formatting switches control the format of the field result. For
example, the \* alphabetic switch causes the result of the field to be
represented as an alphabetic character rather than numeric. These
switches are useful for SEQ and PAGE fields.

When used together the formatting switch overrides the hidden switch



and the field result is no longer hidden. 

To correctly use the \* formatting switch and maintain the hidden
attribute:

1. Select the SEQ Field.

2. From the Format menu, choose Character and select the Hidden check
   box.

This hides the field results, but maintains the desired formatting.

For more information on fields, search for "field" and "sequence" on
the Help menu.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.x, pages 103,
106-107, 112-113

"Microsoft Word for Windows User's Guide," version 2.0, pages 428-429,
562

Additional reference words: w4wfield sequence sequential 1.0 1.00 1.1
1.10 1.10a 1.1a 2.00 2.0a 2.00a



WinWord: Updating Fields When File Is Locked for Annotations
Article ID: Q81181
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, the author of a document can lock his
or her document for annotations so that other users cannot edit the
document. However, locking the document for annotations does NOT
prevent fields from being updated or new text from being entered in
dialog boxes resulting from FILLIN and ASK fields. This behavior is
useful for forms that contains fields for people to fill in; people
can supply needed information without altering the form itself.

This functionality was changed in Word version 6.0 for Windows.

More Information:
 
If you lock a document for annotations, only the author can alter text
and formatting of the document. However, if the document contains
fields, users can update the fields. If the fields are FILLIN or ASK
fields, the user can input text in the dialog boxes, and Word inserts
and saves the results in the document.

To demonstrate this behavior, follow the steps below:

 1. In a new Word for Windows document, type "This is a test," and press
    ENTER.

 2. Press CTRL+F9 to insert field braces, and type the following
    information between the braces:

       FILLIN "What is your name?"

 3. Press F9 to update the FILLIN field. In the dialog box, type your
    name, and choose the OK button.

 4. From the File menu, choose Save As. Type a name for the document in
    the File Name box, choose the File Sharing button (the Options 
    button in version 1.x), and select Lock for Annotations. Choose the 
    OK button twice.

 5. From the File menu, choose Close.

 6. From the Tools menu, choose Options, and select the User Info
    category. (From the Utilities menu in version 1.x, choose 
    Customize.) Type a different name in the User Name field, then    
    choose the OK button.



 7. From the File menu, choose 1 to open the file that was closed in
    step 5.
 
 8. Select the first line of the document. From the Format menu, choose
    Character. This command should be unavailable because the document 
    is locked for annotations by its author.

 9. Select the second line in the document (this is the line containing
    the FILLIN field), and press F9 to update the field. Type a 
    different name in the dialog box and choose the OK button.

10. From the File menu, choose Save. 

The new text you typed in the FILLIN field's dialog box has been
saved.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 80, 750,
752

"Microsoft Word for Windows User's Reference," version 1.x, pages 7,
89, 97

Additional reference words: w4wfield automatic automate prevent block 
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 



WinWord: Fields Split Over Two Lines in Outline View
Article ID: Q81379
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, TOC (table of contents), INDEX,
INCLUDE, and other fields may appear split over two lines in outline
view.

More Information:

It is normal for TOC and INDEX fields to be split over two lines in
outline view. Word spreads these fields over two lines because the
results of the fields contain paragraph marks that contain formatting
information for the TOC or INDEX. INCLUDE fields are also split over
two lines if the included information contains a paragraph.

Steps to Reproduce Behavior in Word version 2.x
-----------------------------------------------

1. From the View menu, choose Normal or Page Layout. From the View
   menu, look at the Field Codes command. If Field Codes is checked,
   press ESC; if Field Codes is not checked, choose Field Codes.

2. In a new Word for Windows document, type a word, and press ENTER.

3. Select the paragraph created in step 2, and select the Heading 1
   style from the Style box on the tool bar.

4. Position the insertion point on a blank line below the Heading 1
   paragraph. From the Insert menu, choose Table of Contents. Select the
   Use Heading Paragraphs option in the Table of Contents box, and 
   choose the OK button.

5. From the View menu, choose Outline. The TOC field appear as
   follows:

      {TOC \o
      }

The functionality of INCLUDE, INDEX and TOC fields split over two
lines in outline view is not affected.

Reference(s):

"Microsoft Word for Windows User's Reference," version 1.x, pages 236,
357



"Microsoft Word for Windows User's Guide," version 2.0, pages 517, 539

Additional reference words: 2.00 1.10a 1.10 2.00a 1.00 6.00
w4wfield broken lines wm_word



Superscript and Subscript Underline Misaligns in WinWord 2.0
Article ID: Q81418
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, the underline for superscript and
subscript text does not align with the underline for normal text.

WORKAROUND
==========

To work around this problem, create an equation field using the
overstrike function to underscore words or phrases that contain
super/subscripted characters, as in the following example:

   Syntax: {eq \o(Text,Underscore characters)}

   {eq \o(Apple,_____)}
    
In the syntax above, "Text" is the string containing superscript text
to be underlined, and "Underscore characters" is the actual characters
to be used to underscore the "Text" characters. The braces for the
equation field are created by pressing CTRL+F9. Type the text between
the braces.
  
Note: The underscore character may not match the one used by Word's
underline character format command. You may need to experiment with
different underscore characters (different font, point size, and so
forth) to achieve a continuous underscore effect.

STEPS TO REPRODUCE PROBLEM
==========================

1. Type some text in a Word for Windows version 2.0  document.
 
2. Select a portion of the text.

3. From the Format menu, choose Character.

4. From the Super/subscript list box, select superscript.

5. Select all of the text in your document.

6. From the Format menu, choose Character.

7. From the Underline list box, select Single.



Microsoft has confirmed this to be a problem in Word for Windows
versions 2.x and 6.0. We are researching this problem and will post
new information here as it becomes available.

Additional reference words: w4wfont w4wprint w4wfield 2.00 2.00a 6.00 
wm_word 2.00a-CD 2.00b 2.00c 



WinWord: NextField and UpdateField Do Not Update All Fields
Article ID: Q81488
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If the Field Codes command is not chosen on the View menu in Microsoft
Word for Windows, using the WordBasic commands NextField and
UpdateFields may not update all of the fields in your document.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New, then choose the OK button.

2. Press CTRL+F9 to insert a pair of field braces. Within the braces,
   type the following:

      Fillin "Test 1"

3. Press the RIGHT ARROW key to move outside the braces, then press
   ENTER to move to the next line.

4. Press CTRL+F9 to insert a second pair of field braces. Within the
   braces, type the following:

      Fillin "Test 2"

5. From the Tools menu, choose Macro. (In version 1.x, choose Edit
   from the Macro menu.) Type "Test" (without the quotation marks) in 
   the Macro Name box, then choose the Edit button. Type the following 
   macro:

      Sub MAIN
      StartOfDocument
      ViewFieldCodes 0
      NextField
      UpdateFields
      NextField
      UpdateFields
      End Sub

6. From the Window menu, choose Arrange All. Place the insertion point
   in the document window, and choose the Start button.



Skipping over Test 1, Word prompts you for Test 2 twice. The function
works correctly if the FILLIN field is not the first character of the
document; the find next field function (F11) cannot find a field in
the first position of a document.

Microsoft is researching this problem and will post new information
here as it becomes available.

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 
2.00c  w4wmacro w4wfield



Word for Windows: Creating a Dot-Leader-Delimited Index
Article ID: Q81516
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you can create an index delimited by a
dot leader (as in a table of contents) by adding a switch to the INDEX
field and redefining the index style.

More Information:

To create an index similar to the example below, use the following
steps:

   Testing....................1,2
   Room.........................3
   Equipment....................5

1. Open a Word for Windows document that contains an index.

2. From the Format menu, choose Style. From the Style Name box, select
   Index 1, choose the Define button, then choose the Tabs button. Set a
   tab in the Tab Stop Position box. In the Alignment box, select Right.
   In the Leader box, select the second option button (dot leader), and
   choose the Set button. Choose the OK button.

3. Choose the Apply button.

4. Select Yes when prompted to change style properties.

5. Press CTRL+F9 to insert a pair of field braces.

6. Within the field braces, type:

      INDEX \e "tab"

   where "tab" represents pressing the TAB key. Note: The quotation 
   marks must be typed before and after pressing the TAB key.

7. Update the field by pressing F9.

Reference(s):

"Microsoft Word for Windows and OS/2 Technical Reference," page 360

Additional reference words: w4wfield 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c 6.00 wm_word



WinWord: Framed & Embedded Object Resizes in Whole Page Zoom
Article ID: Q81731
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

If you choose the Whole Page button in the Zoom dialog box of
Microsoft Word for Windows version 2.0 and then edit a framed,
embedded object, the object resizes.

This problem was corrected in Word version 6.0 for Windows.

Steps to Reproduce Problem
--------------------------

1. From the View menu, choose Zoom, select 100%, and choose the OK
   button.

2. From the Insert menu, choose Object, select WordArt, and choose the
   OK button.

3. Create a WordArt object, then choose the OK button to add the
   object to the document.

4. Select the object. From the Insert menu, choose Frame. Choose the
   Yes button when prompted to switch to page layout view.

5. From the View menu, choose Zoom, and choose the Whole Page button.

6. Double-click the WordArt object. Make a change to the WordArt
   object, and choose the OK button to add the object to the document.

The WordArt object is reduced to a smaller size. This result occurs
regardless of whether or not the \s switch is removed from the
object's EMBED field.

Microsoft has confirmed this to be a problem in Word for Windows
versions 2.0 and 2.0a. We are researching this problem and will post
new information here as it becomes available.

Reference(s):

"Microsoft Word for Windows User's Guide," pages 346-348, 393, 694

Additional reference words: w4wfield linking embedding OLE paste
special scale shrink shrunk
2.00 2.00a 2.00a-CD 2.00b 2.00c



WinWord: PAGEREF Field with Special Bookmarks Produces Error
Article ID: Q81958
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

Using PAGEREF fields in conjunction with the special predefined
bookmarks in Microsoft Word for Windows generates a "Bookmark not
defined" error.

More Information:

The PAGEREF field inserts the page number of a bookmark for
cross-reference purposes; however, with the predefined bookmarks, the
page numbers do not work correctly. These bookmarks are defined as
reserved and do not display in the Bookmark dialog box. You can use
these bookmarks with the Edit Go To command.

The special bookmarks include the following:

   \Sel, \PrevSel1, \PrevSel2, \StartOfSel, \EndOfSel, \Line, \Char,
   \Para, \Section, \Doc, \Page, \StartOfDoc, \EndOfDoc, \Cell, \Table,
   and \HeadingLevel.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 746, 749

"Using WordBasic," by WexTech Systems and Microsoft, pages 88-89

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c w4wtable w4wfield 6.00 wm_word



WinWord: ASK Fields with Default Answers Prompt First
Article ID: Q82091
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows version 2.0, if you supply a field as a
default answer for an ASK field (by using the \d switch within the ASK
field) that field is updated by an AutoNew macro before any other ASK
fields in your document are updated.

This behavior can cause problems if the ASK field containing the
default answer is not physically the first field in the template. If
it is not the first field, the field prompts you for information
twice. It is updated first and then again in order of its physical
location in the template. If the prompts are answered differently,
Word uses the second reply in the document.

Note: The use of fields as default answers to ASK fields in Word for
Windows version 1.x does not cause this reaction when the AutoNew
macro runs.

More Information:

ASK fields are generally used in template files in conjunction with an
AutoNew macro. When you create a new document based on such a
template, the fields are automatically updated so that they prompt you
for appropriate answers to be filled in at the bookmark locations.

If you use the \d switch within an ASK field to supply another field
as the default answer when the prompt appears, an AutoNew macro runs
on that ASK field first (regardless of its position in the document).

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New, select the Template option button,
   and choose the OK button to create a new template file based on
   NORMAL.DOT.

2. Press CTRL+F9 to create the field braces, and insert the following
   fields:

      {ask to "Who is this memo to?"}{to}
      {ask from "Who is it from?"}{from}
      {ask today "Is today's date correct?  If not, type in
      the correct date." \d {date}}{today}
      {ask hour "Time?" \d {time}}{hour}



3. From the File menu, choose Save, type a name for the template, and
   choose the OK button.

4. From the Tools menu, choose Record Macro, type a name for the
   macro, and choose the OK button. Select the In Template option, and
   choose the OK button. Record the following steps:

   a. From the Edit menu, choose Select All.

   b. Press the F9 key.

   c. Cancel the dialog boxes.

   d. From the Tools menu, choose Stop Recorder.

5. From the File menu, choose Close, then choose the Yes button when
   prompted to save changes to the template.

6. From the File menu, choose New, select the template name assigned
   in step 3, select the Document option button, then choose the OK
   button.

The order of prompts is as follows:

   Date
   Time
   To
   From
   Date
   Time

In Word version 6.0, in Page Layout view, the order of prompts is:

   Date
   Time
   Date
   Time
   To
   From
   Date
   Time

The order of prompts should be as follows:

   To
   From
   Date
   Time

Because the default answers to the ASK fields are reserved fields,
DATE and TIME, the AutoNew macro causes them to be updated first
rather than in the appropriate order. 

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 646-650,



763-765, 786

Additional reference words: 2.00 2.00a w4wfield 6.00 wm_word 



Error Message: Cannot Obtain Data from Excel for <filename>
Article ID: Q82278
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Excel versions 2.1, 3.0, and 4.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

This article describes several causes for the following Microsoft Word
for Windows error message:

   Cannot obtain data from Excel for <filename>

The information in this article applies to charts created in Microsoft
Excel for Windows versions 2.1, 3.0 and 4.0.

More Information:

This error message can occur for the following reasons:

1. The Word for Windows document contains an automatic update link to
   a chart in Microsoft Excel and the chart was renamed after the link
   occurred. To maintain a link to a renamed chart, you must change the
   filename in the field to the current name of the chart, and press the
   F9 key to update the field in the Word document.

   To reestablish a link to the renamed chart, make sure that the Field
   Codes option is turned on. In the LINK or DDEAUTO field, change the
   filename to the chart's new name. Be sure to use double backslashes 
   in the path, as in the following example:

      c:\\excel\\chart1.xlc

2. In Excel, the Ignore Remote Requests option is selected in the
   Workspace dialog box. From the Options menu, choose Workspace, and
   clear the Ignore Remote Requests check box. Update the field in Word
   for Windows by pressing the F9 key.

3. Your Excel executable file was renamed to something other than
   EXCEL.EXE. Rename it EXCEL.EXE.

4. When updating a link, Word for Windows actually launches Excel. If
   an Auto_Open macro runs when Excel is launched and the execution of
   that macro exceeds Word's DDE time-out setting, the "Word cannot
   obtain data..." error message occurs.

   To prevent this error when it is caused by DDE time-out, modify the
   DDETIMEOUT=n setting in the Windows WIN.INI file. The value of "n"
   determines the number of seconds Word for Windows waits for DDE data
   from the source application. The default value for n is 30 seconds in



   Word for Windows version 1.x. The default value for n is 60 seconds  
   in Word for Windows version 2.0.

   In Word for Windows version 2.0, the DDETIMEOUT setting should be
   placed in the [Microsoft Word 2.0] section of the WIN.INI file as
   follows:

      [Microsoft Word 2.0]
      DDETIMEOUT=n

   In Word for Windows version 1.x, the DDETIMEOUT setting should be
   placed in the [Microsoft Word] section of the WIN.INI file as 
   follows:

      [Microsoft Word]
      DDETIMEOUT=n

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 684-691,
810

"Microsoft Word for Windows User's Reference," version 1.x, pages 397,
411, 201-203

Additional reference words: w4wfield  1.00 1.10 1.10a 2.00 6.00
2.00a errmsg err msg wm_word



WinWord: Referencing Expression Fields from Separate Tables
Article ID: Q83204
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you can use a bookmark to refer to a
cell which is in a different table.

More Information:

When working with expression fields in a table, you cannot use cell
reference codes (R1C1 or A1, for example) to refer to a cell from a
different table.

To reference an expression from a different table, you can apply a
bookmark to the expression. Whether you apply the bookmark to the
expression or its result, Word inserts the result when you reference
the bookmark. This reference can be included in an expression placed
in a separate table. For example, create the following expression in a
table:

   |----------|----------------------|
   |2         |{=product ([r1c1])*3} |
   |----------|----------------------|

Note: To create the field braces, press CTRL+F9.

Position the insertion point within the field braces, and press F9 to
update the field. 

In versions 1.0 and 2.0:

From the View menu, clear the Field Codes command

In version 6.0:

From the Tools menu, choose Options. Choose the View tab. Put an x in 
the Field Codes check box.

The result of the expression should display in the table, as in the
following example:

   |-------|---------------|
   | 2     |6              |
   |-------|---------------|

Select the expression. From the Insert menu, choose Bookmark. Type
"test" (without the quotation marks), and choose the OK button. Insert



a second table, and type the following expression in a cell:

   {=test*2}

The bookmark "test" references the result from the first table (that
is, 6). The result of the second expression is 12.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 306-311

Additional reference words: 1.0 1.00 1.1 1.10 1.1a 1.10a 2.0a 2.00 6.00
w4wtable 2.00a w4wtable w4wfield add calculate math equation wm_word



WinWord: Insert Page Numbers Switches Header/Footer Option
Article ID: Q83693
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, if you use the Insert Page Numbers
command to add page numbers to a document, Word activates the
Different First Page option in the Header/Footer dialog box.

MORE INFORMATION
================

The Insert Page Numbers command is designed to apply page numbers to
all pages except the first page. If you want page numbers on every
page of a document, choose Header/Footer from the View menu (from the
Edit menu in Word for Windows version 1.x), clear the Different First
Page option, and insert a PAGE field.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.x, pages
122-123, 246-247

"Microsoft Word for Windows User's Guide," version 2.0, pages 421-424

Additional reference words: 6.00 1.00 1.0 1.10 1.1 1.10a 1.1a 2.0a
2.00a wm_word 2.00 pagination w4wfield different missing 2.0b 2.0a-CD
2.00b 2.00a-CD



Update Source Key Does Not Update Non-WinWord Documents
Article ID: Q84322
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you can use the Update Source key
(CTRL+SHIFT+F7) to update changes in included documents; however, if
the included document is not in the Word for Windows version 1.x or
2.0 or 6.0 file format, the changes will not be made.

More Information:

You can use an INCLUDE (called INCLUDETEXT in version 6.0) field to 
insert a portion of a file or an entire file into a separate file. If 
the included file is not in Word for Windows format, you can use the \c 
switch with the INCLUDE field to indicate which converter should be 
used.

You can then make changes in the destination document while in the main 
document. To update the source document with those changes, position the 
insertion point in the text of the included file, and press 
CTRL+SHIFT+F7. If the source document is not a Word for Windows file, 
the changes will not be made, and no message will be displayed to 
indicate that the action cannot be completed.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 246-248

"Microsoft Word for Windows User's Reference," version 1.x, pages
98-99

Additional reference words: w4wfield merge 1.00 1.10 1.10a 2.00 6.00
2.00a 2.00b 2.00a-CD wm_word



WinWord: Placing the Same Page Number on Left and Right Pages
Article ID: Q84659
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

This article describes how to place the same page number on both the
left and right pages of a Microsoft Word for Windows document. This
page-numbering format is useful for producing training documents in
which trainer information (such as delivery notes) is located on the
left page and student information is located on the right page.

First, establish different odd and even headers:

In Word version 6.0, choose Page Setup from the File menu. Choose the 
Layout tab. Under Headers and Footers, choose Different Odd and Even. 
Click OK.

In Word version 2.0, choose Header/Footer from the View menu. Select the 
Different Odd and Even Pages box. 

In the even header, insert the following field:

      {={page}/2}

In the odd header, insert the following field:

      {=({page}+1)/2}

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 6.00
2.00a-CD 2.00b 2.00c  w4wfield pagination wm_word



WinWord: SET and ASK Fields Do Not Work in Headers or Footers
Article ID: Q84715
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, SET and ASK fields do not work
correctly in headers and footers.

More Information:

The SET and ASK fields are used to assign text to bookmarks. You can
then include that bookmark in a field elsewhere in the document to
insert the assigned text. For example, the field

   {SET name "John Doe"}

assigns the text "John Doe" to the bookmark "name." If you insert the
field {name} elsewhere in the document, the result of that field will
be the text "John Doe." For example, if you update the following ASK
field,

   {ASK name "What is your name?"}

a dialog box requesting text for the bookmark "name" will be
displayed. If you insert a SET or ASK field in a document header or
footer, the bookmark will not be defined. Updating an ASK field in a
header or footer does not generate a dialog box.

If you insert a bookmark field into the body of the document, the
header, or the footer, you will receive the error message "Error!
Bookmark Not Defined."

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 573-574,
646-651, 757

"Microsoft Word for Windows User's Reference," version 1.x, pages 89,
92, 107, 149

Additional reference words: w4wfield  err 1.00 1.10 1.10a 2.00 2.00a  
6.00 2.00a-CD 2.00b 2.00c wm_word



WinWord: Spelling Checker Updates Fields in Headers & Footers
Article ID: Q85456
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

If you perform a spell check in a Microsoft Word for Windows document that
contains headers and/or footers, any fields in the headers and/or footers
will be updated.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. From the View menu, choose Header/Footer. Select Header, and choose
   the OK button to open the header pane.

2. Press CTRL+F9 to insert the braces (field characters), and type the
   following within the braces:

      fillin "What is your name?"

3. If the header/footer bar is being displayed, choose the Close
   button to close the header pane.

4. In the body of the document, type the following:

      This is a test.

5. From the Tools menu, choose Spelling.

The FILLIN field in the header is updated, which causes a dialog box
asking for your name to appear.



REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 277,
573, 752

Additional reference words:  w4wproof 2.00 2.00a w4wfield speller 
spelling check checker 2.0b 2.0a-CD 2.00b 2.00a-CD 



Extra Paragraph Mark Above INCLUDE Field at Top of Document
Article ID: Q85489
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you select the Link To File check
box and insert a file at the beginning of a document, Word will add an
additional paragraph mark to the beginning of the document if the
inserted file begins with a table. You cannot delete this additional
paragraph mark.

Note: The additional paragraph mark is not displayed when the Field
Codes command is checked.

If you insert a file that begins with a table at the start of a
document and do NOT select the Link To File check box, Word will not
add the additional paragraph mark to the beginning of the document.

More Information:

To insert a file into a Word for Windows document, use one of the
following methods:

 - From the Insert menu, choose File. Select the file in the File Name
   box. If desired, select the Link To File check box (in Word for
   Windows version 1.x, select the Link check box). Choose the OK 
   button.

  -or-

 - Press CTRL+F9 to insert braces (field characters) in your document.
   Type "INCLUDE <filename>" (without the quotation marks) inside the
   braces. For more information on the INCLUDE field, refer to pages
   244-248 of the "Microsoft Word for Windows User's Guide."

Workaround
----------

If the extra paragraph mark disrupts the page layout of your document,
you can change the paragraph line spacing setting to 0.01 inch. From
the Format menu, choose Paragraph. In Word versions 2.x and 6.0, select 
Exactly in the Line Spacing box, and type "0.01" (without the quotation 
marks) in the At box. In Word 1.x, type "-0.01" (without the quotation 
marks) in the Line Spacing box. Choose the OK button.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 244-248



Additional reference words: 1.0 1.00 1.10 1.1 1.1a 1.10a 2.00 2.00a 6.00 
wm_word 
2.0a w4wfield linked w4wtable extra



Text Containing Fields Does Not Convert Correctly to Table
Article ID: Q85709
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you try to convert text that
contains one or more fields to a table, the resulting table may
contain only one column.

This problem was corrected in Word version 6.0 for Windows.

More Information:

If you convert tab-delimited or comma-delimited text to a table and
the first row of text consists of fields or the results of fields,
Word for Windows will generate only one table column.

In version 2.0 of Word for Windows, if the text is tab-delimited and
contains at least one field, a one-column table will be generated. If
the text is comma-delimited, when you choose to convert the text to a
table, a dialog box will prompt you to specify a delimiter. If you
select the Commas option button, the conversion will work correctly.

In versions 1.0 and 1.1 of Word for Windows, if the text is tab-
delimited or comma-delimited and the text contains at least one field,
a one-column table will be generated. The delimiter option buttons in
the Insert Table dialog box will be unavailable.

Workaround
----------

To convert fields and the results of fields to a table with the
correct number of rows and columns, use one of the following methods:

 - In Word 2.0, replace the tabs with commas. Select the text and
   fields, then choose Convert Text to Table from the Table menu.

  -or-

 - Unlink the fields after you update them by positioning the insertion
   point within the field(s) and pressing CTRL+SHIFT+F9. In version 2.0,
   select the text, and then choose Convert Text to Table from the Table
   menu. In version 1.x, select the text, and then choose Table from the
   Insert menu.
   
   Note: This workaround will not work for {SYMBOL XXX \f "Symbol"}
   fields.



Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 257-258,
265, 316-318, 757

"Microsoft Word for Windows User's Reference," version 1.x, pages 88,
366, 370

Additional reference words: 1.1a 2.0a 1.00 1.10 1.10a 2.00 2.00a
w4wtable w4wfield conversion incorrect wrong dimmed 2.0b 2.0a-CD 2.00b
2.00a-CD



Effect of \*MERGEFORMAT When Updating Link to Excel Sheet
Article ID: Q86353
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you update the link to a Microsoft Excel for Windows spreadsheet in
your Microsoft Word for Windows document, the following formatting may
be affected:

 - Font and Point Size
 - Cell Borders
 - Cell Dimensions

Whether or not changes in the above formatting occur depends on the
presence of the \*MERGEFORMAT switch in the LINK or DDE field. This
formatting is also affected by whether you modify the linked
information from within Word for Windows or from within Excel for
Windows.

More Information:

If you link an Excel spreadsheet to a Word document, a LINK field (DDE
field in Word 1.x) that references the spreadsheet in Excel will be
inserted in your document. If you press F9 to update the results of
this field, Word will insert a new copy of the spreadsheet.

If you use the \*MERGEFORMAT switch in a field, the field result will
retains the exact formatting of the previous result when you update
the field. For example, if your LINK field contains the \*MERGEFORMAT
switch and you edit the data, the font, and the border and cell
dimensions in your Excel spreadsheet, when you update the LINK field
in Word, only the data will be changed in the LINK field results. The
border and cell dimensions from updating. If your LINK field does not
contain the \*MERGEFORMAT switch, formatting of the font and the
border and cell dimensions, as well as the data, will be updated to
reflect changes made to the Excel spreadsheet when you update the LINK
field.

Similarly, if you modify the data and formatting of the spreadsheet by
changing the results of the LINK field in Word, only the data will be
refreshed when you press F9 to update the field results if the field
contains the \*MERGEFORMAT switch. The data AND formatting will be
refreshed when you press F9 if the field does not contain the
applied to the linked spreadsheet in Word, be sure the field contains
the \*MERGEFORMAT switch.

Reference(s):



"Microsoft Word for Windows User's Guide," version 2.0, pages 748, 756

"Microsoft Word for Windows User's Reference," version 1.x, pages
94-95

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a  6.00
2.00a-CD 2.00b w4wfield ddeauto dynamic data exchange wm_word



Error Updating Internal Link That Is Part of an External Link
Article ID: Q86524
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if a portion of an external link is
linked elsewhere in a document, updating the internal link will
generate the error message "Error! Bookmark Not Defined." Word version 
6.0 does not display the error message.

More Information:

If you choose the Paste Link button after choosing the Paste Special
command to link information from an application to a Word for Windows
document, a LINK field will be inserted in your document. If you
choose the Paste Link button after choosing the Paste Special command
to link information from one location in a Word document to another
location in the same document, a REF INTERN_LINK field will be
inserted in your document. If the REF INTERN_LINK field contains a
portion of the result of a LINK field, an error will occur when you
update the REF INTERN_LINK field.

Steps to Reproduce Problem
--------------------------

1. Select an Excel worksheet. From the Edit menu, choose Copy to
   insert the worksheet onto the Clipboard.

2. Switch to Word. From the Edit menu, choose Paste Special. Under
   Data Type, select Unformatted Text, then choose the Paste Link 
   button.

3. Select a portion of the linked worksheet. From the Edit menu,
   choose Copy.

4. Position the insertion point lower in the Word document. From the
   Edit menu, choose Paste Special. Under Data Type, select Formatted
   Text, then choose the Paste Link button.

5. Switch to Excel and modify some of the information in the linked
   worksheet.

6. Switch back to Word. The original link has been changed to reflect
   the change made in Excel; however, the second internal link has not
   been updated. Select the second link and press F9 to update it.

The error message "Error! Bookmark Not Defined" is displayed.



Microsoft has confirmed this to be a problem in versions 2.x and
6.0 of Word for Windows. We are researching this problem and
will post new information here as it becomes available.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 683

Additional reference words: w4wfield ole dde l&e embed  err 6.00
2.00 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD wm_word



SYMBOL or AUTONUM Field Embedded Inside QUOTE Field Disappears
Article ID: Q86679
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, a SYMBOL, AUTONUM, AUTONUMOUT, or
AUTONUMLGL field inserted in a QUOTE field does not appear in the
results of the QUOTE field.

This problem was corrected in Word version 6.0 for Windows.

More Information:

The QUOTE field is often used to keep groups of characters together
and print them in all versions of a merged document. Because they
disappear in the QUOTE field's output to the document, the SYMBOL,
AUTONUM, AUTONUMOUT or AUTONUMLGL fields cannot be used this way.

Steps to Reproduce Problem
--------------------------

1. From the View menu, choose Field Codes if this command is not
   already chosen.

2. Press CTRL+F9 to insert the field characters (braces).

3. Within the braces, type the following:

      QUOTE "75

4. Press CTRL+F9 to insert another set of field characters. With the
   insertion point between the field characters, choose Symbol from the
   Insert menu. Make sure the Symbols From box reads Symbol. Choose the
   degree symbol from the chart (it is near the center), then choose the
   OK button.

6. Position the insertion point between the closing brace for the
   SYMBOL field and the closing brace of the QUOTE field, then type a
   quotation mark. The field should now appear as follows:

      {QUOTE "75{SYMBOL 176 \f "Symbol"}"}

7. Select the entire QUOTE field and press F9. From the View menu,
   choose Field Codes to display the field results.

The QUOTE field result is 75. The degree symbol, which should be
inserted by the nested SYMBOL field, does not appear.



Microsoft has confirmed this to be a problem in 2.x versions
of Word for Windows. This problem was corrected in Word version 6.0 for 
Windows.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 154,
650-651, 751, 752, 754, 757

Additional reference words: w4wfield 2.00 2.00a 2.00a-CD 2.00b



Framed, Linked Excel Worksheet Duplicates Itself When Dragged
Article ID: Q86791
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0b, 2.0b
   2.0c, 6.0
 - Microsoft Windows operating system, versions 3.0 and 3.1
 - Microsoft Excel for Windows, versions 3.0 and 4.0
---------------------------------------------------------------------
Summary:

In Microsoft Word for Windows, if you frame a linked Microsoft Excel
for Windows worksheet, then drag the frame to another location on the
page, the worksheet may be duplicated when you update the link. The
second copy of the worksheet is no longer linked, so you cannot update
it.

More Information:

The problem is related to dragging the framed worksheet to a location
on the same line or above the location where it was originally framed.
If you frame the linked Excel for Windows worksheet when the View
Field Codes option is not selected, the framed worksheet can be moved,
but the underlying LINK field is not moved with it. When you later
update the LINK field, a new copy of the worksheet appears on the same
line where the worksheet was originally framed. This new copy is not
framed.

Microsoft has confirmed this to be a problem in Microsoft Word for
Windows versions 2.x and 6.0. We are researching this problem and
will post new information here as it becomes available.

Workaround
----------

You can avoid this problem by using the Format Frame command to
position the frame instead of using the mouse to click and drag the
frame to its new position.

 -or-

Use the following steps to make sure you frame the LINK field when you
frame the Excel worksheet:

1. From the View menu, select the Field Codes option. You can now see
   the LINK field to the Excel for Windows worksheet.

2. Select the entire LINK field.

3. From the Insert menu, choose Frame. Choose the Yes button if Word
   prompts you to switch to Page Layout view.

     NOTE: The frame is the width of the current column. If necessary,
     change the width and/or height of the frame.



4. From the View menu, clear the Field Codes option. You can now see
   the framed Excel for Windows worksheet. Select the frame and, using
   the mouse, drag it to a new location on the page.

5. From the View menu, select the Field Codes option. Notice that the
   LINK field appears inside the positioned frame.

Steps to Reproduce Problem
--------------------------

 1. Open or create a spreadsheet in Excel for Windows with at least two
    rows and columns containing data.

 2. Select the worksheet. From the Edit menu, choose Copy.
 
 3. Switch to Word for Windows and create a new document. Press ENTER
    several times to insert some paragraph marks.

 4. From the Edit menu, choose Paste Special.
 
 5. In the Data Type box, select Formatted Text (RTF) and choose the
    Paste Link button.

 6. Position the insertion point in the linked table. From the Table
    menu, choose Select Table.

 7. From the Insert menu, choose Frame. Choose the Yes button if Word
    prompts you to switch to Page Layout view.

 8. From the View menu, check the Field Codes command. Notice that the
    LINK field is visible, and the table disappears. The LINK field is
    not framed.

 9. From the View menu, clear the Field Codes option.

10. With the mouse, drag the framed table up to the top margin,
    centered on the page.

11. From the View menu, select the Field Codes option. Notice that the
    table AND a LINK field are now visible. The LINK field is not
    framed and is located at the original insertion point.

12. From the View menu, clear the Field Codes option.

13. From the Edit menu, choose Links. Select the first item in the
    Links box and choose the Update button. Notice that two identical
    tables are visible, one centered at the top margin and one at the
    left margin.

    If you make changes in the Excel for Windows spreadsheet, the
    positioned table is NOT updated because it is no longer linked.

Additional reference words: w4wfield  2.00 2.00a 2.00a-CD 2.00b  6.00
w4wtable wm_word



Index Entry (XE) Field Truncates Text at Optional Hyphen
Article ID: Q87170
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you select text that contains an
optional hyphen (created by pressing CTRL+MINUS SIGN) and then choose
Index Entry from the Insert menu, Word truncates the text in the Index
Entry box at the optional hyphen character. If you choose the OK
button, the resulting Index Entry (XE) field is also truncated. Text
to the right of the optional hyphen is not included in the Index Entry
field.

This problem was corrected in Word version 6.0 for Windows.

Workaround 1
------------

Word for Windows does not truncate text that contains an optional
hyphen if you create the XE field by selecting the text and pressing
CTRL+F9 to insert field brackets.

Workaround 2
------------

Before you create the XE field, temporarily apply Hidden Text
character formatting to the optional hyphen. Turn off the viewing of
hidden text by clicking the show/hide nonprinting characters button on
the ribbon (the show all button in Word versions 1.x) or by choosing
Options from the Tools menu (choose Preferences from the View menu in
Word 1.x), selecting the View category and clearing the Hidden Text
check box.

Microsoft has confirmed this to be a problem in Word versions 1.0,
1.1, 1.1a, 2.0, and 2.0a. We are researching this problem and will
post new information here as it becomes available.

More Information:

Word truncates text at the optional hyphen regardless of whether you
select the Optional Hyphens or Show All options in the View category
of the Tools Options dialog box.

Steps to Reproduce Problem
--------------------------

1. Type a word that contains an optional hyphen. For example, type the
   following:



      HYPHEN, CTRL+MINUS SIGN, ATE

2. Select the word you typed in step 1.

3. From the Insert menu, choose Index Entry. Note that Word for
   Windows has inserted "HYPHEN" in the Index Entry box. Choose the OK
   button. The following field is inserted in your Word for Windows
   document:

      {XE HYPHEN}

Word for Windows does not truncate words that contain ordinary hyphens
or em or en dashes.

References:

"Microsoft Word for Windows User's Guide," version 2.0, pages 260-264,
541-542

"Microsoft Word for Windows User's Reference," version 1.0, pages 165-
166, 289-293

Additional reference words: w4wfield 1.00 1.10 1.10a cut off
incomplete 2.00 2.00a 2.00a-CD 2.00b 2.00c 



Bullets and Symbols Blink in Normal and Page Layout Views
Article ID: Q87438
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

If you insert a bullet or symbol in a Microsoft Word for Windows
document and you are in normal or page layout view, the symbol or
bullet blinks each time you press a key on the keyboard while the
insertion point is on the same line as the symbol or bullet. As soon
as you move the insertion point to another line, the symbol or bullet
stops blinking.

This problem was corrected in Word version 6.0 for Windows.

More Information:

You can insert a bullet by choosing Bullets And Numbering from the
Tools menu or by choosing the Bulleted List button on the tool bar.
The following is an example of the field code generated by Word for
Windows when you insert a bullet:

   {SYMBOL 183 \f "Symbol" \s 12 \h}

To insert a symbol, choose Symbol from the Insert menu.

Workaround
----------

You can avoid the blinking bullet or symbol by switching to draft view
or by choosing Field Codes from the View menu.

Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
and 2.0a-CD of Word for Windows. We are researching this problem and
will post new information here as it becomes available.

Additional reference words: flash flashing blinking flicker bullet
w4wfield 2.00 2.00a 2.00a-CD 2.00b 2.00c 



Internal Link to Range Includes Entire Document When Updated
Article ID: Q87946
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

If you copy a portion of a Microsoft Word for Windows document and
paste link it into another document, the entire document appears in
the destination document when you update the link if you close the
included document without saving changes.

This problem was corrected in Word version 6.0 for Windows.

More Information:

In Word for Windows, you can include a portion of one document as an
internal link in a second document. Word for Windows inserts a
bookmark in the source document to mark the linked selection. If you
create the link, close the source document, and choose the Yes button
when you are prompted to save the changes, the link updates correctly.
If you choose the No button when you are prompted to save the changes,
bookmark information about the internal link is discarded; this forces
Word for Windows to include the entire source document when you update
the link.

Workaround
----------

When you link a portion of one Word for Windows document to another
document, be sure to save any editing changes when you close the
source document.

Steps to Reproduce Problem
--------------------------

1. Open the CONVINFO.DOC file, which is located in the Word for
   Windows program directory.

2. Select a paragraph or two of text. From the Edit menu, choose Copy.

3. From the File menu, choose New, and choose the OK button.

4. From the Edit menu, choose Paste Special. Under Data Type, select
   Formatted Text, then choose the Paste Link button.

5. From the File menu, choose Save. Type a file name and choose the OK
   button.

6. From the Window menu, choose CONVINFO.DOC.



7. From the File menu, choose Close. Choose the No button when you are
   prompted to save changes to CONVINFO.DOC.

8. Activate the window that contains the document you saved in step 5.

9. From the Edit menu, choose Links. Select the link and choose the
   Update Now button.

The entire contents of CONVINFO.DOC appears in place of the portion
that was previously linked.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 682-696

Additional reference words: 2.00 2.00a 2.00a-cd w4wfield



"Error! Not a Valid Embedded Object" Embedding Excel Object
Article ID: Q88352
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

You may receive the following error message when you embed a Microsoft
Excel Worksheet, Macrosheet, or Chart object in a Microsoft Word for
Windows document:

   Error! This is not a valid embedded object.

This error message is displayed when you update the embedded sheet in
Microsoft Excel for Windows.

If you try to delete or unlink the EMBED field, the following error
message appears:

   Low Memory. Save the document now.

When you choose the OK button, the following third error message
appears:

   Word needs more memory to be able to undo this operation.
   Do you want to continue?

If you choose the Yes button, Word for Windows completes the
operation.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Workarounds
-----------

 - In Microsoft Excel, copy the worksheet information to the Clipboard.
   Switch to Word for Windows and choose Paste Special from the Edit
   menu. Select Excel Worksheet Object in the Data Type box and choose
   the Paste button.

  -or-

 - Sometimes this problem is caused by your printer driver and you can
   avoid the error messages by switching to a different printer driver.

Steps to Reproduce Problem
--------------------------



1. Create a new document in Word for Windows. From the Insert menu,
   choose Object. Select Excel Worksheet and choose the OK button.

2. Type some text in the first cell of the Microsoft Excel worksheet.

3. From the File menu, choose Update.

   Note: The Excel Worksheet does not update in Word for Windows the
   first time you update the file in Microsoft Excel.

4. From the File menu, choose Update again.

   Note: The Excel Worksheet updates in Word for Windows.

5. From the File menu, choose Exit, and return to Word for Windows.
   The following error message appears in place of the EMBED field:

   Error! This is not a valid embedded object.

6. Select the EMBED field or the error message and press DELETE to
   remove the EMBED field or press CTRL+SHIFT+F9 to unlink the EMBED
   field. The following error message is displayed:

      Low Memory. Save the document now.

7. Choose the OK button. The following error message is displayed:

   Word needs more memory to be able to undo this operation.
   Do you want to continue?

8. Choose the Yes button. The EMBED field is deleted or unlinked.

Microsoft has confirmed this to be a problem in versions 2.0, 2.0a, 
2.0a-CD, 2.0b, 2.0c  of Word for Windows. We are researching this 
problem and will post new information here as it becomes available.

"Microsoft Word for Windows User's Guide," version 2.0, pages 694-695

Additional reference words: 2.00 2.00a 2.00a-cd  w4wfield
errmsg err msg



Infinite Loop Spell Checking "RE: Testt" Using Grammar Checker
Article ID: Q88372
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------
Summary:

In Microsoft Word for Windows, if you type the text string "RE: Testt"
in response to a FILLIN or ASK field prompt and a pound sign (#) is
directly to the right of the field, when you run the Grammar command
with the Spelling Errors check box selected, the string "Testt#" is
flagged as a misspelled word. If you choose the Ignore All button,
Word for Windows becomes caught in a hanging loop; you must press
CTRL+ALT+DEL to exit this loop.

Microsoft has confirmed this to be a problem in versions 2.0,
2.0a,and 2.0a-CD of Word for Windows. This problem was corrected in
Word for Windows version 6.0. 

More Information:

This problem does not occur if you choose the Add button or the Change
button. Also, if you delete the text "RE:" or the pound sign, the loop
does not occur. You can also avoid this problem by clearing the
Spelling Errors check box in the Customize Grammar Settings dialog
box.

Note: The spelling checker in Word for Windows, which is activated by
choosing Spelling from the Tools menu, does not cause this problem.

Steps to Reproduce Problem
--------------------------

1. From the Insert menu, choose Field. Under Insert Field Type, select
   Fill-in, type a prompt, and choose the OK button.

2. Select the FILLIN field and press F9 to update the field. In the
   dialog box, type "RE: Testt" (without the quotation marks), and choose
   the OK button.

3. Type "#" (without the quotation marks) immediately after the FILLIN
   field. The field should appear as follows:

      {fillin "Enter Text"}#

   Note: If you clear the View Field Codes command, the line appears as
   follows:

      RE: Testt#

4. From the Tools menu, choose Options. Under Category, select



   Grammar, then choose the Customize Settings button. Under Grammar,
   select the Spelling Errors check box, then choose the OK button.

5. From the Tools menu, choose Grammar. When the grammar checker flags
   "Testt#," choose the Ignore All button.

"Microsoft Word for Windows User's Guide for version 2.0", pages
284-286, 472-475, 484-486, 648, 651-652, 752

Additional reference words:  w4wproof 2.00 2.00a 2.00a-CD speller hang 
hangs crash hung stop stops w4wfield locks lock locked reboot soft boot
infinite



Setting Up Different First Header/Footer for Even/Odd Pages
Article ID: Q88404
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In a Microsoft Word for Windows document containing different even/odd
header or footer formatting, you can create a different first header
or first footer that automatically determines whether the page number
is even or odd and then inserts the appropriate first header or first
footer.

More Information:

When you select the Different First Page check box, Word for Windows
not only sets up a different first header, but also sets up a
different first footer. If it is necessary to maintain the appropriate
even or odd footer on the first page of the section, but that page
could be either even or odd, insert the following field in the first
footer:

   {if {=mod({page},2)} = "1" "->->Page {page}" "Page {page}"}

   Note: In this example, "->" represents a TAB character.

The MOD function divides the current page number by two and then tests
to determine if the remainder equals one. If the remainder equals one,
the page is odd; if the remainder does not equal one, it equals zero
(0), which means the page is even. If the page is odd, the odd page
footer is inserted (in the above example, it is two tabs, then the
word "Page" and a PAGE field); if the page is even, the even footer is
inserted (in the above example, it is the word "Page" and a PAGE field
aligned at the left margin).

For example, suppose you have a document for which you want to create
different even and odd headers and footers. However, you want the
header (but not the footer) on the first page of each section to be
blank, similar to the following:

   Odd page, first page
   of section with             Even page with
   footer, but no header       header and footer
   __________________          ___________________
  |                  |        |                   |
  |                  |        | Header            |
  |                  |        |                   |
  |                  |        |                   |
  |                  |        |                   |
  |                  |        |                   |



  |                  |        |                   |
  |                  |        |                   |
  |                  |        |                   |
  |                  |        |                   |
  |       Page {page}|        | Page {page}       |
  |__________________|        |___________________|

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 579-582,
639-641

"Microsoft Word for Windows User's Reference," version 1.x, pages
95-96, 97-98, 103, 147-149

Additional reference words: w4wfield 1.00 1.10 1.10a 2.00 2.00a  6.00
2.00a-CD 2.00b 2.00c wm_word



WinWord: Bookmarked SEQ Field Returns Incorrect Value
Article ID: Q88592
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a, and
   2.0a-CD, 2.0b 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

When you select a sequence (SEQ) field in a Microsoft Word for Windows
document and apply a bookmark to it, the bookmark references the
previous SEQ field or returns the value of the bookmarked field minus
one if your selection also includes text to the left of the SEQ field.

If you apply a bookmark to a SEQ field, be sure to select only the SEQ
field without selecting any text to the left of the field.

This problem was corrected in Word version 6.0 for Windows. To obtain 
new or updated Microsoft products, call Microsoft Consumer Sales at 
(800) 426-9400. If you are outside the United States, contact the 
Microsoft subsidiary for your area. To locate your subsidiary, call 
Microsoft International Customer Service at (206) 936-8661.
More Information:

Steps to Reproduce Problem
--------------------------

1. Create a new Word for Windows document. From the View menu, choose
   Field Codes if that command is not chosen.

2. Type the following:

      Chapter 1{SEQ chapter \h}
      Chapter 2{SEQ chapter \h}

   Note: Create the field braces by pressing CTRL+F9. The \h switch
   formats the field as hidden text.

3. Select the first SEQ field. Make sure that you do not select any
   text or spaces before the field.

4. From the Insert menu, choose Bookmark. Under Bookmark Name, type
   "chapt1" (without the quotation marks). Choose the OK button.

5. Select the second SEQ field and include the number "2" in your
   selection.

6. From the Insert menu, choose Bookmark. Under Bookmark Name, type
   "chapt2" (without the quotation marks), then choose the OK button.

7. Insert the following fields in your document to reference the SEQ
   fields you typed in step 1:



      {SEQ chapter chapt1}
      {SEQ chapter chapt2}

8. From the Edit menu, choose Select All. Press F9 to update fields.

9. From the View menu, choose Field Codes to clear this command.

Notice that the result of both SEQ fields is 1. Word for Windows
returns "1" as the value of the chapt2 bookmark because the bookmark
includes text to the left of the SEQ field.

Reference(s):

"Running Word for Windows Version 2," by Russell Borland, page 181

Additional reference words: w4wfield
2.00 2.00a 2.00a-CD 2.00b 2.00c 1.00 1.10 1.10a



How to Use Wildcards to Perform Selective Print Merge
Article ID: Q88679
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you can use the asterisk (*) and the
question mark (?) wildcard characters as part of a selective print
merge operation. These wildcards function in Word for Windows similar
to the way they function in Microsoft MS-DOS (that is, they act as a
substitute for a letter, number, or string).

MORE INFORMATION
================

The asterisk (*) wildcard character represents a whole word or a group
of characters, regardless of length. For example, "D*" (without the
quotation marks) represents any group of characters that begins with
the letter D, regardless of the length of the string. And, "*D"
represents any group of characters that ends with the letter D,
regardless of its length.

Note: You cannot search for a string that both begins with an asterisk
and ends with an asterisk; therefore, "*D*" is an invalid selection
criteria.

The question mark (?) wildcard represents a single character. For
example, "?D" represents any string that contains one character before
the letter D, such as "ID." And, "?D?" represents any string with one
character before and one character after the letter D, such as "IDE."

While the asterisk (*) wildcard character can successfully merge data
that begins with numbers, the question mark (?) wildcard character
cannot. For example, you could use "98*" during a print merge, but not
"98???".

Using Wildcards to Perform Selective Print Merge
------------------------------------------------

Note: In the following samples, create the field braces by pressing
CTRL+F9.

 - To select records whose First_Name merge field begins with "D", use
   the following syntax in your print merge main document:

      {if {First_Name}="D*" "{First_Name}"}

 - To select records whose First_Name merge field ends with "D":



      {if {First_Name}="*D" "{First_Name}"}

 - To selectively merge those records whose First_Name merge field
   begins with "D" and contain four characters:

      {if {First_Name}="D???" "{First_Name}"}

Note: In a Word for Windows print merge operation, the characters
inside the quotation marks are case sensitive. In the above examples,
records whose First_Name merge field contains "D" would be found,
whereas records whose First_Name merge field contains "d" would not be
found.

For information on using wildcards to perform a selective print merge
in which a numeric character follows the wildcard, query on the
following words in the Microsoft Knowledge Base:

   numeric and w4wmerge and wildcard and incorrect

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 637-644

"Microsoft MS-DOS User's Guide and Reference," version 5.0, pages 73-75

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD wild
card cards w4wmerge w4wfield pmh helper conditional



SYMBOL Field May Not Print If Character Spacing is Condensed
Article ID: Q89284
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, and 2.0b
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you choose Symbol from the Insert
menu and select a font other than Normal Text in the Symbols From box,
the symbol does not print if you apply condensed spacing character
formatting to it. Similarly, if you choose Bullets And Numbering from
the Tools menu and choose the New Bullet button, symbols from a font
set other than Normal Text do not print if they contain condensed
spacing character formatting.

Symbols from the Normal Text font set print correctly when you apply
condensed spacing character formatting.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Workarounds
-----------

 - Select the SYMBOL field that contains condensed spacing character
   formatting. From the Format menu, choose Character. In the Spacing
   box, select Normal, then choose the OK button.

  -or-

 - Insert the symbol using the ANSI character code and then format the
   character for the appropriate font. For example, to insert a 
   Microsoft Windows symbol, choose Character from the Format menu, 
   select WingDings in the Font box, and choose the OK button. Press 
   ALT+Keypad 0255 to create the Microsoft Windows symbol. If you apply 
   condensed spacing character formatting to this symbol, created using 
   the ANSI character code instead of a SYMBOL field, the symbol prints 
   correctly.

Steps to Reproduce Problem
--------------------------

1. From the Insert menu, choose Symbol.

   -or-

   From the Tools menu, choose Bullets And Numbering. Select the Bullets
   option button and choose the New Bullet button.

2. In the Symbols From box, select any font except Normal Text.



3. Select any symbol and choose the OK button.

4. Select the symbol you inserted in step 3 above. From the Format
   menu, choose Character.

5. In the Spacing box, select Condensed, then choose the OK button.

6. Print the document. 

The symbol does not print.

Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
2.0a-CD, and 2.0b of Word for Windows. This problem was corrected in 
Word version 6.0 for Windows.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b w4wfield
w4wprint missing blank printer



Word: Print Merge Does Not Include Tables or Graphics
Article ID: Q89314
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When you perform a print merge in Word for Windows, any table or
linked graphic that is the result of a conditional IF field is not
displayed in the resulting merged documents. To use tables or linked
graphics as the result of a conditional print merge statement, use the
appropriate method below.

This functionality was changed in Word version 6.0 for Windows.

Merging the Table or Graphic Directly
-------------------------------------

Use this method when you want to print only the table or graphic.

Define a glossary entry that contains the table or linked
graphic, then conditionally merge one of two glossaries.

1. Select the table you want to merge and choose Glossary from the
   Edit menu. Type "table" (or another appropriate name, without the
   quotation marks) as the glossary name and choose the Define button.

2. Select the text or field that you want to merge if the condition is
   false. Choose Glossary from the Edit menu. Type "false" (or another
   appropriate name, without the quotation marks) as the glossary name
   and choose the Define button.

3. Insert a field with the following syntax:

      {GLOSSARY {IF <CONDITION><OP>"<CONDITION>" "TRUE GLOSSARY NAME"
      "FALSE GLOSSARY NAME"}}

      For example:

      {GLOSSARY {IF {MERGEFIELD EMPLOYEES}>="100" "TABLE" "FALSE"}}

4. Select the field and press the F9 key before you perform the print
   merge the first time (it should only be necessary to update the
   field only once).

   Note: You must have a glossary defined for the false result or the
   error message

      Error! No glossary entry specified



   will appear in place of the field when you merge. If you want no
   result when the condition is false, define some hidden text as your
   false glossary (be sure you do not include a paragraph mark in the
   glossary entry).

Merging a Document That Contains a Table or Graphic
---------------------------------------------------

Use this method when the table or graphic is part of another document
you insert using an INCLUDE field.

Page 643 of the "Microsoft Word for Windows User's Guide" gives
instructions for including a document during a print merge. If the
included document contains tables and/or graphics, they do not display
in the resulting merged documents when you follow these instructions.

If you reverse the order of the nested fields so the IF conditional
field is nested within the INCLUDE field, Word for Windows displays
the tables and graphics correctly.

A field with the following syntax will allow Word to evaluate a
condition and include one of two documents. Either document may
contain tables or graphics.

   {INCLUDE {if <CONDITION><OP>"<CONDITION>" "TRUE FILENAME" "FALSE
   FILENAME"}}

Note: You must specify a file for Word to include, even when the
condition is false. If no file is specified for Word to import when
the condition is false, the following error message prints on the form
letter:

   Error! Filename Not Specified

The following are examples of the fields for versions 2.x and versions
1.x  of Word for Windows.

Word for Windows versions 2.0, 2.0a, 2.0a-CD, and 2.0b
------------------------------------------------------

   {INCLUDE {IF {MERGEFIELD order}>"100" "C:\\DIRNAME\\LETTER1.DOC"
   "C:\\DIRNAME\\LETTER2.DOC"}}

Using this field, Word for Windows includes the text in LETTER1.DOC if
the amount in the data field "order" is more than 100. If the amount
of the order is less than 100, Word will include LETTER2.DOC. Any
table or graphic in LETTER1.DOC or LETTER2.DOC will be correctly
displayed in the resulting merged documents.

Word for Windows versions 1.0, 1.1, and 1.1a
--------------------------------------------

   {INCLUDE {IF {REF order}>"100" C:\\DIRNAME\\LETTER1.DOC
   C:\\DIRNAME\\LETTER2.DOC}}

Reference(s):



"Microsoft Word for Windows User's Guide," version 2.0, pages 268-271,
639-645

Additional reference words: docerr 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD
w4wtable 2.00b w4wmerge w4wfield missing



Creating All Odd- or All Even-Numbered Pages in a Document
Article ID: Q89348
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

To create all odd- or all even-numbered pages in a Microsoft Word for
Windows document (for example, 1,3,5,7... or 2,4,6,8...) use an
expression field ({=}) in conjunction with a PAGE field ({PAGE}).

More Information:

To create all odd-numbered pages, insert the following field in the
document header or footer:

   {={page} + {={page} - 1}}.

To create all even-numbered pages, insert the following field in the
document header or footer:

   {={page} + {page}}

Note: If you want to number each page in the same way throughout all
sections, add page numbers before you add section breaks. However, if
you've already added section breaks and want to add page numbers,
position the insertion point in the first section of the document and
then insert page numbers or the fields mentioned above.

Note: To create the braces "{}", press CTRL+F9.

For more information on using the expression field, search for
"Expression field" using the Help menu.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 306, 760

"Microsoft Word for Windows User's Reference," version 1.0, pages 95-
96

"Microsoft Word Technical Reference For Windows and OS/2," versions
1.0, pages 336-342

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c w4wfield wm_word



How to Apply Formatting to Results of Link to Excel Worksheet
Article ID: Q89395
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When you use a LINK field to insert a Microsoft Excel worksheet in
your Word for Windows document, you can apply formatting to the
Microsoft Excel worksheet values in Word by modifying the LINK field.

For example, if you want to apply currency formatting to linked
Microsoft Excel worksheet data, modify the LINK field as follows:

Original LINK field:

   {LINK ExcelWorksheet Sheet1 R1C1 \* mergeformat \r \a}

Becomes:

   {DDEAuto ExcelWorksheet C:\\EXCEL\\Sheet1.xls R1C1 \# $###.00 \*
   mergeformat \r \a}

Or becomes:

   {DDE ExcelWorksheet C:\\EXCEL\\Sheet1.xls R1C1 \# $###.00 \*
   mergeformat \r \a}

In the above example, the number "300" appears as "$300.00" in Word
for Windows. Other samples:

   3      appears as  $  3.00
   3.55   appears as  $  3.55
   333.4  appears as  $333.40

More Information:

For more information on the field-specific and numeric picture
switches used in the above example, see pages 760-762 of the
"Microsoft Word for Windows User's Guide."

To add the comma (,) as a thousands separator, modify the LINK field
as follows:

   {DDEAuto ExcelWorksheet C:\\EXCEL\\Sheet1.xls R1C1 \# $#,###.00 \*
   mergeformat \r \a}

Disadvantages to Using This Method
----------------------------------



1. The DDE and DDEAuto fields are supported in versions 2.0, 2.0a,
   2.0a-CD, and 2.0b of Word for Windows to provide backwards
   compatibility with earlier versions of Word for Windows. These
   fields may not be available in future versions of Word for Windows.

2. The DDEAuto field causes Word for Windows to prompt you to update
   each link every time you open the document. For each link you choose
   to update, a separate instance of Microsoft Excel is launched. This 
   is normal behavior in versions 1.x of Word for Windows. The LINK 
   field in versions 2.x, and 6.0 of Word for Windows prompts you
   once to update all the links (if the LINK field is formatted with the
   \a switch).

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 682-690,
760-762

Additional reference words: w4wfield 1.00 1.10 1.10a 2.00  6.00
2.00a 2.00a-CD 2.00b 2.00c wm_word



WinWord: How to Use Dates as Print Merge Selection Criteria
Article ID: Q89532
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you can perform a selective print merge
based on a list of dates. You can selectively print merge based on
such criteria as a group of months, days of months, years or
combinations of all three. For example, you can perform a selective
print merge based on a list of names and birthdates.

In addition, you can instruct Word for Windows to change the date
format of data in the merged document.

MORE INFORMATION
================

To use the selective merge function:

1. Set up the data document. For example:

      FRIENDS,BIRTHDATE
      Raquel Tejeda,10-5-1940
      Norma Jean Baker,6/1/1926
      Marion Michael Morrison,5/26/1907

   Note: You can use either backslashes or dashes in the dates. If
   your data document is formatted as a table, you can also spell out
   the date (for example, "June 1, 1926").

2. Set up the main document:

   a. {if {MERGEFIELD Birthdate \@ "MMMM"}="October" "{MERGEFIELD
      Friends} {MERGEFIELD Birthdate \@ "MMMM d, yyyy"}"}

      This example merges records for people born in October. The
      Birthdate field is formatted as "October 5, 1940", regardless
      of the data format of the data document (October 5, 1940, or
      10/5/1940, or 10/5/40).

   b. {if {MERGEFIELD Birthdate \@ "MM"}="10" "{MERGEFIELD Friends}
      {MERGEFIELD Birthdate}"}

      This example works the same as example a, except that the Birthdate
      prints exactly as it appears in the data document.

   c. {if {MERGEFIELD Birthdate \@ "yy"}="40" "{MERGEFIELD Friends}



      {MERGEFIELD Birthdate \@ "MM dd, yy"}"}

      This example merges records for people born in 1940. The Birthdate
      field is formatted as "10/5/40."

   d. {if {MERGEFIELD Birthdate \@ " yyyy"}="October 5, 1940"
      "{MERGEFIELD Friends} {MERGEFIELD Birthdate \@ "d-MMM-yy"}"}

      Same result as example 3 above, except that the Birthdate prints in
      "5-October-40" format.

   e. {if {MERGEFIELD Birthdate \@ "MMMM d, yyyy"}="October 5, 1940"
      "{MERGEFIELD Friends} {MERGEFIELD Birthdate}"}

      Merges only the records of people born on October 5, 1940.

The above examples do not illustrate all possible selective merge
combinations or date formats. To view all possible DATE field
switches, choose field from the Insert menu. In the Insert Field Type
box, select Date. All the possible date switch combinations appear in
the Instructions box.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 609-656,
751

Additional reference words: 6.00 2.00 2.00a 2.00a-CD 2.00b w4wfield wm_word 
w4wmerge conditional pmh



WinWord: FILLIN Fields in Header Updated at Print or in Views
Article ID: Q89863
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

By design, Word for Windows updates FILLIN fields located in the
header or footer when you print a document, print merge a document to
the printer or to a new document, or switch to print preview or page
layout view. These fields are updated even if the Update Fields check
box is cleared in the Tools Options Print dialog box.

Workaround
----------

To work around this problem, use an ASK field instead of a FILLIN
field to insert text in your header or footer. Insert the ASK field in
the body of the document. In the header or footer, insert a field
reference to the ASK field bookmark. An ASK field prompts you for
information when you update the field, but it is not automatically
updated when you print the document (unless you select the Update
Fields check box in the Tools Options Print dialog box).

To place information in the header with an ASK field:

1. In the body of your document, type:

      {ASK bookmark_name "Text to appear in InputBox"}

   Note: To create field brackets ({}), press CTRL+F9. These ASK
   fields are not visible when you print your document.

2. From the View menu, choose Header/Footer (in versions 1.0, 1.1 or
   1.1a of Word for Windows, choose Header/Footer from the Edit menu).
   Select Header and choose the OK button. In the header window,
   insert the following field:

      {ref bookmark_name}

3. On the header option bar, choose the Close button.

4. Select the entire document and update the fields by pressing the F9
   key. When the ASK field prompts you for information, type the
   appropriate text and choose the OK button.

5. From the File menu, choose Print. The bookmark text appears in your
   document header.

Reference(s):



"Microsoft Word for Windows User's Guide," version 2.0, pages 475-478

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 
6.00 wm_word 
w4wfield w4wprint 3.00 3.10



WinWord: Use of ASK and FILLIN Fields and \o Switch
Article ID: Q90010
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:
 
This article discusses the following issues regarding the use of ASK
and FILLIN fields in a Word for Windows print merge operation:
 
 - Using the \o switch to cause Word to prompt you only once for
   input.
 
 - Choosing the Cancel button or pressing ESC when prompted for ASK or
   FILLIN input.
 
 - How to print the results of ASK and FILLIN fields while suppressing
   blank lines in your merged documents.
 
More Information:
 
ASK Field
---------
 
The ASK field prompts you to type text, which it assigns to a bookmark
name. During a print merge, the ASK field prompts you for input before
printing each merged document, which allows you to customize each
merged document. The ASK field itself has no result; the result is
assigned to the bookmark. You must insert a separate field to
reference the bookmarked information you typed in response to the ASK
prompt. Example:
 
   {ASK BookmarkName "Message Text"}{REF BookmarkName}
 
In this example, the ASK field prompts you for input, which it assigns
to the bookmark named BookmarkName. The REF field inserts the input in
your merged document.
 
FILLIN Field
------------
 
The FILLIN field prompts you for text that is used as the FILLIN field
result. During a print merge, the FILLIN field prompts you for input
before printing each merged document, which allows you to customize
each merged document.
 
Using the \o Switch
-------------------
 
When you add the \o switch to a Word for Windows FILLIN or ASK field,



Word for Windows prompts for input only once, before printing the
first document during a print merge, rather than once for each print
merge document. Word for Windows uses the same information in each
merged document. Examples:
 
   {FILLIN "Batch Number" \o}
   {ASK BookmarkName "Message Text" \o}{REF BookmarkName}
 
What Happens When You Choose the Cancel Button or Press ESC?
------------------------------------------------------------
 
If you previously typed something in the ASK or FILLIN field dialog
box, that text remains in the dialog box for the next prompt. If you
choose the Cancel button (or, in Word for Windows version 2.0, press
the ESC key) to skip an ASK field, Word uses the previously-typed text
as the current value of the ASK field bookmark.
 
Note: In versions 1.0, 1.1, or 1.1a of Word for Windows, if you press
ESC in an ASK or FILLIN field dialog box, the print merge stops.
 
Canceling an ASK or FILLIN field dialog box only cancels the prompt
for input; it does NOT delete the previously-typed input. If you don't
want any value assigned to a FILLIN field or to an ASK field bookmark,
you must press the DEL key to delete the previously-typed text, and
then choose the OK button. In Word version 6.0, a space must be
inserted to create blank results
 
ASK and FILLIN Field Results Don't Print If You Suppress Blank Lines
--------------------------------------------------------------------
 
In versions 2.0, 2.0a, 2.0a-CD, and 2.0b of Word for Windows, the
result of a FILLIN field or ASK field bookmark is not inserted in your
merged document if you check the Skip Completely option under
Treatment of Blank Lines Caused by Empty Fields in the Print Merge
dialog box. In other words, suppression of blank lines by the Word for
Windows Print Merge Helper cancels the result of an ASK or FILLIN
field.
 
Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
2.0a-CD, and 2.0b of Word for Windows. We are researching this problem
and will post new information here as it becomes available.
 
Workarounds
-----------
 
 - If you are not concerned with blank lines appearing in your merged
   documents, select the Print Blank Lines option in the Print Merge
   dialog box.
 
   -or-
 
 - If you want to suppress the printing of blank lines, insert a
   conditional IF statement. When you perform the print merge, select 
   the Print Blank Lines option in the Print Merge dialog box. In the 
   example below, a blank link resulting from an empty {company} field 
   is suppressed with the following instructions:
 



   {MERGEFIELD name}
   {IF {company}<>"" "{company}[SHIFT+ENTER]
   "}{FILLIN "Batch Number" \o}
 
Note: Press SHIFT+ENTER to create a newline character. Do not type
"[SHIFT+ENTER]" in the field. Press CTRL+F9 to create the field
brackets.
 
For more information on ASK and FILLIN fields:
 
 - Search for "fields: print merge", "ask field", or "fillin field"
   using the Help menu in version 2.0 of Word for Windows.
 
Reference(s):
 
"Microsoft Word for Windows User's Guide," version 2.0, pages 646-651
 
Additional reference words: w4wmerge w4wfield 1.00 1.10 1.10a 2.00
2.00a 2.00a-CD 2.00b pmh missing appear data 6.0 wm_word



Changing Excel Link Type Resets Table Alignment Formatting
Article ID: Q90506
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, and 2.0b
 - Microsoft Windows operating system versions 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

In a Word for Windows document that contains a link to a Microsoft Excel
spreadsheet, if you change the link type from manual to automatic (or from
automatic to manual), any alignment formatting you apply in Word for
Windows to the linked object will be lost.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

This loss of alignment formatting occurs regardless of the other settings
in the Links dialog box and regardless of the field switches in the LINK
field. For example, a \* mergeformat switch in the LINK field will keep you
from losing alignment formatting applied to the Microsoft Excel spreadsheet
in Word.

The reason the alignment is lost when you change the link in the Links
dialog box is because Word actually deletes the existing LINK field, then
creates a new one with or without the "\a" switch depending on whether you
are changing from auto to manual or the other way around.

WORKAROUND
==========

1. From the View menu, choose Field Codes.

2. Manually edit the LINK field to Excel to change it from manual to
   automatic as follows:

   - Manual to automatic: Add \a to the LINK field before the \r.

   - Automatic to manual: Remove the \a from the LINK field.



Steps to Reproduce Problem
--------------------------

1. In Microsoft Excel, open or create a spreadsheet.

2. Select the spreadsheet. From the Edit menu, choose Copy.

3. Switch to Word for Windows. From the Edit menu, choose Paste
   Special.

4. In the Paste Special dialog box, under Data Type, select Formatted
   Text. Choose the Paste Link button.

5. Select the linked spreadsheet. From the Table menu, choose Row
   Height. Select Center Alignment and choose the OK button. Note that
   the spreadsheet is now centered on the line.

6. With the spreadsheet selected, choose Paragraph from the Format
   menu. Select Center Alignment and choose the OK button. Note that
   the text is centered in the table cells.

7. From the Edit menu, choose Links. Select the Excel link. Select the
   Automatic option if Manual is currently selected; select the Manual
   option if Automatic is currently selected. Choose the OK button.
   Notice that the alignment formatting for the table and for the text
   in each cell is reset to the original format.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b w4wfield 3.00
3.10



WinWord: Changing Page Numbering Format in "Page of Pages"
Article ID: Q90693
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------
 
Summary:
 
In Microsoft Word for Windows, the format "Page of Pages" is not 
available as a field option.
 
To simulate a "Page of Pages" field:
 
1. Place the insertion point where you would like the "Page of Pages"
   format to appear.

2. From the Insert menu, choose Field (ALT, I, D).

3. In the Insert Field Type list, select Page. (Type "p" on the
   keyboard to jump to the fields beginning with "p.")

4. Type the word "of" (without the quotation marks and with a space
   before and after it).

5. From the Insert menu, choose Field (ALT, I, D).

6. In the Insert Field Type list, select No. Of Page.
 
   Appear on Screen: {page} of {numpages}
 
Note: If you know the field name, you can use Insert Field (CTRL+F9)
and type the field codes directly into your document.
 
More Information:
 
Both fields, NUMPAGES and PAGE, default to Arabic numbers. You can
select other styles from the Page Number Format dialog box available
when you select Page Numbers from the Insert menu of the Word for
Windows toolbar. Or you can enter a page number field code and use
these switches:
 
      ENTRY                                        STYLE
---------------------------------------------------------------------
RESULT
{page} of {numpages}                           Default     "1 of 3"

{page \*roman} of {numpages \*roman}           Lowercase   "i of iii"

{page \*Roman} of {numpages \*Roman}           Uppercase   "I of III"

{page \*alphabetic} of {numpages \*alphabetic} Lowercase   "a of c"



{page \*Alphabetic} of {numpages \*Alphabetic} Uppercase   "A of C"
 
Reference(s):
 
"Microsoft Word for Windows User's Reference," version 1.x, page 113

"Microsoft Word for Windows User's Guide," version 2.0, pages 427, 751
Additional reference words: w4wfield 1.00 1.10 1.10a 2.00 2.00a 6.00
2.00a-CD 2.00b 2.00c wm_word



Err Msg: Number Cannot Be Represented in Specified Format
Article ID: Q91156
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you format an EQ field using an
ORDTEXT (ordinal text), CARDTEXT (cardinal text), or DOLLARTEXT
(dollar text with fraction) switch, the following error message occurs
when the field result is zero (0):

   Error! Number cannot be represented in specified format.

This problem was corrected in Word version 6.0 for Windows. To obtain 
new or updated Microsoft products, call Microsoft Consumer Sales at 
(800) 426-9400. If you are outside the United States, contact the 
Microsoft subsidiary for your area. To locate your subsidiary, call 
Microsoft International Customer Service at (206) 936-8661.

This error message does not occur in versions 1.0, 1.1, and 1.1a of
Word for Windows.

More Information:

For more information on the ORDTEXT, CARDTEXT, and DOLLARTEXT
number-formatting switches, including examples, choose Help Index from
the Help menu and choose the Search button. Type "switches" (without
the quotation marks) in the Search dialog box and choose the Show
Topics button. Select General Switches and choose the Go To button. In
the General Switches window, choose the Format (\*) jump text.

Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
2.0a-CD, and 2.0b of Word for Windows. This problem was corrected in
Word version 6.0 for Windows.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 756

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b w4wfield
errmsg err msg equation formula



Format Print Merge Output with Switches or MERGEFIELD Keyword
Article ID: Q91210
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you can format the results of a
MERGEFIELD field by applying character formatting to the MERGEFIELD
keyword. You can also format MERGEFIELD field results using a general
format switch (\*). General switch formatting overrides direct
formatting you apply to the MERGEFIELD field.

No menu command for initial letter capitalization or lowercase
character formatting exists in Word for Windows; therefore, you must
apply these formats using the FIRSTCAP and LOWER general switches.

More Information:

Print Merge Character Case Switches
-----------------------------------

             Syntax: {MERGEFIELD name \* upper}

             Syntax: {MERGEFIELD name \* lower}

             field.
             Syntax: {MERGEFIELD name \* firstcap}

             Syntax: {MERGEFIELD name \* caps}

Documentation Error
-------------------

Neither page 628 nor page 762 of the "Microsoft Word for Windows
User's Guide" describes the need to use the FIRSTCAP and LOWER general
formatting switches to apply these character formats to MERGEFIELD
output.

For more information on general switches, search for "Switches" using
the Help menu.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 628, 643,
762

"Microsoft Word for Windows User's Reference," version 1.x, pages
111-113



Additional reference words: w4wfont w4wfield pmh  6.00
docerr doc err print wm_word 2.00 2.00a 2.00a-CD 2.00b 2.00c 



How to Send Printer Escape Codes from a WinWord Document
Article ID: Q93658
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

In Word for Windows, you can use one of the following methods to send
an instruction, or printer escape sequence, to your printer:

 - Insert a PRINT field in your document that contains the printer 
   escape codes. Example:

      {PRINT "<printer instructions>"}

-or-

 - Type the printer escape sequence in your document and format it for a
   printer font.

MORE INFORMATION
================

There are limitations and drawbacks to each of the above methods,
depending on which printer driver you use. Neither method is guaranteed
to work on every printer.

Limitations of the PRINT Field
------------------------------

When you insert a PRINT field, Word calls an escape in the printer
driver that sends the printer instruction text to the printer. If the
escape in the printer driver malfunctions, the PRINT field may produce
incorrect or no results.

  Note: The PRINT field does not affect your page layout because Word
  treats a PRINT field as nonprinting characters.

Limitations of Typing Printer Information Directly in Your Document
-------------------------------------------------------------------

When you type printer information directly in your document, Word treats
the escape sequence text as normal text. This means that Word 
incorporates
the text in your document page layout.

When you print the document, the printer interprets the escape sequence
text as printer instructions and does not print it. Your printer may
misinterpret the escape sequence if Word does not send the entire string



contiguously. For example, if you apply justified paragraph formatting,
Word sends other characters to adjust the line length, thereby changing
the escape sequence string.

For information on the PRINT field, search for Print Field using the 
Help menu in version 2.0 of Word for Windows.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.x, page 104

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 1.00 1.10 
6.00 wm_word 1.10a w4wfield w4wprint



Word: FILLIN Field Is Limited to 255 Characters
Article ID: Q93706
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

The Word for Windows FILLIN field prompts you for text that is used as 
the FILLIN field result. The maximum number of characters that can be 
entered in a FILLIN field is 255.

To allow the user to type more than 255 characters, you can use the
WordBasic InputBox$ command.

MORE INFORMATION
================

The InputBox$ command displays a dialog box requesting a single item of
data and returns the text entered in the dialog box when the user 
chooses the OK button.

The syntax is as follows

   a$ = InputBox$(Prompt$ [,Title$] [,Default$])

where:

   Prompt$  is the text displayed in the dialog box.

   Title$   is the title displayed in the title bar of the dialog box;
            if omitted, Word uses the title "Microsoft Word".

   Default$ is the default text proposed in the text box of the dialog
            box.

The InputBox$ command in the following macro assigns the text you enter 
to the "a$" variable. The EditGoTo command is used to move the insertion 
point to a defined bookmark name before inserting the contents of the a$
variable.

Sub MAIN
a$ = InputBox$("Type text")
EditGoTo "bookmark"
Insert a$
End Sub

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 6.00
2.00b 2.00c w4wmacro w4wfield InputBox$ wm_word



Embedded Object Opens in MS Draw from Merged Document
Article ID: Q93734
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

If your print merge main document contains an embedded object, Word for
Windows unlinks the EMBED field and inserts the field result in the merged
document as a graphic image. As a result, if you double-click the image in
the merged document, Word launches Microsoft Draw instead of the original
server application.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wmerge
w4wfield ole equation editor art graph chart client linking embedding



Extra Minus Signs (-) in Front of Negative Field Result
Article ID: Q94338
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, and 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

If you use a thousands separator in a numeric picture switch and the result
is a negative number with three or fewer digits, Word for Windows places
two or three minus signs (-) in front of the number instead of one. This
happens when the field result contains fewer digits than the numeric
picture switch describes.

This problem was corrected in Word version 6.0 for Windows.

More Information:

In the following sample field, Word displays the result correctly if it is
a positive number or if it contains four or more digits. By contrast, Word
displays the result incorrectly, as shown, if the result is negative and
contains three or fewer digits:

   {=sum ([r1c1:r2c2])\# #,##0}

   Note: \# is the numeric picture switch and #,##0 is the number
   picture that includes a thousands separator (,).

If the result is        Word displays result as
---------------------------------------------------

        5996                 5,996    (correct)
       -5996                -5,996    (correct)
         103                   103    (correct)
        -103                - -103    (incorrect)
         -82               - - -82    (incorrect)
          -9              - - - -9    (incorrect)

Workaround
----------

Use the "\# ,0"  numeric picture switch instead. This switch formats
field results correctly regardless of the number of digits in the
result. In the above example, change the field to the following:

   {=sum ([r1c1:r2c2])\# ,0}

For more information on the numeric picture switch, search for
"switches" using the Help menu in version 2.0 of Word for Windows.

Reference(s):



"Microsoft Word for Windows User's Reference," version 1.x, pages 114-
117

Additional reference words: w4wfield alignment misalign too many extra
space spaces hyphen 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Template Field Code Does Not Display "NORMAL.DOT" Template
Article ID: Q94404
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, and 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

The result of the TEMPLATE field is blank (null) if your Word for Windows
document is based on the NORMAL template (NORMAL.DOT).

This problem was corrected in Word version 6.0 for Windows.

More Information:

When your document is based on the NORMAL template, the TEMPLATE field
result is blank regardless of whether the NORMAL.DOT file exists on your
hard disk.

Workaround
----------

The following field displays "NORMAL.DOT" (without the quotation marks) if
your document is based on the NORMAL template. If your document is not
based on NORMAL.DOT, the field displays the name of whichever template your
document is based on.

   {IF {TEMPLATE} <> "" "{TEMPLATE}" "NORMAL.DOT"}

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 490

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c w4wfield attached attach nothing



EQ Field Codes for Foreign Language Characters: Norwegian
Article ID: Q94742
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

You can insert foreign language characters and punctuation in a Word
for Windows document using any of the four methods listed below. This
article provides an extensive list of EQ and SYMBOL fields you can use
to create Norwegian language characters.

MORE INFORMATION
================

Method 1: Choose the Symbol command from the Insert menu.
---------------------------------------------------------

Use this method to insert available symbols. To access a different set
of symbols, select a different font in the Symbols From box.

Method 2: Insert the ANSI character code.
-----------------------------------------

Use this method to insert available symbols. To enter an extended ANSI
character, hold down the ALT key, and type the four-digit ANSI
character code on the numeric keypad with NUM LOCK turned on.

Method 3: Change the international settings.
--------------------------------------------

You can use the International option in Windows Control Panel to
change the Country, Language, and Keyboard Layout settings to those of
a different language. For information on these settings, see the
Control Panel section in "Microsoft Windows User's Guide." For
pictures of international keyboard layouts, see pages 623-630 in
"Microsoft MS-DOS User's Guide and Reference," version 5.0.

Use this method when you type many foreign characters and need to type
them in other applications as well. This method changes the characters
that display when you press the keys on your keyboard.

Method 4: Insert EQ or SYMBOL fields.
-------------------------------------

Use this method if the character you need does not appear in the
Insert Symbol dialog box and if you only occasionally need to type
foreign words.



The following table lists the SYMBOL or EQ fields you can use to
create Norwegian language characters. These fields use a 10-point
Courier New font. If you use a different font or size, you may need to
modify the field contents.

For more information on EQ fields, see the "Using EQ, or Formula,
Fields to Produce Mathematical Formulas" application note. To obtain
this application note, call Microsoft Product Support Services at
(206) 454-2030.

Note: Neither the user's guide nor Help contains information on the
use of EQ fields in version 2.0 of Word for Windows. However, the
documentation on the use of EQ fields in the user's reference for Word
versions 1.x applies to Word version 2.0 as well.

Norwegian Language Characters
-----------------------------

Illustration    Description                   Field Code
-----------------------------------------------------------
A ring          Uppercase A, ring (volle)     {symbol 0197}
a ring          Lowercase A, ring (volle)     {symbol 0229}
AE              Uppercase AE, ligature        {symbol 0198}
ae              Lowercase AE, ligature        {symbol 0230}
O/              Uppercase O, slash            {symbol 0216}
o/              Lowercase O, slash            {symbol 0248}

REFERENCES
==========

"Microsoft MS-DOS User's Guide and Reference," version 5.0, pages 623-
630

"Microsoft Windows User's Guide," version 3.1, pages 169-171

"Microsoft Windows User's Guide," version 3.0, pages 181-182

"Chicago Manual of Style," Thirteenth Edition, The University of
Chicago Press, 1982

"Microsoft Word for Windows User's Guide," version 2.0, pages 153,
265, 268

"Microsoft Word for Windows User's Reference," version 1.x, page 135

Additional reference words:  w4wfont w4wfield 6.00 wm_word 
WD0522 Norway
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Cannot Insert Clipboard Contents Using ^c in Edit Replace
Article ID: Q94880
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

The following error message occurs if you try to insert the contents
of the Windows Clipboard in a Word for Windows document using the Edit
Replace command when the Clipboard contains a TC field that is nested
in an XE field:

   Word cannot read the formatting in this document.

To replace the search text with contents of the Clipboard, choose
Replace from the Edit menu, and type "^c" (without the quotation
marks) in the Replace With box.

More Information:

This problem does not occur with other nested field combinations.

Workaround
----------

1. Use the Find command from the Edit menu to locate the search text.

2. Close the Find dialog box.

3. From the Edit menu, choose Paste to insert the contents of the
   Clipboard.

Steps to Reproduce Problem
--------------------------

1. In a Word document, insert the following field:

      {XE "Index"{TC "Table of Contents Entry"}}

     Note: Press CTRL+F9 to create the curly field brackets ({}).

2. Press ENTER to insert a paragraph mark.

3. Type "YYY" (without the quotation marks).

4. Select the field you inserted in step 1 above.

5. From the Edit menu, choose Copy.

6. From the Edit menu, choose Replace.



7. Type "YYY" (without the quotation marks) in the Find What box.

8. Type "^c" (without the quotation marks) in the Replace With box.

9. Choose the Replace All button. The "Word cannot read the formatting
   in this document" error message occurs. Choose the OK button.

Result: Word inserts the XE field but not the TC field, as follows:

   {XE "Index"}

We are researching this problem and will post new information here in
the Microsoft Knowledge Base as it becomes available.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 260-266

Additional reference words: w4wfield  errmsg err msg 2.00
2.00a 2.00a-CD 2.00b 2.00c 6.00 wm_word



Newline Character Appears As Pipe Character (|) in Dialog Box
Article ID: Q95093
----------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------
 
Summary:
 
When you open a document in version 2.0 of Word for Windows that you
created in version 1.x of Word for Windows, the lines of multiple-line
default text in a FILLIN or ASK field dialog box appear on the same
line, separated by a pipe character (|).
 
The FILLIN or ASK field results print and appear correctly in your
document, with the newline character as the separator.
 
The pipe character also occurs in place of a newline character in
multiple-line entries in the Summary Info dialog box.
 
To change the appearance of the dialog box, delete the pipe
characters. In their place, type SHIFT+ENTER to insert a newline
character.

This problem was corrected in Word version 6.0 for Windows.

Steps to Reproduce Problem
--------------------------

1. Create a document in Word version 1.x that contains a FILLIN
field.

2. Select the FILLIN field and press F9 to update the field.

3. In the FILLIN dialog box, type at least two lines of text.

4. Save the file and exit Word version 1.x.

5. Launch Word version 2.0 and open the file you saved in step 4
above.

6. Select the FILLIN field and press F9 to update the field.

Result: The text in the FILLIN dialog box appears with a pipe (|)
character between the two lines. The text does not wrap to a second
line. However, the FILLIN field result displays correctly in the
document.

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c w4wfield



Index Entry Text Truncated Following Tab Character
Article ID: Q95654
--------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========
 
In Microsoft Word for Windows, the Index Entry command on the Insert
menu truncates text that follows a tab of a index entry. For example,
if you select the following text in your document, only the first word
will appear in the Index Entry dialog box:
 
 John <tab> Smith
 
The word "John" appears in the Index Entry dialog box, but the word
"Smith" is not included.

STATUS
======
 
Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.
 
To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================
 
The following macro allows you to create an index entry from a text
selection that includes a tab character. To use this macro, select the
index entry text in your document and run the macro. The macro creates
an index entry field, {XE}, to the right of the selected text. The
index entry includes the selected text and the tab character. The
resulting index takes on the tabs position defined for the index
styles (Index 1-7).
 
Index Entry Macro
-----------------
 
Sub MAIN
EditCopy
CharRight 1
InsertFieldChars
Insert "XE " + Chr$(34)



EditPaste
Insert Chr$(34)
CharRight 1
End Sub
 
Index entries are formatted as hidden text. To edit or view these
entries in Word 2.x for Windows, choose Options from the Tools menu
and select the View category. Under Nonprinting Characters, select the
All or the Hidden Text check box. In Word 1.x for Windows, change the
view options by choosing Preferences from the View menu.
 
Additional reference words: 1.00 1.10 1.10a 2.00 2.0a 2.0b 2.0c incomplete
xe w4wfield entries w4wmacro



EQ, AUTONUM, and SYMBOL Fields Are Blank in Print Merge
Article ID: Q95658
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When you use an EQ, AUTONUM, or a SYMBOL field in a print merge data
document, this field is printed as a blank space in your Word for
Windows merged document.

These fields are printed as blank spaces because when Word performs a
print merge operation it unlinks the fields and places only the result
in the merged documents. Since Word cannot unlink an EQ, AUTONUM, or a
SYMBOL field, it cannot place a result in the merged document; the
missing result appears as a blank space.

Similarly, if you nest a SYMBOL field in an IF field, as in the
following example, the SYMBOL field does not display or print in a
print merge:

   {IF {MERGEFIELD CODE} <> "" "{SYMBOL 183 \f "Symbol"} {MERGEFIELD
   CODE}"}

This problem was corrected in Word version 6.0 for Windows

Workarounds
-----------

For SYMBOL fields:

Instead of inserting a SYMBOL field, create the symbol by pressing
ALT+NNNN (where NNNN is the ANSI character code of the symbol).

For AUTONUM fields:

Instead of using an AUTONUM, AUTONUMLGL, or AUTONUMOUT field, renumber
the paragraphs using one of the options in the Numbered List dialog
box of the Bullets And Numbering command (located on the Tools menu).

For EQ (Equation) fields:

Use the Microsoft Equation Editor to insert the equation as an EMBED
field; the EMBED field will continue to be displayed even after it is
unlinked during a print merge operation.

More Information:

The EQ, AUTONUM, and SYMBOL fields are in a class of fields called
display fields. The result of such fields depends on the presence of



the field. You cannot unlink such fields from their result, so Word
inserts a blank space in place of the result when it unlinks the field
during a print merge operation.

Note: You cannot unlink an EQ, AUTONUM or a SYMBOL field by pressing
CTRL+SHIFT+F9.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wmerge
w4wfield



Using Expression Fields to Manipulate Page Numbering
Article ID: Q95886
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
This article describes how you can use the Expression field and the
Sum function in conjunction with the PAGE field to manipulate page
numbering in the following ways:
 
 - Return the current page number plus 1 (or more)
 
 - Return the number of pages in the document minus a specified number
 
 - Number the document in reverse order
 
More Information:
 
Return the Current Page Number Plus 1 (or More)
-----------------------------------------------
 
The Expression field below adds 1 to the current page number to
return the number of the next page in your document. You can use this
field in your header or footer to instruct the reader to "Continue
reading on page x" (where x is the result of the Expression field).
 
   {={PAGE}+1}
 
Return the Number of Pages in the Document Minus a Specified Number
-------------------------------------------------------------------
 
The following Expression field subtracts a specified number (x) from
the total number of pages in your document and displays the result:
 
   {={NUMPAGES}-x}
 
For example, if {NUMPAGES} returns 10 as the total number of pages in
the document, {={NUMPAGES}-3} returns 7.
 
Number the Document in Reverse Order
------------------------------------
 
You can insert the Expression field below in the header or footer to
number the pages in your document in reverse order. This method works
if your document is numbered continuously, starting at 1; it does
not work if page numbering in your document is not continuous or does
not start at 1.
 
   {={NUMPAGES}-{PAGE}}



 
Reference(s):
 
Word version 2.0 for Windows Help menu, Field Types and Instructions
section, Expression and Numpages topics.
 
"Microsoft Word for Windows User's Reference," pages 95-96, 103
 
Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c w4wfield equal calculate calculation plus difference



Macro to Remove Document Index Field Entries
Article ID: Q95986
Summary:

-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c 
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

This article contains a macro that deletes all your Word document's
index entries before you convert the document to a text format.

Index entries are converted to plain text when you save a document to
the Microsoft Write or Text With Layout file formats. As a result,
there may be repeated words within the document text.

This problem was corrected in Word version 6.0 for Windows.

To workaround this problem, run the following macro to find and delete
all XE entries. After running the macro, choose Save As from the File
menu, and save a copy of the document in Windows Write, Text With
Layout, or DOS Text With Layout file format.

Sub MAIN
StartOfDocument
ViewFieldCodes 1
EditFindClearFormatting
EditFind "^19XE", .Direction = 2
While EditFindFound()
EditCut
EditFind "^19XE", .Direction = 2
Wend
End Sub

More Information:

Index entries are inserted in Word for Windows as fields formatted as
hidden text. When viewing field codes, the index entry fields
appear as follows:

   {XE "Index Entry Text"}

If you save a Word document in Text With Layout or Windows Write
format, the index entry text is converted as document text. For
example, the following portion of a Word document

   Environmental Concerns {XE "The Environment"}

converts in Text With Layout or Windows Write format as:

   Environmental Concerns The Environment



The above macro removes the index entries from your document so that
the XE fields are not converted to straight document text.

WARNING: ANY USE BY YOU OF THE CODE PROVIDED IN THIS ARTICLE IS AT
YOUR OWN RISK. Microsoft provides this macro code "as is" without
warranty of any kind, either express or implied, including but not
limited to the implied warranties of merchantability and/or fitness
for a particular purpose.

Reference(s):

"Using WordBasic," by WexTech Systems and Microsoft, page 180-182

Additional reference words: w4wmacro w4wfield xe index appsconv text
with layout write 2.00 2.00a 2.00a-CD 2.00b 2.00c 



Numeric Format Switch for Thousands Separator and Dollar Sign
Article ID: Q96049
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

Use the following numeric format switch to format a numeric result
with commas as thousands separators and the currency symbol (such as
$) adjacent to the first number:

   {\# $,0.00}

Examples:

   This field                  Yields this result
   ----------------------------------------------

   {=3190321 \# $,0.00}        $3,190,321.00

   {=43217 \# $,0.00}          $43,217.00

For more information on numeric format switches in Word version 2.0,
use the Field Types and Instructions section of the Help menu and
select the General Switches jump text.

Reference(s):

"Microsoft Word for Windows User's Reference," version 1.x, pages
114-117, 364

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 
6.00 2.00c w4wfield wm_word



SYMBOL Field Affects Word Wrapping and Nonbreaking Characters
Article ID: Q96076
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.1

-------------------------------------------------------------------

Summary:

If you use Symbol command from the Insert menu to place a symbol
character in your document, one of the following problems may result:

 - A symbol character inserted next to a nonbreaking space or
   nonbreaking hyphen may prevent the nonbreaking space or hyphen
   from working as expected.

   -or-

 - A symbol character inserted as part of a word (for example,
   a copyright symbol) may prevent the word from wrapping correctly.
 
To avoid this problem, insert a symbol using ANSI characters rather
than using the Insert Symbol command or by inserting a SYMBOL field.
See the "Workarounds" section below for more information.

More Information:

A nonbreaking space (CTRL+SHIFT+SPACEBAR) prevents a line break
between two words, as in the example "2 ft." A nonbreaking hyphen
(CTRL+SHIFT+HYPHEN) prevents a line break in a hyphenated word, as in
the example "232-3432." However, neither character works as expected
when you insert an adjacent symbol using the Insert Symbol command
because this command inserts a field code rather than ANSI characters.

Similarly, words that contain a SYMBOL field may not wrap correctly.
For example, if you use the Insert Symbol command to insert a
copyright symbol at the end of a word, the copyright symbol may wrap,
but the word itself may not. If you insert a SYMBOL field adjacent to
a footnote reference, Word breaks the line between the text or
footnote reference and the SYMBOL field.

Workarounds
-----------

 - From the Insert menu, choose Symbol, select Normal Text in the
   Symbol From box and then select a symbol from this character set.
   When you insert a symbol from the Normal Text character set, Word
   inserts the symbol character but does not insert a SYMBOL field.

   -or-



 - Insert the symbol using the Windows version 3.1 Character Map (found
   in Windows Program Manager Accessories group).

   -or-

 - Insert the symbol using ANSI characters. With NUM LOCK on, hold
   down the ALT key, and using the keys on the numeric keypad, type 0
   (zero) and the ANSI decimal code for the character you want to
   insert. (You may need to first change character formatting to the
   font that contains the symbol character, such as Symbol or
   Wingdings.)

   To determine the ANSI character code for the symbol:
   ----------------------------------------------------

   1. Be sure the Field Codes command on the View menu has a check
      mark so that all fields show their codes. (If this command does
      not have a check mark, choose Field Codes to switch to field
      code view.)

   2. Insert a symbol using the Insert Symbol command. Note the number
      and font in the SYMBOL field. (Then, delete the field.)

      In the following example, the ANSI character code is 149 and
      the font is Wingdings:

         {SYMBOL 149 \f "Wingdings"}

   You can also determine the ANSI character code by using the Windows
   version 3.1 Character Map (found in Windows Program Manager
   Accessories group). Select the symbol you want and look in the
   Keystroke box in the lower right corner for the ANSI code and the
   Font box in the upper left corner for the name of the font.
Microsoft has confirmed this to be a problem in Microsoft Word
versions 2.0, 2.0a, 2.0a-CD, 2.0b, 2.0c, 6.0. We are researching this
problem and will post new information here in the Microsoft Knowledge
Base as it becomes available.

For more information on using the nonbreaking space and nonbreaking
hyphen characters in Word for Windows, query on the following words in
the Microsoft Knowledge Base:

   symbol and line and wrap

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 91,
153-155

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wfield 
6.00 wm_word 
early wrong place incorrect fixed 2.00 w4wfont non breaking 
non-breaking



Data File Character Formatting Not Retained in Merged Document
Article ID: Q96247
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
In Word for Windows, if a print merge data document contains text with
different character formatting, that text may appear incorrectly in
the merged document. This happens because text merged from the data
file takes on the formatting you apply to the corresponding field in
the main document. As a result, the format of the MERGEFIELD field in
the main document overrides any formatting you applied in the data
document.
 
For example, if you insert a trademark symbol in your data document by
pressing ALT+0226 and formatting the character for the Symbol font,
Word replaces the Symbol font character formatting with that of the
MERGEFIELD field in the main document when you perform the print merge
operation. In the merged document, an accented uppercase A character
appears instead of the trademark symbol (if the MERGEFIELD field is
formatted with a font other than Symbol).
 
Workaround
----------
 
For the data field that contains special character formatting, insert
a REF field in your main document instead of a MERGEFIELD field. For
example, in place of the following MERGEFIELD field
 
   {MERGEFIELD FIELDNAME}
 
insert the following REF field instead:
 
   {REF FIELDNAME}
 
Word retains the data document formatting for the results of the REF
field, which preserves the special character formatting.
 
The drawback to this workaround is that the print merge helper does
not detect errors or suppress blank lines for this field. If you use
this workaround, you must suppress blank lines and resolve any print
merge errors manually for the REF field.
 
For information on suppressing blank lines when not using MERGEFIELD
fields, query on the following words in the Microsoft Knowledge Base:
 
   winword and suppress and blank and line and 1.1
 
Reference(s):



 
"Microsoft Word for Windows User's Guide," version 2.0, pages 153,
628-656
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wfield
monotype sorts symbol wingdings dingbats zapfdingbats w4wmerge changes
changed 6.00 wm_word



Lowercase Roman Numeral Page Numbers Are Uppercase in TOC
Article ID: Q96744
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
If you apply All Caps or Small Caps character formatting to the table
of contents (TOC) style, Word for Windows changes lowercase Roman
numeral and alphabetic page numbers to uppercase page numbers in the
table of contents.
 
For example, if your Word document contains lowercase Roman numeral
(i, ii, iii) page numbers and your TOC 1 style contains All Caps
character formatting, Word capitalizes the page number in the table of
contents, as shown below:
 
   IN THE ROSE GARDEN                                   I
 
Instead, the table of contents should appear as follows:
 
   IN THE ROSE GARDEN                                   i
 
This problem was corrected in Word version 6.0 for Windows.

Workaround
----------
 
Note: This workaround does not work for Small Caps character
formatting. For Small Caps, you must manually format the TOC text.

Use the following workaround to create a table of contents with All
Caps character formatting when your document contains lowercase Roman
numeral or alphabetic page numbers:
 
1. Remove the All Caps character formatting from your TOC styles.
 
2. In the document, insert TOC Entry (TC) fields in your document to
   identify text as table of contents entries. Type the TC entry text
   in uppercase letters, or select the text and press SHIFT+F3 to
   change the case to uppercase.

   The following is a sample TC field:
 
      {TC "IN THE ROSE GARDEN"}

   Note: Do not apply All Caps character formatting to the TC field
   text because, when you create the TOC, the TOC style removes All Caps
   character formatting.
 



3. When you create the table of contents by choosing Table Of Contents
   from the Insert menu, select the Use Table Entry Fields option 
button.
 
Reference(s):
 
"Microsoft Word for Windows User's Guide," version 2.0, pages 558-559
 
"Microsoft Word for Windows User's Reference," versions 1.x, pages 358,
360, 373
 
Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c w4wfield capital capitalized capitalizes upper lower case switch



TOC Field Incorrectly Includes Hidden AUTONUM Field
Article ID: Q96864
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

If you create a table of contents (TOC) by selecting the Use Heading
Paragraphs option in the Table Of Contents dialog box (from the Insert
menu, choose the Table Of Contents command), Word for Windows includes
lines for hidden heading paragraphs if those paragraphs are preceded
by a hidden AUTONUM field.

This problem was corrected in Word version 6.0 for Windows.

More Information:

For example, when you update a document similar to the following

   {toc /o}
   {autonum}. heading #1
   {autonum}. heading #2   <this line is formatted as hidden text>
   {autonum}. heading #3

the TOC field will generate the following table of contents:

   1. heading #1............................................1
   2........................................................1
   3. heading #3............................................1

Workaround
----------

To work around this problem, if your document contains paragraphs with
hidden headings, number paragraphs with the SEQ fields instead of
AUTONUM fields. To do this, replace AUTONUM fields with the following
SEQ field in paragraphs formatted with the Heading 1 style:

   {SEQ h1}

In paragraphs formatted with the Heading 2 style, replace AUTONUM
fields with the following SEQ field

   {SEQ h2}

and so on. After you finish editing your document, update all the SEQ
fields and the TOC field.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wfield





How to Cross Reference Sequence Fields
Article ID: Q96944
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

This article describes how to create a cross-reference to a SEQ
(sequence) field in Word for Windows 2.0. The article also describes two
methods that do not work and shows why you should not use them to
create cross-references to SEQ fields.

Note: although the following methods can be used in Word 6.0, the
interface for creating numbered items and cross-references to them has 
been substantially changed. For more information on this process in Word 
6.0, see chapter 19 of the user's manual, or look in Help under Caption or 
Cross-Reference.

More Information:

To create a cross-reference to a SEQ field:

1. Select the SEQ field to which you want to create a cross-reference.

   IMPORTANT: Be sure you do not select any characters before or after
   the field. For example, select the following SEQ field, but do not
   include "Table " in the selection:

      Field                         Result
      -----                         ------

      Table {SEQ table}             Table 1

2. Insert a bookmark. For example, insert a bookmark named "CrossRef"
   (without the quotation marks). For information on inserting
   bookmarks, see page 741 of the "Microsoft Word for Windows User's
   Guide."

3. Position the insertion point where you want the cross-reference to
   appear.

4. Insert a SEQ field and include the Bookmark argument. To reference
   the SEQ field in the above example, insert the following SEQ field:

      Field                               Result
      -----                               ------

      Table {SEQ table CrossRef}          Table 1

For more information on SEQ field syntax, see the Sequence topic in



the Field Types and Instructions section of the Help menu.

Examples of the WRONG Ways to Create a Cross-Reference
======================================================

Do Not use the REF Field to Create a Cross-Reference to the SEQ Field
---------------------------------------------------------------------

Page 744 of "Microsoft Word for Windows User's Guide," incorrectly
describes a method where you use a REF field to create a
cross-reference to a SEQ field; if you use this method, Word inserts a
copy of the SEQ field. In other words, the REF field behaves as if you
inserted another SEQ field, thereby incrementing the sequence. As a
result, the REF field lists a nonexistent cross reference, and
subsequent SEQ fields are incorrectly incremented (that is, the result
of subsequent SEQ fields is one number too large). The following
example illustrates this behavior:

   Field                                 Result
   -----                                 ------

   Table {SEQ table}                     Table 1
   Table {SEQ table} --> Add the         Table 2
                         CrossRef
                         bookmark to
                         this field
   Table {SEQ table}                     Table 3
   Table {SEQ table}                     Table 4

   See Table {REF CrossRef}              See Table 5 --> Increments
                                                         sequence

   Table {SEQ table}                     Table 6     --> Should be 5
   Table {SEQ table}                     Table 7     --> Should be 6

If you lock the result of the REF field, the cross-reference is
correct, but Word increments the sequence anyway, so subsequent SEQ
fields are incorrectly incremented (the result of subsequent SEQ
fields is one number too large). The following example illustrates
this behavior:

   Field                                 Result
   -----                                 ------

   Table {SEQ table}                     Table 1
   Table {SEQ table} --> Add the         Table 2
                         CrossRef
                         bookmark to
                         this field
   Table {SEQ table}                     Table 3
   Table {SEQ table}                     Table 4

   See Table {REF CrossRef \!}           See Table 2 --> Correct
                                                         result

   Table {SEQ table}                     Table 6     --> Should be 5
   Table {SEQ table}                     Table 7     --> Should be 6



Incorrect Results If You Add Bookmark Name to Text and SEQ Field
----------------------------------------------------------------

There is a documentation error in the the Sequence topic in the Field
Types and Instructions section of the Help menu. The first sentence in
the following paragraph is misleading because it implies that you
should select the item you want to cross-reference instead of or in
addition to the SEQ field for that item:

   Cross-references
   ----------------

   To create an automatic cross-reference to an item you've labeled
   with a SEQ field, you assign a bookmark name to the item and then
   include that bookmark name in a SEQ field where you want the cross-
   reference to appear. Suppose you want to refer to the table showing
   African sales. First, you add a bookmark name -- for example,
   african_sales -- to the SEQ field you've created for the table....

If you select the text before the SEQ field in addition to or instead
of the SEQ field, the cross-reference displays the result of the
previous SEQ field instead. This happens because Word includes
everything after the first SEQ field and before the second SEQ field
as part of the first sequence. For example, if you create a cross
reference to Table 2 by adding a bookmark to the second instance of
"Table {SEQ table}" below, the cross-reference lists "Table 1" (the
previous SEQ field) instead of "Table 2."

   Field                               Result
   -----                               ------

   Table {SEQ table}                   Table 1
   Table {SEQ table}                   Table 2
   <---bookmark---->

   Table {SEQ table CrossRef}          Table 1

To create a correct cross-reference, do not not select any text
preceding or following the SEQ field.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 562-564,
744

Additional reference words: w4wfield 2.00 2.00a 2.00a-CD 2.00b 2.00c
w4whelp 



Conditional Alphanumeric Merge May Yield Incorrect Results
Article ID: Q97484
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
A print merge operation may yield incorrect results if you use a
conditional statement to evaluate alphanumeric data when the first
character of the data is numeric. This happens because conditional
statements (IF fields) evaluate only the first two characters of a
numeric string.
 
More Information:
 
For example, using the sample data file below, the following
conditional statement incorrectly yields a true result for the first
and second records, although only the second record satisfies the
condition:
 
   {IF {MERGEFIELD TEST} = "1AB" "This is true"}
 
Note: The IF field evaluated only the first two characters (1A) of the
numeric string.
 
Sample Data File
----------------
 
   ---------------------------------
   |  Rec_Num  |   Name   |  Test  |
   ---------------------------------
   |     1     |John      |1AA     |
   ---------------------------------
   |     2     |Bill      |1AB     |
   ---------------------------------
   |     3     |Fred      |2AA     |
   ---------------------------------
   |     4     |George    |ABC     |
   ---------------------------------
 
Workaround
----------
 
Word version 2.0
----------------
 
If your alphanumeric data contains entries that begin with a numeric
character, use the print merge Record Selection feature to perform a
conditional merge of the data. By setting record selection rules, you
can merge only data records that meet the criteria you specify.



 
The disadvantage of this workaround is that you must perform multiple
print merge operations if your main document contains more than one
conditional statement for alphanumeric fields. In this case, you must
modify your main document for each condition, change the Record
Selection settings to evaluate each condition individually and then
perform a separate print merge operation. The functionality of the
Record Selection feature differs from that of an IF field, so you must
modify your print merge procedure accordingly.
 
For example, the following procedure uses the Record Selection feature
to perform a conditional print merge of the sample data file above.
This procedure replaces the following conditional statement:
 
   {IF {MERGEFIELD TEST} = "1AB" "This is true"}
 
1. Attach the data file to the main document and then activate the
   main document.
 
2. From the File menu, choose Print Merge, and then choose the Merge
   button.
 
3. Choose the Record Selection button.
 
4. From the Field Name list, select Test.
 
5. From the Is list, select Equal To.
 
6. In the Compared To box, type "1AB" (without the quotation marks)
   and then choose the Add Rule button. Choose the OK button.
 
7. Complete the print merge operation. For record 2, "This is true"
   should appear in the merged document.
 
Word version 1.x
----------------
 
1. Sort your data file based on the field that contains entries that
   begin with a numeric character.
 
2. Number your data records.
 
3. Insert a conditional field, such as IF or NEXTIF, to print merge
   the correct data records.
 
Reference(s):
 
"Microsoft Word for Windows User's Guide," version 2.0, pages 633-645

"Microsoft Word for Windows User's Reference," version 1.0, pages
197-199
 
Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c numbers strings w4wmerge w4wfield alphabetic 6.00 wm_word



"Bookmark Not Defined" Replaces Print Merge ASK Field Result
Article ID: Q97485
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
The following error message prints in place of bookmark information
 
   Error! Bookmark not defined.

if you define a bookmark in a print merge main document using an ASK
field and then perform a print merge operation in which you select the
Skip Completely option to suppress the printing of blank lines. Word
for Windows loses the bookmark and stops printing the bookmark
information in your merged document after the first occurrence of
blank line suppression. 

In other words, when Word suppresses the printing of a blank line, it
does not retain the ASK field results, so this information does not
print in subsequent merged records.  

This problem was corrected in Word version 6.0 for Windows.

Workaround
----------
 
Turn off the Skip Completely option in the Print Merge dialog box.
 
 -or-
 
Replace paragraph marks in your main document with newline characters
(press CTRL+ENTER).
 
Note: Both workarounds disable the suppression of blank lines.
 
Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
2.0a-CD, 2.0b, and 2.0c of Word for Windows. This problem was corrected
in Word version 6.0 for Windows.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wfield
w4wmerge errmsg err msg
 \*



Maximum Values for Field Format Switches
Article ID: Q97591
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
A field will produce the following result (error message)

   Error! Number Cannot be Represented in Specified Format

when the resulting value exceeds the maximum value for the field
formatting switch.

Below is a list of the maximum values each field formatting switch can
produce. If the maximum value is exceeded, the preceding error message
will appear as the field result.

   Switch Maximum
   ----------------------------
 
   \*alphabetic Values > 6,656.4999
 
   \*arabic Values > 2,147,483,647.4999

Note: Can produce the above error message or
incorrect results.
 

   \*cardtext Values > 999,999.4999
 
   \*dollartext Values > 999,999.99
 
   \*hex Values > 32,767.4999
 
   \*ordinal Values > 2,147,483,647.4999
 
   \*ordtext Values > 999,999.4999
 
   \*roman Values > 3,999
 
More Information:
 
Field format switches are used to format the result of a field.  For
example, the field {=99.99 \* dollartext} yields the following result:
 
   Ninety-nine and 99/100
 
For more information on field switches in Word for Windows 2.0, search
for "switches" using the Help menu.
 
Reference(s):



"Microsoft Word for Windows User's Reference," pages 112-114
 
Additional reference words: w4wfield limit limits limitation 6.00
limitations max exceed exceeds numeric 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c wm_word



Result of SEQ Field Is a Negative Number
Article ID: Q97729
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
The maximum positive number result of a SEQ (Sequence) field is 32,767
(2 to the 15th power). If the result of a SEQ field is greater than
32,767, Word for Windows displays the result as a negative number that
descends one increment for each number in the sequence. For example:

   If the SEQ field
   result should be     Word displays 
   ----------------------------------

   32,767  32,767
   32,768 -32,768
   32,769 -32,767
   32,770 -32,766
 
Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
2.0a-CD, 2.0b, 2.0c, 6.0 of Word for Windows. We are researching this
problem and will post new information here in the Microsoft Knowledge
Base as it becomes available.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c limit 6.00
w4wfield



SET Fields Within IF Field Evaluate Incorrectly
Article ID: Q97791
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
When you use an IF field to determine how to set a bookmark, and you
use SET fields inside the IF field, the bookmark being set always
evaluates as the second SET statement.
 
For example, these statements
 
     {ask gender "What is the person's gender?"}
-->  {if gender = f {set pronoun she}{set pronoun he}}
     {ref pronoun}
 
always show the bookmark "pronoun" as "he". This is because Word
evaluates fields from the inside out, and from left to right. It
evaluates the first SET statement, and the bookmark "pronoun" is set
to "she". It then evaluates the next SET field, and the bookmark
"pronoun" is reset to "he". When the IF instruction is carried out,
both the true bookmark and the false bookmark are "he".
 
More Information:
 
The correct way to use these fields together is to put the IF field
inside the SET field, as in the following example:
 
     {ask gender "What is the person's gender?"}
-->  {set pronoun {if gender = f "she" "he"}}
     {ref pronoun}
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wfield 
6.00 define assign wrong value incorrect wm_word



Second NUMWORDS Field Result Is Incorrect
Article ID: Q97797
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
When you use the NUMWORDS field in a document more than once, and
there are more than 10 words in the document, the first NUMWORDS field
shows the correct number of words in the document, and subsequent
NUMWORDS fields show results that are wrong. If there are 10 or fewer
words in the document, all NUMWORDS fields show the correct number of
words.
 
The actual number of words in a document is determined by choosing
Summary Info from the File menu, choosing Statistics, and choosing the
Update button.
 
By contrast, this problem does not occur with the NUMCHARS field
because the NUMCHARS value is never an estimate like NUMWORDS can be.
When you choose the Update button in the Statistics dialog box, Word
updates only the number of words, because of the number of characters
is always accurate.

This problem was corrected in Word version 6.0 for Windows.

Workaround
----------
 
Include the NUMWORDS field in a SET field, and use the REF field to
refer to it. In the following example, "words" is the name of the
bookmark established in the SET field:
 
1. Near the beginning of the document, insert this field:
 
      {set words {numwords}}
 
2. Where you want the number of words in the document to appear,
   insert this field:
 
      {ref words}
 
   You can use this field as many times as needed.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wfield
 



Page Numbering in "Page of Total Pages in Section" Format
Article ID: Q97861
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
This article describes how you can number the pages of a
section in the following format:
 
   <Page Number> of <Total Number of Pages in Section>
 
More Information:
 
This numbering sequence is implemented differently depending on the 
version of Word for Windows you are using.  Follow the directions 
corresponding to the correct version on your machine as follows:

Word for Windows, version 6.0
=============================

1. Place your cursor in the desired section of the document.

2. Go into the header or footer and insert the page number as you 
   normally would.  

3. Press the space bar and type "of", without the quotes, and press the 
   space bar again.

4. Go to the Insert menu and choose Field.  From the Field Name column 
   select SectionPages.

 
Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 2.0c
=========================================================
 
1. Select some text at the end of the last page of the section.
 
2. From the Insert menu, choose Bookmark.
 
3. Type a Bookmark Name and then choose the OK button.
 
4. In the header or footer for the section, insert the following
   fields and text:
 
      {PAGE} of {PAGEREF BookmarkName}
 
   For example, if your section contains 11 pages, the following
   appears in the header or footer on page 3:
 



      3 of 11
 
Word for Windows, Versions 1.x
==============================
 
In Word versions 1.x, there is a problem with the method described for
Word version 2.0 above. When you insert the PAGEREF field in the
header or footer, its result is the current page number instead of the
number of the page where the bookmark is located. As a result, you
must use the one of the following methods in Word versions 1.x:
 
Method 1: Lock the PAGEREF Field
--------------------------------
 
1. Perform steps 1 through 4 of the instructions for Word version 2.0
   above.
 
2. Select the PAGEREF field in the header or footer and update it by
   pressing F9.
 
3. Lock the PAGEREF field by pressing CTRL+F11 (or ALT+CTRL+F1).
 
   Note: If you later add pages to the section, you can update the
   PAGEREF field by doing the following:
 
   a. Unlock the PAGEREF field by selecting it and pressing
      SHIFT+CTRL+F11 (or ALT+SHIFT+CTRL+F1).
 
   b. Repeat steps 2 and 3 above.
 
Method 2: Use a SET Field
-------------------------
 
1. Select some text at the end of the last page of the section.
 
2. Insert a SET field that assigns a unique bookmark name to the page
   number of the last section. The following is the syntax of the SET
   field:
 
      {SET BookmarkName {PAGE}}
 
3. From the View menu, be sure the Page command has no check mark. If
   this command does have a check mark, choose Page to switch to
   Normal view.
 
4. From the Edit menu, choose Header/Footer.
 
5. Choose the Options button.
 
6. In the Start At box, type 1.
 
7. Change the Start At field to 1.
 
8. Select Header or Footer and then choose the OK button.
 
9. In the header/footer pane, insert the following fields and text:
 



      {PAGE} of {BookmarkName \* charformat}.
 
Reference(s):
 
"Microsoft Word for Windows User's Guide," version 2.0, pages 746, 749
 
"Microsoft Word for Windows User's Reference," pages 103-104, 107
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wfield
wrong incorrect wm_word 6.0



Err Msg in Place of REF Field Result: Bookmark Not Defined
Article ID: Q98895
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
If you type nothing in response to an ASK field prompt, Word for
Windows records a nul value, which may cause the following error
message to appear as the result of the REF field that references the
nul ASK field result in versions 2.0 and 1.0:
 
   Error! Bookmark not defined.

In version 6.0, the message is

  Error! Reference source not found.
 
This happens because you cannot assign a bookmark to a nul value. A
bookmark must represent a value, such as a selection or the insertion
point (the insertion point is not the same as a nul value).
 
Workaround 1
------------
 
To prevent the above error message from appearing, insert a SET field
before the ASK field, as shown in the example below. The SET field
assigns the insertion point, or no selection (""), to the bookmark
(instead of a nul value) so the error message does not occur.
 
   {SET address2 ""}{ASK address2 "What is the second line of
   the address?"}{ref address2}
 
This workaround assigns a blank value to the bookmark that Word can
insert if a different value is not later assigned using the ASK field.
 
Note: The \d (default) ASK field switch has no effect on this
workaround.
 
Workaround 2
------------
 
Insert an IF field that compares the reference to the ASK field
bookmark with a reference to an intentionally undefined bookmark. If
the bookmarks are the same (which means that both produce the "Error!
Bookmark not defined" error message), Word inserts an alternate
result.
 
Note: Be sure to choose a unique bookmark name as the intentionally
undefined bookmark. If this bookmark name is later assigned to a



value, the workaround fails.
 
In the following example, which illustrates this workaround, "xxxx" is
an undefined bookmark name. If the value of the mybkmark bookmark is
nul, Word inserts "No name given" as the result of the IF field.
 
   {ASK mybkmark "Type your name:"}
 
Insert the following IF field in place of the REF field that
references the ASK bookmark results:
 
   {IF {mybkmark} = {xxxx} "No name given" {mybkmark}}
 
Reference(s):
 
"User's Guide," version 2.0, pages 477-478, 640-644, 646-650
 
Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c 6.00 w4wfield errmsg err msg w4wmerge print merge wm_word



FILLIN Field Dialog Box Blank During Print Merge
Article ID: Q98897
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
When you use the FILLIN field in a print merge document to prompt for
information to print on each record, Word for Windows does not always
display what was typed in the previous FILLIN dialog box. This happens
if the Skip Completely option is selected in the Print Merge dialog
box and if Word skipped a blank line in the previous record. In other
words, when Word suppresses the printing of a blank line, it does not
retain the FILLIN field results, so this information does not appear
as the default response the next time the FILLIN dialog box appears.

This problem was corrected in Word version 6.0 for Windows. To
obtain new or updated Microsoft products, call Microsoft End User
Sales at (800) 426-9400. If you are outside the United States,
contact the Microsoft subsidiary for your area. To locate your
subsidiary,  call Microsoft International Customer Service at (206)
936-8661.
 
Workaround
----------
 
 - Use the \d switch in the FILLIN field, which displays the same
   default response each time instead of the response you typed in the
   previous FILLIN dialog box.
 
 -or-
 
 - Cancel the selection of the Skip Completely option in the Print
   Merge dialog box.
 
 -or-
 
 - Replace paragraph marks in your main document with newline characters
   (press CTRL+ENTER to create a newline character).
 
NOTE: The last two workarounds disable the suppression of blank lines.
 
Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
2.0a-CD, 2.0b, and 2.0c of Word for Windows. This problem was corrected in 
Word version 6.0 for Windows.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wfield
w4wmerge errmsg err msg error message



Missing Special Characters in Table of Contents
Article ID: Q99412
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========
 
Table of contents entries that contain special characters that you
created using equation fields will be generated with the special
characters missing.

For example, if you apply Heading 1 style to the following paragraph
on page 1

   Scandinavian Cities:  MALM{eq \o(O,/)} 

the entry will appear as follows in your table of contents:

   Scandinavian Cities:  MALM...........................Page 1

STATUS
======

Microsoft is researching this problem and will post new information
here in the Microsoft Knowledge Base as it becomes available.

Additional reference words: 2.00 2.0a 2.0a-cd 2.0b 2.0c omitted lost
gone deleted missing without w4wfield



IF Field Won't Display Table or Linked Graphic as Result
Article ID: Q99683
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
You cannot insert a table or a linked graphic into a Word document as
the result of an IF field that contains INCLUDE, IMPORT, or GLOSSARY
fields.
 
Workaround
----------
 
To display a linked graphic or a table as the result of a conditional
IF field, nest the IF field inside an INCLUDE, IMPORT, or GLOSSARY
field, so that the IF field updates first. For example, you could nest
the fields as follows:
 
   {INCLUDE {IF conditionalTest table.doc falseResult}}
 
More Information:
 
The following examples illustrate the problem that occurs when you try
to insert a linked graphic or table as the result of an INCLUDE,
IMPORT, or GLOSSARY field nested inside an IF field.
 
In the following examples, a table or a linked graphic is used as
results in an IF field. TABLE.DOC is a file that contains a table.
"Glossary table" is a glossary entry that contains a table.
PICTURE.WMF is a Windows metafile graphic. "Glossary picture" is a
glossary entry containing a linked graphic.
 
   {if conditionalTest {include TABLE.DOC} falseResult}
   {if conditionalTest {glossary table} falseResult}
   {if conditionalTest {import PICTURE.WMF} falseResult}
   {if conditionalTest {glossary picture} falseResult}
 
If conditionalTest is true in any of the above examples, the table or
picture will not display when you update the field. Any text above or
below the table in either TABLE.DOC or the table glossary will display
correctly. Any text above or below the graphic in the picture glossary
will display correctly. Embedded graphics and graphics that are not
linked will display correctly.
 
For more information on importing graphics as the result of a
conditional field, query on the following words in the Microsoft
Knowledge Base:
 
   importing and graphics and condition



 
Microsoft has confirmed this to be a problem in Word for Windows,
versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 2.0a-CD, 2.0b, 2.0c, 6.0. We are
researching this problem and will post new information here in the
Microsoft Knowledge Base as it becomes available.
 
Reference(s):
 
"Microsoft Word for Windows User's Reference," version 1.0, pages
97-99
 
Additional reference words: w4wtable w4wfield 1.00 1.10 1.10a 2.00 6.00 
wm_word 2.00a 2.00a-cd 2.00b 2.00c



Creating a Table of Contents That References Ranges of Pages
Article ID: Q103730
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
SUMMARY
=======
 
When Word for Windows builds a table of contents, Word lists the page
number on which the item starts. This article describes how you can
use TC fields to create a table of contents that lists the range of
pages for an item.
 
MORE INFORMATION
================
 
Use the following procedure for each table of contents entry that
references a range of pages:
 
1. Select the first word of the range you want to reference in your
   table of contents.
 
2. From the Insert menu, choose Bookmark.
 
3. Type an appropriate, unique name in the Bookmark Name box, such as
   "Chapter1," and then choose OK.
 
4. Position the insertion point at the end of the range.
 
5. Insert a TC field that references the bookmark you inserted at the
   beginning of the range in steps 2 and 3 above. Use the following
   syntax for this TC field
 
      {TC "<text> [TAB] {PAGEREF <BookmarkName>} - "}
 
   where <text> is the text you want to appear for this entry in the
   table of contents; [TAB] means to press TAB; and <BookmarkName> is
   the name of the bookmark you inserted in steps 2 and 3 above.
 
   Example:
 
      {TC "Chapter 1 [TAB] {PageRef Chapter1} - "}
 
   The above TC field appears as follows in the table of contents:
 
      Chapter 1.............................1-3
 
For more information, select the "TC" and "TOC" jump text in the Field
Types And Instructions section of online Help.
 



REFERENCES
==========
 
Word for Windows "User's Guide," version 2.0, pages 540, 557-562, 564
 
Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c w4wfield



Word Changes Alphabetic Chapter References to Numeric
Article ID: Q103731
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========
 
When you create a table of contents that contains alphabetically
numbered chapters, Word for Windows changes the chapter numbers to
their numeric format when you create a table of contents based on
heading paragraphs.
 
WORKAROUND
==========
 
To create a table of contents in which Word retains alphabetic chapter
numbers, select the Use Table Entry Fields option instead. Use the
following instructions to create the TC fields using SEQ (sequence)
fields to number the chapters:
 
NOTE: This method places the chapter information in individual TC
fields instead of the TOC field. As a result, number formatting
information is retained in the table of contents.
 
1. In your document, insert alphabetic chapter reference numbers using
   SEQ fields. For example, use the following field to number a series
   of appendix chapters:
 
      Appendix {SEQ Appendix \* Alphabetic}
 
   Result: Appendix A
 
2. Insert a TC field that references the SEQ field. For example,
   insert the following field after the SEQ field you added in step 1
   above:
 
      {TC "First Appendix [TAB] {SEQ appendix \c} - "}
 
   where [TAB] means to press the TAB key.
 
   Resulting table of contents entry:
 
      First Appendix.................................A-1
 
3. Position the insertion point where you want the table of contents
   to appear.
 
4. From the Insert menu, choose Table Of Contents.
 



5. Select the Use Table Entry Fields option and then choose OK. Word
   inserts the following field in your document:
 
      {TOC \f}
 
Notes
-----
 
 - The drawback to this workaround is that you must use TC fields
   throughout your document to create your table of contents. You
   cannot base your table of contents on heading paragraphs.
 
 - The tab character in the TC field is essential to the success of
   this method.
 
For more information, select the "General Switches," "TC," and "TOC"
jump text in the Field Types and Instructions section of online Help.
 
REFERENCES
==========
 
Word for Windows "User's Guide," version 2.0, pages 540, 557-562, 564
 
Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c w4wfield



Expression / Formula Field Functions
Article ID: Q105640
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

This article explains in detail the syntax and usage of the operators
and functions that are available to the Expression (Formula) field.

In Word version 6.0, the Expression field name was changed to Formula.
Also, the Formula field name was changed in version 6.0 to Equation.

   1.x, 2.x Field Name      6.0 Field Name
   -------------------      -------------
   = (Expression)           = (Formula)
   Eq (Formula)             Eq (Equation)

MORE INFORMATION
================

Operators
---------

If you combine several operators in one field, Word evaluates in the
following order:

1. %        Percent
2. ^        Exponentiation
3. * and /  Multiplication and division
4. + and -  Addition and subtraction

In formulas with more than one operator with the same priority, Word
evaluates the operators from left to right. Use parentheses if you
want to alter the order of evaluations.

   +   Addition           Syntax: {=x+y}

   -   Subtraction        Syntax: {=x-y}

                          NOTE: {=x--y} is the same as {=x+y}. An even
                          number of subtraction signs is equivalent to
                          one addition sign.

   *   Multiplication     Syntax: {=x*y}

   /   Division           Syntax: {=x/y}

   %   Percentage         Syntax: {=x%}



                                  {=25%} = .25
                                  {=200*25%} = 50

   ^   Powers and roots   Raise a number to another power
                          or find a root of a number.
                          Syntax: {=x^y}
                                  {=4^2} = 16  4 squared
                                  {=3^3} = 27  3 Cubed
                                  {=27^(1/3)} = 3  Cube root 27

   =    Is equal to

   <    Less than

   <=   Less than or equal to

   >    Greater than

   >=   Greater than or equal to

   <>   Not equal to

Table Column References
-----------------------

NOTE: n is used to indicate the row or column number.

   [RnCn]                    Cell in Row n, Column n.

   [Rn]                      All cells in Row n.

   [Cn]                      All cells in Column n.

   [R]                       Row that the formula is in, including the
                             current cell.

   [C]                       Column that the formula is in, including
                             the current cell.

   [RnCn:RnCn]               Range of all cells between the two cell
                             references.

   Bookmarkname  [RnCn]      Cell in table identified by bookmarkname.

   Bookmarkname  [RnCn:RnCn] Range of cells identified by
                             bookmarkname.

                             NOTE: Word for Windows version 6.0 uses
                             A1 reference types to refer to cells. It
                             does not use RnCn reference types.

   Bookmarkname  [D4]        Cell D4 in table identified by
                             bookmarkname.

   Bookmarkname  [D4:J17]    Range of cells identified by
                             bookmarkname.



   ABOVE, BELOW, LEFT, RIGHT can be used with the table functions
   (AVERAGE, COUNT, MAX, MIN, PRODUCT, SUM).

Functions
---------

Functions with () can take any number of arguments. If the arguments
have more than two digits, you must put a space in front of each.

There are five Boolean functions, which return a value of 1 (true) or
0 (false): NOT, OR, AND, FALSE, TRUE.

The following functions can refer to cells in a table: AVERAGE, MAX,
MIN, COUNT, PRODUCT, SUM.

   ABS(x)      Returns the absolute value of a number. The absolute
               value of a number is the number without its sign.

               {=ABS(3.5)} = 3.5
               {=ABS(-3.5)} = 3.5

   AND(x,y)    Returns "1" if both arguments are true. Returns "0" if
               both arguments are false. Mostly used with IF
               statements.

               {=AND(profits>1000, profits<2000)} = 1 when "profits"
               has been defined as $1,234. The same formula returns 0
               when profits has been defined as $2,234.

               {=IF(AND(profits>1000,profits<2000),13,15)} = 13 when
               profits has been defined as $1,234. The same formula
               returns "15" when profits has been defined as $2,234.

   AVERAGE()   Gives the average value of the numbers in the list.

               {=AVERAGE(10, 20, 60)} = 30 {=AVERAGE([RnCn],[RnCn])}

   COUNT()     Tells you how many items are in the list.

               {=COUNT(2, 5, 67, 1.38)} = 4
               {=COUNT([RnCn],[RnCn],[RnCn],[RnCn])}

   DEFINED(x)  Returns "1" (true) if x has been defined, "0" (false)
               if it has not.

               {=DEFINED(4/0)} = 0
               {=DEFINED(gross_income)} = 1 if gross_income exists and
               it evaluates without error.

   FALSE       Returns a 1 or a 0.

               {=FALSE} = 0
               {=IF(5=6,TRUE,FALSE)} = 0

   IF(x,y,z)   x can be a formula. The arguments y and z must be
               numbers, not text.



   INT(x)      Rounds x down to the nearest integer.

               {=INT(5.67)} = 5
               {=INT(-5.67)} = -6

   MAX()       Returns the largest value in the list.

               {=MAX(3, 4, 5)} = 5
               {=MAX([RnCn],[RnCn],[RnCn])}

   MIN()       Returns the smallest value in the list.

               {=MIN(3, 4, 5)} = 3
               {=MIN([RnCn],[RnCn],[RnCn])}

   MOD(x,y)    Returns the remainder (modulus) after x is divided by y.
               The result has the same sign as y. If the answer is 0,
               returns "0.0" (without quotation marks).

               {=MOD(4, 2)} = 0.0
               {=MOD(3, 2)} = 1
               {=MOD(-3, 2)} = 1
               {=MOD(3, -2)} = -1
               {=MOD(-3, -2)} = -1
               {=MOD(3.5, 2.7)} = 0.8

   NOT(x)      Returns the Boolean opposite of the result. Mostly used
               with IF formulas.

               {=NOT(1=1)} = 0
               {=NOT(1=5)} = 1
               If x is defined as 7, 7{=NOT(x>10)} = 1

   OR(x,y)     Returns "1" if one or both arguments are true. Returns
               "0" if both arguments are false. Generally used with IF
               formulas.

               {=OR(1+2=3, 2=4)} = 1
               {=OR(1+5=3, 2=4)} = 0

   PRODUCT()   Multiplies all the items in the list.

               {=PRODUCT(5,4,3)} = 60 {=PRODUCT(5,4,3,(1/2))} = 30
               {=PRODUCT([RnCn],[RnCn],[RnCn])}

   ROUND(x,y)  Rounds x to y digits. If y is greater than 0, then x is
               rounded down to y decimal places.

               If y is 0, x is rounded down to the nearest integer.

               If y is a negative number, x is rounded down to the
               left of the decimal point.

               {=ROUND(x,y)}
               {=ROUND(123.456, 2)} = 123.46
               {=ROUND(123.456, 1)} = 123.5



               {=ROUND(123.456, 0)} = 123
               {=ROUND(123.456, -0)} = 123
               {=ROUND(123.456, -1)} = 120
               {=ROUND(123.456, -2)} = 100
               {=ROUND(156.789, -2)} = 200

               y is zero. Rounds x to the nearest integer.
               {=ROUND(123.456, 0)} = 123

               y is positive. Rounds to y decimal places.
               {=ROUND(123.456, 2)} = 123.46
               {=ROUND(123.456, 1)} = 123.5

               y is negative. Rounds x to that number of places to the
               left of the decimal. Y must not be greater than 1
               minus the number of digits in x. "-1" rounds to the
               nearest tens place, "-2" rounds to the nearest hundreds
               place, "-3" rounds to the nearest thousands place.

               {=ROUND(123.456, -0)} = 123
               {=ROUND(123.456, -1)} = 120
               {=ROUND(123.456, -2)} = 100
               {=ROUND(156.789, -2)} = 200

   SIGN(x)     Determines whether a number is positive (returns 1) or
               negative (returns -1) or zero (returns 0). Mostly used
               with the IF field.

               {=SIGN(-25)} = -1
               {=SIGN(0)} = 0
               {=SIGN(456)} = 1

   SUM()       Adds the numbers in the list.

               {=SUM(5, 13, 2, 4, 6)} = 30 {=SUM(5, 13, -2, 4, -6)} = 14
               {=SUM([RnCn],[RnCn],[RnCn])}

   TRUE        Returns a 1 or a 0.

               {=TRUE} = 1

REFERENCES
==========

"Word for Windows and OS/2 Technical Reference" (blue book), pages
337-342

"Word for Windows Technical Reference" (brown book), pages 153-156

Word for Windows 2.0 Help, Index, Field Types and Instructions, Expression

"Hacker's Guide to Word for Windows," Woody Leonard and Vincent Chen,
Addison Wesley Publishing Company, 1993

Additional reference words: wm_word 1.00 1.10 1.00a 2.00 2.00a
2.00a-CD 2.00b 2.00c 6.00 w4wfield



How to Merge Conditional Number of Records to the Same Page
Article ID: Q105888
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

In Word for Windows, you can merge a conditional number of records to
the same page.

MORE INFORMATION
================

To merge a conditional number of records to the same page, use a
combination of SET, IF, and NEXTIF fields. For example, you could use
this method to merge all records with the same name to one page in the
merge and create a new page in the merge when a new name is
encountered in the data file.

The following example uses a data file with employee names (Employee)
and projects they are working on (Projects). The Check field is used
in the datafile to mark the last record of a particular name.

Sample Data File:

Employee     Project     Check
John Doe     4578j
John Doe     86785x
John Doe     543p          1
Jane Doe     87x
Jane Doe     89976m        1
Sam Smith    7897r
Sam Smith    857t
Sam Smith    78974x
Sam Smith    7868p         1

The main document should be set up as follows, with a copy of the
conditional statements equal to the maximum number of projects for
each employee (four in the above example):

Employee     Project
{MERGEFIELD Employee}     {MERGEFIELD Project}{set duplicate {if
{MERGEFIELD Check}="1" "off" "on"}}{nextif {mergefield check}=""}{if
{duplicate}="on" "P
t{MERGEFIELD Project}"}{set duplicate {if {MERGEFIELD Check}="1"
"off" "on"}}{nextif {mergefield check}=""}{if {duplicate}="on" "P
t{MERGEFIELD Project}"}{set duplicate {if {MERGEFIELD Check}="1"
"off" "on"}}{nextif {mergefield check}=""}{if {duplicate}="on" "P
t{MERGEFIELD Project}"}{set duplicate {if {MERGEFIELD Check}="1"



"off" "on"}}{nextif {mergefield check}=""}{if {duplicate}="on" "P
t{MERGEFIELD Project}"}

Where "P" represents a paragraph mark that would push the next Project
to a new line and "t" represents a tab character that would align the
next project under the previous project.

The resulting merge document would appear as follows:

Employee     Project
John Doe     4578j
             86785x
             5436435p
--- Page Break ---
Jane Doe     87x
             89976m
--- Page Break ---
Sam Smith    7897r
             857t
             78974x
             7868p

Additional reference words: w4wmerge w4wfield 1.00 1.10 1.10a 2.00
2.00a 2.00a-cd 2.00b 2.00c 6.00 wm_word



Error Referencing Bookmarked Heading 7 or Higher
Article ID: Q105889
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

When you update a reference to a bookmarked AUTONUMLGL field that is
formatted for the Heading 7, Heading 8, or Heading 9 style in Word
2.x, the following error will appear

   The document is too large for Word to handle.

and the system may lock, requiring you to reboot to exit the program.

This problem does not occur when you reference bookmarked AUTONUM or
AUTONUMOUT fields, or bookmarked AUTONUMLGL fields formatted with
Heading 6 style or lower.

STATUS
======

This problem does not occur in Word for Windows versions 1.x.

Microsoft has confirmed this to be a problem in Word for Windows
versions 2.x. This problem was corrected in Word version 6.0 for
Windows.

WORKAROUND
==========

When referencing bookmarked AUTONUMLGL fields that are formatted with
the Heading 7, Heading 8, or Heading 9 style, insert at least six
spaces after the second L in the AUTONUMLGL field before bookmarking
it so that the field appears as follows:

   {AUTONUMLGL      }

The added spaces in the field code will not affect the resulting
number and will prevent the error from occurring when you update a
field that references this bookmarked AUTONUMLGL field.

Additional reference words: 2.00 2.00a 2.00a-cd 2.00b 2.00c w4wfield
hang hung crash crashed locks locked frozen freezes crashing quit
quits stopped gpf gp fault



Blank Line Suppression When Using FILLIN field
Article ID: Q106652
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------

SUMMARY
=======

If you are using a FILLIN field in Word for Windows, and do not enter
any information into the FILLIN message box, the line in the document
that holds the field code will still exist (and will be blank). To
have the blank line suppressed if no information is entered in the
FILLIN field message box, use one of the two methods below.

Method 1
--------

1. Using the following example as a model, insert the following lines
   somewhere in your document, before the location where the
   information generated by the FILLIN fields will go. These lines
   assign FILLIN values to bookmarks. These bookmarks will be
   referenced later in the document where the information will
   actually appear.

      {set name "{fillin "enter name"}"}
      {set company "{fillin "enter company"}"}
      {set address "{fillin "enter address"}"}
 
2. Enter the following lines at the location in the document where you
   want the information to appear.

      {if name <> "" "{name}
      "}{if company <> "" "{company}
      "}{if address <> "" "{address}
      "}

Method 2
--------

The results of this method are identical to the results of Method 1.
The SET statements have been incorporated into the conditional
statements.

   {set name {fillin "enter name"}}{if name <> "" "{name}
   "}{set company {fillin "enter company"}}{if company <> "" "{company}
   "}{set address {fillin "enter address"}}{if address <> "" "{address}
   "}

When you select the whole document (choose Select All from the Edit menu)
and press F9 to update the fields, you will be prompted for each piece



of information. If you leave one or more of the pieces of information
blank, the line containing its FILLIN field will be suppressed.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 474 and 672

Additional reference words: 2.00 2.00a 6.00 2.00a-CD 2.00b 2.00c
2.00c-CD 6.00 w4wfield w4wmerge



Converting Files with Extended Characters in Filenames
Article ID: Q69559
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

The following information concerns converting/opening files in Word
for Windows that contain extended characters within the filename.

This functionality has changed in Word version 6.0 for Windows.

Opening a File with an Extended Character within the Filename
-------------------------------------------------------------

The following error will result when trying to convert a document to
Word for Windows if the filename contains an extended or high bit
character:

   Document name or path is not valid

It is possible to create a filename that contains non-ANSI extended
characters if it was created in a non-Windows application such as Word
for DOS. Such a file can be opened in Word for Windows only after the
extended characters are removed from the filename. This can be done by
renaming the file either at the DOS prompt or from within the
application in which the file was originally created.

Saving a File with an Extended Character within the Filename
------------------------------------------------------------

When saving a Word for Windows document that contains extended ANSI
characters in the filename to another file format, two files will be
created: one file that contains characters from the extended ANSI
character set and one that contains characters from IBM PC Extended
Character Set. To open the file in Word for Windows, select the
filename that contains the ANSI characters. To open the file in the
other application, such as Word for DOS, select the filename that
contains the non-ANSI characters.

Additional reference words: w4wformat
1.0 1.1 1.1a 1.00 1.10 1.10a  2.0 2.00
conv  high bit characters file name valid document name



WinWord: Cell Line Layout Lost When Converting Table to Text
Article ID: Q80598
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you convert a multicolumn table to
text, the layout will be lost if the table contains one or more cells
with text that wraps around to another line.

More Information:

In Word for Windows version 2.x and 6.0, you can convert a table to
text by selecting the table and choosing the Convert Table to Text
command from the Table menu. In Word for Windows versions 1.x, you can
do this by choosing the Table To Text command from the Insert menu.

To preserve the line layout of the table, save it in "text with
layout" format. (In the Word 2.0 File Save As dialog box, select the
Text With Layout (*.ans) option; in the Word 1.x File Save As dialog
box, select the Text With Layout (PC-8) option). Then, open the text
with layout file and convert it to normal Word format.

Example
-------

----------------------------------------------------------------|
|one|two                                    |three|four|five|six|
|---------------------------------------------------------------|
| 1 |now is the time for all good men to    |  3  |  4 |  5 | 6 |
|   |come to the aid of their party.  now is|                   |
|   |time for all good men to come to the   |                   |
----------------------------------------------------------------|

If you select this table and convert it from Table to Text, the
resulting text will look like the following:

one                  two        three   four    five    six
  1     now is the time for all good men to come to the aid of their party.
now is the time for all good men to come to the 3   4   5   6

Note: The multiple-line cell that wrapped within the table cell now
wraps across the entire line, distorting the original appearance of
the text.

If you save the table in text with layout format, it retains its
appearance when it is reopened and converted to normal Word format, as
follows:



one     two                             three   four    five    six
1       now is the time for all           3     4       5       6
        good men to come to the
        aid of their party.  Now
        is the time for all good
        men to come to the

Note: In Word 1.x, after you save the document using the Text With
Layout (PC-8) option, when you open it again, Word suggests that you
convert from Text Only format. Make sure you change the selection to
Text With Layout (PC-8) so Word will perform the correct conversion.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 318,
675-676

"Microsoft Word for Windows User's Reference," version 1.x, pages 99,
121, 283, 366, 369-370

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c conv w4wtable



Applying a Style Overrides Existing Paragraph Formatting
Article ID: Q35571
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

If a Style is applied to a paragraph that contains manual paragraph
formatting, the manual paragraph formatting will be removed, leaving
only the paragraph formatting defined in the Style.

For example, if a paragraph is formatted by setting the indents, tabs,
and justification on the Ruler, and a Style is then applied, the
formatting applied on the Ruler will be lost.

This loss of formatting occurs by product design. This functionality
is different than what occurs for manual character formatting.

Additional reference words: w4wformat 1.00 1.10 1.10a  2.00a 2.00a-CD
2.00b 2.00c wm_word 



Column of Letters Displays Along Left Side Of WinWord Screen
Article ID: Q36459
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

When you are trying to set up columns in Word for Windows, a string of 
characters may display along the left side of the screen after you use 
the Section command. This effect occurs if the right-indent marker on 
the ruler is positioned left of the left-indent and first-line-indent 
markers.
  
This problem occurs most frequently when setting up snaking columns.
If you adjust the right indent to the desired column width before you
apply the column formatting with the Section command, the resulting
right indent remains in effect after you set up the columns. This
procedure results in a narrower column than expected, and the column
often has a negative width that produces the long line of characters
along the left side of the screen.

To work around the problem, select the entire problem area, and choose
one of the following methods.
 
1. Press CTRL+X (CTRL+Q in Word for Windows 2.0 or 6.0) to clear the
   paragraph formatting of the paragraph. This method also resets the
   tab- stop settings to be the defaults and resets the left indent and
   first-line indent to zero. If you have set up special tabs or indents
   that need to be retained, you should use method Number 2.

2. Hold down the SHIFT key, and scroll to the left until the right-
   indent marker appears in the negative portion of the ruler. Drag
   the right-indent marker to the right until it lines up with the
   vertical dotted line that indicates the position of the right
   margin or the right edge of a column.

MORE INFORMATION
================
 
For example, if you are working on a document that has 1.25-inch left
and right margins. The right indent would then coincide with the
6-inch mark on the ruler. If your goal was to create two 2.5-inch-wide
columns with 1-inch-wide spacing between the two, then the right-
indent marker should remain at the 6-inch ruler mark and the Division
Layout or Section command should be used to indicate two columns with
1-inch spacing. This is the correct method.

The incorrect method is to first adjust the right-indent marker to the
column width of 2.5 inches on the ruler (yielding an indent of 3.5



inches left of the right margin), and then to choose the same Section
settings. The resulting margin would coincide with the 2.5-inch
position on the ruler, but the text would remain indented 3.5 inches
from this position, corresponding to a column width of -1 inch. Under
such circumstances, there is no horizontal space available for the
text, and the program does its best by placing the characters in a
column of single-character width.

Additional reference words: w4wformat 1.00 1.10 1.10a 2.00 2.00a wm_word 
2.00a-CD  2.00b 2.00c 



Functionality of Style Sheets in Word for Windows
Article ID: Q37803
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

The Styles feature in Microsoft Word for Windows provides a higher
level of format control in addition to normal formatting procedures.
Essentially, the style that you apply to the current paragraph defines
the base paragraph settings.

There are two levels of format control: style formatting and manual
formatting. Style formatting is the formatting that remains if all
other formatting is removed. Manual formatting is formatting that is
in addition to or on top of the style formatting. Changing one level
of formatting does not change the other level.

If you apply formatting only through Styles, the formatting is
completely replaced when another style is applied to that paragraph.
However, if you apply manual formatting in addition to the style, the
manual formatting carries over when the style is redefined with the
new style.

More Information:

Manual formatting commands do not turn off the current style, but add
to that style. For example, if you define a style containing Italic
formatting and apply it to a paragraph and you manually format some of
the text in this paragraph as Bold, that text becomes Italic and Bold.
If you apply a new style containing Underline rather than Italic to
that paragraph, the text in the paragraph becomes Underline and Bold.

Like character formatting, paragraph settings in a style determine the
default paragraph formatting. you can define styles that contain
settings for tab stops, indents, line spacing, and justification. If a
paragraph has a style applied containing paragraph settings and you
apply a different style, the paragraph settings defined in the first
style are completely replaced by the settings in the second style.
However, if there is additional paragraph formatting applied in
addition to the style, that formatting remains even after you apply a
different style.

For example, you define a style containing the settings for tab stops
at 1 inch and 4 inches. You type a paragraph and the text is arranged
in columns lined up at 1 and 4 inches. You define another style with
tab stops at 1.5 inches and 5 inches and apply this style to the
paragraph; the columns in the paragraph now line up at 1.5 and 5
inches. You manually place a tab stop on the ruler at 3.5 inches; now
the columns line up at 1.5 and 3.5 inches. If you reapply the original



style, with tab stops at 1 and 4 inches, to the paragraph, the columns
line up at 1 and 3.5 inches because the manually applied tab remains
on the ruler.

Additional reference words: w4wformat 6.00 wm_word 
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Applied Style's Character Formatting Changes Entire Paragraph
Article ID: Q41741
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows versions 1.x and 2.x, if you apply a style 
to a paragraph, its character formatting is applied to the entire
paragraph, not just the current selection.

For example, if you apply a style containing bold to a paragraph that
is already formatted as italic, the paragraph becomes bold italic.
This behavior occurs no matter what portion of the paragraph is
selected when you apply the style.

Unlike Microsoft Word for MS-DOS, Word for Windows does not have
character styles. Word for Windows has only paragraph styles.

Word version 6.0 provides the capability to assign Character Styles to a 
word or word(s) within a paragraph.

Word version 1.x and 2.x
------------------------

To assign a Character Style to words within a paragraph:

1. Select Format and Style.

2. Select New.

3. Type the name for your Character Style in the Name box.

4. Select Character Style in the Style Type box.

5. Select Format.  Select Font.

6. Then select the attributes for your Style.  Select OK.

7. Select the Add to Template box to make this a permanent change for
   the template.

8. Select OK.  Select Close.

9. The new Character Style may now be assigned to certain words within a 
   paragraph of a Word 6.0 document without effecting the rest of the 
   paragraph.

Additional reference words: w4wformat
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c





Headers and Footers Do Not Wrap Around APOs in WinWord
Article ID: Q41750
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0  
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, headers and footers do not flow around
absolutely positioned objects (APOs) or framed objects as main body
text, footnotes, and annotations do. If you position an APO or a frame
over a header or footer, the APO or frame prints over the contents of
the header or footer.

Objects in the Drawing Layer of Word 6.0 act like APOs in this respect.
However, they can be moved behind the text using the Send Behind Text 
feature.

Additional reference words: w4wformat
format position 1.00 1.10 1.10a 
2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00



WinWord Msg: Save Changes to Style?
Article ID: Q41803
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c  
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Word for Windows Message: "Save changes to style?"

You chose Define Styles from the Format menu, typed or selected a
style name, made some changes to the styles definition, and then
selected another name or chose Cancel without choosing Define. Word
wants to know if you want to keep the changes to the style or discard
the changes.

If you want to keep the changes, choose Yes. If you want to discard
them, choose No or Cancel.

This functionality has changed in Word version 6.0.

Additional reference words: w4wformat 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c 



Creating Borders and Tables of Text in Word for Windows
Article ID: Q47522
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

To place a border around text, follow these steps:

Word for Windows version 2.0 and 6.0
------------------------------------
 
1. Select the line or lines of text you want to put the border around.
  
2. From the Format menu, choose Border.

3. Select the type of border you want to format the text with.

Word for Windows version 1.0 and 1.1
------------------------------------

1. Select the line or lines of text you want to put the border around.
 
2. From the Format menu, choose Paragraph.

3. Select the type of border you want to format the text with.

More Information:
 
A border can be a single line that is a horizontal or a vertical bar,
or a box enclosing the text. However, borders cannot be combined to
create a table.

To create a table, follow these steps:

1. Select the line or lines of text.

2. Choose Insert Table.

This creates a box outside of the selected text as well as inserts
lines that separate the text.

Additional reference words: w4wformat "table of text" 1.00 1.10 1.10a
wm_word 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00



Text in Table Appears in Columns in Word for Windows
Article ID: Q47597
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0  
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

If the text in the cells of a table appears in columns instead of
normal lines, the cell of the table may have paragraph formatting that
includes an indent that is larger than the width of the column.

MORE INFORMATION
================

There are two methods to determine and correct this problem:

1. Check the ruler by doing the following:

   a. Select the problem paragraph.

   b. Activate Paragraph mode by pressing CTRL+SHIFT+F10.

   Small triangles appear under the numbers on the ruler. The triangle
   on the right points left, and the triangle on the left points
   right, so that they point at each other. If this is not the case,
   the left paragraph indent is currently set larger than the cell
   width. The left triangle has two parts, which can be moved
   separately. The top section indicates the first-line indent and the
   bottom section indicates the left paragraph indent.

   The triangles can be moved with a mouse or the keyboard. When using
   the keyboard, the LEFT and RIGHT ARROW keys are used to position
   the ruler cursor, represented by a rectangular box on the ruler.
   Once the cursor is moved, do the following:

   a. To change the left or right paragraph indents, press either the
      "L" or "R" key (respectively) to move the indents to the current
      cursor position.

   b. To change the first-line indent, press the "F" key to move the
      first-line indent to the current cursor position.

   Using the mouse to position the left and right indents is
   accomplished by pointing at the appropriate triangle and, holding
   the left mouse button down, dragging it to the new position on the
   ruler, as follows:

   a. To set a first-line indent, move the left indent to the position
      desired for the first-line indent.



   b. To move just the left margin indicator (the bottom section of
      the triangle), hold the SHIFT key down and drag it back to the
      left.

2. Select the problem paragraph. From the Format menu, choose
   Paragraph. If there are measurements in the From Left, From Right,
   or From First Line text boxes in the Indents group box, the
   measurements should be reduced or removed.

If the problem occurs only on the first line of a paragraph, the cause
is a first-line indent that is too large for the cell width.

Additional reference words: 6.00 w4wformat w4wtable 1.00 1.10 1.10a
2.00 wm_word 2.00a 2.00a-CD 2.00b 2.00c



Changing Footnote Reference Styles in Word for Windows
Article ID: Q47857
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c  
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

Changing the footnote reference style or the annotation reference
style by choosing Styles from the Format menu does not change any
existing footnote reference number or annotation reference style
characteristics. Only footnote references and annotation references
inserted after the style has been redefined take on the new style. To
change the character format of existing footnote references in Word
for windows, use the Replace command from the Edit menu as follows:
 
1. From the Edit menu, choose Replace.
  
2. In the Find box, do not enter text. Use the character formatting
   keys to search for the combination of formatting that is applied to
   the existing footnote reference marks. For example, the default
   formatting for footnote references is Normal + Font: 8-point,
   superscript 3-point. To search for this, hold down the CTRL key and
   press "P" until the space below the search box reads Font: 8-point.
   Then, hold down the CTRL and SHIFT keys and press the PLUS key.

   Note: Key sequences for formatting are summarized on page 290 of
   the "Microsoft Word for Windows User's Reference" manual.

3. In the Replace box, enter the key sequences for the formatting you
   want to use for the footnote references.
 
4. If you have other text that is formatted the same as the new
   footnote reference style, do NOT clear the Confirm Changes box. If 
   you do remove the check, Word reformats all text that meets the 
   search criteria using the new style without prompting you prior to 
   each change.

5. Choose the OK button.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate



your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Additional reference words: w4wformat 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD  2.00b 2.00c  



Using Tabs Within the Cell of a Table in Word for Windows
Article ID: Q48113
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

You can use the Format Tabs command to set up tab positions within
cells of a table. Each cell holds its own individual tab settings,
even among cells located in the same column. Microsoft Word for
Windows ignores tab settings at positions that exceed the cell
boundaries.

The use of tabs is modified slightly when in a table. To move to the
next cell in a table, use the TAB key. To move to a tab position
within a cell, hold down the CTRL key, and press the TAB key.
 
Additional reference words: w4wformat 6.00 wm_word 
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 



Creating Side-by-Side Tables in Word for Windows
Article ID: Q48373
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

You cannot create two side-by-side tables in Word 1.x for Windows;
however, you can create two side-by-side tables in Word versions 2.x
and 6.0. You can create the appearance of two side-by-side tables in
versions 1.x, 2.x, and 6.0.

To create the appearance of two side-by-side tables, create a single
table with enough columns for both tables, plus one extra column to
separate the tables in the center. You can then reduce the column
width of the middle column so that it appears that there are two
side-by-side tables.

Word for Windows Versions 2.x and 6.0
-------------------------------------

1. From the Table menu, choose Insert Table or click the Table Icon
   on the toolbar. Change the number of columns to the total number of
   columns for both tables plus one.

2. Select the column that you want to separate the tables by
   positioning the insertion point in the column; from the Table menu,
   choose Select Column.

3. From the Table menu, choose Column Width; or, drag the table column
   guides with your mouse to change the width of the selected column.

4. Select the columns representing your left part of the table, choose
   Border from the Format menu, and apply borders around the cells in
   the left part of the table. Repeat this step for the right side
   of the table, leaving the center column unformatted. The bordered
   parts of the table will give the appearance of two side-by-side
   tables.

Word for Windows Version 1.x
----------------------------

1. From the Insert menu, choose Table (ALT+I T). Change the number of
   columns to the total number of columns for both tables plus one.

2. Select the column that you want to separate the tables. Using the
   keyboard, move the insertion point to the top cell in the column,
   press F8, and then press DOWN ARROW until you reach the bottom of
   the column.



3. From the Format menu, choose Table (ALT+T A) to change the Width Of
   Column box to the desired space between the tables.

Additional reference words: w4wformat 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD  2.00b 2.00c 6.00 wm_word



Multiple Word Text in a Date-Time Picture Switch
Article ID: Q48919
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

The correct syntax to include multiple word text in a date-time or a
numeric picture switch is to place the text within single quotation
marks within the numeric picture or date-time picture.

According to the fields reference, text can be entered as part of a
date-time or numeric picture switch by enclosing the text in single
quotation marks, as follows:

   'text'

The entire date-time picture or numeric picture must be enclosed
within double quotation marks if literal text is used. The following
are examples:

   {date \@ " 'it is' dddd"}
   {= 0 \# "0;-0;'null value'"}

Additional reference words: 6.00 w4wformat custom format w4wfield 1.0
1.1 wm_word 1.1a 1.00 1.10 1.10a 2.0 2.00



Renumbering Removes Leading Tabs in Word for Windows
Article ID: Q48923
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Word for Windows Versions 2.x and 6.0 
-------------------------------------

If you renumber paragraphs by choosing Bullets and Numbering from the
Tools menu and later choose the same option to remove numbering, Word
only removes the numbers and leading tabs from those paragraphs that
you formatted by choosing Bullets and Numbering from the Tools menu.

Word for Windows Version 1.x 
----------------------------

If you renumber a paragraph by choosing Renumber from the Utilities
menu and later choose the same command with the Remove option, Word
removes the leading white space from any paragraphs containing leading
tabs or spaces.

Word removes leading white space to force alignment of similar heading
levels for an outline and to force alignment of similarly nested
paragraphs created using CTRL+N.

Additional reference words: 6.00 w4wformat 1.00 1.10 1.10a 2.00 2.00a
wm_word 2.00a-CD  2.00b 2.00c 



Utilities Renumber Overwrites Leading Paragraph Numbers
Article ID: Q48924
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0  
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

In Microsoft Word for Windows, if a paragraph begins with a number,
choosing to renumber will replace the leading numbers with new numbers
that follow the current numbering scheme. This will occur whether the
numbers were manually entered from the keyboard or placed there from
the menu option. One exception is if a number is NOT followed by a
space. Word then views the number as part of the text.

Word version 2.0
----------------

To renumber from the menu:

1. Select the text to be renumbered.

2. From the Tools menu and select Bullets and Numbers.

2. Choose the Numbered List button.

3. Make the desired choices from the Number box and choose OK.

Word versions 1.0 and 1.1 
-------------------------

1. Select the text to be renumbered.

2. From the Utilities menu select Numbering.

3. Choose the desired Format and choose OK.

   Note: You can highlight a section of text and select the Learn option
   of Utilities Renumber Format, and the command takes the format of the
   number from the first paragraph of each level and uses this format for
   all other paragraphs in the same level. This option requires that the
   numbers be followed by spaces.

Additional reference words: 6.00 w4wformat 1.00 1.10 1.10a 2.00 2.00a
wm_word 2.00a-CD  2.00b 2.00c



EDITTIME Must Be in Minutes
Article ID: Q49188
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

The EDITTIME field always returns the number of minutes the document
has been open. This time includes any time previous to the current
session that the document was open.

The EDITTIME field cannot be formatted using a date-time picture
switch.

The following field displays the edittime in the hh:mm format:

   {=int({edittime}/60)}:{={={edittime}-({=int({edittime}/60)}*60)}}

Note: All {} are field braces created by using the Insert Field key
(CTRL+F9), not the brace keys on the keyboard.

Additional reference words: 6.00 w4wformat w4wfield 1.0 1.1 1.1a 1.00
1.10 wm_word 1.10a 2.0 2.00



Cannot Format TIME or EDITTIME to Display Seconds
Article ID: Q49459
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

There are two fields in Word for Windows that return a time-related
result:

1. EDITTIME returns the number of minutes the current document has
   been open for editing since it was created.

2. TIME returns the current time of day.

You cannot format the result of a field to include seconds or partial
seconds using a Word for Windows date-time picture switch. The
smallest unit of time that Word for Windows can return or display is
minutes.

Additional reference words: 6.00 w4wformat w4wfield 2.0 2.00 wm_word 



Deleting a Table from a Word for Windows Document
Article ID: Q49865
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:
  
After you insert a table into a Word for Windows document file, there
are three ways to delete it:

Word for Windows Versions 2.0 and 6.0
-------------------------------------
   
1. Select the table or section of rows. From the Table menu, choose
   Delete Rows.
  
2. Select the table or section of table. From the Table menu, choose
   Convert Table to Text, and choose either Paragraph Marks, Tabs, or
   Commas. Press ENTER.
  
3. Select the table or section of the table and at least one paragraph
   marker below the table. Press the DEL key.

Word for Windows Version 1.x
----------------------------
    
1. Select the table or a portion of the table. From the Edit menu,
   choose Table (ALT+D A), and choose the Delete button.
  
2. Select the table or section of table. From the Insert menu, choose
   Table To Text (ALT+I T), select Paragraphs from the Convert Table To
   dialog box, and press ENTER.
 
3. Select the table or section of the table and at least one paragraph
   marker below the table. Press the DEL key.

Insert Table To Text converts the table format to text format without
deleting the text contained in the table. Each cell in the table is
converted into a separate paragraph.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 167, 369-370
"Microsoft Word for Windows User's Guide," page 328

Additional reference words: w4wformat w4wtable 1.00 1.10 1.10a 2.00
2.00a 2.00a-CD 2.00b 2.00c



Removing Direct Character Formatting Using CTRL+SPACEBAR
Article ID: Q50725
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Direct or manual character formatting is applied using the Format
Character menu command or the keyboard equivalents available for the
options in the Format Character command. To remove all direct
character formatting, perform the following steps:

1. Highlight the character(s) you want to remove the formatting from.

2. Press CTRL+SPACEBAR.

This procedure removes all direct character formatting from the
selected characters. It does not affect paragraph formatting or any
formatting applied via style sheets.

Additional reference words: w4wformat



Table Cell Formatting with Borders Is Inconsistent
Article ID: Q60847
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------
 
Summary:

Microsoft Word for Windows is not consistent when formatting borders
in a table. The formatting of a cell will overwrite the formatting of
the cells to the right and left, but may not overwrite the formatting
of the adjacent cells above and below.
 
More Information:
 
The following sample steps reproduce this problem:
 
Example 1
---------

1. Format row 2 with a Single Top border.

2. Format row 1 with a Bottom border of None.

Result: A Single border appears between rows 1 and 2.
 
Example 2
---------

1. Format row 2 with a Single Top border

2. Format row 1 with a Thick Bottom border.

3. Format row 1 with a Bottom border of None.

Result: No border appears between rows 1 and 2.

Additional reference words: w4wformat w4wtable 6.00 wm_word 



Auto Outline Numbering and the "Chicago Manual of Style"
Article ID: Q61514
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

Automatic Outline Numbering in Microsoft Word for Windows follows the
"Chicago Manual of Style" (CMS) in numbering scheme (as stated on page
230 of the "Microsoft Word for Windows User's Reference"), but not in
alignment.

STATUS
======
 
Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This functionality was added
to Word version 6.0 for Windows.
 
To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

According to the CMS, the level numbers should be right aligned, as
follows:

      I.
     II.
    III.
     IV.

Word for Windows numbering (using the Utilities Renumber and Format
Outline commands) is left aligned, as follows:

   I.
   II.
   III.
   IV.

Word version 6.0
----------------

Word version 6.0 defaults to the left alignment described above. This
alignment can be changed using the following steps:



1. Select any Heading Level 1 text.

2. From the Format menu choose Heading and Numbering and choose
   Modify.

3. In the Number Position dialog box set the Alignment of List Text
   drop down list box to Right and choose Ok.

Word version 2.x
----------------

You can correct the numbering alignment using the following general
steps:

1. From the Format menu, choose Style (Styles Define in Word for
   Windows 1.x) and add a right-aligned tab to the appropriate heading 
   style at the desired position. For example, heading 1 might have 
   a right-aligned tab at 0.3 inches.

2. Insert a tab before each {autonumout} field.

You can create a macro to automate step 2. The macro below 
inserts a tab before each {autonumout} field for the "heading 1" 
style:

Sub MAIN
EditFindClearFormatting
StartOfDocument
EditFindStyle .Style = "heading 1"
EditFind .Direction = 2, .Format = 1
While EditFindFound()
  InsertBookmark .Name = "Origin"
  StartOfLine
  If Asc(Selection$()) <> 9 Then
    Insert Chr$(9)
  End If
  EditGoTo .Destination = "Origin"
  EditFind .Direction = 2, .Format = 1
Wend
StartOfDocument
End Sub

This macro only works for heading level 1. You must modify 
the macro to format other heading levels. 

Microsoft is researching this problem and will post new 
information here as it becomes available.

Additional reference words: w4wformat w4wmacro 1.00 1.10 1.10a 2.00 
2.00a 2.00a-CD 2.00b 2.00c 



Bold Formatting Lost in Outline Mode in Word for Windows
Article ID: Q64283
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If text has been formatted in a bold weight in normal editing mode in
Microsoft Word for Windows, and it is brought into outline mode and
changed into a heading-level-two style, the text will lose the bold
formatting it previously had. This is apparent when the text has been
formatted in bold prior to entering outline mode.

To have text hold the bold format from galley, draft, or page view
into outline mode, it is important to format the text using the
heading-level style that will be required when the text is in outline
mode. For example, if you have a paragraph heading that needs to be
formatted in bold, and it is going to also be in a heading-level-two
style, you must format the text with a heading-level-two style prior
to entering outline mode. Or, leave the text in normal format and
allow the appropriate heading-level style to change the text
accordingly when in outline mode.

The text loses the bold formatting because the heading-level-two style
contains bold in its definition, which in turn causes the text to
default back to its original formatting when it is converted to a
heading-level-two style.

Reference(s):

"Microsoft Word for Windows User's Reference" pages 236-239

Additional reference words: w4wformat 6.00 wm_word 
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 



Word for Windows: CTRL+H Does Not Toggle Hidden Text
Article ID: Q65850
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When hidden text in Microsoft Word for Windows is NOT displayed,
CTRL+H (CTRL+SHIFT+H for Word 6.0) will only apply hidden
character formatting, not remove it.This occurs because in this 
situation once hidden character formatting is applied to selected text 
by pressing CTRL+H (CTRL+SHIFT+H for Word 6.0), the text disappears.
When CTRL+H (CTRL+SHIFT+H for Word 6.0) is pressed again, the hidden 
text will not reappear.

In this case, hidden text is a toggle to the selected area. Because
hidden text is not being displayed, the selection becomes an insertion
point once the text is hidden. Any formatting applied without a
selection of text will not be applied to the hidden text.

When working with hidden text in this manner, or when removing
hidden-text formatting from specific selections of text, be sure
to display hidden text.

In Word for Windows versions 1.0, 1.1, and 1.1a, this is done by
choosing Preferences from the View menu and selecting the Hidden Text
check box or the Show All check box.

In Word for Windows version 2.0 and Word version 6.0, this is done
by choosing Options from the Tools menu, selecting View from the
Category list and under Nonprinting Characters, selecting the Hidden
Text check box or the All check box. 

Reference(s):

"Microsoft Word for Windows User's Reference," version 1.0, page 153.

Additional reference words: w4wformat 6.00 wm_word 
1.00 1.10 1.10a 2.0 2.00



Large Selection Blanks Ribbon and Some Dialog Box Settings
Article ID: Q66036
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

If you select 50 or more paragraphs of text in a Microsoft Word for
Windows document, the Style, Font, and Points (Pts) boxes on the
ribbon are blank. Similarly, if you select 20 or more rows in a table
in which all columns are the same width, the values in the Table
Column Width dialog box are blank.

This happens because, in order to optimize performance speed, Word
does not survey large selections to determine formatting information.

More Information:

If you click the arrow on the Font box or the Style box, all the fonts
or styles will be displayed. If you click the arrow on Pts box, the
box will remain empty. To achieve the desired character formatting,
select a font, then type a valid point size in the Pts box.

After you select a font, the font will momentarily appear on the
ribbon and then will disappear. If you enter a point size, it will
disappear when you press ENTER.

Additional reference words: w4wformat 6.00 wm_word 
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00 2.00c nothing



Glossary Items Lose Bold When Pasted into Bold Style
Article ID: Q66103
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

Bold text that has been copied into the Glossary will lose its bold
formatting when pasted into a paragraph that is formatted using a
style with bold formatting.

STATUS
======

Microsoft has confirmed this to be a problem in Word for Windows
versions 1.x, 2.x. and 6.0 We are researching this problem
and will post information here as it becomes available.

Additional reference words: w4wformat 6.00 wm_word  1.0 1.1 1.1a 1.00
1.10 1.10a  2.0 2.00



Top Border of Paragraph Is Lost if Preceded by Two Page Breaks
Article ID: Q68042
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you insert two page breaks immediately before a bordered paragraph
in Word for Windows, the top border disappears. Note that with only
one page break, the paragraph displays correctly.

Microsoft has confirmed this to be a problem in Word for Windows
versions 1.00, 1.10 and 1.10a. We are researching this problem and
will post new information here as it becomes available.

In Word for Windows 6.0, the paragraph and the two blank pages display 
correctly in Normal View, but not in Page Layout or Print Preview.  In 
Page Layout and Print Preview, the second blank page appears with a 
small vertical black line on the left and right side of the page.  These 
lines do not print, and the entire document will print correctly.

More Information:

Workaround
----------

Enter some text between the two inserted page breaks and format the
text as Hidden from the Format Character dialog box.

In Word for Windows 6.0, insert a paragraph mark between the two page 
breaks.

Steps to Reproduce Problem
--------------------------

1. Type a paragraph.

2. Select the paragraph.

3. From the Format menu, choose Paragraph and select Box from the
   Border field.

4. Insert two page breaks before the bordered paragraph. (Be sure
   there are no paragraph marks between the two page breaks and the
   bordered paragraph; if there are, delete them.)

5. Note that the top border has vanished.

Reference(s):



"Microsoft Word for Windows User's Reference." (Document Number OB
14328-0990) Pages 32-33 and 252.

Additional reference words: w4wformat 6.00 wm_word 



WinWord Err Msg: Indentation Too Large
Article ID: Q68048
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

You will receive the error message

   Indentation Too Large 

- or

   The Indent Size is Too Large

if you set an indent that leaves a paragraph smaller than the default
tab width. It is possible to use the mouse to indent a paragraph
smaller than a tab width without receiving this message; however, you
will receive it if you choose Paragraph from the Format menu.

Microsoft has confirmed this to be a problem in Word for Windows. We
are researching this problem and will post new information here as it
becomes available.

More Information:

To eliminate the error message, from the Format menu select Tab and
decrease the value in the Default Tab Width text box until it is less
than the width of the indented paragraph and choose OK.

Additional reference words: w4wformat 6.00 wm_word 
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Merged Styles Not Retained with Some WinWord Documents
Article ID: Q68317
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, and 2.0a
 - Microsoft Windows operating system, versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, styles do not remain in some documents
after being merged from a template. For example, if you merge styles
into a document using the steps below, the new style formatting is
applied to your document during the session; however, it may be lost
after the document is closed and then reopened.

Note: This problem is most common with documents converted from the
Microsoft Word for MS-DOS file format to Word for Windows.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

Versions 1.x of Word for Windows
--------------------------------

1. From the Format menu, choose Define Styles.

2. Choose the Options button, then choose the Merge button.

3. Choose the From Template button.

Versions 2.0 and 2.0a of Word for Windows
-----------------------------------------

1. From the Format menu, choose Styles.

2. Choose the Define button, then choose the Merge button.



3. Choose the From Template button.

WORKAROUND
==========

As an alternative to merging styles from a template, you can manually
change the existing styles by choosing Define Styles from the Format
menu.

Another way to work around this problem is to add an AutoOpen macro
that merges the styles from the template whenever you open the
document.

Another possible workaround to this problem is to save the document in
rich-text format (RTF) after merging the styles from the template. To
save a document in RTF, do the following:

Version 2.0 of Word for Windows 
-------------------------------

1. From the File menu, choose Save As.

2. In the Save File As Type box, select Rich Text Format (*.rtf). 

3. Change the name of the file in the File Name box, and choose the OK
   button.

4. Close the current document and open the file that was just saved in
   rich-text format.

Versions 1.x of Word for Windows 
--------------------------------

1. From the File menu, choose Save As.

2. Choose the Options button.

3. In the File Format box, select RTF.

4. Change the name of the file in the Save File Name box, and choose
   the OK button.

5. Close the current document and open the file that was just saved in
   rich-text format.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 205-208

"Microsoft Word for Windows User's Reference," version 1.x (Document
Number OB 14328-0990), pages 340 and 347

Additional reference words: w4wformat 1.00 1.10 1.10a 2.00 2.00a
w4wtemplate disappear missing





Word for Windows: Creating Styles for Section Formatting
Article ID: Q68363
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Microsoft Word for Windows does not allow you to save section
formatting as a style. You can, however, save the formatted section
marks in glossaries so that the section format can be reused.

In Word for Windows 6.0, glossary entries are referred to as Autotext.

More Information:

To create a glossary or autotext entry for a section format, do the 
following:

Word for Windows Version 6.0
----------------------------

1. Make sure that Page Layout on the View menu is not selected; if
   there is a check in front of Page Layout, choose Normal to change
   to normal view.

2. From the Insert menu, choose Break and select an appropriate
   section break option.

3. Position the insertion point on the section mark. The section mark
   is a double-dotted line.

4. From the File menu, choose Page Setup and the Layout tab, and 
   select the desired section formatting.

5. Select the section mark, choose Autotext from the Edit menu, 
   type in an autotext name, and choose the Add button.

6.  These autotext entries will be saved to the NORMAL.DOT by default 
unless specified 
otherwise.

Word for Windows Version 2.x
----------------------------

1. Make sure that Page Layout on the View menu is not selected; if
   there is a check in front of Page Layout, choose Normal to change
   to normal view.

2. From the Insert menu, choose Break and select an appropriate
   section break option.



3. Position the insertion point on the section mark. The section mark
   is a double-dotted line.

4. From the Format menu, choose Section Layout and make the
   appropriate formatting selections..

5. Select the section mark, choose Glossary from the Edit menu, 
   type in a glossary name, choose the Define button , and choose the
   OK button.

6. When exiting Word for Windows, choose the Yes button when you are
   asked if you want to save global glossary and command changes.

Word for Windows Versions 1.x
-----------------------------

1. Make sure that Page on the View menu is not selected; if there is a
   check in front of Page, choose Page to deselect it.

2. From the Insert menu, choose Break and select an appropriate
   Section Break option.

3. Position the insertion point on the section mark. The section mark
   is a double-dotted line.

4. From the Format menu, choose Section and make the appropriate
   formatting selections.

5. Select the section mark, choose Glossary from the Edit menu, type
   in a glossary (autotext) name, choose the Define button, and choose 
   the OK button.

6. When exiting Word for Windows, choose the Yes button when you are
   asked if you want to save global glossary and changes.

To insert a copy of the section break, choose Glossary (Autotext) from 
the Edit
menu and choose the Insert button.

Additional reference words: w4wformat 6.00 wm_word 
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Preventing Page Breaks in Word for Windows Tables
Article ID: Q69415
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Microsoft Word for Windows adds a page break between rows of a table if 
the table is too long to fit on the page. To force Word to keep the 
table together, do the following:

Word version 6.0
----------------

1. Select the table.

2. From the Insert menu, choose Frame.

3. From the Format menu, choose Frame.

4. Type or choose the desired positions in the Horizontal and Vertical
   dialogs.

5. Choose the OK button.

Word versions 1.x, 2.x
----------------------

1. Select the entire table.

2. From the Format menu, choose Paragraph.

3. In versions 1.x, select the With Next check box under Keep Paragraph.
   In versions 2.0 and 2.0a, select the Keep With Next check box under
   Pagination.

More Information:

The maximum length of a single cell or row of cells in a table is one 
page; therefore, even if the table is formatted to be one unit on a 
single page, Word places a page break between rows if a single cell or a 
row of cells is too long to fit between the top and bottom margins of 
the page. To correct this problem, you can adjust the top and bottom 
margins so that the table fits on the page, or you can absolutely 
position the table on the page to override the margin settings. To 
position the table, use the following steps:

Word version 2.x
----------------



1. Select the table.

2. From the Insert menu, choose Frame.

3. From the Format menu, choose Frame.

4. Type or choose the desired positions in the Horizontal and Vertical
   dialogs.

5. Choose the OK button.

Word version 1.x
----------------

1. From the Format menu, choose Position.

2. Under Horizontal, select Left and select Relative To Margin rather 
   than Relative To Column.

Additional reference words: w4wformat 6.00 wm_word 
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 
w4wtable 2.00c



Converting Files with Extended Characters in Filenames
Article ID: Q69559
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

The following information concerns converting/opening files in Word
for Windows that contain extended characters within the filename.

This functionality has changed in Word version 6.0 for Windows.

Opening a File with an Extended Character within the Filename
-------------------------------------------------------------

The following error will result when trying to convert a document to
Word for Windows if the filename contains an extended or high bit
character:

   Document name or path is not valid

It is possible to create a filename that contains non-ANSI extended
characters if it was created in a non-Windows application such as Word
for DOS. Such a file can be opened in Word for Windows only after the
extended characters are removed from the filename. This can be done by
renaming the file either at the DOS prompt or from within the
application in which the file was originally created.

Saving a File with an Extended Character within the Filename
------------------------------------------------------------

When saving a Word for Windows document that contains extended ANSI
characters in the filename to another file format, two files will be
created: one file that contains characters from the extended ANSI
character set and one that contains characters from IBM PC Extended
Character Set. To open the file in Word for Windows, select the
filename that contains the ANSI characters. To open the file in the
other application, such as Word for DOS, select the filename that
contains the non-ANSI characters.

Additional reference words: w4wformat
1.0 1.1 1.1a 1.00 1.10 1.10a  2.0 2.00
conv  high bit characters file name valid document name



Border Above Doesn't Display in Page View in Word for Windows
Article ID: Q69860
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If the first paragraph on any page after the first page in a document
is formatted with line Spacing Before and a Border Above, the border
will not display in Page View.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Steps to Reproduce Problem
--------------------------

1. Load Word for Windows and bring up a new document.

2. Type about one half of a line of text and press ENTER.

3. Press F4 to repeat this until you have more than one page of text.

4. Position the cursor at the top of page 2.

5. From the Format menu, choose Paragraph and set Spacing Before to
   0.5li.

6. Select Border Above and choose OK.

7. From the View menu, choose Page.

Result: The line above the paragraph on the second page is not
displayed. The border can be viewed in Print Preview and also in
Galley View. If the Spacing Before is set back to 0li, then the border
will show up in Page View as well. This behavior does not occur on the
first page of the document, only on subsequent pages.

Microsoft has confirmed this to be a problem in Word for Windows
versions 1.0 1.1 and 1.1a. This problem was corrected in Word for
Windows version 2.0.

Reference(s): 

"Microsoft Word for Windows User's Reference," pages 304- 305.

. Change the Apply To section of the dialog to Whole Table from   
Selection (Word for Windows 1.x only). 
  



More Information:  
  
It is also possible to position a table horizontally on the page with  
the Format Position command. To do this, use the Format Position  
command as follows:  
  
   Horizontal: Center     Vertical: Inline  
   Relative To: Margin    Relative To: Margin  
  
   Paragraph Width: Auto  
  
Note: Using the Format Position command to position the table will  
allow text to wrap around the table depending upon the width of the
table.   

Additional reference words: w4wformat
1.0 1.1 1.1a 1.00 1.10 1.10a  2.0 2.00



Centering a Table Horizontally on the Page in Word for Windows
Article ID: Q69861
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, to center a table horizontally (left to
right) on the page, do the following:

Word version 6.0
----------------

1. Place the cursor within a cell of the table.

2. From the Table menu select Cell Height and Width.

3. From the Row dialog set the Alignment button to Center and choose OK.

Word versions 1.x and 2.x
-------------------------

1. Place the cursor within a cell of the table.

2. In Word version 2.0, choose Row Height from the Table menu. In
   previous versions of Word for Windows, choose Table from the Format
   menu.

3. Set the alignment for the rows (Align Rows) to Center.

4. In Word versions 1.x, select Whole Table under Apply To.

More Information:

You can also position a table horizontally on the page with the Format
Position command. To do this, choose Position from the Format menu and
select the following settings:

   Horizontal: Center     Vertical: Inline
   Relative To: Margin    Relative To: Margin

   Paragraph Width: Auto

Note: Using the Format Position command to position the table will
allow text to wrap around the table if there is room.

Additional reference words: w4wformat 6.00 wm_word 
1.0 1.1 1.1a 1.00 1.10 1.10a 2.00 2.00a
w4wtable position



No Header in WinWord Print Preview When Using Bin Feeder
Article ID: Q70017
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When printing a document with a Bin Feeder selected in the File
Printer Setup dialog box in Word for Windows, a header will not print
or appear in print preview unless it is specified to print 1 inch or
farther from the top of the page.

More Information:

Some printers (such as 9-pin and 24-pin printers) offer the paper feed
selections of tractor feed or bin feeder. When you print a document
using a bin feeder, the paper is scrolled up 1 inch automatically
before printing begins. Because of this functionality, a header will
not print inside that 1 inch area at the top of the paper. Because the
default setting for the header is 0.5 inch from the top of the paper,
the header will not display in print preview or print unless it is
manually set to print 1 inch or farther from the edge of the page.

Solution:

To display the header in print preview and print it, do one of the
following:

Word for Windows 6.x
--------------------
1. From the File menu, choose Page Setup, select the paper source
   tab, and set the source to tractor feed.

2. Format the document for a top margin that is greater than 1 inch.
   Then choose the Margins tab from the File Page Setup menu. 
   Change  From Edge measurement for the header to 1 inch or greater.

Word for Windows 2.x
--------------------
1. From the format menu, choose Page Layout, select the paper source
   button, and set the source to tractor feed.

2. Format the document for a top margin that is greater than 1 inch.
   Then choose Header/Footer from the View menu, select Options and
   change the Distance From Edge for the header to 1 inch or greater.

Word for Windows 1.x
--------------------
1. From the File menu, choose Printer Setup, select Setup and select
   Tractor Feed for the Paper Feed.



   -or-

2. Format the document for a top margin that is greater than 1 inch.
   Then choose Header/Footer from the Edit menu, select Options and
   change the Distance From Edge for the header to 1 inch or greater.

To Illustrate:

1. Set up one of the Windows 9-pin or 24-pin printers through the
   Control Panel.

2. In Word for Windows use the appropriate commands to set the paper
   source to the bin feeder.

3. Verify that the Distance from Edge measurement for the header is
   smaller than one inch.  Type in an example header.

4. From the File menu, choose Print Preview. Note that the header does
   not display at the top of the page.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 148, 149.

Additional reference words: w4wformat 6.00 wm_word 
w4wprint 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 



Vertical Alignment in Section Doesn't Justify Without Breaks
Article ID: Q70027
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When you choose the Vertical Alignment option in the Format Section
dialog box in Word for Windows (Format Section Layout... in Word
for Windows 2.0), the Justify option will not justify the section
until a page break is inserted.  

This problem was corrected in Word version 6.0 for Windows.

More Information:

According to the description in Help, the Justify option under Format
Section should "expand the space between paragraphs to align the top
line with the top margin and the bottom line with the bottom margin."
However choosing the Justify option will not take effect or cause text
to look any different than the Top Vertical Alignment option until a
page break is inserted.

This behavior is very similar to justifying a paragraph of text in Word
for Windows. Word has no way of knowing how to justify the line
until a paragraph mark is inserted or the line wraps on its own. Word
for Windows has to know where the break is; either a paragraph mark, in
the case of paragraph justifying, or a page break, in the case of 
vertical section justifying.

Note: Choosing Center in the Vertical Alignment option for a section
will center a single column of text, but not multiple columns.

In Word for Windows 6.0, when you choose Page Setup from the File 
menu, select the Layout tab, and choose Vertical Alignment as Justified, 
the page will justify vertically without a page break inserted. 
Justification of text remains the same as described above in 2.0.

Reference(s):

"Microsoft Word for Windows User's Reference" page 315, 316.

Additional reference words: w4wformat
1.0 1.1 1.1a 1.00 1.10 1.10a 2.0 2.00



Using SHIFT+ENTER Within a Justified Paragraph
Article ID: Q70729
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When you are using SHIFT+ENTER to create a new line within a justified
paragraph, the line of text justifies regardless of how many words of
text are on the line.

Word for Windows doesn't calculate a "hotspot" to determine when text
will actually justify. For example, some word processors require text
to fill 75 percent of a line before text will justify. In this case,
Word will justify any amount of text.

To see this on the screen:

1. In a new paragraph formatted as justified, type 

      just text

2. Press SHIFT+ENTER, and the text will appear as:

      just                                          text

3. If you press only ENTER, the text will appear as:

      just text

Additional reference words: w4wformat 6.00 wm_word 
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 2.00c-CD



Word for Windows 1.x Has 34 Automatic Styles
Article ID: Q71366
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

Although only four styles appear when viewing the Format Styles or
Format Define Styles dialog box, Word actually contains 34 automatic
styles. Pressing CTRL+A while in either of these two menus will
display a scroll box listing all 34 automatic styles.

More Information:

The list below defines the 34 automatic styles and their default
definitions.

For definitions that include a reference to "next style," this
signifies the paragraph style that will be attached to a new paragraph
created when the ENTER key it pressed. For example, if the current
paragraph uses the annotation text style, pressing ENTER from this
paragraph will start a new paragraph that uses the annotation text
style. In contrast, if the current paragraph uses the annotation
reference style (one that has no reference to a next style), pressing
ENTER from this paragraph will start a new paragraph that uses the
normal style.

Style               Default Definitions
-----               -------------------

annotation          normal + font: 8 point
reference

annotation          normal + (next style: annotation text)
text

footer              normal + tabs at 3 inches centered, 6 inches right
                    (next style: footer)

footnote            normal + font: 8 point, superscript 3 point
reference

footnote text       normal + (next style: footnote text)

header              normal + tabs at 3 inches centered, 6 inches right
                    (next style: header)

heading 1           normal + font: helv 12 point, bold
                    underline, space before 12 point



heading 2           normal + font: helv 12 point, bold, space
                    before 6 point

heading 3           normal + font: 12 point, bold, indent
                    left .25 inch (next style: normal indent)

heading 4           normal + font: 12 point, underline, indent
                    left .25 inch (next style: normal indent)

heading 5           normal + bold, indent left .5 inch
                    (next style: normal indent)

heading 6           normal + underline, indent left .5 inch
                    (next style: normal indent)

heading 7           normal + italic, indent left .5 inch
                    (next style: normal indent)

heading 8           normal + italic, indent left .5 inch
                    (next style: normal indent)

heading 9           normal + italic, indent left .5 inch
                    (next style: normal indent)

index 1             normal

index 2             normal + left indent .25 inch

index 3             normal + left indent .5 inch

index 4             normal + left indent .75 inch

index 5             normal + left indent 1 inch

index 6             normal + left indent 1.25 inch

index 7             normal + left indent 1.5 inch

index heading       normal + (next style: index 1)

line number         normal

normal              font: tms rmn 10 point, flush left

normal indent       normal + indent left .5 inch
                    (next style: normal indent)

toc 1               normal + indent right .5 inch, left tab
                    at 5.75 inches, right tab at 6 inches

toc 2               normal + left and right .5 inch indents,
                    left tab at 5.75 inches, right tab at 6 inches

toc 3               normal + left indent 1 inches, right indent
                    .5 inch, left tab at 5.75 inches, right tab at 6
                    inches



toc 4               normal + left indent 1.5 inch, right indent
                    .5 inch, left tab at 5.75 inches, right tab at 6
                    inches

toc 5               normal + left indent 2 inches, right indent
                    .5 inch, left tab at 5.75 inches, right tab at 6
                    inches

toc 6               normal + left indent 2.5 inches, right indent
                    .5 inch, left tab at 5.75 inches, right tab at 6
                    inches

toc 7               normal + left indent 3 inches, right indent
                    .5 inch, left tab at 5.75 inches, right tab at 6
                    inches

toc 8               normal + left indent 3.5 inches, right indent
                    .5 inch, left tab at 5.75 inches, right tab at 6
                    inches

In Word for Windows version 2.0 there are now 38 automatically defined
styles. To access these styles, chose either the Styles box on the
ribbon or choose Styles from the Format menu and press CTRL+Y.

Note: there are two styles that do not show up in the list. These
two styles show up only when the create envelope function is used. 
The names of the two styles are as follows:

    ENVELOPE ADDRESS Normal + Font: 12pt, Indent:
    Left 2", Position: Center, Horiz Relative to

    Column, Bottom Vert. Relative to Margin, Width
    5.5"

    ENVELOPE RETURN Normal

Additional documentation for Word for Windows version 2.0 will be
provided at a later date.

Reference(s):

"Microsoft Word for Windows User's Reference" pages 342-349.

Additional reference words: w4wformat standard 6.00 wm_word 
2.00 2.00a 2.00a-CD 2.00b 2.00c 1.00 1.10 1.10a



Creating Side-By-Side Tables in Word for Windows
Article ID: Q71532
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

Word for Windows does not have an automatic feature that allows the
generation of side-by-side tables. It is possible to simulate this
effect with the Format Position command.

PROCEDURE
---------

Word for Windows Version 2.0 and later
--------------------------------------

1. Create a small table (table #1) by choosing the table tool from the
   tool bar, or choose Insert Table from the Table menu.

2. Create another table (table #2) with a paragraph mark between the
   two tables.

3. Select Table #1 by placing the cursor anywhere in the table and
   pressing ALT+Keypad 5, making sure the NUM LOCK key is off.

   -or

   Click with the left mouse button from the first cell in the table
   and drag it to the end of the table.

4. From the Insert menu, choose Frame.

5. Select Table #2 two (as described above) and choose Frame from
   the Insert menu.

Now that you have inserted both tables into a frame, you can click and
drag the tables to whatever position you want while in page view, as
well as position them side by side. The way to know whether or not you
have properly framed the tables is to place your mouse cursor on the
edge of the table and if it turns into a four-way directional arrow,
then you have positioned the table properly.

Word for Windows Version 1.0 and 1.1
------------------------------------

1. Insert the first table into a document.

2. Highlight the table and choose Position from the Format menu. Type



   a number for the Horizontal Position and Paragraph Width and choose
   OK.

3. Insert the second table.

4. Highlight this table and choose Position from the Format menu. Type
   a number for the Horizontal Position that corresponds to the
   position next to the first table. Type a Paragraph Width that will
   allow it to fit alongside the first table and choose OK.

It is also possible to use this technique to simulate tables that have
cells with different heights along the same row. To create this,
follow the steps listed above. Position the tables so that the right
border of the first table is at the same horizontal position as the
left border of the second table, so that they appear as one table.

For another method of creating the side-by-side table effect, query on
the following words:

   table and side and by and word and windows

REFERENCES
==========

"Microsoft Word for Windows User's Reference," page 370

Additional reference words: 6.00 w4wformat 1.00 2.00 2.0 1.10 1.1 1.0
wm_word 1.10a 1.1a w4wtable toolbar



Can't Toggle Case in Table with SHIFT+F3 or ChangeCase Macro
Article ID: Q72549
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

When you select one or more cells of a table in Microsoft Word for
Windows and attempt to toggle the case of characters by pressing
SHIFT+F3 or running the ChangeCase macro, the computer beeps,
indicating that the command is unavailable.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

WORKAROUND
==========

To use SHIFT+F3 or the ChangeCase macro to change the case of
characters in a table, the text entries must be selected individually
(that is, without selecting the cell marker).

To change all the entries in a table at once, use one of the following
workarounds:

Workaround 1
------------

1. Select the table and the paragraph mark that immediately follows
   the table.

2. Press SHIFT+F3 to toggle the case to the desired format.

Workaround 2
------------

1. Select the table.

2. From the Insert menu, choose Table To Text.



3. Press SHIFT+F3 to toggle the case to the desired format.

4. From the Insert menu, choose Table, select the number of rows and
   columns, and choose the OK button. The text is converted back to table
   format with the desired case.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.x, page 378

Additional reference words: w4wformat w4wtable w4wmacro  uppercase
lowercase 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Last Paragraph of Included File Acquires Different Formatting
Article ID: Q73022
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

If you use the INCLUDE field to insert the contents of one document
into another document in Microsoft Word for Windows version 1.0, 1.1,
or 1.1a, the last paragraph in the source document acquires the
formatting that is used in the paragraph containing the INCLUDE field.
To preserve the formatting of the source document's final paragraph,
apply the desired formatting to the paragraph that contains the
INCLUDE field.

More Information:

If you insert the contents of one document into another document using
the INCLUDE field, the last paragraph mark of the source document is
replaced by the paragraph mark that follows the paragraph containing
the INCLUDE field in the destination document.

If you format the paragraph containing the INCLUDE field with the same
formatting that is applied to the last paragraph of the source
document, the formatting of the last paragraph in the source document
does not change when you include it.
 
Steps to Reproduce Behavior
---------------------------

1. Type two lines of text in a blank document.

2. From the Format menu, choose Paragraph, and type "2" (without the
   quotation marks) in the Line box under Spacing.

3. From the File menu, choose Save, name the document, and choose the
   OK button.

3. From the File menu, choose New, and choose the OK button.
  
4. From the Insert menu, choose File. Select the Link check box,
   select the file created above, and choose the OK button.

The included text is single-spaced. To correct the problem, select the
paragraph that contains the INCLUDE field and change its formatting to
double-spaced.

Word for Windows version 2.0 retains the source document's last
paragraph mark when it is included so that it is unnecessary to format
the paragraph containing the INCLUDE field.



Reference(s):

"Microsoft Word for Windows User's Reference," version 1.x, pages 98-99

"Microsoft Word for Windows User's Guide," version 2.0, pages 246-248,
567

Additional reference words: w4wformat 1.0 1.1 1.1a 1.00 1.10 1.10a
2.00 wm_word 6.00



APO Moves to Next Page with Text Inserted Above
Article ID: Q73595
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

If an object is absolutely positioned with the Format Position command
in Microsoft Word for Windows and you insert text or graphics above
the absolutely positioned object (APO) so that in normal or draft view
the APO is below a page break, Word moves the APO to the next page.

MORE INFORMATION
================

Absolute positioning secures an item in a certain location on the
page; however, if you insert text or graphics above the APO so that
the item moves to the next page in normal or draft view, the object
moves to its designated position on the next page.

To bring the positioned item back to the correct page, follow these
steps:

1. On the View menu, choose Normal or Draft. Turn on Show All by
   choosing the asterisk button on the ribbon.
 
2. Select the item and its accompanying paragraph mark. From the Edit
   menu, choose Cut.

3. Position the insertion point on the correct page in a location high
   enough above the page break to allow the item to fit on the page.

4. From the Edit menu, choose Paste.

The picture returns to its designated position on the page.

Additional reference words: w4wformat 6.00 wm_word 
1.0 1.00 1.1 1.10 1.1a 1.10a 2.0 2.00
frame 



WinWord: Underline Doesn't Work with Spaces at End of Line
Article ID: Q75211
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, if a line formatted to be underlined in
a table or document contains only spaces, the line will not be
underlined. In the same manner, if a line with underline formatting
ends in spaces, the spaces will not be underlined.

MORE INFORMATION
================

There must be at least one character at the end of a line for
underline formatting to be applied. Valid characters that will take
the underline formatting are any text characters, tabs, and
nonbreaking spaces (CTRL+SHIFT+SPACEBAR).

Steps to Reproduce Problem
--------------------------

1. Open a new document.

2. Press the SPACEBAR three times.

3. Highlight the spaces.

4. From the Format menu, choose Character and select Underline to
   apply underline formatting.

The blank spaces will not be underlined, even though the ribbon will
indicate that underline formatting is applied.

If the previous steps are taken, using the TAB key or
CTRL+SHIFT+SPACEBAR instead of the SPACEBAR to create the spaces, the
underline formatting will work to underline the blank spaces.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," pages 31-33.

Additional reference words: w4wformat 6.00 wm_word 1.00 1.10 1.10a 1.0 1.1
1.1a 2.0 2.00



Placing Boxes Around Characters and Words
Article ID: Q75456
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, it is possible to put boxes around
individual letters, words, or combinations of words. Listed below are
various examples using the Equation formula field to place boxes
around characters and words.

More Information:

To put a box around an individual letter, word, or combination of
words, use the {eq} field with the \x switch. For example

   {eq \x (b) \x (o) \x (x)}

will give the following result:

   ----- ----- -----
   | b | | o | | x |
   ----- ----- -----

{eq \x (box)} will create the following result:

   -------
   | box |
   -------

You can combine more than one \x switch in a single line of text, but
the combined text and borders is limited to only one line of print. If
the entered text and borders exceeds the width of the paragraph or the
document margins, an error will display.

This field can be combined with paragraph borders and page borders to
get a nested border box effect as in the following example:

1. Insert one or more of the fields shown above.

2. Word 6.0: With the cursor still in the paragraph with the field, from 
   the Format menu select Borders and Shading and from the Borders 
   dialog choose Box 

   Word 2.0: With the cursor still in the paragraph with the field,      
   choose Border from the Format menu and click on Box to put a box      
   around the entire field. 

   Word 1.x: With the cursor still in the paragraph with the      



   field, choose Paragraph from the Format menu and choose Border     
   Box to put a box around the entire field.

The result will be a paragraph border around the border applied with a
field.

Box borders can also be nested as in the following example:

   {eq \x(\x(\x(example)))}

For more information on creating page borders, query on the
following words:

   adding and page and borders

Reference(s):

"Microsoft Word for Windows User's Reference," pages 139-140.

"Take Word for Windows to the Edge," (ISBN 1-56276-079-3) by Guy
Gallo, Ziff-Davis Press, page 338

Additional reference words: w4wformat 6.00 wm_word 
w4wfield



Vertical Justification May Split Paragraph Box Borders
Article ID: Q75541
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

In Microsoft Word for Windows, if you use box paragraph borders to
enclose paragraphs in a box, using vertical justification for the
section formatting may cause the vertical box borders to stretch to
the point that there are visible breaks or gaps in the border. This
will also occur if you enclose a table with border and set the section
to vertical justification. 

MORE INFORMATION
================

If multiple paragraphs are formatted with the Box option and the
section is set for vertical justification as outlined below, the
vertical bars of the box border appear broken unless the bordered text
fills a full page. This problem can occur in a section with any number
of columns. This problem only occurs when multiple paragraphs are
sharing a box border.

Version 2.0 of Word for Windows
-------------------------------

Vertical alignment is set in version 2.0 of Word for Windows by
choosing Section Layout from the Format menu and selecting either Top,
Center, or Justified for the Vertical Alignment option. Choosing
Justified stretches the space between paragraphs.

Paragraph borders are applied by choosing Border from the Format menu
and selecting the desired options from the Border, Line, and Preset
boxes. Refer to page 362-379 of the "Microsoft Word for Windows User's
Guide" for instructions.

Version 1.x of Word for Windows
-------------------------------

Vertical alignment is set in version 1.x of Word for Windows by
choosing Section from the Format menu and selecting either Top,
Center, or Justified for the Vertical Alignment option. Choosing
Justified stretches the space between paragraphs.

Paragraph formatting is applied by choosing Paragraph from the Format
menu and selecting the desired options from the Border and Pattern
boxes. Refer to page 367 of the "Microsoft Word for Windows User's
Guide" for instructions.

Workaround
----------



To set the Vertical Alignment option to Top or Center so that the
space between paragraphs is not stretched, do the following:

1. From the Format menu, choose Section.

2. Set the Vertical Alignment option to Top or Center.

3. Choose the OK button.

   -or-

If the desired effect is a page border, use another method of placing
a border around an entire page. Refer to page 21 of the "Microsoft
Word for Windows User's Reference" or page 367 of the "Microsoft Word
for Windows User's Guide" for instructions.)

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.x, pages 21,
251-252, 315

"Microsoft Word for Windows User's Guide," version 2.x, pages 367-379

Additional reference words: w4wformat 6.00 wm_word 

1.00 1.10 1.10a 2.00 2.00a table



Automatic Styles Cannot Be Deleted or Renamed in WinWord
Article ID: Q75739
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

Microsoft Word for Windows has 34 automatic styles, predefined styles
used for such things as headers, table of contents entries, and so on.
Most do not appear in the Style box on the ruler until they are used.
Once any of these styles has been used, it will show in the list of
Styles on the Ruler. Creating your own styles adds to the list,
increasing its length.

Workaround
----------

Added "user-defined" styles may be added to the top of the Styles list
by beginning all of the names with a period ".". Style names beginning
with a period will be displayed before names beginning with a letter.
Style names beginning with a period will be sorted alphabetically
within that group of names.

To create a style to be added to the top of the Style list, do the
following:

1. Create a line of text containing the desired formatting for the new
   style.

2. Select the text and choose Define Styles from the Format menu.

3. Type the new style name, beginning with a period (.) to add the
   style to the top of the list.

4. Choose OK.

This style name will now appear first in the list of styles.

REFERENCES
==========

"Microsoft Word for Windows User's Reference" pages 342-349

Additional reference words: w4wformat 6.00 wm_word 
1.0 1.1 1.1a 1.00 1.10 1.10a  2.0 2.00



Tab After Hanging Indent Is Ignored in Word for Windows
Article ID: Q75875
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 2.0, 2.0a, 2.0a-CD,
   2.0b
---------------------------------------------------------------------

SYMPTOMS
========

The first tab on the first line of a hanging indented paragraph in
Microsoft Word for Windows will be ignored if it is inserted after
the left indent.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Steps to Reproduce Problem
--------------------------

1. In a new document, create a hanging indent by pressing CTRL+T on
   the keyboard. This should leave the first line with no indent and
   create a left indent at 0.5 inches (this depends on default tab
   stops in format/document) for the rest of the paragraph.

2. Set a tab after the indent, by clicking the ruler below the 1.25
   inch mark.

3. Type just a couple of characters and then press the TAB key to move
   to the 1.25 tab set on the ruler.

The cursor will jump to the left indent mark (.5 inch) set by the
hanging indent instead of the 1.25 tab.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," pages 143-145

Additional reference words: w4wformat 1.00 1.10 1.10a 1.0 1.1 1.1a
2.00 2.0 2.0a 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD 



Word for Windows Returns Incorrect Number of Columns
Article ID: Q77133
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
---------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, if you select the rows of a column and
the end-of-row markers and choose Table from the Format menu, Word
returns an incorrect result for the number of columns.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Steps to Reproduce Problem
--------------------------

1. From the Insert menu, choose Table to insert a table with one row
   and two columns.

2. Select all the columns in the the row and the end-of-row markers.

3. Choose Format Table.

In Word for Windows 2.0 follow these steps:

1. From the Table menu, choose Insert Table to insert a table with
one row and two columns.

2. Select all the columns in the the row plus the end of row
markers.

3. From the Table menu, choose Column Width.

The dialog box displays the width of columns 1-3, even though only two
columns exist in the table.

Additional reference words: w4wformat 1.00 1.10 1.10a 2.0 2.00 2.0a
2.00a 2.0b w4wtable 2.0a-CD 2.00b 2.00a-CD



Continuous Section Breaks Become New Page Breaks in Landscape
Article ID: Q77233
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:
 
Continuous section breaks become next-page section breaks if you
change the page orientation or paper size in one of the sections. This
change is not reversed if you reverse the page orientation change, so
if a continuous section break becomes a next-page section break, it
must be manually changed back to continuous.

More Information:

In Microsoft Word for Windows version 2.0, you can change the page
orientation of one or more sections within the same document.

If you insert a continuous section break between sections that are
subsequently formatted for different page orientations or paper sizes
(for example, landscape and portrait), the continuous section break
becomes a next-page section break. This occurs because a single page
cannot contain both portrait and landscape orientation. Each page can
contain one orientation only.

If you later change the sections of the document back to the original
orientation or paper size, the continuous section break is not
restored. The next-page section break remains until you manually
change it back to a continuous section break using the Format Section
Layout command.

Steps to Reproduce Problem
--------------------------

Note: These steps assume that the default page-setup orientation is
portrait.

1. Create a new document and divide it into three sections, separated
   by continuous section breaks. To insert a continuous section break
   into a document, move the insertion point to the place where you want
   to insert the section break. From the Insert menu, choose Break and
   select Continuous from the Section Break portion of the dialog box.
   Choose the OK button.

2. With the insertion point positioned in the second section, from the
   Format menu, choose Page Setup. Select Size and Orientation and change
   the Orientation to Landscape. Choose the OK button.

3. From the Format menu, choose Section Layout. The Section Start is now
   New Page. Choose the Cancel button.



4. Position the insertion point in the second section. From the Format
   menu, choose Page Setup. Select Size and Orientation and change the
   Orientation to Portrait. Choose the OK button.

5. From the Format menu, choose Section Layout. Notice that the
   Section Start is still New Page; it has not changed back to
   Continuous. Choose the Cancel button.

Additional reference words: w4wformat
2.00 2.0a 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD



Tall Paragraph Mark Clipped If Text Characters Are Smaller
Article ID: Q77252
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you format a paragraph mark in a
larger point size than the text beside it, the paragraph mark can be
clipped on the screen.

More Information:

Word for Windows determines line height from the height of the
characters on the line, not the paragraph mark. If you reduce the line
height, Word clips the larger paragraph mark to fit the new line
height.

Steps to Reproduce Problem
--------------------------

1. Select Show All. Select a paragraph mark and format it for Roman
   24-point.

2. To the left of the paragraph mark, type some text.

3. Press SHIFT+HOME to select the text, and press CTRL+SPACE to remove
   the Roman 24-point formatting.

Notice that the line height decreases to match the text. You can
select the paragraph mark and format it for a smaller point size.

Additional reference words: w4wformat 6.00 wm_word 
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Character Spacing Spin Box Selects Incorrect Value
Article ID: Q77427
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you type an Expanded character spacing value into the By spin box,
Microsoft Word for Windows does not select the closest interval if
you scroll down one option using the arrows in the spin box.

More Information:
 
Word sets Expanded character spacing values at 1/4 point intervals. If
you type an invalid measurement (such as 5.35 pt.) and scroll down
using the arrow, Word selects the second closest interval instead of
the closest interval.

Steps to Reproduce Problem
--------------------------

1. From the Format menu, choose Character.

2. From the Spacing list box, select Expanded and type 5.35 pt. into
   the By spin box.
  
3. Using the spin box arrows, scroll down one option. 5 pt is
   displayed, even though 5.25 pt is the nearest valid match.

This problem does NOT occur if you scroll UP in the spin box. In the
steps above, 5.5 pt displays if you scroll up one option using the
spin box arrows instead of scrolling down.  

Additional reference words: w4wformat 6.00 wm_word 
wrong incorrect 2.00 2.00a 2.00a-CD 2.00b 2.00c  



Shading Not Imported into Word for Windows 2.0 from Excel
Article ID: Q77903
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you copy cells from a Microsoft Excel for Windows spreadsheet
through the Clipboard into version 2.x of Microsoft Word for Windows,
the cells do not retain shading. 

This problem was corrected in Word version 6.0 for Windows.

The following are four possible workarounds for this problem:

 - Use the Edit Copy Picture command in Excel to copy a bitmap image of
   the spreadsheet to the Clipboard:

   1. In Excel, select the cells to be copied.

   2. While holding the SHIFT key, choose Copy Picture from the Edit
      menu.

   3. In Word for Windows, paste the Excel selection.

 - In Excel, copy the spreadsheet to the Clipboard:

   1. In Excel, select the spreadsheet to be copied.

   2. From the Edit menu, choose Copy.

   3. From the Edit menu in Word, choose Paste Special, select Picture 
      or Bitmap as the format, and paste the worksheet image as a 
      picture.

 - In Excel, place the spreadsheet in the Clipboard using an OLE server
   application:

   1. In Excel, select the spreadsheet to be copied.

   2. From the Edit menu, choose Copy.

   3. From the Edit menu in Word, choose Paste Special and select Excel
      Worksheet Object.

 - Format the table after you insert it into Word.

More Information:

This problem occurs because Excel does not include the shading when it



places the table on the Clipboard. Word can pull shaded text from the
Clipboard. To illustrates this, follow the steps below:

1. Start Word.

2. Insert a table.

3. Format a cell in the table as shaded.

4. Copy the table to the Clipboard.

5. Quit Word and then restart Word.

6. From the Edit menu, choose Paste to insert the table into a
   document.

The pasted item is shaded. Quitting Word demonstrates that Word can
copy information sufficient to support shading on the Clipboard.

Steps to Reproduce Problem
--------------------------

1. Start Excel.

2. Type some information in a cell.

3. Format the cell as shaded.

4. Copy the cell to the Clipboard.

5. From the Edit menu, choose Paste to insert the cell back into
   Excel. The cell is shaded.

6. Quit Excel and then restart Excel.

7. From the Edit menu, choose Paste again.

The pasted item is not shaded. The information that Excel places on
the Clipboard does not contain shading information in a format that
other applications can use.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 202-203

Additional reference words: w4wformat
link embed dde 2.00  w4wtable



Colored Table Cell Border Bleeds into Next Cell in WinWord
Article ID: Q77959
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

Microsoft Word For Windows displays inconsistent corners with colored 
formatted borders. The outside gridlines bleed into the next color.

Steps to Reproduce Problem
--------------------------
 
1. Insert a three-row by two-column table.
  
2. Select the first row. From the Format menu, choose Borders.
   
3. Select the thickest line. Select red in the Colors box. In the
   Border box, select both inner and outer lines. Choose the OK button.

4. Select the second row and repeat steps 2 and 3, choosing yellow as
   the color.

5. Select the third row and repeat steps 2 and 3, choosing blue as the
   color.
 
The red cells flow into the yellow cells on the outside border, while
meeting correctly at the inner gridlines. With yellow as the top
color, the lines join the next color correctly.

STATUS
======

Microsoft has confirmed this to be a problem in Word For Windows. This
problem was corrected in Word version 6.0.

Additional reference words: w4wformat 2.00 2.00a 2.00b 2.00a-CD 



Paragraph Border Does Not Enclose Entire Paragraph in WinWord
Article ID: Q77977
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows versions 1.0, 1.1, and 1.10a,
positioning an item inside a bordered paragraph causes the border to
display incompletely on the sides touching the positioned item. The
border may not print correctly.
  
In Word for Windows version 2.0, if you insert a frame inside a
bordered paragraph, the border does not appear on the edges touching
the frame. The document also prints with the borders missing.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

Word for Windows 2.0
--------------------

1. Type a paragraph of text.
 
2. Place the insertion point in the paragraph. From the Format menu,
   choose Border. From the Preset box, select Box. From the Line box,
   select one of the Line patterns. Choose the OK button.
 
3. In the next paragraph after the bordered paragraph, type a word and
   select it. From the Insert menu, choose Frame. 
 
4. Use the mouse to drag the frame into the bordered paragraph, or use
   the Format Frame command to position the frame inside the bordered
   paragraph.
 
The portions of border that touch the positioned word disappear.

Word for Windows 1.0, 1.1 and 1.1a
----------------------------------

1. Type a paragraph of text.

2. From the Format menu, choose Paragraph and select Box from the
   border box.

3. In the paragraph following the bordered paragraph, type a word and



   select it.
 
4. From the Format menu, choose Position. Type "1 inch" (without the
   quotation marks) in the Paragraph Width box, and choose the Preview
   button.
 
5. From the Preview icon bar, choose the Boundaries button. Move the
   absolutely positioned word into the bordered paragraph. Choose the
   Page View button to return to your document.

The portions of border that touch the positioned word disappear.

Microsoft has confirmed this to be a problem in Word for Windows. We
are researching this problem and will post new information here as it
becomes available.

Additional reference words: w4wformat 6.00 wm_word apo incomplete break
broken line 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 



ANSI Characters 0 through 31 Do Not Display in WinWord
Article ID: Q78003
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

The American National Standards Institute (ANSI) allows you to create
characters by typing their ANSI codes. ANSI characters are characters
that do not appear on a standard American keyboard. Microsoft Word for
Windows versions does not display an ANSI code for decimal numbers 0-31 
and Word does not display an error message if you type a decimal number 
ranging from 0-31. The ANSI character set includes  the decimal numbers 
33-255 in Word for Windows.

MORE INFORMATION
================

To create the ANSI characters in Word for Windows, follow the steps
below:

1. From the Format menu, select Character. In the Font box, select
   Symbol.

2. Turn on NUM LOCK.

3. Hold Down the ALT key.

4. Type "0" (without the quotation marks) followed by the decimal
   number that represents the ANSI Character you want to include. You
   must use the numbers on the numeric keypad rather than the numbers
   across the top of your keyboard.

5. After you type the code, release the ALT key. Word inserts the
   character represented by the code into your document. For example, to
   create a bullet character you type ALT+0183.

Note: ANSI character number 32 is a space. If you insert this
character as shown above, it produces a single space. You can verify
this (in version 1.x) by selecting Preferences from the View menu, and
selecting Spaces or Show All. In versions 2.x and 6.0, choose Options 
from the Tool menu, choose View from the Category list, and select 
Spaces or Show All.

For more information, query on the following words:

   ANSI and characters and w4wmacro

Additional reference words: w4wformat 6.00 wm_word 



1.0 1.1 1.1a 1.00 1.10 1.10a 2.00

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.x, pages
427-428

"Microsoft Word for Windows User's Guide," version 2.0, pages 153-155

Additional reference words: w4wformat wm_word 6.00



Frame Around Shaded Paragraph Corrupts Formatting in WinWord
Article ID: Q78144
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

If you place a frame around a shaded paragraph in Microsoft Word for
Windoww, an area of white space surrounds the frame. This causes the
border and shading attributes to be split.

More Information:
 
The white space surrounding the frame varies in width. To minimize
this white space, choose Frame from the Format menu, and set the
Distance from Text option to 0 inches. The amount of white space
decreases but is not eliminated.

Steps to Reproduce Problem
--------------------------
 
1. Type a 5-line paragraph into a document in Word for Windows 2.0.
 
2. Shade the paragraph: from the Format menu, choose Border. Choose the
   Shading button, and select 25% from the Custom Pattern box.

3. Choose the OK button twice.
  
4. Insert a frame below the shaded paragraph. From the Insert menu,
   choose Frame. Use the mouse or keyboard to create a 1 inch by 1 inch
   frame. Shade the frame, as described in step 2.

5. Position the frame over the top of the paragraph created in steps 1
   and 2.
 
The paragraph shading stops short of the frame border, leaving a line
of white space around the frame.
 
Microsoft has confirmed this to be a problem in Word for Windows
versions 2.x and 6.0. We will post new information here as it becomes
available.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 377,
393-397

Additional reference words: w4wformat
2.00 2.00a 2.00a-CD 2.00b 6.00



Items Cannot Be Framed Within a Table in Word for Windows
Article ID: Q78150
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you cannot frame items within a table. 
Depending upon the conditions, different results occur when you attempt 
to frame items in a table. The results of four
different scenarios are listed below.

More Information:

Scenario #1 - Framing a Picture with Only the Picture Selected
--------------------------------------------------------------

1. From the Table menu, choose Insert Table, or select the Table
   button on the tool bar. Format the table with two columns and two
   rows.

2. Position the insertion point in a table cell. From the Insert menu,
   choose Picture. Select a picture to insert, and choose the OK button.

3. Select the picture by clicking inside the picture. Small square
   boxes appear around the picture. 

4. From the Insert menu, choose Frame.

Result: The Frame option is not available.

Scenario #2 - Framing a Picture If the Whole Cell is Selected
-------------------------------------------------------------

1. Repeat steps 1 and 2 in Scenario #1. Select the whole cell by
   placing the insertion point before the picture and holding down the
   SHIFT key while you press the RIGHT ARROW key twice, or by clicking
   and dragging the insertion point until the whole cell is selected.

2. From the Insert menu, choose Frame.

Result: The whole row is framed and can be positioned.

Scenario #3 - Selecting the Whole Cell Including Text
-----------------------------------------------------

1. Repeat steps 1 and 2 in Scenario #1. Enter text within a cell and
   select it. With the insertion point at the beginning of the text
   within the cell, press SHIFT+END, or click and drag the mouse until
   the whole cell is selected.



2. From the Insert menu, choose Frame.

Result: The entire row is framed and can be positioned.

Scenario #4 - Selecting Only the Text Within a Cell
---------------------------------------------------

1. Repeat steps 1 and 2 in Scenario #1. Enter text within a cell and
   select the text only (do not include the end-of-cell marker in the
   selection).

2. From the Insert menu, choose Frame.

Result: The Frame option is not available.

Reference(s):

"Microsoft Word for Windows User's Guide," pages 314-323, 393-397

Additional reference words: w4wformat w4wtable 6.00 wm_word 
2.00 2.00a 2.00a-CD 2.00b 2.00c



WinWord: Framed Items Overlap and Redraw Incorrectly
Article ID: Q78163
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, if you position a framed picture over
another framed picture, one of the pictures appears to redraw
incorrectly, producing a gap. This gives the appearance that one
picture is larger than the other even if both pictures are the same
size. 

STATUS
======
 
Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.
 
To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

WORKAROUND
==========

To correct this problem, select the top framed picture and
choose Frame from the Format menu. Set the Distance From Text box to
zero (0) and choose the OK button.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

Version 1.x of Word for Windows
-------------------------------

1. From the Insert menu, choose Picture. Press ENTER to add an extra
   paragraph mark after the picture for positioning purposes.

2. Insert a second picture below the first one.

3. To position the pictures, follow these steps:



   a. Select one of the pictures.

   b. From the Format menu, choose Position. From the Horizontal Position
      box, select Margin. Choose the OK button.

   c. Repeat steps a and b for the second picture.

4. From the File menu, choose Print Preview. Choose the Boundaries
   button. Use the mouse or keyboard to position one of the pictures over
   a corner of the other picture.

The bottom picture redraws incorrectly. A band of white space displays
between the border of the top picture and the redrawn bottom picture.

Version 2.0 of Word for Windows
-------------------------------

1. From the Insert menu, choose Picture. Press ENTER to add an extra
   paragraph mark below the picture. Insert another picture below the
   first one.

2. Select the first picture. From the Insert menu, choose Frame.
   Repeat this step for the second picture.

3. Select the View menu and verify that you are in page layout view.

4. Use the mouse or keyboard to position one of the pictures over a
   corner of the other picture.

The same result occurs as in Word version 1.x. The bottom picture
redraws incorrectly; the frame of the top picture extends beyond the
picture, not allowing the bottom picture to fully redraw.

The printed accuracy of these pictures depends on the printer and the
printer driver you use. Some printer drivers print the two pictures
incorrectly (as they appear on the screen). Other printer drivers
print the two pictures correctly (as they should appear on the
screen).

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.x, pages
258-259

"Microsoft Word for Windows User's Guide," version 2.0, pages 393-397,
419

Additional reference words: w4wformat 1.00 1.10 1.10a 2.00 2.00a-CD
2.00b superimpose overlay 



WinWord Column Selection Lost After Formatting Characters
Article ID: Q78244
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, if you use CTRL+SHIFT+F8 or the right
mouse button to select a column of text and then apply character
formatting, the text does not remain selected after you apply the
formatting.

MORE INFORMATION
================

When you press CTRL+SHIFT+F8, the Column Selection mode activates, and
you can use the arrow keys to select a column of text. You can also
use the right mouse button to select a column of text. If you apply
character formatting to the selected text, the width of the characters
changes. This can cause the column selection to no longer be accurate.
Therefore, the text selection is lost when character formatting is
applied.

REFERENCES
==========
 
"Microsoft Word for Windows User's Reference," page 318
"Microsoft Word for Windows User's Guide," page 106

Additional reference words: w4wformat 1.0 1.1 1.00 1.10 1.10a 1.1a 2.0 2.00 
2.0a 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD wm_word 6.00



Hidden Text to the Left of Selection Becomes Part of Selection
Article ID: Q78493
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, if your document includes hidden text
that is not currently displaying, any hidden text to the immediate
left of a highlighted selection becomes included with that selection.
If you cut and paste or copy the selection, the hidden text copies or
pastes with the selection.

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New. Type "aaa1bbb2ccc" (without the
   quotation marks).
 
2. Select bbb from the above text. From the Format menu, select
   Character (Format Font in version 6.0), choose Hidden, and click the 
   OK button.
 
3. Ensure that the Hidden Text and Display All options are not
   selected. (From the version 1.x View menu, choose Preferences to
   verify Hidden Text and Show All are not selected. From the version 
   2.0 Tools menu, choose Options, and select the View category.
   Verify that Hidden Text and All are not selected. From the version 
   6.0 Tools Menu, Choose Options, and select the View Tab Option).

4. Select the number 2 from the text you typed in step 1.

5. Set your display to show Hidden Text by following the appropriate
   instructions in step 3.

The hidden text becomes highlighted as well as the normal text you
selected.

If you type text immediately after making the selection, the text is
formatted as hidden text. This text does not display as you type it if
the Hidden Text option is not selected. If you copy or paste a
selection that includes hidden text to the immediate left of the
selection, that hidden text copies with it. Hidden text to the right
of the selection is not affected.

To avoid this situation, make sure you select the Hidden Text option
to view all hidden text.

Additional reference words: w4wformat 6.00 wm_word 
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Inserting a Frame Overwrites Border Information in WinWord
Article ID: Q78534
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======
  
In Microsoft Word for Windows, inserting a frame into a paragraph with a
border causes the border information to be distorted.
   
Inserting a frame around the first character is a convenient method to
insert a dropped capital letter; however, this method does not work if
the paragraph has a formatted border.

Steps to Reproduce Problem
--------------------------
   
1. Type at least three lines of text in a paragraph.
 
2. Select the paragraph.
 
3. From the Format menu, choose Border, select any style, and place
   the border around the paragraph. Choose the OK button. (In version 
   6.0 from the Format menu choose Borders and Shading select the 
   Borders Tab and Box under Presets, select any style line. Choose the 
   OK button).

4. Select the first character of the paragraph.

5. From the Insert menu, choose Frame.
  
The upper left-hand corner of the border covers the top of the framed
character. This border moves with the framed character.
   
For more information on dropped capital letters, refer to the section
titled "Setting Up a Dropped Capital Letter" in the "Microsoft Word
For Windows User's Guide," pages 416-417.

Additional reference words: w4wformat 6.00 wm_word display dropcap 2.00
2.00a 2.00a-CD 2.00b 2.00c



Negative Indents Change to Zero with Numbered or Bulleted List
Article ID: Q78693
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:
   
In Microsoft Word for Windows, if you format text with a negative left 
indent and create a bulleted or numbered list from that text, the 
negative left indent reverts back to zero.
   
Steps to Reproduce Problem
--------------------------
 
1. Type three lines of text in a new document. Select the text.
      
2. In Word 6.0, from the Format menu, choose Paragraph and select the 
   Indents and Spacing Tab Option. In Word 2.x, from the Format menu, 
   choose Paragraph. 

   In the Indentation box, change the From Left value to -0.25 inches 
   and Choose OK.

3. From the Tools menu, choose Bullets and Numbering. Choose the
   Bullets or Numbered List option, and choose the OK button. In version 
   6.0 from the Format Menu, choose Bullets and Numbering, then select 
   the Bulleted Tab Option. Choose the size and style of bullet and then 
   OK.
 
The text changes to a bulleted or numbered list and the left indent
returns to zero. Select the text, and choose Paragraph from the Format
menu. The left indent displays zero inches.

Additional reference words: w4wformat 6.00 wm_word 
2.00 2.00a 2.00a-CD 2.00b 2.00c 2.00c-CD



Infinite Repagination Occurs with Header Text in Large Points
Article ID: Q78729
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

In Microsoft Word for Windows version 2.0, an infinite repagination
occurs if you delete a character in a header that is formatted with a
point size larger than one-half of the document page size. This occurs
if you are using a font that can be scaled to a large point size.

This problem was corrected in Word version 6.0 for Windows.

Steps to Reproduce Problem
--------------------------

1.  Open a new document. From the View menu, choose Page Layout.

2.  From the View menu, choose Header/Footer.

3.  Select Header, and choose the OK button.

4.  Select a font from the tool bar that can be scaled to 127 points
    (such as Modern). Leave the point size at 10 or 12 points.

5.  Type the word "test" (without the quotation marks), and press
    RETURN.

6.  Press the F4 key four times to repeat the text.
  
7.  Select the text, and format it for 127 points by selecting the
    Points box on the tool bar.

8.  Scroll down so that you can see the second line of text.
  
9.  Click your mouse outside the selected text to remove the
    selection.
  
10.  Move the insertion point to the end of the second line and press
     the DEL key.
 
The document begins flashing to indicate Word is repaginating.
Repagination continues until you click your mouse. This occurs because
the text is at the edge of the largest possible header size, and the
repagination only partially succeeds. Word for Windows waits until the
next idle period to try again. Clicking the mouse button stops the
repagination.

Additional reference words: w4wformat





WinWord Frame at the Top of a Column Moves to Previous Column
Article ID: Q78750
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows version 2.0 and 6.0, if you insert a
frame at the top of a column in a multicolumn document and position
the frame relative to the column, the frame moves to the top of the
previous column.

Steps to Reproduce Problem
--------------------------
    
1. Open an existing Full Page document. From the Format
   menu, choose Columns, and format the document to be three columns. 
   
2. Position the insertion point at the top of either column 2 or 3 on
   any page of the document. From the Insert menu, choose Frame.
 
3. Select the frame. From the Format menu, and select Frame. 
  
4. Format the frame's Horizontal position to be centered Relative To 
   Column. 
  
5. Choose the OK button.
 
The frame moves to the top of the previous column.
 
Microsoft has confirmed this to be a problem in Word for Windows 
version 2.0 and 6.0. We are researching this problem and will post new
information here as it becomes available.

Additional reference words: w4wformat 6.00 wm_word 
2.00 and 6.0



WinWord Err Msg: Line Spacing Must Be at Least .01"
Article ID: Q78797
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:
 
When using the Microsoft Word for Windows Format Paragraph command, if 
you select Exactly from the Line Spacing box and type .01 in the Line 
Spacing At box, you receive the following error message:
  
   Line spacing must be at least 0.01".
 
If you type .01, the line spacing is interpreted as exactly .01 lines.
To be interpreted as inches, you must type .01". Typing .01 sets the
line spacing to .01 lines, which is less than .01 inches.

More Information:

Steps To Reproduce Problem
--------------------------

1. Type a paragraph of text.
 
2. From the Format menu, choose Paragraph. In version 6.0 Microsoft
    Word for Windows select the Indents and Spacing Tab Option.
  
3. In the Line Spacing box, select Exactly. Type .01 in the Line
   Spacing At box.

4. Choose the OK button.

Microsoft is researching this problem and will post new information
here as it becomes available.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 185

Additional reference words: w4wformat 6.00 wm_word 
2.00 2.0a 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD



WinWord: Removing Frame Does Not Remove Border
Article ID: Q78922
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:
  
If you insert a frame in a Microsoft Word for Windows version 2.0
document, Word also places a border around the frame. This allows you
to see the boundaries of the frame. If you remove the frame the border
remains intact.

This problem was corrected in Word version 6.0 for Windows.

Steps to Reproduce Problem
--------------------------

1. Type "test" (without the quotation marks).
 
2. Select "test."
 
3. From the Insert menu, choose Frame.
 
4. From the Format menu, choose Frame, and select Remove Frame.

The frame disappears, but the border remains.

Workarounds
-----------

To work around this problem, use one of the following methods: 
   
 - From the Format menu, choose Border, and set the borders to None.

  -or-
 
 - Press CTRL+Q to remove the frame and border if you do not need to
   maintain your paragraph formatting; CTRL+Q resets paragraph
   formatting.

References:

"Microsoft Word for Windows User's Guide," version 2.0, page 397

Additional reference words: w4wformat
2.00 2.00a 2.00a-CD 2.00b 2.00c



WinWord: Colored Text Not Displaying on VGA Monochrome Monitor
Article ID: Q78936
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows version 2.0 and 6.0, formatting text with
certain colors on a VGA monochrome monitor results in the text not
displaying.

More Information:

These colors are all visible as shading or borders. This problem
occurs if you create a document with these colors or if you open a
document that uses these colors because none of the color-formatted
text is visible.

Steps to Reproduce Problem
--------------------------

1. Type some text, and select it.

2. From the Format menu, choose Character (in Word for Windows 6.0
   choose Font).

3. Select Magenta, Cyan, Yellow, Lt Gray, or Gray in the Color box.

4. Choose the OK button.

None of these text colors display in Sample box or in the document.
 
Microsoft has confirmed this to be a problem in Word for Windows
version 2.0 and 6.0. We are researching this problem and will post new
information here as it becomes available.
  
Word for Windows version 1.x does not have the colors Lt Gray and
Gray, nor does it have a Sample box for viewing; therefore, version
1.x does not exhibit this problem.

Additional reference words: w4wformat see gone disappear 6.00 wm_word 
hidden 2.00 2.00a 2.00b 2.00a-CD



WinWord: Position Header Overrides Paragraph Formatting
Article ID: Q78937
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0  
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

If you position a header or footer using a frame in Microsoft Word for
Windows, the paragraph formatting for Page Break Before is overridden.

MORE INFORMATION
================

To avoid this problem, do not insert a frame into the header/footer;
instead, choose Paragraph from the Format menu, and apply your
formatting.

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New, and choose the OK button. From the
   View menu, choose Normal.

2. Type a word, and press ENTER.

3. On the second line, type a few words.

4. Select the first line. From the Insert menu, choose Frame. From the
   Format menu, choose Frame, and select Vertical Position to Center.

5. Select the second line. From the Format menu, choose Paragraph, and
   select Page Break Before.

6. From the View menu, choose Header/Footer, and close the Header
   pane by clicking the Close button.

7. A dotted line should appear between the two lines of text, and the
   status bar should read two pages.

8. From the View menu, choose Header. From the Insert menu, choose
   Frame. From the Format menu, choose Frame, and select Horizontal
   Center to position the Header.

Before you close the Header pane, the dotted line disappears. If you
close the header, the status bar only reads one page. If you print the
document, the first line is centered vertically and the header is
centered horizontally as expected. However, the second line appears on
the same page rather than on the next page as stipulated.



Additional reference words: 6.00 w4wformat 2.00 2.00a 2.00a-CD 2.00b
2.00c wm_word



WinWord: Horizontal Frames Switch Sides on Consecutive Pages
Article ID: Q78951
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you format a frame (version 2.0) or
an absolutely positioned object (APO) (version 1.x) for a Horizontal
Outside position, and you create it on two or more consecutive pages,
Word places the frame or APO on opposite sides of the consecutive
pages.

More Information:

Objects that you position as Horizontal Outside on two consecutive
pages are positioned on the right side of the first page and the left
side of the second page. This problem occurs even if you do NOT select
the Facing Pages option in the Page Setup dialog box (version 2.0) or
the Mirror Margins option in the Document dialog box (version 1.x).

Steps to Reproduce Problem
--------------------------

Word Version 2.x and 6.x
------------------------

1. Type a line of text, and press ENTER.

2. Select the paragraph of text.

3. From the Insert menu, choose Frame.

4. From the Format menu, choose Frame. In the Horizontal box, select
   Outside, and select Margin in the Relative To box. In the Vertical
   box, select Center, and select Margin in the Relative To box.

5. Choose the OK button.

6. Position the insertion point to the right of the frame, and press
   ENTER.

7. Select the frame. From the Edit menu, choose Copy. Position the
   insertion point in front of the second paragraph mark below the 
   frame. From the Edit menu, choose Paste.

8. Position the insertion point in front of the empty paragraph mark
   between the two frames. From the Insert menu, choose Break. Select
   Next Page in the Section Break dialog box, and choose the OK button.



9. From the File menu, choose Print Preview to compare the two pages. 
   The text is positioned on the right side of the first page and the
   left side of the second page.

Word Version 1.x
----------------

1. From the Insert menu, choose Picture. Select the New Picture
   option, and choose the OK button.

2. Select the empty picture frame.

3. From the Format menu, choose Position.
 
4. In the Horizontal box, select Outside, and select Page in the
   Relative To box. In the Vertical box, select Center, and select
   Margin in the Relative To box. Choose the OK button.

5. Press the ENTER key twice to insert two paragraph marks after the
   picture. Position the insertion point in front of the second 
   paragraph mark. From the Insert menu, choose Break. Select Next Page 
   in the Section Break dialog box, and choose the OK button.

6. Repeat steps 1 through 4 on the second page.

7. From the File menu, choose Print Preview to compare the two pages.
   The text is positioned on the right side of the first page and the
   left side of the second page.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 405

Additional reference words: w4wformat 6.00 wm_word 
switch 1.00 1.10 1.10a 2.00 2.00a 2.00b 2.00a-CD 



WinWord: Inserting a Page Break Within a Justified Paragraph
Article ID: Q79085
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you insert a hard page break in a
justified paragraph, the last line of text preceding the page break
justifies regardless of the number of words on the line. If there are
few words on this line, large gaps appear between each word.

More Information:

If you insert a hard page break in a justified paragraph, Word for
Windows behaves as if you inserted a newline character in the
paragraph at that point. The words on that line justify regardless of
the amount of space required between each word.

Workaround
----------

To correct this problem, insert a paragraph mark (press ENTER) before
you insert the hard page break. This causes the last line of the
paragraph to be left-aligned rather than justified.

Steps to Reproduce Problem
--------------------------

1. Create a new document, and type a line of text.

2. From the Format menu, choose Paragraph. Select Justified in the
   Alignment box, and choose the OK button.

3. Position the insertion point in the middle of the text. Press
   CTRL+ENTER to insert a page break.
 
For more information on breaks within justified paragraphs:
   
 - Search for "justifying text" and "page breaks: inserting and 
   removing" using the Help menu.

 - Query on the following words in the Microsoft Knowledge Base:
 
      justify and paragraph and new and line and hotspot
  
Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 166-168,
434-435



"Microsoft Word for Windows User's Reference," version 1.x, pages 4-5,
169-170, 243, 245

Additional reference words: w4wformat 6.00 wm_word 
1.0 1.1 1.1a 1.00 1.10 1.10a 2.00 6.0 left right gap



WinWord: Cannot Use Edit Repeat Table Formatting with Ruler
Article ID: Q79130
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When using the ruler mode and a mouse to format a table in Microsoft
Word for Windows, The Repeat Table Formatting command is not available
on the Edit menu.

More Information:

Steps to Reproduce Problem
--------------------------

Word Version 2.x and 6.x
------------------------
  
1. From the Table menu, choose Insert Table. Specify a 2-column, 
   2-row table, and choose the OK button.
 
2. From the View menu, choose Ruler if it is not already selected. If
   it already checked (selected), press ESC to cancel.

3. The table-width markers display by default.
  
4. Select the first cell of the table, and drag the table-width marker
   on the ruler to change its width.

5. Select the first cell of the second row, and open the Edit menu.
  
The Repeat command on the Edit menu reads "Repeat Insert Table." You
cannot repeat a cell or column formatting change that was made with
the ruler.

Word Version 1.x
----------------
  
1. From the Insert menu, choose Table. Specify a 2-column, 2-row
   table, and choose the OK button.
 
2. From the View menu, choose Ruler if it not already selected. If it
   is already checked (selected), press ESC to cancel.
 
3. Choose the Ruler icon (at the far-right end of the ruler) to
   display the table width markers.
 
4. Select the first cell of the table, and drag the table-width marker
   on the ruler to change its width.



5. Select the first cell of the second row, and open the Edit menu.
  
The Repeat Formatting command is not viewable on the Edit menu.

Microsoft has confirmed this to be a problem in Word for Windows
versions 1.x, 2.x and 6.0. We are researching this problem and will post 
new information here as it becomes available.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 316, 331-
333

"Microsoft Word for Windows User's Reference," version 1.x, page 369

Additional reference words: w4wformat w4wtable 6.00 wm_word 
repeat 2.00 2.00a 2.00a-CD 2.00b 2.00c 1.00 1.10 1.10a 1.1a 6.00 



WinWord: Section Layout Displays Incorrect Name for the Break
Article ID: Q79132
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When you select a section break in a Microsoft Word for Windows
document, the Section Layout dialog box displays the attributes of the 
previous section rather than displaying the type of section break 
highlighted. A section break marks the end of a section; therefore, the 
Section Layout dialog box displays the properties of the preceding 
section.

More Information:

To view or select section breaks on the screen, Word for Windows
versions 2.0 and 6.0 must be in normal view. Choose the Normal View icon 
on the tool bar, or verify Normal is selected on the View menu.

Steps to Reproduce Problem
--------------------------

1. In a new document, type "section 1," (without the quotation marks),
   and press the ENTER key twice to create a blank line beneath the 
   text.

2. From the Insert menu, choose Break. In the Section Break box,
   select Continuous, and press the OK button. Press the ENTER key twice
   to create another blank line beneath the section break.

3. Type "section 2," (without the quotation marks), and press the
   ENTER key twice.

4. From the Insert menu, choose Break. In the Section Break box,
   select Next Page, and press the OK button. Press the ENTER key twice
   to create another blank line beneath the section break.

5. Select the first double-dotted line, which represents the first
   section break. Note that the status bar reads "Sec 2," indicating 
   that you are in Section 2. From the Format menu, choose Section 
   Layout in Word for Windows 2.0. In Word for Windows 6.0 from the File 
   menu, choose Page Setup then select the Layout Tab Option. . The 
   Section Start box displays "New Page" even though Section 2 was 
   formatted with a Continuous section break.

6. Select the second section break. Note that the status bar reads
   "Sec 3," indicating that you are in Section 3. From the Format menu,
   choose Section Layout in Word for Windows 2.0. In Word for Windows 
   6.0 from the File menu, choose Page Setup then select the Layout Tab 



   Option. The Section Start box displays "Continuous," even though 
   Section 3 was formatted with a New Page section break.

Microsoft has confirmed this to be a problem in Word for Windows
version 2.0 and 6.0. We are researching this problem and will post new
information here as it becomes available.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 236

Additional reference words: w4wformat 6.00 wm_word 
2.00 2.00a 2.00a-CD 2.00b 2.00c



Paragraph Borders Are Erratic If Used with a Framed Object
Article ID: Q79264
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, if you place a framed object inside a 
paragraph or group of paragraphs formatted with a border, that border 
behaves erratically. The following problems may occur:

1. If the framed object is near the edge of the border, portions of
   the border disappear.

2. If you insert the framed object into a group of paragraphs that
   have a common border, the border becomes fragmented into pieces
   associated with individual lines of text. You must reset the borders
   to surround individual paragraphs.

3. If you insert the framed object into a group of paragraphs without
   a common border and then insert a common border around the group of
   paragraphs, the border becomes fragmented. In addition, Word for
   Windows places a border around the object itself. If you attempt to
   remove this border by choosing Border from the Format menu, the 
   dialog box shows that there is no border; however, the borders do 
   print correctly.

4. The border arrangements vary between page layout and print preview
   modes.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this problem,
and will post more information here in the Microsoft Knowledge Base as it
becomes available.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. Open a new document.

2. Type several lines of text.

3. Select the text. From the Format menu, choose Border and Shading.



4. Select a border, and choose the OK button.

5. Position the insertion point within the text.

6. From the Insert menu, choose Picture.

7. Select a picture file, and choose the OK button. The picture should
   now be within the paragraph.

8. Select the picture. From the Insert menu, choose Frame.

The border behaves as described in the first problem above. Modify the
text as necessary to duplicate the other problems.

Additional reference words: w4wformat  6.00 wm_word 
2.00 2.00a 2.00a-CD 2.00b 2.00c



Narrow Page Width Crops Text Columns Display in WinWord
Article ID: Q79265
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows version 2.x, if you set the page width
of a document to less than 4 inches, Word for Windows crops the
right-hand side of the display of columns that appears when you press
the Text Columns button.

This problem was corrected in Word version 6.0 for Windows.

More Information:
 
Word for Windows truncates the Text Columns display to reflect the
maximum number of minimum-width columns that you can insert in a
reduced page width document. You can increase the number of columns
that can be inserted by decreasing the Space Between Columns setting
(the default is 0.5 inch) in the Columns dialog box. For example, if
you change the space between columns to 0 inches, the Text Columns
display is still cropped; however, this occurs only at page widths
smaller than 0.5 inch.

As the document's page width decreases, the Text Columns display
becomes more severely cropped. This truncation occurs in the following
increments:

   Page Width (in Inches)       Number of Columns Displayed
   ----------------------       ---------------------------

   4 and up                     4
   3 to 4                       3
   2 to 3                       2
   1 to 2                       1
   less than 1                  0

Steps to Reproduce Problem
--------------------------

Note: The tool bar must be active before performing these steps; from
the View menu, choose Toolbar unless it is already chosen (if it is
already checked, press ESC).
 
1. From the File menu, choose New, and choose the OK button.

2. From the File menu, choose Page Setup, and select the Margins
   option. Select 3" in the Left and Right margin boxes, and choose the
   OK button.



3. Choose Text Columns button. The right side of the display is
   truncated; only two columns display.

Microsoft has confirmed this to be a problem in Word for Windows
version 2.0. This problem was corrected in Word version 6.0 for Windows.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 348-353

Additional reference words: w4wformat newspaper style 2.00 drop down 
drop-down



Formatting Text to Default Font With Mouse Does Not Work
Article ID: Q79269
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you can change the character formatting
of a selection by holding down the CTRL+SHIFT key combination while
you point and click the left mouse button on text that contains the
desired character formatting. The selected text takes on the character
formatting of the text you click. Character formatting includes all
options available in the Character dialog box.
 
This procedure works as described above to apply all character
formatting except the default font, which is determined by the Word
for Windows Setup program.

This functionality was changed in Word version 6.0 for Windows.

More Information:
 
The default font is determined differently in Word for Windows version
1.x and 2.0. In version 2.0, Word uses the default printer font, which
is the primary font of the default printer driver listed in the
WIN.INI file. When using Microsoft Windows version 3.0, the following
fonts are used with the corresponding printer drivers as the default
printer font in Word for Windows version 2.0:
 
Default Printer Driver  Version         Default Printer Font
----------------------  -------         --------------------

HP LaserJet III         3.85 (HPPCL5A)  CG Times, 10-pt
HP LaserJet II          3.4 (PCL/HP)    Courier, 10-pt
Generic Text Only       3.0             Roman 10 CPI, 10-pt
  
In Word for Windows version 1.x, Tms Rmn 10-pt is always designated as
the default font, regardless of the default printer. The font that
actually prints is determined by the printer driver, as described for
version 2.0 above. 
 
Redefining your default font in the Word for Windows NORMAL.DOT file
does not change the default print font.

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New, and choose the OK button.
 
2. Type two lines of text, separated by two paragraph returns, as



   shown in the following example:

   line one

   line two
 
3. Select the second line of text. From the Format menu, choose
   Character. Select Modern in the Font box, and select 16 in the Points
   box. Choose the OK button.
 
4. With the second line still selected, hold down CTRL+SHIFT, then
   point and click the first line of text.

This should change the character formatting of the second line of text
to reflect the character formatting of the first line. However, if you
format the first line of text with the default printer font (in
version 2.0) or with Tms Rmn (in version 1.x), the second line does not
change.
 
Note: To demonstrate the correct behavior of this feature, select the
first line, press SHIFT+CTRL, then point and click the second line.
The formatting of the first line changes to the Modern font in 16-pt.
 
Microsoft has confirmed this to be a problem in Word for Windows
versions 1.0, 1.1, 1.1a, and 2.0. This problem was corrected in Word 
version 6.0 for Windows.

Reference(s):
 
"Microsoft Word for Windows User's Guide," version 2.0, page 152
 
"Microsoft Word for Windows User's Reference," version 1.x, page 208
 
Additional reference words: w4wformat w4wfont 2.00 1.00 1.10 1.10a



WinWord: Search Text Not Found After Changing Measurement Unit
Article ID: Q79273
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

If you change the unit of measure in Microsoft Word for Windows,
paragraph formatting may not be detected during a search. For example,
if you create a paragraph in a document with indents measured in
centimeters, save the document, and later open it with inches as the
unit of measure, a search for paragraphs using an inch measurement
yields the following error message:

   The Search Text Is Not Found

This problem also occurs if your unit of measure is a unit other than
inches and you apply indent formatting to some paragraphs using the
Indent toolbar button (or by pressing CTRL+N) and then apply indent
formatting to other paragraphs by choosing Paragraph from the Format
menu. The indent formatting you apply using the former method is
measured in inches, but the formatting you apply using the latter
method is measured in the new unit of measure, such as centimeters.
When the values do not equate exactly, Word for Windows fails to find
one of the settings. For example, 2.54 centimeters is not exactly one
inch, so 2.54 centimeters is not found if you search for all one-inch
indent formatting.

STATUS
======

This problem was corrected in Word version 6.0 for Windows.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------
 
1. From the Tools menu, choose Options. Select the General category.
    
2. In the Measurement Units box, select Centimeters, and choose the OK
   button.
 
3. Create a new Word for Windows document. Type four short lines of
   text, being sure to press ENTER at the end of each line.
  
4. Select the second and third lines. From the Format menu, choose
   Paragraph. Type "2.54" (without the quotation marks) in the



   Indentation From Left box, and choose the OK button. Press CTRL+HOME
   to go to the beginning of the document.
   
5. From the Edit menu, choose Find. Choose the Paragraph button, and
   type "2.54" (without the quotation marks) in the Indentation From 
   Left box. Choose the OK button, then choose the Find Next button. 
   Lines two and three are successfully found. Choose the Cancel button.
 
6. From the Tools menu, choose Options. In the Measurement Units box,
   select Inches, and choose the OK button.

7. Press CTRL+HOME to return to the beginning of the document. From
   the Edit menu, choose Find. Choose the Paragraph button. Notice that
   the 2.54 previously typed in has converted to inches and now reads
   "1." Choose the OK button, then choose the Find Next button. 
  
The indented lines are successfully found, as before. However, if you
choose the Paragraph button and manually type "1" (without the
quotation marks) in the Indent From Left box, choosing the OK button
and then the Find Next button causes the error message "The Search
Text Is Not Found" to appear. The error occurs because 1 inch is not
exactly 2.54 centimeters, and the conversion of units does not account
for this small difference.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 164,
166, 260

Additional reference words: w4wformat 2.00 2.00a 2.00a-CD 2.00b



WinWord: Page Setup Selects Additional Area of Table
Article ID: Q79331
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows version 2.x, if you choose Page Setup
from the Format menu with the insertion point in a table, Word for
Windows selects either a complete row or additional rows.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Steps to Reproduce Problem
--------------------------

1. From the Table menu, choose Insert Table. Create a 3-row, 3-column
   table, and choose the OK button.

2. Position the insertion point in the second row of the table. From
   the Table menu, choose Select Row. Note that only row two is 
selected.

3. From the Format menu, choose Page Setup.

4. Choose either the Cancel button or the OK button.

Both the second and third rows are now selected. If the insertion
point is active in only one cell of the table, Word selects the entire
row containing that cell when you choose Page Setup.

Microsoft has confirmed this to be a problem in Word for Windows
version 2.x. This problem was corrected in Word version 6.0 for Windows.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 230, 320

Additional reference words: w4wformat 2.00 2.00a 2.00a-CD 2.00b 2.00c 
w4wtable



Underline Prints Broken Under Expanded Leader Tab in WinWord
Article ID: Q79434
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows version 2.0, if you insert an underline
character beneath a dot-leader tab that is formatted as expanded, the
underline character prints broken. This problem only occurs with
certain versions of the Hewlett-Packard (HP) LaserJet III driver, such
as version 30.3.85.

This problem was corrected in Word version 6.0 for Windows.

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New, and choose the OK button.

2. From the Format menu, choose Tabs.

3. Under Tab Stop Position, type 2".
  
4. Make this a dot-leader tab by choosing option 2 in the Leader box.
   Choose the OK button.
  
5. From the Format menu, choose Character, and select Single in the
   Underline box. Select Expanded in the Spacing box, and choose the OK
   button.
 
6. Press the TAB key on the keyboard.
 
These steps result in a two-inch dotted line appearing on the screen.
This line is also underlined; however, if you print to the HP LaserJet
III printer, the underline may appear broken in the printed output.

Microsoft is researching this problem and will post new information
here as it becomes available.

Additional reference words: w4wformat
2.00 laser jet



Frames Cannot Be Inserted Within Frames in Word for Windows
Article ID: Q79458
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows version 2.x, you cannot insert a frame
into or around another frame. If you try to insert a frame around text
that already contains a frame, Word for Windows combines the two
frames into one. If you try to insert a frame around text that wraps
around an existing frame, the text overlaps the original frame.

This problem was corrected in Word version 6.0 for Windows.

MORE INFORMATION
================

The following steps demonstrate the problems that occur if you try to
insert a frame into or around another frame. In page layout view,
selecting and framing a block of text that includes a
previously-framed object causes one of the following results:

 - The two frames are combined into a single frame.

 - The text is framed separately from the previously-framed object, and
   the text frame overlays the first frame.
  
 - If you frame at least half a page of text that includes a framed
   object that is positioned in the middle of the text, the text and
   previously-framed object are enclosed in a single frame; however,
   sometimes the picture remains in the middle of the text, as originally
   positioned, with text wrapping around it.

Steps to Reproduce Problem
--------------------------

Note: You must be in page layout view before performing these steps.
From the View menu, ensure that Page Layout is chosen. The following
scenarios reproduce the results described above.

Scenario 1: Two frames are combined into a single frame.
  
1. Type a multiple-line paragraph. Be sure to press the ENTER key at
   the end of the paragraph.
  
2. From the Insert menu, choose Picture. Select the CLIPART
   subdirectory from the Directories list, select a picture file, then
   choose the OK button. Press the ENTER key to insert a paragraph mark



   after the picture.

3. Type another multiple-line paragraph. Be sure to press the ENTER key
   at the end of the paragraph.

4. Select the picture.

5. From the Insert menu, choose Frame to place a frame around the
   picture.
 
6. Select both paragraphs, and the picture by pressing CTRL+Keypad 5.
 
7. From the Insert menu, choose Frame to place a frame around the
   selection. The frame around the picture is replaced by the frame
   around the entire selection.

Scenario 2: Two frames overlap one another.
 
1. Repeat steps 1-5 in Scenario 1 above.
    
2. If you are using the mouse, select the framed picture, and drag and
   drop the framed picture into the middle of the first paragraph so that
   text wraps around all sides of the picture. 
   
   If you're using the keyboard, select the picture. From the Format
   menu, choose Frame, and in the Horizontal Position box, select Center.
   In the Horizontal Relative To box, select Margin. In the Vertical
   Position box, select Center, and in the Vertical Relative To box,
   select Paragraph. Type 0" in the Distance From Text box, select the
   Move With Text option, and choose the OK button.
 
3. Select the first paragraph only. Using the mouse, click the
   beginning of the paragraph, and drag through the end of the paragraph.
   The framed picture is not selected.
 
4. From the Insert menu, choose Frame. The text is framed separately
   from the framed picture, and the framed text is positioned over the
   top of the framed picture.

Scenario 3: Frame around text replaces frame around picture; however,
the position of the picture is maintained relative to the text.
  
1. Type several multiple-line paragraphs. Be sure to press ENTER at
   the end of each paragraph. The typed text should cover at least half a
   page.
 
2. Position the insertion point at the end of a paragraph in the
   middle of the text. Press the ENTER key to create a blank
   paragraph.
 
3. From the Insert menu, choose Picture. Select the CLIPART
   subdirectory from the Directories list, select a picture file, and
   choose the OK button. Press the ENTER key to insert a paragraph mark
   after the picture.

4. Select the picture.



5. From the Insert menu, choose Frame to place a frame around the
   picture.
 
6. Using the mouse, drag and drop the framed picture into the middle
   of the typed text so that text wraps around all sides of the picture.
 
7. Select the text only (the framed picture should not be selected).
   From the Insert menu, choose Frame.

Microsoft is researching these problems and will post new information
here as it becomes available.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 393-395,
397

Additional reference words: w4wformat
2.00 apo absolute



WinWord: Use As Default Button Removes Bold Formatting
Article ID: Q79498
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, if you choose the Use As Default button in
the Character dialog box with the Bold option selected, the selected text
is not formatted in bold.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this problem,
and will post more information here in the Microsoft Knowledge Base as it
becomes available.

MORE INFORMATION
================

The Use As Default button changes the default character style. To make
the text bold, press CTRL+Q while the text is still selected.

Steps to Reproduce Problem
--------------------------

1. Open a new document based on NORMAL.DOT.

2. Type some text.
   
3. Select the text with the mouse or by pressing CTRL+Keypad 5.

4. Press CTRL+B to format the selection as bold.
  
5. From the Format menu, choose Character, and choose the Use As
   Default button. Choose the OK button.
  
Word for Windows removes the bold formatting from the selected text.

Additional reference words: w4wformat 6.00 wm_word
2.00



WinWord: Setting Default Tab Stop to 0" Displays Incorrectly
Article ID: Q79641
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you can set the default tab stops to
zero inches. Word accepts this setting, but the ruler still displays
the tab stops at .5 inch, which is the normal default setting. The tab
stops actually function at their minimum setting of .01 inch.

Steps to Reproduce Problem Version 6.0
--------------------------------------

1. From the File menu, choose New, and choose the OK button.
  
2. From the Format menu, choose Tabs.
   
3. Select the current setting in the Default Tab Stops box, and press
   the DEL key. Type 0" and choose the OK button.

Steps to Reproduce Problem Version 2.0
--------------------------------------

1. From the File menu, choose New, and choose the OK button.
  
2. From the Format menu, choose Tabs.
   
3. Select the current setting in the Default Tab Stops box, and press
   the DEL key. Type 0" and choose the OK button.

Steps to Reproduce Problem Version 1.x
--------------------------------------

1. From the File menu, choose New, and choose the OK button.
 
2. From the Format menu, choose Document.
   
3. Select the current setting in the Default Tab Stops box, and press
   the DEL key. Type 0" and choose the OK button.

In all versions, the default tabs are set on the ruler to .5 inch;
however, they do function as if the default tab stops were set to .01"
inch.

Microsoft has confirmed this to be a problem in Word for Windows
versions 1.0, 1.1, 1.1a, 2.0, and 6.0. We are researching this problem
and will post new information here as it becomes available.



Additional reference words: w4wformat 6.00 wm_word
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c 2.00c-CD



WinWord: Page Setup Orientation Overrides Print Setup Setting
Article ID: Q79645
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Setting the orientation of a document (portrait or landscape mode) in
the Microsoft Word for Windows version 6.0 Page Setup dialog box
overrides any selection made in the Print Setup dialog box.

More Information:
 
You can set the orientation of each page of your document individually
with the following steps:

1. From the File menu, choose Page Setup.
 
2. Select Size and Orientation. Select the Portrait or Landscape
   option in the Orientation box, and choose the OK button.

You can set the overall page orientation of your document with the
following steps:

1. From the File menu, choose Print Setup. Select Setup.
  
2. Select Portrait or Landscape in the Orientation box and choose the
   OK button.

Word for Windows does not change the orientation setting in the Print
Setup dialog box; it simply bypasses that setting for the current
print job.

Additional reference words: w4wformat 6.00 wm_word 
w4wprint 2.00 2.00a 2.00a-CD 2.00b 2.00c



WinWord: Gap Appears in Border at Line Breaks in Print Preview
Article ID: Q79753
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows version 2.0, a gap appears at each line
break of a paragraph if you apply a border and shading to that
paragraph.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New, and choose the OK button. Type a
   short paragraph.

2. From the Format menu, select Border. Apply a border and shading to
   the paragraph.

3. From the File menu, select Print Preview.

After each line break, a gap appears in the border, and a thin white
line runs across the shading.

Additional reference words: w4wformat 2.00 2.00 2.00a 2.00a-CD 2.00b 2.00c



Paragraph Indenting Produces Incorrect Results in Tables
Article ID: Q79866
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you press CTRL+T, CTRL+G, CTRL+M, or
CTRL+N with one or more cells selected in a table, the entire row or
group of rows containing the selected cells takes on the indent
formatting. If you select an entire column, the whole table becomes
formatted with the indent.

This problem was corrected in Word version 6.0 for Windows.

More Information:

CTRL+T produces a hanging indent, and CTRL+G cancels a hanging indent.
CTRL+N nests paragraphs, and CTRL+M removes nested paragraphs. These
key combinations affect the selected paragraph(s) or the paragraph
containing the insertion point when you press the key combination.

If you select more than one cell in a table, the entire row or group
of rows containing the selected cells is indented to match the
formatting of the selected cells. If you select an entire column of
text, then the entire table is indented to match the formatting of the
selected cells; however, if you use the mouse to format the paragraphs
by moving the first line indent and paragraph indent markers on the
ruler, only the selected text is affected. To adjust indents on the
ruler, the ruler must be in the mode that displays the triangular
indent markers.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 166-177,
322-323

"Microsoft Word for Windows User's Reference," version 1.x, pages
361-372, 404-405

Additional reference words: w4wformat
indentation align alignment 1.0 1.00 1.1
w4wtable 1.10 1.1a 1.10a 2.00



Removing Frame Doesn't Return Object to Its Original Location
Article ID: Q80044
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

When you frame an object or picture, Microsoft Word for Windows
version 2.x places it in a separate paragraph immediately before the
paragraph in which it was originally located. If you subsequently
remove the frame from the object, it does not return to its original
position; instead, Word for Windows places the object at the beginning
of its original paragraph. This behavior is by design; Word for
Windows does not retain information about the object's original
position in the paragraph.

This functionality was changed in Word version 6.0 for Windows.

More Information:

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New, and choose the OK button.
 
2. Type 2-3 paragraphs in the document. Position the insertion point
   in the middle of one of your paragraphs.

3. From the Insert menu, choose Object or Picture, select the file you
   want to insert, and choose the OK button.

4. Select the inserted item. From the Insert menu, choose Frame; or,
   choose the Frame button on the tool bar. Note that Word for Windows
   places the framed object in a separate paragraph immediately before
   the paragraph in which it was originally located.

5. From the Format menu, choose Frame, and choose the Remove Frame
   button.

The object or picture appears at the beginning of the paragraph you
inserted it into rather than returning to its original location in
that paragraph.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 389-419

Additional reference words: w4wformat
2.00 moved back



WinWord 2.0: Problems with DropCap Macro in NEWMACRO.DOC
Article ID: Q80497
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

This article describes two problems with the DropCap macro, supplied
with Microsoft Word for Windows:

 - The macro fails when it is run on a letter whose font size is
   greater than 14 points.

 - If you add a box border to the frame created when you run the
   DropCap macro, the bottom line of the border will neither
   display nor print.

These problems were corrected in Word version 6.0 for Windows.

More Information:

The DropCap macro is one of several macros included in NEWMACRO.DOC,
which is supplied with Word for Windows version 2.0. A dropped capital
letter is an enlarged first letter of a paragraph, positioned in the
upper-left corner of the paragraph, with the paragraph text flowing
around it to the right and below.

See page 767 of the "Microsoft Word for Windows User's Guide" for
instructions on installing the DropCap macro and other macros from
NEWMACRO.DOC.

To create a dropped capital letter, select the appropriate
character(s) and run the DropCap macro. The selected text will be
formatted for a larger font size, then a frame will be added.

Problem 1
---------

The DropCap macro fails on text larger than 14 points. If the selected
text is larger than 14 points, you will receive the following error
message:

   The measurement must be between 0.01" and 22".

Problem #2
----------

If you add a box border to the frame created when you run the DropCap
macro, the bottom line of the border will neither display nor print.



Workaround for Problems 1 and 2
-------------------------------

Type the large capital letter in a separate paragraph. Place a frame
around the letter, then add a border. Move the framed, bordered letter
into place at the beginning of the paragraph.

For information on borders, frames, and positioning, see pages
361-364, 393-395, and 401 (respectively) in the "Microsoft Word for
Windows User's Guide."

In Word for Windows 6.0, the Drop Cap feature is included under the
   Format menu.  The above documented problems do not occur.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 361-364,
393-395, 401, 416-417, 767

Additional reference words: w4wformat
2.00 drop cap newmacros.doc first line big
w4wmacro w4wfont



WinWord: Bottom Border Doesn't Display in Exact Height Frame
Article ID: Q80554
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, the bottom border of a frame with exact
height formatting does not display if the frame contains too much text.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this problem,
and will post more information here in the Microsoft Knowledge Base as it
becomes available.

MORE INFORMATION
================

If the frame contains too much text, the excess text wraps below the
frame border and cannot be seen. This causes the bottom border of the
frame to disappear while leaving the rest of the frame intact.

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New, and choose the OK button. From the
   Insert menu, choose Frame to insert an empty frame.

2. If you are prompted to change to Page Layout View, choose the Yes
   button.

3. From the Format menu, choose Frame.

4. In the Size box, set the height to Exactly 1", and choose the OK
   button.

5. Position the insertion point in the frame, and fill the frame with
   text until it wraps below the bottom border.

The bottom border disappears, and there is no indication that more
text exists.

WORKAROUND
==========

To work around this problem, you must reset the height of the frame.



Use one of the following two methods to reset the height:
   
 - From the Format menu, choose Frame. In the Height At box, increase
   the value until all the text displays.

  -or-
 
 - From the Format menu, choose Frame. In the Height box, change the
   setting to Auto, and choose the OK button.

Either of the above methods resizes the frame to show all the text,
and display the bottom border of the frame again.

Additional reference words: w4wformat 6.00 wm_word 2.00



WinWord: Text Not Vertically Centered with Large Header/Footer
Article ID: Q80605
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

If a Microsoft Word for Windows document contains large headers or
footers, the top or bottom margin increases to accommodate the header
or footer text. If you vertically center text on a page with large
headers or footers, Word for Windows aligns the text between the
adjusted margins rather than between the original margins. This may
give the appearance that the text's alignment is no longer vertically
centered.

More Information:

You can vertically center text on a page by choosing Section Layout
(or Section in version 1.x) from the Format menu and selecting Center
in the Vertical Alignment box. This vertically centers the section's
text between the page margins, rather than between the edges of the
page.
  
When you insert a header/footer, Word for Windows inserts it within
the top/bottom margin. If the header/footer is bigger than the margin,
the header/footer pushes the margin down or up to make room for
itself. Vertically-centered text is then re-aligned between the
adjusted margins.
  
To illustrate how Word for Windows vertically centers text in a
document containing a long header/footer, follow the steps below:
 
1. Create a new document, and type a line of text.
 
2. Position the insertion point on the line of text. From the Format
   menu, choose Section Layout (Section in version 1.x). Select Center in
   the Vertical Alignment box, then choose the OK button.
   
3. From the File menu, choose Print Preview. Choose the Margins
   button. Notice that the text is centered in the middle of the top and
   bottom margins. 
 
4. From the View menu, choose Normal.
       
5. From the View menu, choose Header, type containing 10 lines of
   text, and choose the Close Button. 
 
6. From the File menu, choose Print Preview. Choose the Margins
   button. 
 



The text moves down the page and is now centered between the bottom
margin and the bottom of the header text.

For more information on vertical alignment, search for "vertical
alignment" using the Help menu in Word for Windows version 2.0.

Reference(s):

"Microsoft Word for Windows User's Reference," version 1.x, page 315

"Microsoft Word for Windows User's Guide," version 2.0, page 164, 447,
572-573

Additional reference words: w4wformat
2.00 1.00 1.10 1.10a 1.1 1.1a 1.0 uneven
justification justify



WinWord: Replace Command Doesn't Change Table Formatting
Article ID: Q80612
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

If you create a table that does not contain any text in Microsoft Word
for Windows and then apply paragraph formatting to it, the Edit
Replace command does not replace the formatting. Formatting in an
empty table cell is retained in the end-of-cell marker rather than the
paragraph mark. The Replace command identifies formatting contained
only in text or paragraph markers.

To work around this problem, you can manually select the table and
change the formatting characteristics.

More Information:

Steps to Reproduce Problem
--------------------------

Word for Windows Version 2.0
----------------------------

1. From the File menu, choose New, and choose the OK button.

2. From the Tools menu, select Options. From the Category list, select
   the View icon, and select the Table Gridlines and All options. Choose
   the OK button.

3. Type some text in the document, and press ENTER.

4. From the Table Menu, choose Insert Table. Accept the default
   values, and choose the OK button.

5. Select the entire document by pressing CTRL+Keypad 5.

6. From the Format menu, choose Character, select Bold, and choose the
   OK button. The entire document has bold formatting.

7. From the Edit menu, choose Replace. In the Find What box, press the
   CTRL+B key combination to search for bold formatting. The word "Bold"
   appears below the selection box. In the Replace With box, press the
   CTRL+I key combination to replace with italic formatting. The word
   "Italic" appears below the selection box. Choose the Replace All
   button and then the Close button.

8. All of your text and paragraph marks now have italic formatting;
   however, if you type text within one of the blank table cells, the



   text has bold formatting.

Word for Windows Version 1.x
----------------------------

1. From the File menu, choose New, and choose the OK button.

2. From the View menu, choose Preferences. Select the Table Gridlines
   and Show All options. Choose the OK button.

3. Type some text in the document, and press ENTER.

4. From the Insert Menu, choose Table. Accept the default values, and
   choose the OK button.

5. Select the entire document by pressing CTRL+Keypad 5.

6. From the Format menu, choose Character, select Bold, and choose the
   OK button. The entire document has bold formatting.

7. From the Edit menu, choose Replace. In the Search For box, press
   the CTRL+B key combination to search for bold formatting. The word
   "Bold" appears below the selection box. In the Replace With box, press
   the CTRL+I key combination to replace with italic formatting. The word
   "Italic" appears below the selection box. Clear the Confirm Changes
   option, and choose the OK button.

8. All of your text and paragraph marks have italic formatting;
   however, if you type text within one of the blank table cells, the
   text has bold formatting.

This problem does not occur if text or paragraph marks previously
exist in the table cell. Text or a paragraph mark provide a
recognizable search item for the Replace command.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 263-4

"Microsoft Word for Windows User's Reference," version 1.x, pages
289-90

Additional reference words: w4wformat wm_word
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00  w4wtable



WinWord: Deleting a Section Break and Maintaining Formatting
Article ID: Q80834
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:
  
If you delete a section break in Microsoft Word for Windows, the
document or page layout settings are also deleted. By using the
procedure below, you can work around this situation, and delete a
section break while maintaining the document or page layout settings.

Word for Windows version 6.0
----------------------------

1. From the View menu, choose Normal if it is not already selected.  

2. Position the insertion point in the section that contains the
   section information to be saved.  

3. From the Tools menu, choose Macro, press the Record button, assign
   the name "settings" (without the quotation marks) to the macro, and
   choose the OK  Button. It is not necessary to assign the macro to the
   keyboard, menu or  toolbar. The mouse cursor changes to an arrow and
   cassette tape signifying that the macro recorder is on. The Macro
   toolbar also displays.  

4. From the File menu, choose Page Setup, and choose the OK button, or
   click the Stop button on the Macro toolbar.  

5. From the Tools menu, choose Macro and press the Stop Recording
   button.  

6. Select the section break, and press delete key.  

7. From the Tools menu, choose Macro, select the settings macro, and
   choose the Run button.  

The page layout information is restored.

Word for Windows Version 2.0
----------------------------

1. Position the insertion point in the section that contains the
   section information to be saved.
 
2. From the Tools menu, choose Record Macro, assign the name
   "settings" (without the quotation marks) to the macro, and choose the
   OK button.



3. From the Format menu, choose Page Setup, and choose the OK button.
  
4. From the Tools menu, choose Stop Recorder. The page layout
   information is now recorded in the settings macro.

5. Select the section break, and press the DEL key.
   
6. From the Tools menu, choose Macro, select the settings macro, and
   choose the Run button.

The page layout information is restored.

Word for Windows Version 1.x
----------------------------
  
1. Position the insertion point in the section that contains the
   section information to be saved. 
  
2. From the Macro menu, choose Record, assign the name "settings"
   (without the quotation marks) to the macro, and choose the OK button.
 
3. From the Format menu, choose Document, then choose the OK button.
   
4. From the Macro menu, choose Stop Recorder. The page layout
   information is now recorded in the settings macro.

5. Select the section break, and press the DEL key.
   
6. From the Macro menu, choose Run, select the settings macro, and
   choose the Run button.

For more information on recording macros, search for "recording a
macro" using the Help menu in Word for Windows version 2.0.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 764-765,
766-767

"Microsoft Word for Windows User's Reference," version 1.x, pages
186-187, 284-285

Additional reference words: w4wformat 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c wm_word 6.00



WinWord: Different Indents Cause Improper Numbering Sequence
Article ID: Q80857
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, outline numbering is restarted each time a
new indent measurement is found.

MORE INFORMATION
================

In Word for Windows, you can set indents by choosing Bullets and Numbering
from the Tools menu, selecting the Outline option button, and selecting
Outline in the Format box. Indents are treated as heading levels when Word
applies outline numbering. In the example below, three indented paragraphs
are numbered using the Bullets and Numbering command.

Before applying outline numbering, the three indented paragraphs
appear as follows:

        TITLE

                SUBTITLE

                        SUBTITLE

After applying outline numbering, the three indented paragraphs appear
as follows:

        I.      TITLE

                A.      SUBTITLE

                        1.      SUBTITLE

If you set up a series of indents in the above format and then number
the text, the numbering orders itself properly; however, if you add
more information to the outline and set different indents, the
numbering restarts with one (I.) and does not follow the proper
sequence. This is a design feature of Word version 2.0.

Steps to Reproduce Behavior
---------------------------

 1. In a new document, type "TITLE," and press ENTER.

 2. From the Format menu, choose Paragraph. Select 0.5" in the



    Indentation from Left box, then choose the OK button.

 3. Type the word "SUBTITLE," and press ENTER.

 4. From the Format menu, choose Paragraph. Select 1.0" in the
    Indentation from Left box, then choose the OK button.

 5. Type "SUBTITLE."

 6. Select all the text. From the Tools menu, choose Bullets and
    Numbering, and select the Outline option button.

 7. In the Format box, select Outline, then choose the OK button. (Note
    that lines of text set with different indents are numbered as shown in
    the example above.)

 8. Position the insertion point at the end of the second "SUBTITLE"
    (step 3), and press ENTER.

 9. From the Format menu, choose Paragraph. Type 0.1" in the
    Indentation from Left box, then choose the OK button.

10. Type "TITLE," and press ENTER.

11. From the Format menu, choose Paragraph. Type 0.6" in the
    Indentation from Left box, then choose the OK button.

12. Type "SUBTITLE," and press ENTER.

13. From the Format menu, choose Paragraph. Type 1.1" in the
    Indentation from Left box, then choose the OK button.

14. Type "SUBTITLE."

15. Repeat steps 6 and 7 above.

Note that the text added in steps 10, 12, and 14 are not properly
sequenced. This behavior occurs because Word detects that the indents
are set differently and therefore renumbers the new lines from the
beginning, which produces improper sequencing.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 171-174,
521-532

Additional reference words: w4wformat wm_word 6.00
automatically incorrect 2.00 toolbar tool bar outlining



Word for Windows: Paragraph Formatting Within Table Cells
Article ID: Q80917
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

When you insert a table in a Microsoft Word for Windows document, each
cell in the table assumes the paragraph formatting of the paragraph
where the insertion point is located when you insert the table. This
behavior may produce unexpected results in the display of text in the
table. To check the formatting specified for the paragraph containing
the insertion point, choose Paragraph from the Format menu.

More Information:

A common example of this problem occurs when the paragraph containing
the insertion point is formatted with a non-zero left or right indent.
If you insert a table at this point, each cell contains indents, and
the contents of the cells may align unexpectedly. When you apply an
indent to table cells, the indent is measured from the boundary of
each cell, not from the document margin.

With the ruler's indent scale active, you can view the ruler to check
for paragraph indents before you insert the table. You can also check
for indents in individual cells after you insert the table. If more
than one cell in the table is selected, the ruler reflects the indents
for the top-left cell of the selection, and the triangular indent
markers are unavailable, signifying that they do not apply to the
whole selection.

For a more precise view of the indents choose Paragraph from the
Format menu, and consider the follow conditions:

 - If the left indent is less than the cell width and the combined
   indents are greater than the width of the cell, any text in the cell
   appears in a one-character wide column, positioned at the left indent.

 - If the left indent is larger than the width of the cell, no text
   displays, regardless of the value of any other indents.

 - If the indent values are smaller than the width of the cell (but not
   zero), the indents are made from the left and/or right cell boundaries
   (just as normal paragraphs are indented from the left and/or right
   margins).

Word for Windows Version 2.0
----------------------------

If you use the Format Paragraph command to set left and/or right



paragraph indents for an existing table cell and the indents you
specify narrow the cell or paragraph to less than approximately
.7-inch, you receive the following error message:

   This indent is too large.

If you attempt to set a first-line indent beyond the end of the cell
or paragraph (as determined by the right indent), you receive the same
error message.

You do not receive any error messages if you use the ruler to set the
same paragraph indents.

Word for Windows Versions 1.x
-----------------------------

In Word for Windows version 1.x, you can specify any left, right, or
first-line paragraph indent value(s) within an existing table cell,
regardless of its relationship to the cell width and regardless of
whether you set the indents using the ruler or the Format Paragraph
command. No error messages appear in reference to conflicts in table
cell indentations. In Word version 1.x, the error message "Indentation
too large" appears only in reference to settings that conflict with
page margin and width settings.

Workaround
-----------

You can quickly reset all paragraph indents affecting a table by using
the following steps:

1. With the insertion point positioned in the table, select the whole
   table by pressing ALT+Keypad 5 (with NUM LOCK off).

2. From the Format menu, choose Paragraph.

3. Type 0 (zero) in all three Indent boxes, and choose the OK button.

While paragraph indents are probably the most common cause of
misalignment in table cells, other paragraph formatting can affect
table cells. For more information on table formatting, query on the
following words in the Microsoft Knowledge Base:

   paragraph and line and spacing and table and row and winword

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 49,
162-170, 322-324

"Microsoft Word for Windows User's Reference," version 1.x, page 367

Additional reference words: w4wformat wm_word
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00
w4wtable errmsg



WinWord: Bullet Replaces Leading Number in Paragraph
Article ID: Q81055
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, if you create a list or paragraphs 
containing bullets, Word replaces any leading numbers in the paragraphs 
or list items with the bullet character.

MORE INFORMATION
================

Word for Windows does not allow both a number and a bullet to appear
at the beginning of a paragraph or list item when you use the Bullets
and Numbering command.

Workaround
----------

To stop Word from removing leading numbers from paragraphs or lists
that you want to format with bullets, use one of the following
methods:

 - Place the number in a QUOTE field as follows:

   1. Press CTRL+F9 to insert field braces.

   2. Type "quote" (without the quotation marks), and press the 
      SPACEBAR.

   3. Type the desired number inside the quotation marks. The field code
      should display as follows:

         {quote "12.2"}

    4. Press the F9 key to update the display results.

  -or-

 - Insert bullets manually using the Edit Copy/Paste command or by
   choosing Symbol from the Insert menu.

  -or-

 - Use the following macro, which can replace the
   ToolsBulletListDefault macro assigned to the Bulleted List tool bar
   button. The macro automates the typing of unique characters in front



   of the numbers prior to adding the bullets.

   Sub MAIN
   If Len(Selection$()) = 1 Then
        EditGoTo .Destination = "\Para"
   EndIf
   ToolsBulletsNumbers .Type = 0, .Replace = 1, .Remove
   InsertBookmark .Name = "bulletselection"
   CharLeft 1
   n = CmpBookmarks("\Sel", "bulletselection")
   While n = 8 Or n = 6
        CharRight 1, 1
        If Asc(Selection$()) = 9 Then
                EditClear
        Else
                CharLeft 1
        EndIf
        Insert "X"
        CharLeft
        ToolsBulletListDefault
        EditClear
        EndOfLine
        n = CmpBookmarks("\Sel", "\EndOfDoc")
        If n <> 0 Then
                ParaDown
                StartOfLine
                n = CmpBookmarks("\Sel", "bulletselection")
        EndIf
   Wend
   EditGoTo .Destination = "bulletselection"
   InsertBookmark .Name = "bulletselection", .Delete
   End Sub

Steps to Reproduce Problem
--------------------------

1. Type the following lines in a Word for Windows version 2.0
   document:

      1. item one
      2. item two

2. Select the text typed in step 1. From the Tools menu, choose
   Bullets and Numbering.

3. Select Bullets, and choose the OK button.

The following message appears on the screen:

   Do you want to replace the existing numbers with bullets?

If you choose the No button, no bullets are inserted. If you choose
the Yes button, the numbers are replaced by bullets.

In Word for Windows 6.0, the user is prompted as to whether or not to
replace the leading numbers with the bullet character. Answering NO
to the prompt applies the bullets and leaves then numbers intact.



REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 153-154,
521-528

Additional reference words: w4wformat 6.00 wm_word 
2.00 toolbar button w4wmacro



WinWord 2.0: Solid Black Line Extends Across Ruler
Article ID: Q81111
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

When using a default tab setting that is less than 0.1-inch, the ruler
displays a solid black line from the left indent marker to the right
indent marker. A black line also appears in the body of the document
when you press the TAB key. When using Word for Windows version 6.0,
the ruler no longer displays a solid black line across it but a
similar black line appears in the body of the document when you press
the tab key in the document.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this
problem and will post more information here in the Microsoft Knowledge
Base as it becomes available.

WORKAROUND
==========
 
To ensure that a black line does not extend across the ruler or across
the body of the document when pressing the TAB key, choose a default
tab setting greater than 0.01-inch. 

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. From the Format menu, choose Tabs.

2. Select 0.01" in the Default Tab Stops box.

3. Choose the OK button.

A black line extends from the left indent marker to the right indent
marker on the ruler. A similar black line appears in the body of the
document when you press the TAB key in the document.

REFERENCES
==========



"Microsoft Word for Windows User's Guide," version 2.0, page 179

Additional reference words: w4wformat wm_word 6.00 show screen 2.00 2.00a 
2.00a-CD 2.00b 2.00c



WinWord Documentation Error: Spacing Before Setting
Article ID: Q81281
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In the "Microsoft Word for Windows User's Guide," version 2.x, page
186 states that when you print a document, Word for Windows ignores
the Before setting if the paragraph is at the top of the page. This is
only partially true; Word does not ignore the Before setting on the first
paragraph of the document. For all other paragraphs that occur at the top
of a page the Before setting is ignored.

Steps to Reproduce Problem in Word version 2.x
----------------------------------------------

1. From the File menu, choose New, and choose the OK button.

2. Type some text and press Enter to create a paragraph. Repeat this until
multiple pages are created.

3. Select the document and from the Format menu, choose Paragraph.

4. Select 8li in the Before box.

5. From the File menu, choose Print, then choose the OK button.

Although the documentation indicates the first paragraph should print
at the top of the page, it prints on the eighth line of your document.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 186

Additional reference words: w4wformat
docerr 2.00



Word for Windows: Tab Leader Extends Beyond Frame Border
Article ID: Q81311
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, if you format a tab inside a frame and
the tab is wider than the frame and includes a tab leader, the tab
leader extends beyond the right-hand border of the frame when you
press the TAB key.

MORE INFORMATION
================

Workaround
----------

This behavior occurs if the frame has not yet been applied to an
object or body of text; however, if you select an object or body of
text and then apply a frame to that item, the frame becomes positioned
around the selected item. This positioning stops the tab leader from
extending beyond the frame border. The tab leader displays and prints
correctly; it extends to the right border of the frame but not beyond.

Steps to Reproduce Problem
--------------------------

1. From the Insert menu, choose Frame. Click and drag to create a
   frame.

2. From the Format menu, choose Tabs. In the Tab Stop Position box,
   type a value wider than the frame. Select a leader from the Leader
   section, and choose the OK button.

3. Press the TAB key.

The results of these steps vary depending on the view you are working
in. In page layout and normal, the tab leader displays incorrectly; it
extends past the right-hand border of the frame. In these views, the
tab leader prints outside the frame. In print preview, the tab leader
does not extend past the right border of the frame. In outline view,
the frame and the tab leader are not visible. When printing in outline
view, neither the frame or the tab leader print.

Additional reference words: w4wformat wm_word 6.00 3.0 3.0a 3.1 2.00 
2.00a 2.00a-CD 2.00b 2.00c



Word for Windows: Shading Extends to the Right-Hand Margin
Article ID: Q81434
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0 and 2.0a
---------------------------------------------------------------------

SYMPTOMS
========

If a Microsoft Word for Windows version 2.0 document contains only one
paragraph and you shade that paragraph and then frame it, the shading
extends to the right-hand margin of the paragraph. Framing the
paragraph should restrict the shading to the frame.
 
You can avoid this problem by inserting the frame before you add the
shading.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New, then choose the OK button. Type
   some text on the first line. Select the text and the end of paragraph
   marker.

2. From the Format menu, choose Border, then choose the Shading
   button. Select a shade percentage under Pattern, and choose the OK
   button twice.

3. From the Insert menu, choose Frame.

The frame surrounds the text, but the shading extends to the
right-hand margin.

WORKAROUND
==========

1. From the Tools menu, choose Options, and select the View category.
   Select the Paragraph Marks option in the Nonprinting Characters box.
   Choose the OK button.



2. Select the last paragraph mark. From the Format menu, choose
   Border, then choose the Shading button. In the Pattern box, choose the
   Clear option, then choose the OK button.

Additional reference words: w4wformat 2.0a 2.00 2.00a



Paragraphs After Bullets & Numbering Retain Hanging Indent
Article ID: Q81484
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you can use two methods to apply bullets 
and numbering to your text. To apply bullets or numbers, you can choose 
the appropriate button on the tool bar, or you can choose Bullets and 
Numbering from the Tools menu.

You can also use both of these methods to insert a hanging indent for
the current paragraph or for all paragraphs currently selected. After
you apply the formatting to the current paragraph or selection, Word
applies the hanging indent to any paragraphs subsequently entered. You
must manually remove the hanging indent formatting.

MORE INFORMATION
================

To remove the hanging indent from subsequent paragraph(s), select all
affected paragraphs, choose Paragraph from the Format menu, and set
the From Left Indent and First Line Indent to 0 (zero).

In Word for Windows 6.0, Bullets and Numbering are now a paragraph
property. Even so, the hanging indent issue described above is still
applicable.  When the last paragraph has a hanging indent set, and 
you press ENTER to create a new paragraph all paragraph formatting is
propagated to the new paragraph. So in Word 6.0, not only will you have
to remove the indents, but also the bullet or number. This can be 
accomplished by using the Ctrl-Q (Return to Style) keystroke, or by
using the Format Bullets and Numbering menu, and choosing Remove in 
the dialog box. A third way is to use the right mouse button to get
the shortcut menu for paragraphs, and choosing Stop Numbering from the
list.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 171-3,
521

Additional reference words: w4wformat maintain assume 6.00 wm_word 
2.00 2.00a 2.00a-CD 2.00b 2.00c toolbar associated



Word: Border Below or Above Does Not Display or Print
Article ID: Q81647
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, a paragraph will not display a border
formatted as Below using the Border command if the following paragraph
is also formatted with a border Below. This behavior also occurs for
paragraphs with borders formatted as Above.

MORE INFORMATION
================

The Format Border command facilitates placing borders around multiple
paragraphs as well as placing border lines between paragraphs.

NOTE: Word for Windows versions 1.x do not support placing borders
around multiple paragraphs, only single paragraphs. Consequently, a
paragraph with a border formatted as Below or Above will always
display since it is formatted independent of the paragraphs around it.

To place a border between two paragraphs in Word for Windows
----------------------------------------------------------------

1. Select the paragraphs you want to place a line between and choose
   Borders and Shading (Border in Word 2.0) from the Format menu.

2. In the Border box, choose the line between the paragraphs in the
   sample. If you are using the keyboard, press ALT+R, then press the
   RIGHT ARROW key four times (twice in Word 2.0). 

3. In the Line box, select a line style other than None. Choose the OK
   button.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. In a new document, press ENTER three times to create three blank
   paragraphs.

2. Select all three lines. From the Format menu, choose Borders and 
   Shading (Border in Word 2.0).

3. In the Border box, choose the line below the sample paragraph. To



   do this using the keyboard, press ALT+R, then press the RIGHT ARROW
   key six times (four times in Word 2.0).

4. In the Line box, select a line style other than None. Choose the
   OK button.

   Word for Windows places a border below the last paragraph only. 

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 361-379

"Microsoft Word for Windows User's Reference," versions 1.x, pages 20,
21, 252, 304-305, 387.

Additional reference words: w4wformat 6.00 wm_word 
gone middle missing incorrect improper 2.0
2.00 2.0a 2.00a



Glossary Entry with Normal Style Doesn't Maintain Alignment
Article ID: Q81742
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you format an autotext (known as 
glossary entry in Word 2.0) entry with Normal style and then directly 
format it with an alignment that differs from the Normal style, the 
autotext entry loses the direct alignment formatting if you save the 
template. After saving the template, text inserted from the autotext 
entry is formatted with the Normal style alignment rather than the 
alignment you originally assigned to the autotext entry.

Microsoft has confirmed this to be a problem in Microsoft Word for
Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 2.0b, 2.0c, and 6.0. We are
researching this problem and will post new information here as it
becomes available.

More Information:

Workaround
----------

Format the text with a unique
style prior to defining as autotext. When the autotext is
expanded, the style is included with the expanded text.

1. Type the desired autotext text on a blank paragraph line.

2. Apply the desired alignment formatting to the text.

3. Press CTRL+Shift+S (CTRL+S in Word 2.0) to activate the Style box
   on the ribbon.

4. Type a unique style name (preferably the same name that you want to
   use for the autotext name), and press ENTER.

5. Select the paragraph.

6. From the Edit menu, choose AutoText (Glossary in Word 2.0). In the 
   Name box, type a unique name (preferably the same name entered in 
   step 4), and choose the Add (Define in Word 2.0) button.

7. From the File menu, choose Save All. Choose the Cancel or No button 
   when prompted to save the current document. Choose the Yes button in
   response to the prompted to save changes to global template.

The next time the autotext is expanded, the text is formatted



according to the uniquely-defined style.

Steps to Reproduce Problem
--------------------------

 1. From the File menu, choose New, then choose the OK button.

 2. Change the Normal style alignment to Justified with the following
    steps:

    a. From the Format menu, choose Style, and select Normal in the 
       Style box.

    b. In Word 6.0, choose the Modify button and from the Format drop-
       down box choose Paragraph. In Word 2.0, choose the Define button, 
       then choose the Paragraph button.

    c. In the Alignment box, select Justified, then choose the OK 
       button.

    d. Check the Add To Template.
   
    e. Choose the Change button (Word 2.0 only). Choose the Yes button 
       is response to the prompt "Do you want to change the properties 
       of the standard style?"

    f. Choose the Apply button.

    g. From the File menu, choose Save All. Choose the Cancel or No 
       button when prompted to save the current document. Choose the Yes 
       button in response to the prompted to save changes to global 
       template.

 3. Type the desired AutoText text on a blank paragraph line.

 4. Press CTRL+L to left-align the text.

 5. Select the current paragraph.

 6. From the Edit menu, choose AutoText, type "test" (without the
    quotation marks) in the Name box, and choose the Add
    button.

 7. Test the AutoText in the current document. On a blank line
    formatted with the Normal style (paragraph alignment is justified),
    type "test" (without the quotation marks), and press F3 to expand 
    the AutoText entry.

 8. Position the insertion point in the inserted text. Note that it is
    left-aligned, as expected.

 9. From the File menu, choose Save All. Choose the Cancel or No button 
    when prompted to save the current document. Choose the Yes button in
    response to the prompted to save changes to global template.

10. Repeat step 7.



Position the insertion point in the text inserted in step 10. Note
that the alignment is now justified.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 267-269,
700-704

"Microsoft Word for Windows User's Reference," version 1.x, pages
141-142, 69-70

Additional reference words: w4wformat w4wtemplate 6.00 wm_word 
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c wrong stored expand



WinWord 2.0: Compiled TOC Entry Acquires Extra Tab Stop
Article ID: Q81776
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
---------------------------------------------------------------------

SYMPTOMS
========

In Word 2.0, 2.0a, 2.0a-CD, 2.0b, and 2.0c, a compiled Table of
Contents(TOC) entry contains an extraneous tab stop, formatted
approximately .38 or .25 inch from the left indent, if the text that
the entry was compiled from contains a tab character in the middle of
the text.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

For example, if you format the text "Microsoft  ->  Word for Windows"
(where "->" represents a tab character) with the Heading 1 style, the
compiled TOC entry will contain a manually inserted tab stop, which is
visible on the ruler and in the Tabs dialog box at .38 inch. This extra tab
stop is not included in the TOC 1 style that the compiled entry is
formatted with.

WORKAROUND
==========

After compiling the table of contents, use the following steps:

Word 2.0b and 2.0c
------------------

1. Highlight the entire Table of Contents to select it.

2. Press CTRL+Q to remove any manual paragraph formatting.

Word 2.0 and 2.0a
-----------------



1. Position the insertion point in the first TOC entry.

2. Press CTRL+Q to reset the paragraph to the defaults defined in the
   TOC style.

3. Repeat this process for each TOC entry.

   You can use the following macro to automate this process:

         Sub MAIN
         fCodes = ViewFieldCodes()
         ViewFieldCodes 0
         For toc = 1 To 8
           StartOfDocument
           EditFindStyle .Style = "toc" + Str$(toc)
           EditFind .Find = "", .Direction = 2, .Format = 1
           While EditFindFound()
             ResetPara
             CharRight 1
             EditFindStyle .Style = "toc" + Str$(toc)
             EditFind .Find = "", .Direction = 2, .Format = 1
           Wend
         Next toc
         ViewFieldCodes Abs(fCodes)
         End Sub

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New, then choose the OK button. Press
   ENTER to create an additional blank line.

2. Type "This is a" (without the quotation marks), press the TAB key,
   then type "test" (without the quotation marks).

3. With the insertion point positioned in the text, choose the Heading 1
   style from the Style box on the tool bar, and press ENTER.

4. Position the insertion point in the first line of the document.

5. From the Insert menu, choose Table of Contents, and choose the OK
   button. This generates a table of contents based on all heading styles
   in the document.

6. Position the insertion point in the first TOC entry. Note that there are
   three tab markers on the ruler. The TOC 1 style, by default, has only
   two tab stops defined.

7. From the Format menu, choose Tabs. Note the extraneous tab setting
   at .38 inch in the Tab Stop Position box.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 552-557



Additional reference words: w4wformat 2.0a 2.00 2.00a number bullet
2.0b 2.0a-CD 2.00b 2.00a-CD w4wmacro



WinWord: Search for Style Does Not Select Entire Paragraph
Article ID: Q81833
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows version 1.x, if you use the Edit Search
command to find style formatting, the entire paragraph is not selected
if that paragraph contains hidden text. The selection stops at the
hidden text. This is not the case in Word for Windows versions 2.x and
6.0; in versions 2.0 and 6.0, the entire paragraph is selected
regardless of the presence of hidden text.

More Information:

In Word for Windows versions 1.0, 1.1, and 1.1a, you can search for
paragraphs that contain style formatting by typing "^y" (without the
quotation marks) and the style name in the Search For box of the Edit
Search dialog box. For example, to search for paragraphs formatted
with the New style, type the following in the Search For box:
 
   ^yNew
 
If the paragraph formatted with the New style contains hidden text,
Word selects the portion of the paragraph preceding the hidden text.
The remainder of the paragraph is not selected.

In Word for Windows versions 2.x and 6.0, the entire paragraph is
selected even if it contains hidden text.

Steps to Reproduce Problem
--------------------------

1. In Word for Windows version 1.x, create a document with several
   paragraphs.

2. Select the first line in a paragraph. Press the B button on the
   ribbon to apply bold character formatting.

3. From the Format menu, choose Define Styles, then choose the Options
   button. In the Define Style Name box, type "New" (without the
   quotation marks) and choose the OK button to create a style based on
   that selection.

4. Select the rest of the paragraph. From Style box, select New to
   apply the style to the paragraph.

5. Select a few words in the middle of that paragraph. From the Format
   menu, choose Character, select the Hidden option box, and choose the
   OK button.



6. From the View menu, choose Preferences. Clear the Hidden Text and
   Show All option boxes. Choose the OK button.

7. Press CTRL+HOME to position the insertion point at the beginning of
   the document.

8. From the Edit menu, choose Search.

9. Type "^ynew" (without the quotation marks) in the Search For box,
   then choose the OK button.

The first part of the paragraph typed in step 2 is selected; however,
the part of the paragraph following the hidden text is not selected.

Reference(s):

"Microsoft Word for Windows User's Reference," version 1.x, page 312

Additional reference words: w4wformat 2.00 1.10 1.10a 1.00 2.0a 2.00a
missing found skip



Paragraph Formatting Affects DropCap Macro Results in WinWord
Article ID: Q81860
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

The DropCap macro included in the Microsoft Word for Windows 
NEWMACRO.DOC file works correctly only on single-spaced text that is not 
indented. The DropCap macro produces varying results depending on the 
formatting of the paragraph to which you want to apply the macro. The 
possible results are described below.

This functionality was changed in Word version 6.0 for Windows.

More Information:
 
 - If you set a left indent, the macro positions the character
   correctly but does not position the frame around the character. 
  
 - If you set the Line Spacing option to At Least 1.5 Li or 2 Li, 
   Double, or 1.5 Lines, you will receive the following error message:

      This is not a valid integer
    
 - If you set the Line Spacing option to Exactly XXX (where "XXX" is a
   point value or number of lines), DropCap positions the frame
   correctly but does not position the character correctly.
    
 - If you set the Line Spacing option to At Least YYY (where "YYY" is a
   point value or number of lines greater than but not equal to 2
   lines), you can move the frame and character to the correct
   position by dragging the frame surrounding the character.

 - If the character is in a Word for Windows table, the following
   error message will occur: 

      WordBASIC error 509 "Command is Unavailable"
  
The DropCap macro works correctly only if you set the Line Spacing
option to Auto, Single, At Least 0 Li, or At Least 1 Li; and the From
Left box under Indentation is set to 0 (zero).

These problems were corrected in Word for Windows 6.0. The new Drop Cap 
(not a macro) feature takes into account variations in line spacing and 
indentation, and is not available when attempting to insert into 
a table cell. To insert a Drop Cap, in Word 6.0, choose Drop Cap from 
the Insert menu.

Additional reference words: w4wformat



w4wmacro 2.00 2.00a 2.00a-CD 2.00b 2.00c



Page Setup May Not Apply to Whole Document or Other Sections
Article ID: Q82182
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you change section formatting in the
Page Setup dialog box and later try to reapply these settings using
the Whole Document option or the This Point Forward option, the box
containing the settings is cleared. To successfully apply the page
setup formatting to subsequent sections or the whole document, you
must first retype or re-select the settings. If you do not re-select
the settings, Word does not apply the formatting to the designated
sections in the Apply To box.

Steps to Reproduce Behavior
---------------------------

1. From the File menu, choose New, and choose the OK button to open a
   new document based on NORMAL.DOT.

2. From the Insert menu, choose Break. Select Continuous in the
   Section Break box, then choose the OK button.

3. Position the insertion point in the first section. From the File
   menu (Format menu in Word 2.0), choose Page Setup.

4. Select the Margins option button.

5. Change the top margin from its current setting. For example, select
   .50 for this setting. Verify that the Apply To box has This Section
   selected, and choose the OK button.

6. From the File menu (Format menu in Word 2.0), choose Page Setup.
   Select Whole Document in the Apply To box.

The top margin setting is cleared. If you choose the OK button at this
point, the .50 setting is NOT applied to the whole document. You must
re-select .50 in the Top box or manually type the setting to apply
this setting to the entire document.

Note: This behavior occurs in all three page setup categories
(margins, size and orientation, and paper source settings).

Additional reference words: w4wformat 6.00 wm_word 
2.00 2.00a



Status Bar Incorrect with SuppressTopSpacing=Yes in WinWord
Article ID: Q82250
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows version 2.x, the SuppressTopSpacing=yes
entry in the [Microsoft Word 2.0] section of the WIN.INI file
suppresses spacing at the top of pages following a hard or soft page
break obtained with Space Before paragraph formatting. Although Word
suppresses the extra spacing, the At position on the status bar
includes the spacing following a soft (automatic) page break. The At
position displays correctly for paragraphs that follow a hard page
break.

Note: This problem is corrected in Word for Windows 6.0. By default, 
line spacing at the top of a page is suppressed.

More Information:

Steps to Reproduce Problem
--------------------------

1. From the Tools menu, choose Options, and select the WIN.INI
   category.

2. In the Option box, type "SuppressTopSpacing" (without the quotation
   marks).

3. In the Setting box, type "yes" (without the quotation marks).
   Choose the Close button.

4. From the Format menu, choose Page Setup. Set the top margin to 1".
   Choose the OK button.

5. Type several paragraphs of text to create a multiple-page document.

6. From the Edit menu, choose Select All.

7. From the Format menu, choose Paragraph, and set the Spacing Before
   option to 1". Choose the OK button.

8. Position the insertion point in a paragraph at the top of a page,
   following a soft page break.

The status bar displays At 2", even though the 1" spacing before is
suppressed.

Note: In normal and draft views, the extra spacing displays on the



screen following page breaks. Page layout view and print preview
accurately display the spacing suppressed following page breaks. 

Reference(s):

"Microsoft Word for Windows User's Guide," pages 186-187, 806, 810

Additional reference words: w4wformat
measurement location 2.00a



WinWord: Edit Replace Character Spacing Does Not Work
Article ID: Q82996
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you use the Edit Replace command to replace all instances of
character spacing with different character spacing in a Microsoft Word
for Windows version 2.x document, the command does not work
properly. 

This problem was corrected in Word version 6.0 for Windows.

More Information:

The Edit Replace command in Word for Windows 2.x is more
advanced than in Word for Windows 1.x. In Word for Windows 2.x, you have 
the option to replace any type of character formatting
with another type of character formatting; however, this option does
not function correctly for character spacing. For example, if a
document contains characters formatted with expanded spacing and you
want to replace them with normally spaced characters, the Edit Replace
command finds the characters with the expanded spacing but does not
replace them with normally spaced characters. This behavior occurs if
you are using normal, expanded, or condensed spacing.

Steps to Reproduce Problem
--------------------------

1. Select some text in a document.

2. From the Format menu, choose Character.

3. In the Spacing box, select Expanded, and choose the OK button.

4. From the Edit menu, choose Replace, and choose the Character
   button.

5. In the Spacing box, select Expanded, and choose the OK button.

6. In the Replace With box, click the mouse button once, then choose
   the Character button.

7. In the Spacing box, select Normal, and choose the OK button.

8. Choose the Find Next button, the expanded text is found.

9. Choose the Replace button. The character spacing is not replaced.



Microsoft has confirmed this to be a problem in Word for Windows
versions 2.x. This problem was corrected in Word version 6.0 for 
Windows.

Additional reference words: w4wformat
2.00 2.00a 2.00a-CD 2.00b 2.00c



Font Changes When Editing Word Object Embedded in Client App.
Article ID: Q85913
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you copy text to the Clipboard and 
paste it into a Windows-based application (for example, version 4.0 of 
Microsoft Excel for Windows, Microsoft Mail, or Windows Write) by 
choosing Paste Special from the Edit menu and selecting Word Document 
Object, a Word icon will appear in the application file. If you double-
click the Word icon to edit the object, Word may change the font of the 
text. Word may also change the paragraph formatting and style of the 
text to Normal.

More Information:

Workaround 1
------------

Create the Word Object by launching Word for Windows from the client
application. If you use the following steps to create the object, Word
for Windows does not change the font or style when you edit the 
embedded object:

1. Launch the client application.

2. From the Edit menu, choose Insert Object. Under Object Type, select
   Word Document, then choose the OK button.

   Note: This step activates Word for Windows; an active window titled
   "Microsoft Word - Object in CLIENT.APP" (where "CLIENT.APP" is the
   filename from the server application) appears on the screen.

3. Create the Word object. From the File menu, choose Close. When you
   are prompted to update the object in the client application file,   
   choose the Yes button.

   Note: This step returns you to the client application. A Word icon
   representing the Word object appears in the current cell.

4. To edit the Word object, double-click the icon. The Word object
   window appears in Word for Windows with all font and style formatting
   unchanged.

Workaround 2
------------

Do not use this workaround if your style has been changed; instead,



use the first workaround. Use the following workaround only if your
font has been changed:

1. With the Word object window active in Word for Windows, choose
   Style from the Format menu.

2. Choose the Define button, then choose the Character button.

3. Select the correct settings in the Character dialog box, and choose
   the OK button. Choose the Change button, then choose the Close 
   button.

4. From the File menu, choose Close. When you are prompted to update
   the object, choose the Yes button.

The next time you double-click the Word object, the original font will
remain unchanged.

Steps to Reproduce Problem
--------------------------

1. In a Word for Windows document, type "This is a test." Select this
   text.

2. From the Format menu, choose Character. In the Font box, select
   Courier New; in the Points box, select 20. Choose the OK button.

3. From the Edit menu, choose Copy.

4. Launch or activate version 4.0 of Excel for Windows. From the Edit
   menu, choose Paste Special.

5. Under Data Type, select Word Document Object, then choose the Paste
   button. A Word icon representing the Word object appears in the
   current cell.

6. Double-click the Word icon to edit the Microsoft Word object in
   Word for Windows.

Notice that the text, originally formatted for 20-point Courier New,
has changed to a different font. The point size remains unchanged.

Microsoft has confirmed this to be a problem in versions 2.x and 6.0
of Word for Windows. We are researching this problem and will post new
information here as it becomes available.

Additional reference words: w4wformat 6.00 wm_word 
2.00 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD 



Frame Above Top Margin Displaces Return Address on Envelope
Article ID: Q85933
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1

--------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, if you use the Create Envelope command and
choose to add the envelope to your document, Word will insert a section
break between the envelope and the first page of your document. If your
document contains a frame that is positioned above the top margin, Word
will incorrectly frame the section break with the same dimensions as the
frame at the top of page 1. This new frame will appear on the envelope and
will cause problems if the frame is positioned near the return address on
the envelope. The return address may wrap around the frame and print in the
wrong position.

If you do not add the envelope to your document (that is, you print
the envelope separately), this problem will not occur.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Steps to Reproduce Problem
--------------------------

1. Open a new document. From the Format menu, choose Page Setup, and
   select the Margins option button. Set the top margin to 1 inch, and
   choose the OK button.

2. From the Insert menu, choose Picture, and select a picture file
   from the CLIPART subdirectory. Choose the OK button.

3. Select the picture. From the Insert menu, choose Frame.

4. From the Format menu, choose Frame. Under Vertical, set the
   position to 0.5 inch. Under Relative To, select Page. Choose the OK
   button.



5. From the Tools menu, choose Create Envelope. If a return address is
   not already shown, type a return address, then choose the Add To
   Document button.

Notice that there is too much space between the first and second lines
of the return address. This is easier to see when the Text Boundaries
check box is selected. To view text boundaries, choose Options from
the Tools menu, select the View category, and select the Text
Boundaries check box under Show Text With. Choose the OK button.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 119,
382, 393, 401

Additional reference words: w4wformat apo split 2.00 2.00a 2.0b
2.0a-CD 2.00b 2.00a-CD w4wenvelope



WinWord: Uneven Double Underline with Tab Character
Article ID: Q86237
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, if you use double underline character
formatting to underline a tab character when the tab is the last
character in the line, the double underline will print unevenly; the
top line will appear longer than the bottom line.

STATUS
======
 
Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.
 
To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

WORKAROUND
==========

To work around this problem, use one of the following methods:

 - If possible, insert a table, and apply a double border to the bottom
   of the cell to achieve the desired effect.

  -or-

 - Use the fixed-space character (CTRL+SHIFT+SPACEBAR) instead of a tab
   at the end of the double underline format.

For more information about using the fixed-space character with
underline formatting, query on the following words in the Microsoft
Knowledge Base:

   nonbreaking and space and extend and underline

Steps to Reproduce Problem
--------------------------

1. Open a new document in Word for Windows.



2. From the Format menu, choose Character.

3. Select any font except Courier.

4. In versions 2.0 and 2.0a of Word for Windows, select Double in the
   Underline box under Style. In version 1.x of Word for Windows, select
   the Double Underline check box. Choose the OK button.

5. From the Format menu, choose Tabs.

6. Type "2" (without the quotation marks) in the Tab Stop Position
   (Tab Position in Word 1.x) field, and choose the OK button.

7. Type "test" (without the quotation marks) in the document, and
   press the TAB key.

8. From the File menu, choose Print, then choose the OK button.

The double underline appears correctly on the screen but prints
unevenly. The top line extends beyond the bottom line. This problem
does not occur with the Courier font unless the tab is set too close
to the document margin.

Additional reference words: w4wformat 1.00 1.10 1.10a 2.00 2.00a 2.00b
2.00a-CD 2.00c



Methods for Finding and Replacing Text with Revision Marks
Article ID: Q86617
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you can choose Find from the Edit menu
to locate text marked as new or deleted with revision marks, and you
can choose Replace from the Edit menu to replace text marked as new.
In version 1.x of Word for Windows, you can only search for new text;
you cannot find deleted text or replace new text.

This problem was corrected in Word version 6.0 for Windows.

More Information:

The Revision Marks command marks text that has been deleted from a
document or added to it. Deleted characters are marked with
strikethrough formatting. New text can be displayed with bold, italic,
underline (the default), or double-underline formatting, or it can be
invisibly marked, in which case you must use the procedure below to
locate it.

To move sequentially through all text with revision marks, choose
Revision Marks from the Tools menu in version 2.0 or 2.0a (the
Utilities menu in version 1.x), then choose the Search button. To
search for text marked as new, choose Find (Search in version 1.x) or
Replace from the Edit menu, and press CTRL+N in the Find What box
(Search For box in version 1.x). To search for text marked as deleted,
choose Find from the Edit menu, and press CTRL+Q in the Find What box.

Note: In version 1.x, the CTRL+N combination works only with the Edit
Search command; it does not work with the Edit Replace command. The
CTRL+Q combination does not work with either of these commands.

You cannot replace text marked as deleted. This limitation is by
design; deleted text should not be different from the original text.
To restore deleted text (that is, to remove the strikethrough
formatting), select the text, choose Revision Marks from the Tools
menu (Utilities menu in version 1.x), and choose the Undo Revisions
button. If you want to restore all deleted text, choose the Yes button
when prompted to undo all revisions.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 255-258,
604-607

Additional reference words: w4wformat



1.00 1.10 1.10a 2.00 2.00a



EditReplace Fails to Replace Formatting After Prior Command
Article ID: Q86671
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, if the EditReplace command is called in
a macro right after the execution of another EditReplace command, the
second command does not apply any character formatting. The second
occurrence of EditReplace does apply character formatting correctly in
a macro if you run the macro using the Step button on the macro-
editing bar.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

WORKAROUND
==========

Adding a different statement, function, or command between the two
EditReplace commands forces Word to reevaluate the execution of the
macro and operate correctly. The following are options you can
consider adding immediately above the second EditReplace command:

 - StartOfDocument

  -or-

 - Dim dlg As EditReplace
   GetCurValues dlg

  -or-

 - ToolsRepaginateNow

Performing any document navigation causes the EditReplace command to
work correctly. If you want to cover the entire document, use the
StartOfDocument command. The second option above may be preferable



because it requires no navigation. ToolsRepaginateNow requires a
lengthy processing time; therefore, you may not want to use it if you
are processing long documents.

Steps to Reproduce Problem
--------------------------

1. Create a document that contains the following text:

      tony
      bill
      tony
      bill

2. From the Tools menu, choose Macro. In the Macro Name box, type a
   name, then type the following macro text in the macro-editing window:

   Sub MAIN
   EditFindClearFormatting         'ensure find formatting cleared
   EditReplaceClearFormatting      'ensure replace formatting cleared
   EditReplaceChar  .Bold = 1      'choose to boldface the replacement text

   ' Boldface all occurrences of "tony"
   EditReplace .Find = "tony", .Replace = "tony", .WholeWord = 0, \
   .MatchCase = 0, .Format = 1, .ReplaceAll = 1

   ' The next three lines can be omitted. They simply demonstrate that
   ' resetting the formatting has no affect on the problem
   EditFindClearFormatting         'ensure find formatting cleared
   EditReplaceClearFormatting      'ensure replace formatting cleared
   EditReplaceChar  .Bold = 1      'choose to boldface the replacement text

   ' Boldface all occurrences of "bill"
   EditReplace .Find = "bill", .Replace = "bill", .WholeWord = 0, \
   .MatchCase = 0, .Format = 1, .ReplaceAll = 1
   End Sub

3. From the Window menu, choose Arrange All to view both the document
   window and the macro-editing windows.

4. Click the document window, then choose the Start button on the the
   macro-editing bar.

   The name "tony" has bold character formatting, but the name "bill" does
   not.

5. From the Edit menu, choose Select All, and press CTRL+B twice to
   strip the bold formatting from the text.

6. Press CTRL+HOME to move to the top of the document.

7. Choose the Step button on the macro-editing bar repeatedly until
   the macro completes.

Now both "tony" and "bill" have bold formatting.

Additional reference words: w4wformat w4wmacro 2.00 2.00a 2.00a-CD



2.00b 2.00c



Cannot Move Frames if Directly Under a Page or Column Break
Article ID: Q86683
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you cannot move frames if they are
directly beneath a page or column break. An easy way to work around
this problem is to insert a paragraph mark between the frame and the
break.

Note: Section breaks do not affect the ability to move frames.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Workaround
----------

Return to normal view so that you can see the page or column break.
Position the insertion point anywhere in the lower frame. Press
CTRL+SHIFT+ENTER to insert a paragraph mark above the frame and below
the break.

Steps to Reproduce Problem
--------------------------

To reproduce this problem with a frame beneath a page break, use the
following steps:

1. Create a new document based on the NORMAL.DOT template.

2. Type some text.

3. Select the text. From the Insert menu, choose Frame. Choose the Yes
   button when prompted to switch to page layout view.

4. Position the insertion point immediately after the frame. From the
   Insert menu, choose Break. Select the Page Break option button, then
   choose the OK button.

5. Directly beneath the page break, type some additional text. Select
   that text. From the Insert menu, choose Frame.

6. Attempt to move the text frame on the second page.

The repositioning arrow appears, and you can drag the frame outline,
but the text is not repositioned when you release the left mouse



button.

For information on positioning a frame, refer to the "Microsoft Word
for Windows User's Guide" for version 2.0, pages 394 and 397.

To reproduce this problem with a frame beneath a column break, use the
following steps:

1. Create a new document based on the NORMAL.DOT template.

2. From the Format menu, choose Columns. Select 2 in the Number Of
   Columns box, then choose the OK button.

3. Type some text.

4. Select the text. From the Insert menu, choose Frame. Choose the Yes
   button when prompted to switch to page layout view.

5. Position the insertion point after the frame. Press ENTER a few
   times.

6. From the Insert menu, choose Break, select the Column Break option
   button, then choose the OK button.

7. Type some more text and then select it. From the Insert menu,
   choose Frame.

8. In page layout view, attempt to move the frame in the second
   column.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 394 and
397

Additional reference words: w4wformat
2.00 2.00a frame column under



WinWord: Top Text Boundary Disappears in Page View
Article ID: Q86697
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, the text boundary at the top of the
page disappears if you are in page layout view, or if the following
settings exist:

   Paragraph line spacing = Double

   SuppressTopSpacing=Yes (in the [Microsoft Word 2.0] section of the
                         Microsoft Windows WIN.INI file)

STATUS
======
 
Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.
 
To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

The SuppressTopSpacing parameter is used to suppress a blank line at
the top of a page. If your text is not double-spaced, this is not an
issue. The text boundary reappears if you format the paragraph with
single spacing.

To work around this problem, do one of the following:

 - Make the top paragraph single-spaced.

  -or-

 - Add a blank header to the page.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 729,



739, back cover

Additional reference words: w4wformat
2.00 2.00a suppress double text boundary



Tab Positions Incorrect in Center and Right-Aligned Paragraphs
Article ID: Q86712
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you use centered or right justified
paragraph format combined with any tab settings, the tabs will not be
aligned correctly.

More Information:

This problem occurs because Word for Windows aligns the tabs first,
then positions the paragraph for center or right alignment, causing
the tabs to lose their correct positions. This problem also occurs in
table cells.

Workaround
----------

Avoid using tab settings in right or center-aligned paragraphs. When
possible, use a combination of right and centered tabs in a
left-aligned or justified paragraph to acheive the desired format.

Steps to Reproduce Problem
--------------------------

1. Set both the left and right margins to 1.25 inches. In version 2.0
   or 2.0a of Word for Windows, choose Page Setup from the Format menu.
   In version 1.x of Word for Windows, choose Document from the Format
   menu. Type the measurements in the appropriate boxes, then choose the
   OK button.

2. From the Format menu, choose Paragraph. In version 2.0 or 2.0a,
   select Centered from the Alignment box, then choose the OK button. In
   version 1.x, select the Center option button under Alignment, then
   choose the OK button. In your document, type "Information" (without
   the quotation marks).

3. Press TAB and type the current date.

4. From the Format menu, choose Tabs. Type 5.75" in the Tab Stop
   Position box. Under Alignment, select the Right option button. Choose
   the OK button.

The date is incorrectly positioned approximately 3 inches past the
right margin.

Additional reference words: w4wformat 1.00 1.10 1.10a 2.00 2.00a



incorrect 2.0b 2.0a-CD 2.00b 2.00a-CD  unexpected mis-aligned
misaligned center-aligned



WinWord: Cannot Find or Replace Styles in Empty Table Cells
Article ID: Q86798
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, you can use the Edit Find and Edit
Replace commands to find and/or replace paragraphs formatted with a
specific style. However, these commands cannot find or replace styles
in an empty table cell. By choosing the Styles button in the Replace
or the Find dialog box, you can search for a specific style. However,
if there are empty table cells in your document, neither command can
find a style in those cells.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 260-264

Additional reference words: w4wformat 2.00 2.00a w4wtable



Cannot Use Tab Leader as Edit Find or Edit Replace Criteria
Article ID: Q86856
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system, versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you cannot use tab leaders as find
(search in versions 1.x) or replace criteria. As a result, you cannot
find or modify tab leaders using the Find (Search) or Replace commands
from the Edit menu.

This article describes steps you can use to find and replace tab
leaders (dotted, hyphen, and underline) by saving your Word for
Windows document in rich-text file (RTF) format, opening the RTF file
as Text Only, and modifying the RTF tab leader codes.

MORE INFORMATION
================

Do the following to find and replace tab leaders in your Word for
Windows document. Be sure to create a backup copy of your file before
using these steps.

1. Open the document that contains tab leaders. From the File menu,
   choose Save As. In the File Name box, type a new filename. In the
   Save File As Type box, select Rich Text Format (*.rtf) and choose
   the OK button.

2. From the File menu, choose Open. Select the file you saved in step
   1 above and choose the OK button. In the Convert File dialog box,
   select Text Only and choose the OK button.

3. From the Edit menu, choose Replace. Use the following RTF tab
   leader codes in the Find and Replace boxes:

      RTF Code   Type
      --------   ----

      \tldot     Dotted leader tab
      \tlhyph    Hyphen leader tab
      \tlul      Underline leader tab
      NUL        No leader (default, no leader code)

4. From the File menu, choose Save. From the File menu, choose Close.

5. Reopen the file you closed in step 4 above. In the Convert File
   dialog box, select Rich Text Format (RTF) and choose the OK button.
   The new tab leaders should appear in the file.



6. When you close the file, you will be prompted to overwrite the RTF
   file format with Word for Windows 2.0 format. Choose the Yes button.

Example
-------

The following example replaces all dotted leader tabs with hyphen
leader tabs:

                 RTF Code     Type
                 --------     ----
   Find          \tldot       (Dotted leader tab)
   Replace with  \tlhyph      (Hyphen leader Tab)

How to Replace Tabs with No Leader with Another Leader Format
-------------------------------------------------------------

Tabs with No Leader is the default, so there is no RTF code you can
use in the Find What box. Therefore, you must use these additional
steps to replace No Leader tabs with another leader format.

1. Follow steps 1-2 in the previous procedure.

2. From the Edit menu, choose Replace. Do the following, in order
   (these steps maintain other leader formats):

      Note: In all steps, do not type the quotation marks.

   a. In the Find What box, type "\tldot\tx". In the Replace With box,
      type "DOT_TAB" (skip this step if there are no dot leader tabs
      in your document).

   b. In the Find What box, type "\tlhyph\tx". In the Replace With
      box, type "HYPH_TAB" (skip this step if there are no hyphen
      leader tabs in your document).

   c. In the Find What box, type "\tlul\tx". In the Replace With box,
      type "UNDERLN_TAB" (skip this step if there are no underline
      leader tabs in your document).

   d. In the Find What box, type "\tx". In the Replace With box, type
      "<Desired RTF tab leader code>\tx". Use the following RTF tab
      leader codes in the Replace box:

         RTF Code   Type
         --------   ----

         \tldot     Dotted leader tab
         \tlhyph    Hyphen leader tab
         \tlul      Underline leader tab

      Example: If you type "\tldot\tx" in the Replace With box, you
      will replace all tabs with no leader with dotted leader tabs.

   e. In the Find What box, type "DOT_TAB". In the Replace With box,
      type "\tldot\tx" (skip this step if you skipped step 2a above).



   f. In the Find What box, type "HYPH_TAB". In the Replace With box,
      type "\tlhyph\tx" (skip this step if you skipped step 2b above).

   g. In the Find What box, type "UNDERLN_TAB". In the Replace With
      box, type "\tlul\tx" (skip this step if you skipped step 2c
      above).

3. Follow steps 4-6 in the previous procedure.

For more information on the RTF file format, query on the following
words in the Microsoft Knowledge Base:

   RTF and specification and appnote and obtain and available

Additional reference words: 6.00 w4wformat 1.00 1.10 1.10a 2.00 2.00a
wm_word editreplace editfind editsearch



Cannot Use Tab Alignment as Edit Find or Replace Criteria
Article ID: Q86857
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you cannot use tab alignment as find or
replace criteria (search or replace criteria in version 1.x of Word
for Windows). As a result, you cannot find or modify tab alignment
using the Edit Find (Edit Search in 1.x) or Edit Replace commands.

This article describes steps you can use to find and replace tab
alignment (right, left, decimal, and center) by saving your Word for
Windows document in RTF file format, opening the RTF file in Text Only
format, and modifying the RTF tab alignment codes.

MORE INFORMATION
================

Be sure to create a backup copy of your file before using the steps
below. Use the following steps to find and replace tab alignment in
your Word for Windows document:

1. Open the document containing the tab alignment you want to change.
   From the File menu, choose Save As. Type a new filename. In the Save
   File As Type box, select Rich Text Format (*.rtf), then choose the OK
   button.

2. From the File menu, choose Open. Select the file you saved in step
   1, and choose the OK button. In the Convert File dialog box, select
   Text Only, then choose the OK button.

3. From the Edit menu, choose Replace. Use the following RTF tab
   alignment codes in the Find What and Replace With boxes:

      \tqr    =   Right-justified tab
      \tqc    =   Center tab
      \tqdec  =   Decimal tab
      NUL     =   Left-justified (default, no RTF code)

4. From the File menu, choose Save. From the File menu, choose Close.

5. Reopen the file closed in step 4. In the Convert File dialog box,
   select Rich Text Format (RTF), and choose the OK button. The new tab
   alignment should appear in the file.

6. When you close the file, you are prompted to overwrite the RTF file
   format with Word for Windows format. Choose the Yes button.



The following example replaces all decimal tabs with right-justified
tabs:

   Find         "\tqdec"     (Decimal tab)
   Replace with "\tqr"       (Right-justified tab)

How to Replace Left-Justified Tabs with Another Alignment Format
----------------------------------------------------------------

Left-justified tabs are the default format; there is no RTF code you
can use in the Find What box. Therefore, you must use the following
additional steps to replace left-justified tabs with another alignment
format:

1. Follow steps 1-2 above.

2. From the Edit menu, choose Replace, and follow steps a-g below. Be
   sure to complete these steps in order so that you maintain other
   alignment formatting. Do NOT type the quotation marks in the steps
   below.

Warning: Do NOT use the following steps if your document contains tabs
with leader formatting. For information on removing tab leader
formatting from your document, query on the following words in the
Microsoft Knowledge Base:

   leader and tabs and criteria and find and replace and winword

   a. In the Find What box, type "\tqr\tx". In the Replace With box, type
      "RIGHT_TAB". (Skip this step if there are no right-aligned tabs in
      your document.)

   b. In the Find What box, type "\tqc\tx". In the Replace With box, type
      "HYPH_TAB". (Skip this step if there are no center-aligned tabs in
      your document.)

   c. In the Find What box, type "\tqdec\tx". In the Replace With box,
      type "DECIMAL_TAB". (Skip this step if there are no decimal-aligned
      tabs in your document.)

   d. In the Find What box, type "\tx". In the Replace With box, type
      "<Desired RTF tab alignment code>\tx". Use the following RTF tab
      alignment codes in the Replace With box:

         \tqr    =   Right justified tab
         \tqc    =   Center tab
         \tqdec  =   Decimal tab

      For example, if you type "\tqr\tx" in the Replace With box, you
      replace all left-aligned tabs with right-aligned tabs.

   e. In the Find What box, type "RIGHT_TAB". In the Replace With box,
      type "\tqr\tx". (Skip this step if you skipped step a.)

   f. In the Find What box, type "CENTER_TAB". In the Replace With box,
      type "\tqc\tx". (Skip this step if you skipped step b.)



   g. In the Find What box, type "DECIMAL_TAB". In the Replace With box,
      type "\tqdec\tx". (Skip this step if you skipped step c.)

3. Follow steps 4-6 above.

For more information on the RTF file format, query on the following
words in the Microsoft Knowledge Base:

   RTF and specification and appnote and obtain and available

Additional reference words: 6.00 w4wformat 1.00 1.10 1.10a 2.00 2.00a
wm_word editreplace editfind editsearch



WinWord: Fonts in Table Appear to Have Superscript Formatting
Article ID: Q87088
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, and 2.0a
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, if you use TrueType fonts with small
point sizes in a table, the text may appear to have superscript
formatting. This problem occurs with certain printer fonts and point
sizes smaller than 10 points.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

WORKAROUND
==========

To work around this problem, use the following steps:

1. Select the text that appears to have superscript formatting.

2. From the Format menu, choose Paragraph.

3. In the Line Spacing box, change the setting from Auto to Single.

Additional reference words: w4wformat 1.00 1.10 1.10a 2.00 2.00a
superscripted w4wtable



At Measurement on Status Bar Incorrect in Multiple Columns
Article ID: Q87920
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a, and
   2.0a-CD
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, the At measurement on the status bar
may display an incorrect measurement when you are working in a
document formatted for multiple columns.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

The status bar, which is displayed at the bottom of the Word for
Windows window, provides statistics about the insertion point position
and the status of some important keys. The status bar At value
indicates the vertical distance between the insertion point and the
top edge of the page. However, if you are working in page layout view
(page view in version 1.x of Word for Windows) with a multiple-column
document, the At value does not indicate the correct distance from the
top edge of the page in any columns other than the first one.

Steps to Reproduce Problem
--------------------------

Version 2.0, 2.0a, or 2.0a-CD of Word for Windows
-------------------------------------------------

1. Create a new document.

2. From the Tools menu, choose Options. Under Categories, select
   General.

3. Select the Background Repagination check box, then choose the OK
   button.



4. From the View menu, choose Page Layout.

5. From the Format menu, choose Columns. Select 2 in the Number Of
   Columns box, then choose the OK button.

6. Type enough text to fill the first column and part of the second
   column.

7. Check the At value on the status bar.

The At measurement indicates the distance from the beginning of the
document instead of the distance from the top edge of the page.

Version 1.0, 1.1, or 1.1a of Word for Windows
---------------------------------------------

1. Create a new document.

2. From the Utilities menu, choose Customize.

3. Select the Background Pagination check box, then choose the OK
   button.

4. From the View menu, choose Page.

5. From the Format menu, choose Section. Type 2 in the Number box and
   choose the OK button.

6. Type enough text to fill the first column and part of the second
   column.

7. Check the At value on the status bar.

The At measurement indicates the distance from the beginning of the
document instead of the distance from the top edge of the page.

When you are working with multiple columns, the At measurement on the
status bar continues to measure the vertical distance from the top of
the document as if the document is one continuous column. This causes
the At position at the end of each column to become increasingly
large, even though the vertical position from the top of the page is
the same.

Additional reference words: w4wformat 1.00 1.10 1.10a 2.00 2.00a 2.00a-cd



Bulleted List Does Not Align with Margin Using Unindent Button
Article ID: Q88125
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, and 2.0a-CD
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, if you indent a bulleted list by
choosing the Indent button on the toolbar, you cannot then use the
Unindent button to return the bullet to the left margin. If you choose
the Unindent button, the bullet repositions on the left or right side
of the left margin; it does not reposition AT the left margin.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

This problem occurs because the Bulleted List command applies hanging
indent formatting to the paragraph, which includes a First Line
setting of -0.25 inches under Indentation. The Indent and Unindent
buttons do not change the First Line setting; therefore, the first
line of the paragraph remains formatted for -0.25 inches when the rest
of the paragraph is formatted for no left indent.

WORKAROUND
==========

If the value of the Hanging Indent By setting is the same as the
Default Tab Stops value, you can reposition the bullet at the left
margin by choosing the Unindent button on the toolbar. Change one of
these settings to match the other.

To change the Hanging Indent By setting, choose Bullets and Numbering
from the Tools menu. Select the Bullets option button. Type or select
the new value in the By box and choose the OK button.

To change the Default Tab Stops setting, choose Tabs from the Format
menu. Type or select the new value in the Default Tab Stops box and



choose the OK button.

Note: You can create a style that contains the modified tab or hanging
indent formatting. For information on creating styles, refer to pages
200-204 of the "Microsoft Word for Windows User's Guide."

Steps to Reproduce Problem
--------------------------

1. In a Word for Window document, select a paragraph that contains no
   indent formatting.

2. Choose the Bulleted List button on the toolbar.

3. Choose the Indent button on the toolbar. The text is now indented
   to the first default tab stop.

4. Choose the Unindent button on the toolbar. The bullet is located
   0.25 inches to the left of the left margin, and the text is aligned
   with the left margin.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 200-204

Additional reference words: w4wformat 2.00 2.00a 2.00a-cd tool bar



WinWord 2.0: Move with Text Frame Option Ignores Bottom Margin
Article ID: Q88773
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

In a Microsoft Word for Windows document, if you select the Move With
Text check box in the Frame dialog box, text you type above your frame
may push the frame beyond the bottom margin and cause the frame to
overwrite the document footer.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this
problem and will post new information here as becomes available.

MORE INFORMATION
================

The Move With Text option causes the vertical position of the frame to
adjust in conjunction with the paragraph preceding the frame. As the
paragraph moves down the page, the frame also moves down the page. The
frame continues to move down into the bottom margin area, overlapping
the document footer, until Word advances the preceding paragraph to
the next page.

Steps to Reproduce Problem
--------------------------

1. Type "this is the paragraph above the frame" (without the quotation
   marks) and press ENTER twice.

2. Type "this is the paragraph below the frame" (without the quotation
   marks) and press ENTER.

3. From the View menu, choose Header/Footer. Select Footer and choose
   the OK button. Type some text in the footer pane.

4. Position the insertion point between the two paragraphs you typed
   in steps 1 and 2. From the Insert menu, choose Frame, and use the
   mouse or the keyboard to insert a frame.

5. From the Format menu, choose Frame. If Word for Windows prompts you
   to switch to page layout view, choose the Yes button. Select the Move
   With Text check box, then choose the OK button.



6. Position the insertion point above the first paragraph of text and
   type until the frame moves beyond the bottom margin, where it
   overwrites the footer.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 394,
397, 408, 573

Additional reference words: w4wformat apo picture border boundary
boundaries 2.00 2.00a 2.00a-CD overwrites overlay too low past beyond
below 2.00b



Line Spacing Changes if You Super/Subscript a SYMBOL Field
Article ID: Q89551
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Word for Windows, if you apply a superscript or subscript format to
a SYMBOL field, the paragraph line spacing is different than for
standard superscript or subscript characters. The line spacing
increases by the number of points the SYMBOL field is moved above or
below the baseline when it is formatted as superscript or subscript
text.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Workaround 1
------------

Add the \h switch to the end of the SYMBOL field to prevent the field
result from affecting line spacing.

Workaround 2
------------

Paragraph line spacing changes only when the character is generated
using a SYMBOL field. If you insert the symbol by typing its ANSI
character code, line spacing is not affected. Use the following steps
to determine the ANSI character code and font name for the symbol
character you want to insert:

1. Open the View menu. If the Field Codes command is not selected
   choose Field Codes. Note the character code and font in the SYMBOL
   field. For example, in the following example of a SYMBOL field, the
   character code is 169 and the font name is Symbol:

      {SYMBOL 169 \f "Symbol"}

2. Delete the SYMBOL field.

3. Type the ANSI character code by holding down the ALT key and typing
   "0nnn" (without the quotation marks, and where "nnn" is the ANSI
   character code) on the numeric keypad. In the above example, you
   would hold down the ALT key and type 0169.

4. Select the character. From the Format menu, choose Character.
   Select the font name noted in step #1 above (in the above example,
   you would select Symbol) and choose the OK button.



Steps to Reproduce the Problem
------------------------------

1. Create a new document and type a three-line paragraph.

2. Position the insertion point in the middle line. From the Insert
   menu, choose Symbol. In the Text From box, select a decorative font
   (any font other than Normal). Choose the OK button.

3. Select a symbol. From the Format menu, choose Character. In the
   Super/Subscript box, select Superscript and choose the OK button.
   Note the line spacing change.

4. Select the symbol. From the Format menu, choose Character. In the
   Super/Subscript box, select Subscript and choose the OK button.
   Note the line spacing change.

Additional reference words: w4wformat 2.00 2.00a 2.00a-CD 2.00b



WinWord: Black Box Inserted Into Black Section Creates Border
Article ID: Q89766
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

If you apply solid black shading to a portion of a Word for Windows
document using the Format Border command, then insert a black box,
created in Microsoft Draw, in the middle of the shaded area, a thin
white border appears around the Microsoft Draw box that you cannot
remove. The border prints as displayed.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Steps to Reproduce Problem
--------------------------

1. In a Word for Windows document, press ENTER several times to
   insert blank paragraphs. Select the paragraphs and, from the Format
   menu, choose Border. Choose the Shading button. In the Pattern box,
   select Solid. In the Foreground and Background boxes, choose Black
   and choose the OK button.

2. Position the insertion point in one of the shaded paragraphs.
   From the Insert menu, choose Object, select Microsoft Drawing and
   choose the OK button.

3. In Microsoft Draw, select black in the Line and Fill color
   palettes. Choose the Rectangle/Square tools and drag to create a
   box. From the File menu, choose Exit and Return to Document.
   Choose the Yes button when prompted to update the drawing.

You will see a border surrounding the black box in the black section.
No border should appear around the box you created in MS Draw.

Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
2.0a-CD, 2.0b, 2.0c. This problem was corrected in Word version 6.0
for Windows.

"Microsoft Word for Windows User's Guide," version 2.0, pages 361-364,
377-379, 694

"Microsoft Draw User's Guide," version 1.0, pages 23, 35

Additional reference words: w4wformat
2.00, 2.00a



Bullets and Numbering on Selection Resets Indent Information
Article ID: Q90516
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When you use the Bullets And Numbering command in Word for Windows,
paragraphs with varied hanging indent formatting that are numbered or
bulleted as a group may not retain their original hanging indent
formatting.

The paragraph indent will remain, the hanging indent will take on the 
format of  bullets and numbering.

Microsoft has confirmed this to be a problem in Word for Windows. We
are researching this problem and will post new information here as it
becomes available.

More Information:

Page 524 of the version 2.0 "Microsoft Word for Windows User's Guide"
states that "Word does not change the existing formatting" when you
add numbers or bullets to paragraphs with hanging indent formatting.
This statement is not true for paragraphs that contain varied hanging
indent formatting.

Steps to Reproduce Problem
--------------------------

 1. From the File menu, choose New. Choose the OK button.

 2. Type three paragraphs of text.

 3. Position the insertion point in the first paragraph. From the
    Format menu, choose Paragraph.

 4. In the Indent From Left box, select .5". In the First Line box,
    select -.5" and choose the OK button.

 5. Position the insertion point in the second paragraph. From the
    Format menu, choose Paragraph.

 6. Select 1.5" in the Indent From Left box. Select -.75" in the First
    Line box and choose the OK button.

 7. Position the insertion point in the third paragraph. From the
    Format menu, choose Paragraph.

 8. Select 1.8" in the Indent From Left box. Select -.8" in the First



    Line box and choose the OK button.

 9. Select all three paragraphs.

10. From the Tools menu, choose Bullets and Numbering and choose the
    OK button.

Note that all previous first-line indent formatting is replaced with
the first-line indent setting of the first paragraph, and the left
indent of each paragraph (except the first paragraph) is set to
another value.

If the hanging indent option is cleared in the Bullets And Numbering
dialog box, the paragraphs lose the first-line indent formatting and
the left indent is set to the value of the original left indent plus
the original first-line indent. For example, if the paragraph is
formatted with a 1-inch left indent and a -.5-inch first-line indent,
after you number or bullet the paragraph, it will have a .5-inch left
indent (1" + -.5") and a 0-inch first-line indent.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 170-171,
173

Additional reference words: w4wformat   6.00 wm_word 
2.00 2.00a 2.00a-CD 2.00b bulleting changes modifies 3.00 3.10



Font in Header Changes When Included in Another Document
Article ID: Q90542
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c  
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you manually apply a font to the
header of a document and that document is later included in another
file using an INCLUDE field, the font of the header may change to
match the font of the body text.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Steps to Reproduce Problem
--------------------------

 1. In a new document, type some text, select it, and format it with
    the Times New Roman font.

 2. From the View menu, choose Header/Footer (the Edit menu in Word
    versions 1.x), and choose the OK button to open the header. Type
    some text, select the text and format it for the Arial font, 18
    points. If you are in normal view, choose the Close button to to
    close the header window.

 3. Position the insertion point at the end of the document. From the
    Insert menu, choose Break, select Continuous in the Section Break
    box, and choose the OK button.

 4. From the File menu, choose Save. In the File Name box, type
    TEST1.DOC and choose the OK button.

 5. From the File menu, choose New and choose the OK button to create
    a new document. Type some text, then select the text and format it
    for the Script font.

 6. From the View menu, choose Header/Footer (Edit menu in version
    1.x), and choose the OK button to open the header. Type some text,
    then select the text and format it for the 10-point Century
    Schoolbook font. If you are in normal view, choose the Close
    button to return to the body text.

 7. Position the insertion point at the end of the document. From the
    Insert menu, choose Break, select Continuous in the Section Break
    box, and choose the OK button.

 8. From the File menu, choose Save. In the File Name box, type



    TEST2.DOC, and choose the OK button.

 9. From the File menu, choose New. From the Insert menu, choose File.
    In the File Name box, type TEST1.DOC, select the Link To File
    option, and choose the OK button.

10. Position the insertion point at the end of the document. From the
    Insert menu, choose Break, select Next Page in the Section Break
    box, and choose the OK button.

11. From the Insert menu, choose File. In the File Name box, type
    TEST2.DOC, select the Link To File option, and choose the OK
    button.

12. From the Edit menu, choose Select All (press CTRL+5 on the numeric
    keypad in version 1.x of Word for Windows) and press the F9 key to
    update the included files. If field codes are visible, choose
    Field Codes from the View menu.

13. From the View menu, choose Page Layout (Page in version 1.x) and
    scroll to the second page of the document.

Note that the header of the TEST2.DOC portion of the document is
formatted with the Script font, matching the body text of TEST2.DOC.
However, if you position the insertion point in the header text, the
Ribbon shows the font as Times New Roman.

Microsoft has confirmed this to be a problem in versions 1.0, 1.1,
1.1a, 2.0, 2.0a, 2.0a-CD, 2.0b and 2.0c of Word for Windows.This problem 
was corrected in Word version 6.0 for Windows.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 142,
248, 573

"Microsoft Word for Windows User's Reference," version 1 x  pages 124,
148, 161

Additional reference words: w4wformat  
switches reformats 1.00 1.10 1.10a 
2.00 2.00a 2.00a-CD 2.00b 2.00c  3.00 3.10



WinWord: Using Microsoft Graph to Create Vertical Text
Article ID: Q91070
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b
   2.0c, 6.0
 - Microsoft Graph, versions 3.0, 3.0a, and 3.0b
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

Summary:

You can use Microsoft Graph to create vertical text in your Microsoft
Word for Windows documents. This method, which is described below,
allows you to use your available Windows fonts. (You can also use
Microsoft WordArt to create vertical text; however, that method
requires a separate set of fonts.)

More Information:

In Microsoft Graph, you can type unattached text and apply vertical
orientation formatting. You can also apply shading and border
formatting. Use the following steps to create vertical text in
Microsoft Graph:

1. In Word for Windows, create a new document based on the normal
   template.

2. Launch Microsoft Graph.

3. Switch to the Datasheet window. Select the entire datasheet by
   clicking the blank square in the upper-left corner of the datasheet
   next to the column headings. From the Edit menu, choose Clear. Select
   the Clear Both option button and choose the OK button.

4. Switch to the Chart window. Type the desired text, which should
   appear as unattached text in the middle of the Chart window. Press
   ESC. Microsoft Graph surrounds the text with black selection squares.

5. From the Format menu, choose Text. Under Orientation, select one of
   the vertical orientation options. To change the font, choose the Font
   button. To add shading or border formatting, choose the Patterns
   button. When you are finished formatting, choose the OK button.

6. From the File menu, choose Exit And Return To <<Filename>>. Choose
   the Yes button when Microsoft Graph prompts you to update the graph.

7. You can crop, scale, and position the Microsoft Graph object in
   your Word for Windows document. 

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 340



"Microsoft Graph User's Guide," version 3.0, pages 7, 15-16, 76-78

Additional reference words: w4wformat  rotate top bottom landscape
wm_word portrait 2.00 2.00a 2.00a-CD 2.00b  2.00c  3.00 3.00a 3.00b



Word: Style List on Ribbon Shows Too Many Styles
Article ID: Q91654
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Microsoft Word for Windows adds unused standard styles to the styles box 
on the ribbon when you copy information from one document and paste it 
in another. Word should add styles to the styles box only if they are 
used in your document; instead, Word sometimes displays styles that you 
have never used in any document. When this happens, Word requires more 
time to display the list of styles when you select the drop-down arrow. 
You cannot delete these extraneous styles from the styles box once Word 
for Windows has added them to a document.

Microsoft has confirmed this to be a problem in Word versions 2.0, 2.0a,
2.0a-CD, 2.0b, and 2.0c. This problem was corrected in Word version 6.0 
for Windows.

More Information:

This problem occurs after you modify a standard style and save the 
changes in your NORMAL.DOT template file. If you later copy text from a 
document based on the revised NORMAL.DOT file and paste it in a new 
document, Word sometimes adds a large number of never-used standard 
styles to the styles box on the ribbon.

Workaround
----------

From the Format menu, choose Style. In the Style dialog box, select
the style you want to delete and choose the Delete button.

Note: This workaround works only for custom styles. It does not work for
standard styles because you cannot delete standard styles.

Steps to Reproduce Problem
--------------------------

1. Create a new document based on the default NORMAL.DOT template.

2. From the Format menu, choose Styles. Press CTRL+Y to display the
   complete list of Word standard styles in the Style Name list. Choose
   the Define button and select the Add To Template check box.

3. Select Annotation Reference in the Style Name box. Choose the 
   Character button, then choose the OK button. (You do not need to   
   modify any settings in the Character dialog box.) In the Styles 
   dialog box, choose the Change button. Choose the Yes button when Word 



   asks if you want to change the properties of the standard style, then 
   choose the Close button.

4. From the File menu, choose Exit. Choose the Yes button when you are
   prompted to save the global command and glossary changes, then   
   restart Word for Windows.

5. In a new document based on the default NORMAL.DOT template, type six
   single-line paragraphs. Be sure to press ENTER at the end of each
   line.

6. Position the insertion point on the first line and apply the Heading   
   1 style.

7. From the Edit menu, choose Select All. From the Edit menu, choose 
   Copy. Press CTRL+END to position the insertion point at the end of 
   the document.

8. Press SHIFT+INS ten times to paste ten copies of the text.

9. From the Edit menu, choose Select All. From the Edit menu, choose 
   Copy. From the File menu, choose New and choose the OK button to 
   create a new document based on the NORMAL.DOT template.

10. From the Edit menu, choose Paste.

11. Open the styles box on the ribbon. Note that many standard styles 
    are displayed, even though you have not used them in either 
    document. The only styles that Word for Windows should display are 
    Normal, Heading 1, Heading 2, Heading 3, and Annotation Reference 
    (the latter style displays because you modified it in step 3 above).

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 198-199

"Microsoft Word User's Guide," Word for the Macintosh version 5.0, page 
184

Additional reference words: w4wformat
2.00 2.00a 2.00a-CD 2.00b 2.00c w4wtemplate



WinWord: Border Splits Over Page Break
Article ID: Q91663
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c 
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if a paragraph or table with border
formatting extends over a page break, the border is split and the
following formatting problems occur:

 - The portion of the paragraph on the first page lacks a bottom border
   and the remainder of the paragraph on the next page lacks a top
   border.

   -and-

 - The portion of the table on the first page either lacks a bottom
   border or has the inside border applied to the bottom.

   -and-

 - The remainder of the table on the next page either lacks a top
   border or has the inside border applied to the top.

This problem was corrected in Word version 6.0 for Windows if you
apply the border to the bottom cell of one page and the top cell of
the following cell at the same time. If you apply the border to the
bottom cell of one page and then apply the border to the top cell of
the next page the above listed problem will occur.

More Information:

Workaround - Bordered Paragraph
-------------------------------

To work around this problem with a bordered paragraph, insert a paragraph
mark at the end of the first page to break the paragraph into two
paragraphs. This allows each paragraph to maintain a complete border.

Workaround - Bordered Table
---------------------------

To work around this problem with a bordered table, do one of the
following:

 - Position the insertion point in the first row on the second page and
   press CTRL+SHIFT+ENTER to split the table. Select the last row at
   the bottom of the first page and reapply the bottom border, then
   select the first row at the top of the next page and reapply the



   top border.

   Note: Reapplying the borders without splitting the table does not
   complete the border at the top of the second page.

   -or-

 - If you cannot split the table, select the two rows that span the
   page break and use the Format Border command to add a border to the
   bottom and top of the page.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 318,
362-364

"Microsoft Word for Windows User's Reference," version 1.x, pages
20-22, 369

Additional reference words: w4wformat
box line incomplete broken 1.00 1.10 1.10a
w4wtable 2.00 2.00a 2.00a-CD 2.00b



Word: Print Preview Does Not Display Background Shading
Article ID: Q92570
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

In Word for Windows, background shading border formatting does not display
in print preview.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Although background shading does not display in print preview, it prints
correctly. Foreground shading and pattern border formatting display
correctly in print preview.

This problem is independent of the Windows printer driver.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 377-379

Additional reference words: w4wformat 2.00 2.00a 2.00a-CD 2.00b shade
colored



Word for Windows: How to Create Crop Marks
Article ID: Q92600
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

Word for Windows includes no automatic feature that adds crop marks to your
document. This article presents two methods you can use to create crop
marks in your Word for Windows document.

More Information:

Crop marks are short lines at the corners of a page that show where the
outer edges of the paper should be trimmed:

       |               |
   ____|               |____

           Document
             Page

   ____                 ____
       |               |
       |               |

Below are two methods you can use to create crop marks in your Word for
Windows document. Method 1 is easier to set up; however, you may not be
able to position the crop marks close enough to the text of the document.
Method 2 allows greater precision in the positioning of the crop marks;
however, as mentioned earlier, Method 2 is more difficult to set up.

The companion disk for "Word for Windows 2.0 Macros," by Russell Borland,
includes a macro to create crop marks called InsertCropMarks. For more
information about this macro, which is located in EDITMAX.DOC, see page 440
of "Word for Windows 2.0 Macros".

Method 1: Insert a Three-Column Table in Header and Footer
----------------------------------------------------------

Using this method, you can create crop marks by inserting a three-column,
one-row table in the header and footer of your document and adding borders.

1. In the document header, insert a table that contains one row and three
   columns.

2. Select column 2. From the Table menu, choose Column Width. In the Width
   Of Column 2 box, type the distance between the left and right margin



   (for example, type 6 inches if your left and right margins are 1.25
   inches and your paper width is 8.5 inches). Choose the OK button.

3. Set the column width of columns 1 and 3 to 0.5 inches.

4. Select the entire table. From the Table menu, choose Row Height. In the
   Indent From Left box, type -.5". In the Height Of Row box, select
   Exactly. In the At box, type .5" and choose the OK button.

    Note: You can vary the position of your crop marks by adjusting the
    Indent From Left setting and the column width of columns 1 and 3. The
    column width of columns 1 and 3 must be the same. The Indent From Left
    setting must be the negative of the column width setting (for example,
    if the column width is 1", the Indent From Left setting must be -1").

5. Select column 1 and apply a right and bottom border. Select column 3 and
   apply a left and bottom border. The header table should look like this:

        |               |
   _____|               |_____

6. Copy the header and paste it into the footer.

7. In the footer table, change the border formatting in columns 1 and 3.
   Apply a top and right border to column 1. Apply a top and left border to
   column 2. The footer table should look like this:

   _____                 _____
        |               |
        |               |

Method 2: Create Four Framed, Single-Cell Tables
------------------------------------------------

  Note: These instructions are for use in versions 2.0, 2.0a, 2.0a-CD, and
  2.0b of Word for Windows only.

1. From the View menu, choose Header/Footer. Select Header and choose the
   OK button.

2. Insert two single-cell tables in the header. Apply the following table
   and border formatting to each table:

   a. From the Table menu, choose Column Width. In the Width Of Column 1
      box, select .5 inches. In the Space Between Cols box, select 0 inches
      and choose the OK button.

   b. From the Table menu, choose Row Height. In the Indent From Left box,
      select 0 inches. In the Height Of Row 1 box, select Exactly. In the
      At box, type a value, such as .5 inches, that represents the distance
      from the top edge of the paper where you want the top crop marks to
      appear. (For example, if you want a crop mark to appear .5 inches
      from the top edge of the paper, type .5" in the At box.) Choose the
      OK button.

   c. Select the first table. From the Format menu, choose Border. Select
      one of the line styles. Select the bottom and right sides in the



      Border box and choose the OK button.

   d. Select the second table. From the Format menu, choose Border. Select
      one of the line styles. Select the bottom and left sides in the
      Border box and choose the OK button.

3. Frame the tables. Choose the No button when Word for Windows asks if you
   want to switch to page layout view.

   a. Select the first table. From the Format menu, choose Frame. Select
      the following frame options and choose the OK button:

         Horizontal Position: Left
            Relative To: Page
            Distance from Text: 0"
         Vertical Position: 0"
            Relative To: Page
            Distance from Text: 0"

   b. Select the second table. From the Format menu, choose Frame. Select
      the following frame options and choose the OK button:

         Horizontal Position: Right
            Relative To: Page
            Distance from Text: 0"
         Vertical Position: 0"
            Relative To: Page
            Distance from Text: 0"

4. From the View menu, choose Header/Footer. Select Footer and choose the
   OK button.

5. Insert two single-cell tables in the footer. Apply the following table
   and border formatting to each table:

   a. From the Table menu, choose Column Width. In the Width Of Column 1
      box, select .5 inches. In the Space Between Cols box, select 0 inches
      and choose the OK button.

   b. From the Table menu, choose Row Height. In the Indent From Left box,
      select 0 inches. In the Height Of Row 1 box, select Exactly. In the
      At box, type a value, such as .5 inches, that represents the distance
      from the bottom edge of the paper where you want the bottom crop
      marks to appear. (For example, if you want a crop mark to appear .5
      inches from the top edge of the paper, type .5" in the At box.)
      Choose the OK button.

   c. Select the first table. From the Format menu, choose Border. Select
      one of the line styles. Select the top and right sides in the Border
      box and choose the OK button.

   d. Select the second table. From the Format menu, choose Border. Select
      one of the line styles. Select the top and left sides in the Border
      box and choose the OK button.

3. Frame the tables. Choose the No button when Word for Windows asks if you
   want to switch to page layout view.



   a. Select the first table. From the Format menu, choose Frame. Select
      the following frame options and choose the OK button:

         Horizontal Position: Left
            Relative To: Page
            Distance from Text: 0"
         Vertical Position: Bottom
            Relative To: Page
            Distance from Text: 0"

   b. Select the second table. From the Format menu, choose Frame. Select
      the following frame options and choose the OK button:

         Horizontal Position: Right
            Relative To: Page
            Distance from Text: 0"
         Vertical Position: Bottom
            Relative To: Page
            Distance from Text: 0"

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 313-342, 361-
380, 389-420, 571-584

"Word for Windows 2.0 Macros," Russell Borland, Microsoft Press, 1992, page
441

Additional reference words: w4wformat wm_word
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
cropmark w4wprint 2.00c insertcropmarks



Continuous Section Break in Glossary Entry Causes Page Break
Article ID: Q93346
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, and 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

If you define a glossary entry that contains a continuous section break,
that section break becomes a next-page section break when you insert the
glossary entry in your Word for Windows document.

Microsoft has confirmed this to be a problem in Word versions 2.0, 2.0a,
2.0a-CD, 2.0b, and 2.0c. This problem was corrected in Word version 6.0 
for Windows.

Workaround
----------

You must manually change the section break formatting from Next Page to
Continuous:

   Word 2.0
   --------

   1. Position the insertion point after the section break.

   2. From the Format menu, choose Section Layout.

   3. Select the Continuous option and choose the OK button.

   Word 1.x
   --------

   1. Position the insertion point after the section break.

   2. From the Format menu, choose Section.

   3. Select the No Break option and choose the OK button.

Additional reference words: w4wformat



Ruler Displays Incorrect Paragraph Formatting
Article ID: Q93555
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

Sometimes Word for Windows displays formatting on the ruler that is
different from the formatting you applied to the current paragraph. This
happens if Hidden Text is not being displayed and you position the
insertion point at the beginning of a paragraph that follows a paragraph
with Hidden Text character formatting.

This problem was corrected in Word version 6.0 for Windows.

If you select the first character of the paragraph that follows a paragraph
with Hidden Text formatting and press DELETE, Word for Windows deletes the
entire block of hidden text along with the first character.

On the other hand, if you backspace over the first character of the
paragraph that follows a paragraph with Hidden Text formatting, Word beeps
and does not delete the hidden text.

If you position the insertion point at the beginning of the paragraph that
follows a paragraph with Hidden Text formatting and type some text, Word
formats the new text with the paragraph formatting of the hidden paragraph
(minus the hidden text character formatting).

More Information:

Microsoft has confirmed this to be a problem in versions 2.0, 2.0a, 2.0a-
CD, 2.0b, and 2.0c of Word for Windows. This problem was corrected in
Word version 6.0 for Windows.

Steps to Reproduce Problem
--------------------------

1. From the Tools menu, choose Options. In the View category, under
   Nonprinting Characters, select the All option button. Clear all the
   other Nonprinting Characters check boxes and choose the OK button.

2. In a new Word for Windows document, type four single-line paragraphs.

3. Select the second and third paragraphs. From the Format menu, choose
   Paragraph. Select 1" in the From Left and From Right boxes and choose
   the OK button.

4. With the second and third paragraphs selected, choose Character from the
   Format menu. Select Hidden Text and choose the OK button.

5. Choose the Show/Hide Nonprinting Characters button on the ribbon.



   -or-

   From the Tools menu, choose Options. Under the View category, under
   Nonprinting Characters, clear the All check box. Choose the OK button.
   Notice that lines 2 and 3 disappear.

6. Position the insertion point at the start of line 4. Notice that the one-
   inch right and left margin indents appear on the ruler, even though the
   current paragraph contains no paragraph indent formatting.

7. Press the RIGHT ARROW key once. Notice that the ruler now displays the
   correct paragraph indent settings for the current paragraph.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 49, 144-
146, 149, 730

Additional reference words: w4wformat
2.00 2.00a 2.00a-CD 2.00b 2.00c 



Pressing CTRL+N Indents to Custom Tab, Not to Default Tab Stop
Article ID: Q94050
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, and 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When you press CTRL+N to apply indent paragraph formatting, Word for
Windows indents to the next tab stop, which may be a custom tab stop or a
default tab stop. In paragraphs that contain custom tab formatting, the
next tab stop might be a custom tab and not a default tab stop.

When you set a custom tab stop, Word deletes all default tabs to the left
of the custom tab stop. As a result, when you press CTRL+N, Word will
indent the paragraph to the custom tab stop. For example, if you set a
custom tab stop at 4 inches, Word deletes all incremental default tab stops
that occur before the 4-inch mark. If you then press CTRL+N, Word sets a
left indent at 4 inches instead of at the default .5-inch tab stop.

This behavior occurs with all tab stops (left, right, decimal, and center
alignment).

This problem was corrected in Word version 6.0 for Windows.

Workaround
----------

In paragraphs that contain custom tab stops, do not use CTRL+N to set
indent formatting to the default tab stops. Instead, select the paragraph
and apply the indent formatting by choosing Paragraph from the Format menu.
Select a From Left setting and choose the OK button.

More Information:

There is a documentation error on page 170 of "Microsoft Word for Windows
User's Guide," version 2.0. The heading at the top of the page incorrectly
reads as follows:

   To indent a paragraph to the next default tab stop...

Instead, it should read as follows:

   To indent a paragraph to the next tab stop...

Note: The online Help topic is correct.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 169-171



Additional reference words: w4wformat
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Cannot Use Spaces to Indent a Wrapped Line
Article ID: Q94241
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

You cannot use spaces to indent a line of text that is wrapped from a
previous line. If you insert spaces at the beginning of a wrapped line, the
spaces attach themselves to the end of the previous line. If you continue
to enter spaces they will run on past the right margin instead of wrapping
and appearing at the beginning of the following line.

There are four ways to work around this problem:

1. Use hanging indents.

   Hanging indents allow you to set different indents for the first line of
   a paragraph and its subsequent lines. To use a hanging indent with a
   paragraph, follow these steps:

   a. Highlight the text you want to indent.

   b. From the Format menu, choose Paragraph.

   c. In the Indentation section, enter your desired measurements.

   For example, if you do not want the first line to be indented at all,
   but you want the subsequent lines to be indented by half an inch, enter
   the following measurements:

   From Left:  0.5"
   From Right:   0"
   First Line: -0.5"

   You can also set indent measurements by dragging the indent markers on
   the ruler.

2. Use nonbreaking spaces.

   Insert nonbreaking spaces at the beginning of the wrapped line. To
   insert nonbreaking spaces, position your insertion point at the
   beginning of the line and press CTRL+SHIFT+SPACEBAR.

   Word treats nonbreaking spaces like printable characters. Unlike regular
   spaces, nonbreaking spaces follow the standard rules regarding text
   wrapping.

3. Enter a hard-carriage return.



   Before entering spaces at the beginning of the line you wish to indent,
   press the ENTER key once. This severs the line you are on from the
   previous line; it is no longer wrapped. Spaces you enter will now push
   the text on the line forward.

4. Use tab characters.

   Instead of entering spaces at the beginning of the line, press TAB to
   insert a tab character instead.

For more information on using hanging indents in Word, see pages 171-174 in
the "Microsoft Word User's Guide."

For more information on using nonbreaking spaces in Word, see pages 90-91
in the "Microsoft Word User's Guide."

For more information on how Word wraps text, see page 87 in the "Microsoft
Word User's Guide."

Additional reference words: w4wformat 2.00 2.00a 2.00b 2.00c 2.00a-CD wm_word 
wordwrap align spacebar



Line Spacing Before Causes Clipped Text in Column
Article ID: Q94266
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In page layout view, if a document is formatted for two or more newspaper-
style columns and a new paragraph that is formatted for .3 to .9 line
spacing before begins at the top of the second or succeeding page of
columnar text, the first line of all columns (except the first column)
appear clipped. However, the text prints correctly.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this
problem and will post more information here in the Microsoft Knowledge
Base as it becomes available.

Steps to Reproduce Problem
--------------------------

1. Type two or more full pages of text.

2. From the Edit menu, choose Select All. From the Format menu, choose
   Paragraph and set Space Before to .5 li. Choose the OK button.

3. From the Format menu, choose Columns. Set the number of columns to 2 or
   more, then choose the OK button.

4. Go to the end of the first page, and press ENTER after the last
   character on the page so that the second page will start with a new
   paragraph.

5. From the View menu, choose Page Layout.

Notice that on the second page the first line of text in the second column
(and each column after the second column if you set the number of columns
greater than 2) appears clipped at the top. This is a display problem only.
The text will not be clipped when it is printed.

REFERENCES
==========

"Microsoft Word for Windows User's Guide", pages 187, 348-350, 444

Additional reference words: w4wformat chopped missing gone cut off wm_word 



snaking 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00



Text in One Section Overlaps Text in Next Section on Page
Article ID: Q94270
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Word for Windows, if you create a one-page document that contains two
sections and format both sections for Justified vertical alignment using
the Section Layout command from the Format menu, the sections may overlap
when you print the document or view it in the print preview window.

The document displays correctly in normal view and page layout view (by
design, Word does not display the vertical alignment formatting in
page layout view).

More Information:

Word vertically justifies each section separately on the page, which
causes section 1 to superimpose itself on section 2.

Note: This problem does not occur in versions 1.x of Word for Windows.
In versions 1.x, Word ignores such incompatible vertical justification,
so the sections do not overlap.

Workarounds
-----------

 - Replace the Continuous section break with a Next Page section break.
   This causes each section to appear vertically justified on a separate
   page.

 -or-

 - Remove the Justified vertical alignment formatting. To do this, select
   the entire document and choose Section Layout from the Format menu.
   Clear the Justified option under Vertical Alignment and choose the OK
   button.

Microsoft has confirmed this to be a problem in versions 2.0, 2.0a, 2.0a-
CD, 2.0b, 2.0c, 6.0 of Word for Windows. We are researching this problem and
will post new information here as it becomes available.

Additional reference words: w4wformat
2.00 2.00a 2.00a-CD 2.00b 2.00c overlaying
overlayed write over on top under behind front overwritten garbled
places



Cannot Replace Hidden Paragraph Marks with Unhidden Formatting
Article ID: Q95076
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========
 
If your Word for Windows document contains paragraph marks formatted
as hidden text, the Replace command on the Edit menu does not replace
the hidden paragraph marks with nonhidden paragraph marks.
 
STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. 

Steps to Reproduce Problem
--------------------------
 
1. In a Word for Windows document, apply Hidden character formatting
   to one or more paragraph marks.
 
2. From the Edit menu, choose Replace. If the Clear button is
   available, choose it.
 
3. In the Find What box, type "^p" (without the quotation marks).
   Choose the Character button. Select the Hidden option and choose
   the OK button.
 
4. In the Replace With box, type "^p" (without the quotation marks).
 
5. Choose the Replace All button and then choose the Close button.
 
Result: Word did not replace the hidden paragraph marks with unhidden
paragraph marks.
 
Additional reference words: w4wformat 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c non-hidden 



Change Case (SHIFT+F3) Does Not Work with All Caps Formatting
Article ID: Q95100
-----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-----------------------------------------------------------------------

SYMPTOMS
========

In Word for Windows, pressing SHIFT+F3 to change the case of a
selection has no effect if the text contains All Caps character
formatting.

If the text contains Small Caps character formatting, Word
distinguishes between uppercase and lowercase letters by increasing
the point size of uppercase letters.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

WORKAROUND
==========

To change the case of the text that contains All Caps character
formatting, remove the All Caps formatting and press SHIFT+F3. To
remove All Caps formatting, select the text to be changed and press
CTRL+SPACEBAR, or:

1. Select the text to be changed.

2. From the Format menu, choose Character.

3. Clear the All Caps check box.

4. Choose the OK button.

Additional reference words: w4wformat 2.00 2.00a 2.00a-CD 2.00b 2.00c
toggle



Header Text Lost When Margin and From Edge Value the Same
Article ID: Q95110
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========
 
When the Margin (in the Page Setup dialog box) and From Edge (in the
Header/Footer dialog box) values are the same, under some
circumstances Word For Windows will cut off or misplace the header in
a document.
 
WORKAROUND
==========
 
If you change the value in From Edge in the Header/Footer dialog box
to a different value than the Margin setting, everything works as
expected.
 
Steps to Reproduce Problem
--------------------------
 
 1. Create a new document based on the Normal template.
 2. From the View menu, choose Page Layout.
 3. Type "This is body text" at the insertion point in the body.
 4. From the Format menu, choose Page Setup; set Top and Bottom margins
    to 1 inch and choose the OK button.
 5. From the View menu, choose Header/Footer.
 6. Select the Different First Page check box.
 7. Under From Edge, set Header and Footer to 1 inch.
 8. Under Header/Footer, select Header, and choose the OK button.
 9. Type "This is line one." Press ENTER.
10. Type "This is line two." Press ENTER.
11. Type "This is line three." 
12. From the Edit menu, choose Select All to highlight the paragraphs
    in the header.
13. From the Format menu, choose Paragraph, and specify 1 line in the
    Spacing Before box. Choose the OK button.
14. Place the insertion point in the body of the text after "This is 
    body text."
15. From the Insert menu, choose Break, select Page Break, and choose
    the OK button.
16. Type "This is page two."
17. From the View menu, choose Header/Footer.
18. Under Header/Footer box, select Footer, and choose the OK button.
19. Type "This is the footer."
20. Press CTRL+HOME to go to the start of document.
 
Notice the third line has disappeared. It will not print, or it will



print in the body text.
 
Additional reference words: w4wformat 2.00 2.00a 2.00a-CD 2.00b 2.00c wm_word 
disappear cut off 6.00



Underline Formatting Does Not Appear at End of Line
Article ID: Q97793
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

In Word for Windows, if you apply underline character formatting to a
line that contains only spaces, the underline does not appear or
print. There must be at least one character other than a space at the
end of a line for underline formatting to appear. Similarly, underline
character formatting does not appear on spaces following the last
character on a line.

WORKAROUND
==========

Use one of the following procedures to extend an underline past the
end of text on a line:

 - Type at least one nonbreaking space at the end of the line where
   you want the underline to stop. To type a nonbreaking space, press
   CTRL+SHIFT+SPACEBAR.

 - Set a right-aligned tab stop at the position where you want the
   underline to stop. Apply underline formatting to the tab.

 - Set a right-aligned tab stop with a solid, underscore leader
   (select the Leader 4 option button in the Tabs dialog box).
 
If you apply hidden and underline character formatting to text, the
underline formatting displays on the screen but does not print and
does not display in print preview.
 
REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 18, 19,
90, 91, 144-146, 178-183

"Microsoft Word for Windows User's Reference," version 1.x, pages 33-
35, 77, 177, 382
 
Additional reference words: 6.00 w4wformat 1.00 1.10 1.10a 2.00 2.00a
wm_word 2.00a-CD 2.00b 2.00c



Can't Remove Character Formats Using Ribbon or Shortcut Keys
Article ID: Q98265
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
In Word for Windows, you can apply character formatting to a selection
that contains 50 paragraphs or more using the buttons on the ribbon or
the shortcut keys, but you cannot remove that formatting in the same
manner. You must use the Character command from the Format menu to
remove character formatting from a selection that is larger than 50
paragraphs.
 
For example, if you select more than 50 paragraphs and apply bold
character formatting by pressing CTRL+B or by choosing the Bold button
on the ribbon, you cannot remove the bold formatting by pressing
CTRL+B again or by choosing the Bold button again. To remove the bold
formatting, choose Character from the Format menu, clear the Bold
check box, and then choose OK.

This functionality has changed in Word version 6.0

Reference(s):
 
"Microsoft Word for Windows User's Guide," version 2.0, pages 138,
146-147
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wformat



Edit Undo Formmatting Command Deletes or Modifies Bookmark
Article ID: Q98880
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
If you apply character formatting to a selection that includes the
text preceding a bookmark plus all or part of the bookmarked text and
then use the Edit Undo Formatting command to remove the formatting,
the bookmark no longer includes the selected text. In other words,
Word for Windows removes the bookmark formatting as well as the
character formatting.
 
This problem does not occur unless you use the Undo command to remove
character formatting.

This problem was corrected in Word version 6.0 for Windows.
 
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wformat



How To Justify the Last Line of a Justified Paragraph
Article ID: Q100102
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========

When using the jusified paragraph formatting, Word for Windows is
designed to justify all the lines in the paragraph except the last
line. Similiarly, Word will not justify a single line paragraph. This
article describes a workaround you can use to justify the last line of
a justified paragraph or to justify a single line paragraph.

WORKAROUND
==========

At the end of the paragraph, insert a newline character by pressing
SHIFT+ENTER. Do not delete the existing paragraph mark.
 
Note: If the addition of a newline character produces too much line
space after the paragraph, you can adjust one of the following
settings:
 
 - Decrease the Space After setting for the paragraph that contains
   the newline character.
 
   -or-
 
 - Decrease the Line Spacing setting for the blank paragraph (if one
   exists) between paragraphs.

   -or-

 - Decrease the Space Before setting for the next paragraph.

REFERENCES
==========

"User's Guide," version 2.0, pages 166-168

Additional reference words: 6.00 w4wformat 2.00 2.00a 2.00a-CD 2.00b
2.00c wm_word spread out margin



WinWord Uses Wrong Page Size Setting with Windows NT
Article ID: Q103662
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows NT operating system version 3.1
 - Microsoft Windows NT Advanced Server version 3.1
-------------------------------------------------------------------

SYMPTOMS
========

If two or more forms (custom page sizes) under Windows NT have the
same paper size, Word for Windows can only use one of them.

For example, if you create a form named "Letterhead" with a page size
of 8.5-by-11 inches (which is the same dimension as the standard
Letter page size in the U.S. version), Word includes this form on the
Page Size list in the Format Page Setup dialog box. If you select
Letterhead from the Page Size list, choose OK, then reopen the Page
Setup dialog box, Word changes the Page Size setting to Letter. Word
selects the first item on the Page Size list that matches the
specified dimensions.

CAUSE
=====

A Word document retains information about page size based on the form
size, not its name. Word uses the first selection on the Page Size
list that matches the specified dimensions, which means that Word may
not select the correct form when more than one has the same
dimensions.

Word includes the custom forms you define in Windows NT in the Page
Size list box in the Format Page Setup dialog box.

STATUS
======

We are researching this problem and will post new information here in
the Microsoft Knowledge Base as it becomes available.

MORE INFORMATION
================

In Windows NT, the administrator can define forms in addition to the
standard forms supported by the printer (such as Letter, Legal or
Envelope #10). These forms are defined by any name and any size.
Windows NT also allows more than one form to be defined as the same
size. When the Windows printer driver reports the paper sizes to Word,
Word includes the custom-defined forms in the Paper Size list.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wformat



wrong page setting selection



Vertical Cell Alignment Not Supported in Word for Windows
Article ID: Q105915
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Word for Windows does not support vertical alignment for table cells.

For example, if you copy cells from a Microsoft Excel spreadsheet that
are formatted for Center or Bottom vertical alignment, and then paste
them into a Word document, the height of the cell remains the same,
but Word places the text at the top of the cell. In other words, the
vertical alignment formatting is lost.

Additional reference words: 6.00 w4wformat w4wtable



Footnotes and Endnotes Not Renumbered with Revision Marks On
Article ID: Q106072
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========
 
Word 6.0 does not renumber the footnotes and endnotes when you delete
a footnote if the Mark Revisions While Editing option is selected in
the Revisions dialog box. (To locate this option, choose Revisions
from the Tools menu.)

Word 2.x does not renumber the footnotes when you delete a footnote if
the Mark Revisions option is selected in the Revision Marks dialog
box. (To locate this option, choose Revision Marks from the Tools
menu.)
 
This behavior is inconsistent with the behavior of other numbering
features, such as heading and line numbering, which renumber when the
Mark Revisions option is on.

STATUS
======
 
We are researching this problem and will post new information here in
the Microsoft Knowledge Base as it becomes available.
 
Additional reference words: 6.00 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wformat



Page Setup Command Unavailable in Unprotected Section
Article ID: Q106342
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, version 6.0
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------

SYMPTOMS
========

In a multiple-section Word for Windows document that contains both
protected and unprotected sections, the Page Setup command on the File
menu is unavailable (dimmed) in the unprotected section.

This command should be available when the insertion point is in an
unprotected section.

STATUS
======

We are researching this problem and will post new information here in
the Microsoft Knowledge Base as it becomes available.

WORKAROUND
==========

Do one of the following to change Page Setup settings in the
unprotected section of a document:

 - Adjust the margins by dragging the margin boundaries on the rulers.

   -or-

 - Unprotect the document (from the Tools menu, choose Unprotect
   Document), modify the Page Setup settings, and then protect
   the document again (from the Tools menu, choose Protect Document).

   IMPORTANT: If you enter text in your FORM fields while the document
   is protected, then unprotect the document to change the Page Setup
   settings, and then re-protect the document, Word removes any text
   you entered in the FORM fields. In other words, Word clears the
   form and resets the text in the FORM field to the default text you
   defined when you created the form. Although this is a drawback to
   the above workaround, it is a design feature of Word.

Additional reference words: 6.00 Dim Dimmed Grey Gray greyed grayed
w4wformat



WinWord: Center Vertical Alignment Causes Gap After Frame
Article ID: Q102141
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   and 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========
 
When you select the Center Vertical Alignment option in the Format
Section Layout dialog box, Word for Windows may insert extra space
after a frame, which causes a gap under the frame. This space does not
appear on the screen in all views, but it appears in print preview and
when you print the document.
 
If you change the Vertical Alignment section layout setting to Top or
Justified, Word does not add any extra space after the frame.
 
The Center Vertical Alignment option is designed to center the
information on a page between the top and bottom margins. It should
not change the spacing between page elements.
 
Microsoft is researching this problem and will post new information
here in the Microsoft Knowledge Base as it becomes available.
 
WORKAROUND
==========
 
If you want to vertically center a page that contains a frame, do not
use the Center Vertical Alignment option. Instead, use one of the
following methods to manually center the page:
 
 - Insert paragraph marks at the top of the page.
 
   -or-
 
- In the Paragraph dialog box, change the Before, After, and Line
  Spacing paragraph settings under Spacing.

 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wframe
centered expands expanded gaps pictures picture spaced



Insert Break, File Page Setup, and Format Columns Unavailable
Article ID: Q105812
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========
 
In Word version 6.0 for Windows, the Insert Break, File Page Setup,
and Format Columns commands are unavailable if the insertion point is
in a frame. Similarly, in Word versions 2.x for Windows, the Insert
Break command is unavailable if the insertion point is in a frame.
 
CAUSE
=====
 
These commands are unavailable because frames cannot extend beyond a
page break and frames cannot contain multiple columns. Many of the
features available through File Page Setup and Insert Break will cause
page breaks or Next Page section breaks to be inserted. Since frames
cannot span a page break, features that create page breaks are
disabled when the insertion point is in a frame.
 
MORE INFORMATION
================

In Word 2.x, the Format Page Setup and Format Columns commands are
available, but if you use these commands while the insertion point is
in a frame, Word applies the formatting to the section in which the
frame is located. This behavior is somewhat misleading, so Microsoft
decided to disable the Insert Break and Format Columns commands in
Word 6.0 when the insertion point is in a frame.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00
w4wframe change frames grey greyed gray grayed dim dimmed disabled
WM_WORD



Borders Misalign in Framed, Indented Paragraphs
Article ID: Q106404
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------

SYMPTOMS
========

In Word for Windows, paragraphs with different indentation settings
that are contained in a single frame will display with separate
borders instead of showing one border around the entire frame.

CAUSE
=====

Borders around paragraphs in Word are placed directly around the text
area, whether or not the paragraph is formatted for indentation. If no
paragraph indentation is set, a border set around the paragraph will
go from the left margin to the right margin, even if the paragraph
contains only one character.

This functionality takes precedence over frame borders in Word, so it
is not currently possible to have one contiguous border around a frame
containing multiple paragraphs with different indentation.

STATUS
======

Microsoft has confirmed this to be a problem in Microsoft Word for
Windows, versions 2.x and 6.0. We are researching this problem and
will post new information here in the Microsoft Knowledge Base as 
it becomes available.

WORKAROUND
==========

Set indentation on all paragraphs contained in a frame to the same value.

Alternatively, in Word 6.0, you can use the frame and text box feature
together to simulate the desired results, as described in the
following instructions. The text box feature is not available in Word
2.x.

1. Create a Text Box by selecting the Text Box tool from the Drawing
   toolbar, then drawing a box in the location where the framed text
   is desired.

2. Type the desired text in the box, and apply the desired
   indentations.



3. Select the border of the Text Box, then click the Line Color tool
   on the Drawing toolbar.

4. In the Line Color dialog box, select None.

5. From the Insert menu, choose Frame, then draw a frame of the
   desired size around the text box. The text box should anchor to the
   paragraph mark in the frame, so when the frame is moved, the text
   box will move with it.

MORE INFORMATION
================

For more information on how Word handles paragraph indentation in
frames, query on the following words in the Microsoft Knowledge Base:

   frame and indented and misalignment and winword

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00
w4wframe wm_word



Frame Formatting Changes Differently Based on Sizing Handle
Article ID: Q106406
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------

SYMPTOMS
========

If you resize a frame by dragging the sizing handles with the mouse,
Word for Windows changes the Horizontal Position and Vertical Position
settings differently in the Frame dialog box, depending on which
sizing handle you drag. (To locate the Frame dialog box, choose Frame
from the Format menu.)

CAUSE
=====

Word anchors the position of a frame at the upper-left corner of the
frame. If you drag a sizing handle that changes that point either
horizontally or vertically, Word changes the position formatting for
the frame.

MORE INFORMATION
================

Below is a table that lists the rules Word uses to change the
position formatting of a frame when you resize it using the mouse.
The numbers in parentheses refer to the numbered sizing handles in
the diagram following this table.

   Dragging This Handle            Has This Effect
   --------------------            ---------------

   Any handle on the right         Does not change horizontal
   side (3, 5, 8)                  position settings

   Any handle on the bottom        Does not change vertical
   side (6, 7, 8)                  position settings
   
   Any handle on the left          Adjusts horizontal position to
   side (1, 4, 6)                  an absolute value relative to 
                                   page
   
   Any handle on the top           Adjusts vertical position to
   side (1, 2, 3)                  an absolute value relative to 
                                   page

The following diagram and table describe the specific effect of
dragging each sizing handle on a frame (numbers 1 through 8 represent
sizing handles:



   1----2----3
   |         |
   |         |
   4  FRAME  5
   |         |
   |         |
   6----7----8

   Sizing     Effect of Dragging
   Handle     on Frame Position Formatting
   ------     ----------------------------

     1        Adjusts vertical and horizontal to absolute position,
              relative to page (this handle is the position anchor for
              the frame).

     2        Adjusts vertical to absolute position, relative to page.
              Does not change horizontal.

     3        Adjusts vertical to absolute position, relative to page.
              Does not change horizontal.

     4        Adjusts horizontal to absolute position, relative to
              page. Does not change vertical.

     5        Does not change vertical or horizontal.

     6        Adjusts horizontal to absolute position, relative to
              page. Does not change vertical.

     7        Does not change vertical or horizontal.

     8        Does not change vertical or horizontal.

REFERENCES
==========

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00
w4wframe wm_word



Print Preview Incorrect with Shaded Frame on top of Border
Article ID: Q87321
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

If you position a shaded frame over a portion of a bordered paragraph
in Microsoft Word for Windows, the shaded frame appears to overlay the
frame when you view the page in Print Preview. When you print the
page, the border prints on top of the shaded frame.

This problem was corrected in Word version 6.0 for Windows.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. Create a new document in Word for Windows. Using the steps on page
   367 of the "Microsoft Word for Windows User's Guide," create a
   border around the page.

2. From the Insert menu, choose Frame. Drag to create a 2-inch by
   2-inch frame. Choose the Yes button if prompted to switch to Page
   Layout view.

3. From the Format menu, choose Border. Choose the Shading button.

4. In the Foreground and Background boxes, select a color other than
   Auto. Choose the OK button twice.

5. Position the shaded frame so that it overlaps part of the page
   border you created in step 1 above.

6. From the File menu, choose Print Preview. Notice that the shaded
   frame overlaps the page border.

7. Choose the Print button and print this document.

Notice that the page border overlaps the shaded frame.

Note: If you are printing to a PostScript printer and you chose Black
in the Foreground and Background boxes in step 4 above, a portion of
the shaded frame prints reversed (white on black). This does not occur
with other printers such as the HP LaserJet Series printers.

For more information on frames and positioning, query on the following



words in the Microsoft Knowledge Base:

   frame and overlap and winword

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 367,
393-397

Additional reference words:2.00 2.00a 2.00a-cd 2.00b 2.00c apo
w4wgraphics w4wprint superimpose opaque transparent under
behind front



256-Color Bitmap Pastes into Word Smaller Than Expected
Article ID: Q105917
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========
 
A 256-color bitmap may paste into a Word for Windows document smaller
than it pastes into other applications such as HiJaak, Microsoft
Excel, or PowerPoint.
 
CAUSE
=====
 
The scaling fields in the bitmap tell the application how to display
and print the graphic. Word is a printer-centric application, so it
displays the graphic using the printing instructions in the graphic
file. In other words, Word displays the graphic as it will print. By
contrast, display-centric applications such as Microsoft Excel or
PowerPoint display the graphic using its display instructions (instead
of the printing instructions).
 
Additional reference words: w4wgraphics picture size HiJaak 2.00 2.00a
2.00a-CD 2.00b 2.00c 6.00 wm_word



Changing Default Settings for Subscripts and Superscripts
Article ID: Q37801
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

By default, the subscript or superscript formats in Microsoft Word for
Windows are set to 3 pts above and below the baseline. You
can, however, record a macro with a different point settings for
superscript or subscript.

MORE INFORMATION
================

Use the following procedure to record the macro:

Word for Windows version 6.0
----------------------------

1. Position the insertion point where you want to include
   superscripting/subscripting.

2. From the Tools menu, choose Macro. Then select Record. If you desire,
   give the macro a Tool Bar button, Short Cut Key or Menu Assignment. 
   Name the macro, and choose the OK button.

NOTE: you may give the macro an assignment after it has been recorded
later.

3. From the Format menu, select Font.  Then Character Spacing.

4. Modify the character spacing position to the desired setting (for
   example, raised 12-point). Choose the OK button.

5. Choose the Stop button on the floating tool bar Recorder.

Word for Windows version 2.0
----------------------------

1. Position the insertion point where you want to include
   superscripting/subscripting.

2. From the Tools menu, choose Record Macro. Name the macro, and
   choose the OK button.

3. From the Format menu, select Character.

4. Modify the character format to the desired setting (for example,



   superscript 12-point). Choose the OK button.

5. From the Tools menu, choose Stop Recorder.

6. Add the formatting to a menu or assign to a key using one or both
   of the following methods:

To assign to a menu, follow these steps:

   a. From the Tools menu, select Options and choose Menus as the
      Category.

   b. Select the Macros button in the Show group box.

   c. Select the macro and choose the menu to assign it to.

   d. Choose the Add button and the Close button.

To assign to a key, follow these steps:

   a. From the Tools menu, select Options and choose Keyboard as the
      Category.

   b. Select the Macros button in the Show group box.

   c. Select the macro and choose the key combination to assign it to.

   d. Choose the Add button and the Close button.

Word for Windows versions 1.x
-----------------------------

1. Position the insertion point where you want to include
   superscripting/subscripting.

2. From the Macro menu, choose Record. Name the macro, and choose the
   OK button.

3. From the Format menu, select Character.

4. Modify the character format to the desired setting (for example,
   superscript 12-point). Choose the OK button.

5. From the Macro menu, choose Stop recorder.

6. Add the formatting to a menu or assign to a key using one both of
   these methods:

To assign to a menu, follow these steps:

   a. From the Macro menu, select Assign to menu.

   b. In the Macro Name list box, select the macro created above.

   c. In the Menu list box, select the name of the menu that you want to
      assign to macro to.



   d. Choose the Assign button.

   e. Choose the OK button.

To assign to a key, follow these steps:

   a. From the Macro menu, select Assign to key.

   b. In the name list box, select the name of the macro created
      above.

   c. Press the key to assign to that function (for example,
      CTRL+SHIFT+S).

   d. Choose the OK button.

Additional reference words: w4wmacro 2.0 2.00 1.0 1.1 1.1a 1.00 1.10
wm_word 1.10a 6.00



AutoClose Macro Is Executed Before Document Is Closed
Article ID: Q41735
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

In Microsoft Word for Windows, an AutoClose macro runs whenever you
close a document. However, if changes have been made to the document
since the last save, after the AutoClose macro finishes, Word prompts
you to save the changes.
  
To make sure that the document closes without the save message, an
AutoClose macro should use the command "FileSaveAll 1" to save all
edited documents automatically without prompting.

REFERENCES
==========

"Microsoft Using WordBasic," page 208.

Additional reference words: 6.00 1.00 1.10 1.10a 2.00 2.00a w4wmacro wm_word 



Word for Windows: Macro Language Doesn't Support END Command
Article ID: Q41743
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======
 
Many versions of BASIC support the END command to exit the current
program. Although the Microsoft Word for Windows macro language is
similar to BASIC, it does not support this command. Using END causes a
macro error.

MORE INFORMATION
================

To exit out of a WordBasic macro, use the following:

 - A Goto statement with a Lable just before End Sub. 

 Sub Main
 Msgbox "This is the first message box"
 Goto Bye
 MsgBox "this is the second message box that will not appear"
 Bye:
 End Sub

-or-

 - Use the STOP command.  The STOP command will initiate a
   dialog box stating "Macro Interrupted".

REFERENCES
==========

"Using WordBasic" pages 230 and 292.

Additional reference words: w4wmacro pop up 1.00 1.10 1.10a 2.00 2.00a
wm_word 2.00a-CD 2.00b 2.00c



"Illegal Function Call" Error When Using a Dialog Box
Article ID: Q45745
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

The following are possible causes of an "Illegal function call"
(Err=5) in a macro that includes a dialog box:

1. The location or size of the dialog box causes the box or some
   portion of the box to be off the screen. This can be identified by
   the error occurring at the "Begin Dialog" statement.

2. The location or size of an item in the dialog box may cause the
   item or some portion of the item to be outside the dialog box. This
   can be identified by the error occurring at that particular item in
   the definition (Begin Dialog ... End Dialog) of the dialog box.
   For example:

   Sub Main
   Begin Dialog UserDialog 50, 50
   OK Button 10, 25, 60, 30 'the size is outside the dialog boundaries
   End Dialog
   Dim SampleDlg As Dialog UserDialog
   Dialog SampleDlg
   End Sub

3. The dialog box definition does not include an OK and/or Cancel button.
   This error can be identified by the error occurring at the "Dialog"
   statement.

4. The dialog box is larger than the maximum size of a dialog box.
   For example:

      Begin Dialog UserDialog 5000, 5000

   The above coordinates exceed the maximum size.

5. Specifying more than one OK or Cancel button in a Microsoft WordBasic
   custom dialog box causes the error message.

   Note: You can specify a single OK or Cancel button and rename the
   buttons.

6. No buttons (OK, cancel, etc.) will cause the "illegal function call"
   error message. The dialog has to have a way to exit.

   For more information, query on the following:

      creating and custom and OK and cancel and buttons and word and
      windows



Additional reference words: w4wmacro 1.0 1.1 1.1a 2.0 1.00 1.10 1.10a
2.00 2.00a-CD 2.00b 2.00c 6.00



Using the OPEN Statement in Word for Windows Embedded BASIC
Article ID: Q47518
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

The OPEN statement is part of the Word for Windows Embedded BASIC (EB)
language. This command allows you to open a data file for reading,
modifying, or adding to the file.

Note that the OPEN statement does not open the file into the
workspace, it merely opens the file for manipulation by your macro.

The correct syntax for the OPEN statement is

   OPEN [File] FOR [Mode] AS [#]FileNumber

where [File] is the name of the file you will be accessing; [Mode] is
Output, Input, or Append; and [#]FileNumber associates a unique file
number with that file.

MORE INFORMATION
================

Mode Statements
---------------

"Output" opens a file for data to be output to. If the file already
exists, the existing file is overwritten with no warning.

"Input" opens an existing data file so records can be read from it.

"Append" opens an existing data file (or creates a new one if a file
of that name doesn't exist) so new records can be added to the end of
the file.

File Number
-----------

The file number associates a unique file number with that file, as
long as that file is open. When the file is closed, the file number
can then be assigned to another file that is being opened.

Statement Example
-----------------
Sub MAIN
OPEN "Datafile.txt" FOR Input AS #1
Write #1, "Testing",123,"Testing"



End Sub

This macro will create or open a file called Datafile.txt and put in the
comma and quote deliminated data into the file. The data can then later be
retrieved using WordBasic command "Read".

REFERENCES
==========

Additional reference words: w4wmacro word basic wordbasic 1.00 1.10
1.10a wm_word 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00



Word for Windows Macro Language is Interpretive
Article ID: Q47521
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Word for Windows Embedded Basic (EB) language is an interpreted
language. Rather than compiling (translating all the statements prior
to executing the statements), the Word for Windows interpreter
translates each statement and executes the statement as it is
encountered in the macro.

However, before you run a macro, Word for Windows tokenizes the
current macro. During tokenizing, any syntax errors (such as a FOR
loop without a NEXT statement or a WHILE statement without a closing
WEND) generate warnings from Word for Windows, giving the false
appearance that the code is being compiled.

Additional reference words: w4wmacro 1.0 1.1 1.1a 2.0 1.00 1.10 1.10a
2.00 6.00



Accessing the Ruler from the Keyboard in Windows Word
Article ID: Q48402
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

You can perform all ruler functions except for setting table column
widths and page margins from the keyboard in Microsoft Word for
Windows. Column widths and page margins must be set with a mouse or
through the menus.

MORE INFORMATION
================
 
The following is a list of how to access the ruler functions from the
keyboard:

   Function                   Key(s) to Press
   --------                   ---------------

   Access the ruler           CTRL+SHIFT+F10
   Move on ruler              LEFT and RIGHT ARROW

After moving, use the following keys to set indents and tabs:

   Function                   Key(s) to Press
   --------                   ---------------

   Indents
      Left indent             L
      First line              F
      Right indent            R

   Tabs
      Left                    1
      Center                  2
      Right                   3
      Decimal                 4
      To accept tab           INS
      To remove tab           DEL
      under ruler cursor

The following are active only while in the text of the document:

   Function                   Key(s) to Press
   --------                   ---------------

   Paragraph Alignment



      Flush left              CTRL+L
      Centered                CTRL+C
      Right                   CTRL+R
      Justified               CTRL+J

   Line Spacing
      Single spacing          CTRL+1
      1.5 spacing             CTRL+5
      Double spacing          CTRL+2

   Paragraph Spacing
      Space before            CTRL+O (the letter "O")
      Remove space before     CTRL+E

The ruler view cannot be selected with a default keystroke. Assigning
a keystoke combination to a macro accomplishes the same function. To
do this, follow these steps:

1. From the Macro menu, choose Assign to Key.

2. Under the Assign Macro Name section, select ChangeRulerMode.

3. Press the keystroke to which you want to assign this function. For
   example, CTRL+SHIFT+R.

4. Choose the Assign button.

5. Choose the OK button.

For more information on how to assign macros to keys, refer to the
macro sections in "Microsoft Word for Windows User's Reference" and
"Microsoft Word for Windows Technical Reference."
                                
Additional reference words: w4wmacro 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c 6.00



Macro to Change Printer Orientation for HP/PCL Driver
Article ID: Q49000
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

The following macro allows you to change the orientation of the
printer setup from portrait to landscape using the HP/PCL driver
version 3.20:

Word for Windows Version 2.0
----------------------------

   Sub Main
   SendKeys "%l{enter}", -1
   FilePrintSetup .Printer="PCL / HP LaserJet on LPT1:", .SETUP
   End Sub

Word for Windows Version 1.x
----------------------------

   Sub Main
   SendKeys "%l{enter}", -1
   FilePrinterSetup .Printer="PCL / HP LaserJet on LPT1:", .SETUP
   End Sub

Changing the "l" to "r" changes the orientation from landscape to
portrait. You can modify this macro to select the orientation for
other printers by changing "PCL / HP LaserJet on LPT1:" to the printer
you want to use. To customize the key that is selected, check the
printer dialog box for the underscored character that is used with the
ALT key (indicated as "%" with SendKeys) to make that selection.

Additional reference words: 6.00 1.0 1.1 1.1a 1.00 1.10 1.10a w4wmacro
hp3 wm_word hp2 hp2d hpdp 2.00



Macro to Set Create Backup As Default in Word for Windows
Article ID: Q49481
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

To make sure that Create Backups is always selected when saving a
document in Microsoft Word for Windows version 1.0, 1.1, and 1.1a,
make the following modifications to the global macros FileSave and
FileSaveAs:

FileSave Modifications
----------------------

   Sub MAIN
   On Error Goto finish
   Dim FileDlg As FileSaveAs
   GetCurValues FileDlg
   FileDlg.CreateBackup = 1
   If FileDlg.Name = "" Then
      Dialog FileDlg
      Super FileSaveAs FileDlg
   Else
      Super FileSave
   End If
   finish:
   End Sub

FileSaveAs Modifications
------------------------

   Sub MAIN
   On Error Goto finish
   Dlg:
      Dim FileDlg As FileSaveAs
      GetCurValues FileDlg
   FileDlg.CreateBackup = 1
   Dialog FileDlg
   Super FileSaveAs FileDlg
   finish:
   End Sub

More Information:

If you have Word for Windows version 2.0 or 6.0, you can permanently select
Create Backups by following the steps below:

1. From the Tools menu, choose Options.



2. Choose the Save category.

3. Select the Always Create Backup Copy check box.

Additional reference words: 1.00 1.10 1.10a 2.00 w4wmacro wm_word 



WinWord Menu Commands Unavailable If Locked for Annotations
Article ID: Q49867
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

To lock a Microsoft Word for Windows document, choose Save As from the
File menu, press the Options button, and select the Lock for
Annotation check box.

To lock a Microsoft Word for Windows version 2.0 document, choose Save
As from the File menu, press the File Sharing button, and select the
Lock for Annotation check box.

To lock a Microsoft Word for Windows version 6.0 document, choose Tools
select Protect Document, and press the Annotations options.

MORE INFORMATION
================

If a document is locked in Word for Windows 1.x and 2.0, the following
commands are unavailable to readers and appear grayed:

   Menu              Unavailable Commands
   ----              --------------------

   File              Lock For Annotations option in the Save As dialog box
                     Summary Info Update**
                     Template**
                     Print Merge

   Edit              Undo, Repeat, Cut, Paste, Paste Link, Paste Special**
                     Replace, Summary Info, Header/Footer, Glossary,Table
                     Links** and Object**

   View              Footnotes, Annotations and Header/Footer**

   Insert            All commands except Annotation

   Format            All commands

   Tools**           All commands except Record Macro, Macro, and Options

   Utilities         Customize

   Macro             Assign to Menu and Assign to Key have Template context
                     unavailable



   Table**           All commands except Gridlines

** Word for Windows version 2.0 commands only

If a document is locked in Word for Windows 6.0, the following commands
are unavailable to readers and appear grayed:

   Menu              Unavailable Commands
   ----              --------------------

   File              Page Setup

   Edit              Undo, Cut, Paste, Paste Special, Clear
                     Autotext, Bookmark, Links and Object

   View              Footnotes, and Annotations

   Insert            All commands except Annotation

   Format            All commands

   Tools             All commands except AutoCorrect, (Un)Protect Document
                        Revisions, Macro, Customize, and Options

   Table             All commands except Gridlines

You can turn on the ribbon, ruler, and icon bars; however, you cannot
apply formatting with them. Keyboard commands that edit or format text
and graphics are also unavailable.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, page 80

"Microsoft Word for Windows User's Reference," version 1.x, pages 7-9

Additional reference words: w4wmacro greyed 1.00 1.10 1.10a 2.00 2.00a
wm_word 2.00a-CD 2.00b 2.00c 6.00



Word BASIC Date$() Function Defined
Article ID: Q50168
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

The Word BASIC Date$() function returns a string containing the
current date. The function returns a 10-character string. The form of
the string depends on the country setting in the WIN.INI file. For the
United States, the form is mm-dd-yyy.

Syntax
------

   Date$()

Example
-------

   Print "The current date is: ";Date$()

Result: The following will be displayed in the status bar:

   The current date is: 10/19/89

Additional reference words: w4wmacro 1.00 1.10 1.10a 2.0 2.00



Word BASIC Kill Statement Defined
Article ID: Q50801
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

The Word BASIC Kill statement deletes a file from disk.

Syntax
------

Kill "Name$"      Name$ is the name of the file to be deleted.

The name can include a path specification and must be enclosed in double
quotation marks.

Example
-------

Sub MAIN
Kill "C:\WINWORD\DOCUMENT.DOC"
End Sub

MORE INFORMATION
================

The Name$ argument can contain question marks (?) or asterisks (*)
used as wildcards. A question mark matches any single character in the
filename or extension. An asterisk matches one or more characters
starting at its position in the string. Use caution when using
wildcards with Kill. You can delete many files unintentionally with
the wildcard characters.

Kill is used for all types of disk files: program files, random data
files, and sequential data files.

Kill deletes only files, however. Kill does not delete directories. To
delete directories, use the RmDir command.

For more information on Word BASIC functions and statements, please
refer to the "Microsoft Word for Windows Technical Reference."

Additional reference words: w4wmacro 1.00 1.10 1.10a 2.00 2.00a wm_word 
2.00a-CD 2.00b 2.00c 6.00



Word BASIC Shell Command Defined
Article ID: Q50816
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

The Word BASIC Shell command starts another program under Microsoft
Windows.

Syntax
------

Shell "App$", Window_Style

App$ uses the same format as the File Run command in the Windows
MS-DOS Executive, including any switches or arguments that the program
accepts. If App$ is the name of a file with an extension specific to
an installed application (.DOC for a Word document, for example), the
statement starts the application and loads that file.

Window_Style specifies how the window containing the program should
appear, as follows:

   Mode     Window Type
   ----     -----------

   0        Minimized window; default
   1        Normal window
   2        Minimized window (for Microsoft Excel
            compatibility)
   3        Maximized window
   4        Deactivated window

Example
-------

Shell "C:\EXCEL\EXCEL.EXE",2    Starts Microsoft Excel and minimizes
the window

More Information:

If the application that is being shelled is not listed on the PATH
statement in the AUTOEXEC.BAT file, and the full directory and path
are not stated in App$, then Microsoft Word generates the error
message:

   Cannot find or run application.



For more information on Word BASIC functions and statements, please
refer to the "Microsoft Word for Windows Technical Reference."

Additional reference words: W4wmacro 2.0 2.00



Using SendKeys with Dialog Boxes in Word for Windows
Article ID: Q52159
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

If you try to simulate pressing the ENTER key by using the SendKeys
"{Enter}" function after calling the File Open dialog box, your macro
will not run correctly. For example, the following macro will not run
correctly:

Sub MAIN
ChDir "C:\winword"                  ' Change Directory
FileOpen "test.doc"                    ' File Open dialog box.
SendKeys "{Enter}", -1       ' Send the Enter key.
End Sub

MORE INFORMATION
================

WordBasic processes code one line at a time. The SendKeys function
sends the specified keys to the active application, just as if they
were typed at the keyboard. If Word is not the active application and
wait is set to -1, Word will wait for all the keys to be processed
before proceeding.

Whenever a Word dialog box is opened, it becomes the active foreground
application and is ready to take commands; it also must be terminated
(with OK or Cancel) before the next line can be processed. In the
above example, the SendKey "{Enter}" command should come before the
FileOpen command so that the File dialog box can process the keys and
close. Then, the next line of code can be processed.

Sub MAIN
ChDir "C:\winword"
SendKeys "{Enter}", -1       ' Send the Enter Key.
FileOpen "test.doc"             ' File Open Dialog box.
End Sub

Word waits for the dialog box to open, then it sends the ENTER key to
the FileOpen dialog box.

Additional reference words: w4wmacro 1.0 1.1 1.1a 1.00 1.10 1.10a 2.00
wm_word 2.0 2.0a 2.00a



SendKeys Key Code for a Space Character Undocumented
Article ID: Q58000
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

When using the SendKeys macro command to indicate a space, use braces
surrounding a space as follows:

  SendKeys { }

This key code is not documented in the "Microsoft Word for Windows
Technical Reference."

All keyboard ascii/ansi equivalent values can be used inside {}
in order to produce the keyboard character. For example:

   SendKeys "{32}"

Can also be use to send a space character.

   SendKeys "{13}"

Can be used to send the Enter key.

For more information on the SendKeys macro in Word for Windows version
2.0, follow these steps:

1. From the Help menu, choose Help Index.

2. Select WordBASIC Programming Language, and scroll through the
   commands for SendKeys.

Additional reference words: w4wmacro function 1.0 1.1 1.1a 1.00 1.10
1.10a 2.00 wm_word 6.00



Special Bookmarks in the WordBasic Macro Language
Article ID: Q60003
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c. 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Some macro statements can use the following special bookmarks in
Microsoft Word for Windows:

   Bookmark                  Definition
   --------                  ----------

   \Sel                      Current selection
   \PrevSel1                 Previous selection 1 where editing occurred
                              (0 at start)
   \PrevSel2                 Previous selection 2 where editing occurred
                              (0 at start)
   \StartOfSel               Start of selection
   \EndOfSel                 End of selection
   \Line                     Current line (first of selection)
   \Char                     Current character (first of selection)
   \Para                     Current paragraph (first of selection)
   \Section                  Current section (first of selection)
   \Doc                      Entire document
   \Page                     Current page
   \StartOfDoc               Beginning of document
   \EndOfDoc                 End of document
   \Cell                     Cell
   \Table                    Table
   \HeadingLevel             A heading level

Example
-------

   EditGoto "\StartOfDoc"

Reference(s):

"Using WordBasic," by WexTech Systems and Microsoft, pages 88-90
"Word for Windows and 0S/2 Technical Reference", pages 103-107.

Additional reference words: w4wmacro 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c wm_word 6.00



Valid Word for Windows Macro Names
Article ID: Q60006
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

A Microsoft Word for Windows macro name can be up to 80 characters
long using Word 6.0, and 32 characters if using earlier versions. It
must start with an alpha character, and thereafter can be any
combination of alphanumeric characters. However, Word for Windows does
not support underscores or dashes, which are commonly used in MS-DOS.

Additional reference words: w4wmacro 1.00 1.10 1.10a 2.0 2.00 wm_word
6.00



UPDATE FIELD Key (F9) Updates Only Selected Fields
Article ID: Q60587
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

The UPDATE FIELD key (F9) operates only on the selected field or
fields. Fields outside the selected area are not updated.

The following WordBASIC code segment updates all fields on the active
document:

Word 6.0
--------
   Sub MAIN
   EditBookmark "Temp"
   EditSelectAll
   Super UpdateFields
   EditGoTo "Temp"
   EditBookmark "Temp", .Delete
   End Sub

Word 2.x
--------
   Sub MAIN
   InsertBookmark "Temp"
   EditSelectAll
   Super UpdateFields
   EditGoTo "Temp"
   InsertBookmark "Temp", .Delete
   End Sub

The standard UpdateFields macro could be changed to this macro, if
desired, or this macro could be assigned to the F9 key to force all
fields to update when F9 is pressed.

Additional reference words: w4wmacro 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c wm_word 6.00



Auto Outline Numbering and the "Chicago Manual of Style"
Article ID: Q61514
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

Automatic Outline Numbering in Microsoft Word for Windows follows the
"Chicago Manual of Style" (CMS) in numbering scheme (as stated on page
230 of the "Microsoft Word for Windows User's Reference"), but not in
alignment.

STATUS
======
 
Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This functionality was added
to Word version 6.0 for Windows.
 
To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

According to the CMS, the level numbers should be right aligned, as
follows:

      I.
     II.
    III.
     IV.

Word for Windows numbering (using the Utilities Renumber and Format
Outline commands) is left aligned, as follows:

   I.
   II.
   III.
   IV.

Word version 6.0
----------------

Word version 6.0 defaults to the left alignment described above. This
alignment can be changed using the following steps:



1. Select any Heading Level 1 text.

2. From the Format menu choose Heading and Numbering and choose
   Modify.

3. In the Number Position dialog box set the Alignment of List Text
   drop down list box to Right and choose Ok.

Word version 2.x
----------------

You can correct the numbering alignment using the following general
steps:

1. From the Format menu, choose Style (Styles Define in Word for
   Windows 1.x) and add a right-aligned tab to the appropriate heading 
   style at the desired position. For example, heading 1 might have 
   a right-aligned tab at 0.3 inches.

2. Insert a tab before each {autonumout} field.

You can create a macro to automate step 2. The macro below 
inserts a tab before each {autonumout} field for the "heading 1" 
style:

Sub MAIN
EditFindClearFormatting
StartOfDocument
EditFindStyle .Style = "heading 1"
EditFind .Direction = 2, .Format = 1
While EditFindFound()
  InsertBookmark .Name = "Origin"
  StartOfLine
  If Asc(Selection$()) <> 9 Then
    Insert Chr$(9)
  End If
  EditGoTo .Destination = "Origin"
  EditFind .Direction = 2, .Format = 1
Wend
StartOfDocument
End Sub

This macro only works for heading level 1. You must modify 
the macro to format other heading levels. 

Microsoft is researching this problem and will post new 
information here as it becomes available.

Additional reference words: w4wformat w4wmacro 1.00 1.10 1.10a 2.00 
2.00a 2.00a-CD 2.00b 2.00c 



WordBASIC InStr Function Is Case Sensitive
Article ID: Q61960
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

The WordBASIC InStr function is case sensitive. For example, a search
for the string "Test String", as in

   N = InStr(A$, "Test String")

returns a valid position number only if the string "Test String" is
present in A$. "TEST STRING" and "test string" are not found by the
InStr function.

To work around this problem, use one of the following:

   N = InStr(LCase$(A$), "test string")

  -or-

   N = InStr(UCase$(A$), "TEST STRING")

The LCase$ and UCase$ functions return their arguments (in this case,
the text of A$) in either lowercase text or uppercase text
respectively, without modifying the original string. As a result,
either method is effective for case-insensitive text searches.

Additional reference words: w4wother w4wmacro 1.00 1.10 1.10a 2.00
2.00a  2.00a-CD 2.00b 2.00c  



MacroAssignToMenu Removing Separator Fails in Word Macro
Article ID: Q61977
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

Using a macro to unassign/delete a separator bar from a Microsoft Word
for Windows menu does not work. You must manually unassign/delete a
separator bar to remove it.

STATUS
======
 
Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.
 
To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Word for Windows Version 2.x
----------------------------

To manually remove a menu separator bar in Word for Windows version
2.0, 2.0a 2.0b or 2.0c, follow these steps:

1. From the Tools menu, choose Options.

2. Select the Menus category.

3. Select the desired menu.

4. Select the desired separator bar.

5. Choose the Delete button.

6. Choose the Close button.

Word for Windows Version 1.x
----------------------------

To manually unassign a menu separator bar in Word for Windows versions



1.0, 1.1, or 1.1a, follow these steps:

1. From the Macro menu, choose Assign to Menu.

2. Select the desired menu.

3. Select the desired separator bar.

4. Choose the Unassign button.

5. Choose the Close button.

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a w4wmacro 2.0b
2.0a-CD 2.00b 2.00a-CD



Word for Windows Not Responding to Message Quickly
Article ID: Q64624
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

Microsoft Word for Windows will not respond to a bogus DDEexec message
in a timely fashion if you do the following:

1. Boot Word for Windows and Excel version 3.x or 4.0 for Windows.

2. Run the following macro in Excel:

     = initiate("winword","document1")
     = execute(a1,"[bogus]")
     = return()

Word for Windows receives the bogus command and begins flashing its
title bar; however, Word for Windows does not provide the incorrect
DDEexec message until Word is the active application and has displayed
its error message.

STATUS
======
 
Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.
 
To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Expected Behavior
-----------------

Word for Windows should respond to the DDEexec message in a more
timely manner. Excel should not be forced to wait until Word has sent
an error message.

Additional reference words:  w4wmacro 1.00 1.10 1.10a 2.00
2.00a



Incorrect Recording of FileFind Session in Word for Windows
Article ID: Q65137
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

If from the Macro menu, you choose Record and record the following

   File Find
   Select a file and choose Summary
   Choose OK
   Choose Close
   Macro Stop Recorder

you will receive a recording error. The first statement in the macro
is an EditSummary macro with no references to the file associated with
it.

The same error will occur in Word for Windows 2.0 if you choose
Record Macro from the Tools menu and record the following:

File Find File
Summary
OK
Close
Tools Stop Recorder

If you choose Macro from the Tools menu and choose the Edit
button to edit the recorded macro, the FileSummaryInfo command in
the macro has no reference for the filename.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

REFERENCES
==========

"Microsoft Word for Windows Technical Reference," pages 49-50



"Microsoft Word for Windows and OS/2 Technical Reference," pages
171-172

Additional reference words: w4wmacro 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c 



Assign To Key Limit Is Eight Keys for Single Macro in Winword
Article ID: Q65835
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

In Word versions 1.0, 1.1, and 1.1a, the maximum number of keys you
can display for a single macro in the Assign To Key dialog box under
Current Keys option is eight.

Although more keys can be assigned to the same macro, they cannot be
displayed in this box.

In Word for Windows 2.0, the maximum number of keys you can display
for a single macro or command in the Assign to Key dialog box under
Current Keys option is eight. Multiple keys can be assigned to a macro
or command with the following steps:

 1. From the Tools menu, choose Options.

 2. Select Keyboard from the list of categories.

3. Select the specific command or macro to be assigned a key.

4. Choose a shortcut key for the macro or command.

5. Repeat step 4 to assign additional keys to the macro or command.

This procedure adds each additional key selected for the macro or
command to the Current Keys option for macroname list. Only the first
eight keys assigned display in the Current Keys option for macroname.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," pages 171-172

Additional reference words: w4wmacro 1.0 1.1 1.1a 1.00 1.10 1.10a 2.0
2.00 wm_word 



SendKeys Not Sending All Keystrokes to Dialog Box in WinWord
Article ID: Q65848
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

The SendKeys command does not send all keystrokes to a dialog box in
some circumstances. This problem usually occurs if you send several
commands in a situation where the computer's stack space is limited.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

To reproduce this problem in Word for Windows versions 2.0 and 2.0a,
use the following steps:

1. From the Tools menu, choose Macro. Type "hi" (without the quotation
   marks) in the Macro Name box, and choose the Edit button.

2. Type the following lines between "Sub MAIN" and "End Sub":

      SendKeys "~~{esc}"
      ToolsMacro .Name = "FileSaveAs", .Run

3. Load a read-only document, then choose the Start button.

To reproduce the problem in Word for Windows versions 1.0, 1.1, and
1.1a, follow the steps below:

1. From the Macro menu, choose Edit. Type "hi" (without the quotation
   marks) in the Edit Macro Name box, and choose the OK button.



2. Type the following lines between "Sub MAIN" and "End Sub":

      SendKeys ("~~{esc}")
      MacroRun ("FileSaveAs")

3. Load a read-only document, then choose the Start button.

Because you cannot use the command FileSaveAs with a read-only
document, the macro should produce the following error message:

   Document is Read Only

The SendKeys commands should send two returns (~) and an escape
({esc}) to stop the error message; however, Word for Windows returns
the message

   WordBasic Err=102 Command Failed

instead of closing the error message.

Additional reference words:  w4wmacro 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 
2.00b 2.00c 



Ribbon and Ruler Commands Execute Embedded Super Macros Only
Article ID: Q68491
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

Any button selected on the ribbon or ruler executes the embedded Super
macro only. For example, if you have modified the Bold macro and
subsequently highlight a word and select the Bold button from the
ribbon, the modified macro is not executed. The built-in Bold macro is
executed instead.
STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Additional reference words: w4wmacro 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c 



Macro to Print Current Page in Word for Windows
Article ID: Q69519
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, and 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

You can use the following version-specific methods to print the
current page only (that is, the page where the insertion point
resides) of a Microsoft Word for Windows document.

Word for Windows Version 2.0 and 6.0
------------------------------------

1. From the File menu, choose Print.

2. Choose the Current Page button in the Range dialog box, and choose
   the OK button.

The following WordBasic macro instruction prints the current document
page:

   FilePrint .Range = 2

Word for Windows Versions 1.x
-----------------------------

Method 1
--------

Note: This method is intended for use in single section documents.
Before you begin, make sure that nothing is selected in the document.

1. From the Macro menu, choose Edit. Type a name for the macro (for
   example, currentpage).

2. Press ENTER or choose the OK button.

3. In the resulting macro window, type the following macro text:

   Sub MAIN
   EditGoto "\Page"
   FilePrint .Range = 1
   GoBack
   End Sub

4. From the File menu, choose Close, and choose Yes to save changes to
   your macro. From the Macro menu, choose Run, or assign the macro to a
   key or menu.

Method 2
--------



1. From the Macro menu, choose Edit. Type a name for the macro (for
   example, currentpage).

2. Press ENTER or choose the OK button.

3. In the resulting macro window, type the following macro text:

   Sub MAIN
   StartOfLine
   UtilRepaginateNow
   InsertField .Field = "Page"
   CharLeft 1, 1
   UnLinkFields
   PageNum$ = Selection$()
   EditClear
   FilePrint .Range = 2, .From = PageNum$, .To = PageNum$
   End SUB

4. From the File menu, choose Close, and choose Yes to save changes to
   the your macro. To run the macro, from the Macro menu, choose Run, or
   assign the macro to a key or menu.

Additional reference words: w4wmacro w4wprint active range 1.1a 1.00
wm_word 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Must Specify as Integer When Calling External DLL
Article ID: Q69675
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

When declaring an external function that takes an integer as one of
its parameters in a Word for Windows version 1.1 macro, "As Integer"
must be used specifically in the parameter declaration or an
Unrecoverable Application Error (UAE) will occur.

If the Declare statement made a call to IsAppLoaded using "(name$)"
instead of "(name$) As Integer," a UAE will occur in Word for Windows
when the macro is run.

Word for Windows version 2.0 and version 6.0
--------------------------------------------

This procedure is different in Word for Windows version 2.0. If "As
Integer" is not specified, you will receive a WordBASIC error 100,
"Syntax Error".

MORE INFORMATION
================

Windows Dynamic Link Libraries (DLL) can be accessed using WordBasic
macros in Word for Windows. In the following example, an external
function is declared for use within Word for Windows using the
WordBasic macro language.

For example:

Declare Function IsAppLoaded Lib "kernel" (name$) As Integer
Alias "GetModuleHandle"
Sub Main
        AppName$ = InputBox$("Enter an application name (e.g.,
Excel)")
        If IsAppLoaded(AppName$) Then Print "The application is
loaded"
End Sub

REFERENCES
==========

"Microsoft Word for Windows and OS/2 Technical Reference," pages
437-438

Additional reference words: w4wmacro 2.0 2.00 6.00 wm_word 





Default$ Does Not Display Linefeed in WinWord InputBox
Article ID: Q69676
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

The linefeed character will not display in the default text in a Word
for Windows InputBox.

MORE INFORMATION
================

InputBox$ can be used in the Word for Windows macro language to
display a dialog box that can be edited. It returns the text that was
in the box when OK was chosen.

The proper syntax for InputBox$ is

   A$ = InputBox$(Prompt$, Title$, Default$)

where Prompt$ is the message the dialog box displays; Title$ is
displayed in the title bar; and Default$ is loaded into the dialog box
when it is displayed. Both Title$ and Default$ are optional
parameters.

Using the InputBox$() statement, linefeeds can be entered (using
SHIFT+ENTER) into the dialog box when the statement is displayed, and
linefeeds can be brought back in the return variable. However, the
Default$ parameter will not display Chr$(11), the line feed character,
in the default text for the Inputbox.

In the following example, Chr$(11) is used in the Default$ parameter
for Inputbox$:

   DfltTxt$ = "Big"+Chr$(11)+"Things"

The default text displays as Big.Things. The linefeed will not display
when used in the Default$ parameter.

Microsoft has confirmed this to be a problem in Word for Windows
versions 1.0, 1.1, 1.1a, and 2.0. We are researching this problem and
will post new information here as it becomes available.

REFERENCES
==========

"Microsoft Word for Windows and OS/2 Technical Reference," pages
34-35, 56-57, and 200-201



Additional reference words: w4wmacro 1.00 1.10 1.10a 1.0 1.1 1.1a  2.0 2.00
wm_word 6.00



File Find Print Option Uses Built-In Print Macro Only
Article ID: Q69761
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

If you choose Print from the File Find dialog box, Word for Windows
uses its built-in Print macro instead of the Global or Template
FilePrint macro. For example, if you modify the FilePrint macro to
always check Update Fields and choose Print from File Find, the
FilePrint macro you modified is not used. Word for Windows uses the
built-in Super FilePrint instead.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this problem,
and will post more information here in the Microsoft Knowledge Base as it
becomes available.

Additional reference words: w4wmacro filefind w4wtemplate 1.00 1.10
1.10a wm_word 2.00 2.00a 2.00a-CD 2.00b 2.00c



How to Use Percent, Caret, and Plus SendKeys in WinWord
Article ID: Q69939
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

The SendKeys statement is the only way to "send" keyboard instructions
to other Windows applications. For example, WordBASIC instructions
will not interact with the Control Panel in Windows without using
SendKeys.

The percent (%), caret (^), and plus (+) signs are special reserved
SendKeys.

The % sign represents the ALT key used to access Windows menus.
SendKeys "% up{enter}" accesses the Control Panel from Word for
Windows.

The ^ sign represents the CTRL key. SendKeys "^{esc}" brings up the
task list.

The + sign represents the SHIFT key. SendKeys "^+{F12)" brings up the
File Print dialog box.

There may be specific applications that need to have a %, ^, or + sign
sent to them, without having the special meanings attached to them.
This is done by surrounding the characters with curly brackets:

   For the %:Sendkeys "{%}
   For the +:Sendkeys "{+}
   For the ^:Sendkeys "{^}

Note: The curly brackets are keystrokes NOT field codes.

Additional reference words: w4wmacro 2.0 2.00 6.00



OnTime Macro Doesn't Execute Unless Word for Windows Has Focus
Article ID: Q69947
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

The OnTime command used in Word for Windows will not execute the
specified macro until Word for Windows is given the focus.

MORE INFORMATION
================

The OnTime command in Word for Windows sets up a background timer that
runs a specified macro at a specified time. The syntax for using the
OnTime command is as follows

   OnTime When$, Name$, [Tolerance]

where Name$ is the name of the macro to be run at the time specified
by When$. If Tolerance is omitted or set to zero, the macro will run
no matter how many seconds elapse before Word is idle and available to
run the macro.

However, a Word for Windows macro will not execute this command if
Word does not have the focus. It is not possible to use this command
to run something if Word does not have the focus when the time to run
the macro comes up.

STATUS
======

Microsoft has confirmed this to be a problem in Word for Windows. We
are researching this problem and will post new information here as it
becomes available.

REFERENCES
==========

"Microsoft Word for Windows and OS/2 Technical Reference," pages 230,
231.

Additional reference words: 1.0 1.1 1.1a 1.00 1.10 1.10a  w4wmacro 2.0 2.00
6.00



WinWord: Overtype Command Doesn't Work When Recorded
Article ID: Q69949
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

The overtype command does not work in Word for Windows when recorded
as a macro.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this
problem and will post more information here in the Microsoft Knowledge
Base as it becomes available.

MORE INFORMATION
================

Overtyping is used for typing new text over existing text. One way
this mode can be activated in Word for Windows is by pressing the INS
key on the keyboard. When this key is activated, the status bar will
display OVR (overtype) and all typing will replace previously typed
text.

When this action is recorded as a macro, however, the overtype mode is
turned on but does not record overtyped text.

To demonstrate this, do the following:

1. From a Word for Windows document, choose Record from the Macro menu.

2. Type the word Test and press the HOME key.

3. Press the INS key and type the word Case. Notice that the letters
   OVR appear on the status bar and that Test is replaced with the
   word Case.

4. From the Macro menu, choose Stop Recorder.

5. Press the INS key again to remove overtype and run the macro.

Notice the overtype command does not work. Case is typed next to the
word Test instead of typing over it, even though OVR is now displayed
in the status bar. Overtype mode is turned on when the macro is run,
but the actual overtyping is not recorded.



REFERENCES
==========

"Microsoft Word for Windows User's Reference," pages 240, 241.

Additional reference words: w4wmacro 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c 6.00



Cannot Select Radio Button with Mouse in User Dialog Box
Article ID: Q70730
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

When using a user dialog box created in Microsoft Word for Windows,
you may not be able to select an option button or checkbox if the
horizontal position of the button or box is too close to the position
of another selection even if it appears there is enough room between
selections on the screen.

MORE INFORMATION
================

To demonstrate, run the following macro:

   a Sub MAIN
   On Error Goto bye
   Begin Dialog UserDialog 312, 144
           GroupBox 8, 51, 180, 35, "&Display in:"
           OptionGroup .Where
           OptionButton 24, 62, 80, 18, "&Header"
           OptionButton 91, 62, 80, 18, "&Footer"
           OKButton 232, 49, 64, 21
           CancelButton 232, 78, 64, 21
   End Dialog
   Dim Dlg As UserDialog
   Dialog Dlg
   Bye:
   End Sub

This macro brings up a dialog box displaying the options header and
footer with option buttons next to each. There appears to be enough
horizontal space between options; however, pressing the button to
select the footer with the mouse does not select the footer option. By
changing the horizontal position of the option button for the footer,
the problem can be corrected so that the footer option can be selected
with the mouse.

To correct this behavior in the above macro, increase the horizontal
distance between option buttons as follows:

   OptionButton 24, 62, 80, 18, "&Header"
   OptionButton 100, 62, 80, 18, "&Footer"

The first number in these lines is the horizontal position of the
button. By increasing this horizontal position number for the footer



option, the distance between the footer selection button and the word
"header" is increased in the dialog box and "footer" can now be
selected with the mouse.

REFERENCES
==========

"Microsoft Word for Windows and OS/2 Technical Reference," pages
87-88, 232-233.

Additional reference words: w4wmacro 1.10 1.00 1.10a 1.1 1.0 1.1a 2.0 2.00
wm_word 6.00



Auto Macros in Word for Windows
Article ID: Q70991
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

Word for Windows reserves special names for macros that you can create
to alter aspects of Word's behavior. These are called auto macros.
AutoExec, AutoNew, AutoOpen, AutoClose, and AutoExit are the auto
macros in Word for Windows.

MORE INFORMATION
================

Word recognizes a macro whose name begins with "Auto" as a macro that
runs automatically when the situation to which it applies arises. You
supply the actual steps for the auto macro by either writing or
recording the macro.

You can prevent an auto macro from running by holding down the Shift
key when you perform the action that triggers the macro.

Description of Auto Macros
--------------------------

AutoExec        The AutoExec macro runs when you start Word.
                This macro makes it easy to instruct Word to
                automatically make adjustments when you start
                Word. For example, you can create an AutoExec
                macro that will automatically change the default
                directory when Word for Windows is opened.
                For more information on how to change the default
                directory, query on the words:

                   changing and default and directory and word and
                   windows

                You can prevent AutoExec from running by typing

                   winword /m

                when you start Word.

AutoNew         The AutoNew macro runs after you create a
                new document based on a current template.
                For example, an AutoNew macro could be created
                to update all the fields in a document, attached
                to a template of choice, and then executed when



                a new document is opened based on that template
                of choice. To base a new document on a template,
                first select File from the menu bar then New from
                the File menu. Now select New document and
                specify which template the document will be
                based on under Use Template. You now have a new
                document based on a selected template.

AutoOpen        The AutoOpen macro runs after you open a file with
                the File Open or File Find command, or from the list
                of the last four documents that were opened found at
                the bottom of the File menu.

AutoClose       The AutoClose macro runs when you close a document.

AutoExit        The AutoExit macro runs when you quit Word.

REFERENCES
==========

"Microsoft Word for Windows Technical Reference," pages 7-8

"Microsoft Word for Windows and OS/2 Technical Reference," pages 97-99

"Using WordBasic," by WexTech Systems and Microsoft, pages 84-87.

Additional reference words: 1.0 1.1 1.1a 1.00 1.10 1.10a w4wmacro wm_word 
w4wtemplate filefind 2.0 2.00 6.00



Macro to Designate Table of Contents Entry Automatically
Article ID: Q70996
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

The following macro allows you to designate highlighted text as a
table of contents entry without removing the text from the body of the
document. You do not have to type the table of contents entry twice.

MORE INFORMATION
================

You can assign the following macro to a menu and/or a key sequence to
quickly designate text to be included in a table of contents:

   Sub MAIN
   a$ = Selection$()
   CharRight 1
   InsertFieldChars
   Insert "tc " + Chr$(34) + a$
   Insert Chr$(34)
   CharRight 1
   End Sub

When you have designated all of the table of contents entries with
this macro, choose Table Of Contents from the Insert menu and select
Use Table Entry Fields.

Table of Contents entries or TC fields are automatically formatted as
hidden text. To edit these entries, you must select either Show All or
Hidden Text. In Word 6.0, choose Options from the Tools menu, then 
choose Field Codes from the View tab. Mark the Hidden Text check box. In 
Word version 2.0 for Windows, choose Options from the
Tools menu. Select the View category and mark the Hiddent Text check
box. In Word version 1.0 for Windows, choose Preferences from the View
menuand mark the Show All check box.

Additional reference words: w4wmacro w4wfield 1.00 1.10 1.10a 2.0 2.00
wm_word



WinWord: Undocumented WordBasic ExitWindows Command
Article ID: Q71012
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

There is an undocumented ExitWindows command in the WordBasic language
that you can use to exit Microsoft Windows from Microsoft Word for
Windows.

MORE INFORMATION
================

If you run a macro with this ExitWindows command, Word for Windows
does NOT prompt you to save document, global, glossary, and command
changes. As a result, document edits, glossaries, macros, and even the
macro that calls the ExitWindows command itself can be lost if you run
the ExitWindows command.

To use this command within Word for Windows and still be prompted to
save any changes made during the current session, you can use an
AutoExit macro to exit Windows when you exit Word for Windows. The
AutoExit macro runs each time you close Word for Windows.

To create this macro, use the appropriate procedure below.

Versions 2.0 and 2.0a of Word for Windows
-----------------------------------------

1. From the Tools menu, choose Macro.

2. In the Macro Name box, type "AutoExit" (without the quotation
   marks), then choose the Edit button.

3. Type "ExitWindows" (without the quotation marks) on the line
   between Sub Main and End Sub. The complete macro should read as
   follows:

      Sub Main
      ExitWindows
      End Sub

4. From the File menu, choose Close. When prompted to save changes,
   choose the Yes button.

5. From the File menu, choose Save All. When prompted to save global
   glossary and command changes choose the Yes button.



Version 1.x of Word for Windows
-------------------------------

1. From the Macro menu, choose Edit.

2. In the Edit Macro Name box, type "AutoExit" (without the quotation
   marks), then choose the OK button.

3. Type "ExitWindows" (without the quotation marks) on the line
   between Sub Main and End Sub. The complete macro should read as
   follows:

      Sub Main
      ExitWindows
      End Sub

4. From the File menu, choose Close. When prompted to keep changes to
   Global: autoexit, choose the Yes button.

5. From the File menu, choose Exit. When prompted to save global
   glossary and command changes, choose the Yes button.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.x, pages
187-189

Additional reference words: w4wmacro 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c wm_word 6.00



WordBASIC Macro to Run the Windows File Manager
Article ID: Q71342
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

If you need to do a file management task when working in Microsoft
Word for Windows, such as moving files, you can run the following
macro to bring up the Windows version 3.0 File Manager:

   Sub Main
   Shell "winfile.exe"
   End Sub

After you complete your file management task, you can exit File
Manager and resume Word for Windows again.

Note: You can assign this macro to a key or menu in Word for Windows
for quick access to the File Manager.

REFERENCES
==========

"Microsoft Word for Windows Technical Reference," page 117

"Microsoft Word for Windows and OS/2 Technical Reference," pages
256-257

Additional reference words: w4wmacro 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c 6.00



Word for Windows Macro to Insert Specified Dates
Article ID: Q71343
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

If you use the DATE field in Microsoft Word for Windows, you can
insert the current date into any document. In certain cases, it may be
desirable to insert a future or past date into a document. To force
Word to accept any date in numeric form and insert it into a document
in the format desired, you can run the macro below.

MORE INFORMATION
================

The following macro prompts you to enter a specific date:

   Sub MAIN
   A$ = InputBox$("date")
   InsertField "set thing " + a$
   InsertField "thing \@" + Chr$(34) + " MMMM d, yyyy " + Chr$(34)
   End Sub

NOTE:  The space after "thing" is important otherwise, the error
"Bookmark not defined" will occur.

When you run this macro, you enter the date in the dialog box in
numeric form, separated by hyphens or slashes, as in the following
example:

   9-1-91
   9/1/91

After you enter the numbers, the macro inserts the date where you
position the insertion point in the document. To view the results of
inserted fields, clear the Show All option (version 1.x) and the Field
Codes command from the View menu. (To clear the Show All option,
choose Preferences from the View menu, and clear the check box.) The
above macro inserts the date in the form of MMMM d, yyyy. You can
change this to any format listed on page 117 or 118 of the "Microsoft
Word for Windows User's Reference."

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.x, pages
117-118



Additional reference words: w4wmacro 1.00 1.10 1.10a 2.00 6.00



Word for Windows Macro to Save Selection to New File
Article ID: Q71461
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.1
----------------------------------------------------------------------

SUMMARY
=======

The following WordBasic macro copies the selected text from the
current Microsoft Word for Windows document to a new document based on
the Normal template. After copying the selected text to the new
document, the File SaveAs dialog appears so that a filename and format
can be entered.

   Sub MAIN
   A$ = Selection$()
   If SelType() = 1 Then MsgBox "Nothing is selected." : Goto finish
   EditCopy
   FileNew
   EditPaste
   On Error Resume Next
   FileSave
   Finish:
   End Sub

If the selection is less than one character (nothing is selected), a
message box will display the message "Nothing is selected." If the
selection is one character or more, the selected text will be copied
to a new file based on the Normal template.

REFERENCES
==========

"Microsoft Word for Windows Technical Reference," version 1.0, pages
77 and 88.

"Microsoft Word for Windows and OS/2 Technical Reference," version
1.0, pages 223-224 and 250.

"Using WordBasic" by WexTech Systems, Inc. and Microsoft
Corporation,Microsoft Press, 1992.

Additional reference words: 1.00 1.10 1.10a 1.0 1.1 1.1a document wm_word 
 w4wmacro 2.0 2.00 6.00



Macro to Insert Filename with Path Information in WinWord
Article ID: Q71995
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

The WordBasic FileName$() function returns the document file name
and path. The following macro inserts the document name and path
into your document window.

  Sub MAIN
  a$=FileName$()
  Insert a$
  End Sub

However, if the insertion point is positioned within a header or
footer, the document file name and path is not inserted. This occurs
because the header and footers in Word for Windows are treated as
separate windows from the document window. As a result, the FileName$()
function does not return the name of the document.

The following macros can be used as alternatives to using the
FileName$() function. To determine the document name and directory,
the macros access the summary information dialog box and extracts the
filename and directory information. Word for Windows adds the directory
and filename together with a backslash between them with the following
macro line:

   Insert A$ + "\" + B$

The path and filename (C:\WINWORD\README.DOC) are inserted at the
position of the insertion point.

Word for Windows version 6.0
----------------------------
You can use the field code {FILENAME \p} to print the full file name, in-
cluding the path; this field code is available from Insert, Field, Document
Information, File Name. To print the path as well, from that menu choose 
Options, the Field-Specific Switches tab, and \p. Press Add to Field to set 
the switch, and OK to close the dialog and insert the field code. 

In a macro, this would be

  Sub MAIN
  ViewHeader
  InsertField .Field = "FILENAME \p \* MERGEFORMAT"
  End Sub



To print the filename in the footer, change ViewHeader to ViewFooter.

Word for Windows version 2.0
----------------------------

The following macro inserts the document file name and path into the
document header.

  Sub Main
  ViewNormal
  FileSummaryInfo .Update
  Dim dlg As Dialog FileSummaryInfo
  GetCurValues dlg
  A$ = dlg.Directory
  B$ = dlg.FileName
  ViewHeaderFooter   'open document header
  Insert A$ + "\" + B$
  ClosePane
  End Sub

In the above macro, change the line "ViewHeaderFooter" to "ViewHeaderFooter
.type=1" to insert the information into the footer.

Word for Windows version 1.x
------------------------------------

Position the insertion point in the header or footer and run the
following macro.

  Sub MAIN
  EditSummaryInfo .Update
  Dim dlg As Dialog EditSummaryInfo
  GetCurValues dlg
  A$ = dlg.Directory
  B$ = dlg.FileName
  Insert A$ + "\" + B$
  End Sub

The document name and path are inserted at the insertion point. To
automate the process entirely, use the EditHeaderFooter command to open
the header or footer pane.

  EditHeaderFooter     'header
  EditHeaderFooter 1   'footer

REFERENCES
==========

"Microsoft Word for Windows User's Reference," page 96
"Microsoft Word for Windows Technical Reference," page 46
"Microsoft Word for Windows and OS/2 Technical Reference," pages
163-164
"Microsoft Word for Windows User's Guide", version 6, pages 736-7
Additional reference words: 1.1a 1.00 1.10 1.10a 2.00 6.0 w4wmacro wm_word 
directory edit summary full complete



Disabling the FastSave Option in Word for Windows
Article ID: Q71999
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

Many third-party programs that are used to check Microsoft Word for
Windows files (such as Grammatik) do not work correctly if the file
was saved with a fast save, rather than a normal save. A fast save
appends changes to a document to the end of a file, rather than
rearranging the entire file to insert all changes every time you save
the file.

MORE INFORMATION
================

Word for Windows Version 2.x
----------------------------

To disable the Allow Fast Saves option in Word for Windows versions
2.x, do the following:

1. From the Tools menu, choose Options, and select the Save category.

2. Clear the Allow Fast Saves check box, and choose the OK button.

Word for Windows Version 1.x
----------------------------

To disable the FastSave feature in Word for Windows version 1.0, 1.1
or 1.1a, edit the FileSave macro as follows:

1. From the Macro menu, choose Edit. Select FileSave, and choose the
   OK button. Edit the macro as follows:

   Sub MAIN
        DisableInput
        Dim dlg As FileSaveAs
        GetCurValues dlg
        dlg.FastSave=0
        On Error Goto Done
        If dlg.Name = "" Then
             Super FileSave
        Else
             Super FileSaveAs dlg
        End If
   Done:
   End Sub



2. From the File menu, choose Close. Choose the OK button when
   prompted to save changes to Global:FileSave. When you exit Word for
   Windows, you must choose Yes when the prompt "Save Global Glossary &
   Command Changes?" appears.

Additional reference words: w4wmacro 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c



NextPage and PrevPage Commands Do Not Work as Documented
Article ID: Q72074
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

The NextPage and PrevPage macro commands do not work as documented.
The "Microsoft Word for Windows Technical Reference" and the
"Microsoft Word for Windows and OS/2 Technical Reference" state that
the NextPage command "moves the insertion point to the beginning of
the next page" and that the PrevPage command "moves the insertion
point to the beginning of the previous page." 

The NextPage function changes the view to the beginning of the next
page, and PrevPage changes the view to the beginning of the previous
page. However, they do not change the insertion point position.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Workarounds
-----------

To move the insertion point to the beginning of the next page, replace
the NextPage command with the following:

   EditGoto "p+1"

To move the insertion point to the beginning of the previous page,
replace the PrevPage command with the following:

   EditGoto "p-1"

REFERENCES
==========

"Microsoft Word for Windows and OS/2 Technical Reference," pages 156,
227, 240

"Microsoft Word for Windows Technical Reference," pages 42, 79, 84

Additional reference words: 1.0 1.1 1.1a 1.00 1.10 1.10 2.00 2.00a
2.00a-CD 2.00b 2.00c  w4wmacro



Recursive Functions in WordBasic
Article ID: Q72280
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you can write WordBasic macros that use
recursive functions.

MORE INFORMATION
================

In WordBasic, functions can call other functions; additionally, as in
many other languages, WordBasic functions can call themselves. Any
function that makes a call to itself is considered recursive. For more
information on recursive functions, refer to the Waite Group's book
"Microsoft Quick C Programming," pages 164-167.

The following two examples use WordBasic to figure the factorial of a
number. The first example does not use recursion; the second example
uses recursion.

Sample Macros to Figure the Factorial of a Number (n!)
------------------------------------------------------

Method 1: Finding  (n!) Without Recursion
-----------------------------------------

Sub MAIN
Input "Find Factorial Of: ", a     'Allows user input
result = Factorial(a)              'Only function call
Print result                       'Prints the final result
End Sub

Function Factorial(a)
If a = 0 Then                      'If a = 0 return 1 (0!=1)
           sum = 1
         Else                      'calculate with loop
           sum = a
           For x = a - 1 To 1 Step - 1
             sum = sum * x
           Next x
End If
Factorial = sum
End Function

Method 2: Finding (n!) with Recursion
-------------------------------------



Sub MAIN
Input "Find Factorial Of: ", a     'Allows user input
result = Factorial(a)
Print result
End Sub

Function Factorial(a)
If a = 0 Then                       '(0!=1 so return 1)
           result = 1
         Else
           result = a * Factorial(a - 1)  'if not 0 then
End If                                    'multiply "a" by
Factorial = result                        'factorial of a-1
End Function

Both methods return the same result; however, the recursive method is
slightly more efficient. This is one possible use of recursive
functions in WordBasic.

REFERENCES
==========

The Waite Group's book "Microsoft Quick C Programming," pages 164-167

Additional reference words: w4wmacro  2.00 2.00a 2.00a-CD 2.00b 2.00c wm_word 



Using AppActivate to Switch to Another Application
Article ID: Q72287
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

This article contains a macro that switches the focus from Microsoft
Word for Windows to another application; when it is finished, the
macro returns the focus to Word for Windows. What the macro does
between switching applications is up to the individual user.

The AppActivate statement activates the specified window in an
application other than Microsoft Word for Windows. To activate a
window within Word for Word windows, use Activate command. Use
AppActivate to switch to another application that is already running
or that you have started by using Shell.

Note: If the other application is minimized, this macro will not
maximize that application; it simply gives that application the focus
and then returns the focus to Word for Windows.

MORE INFORMATION
================

The following is the text of the macro:

   Sub Main
   ActiveWin$ = WindowName$()    'get the title of the current window
   AppActivate "Microsoft Excel", 1
   Activate ActiveWin$
   End Sub

The WordBasic AppActivate syntax is as follows: 

   AppActivate WindowText$ [,Immediate]

Note: Many applications append the name of the working file to the
application name used in the window title bar. For example, the Windows
Cardfile application might have window names such as:

   Cardfile - (untitled)
   Cardfile - PHONE.CRD

In this case the following AppActivate command should include
the complete window text string:

   AppActivate "Cardfile - PHONE.CRD", 1



Microsoft Excel includes the working file name in the windows titleb bar
when the spreadsheet window is maximized.

There are other methods to return the focus to Word for Windows. The
main advantage of this method is its simplicity. When the macro
returns the focus, Word for Windows will be in the exact state that it
was left in prior to running the macro.

REFERENCES
==========

"Microsoft Word for Windows Technical Reference," page 29

"Microsoft Word for Windows and OS/2 Technical Reference," pages
128-129

Additional reference words: 1.0 1.1 1.1a 2.0 2.0a 1.00 1.10 1.10a 2.00
2.00a w4wmacro wm_word 6.00



Can't Toggle Case in Table with SHIFT+F3 or ChangeCase Macro
Article ID: Q72549
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

When you select one or more cells of a table in Microsoft Word for
Windows and attempt to toggle the case of characters by pressing
SHIFT+F3 or running the ChangeCase macro, the computer beeps,
indicating that the command is unavailable.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

WORKAROUND
==========

To use SHIFT+F3 or the ChangeCase macro to change the case of
characters in a table, the text entries must be selected individually
(that is, without selecting the cell marker).

To change all the entries in a table at once, use one of the following
workarounds:

Workaround 1
------------

1. Select the table and the paragraph mark that immediately follows
   the table.

2. Press SHIFT+F3 to toggle the case to the desired format.

Workaround 2
------------

1. Select the table.

2. From the Insert menu, choose Table To Text.



3. Press SHIFT+F3 to toggle the case to the desired format.

4. From the Insert menu, choose Table, select the number of rows and
   columns, and choose the OK button. The text is converted back to table
   format with the desired case.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.x, page 378

Additional reference words: w4wformat w4wtable w4wmacro  uppercase
lowercase 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Word for Windows: Using WordBasic to Print Out a DOS Directory
Article ID: Q72579
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

You can print a listing of the files in a directory without leaving
Microsoft Word for Windows. The following macro prints a listing of
all of the files in the WINWORD directory:

   Sub MAIN
   Shell "command.com /c dir c:\winword>prn"
   End Sub

NOTE: Word 6.0 provides this functionality with the File$() WordBasic
command.

MORE INFORMATION
=================

You can modify this macro to print the listing of any directory by
prompting the user for input with any valid WordBASIC method (for
example, InputBox or Dialog). The following is an expanded version of
the above macro:

   Sub MAIN
   a$ = InputBox$("Enter the directory to print")
   Finalcommand$ = "command.com /c dir " + a$ + ">prn"
   Shell Finalcommand$
   End Sub

When you run this macro, if you type "c:\excel" (without the quotation
marks) at the command prompt for a directory to print, the macro
prints a listing of the entire EXCEL directory. You can use other
MS-DOS conventions as well. For example, to print a listing of the
.DOT files in a directory, you could input "c:\winword\*.dot" (without
the quotation marks).

The key to this macro is the /c switch used with COMMAND.COM. The /c
followed by a string tells the command processor to perform the
command or commands specified by the string and then to return
automatically to the primary command processor.

Note: The above macros assume a printer is connected to LPT1.

REFERENCES
==========



"Microsoft MS-DOS User's Guide and Reference" pages 47-48

"Microsoft Word for Windows and OS/2 Technical Reference" pages
256-257

Additional reference words: w4wmacro 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c



Using RecordNextCommand Macro When Writing WinWord Macros
Article ID: Q73113
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

It is possible to use the RecordNextCommand macro to record the 
syntax of the next WordBasic command executed into an open macro window 
in Microsoft Word for Windows versions 1.x through 6.0.

MORE INFORMATION
================

The RecordNextCommand macro can be helpful when you are writing a macro and
are unsure of the syntax for a particular command. The RecordNextCommand
will insert the syntax of the next command executed into the open macro
window.

Word for Windows version 6.0
----------------------------

To activate the RecordNextCommand in Word for Windows 6.0, do the
following:

1. In the Macro Editor, place your insertion point at the spot 
   where you wish the recorded command to begin.

2. Switch to an open document window from the Window menu or by
   pressing Ctrl-F6), or open a new document. 

3. From the Macro Editor toolbar, which is still showing above 
   the Ruler, press the button second from left, a dot with a
   number "1" next to it. (If you're not sure which button, the 
   Toolbar Hint will say "RecordNextCommand" when your mouse
   pointer is positioned on the button.)

4. Your mouse pointer will grow an icon resembling an audio
   cassette, to indicate that the Macro Recorder is active.

5. Perform the action that is to be recorded into your macro.
   (You may re-press the button to abort the recording.)

6. Once the command is completed, the recorder will place the 
   command syntax into the macro window. Switch back to the open
   macro sheet to view the recorded syntax.

There is no pre-assigned shortcut key for RecordNextCommand in 
Word for Windows version 6. For information about creating a 



shortcut key or assigning RecordNextCommand to a menu or toolbar,
refer to pages 716-728 of the Microsoft Word for Windows version 
6.0 User's Guide.

Word for Windows version 2.0
----------------------------

To activate the RecordNextCommand in Word for Windows 2.x, do the
following:

1. Follow step 1 below in the section on version 1.x.

2. From the Tools menu, choose Macro and press ALT+C to select the
   Commands option button in the Show box. This selects all macro
   commands.

3. Select RecordNextCommand from the list of available macros and
   press ENTER. (Make sure that you have opened a macro menu at this
   point by selecting Macro from the Tools menu and giving your macro
   a name. Choose Edit to open a macro window).

4. Follow step 4 below.

5. Follow step 5 below.

Word for Windows versions 1.x
-----------------------------

To use the RecordNextCommand macro in Word for Windows version 1.x,
position the cursor on the line where the recorded syntax should
appear in the macro window, and do the following:

1. Switch to an open document window from the Window menu or open a
   document. (Make sure that you have a macro window open as well by
   choosing Edit from the Macro menu, giving a name to your macro, and
   then pressing ENTER.)

2. From the Macro menu, choose Run and press ALT+A to select the
   Show All check box (if not already selected).

3. Select RecordNextCommand from the list of available macros and
   press ENTER.

4. "REC" will now appear in the status bar at the bottom of the
   Word for Windows screen to indicate that the Macro Recorder is
   active.

5. Perform the command that is to be recorded into the macro sheet.

Once the command is completed, the recorder will place the command
syntax into the macro window. Switch back to the open macro sheet 
to view the recorded syntax.

Note: If no macro windows are open, the RecordNextCommand macro 
will beep when executed.

The RecordNextCommand macro can be added to the Macro menu by 



using the Assign to Menu function (refer to page 195 of the "Microsoft 
Word for Windows User's Reference" for more information on adding 
macros to menus).

REFERENCES
==========

"Microsoft WordBASIC Primer," by Russell Borland, page 42
"Microsoft Word for Windows User's Guide," version 2, pages 764-5
"Microsoft Word for Windows User's Guide," version 6, pages 716-
728

Additional reference words: 1.0 1.1 1.1a 1.00 1.10 1.10a  2.0 2.00
wm_word 2.0a 2.0b 2.0c 6.00 w4wmacro



Variable Assigned to Comments Field Limited to 127 Characters
Article ID: Q73209
--------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

If you assign a string variable to the value of the comment field by
dimensioning the EditSummaryInfo dialog box in a Microsoft Word for
Windows macro, you can only retrieve the first 127 characters from the
Comments field.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

The Comments field in the Summary Info dialog box can hold up to 256
characters. However, if you assign a string variable to the value of
the Comments field (as in the following macro), only the first 127
characters are assigned.

Word for Windows versions 1.0, 1.1 and 1.1a
-------------------------------------------

Sub MAIN
Dim dlg as EditSummaryInfo
GetCurValues dlg
A$ = dlg.Comment
End Sub

----------------------------

Sub MAIN
DIM dlg as FileSummaryInfo
GetCurValues dlg
A$=dlg.Comment
End Sub



If you run this macro, A$ only contains the first 127 characters of
the information in the document's Comments field.

Workaround
----------

You can extract more than the first 127 characters from the Comments
field with the following macro:

Sub MAIN
EndOfDocument
InsertField "comments"
CharLeft 1,1
UpdateFields
Dim dlg as ViewPreferences
GetCurValues dlg
If dlg.ShowAll Then Super ShowAll
ViewFieldCodes 0
A$=Selection$()
EditClear
End Sub

This macro moves the insertion point to the end of the document and
inserts the {comments} field code. Once inserted, it is highlighted,
updated to the current value, stored in A$, and removed from the
document. So that A$ is assigned the result of the {comments} field
instead the name of the field itself, the macro also clears the Show
All and Field Codes options to ensure that the result of the field is
displayed rather than the field code itself.

REFERENCES
==========

"Microsoft Word for Windows and OS/2 Technical Reference," pages
163-164

Additional reference words: w4wmacro W_OS2Word 1.0 1.00 1.10 1.1 1.1a
1.10a 2.0 2.00



Button Fields Following Nonupdated Field Don't Work Correctly
Article ID: Q73434
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, a MACROBUTTON field or a GOTOBUTTON
field will not work correctly when it directly follows any field that
has not been updated and is not displaying a result. The text of the
button field will appear in the document, but it will not perform the
function when you double-click it or when you press ALT+SHIFT+F9.

STATUS
======

This problem was corrected in Word version 6.0 for Windows.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. Insert the DATE field by pressing CTRL+F9 and typing "date"
   (without the quotation marks) between the field brackets.

2. Press the END key to move outside the DATE field.

3. Enter a MACROBUTTON field (or a GOTOBUTTON field) on the same line
   as the DATE field with no spaces or tabs between the two fields.

4. Select the two fields and toggle the field codes off with SHIFT+F9.

The button field text will appear but the DATE field will not display
a result. Double-clicking a MACROBUTTON will result in a beep.
Double-clicking a GOTOBUTTON may result in the insertion point moving
to the beginning of the document.

This behavior only occurs if there is a field directly in front
of the button field that is not displaying either the field code
or result. This can be corrected by doing any one of the
following:

1. Press F9 to display the result of the field that has not been
   updated.

   -or-



2. Press SHIFT+F9 to display the field code of the nonupdated field.

   -or-

3. Display both field codes and put a space, tab, or paragraph return
   between the fields.

Additional reference words: w4wfield w4wmacro



Supported Mathematical Operators in WordBasic
Article ID: Q74050
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

Exponential calculations do not have a supported mathematical operator
in WordBasic. The following table indicates the mathematical operators
that are supported using Microsoft WordBasic:

   Operator     Operation Performed
   --------     -------------------

   ()           Changes precedence; performs the operation inside the
                parentheses first
  
   -            Negative value
   
   *            Multiply

   /            Divide

   Mod          Round both numbers to integers, divide, and return the
                remainder

   +            Add

   -            Subtract

Examples: 

   total = (23 - 1)/2  

   x = (6 * 3) + 2

MORE INFORMATION
================

To perform a mathematical calculation that involves exponents, you
must use the UtilCalculate() function. This functions returns a value
to a numeric variable. For example, in version 1.x of Word for
Windows, to find out what 2 to the eighth power (2^8) is, you need
the following WordBasic statement:

   x = UtilCalculate("2^8")

In version 2.0 of Word for Windows, you need the following WordBasic



statement:

   x=ToolsCalculate("2^8")

For more information on calculations with exponents, query on:

   Exponent and w4wmacro

REFERENCES
==========

"Microsoft Word for Windows and OS/2 Technical Reference," page 28

"Microsoft WordBASIC Primer," page 176

Additional reference words: w4wmacro wm_word 6.00 1.00 1.10 1.10a 2.00 
2.00a 2.00a-CD 2.00b 2.00c



Simulating a Macro Pause in Word for Windows
Article ID: Q74630
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

There is no built-in WordBASIC command to pause a running macro and
allow user intervention in Microsoft Word for Windows. However, the
method below simulates a macro pause.

MORE INFORMATION
================

To simulate a pause feature in a macro, insert a MsgBox command at the
point where you want to pause and allow user intervention. This MsgBox
should prompt you press a certain key combination (such as CTRL+Z)
when you are ready to resume the macro.

Place the commands for the remainder of the macro into another macro
and assign it the key combination referenced in the MsgBox. When you
press this key combination, this macro runs, creating a pause effect
between the first and second macro.

REFERENCES
==========

"Microsoft Word for Windows Technical Reference," page 77

"Microsoft Word for Windows and OS/2 Technical Reference," pages 224-225

Additional reference words: w4wmacro wm_word 6.00 1.00 1.10 1.10a 2.00
2.00a 2.00a-CD 2.00b 2.00c



Runnning Word for Windows Macro from Visual Basic Program
Article ID: Q74653
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

It is possible to write a Visual Basic program to communicate with 
Microsoft Word for Windows using DDE (Dynamic Data Exchange). The
following example displays the syntax necessary to run a Word for
Windows macro from a Visual Basic application:

   Const COLD = 2
   Const NONE = 0
   Const HOT  = 1

   Sub Compic2_Click ()
   compic2.LinkTopic = "WinWord|system"
   compic2.LinkMode = COLD
   a% = DoEvents()
   compic2.LinkExecute [Hellomacro]
   compic2.LinkMode = NONE
   End Sub

MORE INFORMATION
================

The most important part of this macro from the Word for Windows
viewpoint is the syntax to communicate with Word for Windows
specifically. The command that actually executes the macro is the
.LinkExecute command. This is the Visual Basic equivalent of the
DDEExecute in Word for Windows. The correct lines of code to run a
Word for Windows macro should follow this syntax:

   compic2.LinkTopic = "WinWord|system"
   compic2.LinkMode= either HOT OR COLD
   compic2.LinkExecute [Macroname]
   (you should always close the link as the example does)

REFERENCES
==========

"Microsoft Visual Basic Programmer's Guide," pages 354-376

Additional reference words: w4wmacro wm_word 6.00 1.00 1.10 1.10a 2.00
2.00a 2.00a-CD 2.00b 2.00c



Macros to Find the ANSI Value of Characters
Article ID: Q74894
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

To troubleshoot a problem or search for an extended character, you may
need to find the ANSI value of a string of text in Microsoft Word for
Windows. Below are two simple macros to accomplish this task. The
first is for one character selections and the second is for strings or
formatting characters.

The application note titled "WordBasic Macro Examples for Word for
Windows 2.0" includes a macro named ANSIChar. You can use this macro
to display the ANSI value of a selected character in a message box.

MORE INFORMATION
================

Macro 1
-------

Sub Main
A$=Selection$() '* A$ = highlighted text
Print Asc(A$)           '* Print ANSI value of the first
                                '* character in A$ on the Status bar.
End Sub

This macro displays its result on the status bar.

Macro 2
-------

You can use this macro for formatting characters or dissecting any
size text string. It displays both character and ANSI values in a
message box.

Sub Main
A$ = Selection$()               '*A$=Highlighted text
While Len(A$) >=1               '* While the Length of A$ is
                                        '* greater than 1
CharValue = ASC(A$)             '* the ANSI value of 1st character
If Len(A$) >1 Then              '* Reducing the length of A$
        A$ = Mid$(A$, 2)        '* A$ = A$ minus the 1st character
Else
        A$=""                   '* A$ = nothing
End if
MsgBox Chr$(34) + Chr$(CharValue) + Chr$(34) + " ASC val = " +



Str$(CharValue)         '* Display values in a message box
Wend                                    '* end while loop
End Sub

To use these macros most efficiently, follow these steps:

1. From the Tools menu in Word for Windows 2.0, choose Macro, type a
   macro name, and choose the Edit button. From the Macro menu in Word
   for Windows 1.x, choose Edit, type a macro name, and choose the OK
   button.

2. Type the macro.

3. Choose File, Close, and save the macro when prompted.

4. Select the text to run the macro on.

5. Choose Tools, Macro.  Highlight the macro name and choose Run.

Additional reference words: w4wmacro 1.0 1.1 1a 1.00 1.10 1.10a 2.00
2.00a 2.00a-CD 2.00b 2.00c wm_word 6.00



Recorded Macro to Print Merge to Printer Requires SendKeys
Article ID: Q74913
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

The SendKeys macro command is required in a macro to print merge a
document to the printer in Microsoft Word for Windows. Without the
SendKeys macro command, the Print dialog box remains on the screen.
This problem occurs because Word for Windows does not have control
over the File Print dialog box; therefore, you must send all relevant
keystrokes using the SendKeys command.

MORE INFORMATION
================

If a macro is recorded to merge a document to the printer, the macro
has the following commands (there may be different values for the
parameters, depending on your choices in the dialog boxes):

Sub MAIN
FilePrintMerge .MERGERECORDS = 0, .From = "", \
.To = "", .PRINT
FilePrint .Type = 0, .NumCopies = "1", .Range = 0,\
.From = "", .To = "", .Reverse = 0, .Draft = 0,\
.UpdateFields = 0, .PaperFeed = 8, .Summary = 0, \
.Annotations = 0, .ShowHidden = 0, .ShowCodes = 0,\
.FileName = ""
End Sub

Note: The backslashes (\) indicate the command is continued on the
next line. Do not include the backslashes in your macro.

For the macro to work correctly, the following command must be
inserted before the FilePrintMerge command:

   SendKeys "{enter}", -1

Multiple Copies
---------------

If you want to print more than one copy of your merged document, use
the following SendKeys command to modify the Copies box in the File
Print dialog box:

   SendKeys "N{ENTER}", -1

Note: "N" is the number of copies you want to print.



REFERENCES
==========

"Microsoft Word for Windows Technical Reference," pages 88-90

"Microsoft Word for Windows and OS/2 Technical Reference," pages
251-253

Additional reference words: w4wmacro w4wmerge 1.00 1.10 1.10a 2.00
2.00a 2.00a-CD 1.x appears automatic 6.00



Changing the Default Filename and Directory in File Open
Article ID: Q75740
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you can change the default directory
and default filenames that appear when you choose Open from the File
menu. You can modify the FileOpen macro to list all files or only
files with a particular extension within a directory. You can also
modify the FileNew macro to change the default directory that is
displayed when you choose New from the File menu.

Displaying All Files in a Directory
-----------------------------------

WARNING: ANY USE BY YOU OF THE CODE PROVIDED IN THIS ARTICLE IS AT YOUR
OWN RISK. Microsoft provides this macro code "as is" without warranty
of any kind, either express or implied, including but not limited to
the implied warranties of merchantability and/or fitness for a
particular purpose.

Caution: See the "Note" section below this procedure before
proceeding.

To modify the FileOpen macro so that it will list all the files in a
specific directory, do the following:

1. In versions 1.x of Word for Windows, choose Edit from
   the Macro menu. In versions 2.x of Word for Windows, choose
   Macro from the Tools menu.

2. In the Macro Name box, type "FileOpen" (without the quotation
   marks).

3. The macro-editing window displays the FileOpen macro. Make the
   following changes to this macro:

Word Version 6.0
----------------

Sub MAIN
Dim dlg As FileOpen
GetCurValues dlg
dlg.Name = "*.*"
Dialog dlg
On Error Resume Next
If dlg.Name <> "*.*" FileOpen dlg
End Sub



Word Version 1.x, 2.x
---------------------

      Sub MAIN
      on error goto bye
      ChDir "f:\winword"   'use any existing directory here
      Dim dlg As FileOpen
      GetCurValues dlg
      dlg.Name = "*.*"
      Dialog dlg
      Super FileOpen dlg
      bye:                 'Error exit out,  and clear errors
      err = 0
      End Sub

4. From the File menu, choose Close and save changes to
   Global:FileOpen.

Now when you choose Open from the File menu, the File Name list box
will display all the files in the desired directory.

Note: If you use this macro to replace the built-in FileOpen macro,
the Find button will no longer be available in the Open dialog box in Word
1.x and 2.0. The OK and Cancel buttons will be the only buttons available.
To use the macro listed above while keeping the Find option accessible in
the Open dialog box, create the above macro in addition to the FileOpen
macro instead of replacing it. The following steps outline this
procedure:

1. In Word for Windows version 1.0, 1.1, or 1.1a, choose Edit from the
   Macro menu. In Word for Windows version 2.0 or 2.0a, choose Macro from
   the Tools menu.

2. Type a new macro name, such as "OpenAll" (without the quotation
   marks).

3. Type a description, such as "Opens all files" (without the
   quotation marks).
4. In the macro-editing window, type the macro as it appears in the
   above procedure. From the File menu, choose Close and save the
   changes to the Global:OpenAll macro.

You can now assign this macro to the File menu so that it appears in
addition to the regular Open command. The Find button will remain
functional in the Open dialog box when you run the FileOpen macro.
Changing the Default Directory
------------------------------
To change the default directory that will display when you choose New
from the File menu, make the following changes to the FileNew macro:

   Sub MAIN
   On Error Goto seeya             'Error handling trap
   ChDir "f:\winword1.a"           'To change the directory
   Dim dlg As FileNew
   GetCurValues dlg
   Dialog dlg
   Super FileNew dlg



   seeya:
   err = 0                         'Exit for error
   End Sub

When you exit Word for Windows after you have modified or added any of
these macros, the message "Do you want to save the global glossary and
command changes?" will appear. Choose the Yes button to save your
changes.

In the macros listed above, the directories specified in the
ChDir line can be any valid directory on your system.

Note: Microsoft provides macros "as is" without warranty of any kind,
either express or implied, including but not limited to the implied
warranties of merchantibility and/or fitness for a particular purpose.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 765

"Microsoft Word for Windows User's Reference," versions 1.x, pages
186-189

"Microsoft Word for Windows Technical Reference," pages 16-17, 115

"Microsoft Word for Windows and OS/2 Technical Reference," pages 95-97

Additional reference words: w4wmacro
grey gray unavailable
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Displaying Values for Arrays and Dialog Box Variables
Article ID: Q75867
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

The Show Variables Toolbar button and the ShowVars statement in the 
Word 6.0 macro editor, display a list of variables and their current 
values to help you debug the active macro. However, array elements 
and dialog box variables are not displayed in the Macro Variables 
dialog box.

In order to check the value of an array element, you can use a MsgBox
statement and specify an array element. The following macro displays 
the value of the third element in the month$(2) array "MAR" (the array
begins at zero).

For example:

Sub MAIN
Dim month$(2)
month$(0) = "JAN"
month$(1) = "FEB"
month$(2) = "MAR"
MsgBox "month$(2)= " + month$(2)
End Sub

The Msgbox statement can also be used to display the value of a dialog
box variable. The following macro displays the value assigned to the 
"dlg.Textbox" variable (the text entered into the TextBox).

Sub MAIN
Begin Dialog UserDialog 230, 130
 Text 16, 12, 136, 24, "&Enter Text:"
 TextBox 16, 30, 124, 20, .TextBox
 OKButton 16, 60, 64, 21
 CancelButton 16, 90, 64, 21
End Dialog
Dim dlg As UserDialog
n = Dialog(dlg)
If dlg.Textbox <> "" Then MsgBox "TextBox Variable = " \
 + dlg.Textbox
End Sub

REFERENCES
==========

"Microsoft WordBASIC Primer" by Russell Borland, pages 115-117.

Additional reference words: w4wmacro 2.0 2.00 6.00 wm_word 



Word Basic Int() Function Limitations and Work Around
Article ID: Q76183
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, the INT WordBasic function is limited
to working with values less that 32,769. Attempting to calculate INT
on a variable larger than 32,769 causes Word to return the WordBasic
error message "# 6 Overflow Error." This is often a problem because
the INT function is often used to round a number correctly; as a
result, the number is divided by 10 or 100, and you cannot round
numbers larger than 327.69 to the hundredths decimal place.

MORE INFORMATION
================

The following macro reproduces this error:

   Sub MAIN
   a = 100000
   b = Int(a)
   Print b
   End Sub

Workaround
----------

The following is an example of a rounding function that rounds to
whole numbers, tenths (1/10), or hundredths (1/100) by specifying the
round variable as follows:

   Sub MAIN
   origvar = 1102540.126456
   round = 100
   'To round to nearest  Integer           Tenths              Hundredths
   'Round =                 1                10                    100
   'Round to                0               0.1                   0.01
   'Limitation    1,073,741,824      107,374,182.4          10,737,418.24
   If origvar <=( 32768 * 32768) / round Then
           newvar = Int((origvar * round) / 32768) * 32768
           result =(newvar + Int((origvar * round) - newvar + 0.5)) / round
   Else
           MsgBox "Number " + Str$(origvar) + " too large to Round"
   End If
   Print "Original ->" ; origvar ; " |     Result -> " ; result
   End Sub



To round to the nearest whole number, the function is simplified to
eliminate the round variable from the macro above. The + 0.5 in the
line "result= (newvar + Int((origvar * round) - newvar + 0.5))" can be
removed if you only want the integer part of the number to be
returned.

   Sub MAIN
   origvar = 1100000000.12646
   'Limitation                   1,073,741,824
   If origvar <=( 32768 * 32768) Then
           newvar = Int((origvar) / 32768) * 32768
           result =(newvar + Int((origvar) - newvar + 0.5))
   Else
           MsgBox "Number " + Str$(origvar) + " too large to Round"
   End If
   Print "Original ->" ; origvar ; " |     Result -> " ; result
   End Sub

REFERENCES
==========

"Microsoft Word for Windows Technical Reference," page 69

"Microsoft Word for Windows & OS/2 Technical Reference," pages 57-60,
209

Additional reference words: w4wmacro wm_word 6.00 1.00 1.10 1.10a 2.00
2.00a 2.00a-CD 2.00b 2.00c



File Search Macro in Word for Windows
Article ID: Q76188
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, choosing Find from the File menu allows
you search in certain directories only after you have completely
searched the directories specified in the search option.

MORE INFORMATION
================

The following macro allows you to enter the search path and search
only the specified directories, without going through the entire
search list first. You can search more than one directory at a time by
typing multiple search paths separated by semicolons.

For example:  

   c:\winword\data;c:\winword

If you choose the Cancel button in the Input box, the previous search
path is used and the FindFile dialog appears.

Word for Windows Version 2.0
----------------------------

   Sub MAIN 
   On Error Resume Next 
   SearchList$ = InputBox$("What is the Directory") 
   FileFind .SearchPath = SearchList$ 
   ToolsMacro .Name ="FileFind", .Run 
   End Sub

Word for Windows version 1.x
----------------------------

   Sub MAIN
   On Error Goto Bye
   SearchList$ = InputBox$("What is the Directory")
   FileFind .SearchPath = SearchList$
   MacroRun "FileFind"
   Bye:
   End Sub

REFERENCES
==========



"Microsoft Word for Windows Technical Reference," pages 49-50

"Microsoft Word for Windows and OS/2 Technical Reference," pages
171-172

Additional reference words: w4wmacro 1.00 1.10 1.10a 1.0 1.1 1.1a 2.00
2.00a 2.00a-CD 2.00b 2.00c wm_word 6.00



\Cell Bookmark Does Not Select Correct Cell in WinWord
Article ID: Q77145
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, the WordBASIC macro language uses the
"\cell" bookmark to select the entire contents of a cell in a table
where you position the insertion point.

If a series of cells are highlighted in a table, the first cell in the
upper-left corner of the highlighted area should be selected. However,
if there are cells in the table to the left of the highlighted area,
the bookmark selects the first cell in the table row that contains the
highlighted area even though that cell was not part of the highlighted
area. This is contrary to the description of the \cell bookmark
described on page 106 of the "Word for Windows and OS/2 Technical
Reference" and on page 89 of "Using WordBasic."

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Steps to Reproduce Problem:
---------------------------

1. Create a 3 x 3 table in Word for Windows and type something in each
   cell.

2. Highlight the rightmost two columns and run the following macro:

      Sub Main
      EditGoTo .destination = "\cell"
      End Sub

3. Notice that an incorrect cell is highlighted.

REFERENCES



==========

"Using WordBasic," page 89

"Microsoft Word for Windows Technical Reference," page 21

"Microsoft Word for Windows and OS/2 Technical Reference," pages
104-106

Additional reference words: w4wmacro w4wtable cmpbookmarks 1.00 1.10
1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



WinWord: Sharing a Global Dimensioned Array with Other Macros
Article ID: Q77273
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In the Microsoft Word for Windows WordBasic macro language, you can
create a dimensioned array, such as A(6,6), that is available
throughout any macro or subroutine.

MORE INFORMATION
================

To create a dimensioned array that is available globally to any
WordBasic macro or subroutine, load the values into the array, open a
text file, and write the contents of the array to the text file.

If a macro needs to access these values, it opens the text file, reads
the values into the array, and manipulates the values as necessary.
The macro writes the values back to the text file. The manipulated
values are available again to the originating macro or any other
WordBasic macro that requires them. The following sample WordBasic
macro illustrates this process:

   Sub MAIN

   Dim a(6, 6)
   For x = 1 To 6
   For y = 1 To 6
   a(x, y) = y : Rem loading the array
   Next y
   Next x

   Open "test.dat" For Output As #2
   For x = 1 To 6
   For y = 1 To 6
   Print #2, a(x, y):REM Writing the array to a text file
   Next y
   Next x
   Close 2

   REM After opening a second macro, open the text file and read
   REM it into the array again. Manipulate the array at this
   REM point and write it back out to the text file.

   Open "TEST.DAT" For Input As #2
   For x = 1 To 6
   For y = 1 To 6



   Input #2, a(x, y) : Print "read " ; a(x, y)
   Next y
   Next x
   Close 2

   End Sub

Additional reference words: w4wmacro passing parameters wm_word 6.00 1.00
1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



No Prompt for Number of Columns in Word for Windows 2.0
Article ID: Q77297
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows version 2.0, there is no option to
indicate the number of columns you want when you create a table from
selected text. When performing this operation in Microsoft Word for
Windows versions 1.0, 1.1, and 1.1a, a dialog box appears prompting
you for the number of columns and the type of delimiter you want to
use.

Word for Windows version 2.0 attempts to automatically determine the
type of delimiter to use. If Word cannot determine the delimiter to
use, it prompts you for a delimiter type. However, no option exists
for choosing the number of columns in a table when you use the Convert
Text to Table command. The number of columns is determined by the
number of delimiters included in the selected text.

Word for Windows version 2.0 excludes this prompt by design.

STATUS
======
 
Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.
 
To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

You can modify the the TableInsertTable macro to prompt for the number
of columns. The following is an example of a macro that can be used as
a replacement for the existing TableInsertTable macro to prompt for
the number of columns to be inserted in a table:

   Sub MAIN
   InsertBookmark .Name = "zTable" 'placeholder bookmark
   CharLeft 'making sure nothing
   Dim dlg As TableInsertTable 'is selected
   GetCurValues dlg



   Dialog dlg 'if nothing is
'selected, you can
'enter #rows & columns

   EditGoTo "zTable" 'go back to the
'selection

   Super TableInsertTable dlg 'insert the table
   InsertBookmark .Name = "zTable", .Delete 'delete the bookmark
   End Sub

Additional reference words: 1.00 1.10 1.10a 2.00 w4wmacro



Style Shortcut Keys Not Reflected in Template
Article ID: Q77547
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, any shortcut keys that you
assign to styles in a document are not reflected in the document
template unless you add the styles to the template file.

This problem was corrected in Word version 6.0 for Windows.

MORE INFORMATION
================

If you assign a shortcut key to a style within a document, the key
assignments are not added to the document template file unless you
select the Add to Template option. The key assignments are valid in
the current document, but new documents that are based on the template
file do not include the key assignments.

To record the shortcut key assignments in the template file, follow
these steps:

1. From the Format menu, select Style.

2. Choose the Define button. Assign a shortcut key to a style if a key
   assignment has not already been made by selecting the style name from
   the drop-down list box, choosing a shortcut key, and clicking on the
   Assign button.

3. Select the check box labeled Add to Template (ALT+E).

4. Choose the Apply button.

Any changes made to the selected style, including the shortcut key
assignment are now reflected in the template file.

STATUS
======

Microsoft has confirmed this to be a problem in Word for Windows
versions 2.x. This problem was corrected in Word version 6.0 for
Windows.

Additional reference words: 2.00 2.00a w4wmacro 2.00a-CD 2.00b
w4wtemplate



Summary Info Statistics Values Not Recorded in WinWord Macro
Article ID: Q77555
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

When recording a Microsoft Word for Windows macro to access a file's
Summary Info dialog box, the current values in the Statistics fields
are not recorded; they are always left blank.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

The following is a recorded macro which accesses a document's Summary
Info and Document Statistics dialog boxes.

   FileSummaryInfo .Title = "Test of Macro record Summary Info", \
   .Subject = "testing document", .Author = "Mickey Mouse",  \
   .Keywords = "w4wmacro w4w", .Comments = \
   "This is a test. This is a test.", .FileName = "", .Directory = "",  \
   .Template = "", .CreateDate = "", .LastSavedDate = "", \
   .LastSavedBy = "", .RevisionNumber = "", .EditTime = "", \
   .LastPrintedDate = "", .NumPages = "", .NumWords = "", .NumChars = ""

Any fields after the Comments field are blank. These blank fields are
unique because they are the only read-only fields in Word for Windows;
therefore, they cannot be modified in the usual manner. They appear
because Word automatically lists all fields if you access a dialog box
in a recorded macro.

Additional reference words: w4wmacro 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD
2.00b 2.00c



Creating Bullets When the Default Symbol Font Won't Print
Article ID: Q77824
---------
-------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

If you don't have access to the Symbol font with your printer, it is
possible to make a solid bullet by drawing it in Windows Paintbrush,
copying it, and pasting it into Microsoft Word for Windows.

More Information:

If a solid bullet is needed, and the Symbol fonts are not available on
the printer being used, a bullet can be created with the following
steps:

1. Minimize Word for Windows.

2. Start the Paintbrush program from the Accessories Group of the
   Windows Program Manager.

3. Select the Filled Circle/Ellipse tool from the Paintbrush Toolbox.
   Choose black from the Palette. Draw a small circle.

4. Choose the Pick cutout tool to select the solid circle you just
   created.

5. From the Edit menu, choose Cut or Copy.

6. Minimize or Exit Paintbrush.

7. Go back into Word for Windows and paste the "bullet" into a
   document.

8. Option: You can store the bullet as a glossary entry by selecting
   the bullet, choosing Glossary from the Edit menu, typing a Glossary
   Name, and choosing Define.

9. Option: You can further automate the insertion of this "bullet" by
   recording a macro to insert the bullet from the glossary(Winword
   1.x,2.x) or Autotext(Winword 6.0). This macro can then be assigned
   to a keystroke or menu.

Word for Windows 2.0 Feature
----------------------------

In Word for Windows 2.0, Microsoft Draw can be used to create a
"bullet", which is then embedded into the Word document, as follows:



1. Start Microsoft Draw by selecting the Microsoft Draw button. You can
   also start Microsoft Draw by choosing Draw from the Insert menu and
   selecting Microsoft Drawing from the Object Type box.

2. Choose the Circle tool from the tool bar, and select black for both
   the line and the fill from the color palette.

3. Draw a small circle.

4. From the File menu, choose Exit and Return to Document.

5. Choose Yes to update the the Document.

The "bullet" will now appear in the document. This embedded Microsoft
Drawing can also be made a glossary entry and/or macro, as described
above.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 141-142, 185-189

Additional reference words: 1.00 1.10 1.10a 2.00 1.0 1.1 1.1a 1.0 
w4wfont w4wmacro



Macro to Insert a Bullet in WinWord If No Keypad Exists
Article ID: Q77914
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

Some keyboards, such as those used with laptop computers, do not have
a separate numeric keypad to use to insert the bullet code (ALT+0183)
or other symbols using the symbol soft font set that comes with Word
for Windows version 1.x. The following macro inserts the bullet
character. You can create a glossary item with the resulting bullet.
 
   Sub MAIN
   Dim dlg As FormatCharacter
   GetCurValues Dlg
   a$ = dlg.Font
   FormatCharacter .Font = "Symbol"
           Insert Chr$(183)
   FormatCharacter .Font = a$
   End Sub

You can modify the sixth line in the above macro to create another
symbol code by replacing (183) with the code of the symbol you want to
use.
 
You can also use this macro in Microsoft Word for Windows version 2.0 or 
6.0. However, version 2.0 or 6.0, includes a function that allows you to
automatically insert a symbol by selecting the appropriate symbol from
a list. To use this feature, choose Symbol from the Insert menu. A
dialog box appears displaying all of the available symbol codes.
Select the symbol you want to use and choose the OK button. The symbol
is inserted in your document.

Additional reference words: 1.0 1.1 1.1a 1.00 1.10 1.10a 2.00 w4wmacro
wm_word 6.00



ANSI Characters 0 through 31 Do Not Display in WinWord
Article ID: Q78003
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

The American National Standards Institute (ANSI) allows you to create
characters by typing their ANSI codes. ANSI characters are characters
that do not appear on a standard American keyboard. Microsoft Word for
Windows versions does not display an ANSI code for decimal numbers 0-31 
and Word does not display an error message if you type a decimal number 
ranging from 0-31. The ANSI character set includes  the decimal numbers 
33-255 in Word for Windows.

MORE INFORMATION
================

To create the ANSI characters in Word for Windows, follow the steps
below:

1. From the Format menu, select Character. In the Font box, select
   Symbol.

2. Turn on NUM LOCK.

3. Hold Down the ALT key.

4. Type "0" (without the quotation marks) followed by the decimal
   number that represents the ANSI Character you want to include. You
   must use the numbers on the numeric keypad rather than the numbers
   across the top of your keyboard.

5. After you type the code, release the ALT key. Word inserts the
   character represented by the code into your document. For example, to
   create a bullet character you type ALT+0183.

Note: ANSI character number 32 is a space. If you insert this
character as shown above, it produces a single space. You can verify
this (in version 1.x) by selecting Preferences from the View menu, and
selecting Spaces or Show All. In versions 2.x and 6.0, choose Options 
from the Tool menu, choose View from the Category list, and select 
Spaces or Show All.

For more information, query on the following words:

   ANSI and characters and w4wmacro

Additional reference words: w4wformat 6.00 wm_word 



1.0 1.1 1.1a 1.00 1.10 1.10a 2.00

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.x, pages
427-428

"Microsoft Word for Windows User's Guide," version 2.0, pages 153-155

Additional reference words: w4wformat wm_word 6.00



Word for Windows: Macro to List Files
Article ID: Q78122
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

The following macro displays a listing of files for any specified
directory. It also allows you to specify files you want to search for.
For example, if you type a*.*, the macro searches for all files that
begin with the letter "a." Microsoft Word for Windows places the list
of files in a document. You can save this document for future
reference.

   Sub MAIN
   On Error Goto errorfound
   FileNew .NewTemplate = 0, .Template = "NORMAL"
   FormatSection 2
   Dir$ = InputBox$("What directory do you want to List ?")
   Spec$ = InputBox$("What file specification do you want me to look
           for?")

   ChDir Dir$
   a$ = Files$(Spec$)
   While A$ <> ""
   Insert  A$
   filecount = filecount + 1
   InsertPara
   a$ = Files$()
   Wend
   totalnum$ = Str$(filecount)
   dir$ = Files$(".")
   text$ = "Total files in "
   Insert text$ + dir$ + " = " + totalnum$
   Goto exitmain
   errorfound:
   MsgBox "An error occurred check specified directory and file
   specification it should follow
   normal DOS standards . ", 16
   exitmain:
   End Sub

If you use the above macro in Word for Windows version 2.0, & 6.0
replace the fourth line, "FormatSection 2," with the following line:

   FormatColumns .Columns = "2", .ApplyColsTo = 4

For more information on directories and file specifications, consult
your disk operating system (DOS) manual.

REFERENCES
==========



"Microsoft Word For Windows and OS/2 Technical Reference", page 178
Additional reference words: w4wmacro 1.0 1.1 1.1a 1.00 1.10 1.10a 2.00
wm_word



Creating Special and Foreign Characters in Word for Windows
Article ID: Q78160
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

You can create special and foreign characters in Microsoft Word for
Windows version 2.0 using the Insert Symbol command. Each font
displays its own set of characters. To change the font, select a new
font from the Symbol From box in the Symbol dialog box.

More Information:

Word for Windows 2.0
--------------------

To create special or foreign characters in Word for Windows version
2.0, use one of the following methods:

1. From the Insert menu, choose Symbol. Select the symbol you want to
   use, and choose the OK button.

2. Hold down the ALT key while you type zero and the ANSI decimal
   character number on the numeric keypad (with NUM LOCK on).

3. From the Format menu, choose Character. In the Character dialog
   box, choose the Symbol font, and choose the OK button. Type the
   symbol.

Word for Windows 1.x
--------------------

To create special or foreign characters in Word for Windows version
1.0, 1.1, or 1.1a, choose one of the following methods:

1. Hold down the ALT key while you type zero and the ANSI decimal
   number on the numeric keypad (with NUM LOCK on).

2. From the Format menu, choose Character. In the Character dialog
   box, choose the Symbol font, and choose the OK button. Type the
   symbol.

For a keyboard layout of the symbols you can type using the Symbol
font, see the KEYCAPS.DOC file provided with Word for Windows 1.x.

For additional information on printing symbols, query on the following
words in the Microsoft Knowledge Base:

   w4wmacro and symbol



Reference(s):

"Microsoft Word for Windows User's Reference," 1.x, pages 10, 35, 353,
427-429

"Microsoft Word for Windows User's Guide," version 2.0, pages 153-155

Additional reference words: 1.x 1.00 1.10 1.10a 2.00 w4wfont 6.00 
wm_word diacritical



Special WinWord BookMarks: EnvelopeAddress and EnvelopeReturn
Article ID: Q78530
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Microsoft Word for Windows can usually determine the To and From
addresses when you choose the Create Envelope command. You can
manually specify these addresses by selecting the To and From
addresses and inserting bookmarks named EnvelopeAddress and
EnvelopeReturn, respectively. Word uses the text of these bookmarks
when you choose the Create Envelope command.

If you do not specify bookmarks or Word cannot determine the return
address in the letter, Word uses the return address specified in
Mailing Address box (accessed by choosing Options from the Tools menu
and selecting the User Info category).

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 118-119

Additional reference words: 6.00 2.00 w4wmacro toolbar tool bar wm_word 
button w4wenvelope bookmark



Deleting Key Assignments In Word for Windows 2.0
Article ID: Q78544
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word For Windows, the Delete button is not available after you
make a key assignment. 

Steps to Reproduce Problem
--------------------------
   
1. Create the following macro, and name the macro "Test."

      SUB Main
      Print "Hello"
      END Sub
 
2. From the Tools menu, choose Options. From the Category list, select
   Keyboard.
  
3. In the Show box, select Macros. Select your macro in the Macro box.
    
4. Choose a key combination to assign to the macro, or select the keys
   from the Shortcut Key box. Choose the Add Button.
 
5. From the Tools menu, choose Options, and select the Keyboard
   category again. Select your macro. 
 
The Delete button is unavailable and not a valid selection.
 
To remove a key assignment, you must select the key settings from the
Current Key For box. After you make this selection, the Delete button
becomes an available and valid option.

Word 6 Steps to Reproduct Problem
---------------------------------

1. Create the following macro, and name the macro "test".
      SUB Main
      Print "Hello"
      END Sub

2. From the Tool menu, choose Customize, select Keyboard tab. Enter key 
   combination, click on Assign button. Close.

3. From the Tools menu, choose Customize, Keyboard tab and select "test" 
   macro. The Shortcut key is shown, but the Remove button is grayed out.



4. Highlight shortcut key and Remove button is available.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 722, 767

Additional reference words: 2.00 grayed greyed removing key strokes
wm_word 2.0a 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD w4wmacro



Checking For Execute-Only Macro Status with IsExecuteOnly
Article ID: Q78570
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

You can use the Microsoft Word for Windows WordBasic function,
IsExecuteOnly, to determine whether a macro is editable or
execute-only. The syntax for the command is as follows:

   IsExecuteOnly(Macro$)

IsExecuteOnly returns zero if a macro is editable or -1 if the macro
is execute-only. The Macro string (Macro$) takes the form of
ContextName:MacroName. Macros that cannot be edited are sometimes 
referred to as encrypted. You can make a macro execute-only using
the WordBasic MacroCopy statement.

The following macro displays the status of the FileNew macro in a
message box, using the value returned from the IsExecuteOnly function:

 Sub MAIN
 exe = IsExecuteOnly("Global:FileNew")
 If exe = - 1 Then
  MsgBox "Execute Only Macro"
 Else
  MsgBox "Edit and Execute Macro"
 Endif
 End Sub

or:

 Sub MAIN
 If IsExecuteOnly("Global:FileNew") Then
  MsgBox "Execute Only Macro"
 Else
  MsgBox "Edit and Execute Macro"
 Endif
 End Sub

For more information, refer to IsExecuteOnly in the Programming 
with Microsoft Word section of the Word 6.0 Online Help file, or
query on the following words:

   macrocopy and execute

Additional reference words: w4wmacro 2.00 exe compile macrocopy 6.00 wm_word 



Custom Table Insertion with Text to Table in WinWord 2.0
Article ID: Q78763
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, converting text to a table is an
automatic process that does not allow you to specify the desired
number of rows or columns. However, you can install the
ManualInsertTable macro from the NEWMACRO.DOC file, included with Word
for Windows version 2.0 and usually found in the program directory, to
provide this functionality.

This functionality was changed in Word version 6.0 for Windows.

MORE INFORMATION
================

NEWMACRO.DOC contains a macro called ManualInsertTable that allows you
to specify the number of rows and columns desired when converting text
to a table in Word for Windows version 2.0. This macro emulates the
functionality of the Insert Table command in Word for Windows version
1.x. NEWMACRO.DOC allows you to install this macro by using the
following steps:

1. Open the file NEWMACRO.DOC.

2. This file contains a list box of optional macros, descriptions of
   the macros, and the ability to demonstrate and/or install each macro.

3. From the list of macros, select ManualInsertTable.

4. Choose the Install button.

5. An "Install ManualInsertTable to" dialog box appears. Select the
   desired template and menu to contain the macro, and choose the OK
   button.

Word installs the macro on the template and menu you selected and
automatically saves the macro. Word returns you to the list box of
available macros to choose another macro or to exit.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 316-318

Additional reference words: w4wmacro w4wtemplate 2.00 2.00a 2.00a-CD 2.00b



2.00c



Context-Sensitive Help for Items Added to the Tool Bar
Article ID: Q78775
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

Context-sensitive help is available for commands added to the
Microsoft Word for Windows version 2.0 tool bar. The contents of the
help varies depending on the nature of the item added to the tool bar.

MORE INFORMATION
================

To access the Context-Sensitive Help for the tool bar, press SHIFT+F1,
and choose the tool bar icon that you want help with. Pressing
SHIFT+F1 causes the mouse cursor become a Help Pointer (an arrow and
question mark together). If you choose an added tool bar item that is
a built-in Word for Windows command, the help screen displays the
topic associated with that built-in command. If the tool bar item
chosen is a user-defined macro, the help screen displays a generic
help topic describing the purpose and function of user-defined macros.

Specific information about a tool bar item displays on the status bar
if you click and holding down the left mouse button on the tool bar
item. In the case of user-defined macros, the text on the status bar
corresponds to the macro's description.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, page 127

Additional reference words: w4wmacro toolbar custom 2.00 2.00a
2.00a-CD 2.00b 2.00c wm_word 6.00



Cannot Cancel Macro Description in Word for Windows 2.0
Article ID: Q78996
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, when you press the Cancel button while
editing a macro description, the description is retained.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this problem,
and will post more information here in the Microsoft Knowledge Base as it
becomes available.

MORE INFORMATION
================

To remove the description of a macro, you must delete the description
manually, and press the Cancel or the Close button.

Steps to Reproduce Problem
--------------------------

1. Start Word for Windows version 2.0.

2. From the Tools menu, choose Macro.

3. Type "test" (without the quotation marks) in the Macro Name box,
   and choose the Edit button.

4. Type the following line between the Sub MAIN and End Sub lines:

      Print "this is a test"

5. From the File menu, choose Close. Choose the Yes button to save
   changes to Global: test.

6. From the Tools menu, choose Macro, and select test from the list of
   macros.

7. Type a description in the Description box, and choose the Cancel
   button.

8. Repeat step 6. The description for the macro remains intact.



REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 719-721

Additional reference words: w4wmacro 2.00 2.00a 2.0b 2.0a-CD 2.00b
2.00a-CD wm_word 6.00



Paragraph-Delimited Text Converts to 1-Column Table in WinWord
Article ID: Q79021
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
tem versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows version 2.0, if you select
paragraph-delimited text to insert into a table, Word for Windows
inserts the text into a 1-column table.

This problem was corrected in Word version 6.0 for Windows.

MORE INFORMATION
================

If you select text that is separated by paragraphs, commas, or tabs to
insert into a table, Word for Windows determines the correct number of
columns automatically. However, if the text is separated only by
paragraph marks, Word for Windows will convert the text to a 1-column
table.

Workaround
----------

The following macro prompts you for the number of columns and then
automatically determines the number of rows for the selected text
before inserting the table:

   Sub MAIN
    col$=InputBox$("How many columns?")
    TableInsertTable .ConvertFrom=0, .NumColumns=val(col$)
   End Sub

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 317-318

Additional reference words: w4wmacro w4wtable  toolbar
2.00 2.00a 2.00a-CD 2.00b 2.00c



AutoNew Macro Does Not Run When You Start Word for Windows
Article ID: Q79054
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

If you have an AutoNew macro in the NORMAL.DOT template and you start
Microsoft Word for Windows, a new document is created, but the AutoNew
macro does not run.

MORE INFORMATION
================

The AutoNew macro only runs if you open a new document after starting
Word for Windows.  The AutoExec macro will run when starting Word for
Windows.

For more information on AutoNew, search for "auto macros" and
"Creating macros that run automatically" using the Help menu.

REFERENCES
==========

"Microsoft Word Technical Reference," pages 97-98

TECHREF.DOC, Microsoft Word for Windows version 1.x

Additional reference words: 6.00 execute 2.00 w4wmacro w4wtemplate wm_word 



Can't Exit Second Instance of WinWord Without a Global Save
Article ID: Q79135
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

When editing a global macro in a second instance of Microsoft Word for
Windows, this second instance does not close as expected if you choose No
when prompted to overwrite the NORMAL.DOT template that is open in the
first instance of Word for Windows. Choosing No cancels the File Exit
command and returns you to the second instance of Word for Windows.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------
  
1. Start Word for Windows version 2.0, and minimize it to an icon.
   Start a second instance of Word for Windows.
   
2. From the Tools menu, choose Macro (in the second instance of Word).
   In the Show box, select Commands. Select AllCaps from the Macro 
   Name box, and choose the Edit button. At the beginning of the "Super
   AllCaps" line in the macro, type "REM " (without the quotation 
   marks). Make sure you include a space after REM. 

3. From the File menu, choose Exit.
    
4. Choose the Yes button when Word prompts you to save changes to
   Global:AllCaps.
 
5. Choose the Yes button again when Word prompts you to save the
   global glossary and command changes. The following message appears
   in a dialog box:



 
      This document is a copy of a file that was being edited by another
      Word session. Changes may have been saved to the original file.
 
      Do you want to save the document using the original name and
      overwrite other possible changes?
 
6. Choose the No button. The File Save dialog box appears with
   NORMAL.DOT in the File Name box. Change this name to NORMAL2.DOT.
  
7. Word saves the new template; however, Word returns to the second
   instance of Word instead of exiting the program.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 267-268,
273, 765

Additional reference words: 2.00 2.00a 2.00a-cd 2.00b 2.00c 2.00c-cd 
w4wmacro w4wtemplate



ANSI Carriage Return Doesn't Work in Macro Editing Window
Article ID: Q79189
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, using the ANSI character set and
selecting the carriage return character (Chr$(13)) does not produce a
carriage return in the macro editing window. Instead, it produces a
period.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this problem,
and will post more information here in the Microsoft Knowledge Base as it
becomes available.

Steps to Reproduce Problem in Version 2.0
-----------------------------------------

1. From the Tools menu, choose Macro, type in a macro name, and choose
   the Edit button.

2. Type the following macro:

      Sub MAIN
      A$=InputBox$("Line 1"+Chr$(13)+"Line 2")
      End Sub

3. Choose the Start button, or press ALT+S. The macro editing window
   displays the following:

      Line1.Line2.

Steps to Reproduce Problem in Version 1.x
-----------------------------------------

1. From the Macro menu, choose Edit, and type in a macro name. Choose
   the OK button.

2. Type the following macro:

      Sub MAIN
      A$=InputBox$("Line 1"+Chr$(13)+"Line 2")
      End Sub



3. Choose the Start button, or press ALT+S. The macro editing window
   displays the following:

      Line1.Line2.

Additional reference words: 1.00 1.10 1.10a 2.00 w4wmacro wm_word 6.00



WinWord: Limitations on Pasting Text into Macro Descriptions
Article ID: Q79272
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows version 2.0, if you paste more than one
line of copied text or more than 256 characters into the Description
box of the Macro dialog box, the description text wraps, and line
breaks display where the text was wrapped in its original source.
 
In Word for Windows version 1.x, the macro description is limited to
one line of text, so no wordwrap can occur.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Steps to Reproduce Problem in Version 2.0
-----------------------------------------
 
1. Open a new document.

2. Type more than 256 characters into the document.
  
3. From the Edit menu, choose Select All. From the Edit menu, choose
   Copy.
      
4. From the Tools menu, choose Macro.
  
5. Type "test" in the Macro Name box. Activate the Description box by
   pressing ALT+I.
 
6. From the Edit menu, choose Paste.
 
Notice that line breaks occur in the description text wherever the
characters previously wrapped in the original text of the document.

Additional reference words: 2.00 w4wmacro





Passing -1 Value to a Dialog Box in WordBasic
Article ID: Q79279
SYMPTOMS
========

Using the macro language in Microsoft Word for Windows version 2.0,
you can change the data in a dialog box. The valid values for option
buttons, drop-down lists, and edit controls are 1, 0, and -1. The -1
value normally indicates no change in the original value; however,
passing a -1 value to change the data in a dialog box results in none
of the option buttons being selected in the dialog box.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. From the Tools menu, choose Macro.

2. Type any macro name, and choose the Edit button.

3. Type the following macro in the macro editing window:

      Sub Main
        Dim dlg as FormatPageNumber
        GetCurValues dlg
        dlg.NumRestart=-1
        Dialog dlg
      End Sub

4. From the File menu, choose Close, and save changes to the macro.

5. From the Tools menu, choose Macro, and select the macro you just
   created.

6. Choose the Run button.

No option button is selected in the Page Numbering section of the
dialog box. The available values for the .NumRestart field should only
be 0 and 1.



Note: Any other negative number generates the error message "WordBASIC
Err=5, Illegal function call."

For more information, query on the following words in the Microsoft
Knowledge Base:

   field and dialog and argument

REFERENCES
==========

"Microsoft Word For Windows and OS/2 Technical Reference," pages 89-91

Additional reference words: w4wmacro clear deselect 2.0 2.00



WinWord: Envelope Macro Views SHIFT+ENTER Formatting Wrong
Article ID: Q79309
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows version 2.0, the print envelope macro
views text formatted with the SHIFT+ENTER key combination in a pop-up
box as a single string of text rather than separate lines.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Steps to Reproduce Problem
--------------------------

1.  From the File menu, choose New, and choose the OK button.

2.  Insert a FILLIN field by pressing CTRL+F9. Inside the field
    braces, type the following:

       {fillin "What is the Address?"}

3.  Position the insertion point outside the field code, and insert two
    paragraph returns (press ENTER twice).

4.  Type in a name and address. Press the ENTER key at the end of each
    line.

5.  Insert two more paragraph returns at the end of the address.

6.  Type in the same name and address again, except use the
    SHIFT+ENTER key combination to make soft carriage returns at
    the end of each line.

7.  Select the FILLIN field at the top of the document, and press the
    F9 key. Type a 3-line address, pressing SHIFT+ENTER at the end of each
    line, and choose the OK button when finished.



8.  Select the View menu, and clear the Field Codes option if it is
    selected.

9.  Select the first address, and choose the Create Envelope icon.
    Note: The text ignores the carriage returns from the FILLIN fields,
    and the address scrolls out of the box as one line of text.

10. Choose the Cancel button for this dialog box, and select the next
    address. Select the Create Envelope icon. Note that this address
    reacts correctly and recognizes the returns.

11. Repeat step 10 with the third address, which uses the soft
    carriage returns. This address reacts the same way as the hard
    paragraph returns.

The results are the same even if you unlink the fields by pressing
CTRL+SHIFT+F9. Word for Windows prints the envelope as it appears on
the screen.

WORKAROUND
==========

To add information with a message box or FILLIN field, use the
following steps:

1.  Turn on the Show All button on the ruler.

2.  Replace the SHIFT+ENTER soft carriage returns with hard returns
    generated by pressing the ENTER key.

3.  Select the address, and proceed with creating the envelope.

Additional reference words: 2.00 pop-up w4wmacro w4wenvelope



EditClear Statement Deletes Footnote Reference or Field Code
Article ID: Q79334
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

If you position the insertion point to the left of a field code or
footnote reference in Microsoft Word for Windows and you press the DEL
key or run the EditClear macro, the field code or footnote reference
is not deleted; instead, the system beeps. However, if you position
the insertion point at the same location and run the EditClear
statement from within a macro, the field code or footnote reference is
selected and deleted.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this problem,
and will post more information here in the Microsoft Knowledge Base as it
becomes available.

MORE INFORMATION
================

Pressing the DEL key is the keyboard equivalent to the EditClear
command and macro statement; therefore, they should behave in a
similar manner, regardless of how they are executed.

You can use the following macro to delete a footnote reference
number:

   Sub Main
   EditClear
   End Sub

The EditClear command selects the word to the immediate right of the
insertion point and performs a delete.

Steps to Reproduce Problem
--------------------------

1. Create or open a document that contains an automatically-numbered
   footnote.

2. Position the insertion point to the left of the footnote reference
   number. Press the DEL key. The system beeps, and the footnote
   reference number is not deleted.



To record and run a macro to execute the EditClear command, use the
steps listed below.

Word for Windows Version 2.0
----------------------------

1. From the Tools menu, choose Record Macro. Type a name in the Macro
   Name box, and choose the OK button. Note: "REC" should appear on the
   right end of the status bar.

2. Press the DEL key.

3. From the Tools menu, choose Stop Recorder.

4. Position the insertion point to the left of the footnote reference
   number.

5. From the Tools menu, choose Macro. Select the macro recorded in
   steps 1-3 above, and choose the Run button.

Word for Windows Version 1.x
----------------------------

1. From the Macro menu, choose Record. Type a name in the Macro Name
   box, and choose the OK button. Note: "REC" should appear on the right
   end of the status bar.

2. Press the DEL key.

3. From the Macro menu, choose Stop Recorder.

4. Position the insertion point to the left of the footnote reference
   number.

5. From the Macro menu, choose Run. Select the macro recorded in steps
   1-3 above, and choose the OK button.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.x, pages
127-128, 185-187, 284-285

"Microsoft Word for Windows User's Guide," version 2.0, pages 264-265,
591-592, 765-767

Additional reference words: W4WMacro wm_word 6.00
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



GetBookmark$() Used with EditGoto Returns Incorrect Value
Article ID: Q79559
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, using the WordBasic commands
GetBookmark$() and EditGoto with the \Cell bookmark returns the cell
value of the previous column. It should return the cell value of the
current column.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Workaround
----------

The following WordBasic macro yields the contents of the current
column instead of the contents of the previous column:

   Sub MAIN
   If PrevCell() Then NextCell
   Print GetBookmark$("\Cell")
   End Sub

Steps to Reproduce Problem
--------------------------

The following macro illustrates this problem:

1. From the Table menu, choose Insert Table (in version 2.0). From the
   Insert menu, choose Table (in version 1.x). Insert a 2-column, 1-row
   table, and type some text in each cell. Select the second cell.

2. From the Tools menu, choose Macro, and type a name for a new macro.
   Choose the Edit button.

3. Type the following macro in the macro editing window:

      Sub MAIN
      EditGoto .Destination = "\Cell"
      Print GetBookmark$("\Cell")
      End Sub

4. From the File menu, choose Close. Choose Yes when prompted to save
   changes to the macro.

5. From the Tools menu, choose Macro. Select the macro you just



   created, and choose the Run button.

6. Notice the value displayed in the status bar is from column 1, not
   column 2.

Microsoft has confirmed this to be a problem in Word for Windows. This 
problem was corrected in Word version 6.0 for Windows.

Reference(s):

"Microsoft Word for Windows and OS/2 Technical Reference," pages 156-
157, 192, 226, 238, 241

"Microsoft Word for Windows Technical Reference," pages 42, 62, 78,
83-84

Additional reference words: w4wmacro 1.x 1.00 1.10 1.10a 2.00 2.0a
w4wtable 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD



Using Shell Statement to Access MS-DOS Prompt from WinWord
Article ID: Q79696
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

From within Microsoft Word for Windows, you can use the Shell
WordBasic statement to access the MS-DOS prompt. You can assign this
macro to a key, a menu or (in version 2.0) a tool bar button.

MORE INFORMATION
================

The following steps create a macro to access the MS-DOS prompt from
within Word for Windows:

Word for Windows Version 6.0
----------------------------

1. From the Tools menu, choose Macro

2. In the Macro Name box, type "dosprompt" (without the quotation
   marks), and choose the Create button.

3. In the macro editing window, type the following macro text:

      Sub MAIN
      Shell "command.com", 1
      End Sub

4. From the File menu, choose Close. Choose the Yes button when
   prompted to save changes to the macro.

5. From the Tools menu, choose Customize, and select the Keyboard,
   Menu, or Toolbar Category to assign this macro to a key
   combination, menu or tool bar button.

Word for Windows Version 2.0
----------------------------

1. From the Tools menu, choose Macro.

2. In the Macro Name box, type "dosprompt" (without the quotation
   marks), and choose the Edit button.

3. In the macro editing window, type the following macro text:

      Sub MAIN



      Shell "command.com", 1
      End Sub

   Note: In the Shell line, the following arguments can be used:

      0 for minimized window
      1 for normal window
      3 for maximized window
      4 for deactivated window

4. From the File menu, choose Close. Choose the Yes button when
   prompted to save changes to the macro.

5. From the Tools menu, choose Options, and select the Keyboard, Menu,
   or Toolbar Category to assign this macro to a key combination, menu
   or tool bar button.

For more information on the Shell statement, search for "WordBasic
Programming Language" and "Shell" using the Help menu.

Word for Windows Version 1.x
----------------------------

1. From the Macro menu, choose Edit.

2. In the Edit Macro Name box, type "dosprompt" (without the quotation
   marks), and press the OK button.

3. In the macro editing window, type the following macro text:

      Sub MAIN
      Shell "command.com", 1
      End Sub

   Note: In the Shell line, the following arguments can be used:

      0 for minimized window
      1 for normal window
      3 for maximized window
      4 for deactivated window

4. From the File menu, choose Close. Choose the Yes button when
   prompted to save changes to the macro.

5. From the Macro menu, you can choose the Assign to Key, or Assign to
   Menu commands to assign this macro to a key sequence or menu.

REFERENCES
==========

"Microsoft Word for Windows and OS/2 Technical Reference," page 257

Additional reference words: w4wmacro 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD wm_word 2.00b 2.00c 6.00



WinWord: Envelopes Don't Print with Reverse Print Order Option
Article ID: Q79905
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows version 2.0, if you choose the Create
Envelope command when the Reverse Print Order option is selected,
envelopes do not print. Word acts as if it is printing; however, the
printer is inactive. To run the Create Envelope command, choose the
Envelope button on the tool bar or choose the command from the Tools
menu.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

WORKAROUND
==========

To work around this problem, use one of the following methods:

 - From the Tools menu, choose Options, select the Print category, and
   clear the Reverse Print Order check box. Choose the OK button.

 - From the Tools menu, choose Create Envelope, select the Add to
   Document button, then print it using the File Print command.

HP DeskJet
----------

The HP DeskJet printer outputs printed pages in reverse order. The
Reverse Print Order option causes pages to be printed in the correct
order. However, if you select this option, envelopes do not print
using the Create Envelope command.

If your printer is an HP DeskJet, you can modify the
ToolsCreateEnvelope macro to clear the Reverse Printer Order option
when creating an envelope and then select the option again after the



envelope prints. To modify the ToolsCreate Envelope macro, add the
lines "ToolsOptionsPrint .Reverse=0" and "ToolsOptionsPrint
.Reverse=1" to the macro, as follows:

Sub Main
ToolsOptionsPrint .Reverse = 0
Dim dlg As ToolsCreateEnvelope
GetCurValues dlg
x = Dialog(dlg)
If x = - 1 Then ToolsCreateEnvelope dlg
ToolsOptionsPrint .Reverse = 1
End Sub

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 117-122

Additional reference words: 2.00 w4wprint w4wmacro hewlett packard 500
plus jam feed backward toolbar dj w4wenvelope



WinWord: Cannot Assign a Shortcut Key with the Numeric Keypad
Article ID: Q79984
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, you cannot assign a shortcut key to a
macro using a number from the numeric keypad.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New, and choose the OK button.

2. From the Tools menu, choose Record Macro.

3. Type a name for the macro.

4. In the Shortcut Key box, select the Ctrl check box, and verify the
   Shift check box is NOT selected. Position the insertion point in the
   Key box, and type the number 1 on the numeric keypad.

5. Type a few lines of text in your document.

6. From the Tools menu, choose Stop Recorder.

7. Activate the macro by pressing CTRL+Keypad 1.

The system just beeps. If you activate the macro by pressing CTRL+1
using the number 1 on the top of the keyboard, rather than the numeric
keypad, the macro runs correctly.

This feature works correctly in Word for Windows version 1.x. If you
convert a template from version 1.x that contains a macro shortcut key
assigned to the numeric keypad, the macro works correctly in version



2.0 using the numeric keypad assignment.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b w4wmacro
w4wtemplate



Word for Windows Macro to Print List of Found Files
Article ID: Q80029
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

The following macro prints a list of all the files found by using the
FileFind function in Microsoft Word for Windows version 2.0 and later.

MORE INFORMATION
================

The macro displays the FileFind dialog where you can specify search
parameters. Once you have searched for a list of documents, choose
the Close button to exit the dialog. The macro then opens a new 
document and creates a list of all the files found by the FileFind 
function. You can save the resulting document or print it. You can 
also create different file listings by changing the search parameters.

The following macro uses the WordBasic macro FoundFileName$() and 
CountFoundFiles() functions to return the number of files found and
the corresponding filenames.

 Sub MAIN
 ToolsMacro "FileFind", .Run
 FileNew
 Num = CountFoundFiles()
 Insert "Total Files Found="
 Insert Str$(Num)
 InsertPara
 For I = 1 To Num
 E$ = FoundFileName$(I)
 InsertPara
 Insert E$
 Next
 End Sub
 
For more information on macro commands, search for "WordBasic
Programming Language" using the Help menu.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 491-504

Additional reference words: w4wmacro file find 2.00 2.00a 2.00a-CD
2.00b 2.00c 



WinWord: FilePrintSetup Appears Twice in Recorded Macro
Article ID: Q80043
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, if you record a macro that executes the
File Print Setup (File Printer Setup in Word for Windows version 1.x)
command, two "FilePrintSetup" lines appear in the macro instead of
one. This syntax is correct.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

When you record a macro that performs the File Print Setup command,
you expect the recorded macro to only have one line, as follows:

   FilePrintSetup .Printer = "PostScript Printer on LPT1:", .Setup

The actual recorded macro appears as follows:

   FilePrintSetup .Printer = "PostScript Printer on LPT1:", .Setup
   FilePrintSetup .Printer = "PostScript Printer on LPT1:"

A Word for Windows macro cannot record steps that are executed outside
of the Word environment; therefore, information from the Print Setup
(Printer Setup in version 1.x) dialog box is not recorded by the Macro
Recorder. As a result, Word for Windows must record two lines; the
first line brings up the printer-specific Print Setup dialog box, and
the second line records the printer you selected.

Steps to Reproduce Problem
--------------------------

Word for Windows Version 2.0



----------------------------

1. From the Tools menu, choose Record Macro. Choose the OK button to
   accept the default name in the Record Macro Name box.

2. From the File menu, choose Print Setup. Choose the Setup button.

3. Choose the OK button twice.

4. From the Tools menu, choose Stop Recorder.

5. To look at the macro text, from the Tools menu, choose Macro.
   Select the macro name, then choose the Edit button.

Word for Windows Version 1.x
----------------------------

1. From the Macro menu, choose Record. Choose the OK button to accept
   the default name in the Record Macro Name box.

2. From the File menu, choose Printer Setup. Choose the Setup button.

3. Choose the OK button twice.

4. From the Macro menu, choose Stop Recorder.

5. To look at the macro text, from the Macro menu, choose Edit. Select
   the macro name, then choose the OK button.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.x, pages 120,
185-189

"Microsoft Word for Windows User's Guide," version 2.0, pages 121,
763-792

Additional reference words: w4wmacro 1.00 1.10 1.10a 1.0 1.1 1.1a 2.00



Evaluating Which Button Was Pressed in a User-Defined Dialog
Article ID: Q80070
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

The following Microsoft WordBasic macro provides an example of how to
evaluate which button was pressed in a user-defined dialog box. The
macro uses a Select Case structure to evaluate the value returned by
the dialog function; N = Dialog(DialogRecord).

MORE INFORMATION
================

Specific values are assigned to the buttons in a dialog box. The
function N=Dialog(DialogRecord) stores the value assigned to the
button in the dialog box for later use. (DialogRecord) is the name
that the user gives to the dialog box. The values of "N" are as
follows:

Button Type        N=Dialog(DialogRecord)       Value Assigned
-----------        ----------------------       --------------

OK button              -1                       Always
Cancel button           0                       Always
Pushbutton-1            1                       According to order
Pushbutton-2            2                       According to order
Pushbutton-3            3                       According to order
Pushbutton-M            M                       According to order

The values for the pushbuttons are chronologically assigned, meaning
the first pushbutton is assigned one, the second two, and so on. The OK
button always has the value minus one (-1) and the Cancel button
always has the value zero (0).

The following macro demonstrates how the evaluation works. Inside the
case statements various types of tasks can be performed. This example
uses message boxes for simplicity.

Sub MAIN                                'Macro Starts Here
Begin Dialog UserDialog 320, 98, "Example Macro"
        PushButton 10, 6, 88, 21, "Button-1"
        PushButton 10, 30, 88, 21, "Button-2"
        PushButton 10, 54, 88, 21, "Button-3"
        OKButton 165, 18, 88, 21
        CancelButton 166, 46, 88, 21
End Dialog



Dim MyDlg As Dialog UserDialog   'Mydlg came be change to anything
N = Dialog(MyDlg)
Select Case N
        Case - 1
                MsgBox("Ok was Pressed!", "OK-Bottom", 64)
        Case 0
                MsgBox("Cancel was Pressed!", "Cancel-Bottom", 16)
        Case 1
                MsgBox("Button-1 was Pressed!", "PushBottom-1", 64)
        Case 2
                MsgBox("Button-2 was Pressed!", "PushBottom-2", 64)
        Case 3
                MsgBox("Button-3 was Pressed!", "PushBottom-3", 64)
        Case Else
                Goto Bye
        End Select
Bye:
End Sub                                 'End of Macro

For more information, search for "WordBasic Programming Language" and
"Dialog" using the Help menu.

Additional reference words: w4wmacro pushbutton dialog
push button 2.00 2.00a 2.00a-CD 2.00b 2.00c



WinWord: Avoiding Password Prompt Using FileNew Command
Article ID: Q80090
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In a Microsoft Word for Windows macro, if you use the FileNew command to 
create a new document or template based on a password-protected 
template, you receive a prompt for the template's password. The only way 
to avoid receiving this prompt is to have the specified template already 
open.

MORE INFORMATION
================

In Word for Windows macros, the FileOpen command may use a PASSWORDDOC 
and/or a PASSWORDDOT field to provide the password for the given 
document and/or the template that it is based on. The FileNew
command does not have either of these fields; therefore, when you
create a new document or template based on a specific template, you
cannot specify a password inside the macro to avoid the password
prompt.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c  wm_word 
w4wmacro wordbasic statement protection
w4wtemplate



WinWord: Searching for Multiple Extensions with File Find
Article ID: Q80250
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you can use the File Find command to
search for files that have different extensions but are in the same
directory. However, the search path is limited to 255 characters. If
the search path reaches or exceeds the 255 character limit the the
path line will be unavailable.  You must use Edit Path and delete some
search entries to make the path available.  One way to circumvent this
limitation is to use a WordBasic macro to set up multiple search
iterations.

MORE INFORMATION
================

Scenario
--------

You create an MS-DOS directory identified as "C:\DOCUMENTS," and move
all of your text-based files to this directory. In C:\DOCUMENTS, you
have files with eight different extensions; however, you want only
five of these extensions to be maintained in the search list. The five
extension you want included in the search list are BBA, DOC, LOG, RPT,
AND TXT.

To set up File Find to search for the different extensions within the
same directory, use the following steps:
 
1. Start Word for Windows version 2.0. From the File menu, choose Find
   File, and the choose the Search button.

2. From the Options box, select Create New List. From the Drives box,
   select Path Only. Choose the Edit Path button.

3. From the Directories list, select C:\DOCUMENTS. Choose the Add
   button. This places C:\DOCUMENTS in the Search Path list. Choose the
   Close button.

4. The Path list should now contain C:\DOCUMENTS. Edit this entry so
   that it also contains the first extension type. The entry should now
   read C:\DOCUMENTS\*.BBA. Choose the Edit Path button.

5. From the Directories list, select C:\DOCUMENTS. Choose the Add
   button. This places C:\DOCUMENTS in the Search Path list.
   C:\DOCUMENTS\*.BBA should already be present. Choose the Close button.



6. The Path list should now contain C:\DOCUMENTS\*.BBA; C:\DOCUMENTS.
   Edit this entry so that it also contains the second extension type.
   The entry should now read C:\DOCUMENTS\*.BBA;C:\DOCUMENTS\*.DOC.

7. Repeat steps 3-6 until all of the extensions that you want in the
   search path are present.

8. In the Search dialog box, choose the Start Search button. The
   results containing the files with multiple extensions display in the
   File Find dialog box.

Note: Each specific extension must be added to the Path list before
the same directory can be selected additional times.

For more information on using FileFind:

 - Search for "FileFind" using the Help menu.

  -or-

 - Query on the following words in the Microsoft Knowledge Base:

       winword and macro and filefind

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 494, 498

Additional reference words: greyed dimmed grayed gray grey w4wmacro
2.00 2.00a 2.00a-CD 2.00b 2.00c  wm_word 6.00



WinWord: Macro to Make Define the Default for Format Style
Article ID: Q80455
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you can create a macro to automatically
select the Define button when you choose Style from the Format menu.

MORE INFORMATION
================

Normally when you choose the Style command, you must choose the Define
button to change the definition of a particular style. If you want to
automatically access the Define options, use the following macro:

   Sub MAIN
   On Error Resume Next
   SendKeys "%d"
   ToolsMacro "FormatStyle", .Run
   End Sub

Note: The On Error statement prevents an error message that results if
you choose the Cancel button in the Style dialog box.

This macro can replace the existing Style command, or you can assign
it a new name (for example, DefineStyle), and assign it to the Format
menu as a separate command.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 719-720,
736-737, 784-786, 765

"Using WordBasic," by WexTech Systems and Microsoft, pages 223-224,
261, 279-282

Additional reference words: 2.00 w4wmacro formatdefinestyles wm_word 6.00



WordBasic Error 504: Window Does Not Exist...Read-Only File
Article ID: Q80465
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, if you open a document with the Read
Only option selected and attempt to access that document's window
using the Activate WordBasic command, Word for Windows generates the
following error message:

   WordBasic Error 504: Window does not exist.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this problem,
and will post more information here in the Microsoft Knowledge Base as it
becomes available.

MORE INFORMATION
================

The following macro results in the above WordBasic error message in
Word for Windows version 2.x if you open README.DOC as a read-only
file. The error message does not occur if you open the file as a
read-write file.

   Sub Main
   Document$="readme.doc"
   Activate Document$,1
   End Sub

This error message does not occur in Word for Windows versions 1.0,
1.1, or 1.1a when you open a file as read-only.

For more information on the Activate command, search for "WordBasic
Programming Language" and "activate" using the Help menu in Word for
Windows version 2.0.

REFERENCES
==========

"Using WordBasic," by WexTech Systems and Microsoft, page 150

Additional reference words: w4wmacro  errmsg err msg 1.x 1.10
1.00 1.10a 2.00 2.0a 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD wm_word 6.00





WinWord 2.0: Problems with DropCap Macro in NEWMACRO.DOC
Article ID: Q80497
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

This article describes two problems with the DropCap macro, supplied
with Microsoft Word for Windows:

 - The macro fails when it is run on a letter whose font size is
   greater than 14 points.

 - If you add a box border to the frame created when you run the
   DropCap macro, the bottom line of the border will neither
   display nor print.

These problems were corrected in Word version 6.0 for Windows.

More Information:

The DropCap macro is one of several macros included in NEWMACRO.DOC,
which is supplied with Word for Windows version 2.0. A dropped capital
letter is an enlarged first letter of a paragraph, positioned in the
upper-left corner of the paragraph, with the paragraph text flowing
around it to the right and below.

See page 767 of the "Microsoft Word for Windows User's Guide" for
instructions on installing the DropCap macro and other macros from
NEWMACRO.DOC.

To create a dropped capital letter, select the appropriate
character(s) and run the DropCap macro. The selected text will be
formatted for a larger font size, then a frame will be added.

Problem 1
---------

The DropCap macro fails on text larger than 14 points. If the selected
text is larger than 14 points, you will receive the following error
message:

   The measurement must be between 0.01" and 22".

Problem #2
----------

If you add a box border to the frame created when you run the DropCap
macro, the bottom line of the border will neither display nor print.



Workaround for Problems 1 and 2
-------------------------------

Type the large capital letter in a separate paragraph. Place a frame
around the letter, then add a border. Move the framed, bordered letter
into place at the beginning of the paragraph.

For information on borders, frames, and positioning, see pages
361-364, 393-395, and 401 (respectively) in the "Microsoft Word for
Windows User's Guide."

In Word for Windows 6.0, the Drop Cap feature is included under the
   Format menu.  The above documented problems do not occur.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 361-364,
393-395, 401, 416-417, 767

Additional reference words: w4wformat
2.00 drop cap newmacros.doc first line big
w4wmacro w4wfont



WinWord: Simulating XOR Logic with Field Codes or WordBasic
Article ID: Q80510
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you can simulate the XOR logic by using
either field codes or the WordBasic macro language.

MORE INFORMATION
================

To reproduce the XOR operation in Word for Windows using a WordBasic
function, use the following formula:

   XOR=(Abs(test1 + test2 +... + testn) Mod 2) * - 1

For example:

   Sub MAIN
      a =(2 = 2)
      b =(2 = 3)
      c =(2 = 3)
      If XOR(a, b, c) Then

Print "XOR is True"
      Else

Print "XOR is False"
      End If
   End Sub

   Function XOR(a, b, c)
      XOR =  (Abs(a + b + c) Mod  2) * - 1
   End Function

The following is an explanation of how the function works:

1. The formula applies the ABS function to the sum the variables that
   return TRUE. Note: In Word for Windows, TRUE has the numerical value
   of negative one (-1), FALSE equals zero (0).

2. The MOD statement divides this sum by two (2) and returns the
   remainder, which is one (1) if an odd number of the tests are TRUE,
   and zero (0) if an even number of the tests are TRUE.

3. The remainder is multiplied by negative one. FALSE remains zero,
   but TRUE becomes negative one (-1) to conform to WordBasic notation.

You can create this type of logical structure in Word for Windows by



using field codes. In the following example, T=TRUE and F=FALSE. Note:
To insert the braces, press CTRL+F9.

   {IF {IF x ="T" "T" "F"} = {IF y ="T" "T" "F"} "F" "T"}

In the above example, the field on either side of the equal sign (=)
checks to see if the comparison is TRUE. If it is, the results are
TRUE; if not, the result is FALSE. The comparison of the two IF
statements yields TRUE if they are the same and FALSE if they are not.
The following table illustrates the values and the results:

   Statement 1       Statement 2      Results
   -----------       -----------      -------

       T                  T              F
       T                  F              T
       F                  T              T
       F                  F              F

You can also create this kind of logical structure in a Word for
Windows macro. In the following example, T=TRUE and F=FALSE. In
WordBasic, the IF statement is combined with the THEN and ELSE
statements. An example would be as follows:

   IF X$="T" THEN Test1$="T" ELSE Test1$="F"
   IF Y$="T" THEN Test2$="T" ELSE Test2$="F"
   IF Test1$=Test2$ THEN Results$="F" ELSE Results$="T"
   END IF

For more information on the If...Endif statement, search for
"WordBasic Programming Language" and "If...ElseIf...Else...End If"
using the Help menu.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 747-762,
774-776

"Microsoft Excel Function Reference," version 3.0, page 155

"GW-Basic Interpreter User's Guide," page 60

Additional reference words: 6.00 w4wfield w4wmacro 1.00 1.10 1.10a
2.00 wm_word 2.00a 2.00a-CD 2.00b 2.00c



Automating Form Templates Without Using ASK or FILLIN Fields
Article ID: Q80551
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, the normal procedure for automating
form templates is to use a series of ASK or FILLIN fields in
conjunction with an AutoNew macro. (For more information on this
procedure refer to the "Microsoft Word for Windows User's Guide,"
version 2.0, pages 480-484, or the "Microsoft Word for Windows User's
Reference," page 188.) With this procedure, responses are restricted
to a total character value of 255 per dialog box. If your automated
form requires greater response flexibility and/or the response dialog
boxes are not desired, the method below may prove effective.

Note: Word for Windows version 6.0 uses Form fields to get around the 
character restriction in Ask and Fillin fields.

To use blank fields to automate form templates, use the following
steps:

1. From the File menu, choose New, and choose the OK button.

2. Type the following information, pressing ENTER several times after
   each entry:

      Name:

      Address:

      Phone Number:
  
3. Press CTRL+F9 to create a set of field code braces for each entry.
   Your form should appear as follows:

      Name:  {}

      Address:  {}

      Phone Number:  {}
 
   Note: These braces are hidden unless you choose Field Codes from the
   View menu. As long as the braces do not contain any spaces or
   characters, they do not generate any error messages.
 
4. With the field code braces positioned after each question, you can
   use the F11 key to move quickly to each question. The SHIFT+F11 key



   combination moves your insertion point to the previous question.
 
5. From the File menu, choose Save As. Assign the new form template a
   name. In Word for Windows version 2.0, select Document Template
   (*.DOT) from the Save File as Type list, and choose the OK button. In
   Word for Windows version 1.x, choose the Options button, choose
   Document Template from the File Format list, and choose the OK 
   button.

MORE INFORMATION
================

You can further automate the above process by adding an AutoNew 
macro that alerts the user (with a message box) that the F11 and the
SHIFT+F11 keys are available for navigation within the form.
Additionally, you can use the insertion of bookmark names
corresponding to the empty field code braces to customize navigation
to individual questions. For example, in the above procedure, choose
Field Codes from the View menu to display the hidden braces. Select
the braces beside the Address field. From the Insert menu select
Bookmark. In the Bookmark Name field, type "Address" (without the
quotation marks) and choose the OK button. You can use the GoTo key
(F5) to position the insertion point at any specified question.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 480-84,
730, 742, 753-54

"Microsoft Word for Windows User's Reference," version 1.x, pages
19-20, 84-89, 188, 215

Additional reference words: w4wmacro w4wfield w4wtemplate
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 2.00c-cd



Macro to Create a Subdirectory in Word for Windows
Article ID: Q80657
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

You can use the following macro in any version of Microsoft Word for
Windows to create a subdirectory on any drive:

 Sub MAIN
 On Error Goto Bye
 Input "Sub directory name " , a$
 MkDir a$
 Bye:
 End Sub

When you run the above macro, the message "Subdirectory name?" appears
on the status bar. Type a name for the subdirectory, and press ENTER.
The subdirectory is created on the current directory that Word for
Windows is pointing to. For example, if you choose Open from the File
menu and see that Word for Windows is pointing to the C:\WINWORD
directory, creating a directory with this macro creates a subdirectory
under WINWORD.

This macro makes it convenient to create new directories for Word for
Windows documents without having to leave the program.

Additional reference words: w4wmacro wm_word 6.00 1.00 1.10 1.10a 2.00
2.00a 2.00a-CD 2.00b 2.00c



Macro Editing Commands Available When Template Is Read-Only
Article ID: Q80785
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

If you open a read-only template in Microsoft Word for Windows, the
Edit, Rename, Delete, and Set (Set is in Word for Windows version 1.x
only) macro options do not appear unavailable (dimmed). If you make
changes to any template macros, Word doesn't display an error message
to warn that changes cannot be made to the template until you try to
save the template.

MORE INFORMATION
================

When using a read-only template, such as one on a network, the options
to Rename, Delete, Edit or Set are available. In Word for Windows
version 2.0, the Rename, Delete, and Edit buttons are available in the
Tools Macro dialog box when the Show Template Macros option is
selected. In Word for Windows version 1.x, the Delete, Rename, and Set
buttons are available in the Macro Edit dialog box when the Global
Context is selected. However, if you use any of the above buttons to
make changes to macros in a read-only template and choose the File
Save command, you receive the error following message:

   File is read-only. (version 1.x)

   This file is read-only. (version 2.0)

The Save As dialog box displays, and you can save the changes to a new
filename.

Additional reference words: 2.00 1.00 1.10 1.10a 1.0 1.1 1.1a  wm_word 
w4wtemplate w4wnetwork w4wmacro greyed ghost unavailable 6.00



WinWord: Macro to List File Format as 1.x, 2.0, or Other
Article ID: Q80816
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

This article contains a Microsoft Word for Windows macro that searches a
specified group of files on a directory and lists each the format of each
file as one of the following:

 - 1.x (for files in Word for Windows version 1.0 or 1.1 format)

 - 2.x (for files in Word for Windows version 2.x format)

 - 6.0 (for files in Word for Windows version 6.0 format)

 - Other (for files in a format other than 1.x or 2.x)

MORE INFORMATION
================

This macro is useful for determining whether a file is in Word for
Windows version 1.x . 2.x or 6.0 file format. It searches the specified
directory and lists each file, followed by the indicator of its
format. In the macro below, all the files with a .DOC file extension
in the C:\WINWORD directory are listed and identified by file format.
For example, you could search a directory containing the following
four files:

   MYFILE1.DOC
   MYFILE2.DOC
   MYFILE3.DOC
   MYFILE4.DOC

After you run the macro, the files are listed in the active document
as follows:

   MYFILE1.DOC     1.x
   MYFILE2.DOC     2.0
   MYFILE3.DOC     6.0
   MYFILE4.DOC     Other

In the above example, MYFILE1.DOC is Word for Windows version 1.x file
format, MYFILE2.DOC is Word for Windows version 2.0 file format, and
MYFILE3.DOC is a Word for Windows 6.0 and MYFILE4.Doc is a format
other than Word for Windows version 1.x, 2.0. or 6.0



Macro
-----

Sub MAIN
ChDir "c:\winword6"
DocName$ = Files$("*.doc")
     While DocName$ <> ""
     Open DocName$ For Input As #1
     Test$ = Input$(1, 1)
     Insert DocName$ + Chr$(9)
     If Test$ = Chr$(219) Then
          Insert "2.0"
          InsertPara
     ElseIf Test$ = Chr$(155) Then
          Insert "1.x"
          InsertPara
     ElseIf Test$ = Chr$(220) Then
          Insert "6.0"
          InsertPara
     Else
          Insert "Other"
          InsertPara
     End If
     Close #1
     DocName$ = Files$()
Wend
End Sub

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 765-785

Additional reference words: w4wmacro 1.00 1.10 1.10a 1.0 1.1 1.1a 2.00
2.00a 2.00a-CD 2.00b 2.00c wordbasic determine



Word for Windows: Setting Column Width to Auto in Tables
Article ID: Q80833
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

In Word versions 2.0, 2.0a, 2.0a-CD, 2.0b, and 2.0c, if you select a
column(s) or cell(s) and type "auto" (without the quotation marks) in the
Width Of Columns box, you will receive the following error message:

   This is not a valid measurement.

Note: In versions 1.x of Word, setting the width of a column or cell to
Auto was permitted so that you could adjust the width of column(s) or
cell(s) within the margins.

STATUS
======

This problem was corrected in Word version 6.0 for Windows.

MORE INFORMATION
================

The Auto setting evenly divides the width of the table among the columns.
In Word for Windows version 2.0, you can use any of the following three
methods to set column or cell width to Auto.

Method 1
--------

1. Set the rightmost edge of the table at the desired position.

2. Hold down the CTRL key while dragging the column marker of the column
   that is to the left of the columns you want to adjust.

Note: The above method does not adjust columns based on margins; it resizes
the columns without changing the user-defined size of the table. The space
between the column you are sizing and the end of the table is divided
equally among the columns to the right of the column marker. Use the
procedure below to adjust the columns based on the margins of the document.

Method 2
--------

Use the steps below to create a macro that adjusts the selected column(s)
or cell(s) to Auto based on the margin settings within the document section
where the table is located.



1. From the Tools menu, choose Macro, type a macro name, and choose the
   Edit button.

2. Insert the following line between the Sub Main and End Sub:

      TableColumnWidth .ColumnWidth = "0"

To run this macro on the selected column(s) or cell(s) of the table, choose
Macro from the Tools menu.

Note: This macro can be assigned to a menu or to a toolbar button.

Method 3
--------

Note: This method works if the text in the table is not enclosed in
quotation marks with commas used as punctuation within the quotation marks.
If this is not the case, Word for Windows will break the text enclosed in
quotation marks into two columns when you convert it to a table.

1. Select the entire table.

2. From the Table menu, choose Convert Table To Text. In the Convert Table
   To Text dialog box, select the Commas option and choose the OK button.

3. Select the comma-delimited text. From the Table menu, choose Convert
   Text To Table. The table contains evenly-sized cells and extends from
   the left to the right margin.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, page 333

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wmacro w4wtable



Word for Windows: How to Search in Help for Macro Commands
Article ID: Q80836
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

In Microsoft Word for Windows, you cannot search directly for a macro
command from within Help. To demonstrate this behavior, access the Help
menu when you are working in the Macro Editor.

To access topics on macro commands, select a macro statement and press
F1 for information on the selected macro statement; or, choose
WordBasic Programming Language from the Help Index to display an
alphabetical listing of macro commands.

Additional reference words:  wm_word 6.00 w4whelp w4wmacro context
sensitive context sensitive 2.00 2.00a 2.00a-CD 2.00b 2.00c 



Word for Windows: Glossary Management Macros
Article ID: Q80838
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

This article contains four macros to automate the management and
movement of glossary entries in Microsoft Word for Windows version
2.0.

Note: This is a built-in feature in Word for Windows version 6.0.

MORE INFORMATION
================

Macro 1 copies all glossary entries (with formatting) from the global
template (NORMAL.DOT) to the document template. This macro assumes 
the following conditions:

 - The active document is blank (if Show All is active, one paragraph
   mark displays).

 - The active document is based on a template other than NORMAL.DOT.
   Check the Template dialog box for this information.

Note: This article refers to "document template" as the template
attached to the active document.

For more information about templates and glossaries:

 - Refer to pages 273 and 705-706 in the "Microsoft Word for Windows
   User's Guide."

  -or-

 - Search for "Chapter Listing" and "Customizing Word" using the Help
   menu.

Macro 1
-------

Sub MAIN
For N = 1 To CountGlossaries(0)
  EditGlossary .Name = GlossaryName$(N, 0), .Context = 0,\
     .Insert
  EditSelectAll
  CharLeft 1, 1
  EditGlossary .Name = GlossaryName$(N, 0), .Context = 1,\
      .Define
  EditClear
Next



End Sub

For more information about EditGlossary, GlossaryName$(), and
CountGlossary(), search for "WordBasic Programming Language" using 
the
Help menu.

Macro 2 contains a reversal of the .Context = X information in Macro
1. In all other respects, Macros 1 and 2 are the same. All assumptions
for Macro 1 also apply to Macro 2.

Macro 2
-------

Sub MAIN
For N = 1 To CountGlossaries(1)
   EditGlossary .Name = GlossaryName$(N, 1), .Context = 1,\
      .Insert
   EditSelectAll
   CharLeft 1, 1
   EditGlossary .Name = GlossaryName$(N, 1), .Context = 0,\
      .Define
   EditClear
Next
End Sub

Macro 3 copies all glossary entries from the global template to the
document template. This macro is much faster than the previous macros;
however, formatting IS lost.

Note: SetGlossary statement is limited to 255 characters.  A dialog
box will appear, informing of what glossary items not copied. Use
macros 1 or 2 for large glossaries.

Macro 3
-------

Sub MAIN
For N = 1 To CountGlossaries(0)
        A$ = GetGlossary$(GlossaryName$(N, 0), 0)
        If Len(A$) < 256 Then
             SetGlossary GlossaryName$(N, 0), A$, 1
        Else
             MsgBox "The glossary named " + GlossaryName$(N, 0) + \
             " is to large to copy"
        End If
Next
End Sub

To go from document template to global template, replace each of the
zeros with the number one (1), and replace the number one (1) on the
SetGlossary line with a zero (0).

Macro 4 deletes all glossary entries from a template. Use a zero (0)
for the global template and the number one (1) for a document
template. The following macro deletes all global glossaries:



Macro 4
-------

Sub MAIN
For N = 1 to CountGlossaries(0)
   EditGlossary .Name = GlossaryName$(N, 0), .Context = 0,\
      .Delete
Next
End Sub

Additional reference words: 2.00 2.00a 2.00a-cd 2.00b 2.00c 2.00c-cd 
w4wmacro copy move w4wtemplate



Using Windows Calls to Create Dialog Boxes in Word for Windows
Article ID: Q80931
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows macros, you can use Microsoft Windows
calls to create dialog boxes.

MORE INFORMATION
================

The following is a sample Word for Windows macro that uses Windows
calls to display a sample dialog box:

Declare Function GetFocus Lib "user"() As Integer
Declare Function MessageBox Lib "user"(hWndParent As Integer, lpText$, \
lpCaption$, wType As Integer) As Integer
Sub MAIN
hWndParent = GetFocus
lpText$ = "Example Text"
lpCaption$ = "Example Caption"
wType = 0
result = MessageBox(hWndParent, lpText$, lpCaption$, wType)
End Sub

For more information on creating dialog boxes using the WordBasic macro
language, query on the following in the Microsoft Knowledge Base:

   dialog and box and macro and editor

REFERENCES
==========

"Microsoft Word for Windows and OS/2 Technical Reference" pages 149,
437-438

"Using WordBasic," by WexTech Systems and Microsoft, pages 173,
363-366

Additional reference words: W4WMacro wm_word 6.00 1.0 1.1 1.1a 2.0 1.00
1.10 1.10a 2.00



How to Select the Current Page in a WinWord Document
Article ID: Q80959
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you can select the current page in a
document by choosing the Edit GoTo command and typing "\page" (without
quotation marks) in the GoTo dialog box.

MORE INFORMATION
================

"\Page" is a special bookmark in Word for Windows. When you use this
bookmark with the Edit GoTo command, the current page, from page break
to page break, is selected.

For more information on special bookmarks, query on the following
words in the Microsoft Knowledge Base:

   special and bookmarks and wordbasic and macro and language

REFERENCES
==========

"Using WordBasic," by WexTech Systems and Microsoft, pages 88-90

Additional reference words: 1.0 1.00 1.1 1.10 1.1a 1.10a 2.0 2.00 2.0a
2.00a W4WMacro wm_word 6.00 reserved



WordBASIC Err=514 Using the MacroCopy Statement
Article ID: Q80983
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows version 2.x, if you use the MacroCopy
WordBasic command to reference templates that have not been saved,
Word generates the following error message:

   WordBASIC Err=514
   Document not open

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

When you create a new template, Word for Windows assigns it a default
name (for example, Template1 or Template2). If you use an unsaved
template's default name as an argument for the MacroCopy statement,
you receive the above WordBasic error message.

To work around this problem, save templates with appropriate filenames
before using them with the MacroCopy command.

Additional reference words: 2.00 2.00a 2.00a-cd 2.00b 2.00c 2.00c-cd 
w4wmacro errmsg msg w4wtemplate



WinWord: ToolsMacro .Run Does Not Follow Context Hierarchy
Article ID: Q81027
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

In the Microsoft Word for Windows version 2.x WordBasic macro
language, the ToolsMacro .Run command is not designed to follow the
context hierarchy prescribed for the execution of Word for Windows
macros. This is because the command corresponds to the Macro dialog
box where the context is selected with an option button in the Show
box.

In Word for Windows version 6.0, the ToolsMacro .Run command has an
argument that is designed to follow the context hierarchy.

MORE INFORMATION
================

When you run a Word for Windows macro from the command line (ie. if
you start Word by typing "WIN WINWORD /mMyMacro" at the MS-DOS
prompt), Word looks for the macro first in the document template, then
in NORMAL.DOT, and finally in the built-in commands. This hierarchy
holds even if the macro has the same name as a built-in command (such
as FilePrint).

When you run a Word for Windows macro that has the same name as a
built in command by calling its name in another macro, Word runs the
built-in command.

If you run a macro using the ToolsMacro .Run WordBasic command and do
not specify the .Show argument, the macro runs in the context
specified the last time the you chose Macro from the Tools menu.

Word for Windows version 6.0
-----------------------------

If you run a macro using the ToolsMacro .Run command with the .Show
argument 0, the macro will run according to Word's macro searching
hierarchy. In the following example, Word looks for the macro first in
the document template, then in NORMAL.DOT, and finally in the built-in
commands.

   ToolsMacro .Name = "mymacro", .Show = 0, .Run

Word for Windows version 2.0
----------------------------



If you run a macro using the ToolsMacro .Run command without the .Show
argument AND have not previously chosen Macro from the Tools menu, the
.Show argument defaults according to the .Store argument in the
Template dialog box (accessed by choosing Template from the File
menu). The .Store argument corresponds to the options in the Store New
Macros And Glossaries As box. The .Store argument corresponds as
follows to the .Show argument:

   File Template                  Tools Macro
   -------------                  -----------
   Store New Macros and
   Glossaries as:                 Show:
      Global                         Global
      Template                       Template
      Prompt for Each New            Previous Setting

If you want Word for Windows to follow the Template, Global, Built-in
Command context hierarchy for macro execution in Word for Windows
version 2.0 (assuming the name is not the same as a built-in command),
run your macro by calling its name rather than using the ToolsMacro
statement.

REFERENCES
==========

"Using WordBasic," by WexTech Systems and Microsoft, pages 210, 308

"Microsoft Word for Windows User's Guide," version 2.0, pages 705-706

Additional reference words: 2.00 2.00a 2.00a-cd 2.00b 2.00c 2.00c-cd
wm_word 6.00 w4wmacro wrong w4wtemplate



WinWord: Bullet Replaces Leading Number in Paragraph
Article ID: Q81055
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, if you create a list or paragraphs 
containing bullets, Word replaces any leading numbers in the paragraphs 
or list items with the bullet character.

MORE INFORMATION
================

Word for Windows does not allow both a number and a bullet to appear
at the beginning of a paragraph or list item when you use the Bullets
and Numbering command.

Workaround
----------

To stop Word from removing leading numbers from paragraphs or lists
that you want to format with bullets, use one of the following
methods:

 - Place the number in a QUOTE field as follows:

   1. Press CTRL+F9 to insert field braces.

   2. Type "quote" (without the quotation marks), and press the 
      SPACEBAR.

   3. Type the desired number inside the quotation marks. The field code
      should display as follows:

         {quote "12.2"}

    4. Press the F9 key to update the display results.

  -or-

 - Insert bullets manually using the Edit Copy/Paste command or by
   choosing Symbol from the Insert menu.

  -or-

 - Use the following macro, which can replace the
   ToolsBulletListDefault macro assigned to the Bulleted List tool bar
   button. The macro automates the typing of unique characters in front



   of the numbers prior to adding the bullets.

   Sub MAIN
   If Len(Selection$()) = 1 Then
        EditGoTo .Destination = "\Para"
   EndIf
   ToolsBulletsNumbers .Type = 0, .Replace = 1, .Remove
   InsertBookmark .Name = "bulletselection"
   CharLeft 1
   n = CmpBookmarks("\Sel", "bulletselection")
   While n = 8 Or n = 6
        CharRight 1, 1
        If Asc(Selection$()) = 9 Then
                EditClear
        Else
                CharLeft 1
        EndIf
        Insert "X"
        CharLeft
        ToolsBulletListDefault
        EditClear
        EndOfLine
        n = CmpBookmarks("\Sel", "\EndOfDoc")
        If n <> 0 Then
                ParaDown
                StartOfLine
                n = CmpBookmarks("\Sel", "bulletselection")
        EndIf
   Wend
   EditGoTo .Destination = "bulletselection"
   InsertBookmark .Name = "bulletselection", .Delete
   End Sub

Steps to Reproduce Problem
--------------------------

1. Type the following lines in a Word for Windows version 2.0
   document:

      1. item one
      2. item two

2. Select the text typed in step 1. From the Tools menu, choose
   Bullets and Numbering.

3. Select Bullets, and choose the OK button.

The following message appears on the screen:

   Do you want to replace the existing numbers with bullets?

If you choose the No button, no bullets are inserted. If you choose
the Yes button, the numbers are replaced by bullets.

In Word for Windows 6.0, the user is prompted as to whether or not to
replace the leading numbers with the bullet character. Answering NO
to the prompt applies the bullets and leaves then numbers intact.



REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 153-154,
521-528

Additional reference words: w4wformat 6.00 wm_word 
2.00 toolbar button w4wmacro



Printing Multiple Pages with Single-Sheet Feed to a Dot Matrix
Article ID: Q81084
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

When you print a multiple-page document to a dot-matrix printer using a
single-sheet feed, Windows Print Manager stalls the print job after each
page. Print Manager receives a "Paper Out" message from the printer that
causes it to stall. You can use the macros below in Word for Windows to
pause the print job between each page so you can add paper.

MORE INFORMATION
================

The following macros prompt you for the number of pages you want to print.
Then they determine the number of pages in your document and display the
following message:

   Ready to print page X. Press OK when the paper is loaded?

Choose the OK button to print the listed page or choose the Cancel button
to terminate the print job.

WARNING: ANY USE BY YOU OF THE CODE PROVIDED IN THIS ARTICLE IS AT
YOUR OWN RISK. Microsoft provides this macro code "as is" without
warranty of any kind, either express or implied, including but not
limited to the implied warranties of merchantability and/or fitness
for a particular purpose.

Macro for Word for Windows Version 6.0
--------------------------------------

Sub Main
  StartOfDocument
  FileSummaryInfo .Update
  Dim dlg As DocumentStatistics
  GetCurValues dlg
  Pages = Val(dlg.Pages)
  ncopies = 0
  On Error Resume Next
  ncopies = Val(InputBox$("Print how many copies of each page?"))
  If Not Err Then
    Err = 0
    For x = 1 To Pages
      For i = 1 To nCopies
        If MsgBox("Ready to print copy" + Str$(i) + " of page" + Str$(x) \
          + ".  " + "Press OK when the paper is loaded?", 1) Then



          FilePrint .Range = 3, .From = Str$(x), .To = Str$(x)
        Else
          i = nCopies
          x = Pages
        End If
      Next
    Next
  End If
End Sub

Macro for Word for Windows Version 2.0
--------------------------------------

Sub Main
  StartOfDocument
  fView = ViewFieldCodes()
  If fView <> 0 Then ViewFieldCodes
  InsertField "numpages"
  CharLeft 1, 1
  UpdateFields
  Pages = Val(Selection$())
  EditClear
  ncopies = 0
  On Error Resume Next
  ncopies = Val(InputBox$("Print how many copies of each page?"))
  If Not Err then
    Err = 0
    For x = 1 To Pages
      For I = 1 to nCopies
        If MsgBox("Ready to print copy" + Str$(i) + " of page" + Str$(x) \
          + ".  " + "Press OK when the paper is loaded?", 1) Then
          FilePrint .Range = 3, .From = Str$(x), .To = Str$(x)
        Else
          i = nCopies
          x = Pages
        End If
      Next
    Next
  End If
  If fView <> 0 Then ViewFieldCodes
End Sub

Macro for Word for Windows Versions 1.x
---------------------------------------

Sub MAIN
  StartOfDocument
  Dim dlg As ViewPreferences
  GetCurValues dlg
  prefer = dlg.ShowAll
  If prefer <> 0 Then dlg.ShowAll = 0
  ViewPreferences .ShowAll = dlg.ShowAll
  fview = ViewFieldCodes()
  If fview <> 0 Then ViewFieldCodes
  InsertField "numpages"
  CharLeft 1, 1
  UpdateFields



  pages = Val(Selection$())
  EditClear
  ncopies = 0
  On Error Resume Next
  ncopies = Val(InputBox$("Print how many copies of each page?"))
  If Not Err Then
    Err = 0
    For x = 1 To pages
      For I = 1 to nCopies
        If MsgBox("Ready to print copy" + Str$(i) + " of page" + Str$(x) \
          + ".  " + "Press OK when the paper is loaded?", 1) Then
          FilePrint .Range = 2, .From = Str$(x), .To = Str$(x)
        Else
          I = nCopies
          x = Pages
        End If
      Next
    Next
  End If
  If fview <> 0 Then ViewFieldCodes
  If prefer <> 0 Then dlg.ShowAll = 1
  ViewPreferences .ShowAll = dlg.ShowAll
End Sub

Note: You can run this macro instead of the default FilePrint macro to
print multiple pages using single-sheet feed.

REFERENCES
==========

"Microsoft Word for Windows and OS/2 Technical Reference," pages 63,
66, 203, 280, 283
"Using WordBasic," by WexTech Systems and Microsoft, pages 45-49, 226,
234

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c
w4wmacro w4wprint dmp  offline ready epson



Excel Dialog Box Pastes as Tabs and Numbers in WinWord
Article ID: Q81151
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

Dialog boxes created with version 3.0 or 4.0 of the Microsoft Excel
Dialog Editor are not directly compatible with Microsoft Word for
Windows WordBasic.  When used with WordBasic, these Excel dialog boxes
appear as tabs and numbers.

MORE INFORMATION
================

Version 2.0 of Word for Windows comes with a Dialog Editor that works
correctly with WordBasic. To use dialog boxes created with the Excel
Dialog Editor in a WordBasic document, these dialog boxes must first
be converted to version 2.0 Word for Windows dialog boxes.

To determine which Dialog Editor you are using, choose About Dialog
Editor from the File menu. The following table lists the Dialog Editor
version numbers for Excel and Word:

Product Name                  Dialog Editor Version Number
------------                  ----------------------------

Word for Windows 2.0          2.40.0018
Excel for Windows 3.0         3.00
Excel for Windows 4.0         4.00

For more information on the Word for Windows Dialog Editor, query on
the following words in the Microsoft Knowledge Base:

   w4wmacro and dialog and editor

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 787-92

Additional reference words: w4wmacro word basic 1.00 1.10 1.10a 2.0
w4wtable 2.00 2.0a 2.00a wm_word 6.00



SendKeys Does Not Work with Third-Key Characters
Article ID: Q81152
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, the SendKeys macro command does not
work for characters accessed by using third-key character combinations
on international keyboards.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

On international keyboards, some keys have a third character assigned
to them that is accessed by pressing the RIGHT ALT key plus the
character's key (the RIGHT ALT key is labeled ALT GR on international
keyboards) or by pressing CTRL+LEFT ALT plus the key. An example of a
third-key character is the backslash character ("\") on the French
keyboard layout; this character is accessed by pressing RIGHT ALT+8
(press the 8 key on the keyboard, not on the numeric keypad).

Third-key combinations vary between international keyboard layouts.

Steps to Reproduce Problem
--------------------------

1. In a Word for Windows macro-editing window, type a macro that
   contains the following syntax:

      SendKeys "c:\windows"

2. Choose the International icon from the Microsoft Windows Control
   Panel window. In the Keyboard Layout box, select French. Choose the
   OK button and switch back to Word for Windows.



3. Run the macro you created in step 1.

The result of the SendKeys command is "c:windows" instead of
"c:\windows" when the French keyboard layout is active. This is
because the "\" character is accessed by using a third-character key
combination on the French keyboards.

Microsoft is researching this problem and will post new information
here as it becomes available.

REFERENCES
==========

"Microsoft Windows User's Guide," version 3.0, pages 180-182.

Additional reference words: foreign language 1.00 1.0 1.10 1.1 1.10a 1.1a
2.0 2.00 2.00a 2.0a w4wmacro



Trapping WordBasic ERR=102 After Choosing Cancel Button
Article ID: Q81364
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, when you choose the Cancel button in a
custom dialog box, you receive the following error message:

   WordBASIC err=102
   Command Failed

To Word for Windows, the Cancel button indicates a run-time error;
therefore, Word halts execution of the macro. You can trap this error
with an On Error command in your macro if you want to suppress the
message and let the macro continue.

An alternative method of trapping this error is to call the function
form of the dialog box. When you choose the Cancel button, a value of
0 (zero) is returned instead of a WordBasic error.

MORE INFORMATION
================

An error trap statement within a sample section of macro code
resembles the following example:

   Sub Main
   On Error Goto ExitMacroDialog
   Begin Dialog UserDialog
   '
   '
   End Dialog
   '
   '
   ExitMacroDialog:
   '
   '
   End Sub

where "ExitMacroDialog" is a label somewhere beyond the dialog
statement for the dialog box.

The lines that include an apostrophe indicate there may be more macro
code between the given statements. If you receive the WordBasic error
102 after putting the error trap into the macro, check to make sure
the label is valid and that the On Error statement appears in order
before the Dialog statement.



Alternative Error Trapping Method
---------------------------------

The alternative method for trapping the Cancel button in a custom
dialog box is to call the function form of a dialog box. If you trap
an error with this method, the "On Error Goto" statement is not used.
The following is a sample macro that creates a custom dialog box using
the function form of the dialog box. This method returns a value of 0
(zero) if you choose the Cancel button instead of halting the macro
and generating the WordBasic error 102.

   Sub Main
   Begin Dialog UserDialog 320, 124, "Word for Windows 2.00"
    TextBox 12, 30, 160, 18, .TextBox1
    TextBox 13, 83, 160, 18, .TextBox2
    Text 18, 10, 92, 13, "First Name :"
    Text 17, 60, 92, 13, "Last Name :"
    OKButton 205, 41, 88, 21
    CancelButton 205, 65, 88, 21
   End Dialog
   Dim dlg As UserDialog
   '
   msg = Dialog dlg
   If msg = - 1 Then
    Goto RestofMacro
   Else
    Goto ExitMacroDialog
   EndIf
   '
RestofMacro:
    MsgBox "Rest of Macro..."
   '
ExitMacroDialog:
    MsgBox "Exit Macro. Choose OK Button."
   End Sub

REFERENCES
==========

"Using WordBasic," by WexTech Systems and Microsoft, pages 158,
173-174

Additional reference words:  w4wmacro wm_word 6.00 1.00 1.10 1.10a 2.00
2.00a 2.00a-CD 2.00b 2.00c



Calling One Macro Routine or Function from Another Macro
Article ID: Q81414
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you can call macro subroutines and functions
that are defined in one macro from within another macro. You can use this
technique to create libraries of common routines and avoid having to copy
or rewrite procedures you use often.

MORE INFORMATION
================

Subroutine
----------

To call a macro subroutine from within another macro, use the
following syntax:

   MacroName.RoutineName

MacroName is the name of the macro containing the routine, and
RoutineName is the name of the routine you want to use. The template
containing the library routine, or a document to which the template is
attached, must be open when the routine is called. Routines stored in
the NORMAL.DOT template are always available. For example, if you
create a macro called Lib1, which contains the subroutine MyBeep, you
can call MyBeep from other macros. The following is the subroutine
MyBeep:

   Sub MyBeep
     Beep : Beep : Beep
     For t = 1 to 100 : Next          'Pause
     Beep : Beep : Beep
   End Sub

The following example illustrates how you can use the MyBeep
subroutine in a macro called SwitchToDotPath:

   Sub MAIN
     DotPath$ = GetProfileString$("DOT-PATH")
     If DotPath$ = "" Then
       Lib1.MyBeep
       MsgBox "No DOT-PATH is specified in WIN.INI"
     Else
       ChDir DotPath$
     EndIf



   End Sub

Function
--------

The syntax for using a function that you defined in another macro is
similar to that used for calling a subroutine. For example, if you
define a function called MyDateTime$(time$) in the Lib1 macro library,
you could call that function from another macro, titled CheckDateTime.
The following is the MyDateTime$(time$) function:

   Function MyDateTime$(time$)
     mDate$ = Date$()
     mTime$ = Time$()
     MyDateTime$ = mDate$ + " " + mTime$
   End Function

You can call the MyDateTime$(time$) function from the following macro,
called CheckDateTime:

   Sub Main                          'CheckDateTime macro
     CheckDateTime$ = "91.09.30 11:50 AM"
     ThisDateTime = Lib1.MyDateTime$(ThisDateTime$)
     Print ThisDateTime$
     If ThisDateTime$ = CheckDateTime$ Then
       Lib1.MyBeep
       MsgBox "It's time for lunch!"
     Else
       MsgBox "It's not time for lunch yet!"
     EndIf
   End Sub

REFERENCES
==========

"Using WordBasic," by WexTech Systems and Microsoft, pages 58-59

Additional reference words: w4wmacro 1.00 1.10 1.10a 1.0 1.1 1.1a 2.00
2.00a 2.0a wm_word 6.00



Variable with Underscore Character Truncated by Dialog Editor
Article ID: Q81427
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

The Microsoft Word for Windows Dialog Editor truncates WordBasic
dialog box variable names that contain an underscore character.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

This same truncation occurs if you type an underscore character in
string or numeric arrays in other dialog properties.

Steps to Reproduce Problem
--------------------------

1. Select the following WordBasic macro text. From the Edit menu,
   choose Copy to place it on the Clipboard. The variable name in this
   example is "List_Box$()."

      Begin Dialog UserDialog 320, 144, "Microsoft Word"
         ListBox 10, 6, 160, 84, List_Box$(), .ListBox1
         OKButton 10, 93, 88, 21
      End Dialog

2. Start the Word for Windows Dialog Editor.

3. From the Dialog Editor Edit menu, choose the Paste command. The
   dialog box described by the above text appears.

4. From the Edit menu, choose Select Dialog.

5. From the Edit menu, choose Copy.



6. Return to Word for Windows and create a new document.

7. From the Edit menu, choose Paste. The following text appears:

      Begin Dialog UserDialog 320, 144, "Microsoft Word"
         ListBox 10, 6, 160, 84, List, .ListBox1
         OKButton 10, 93, 88, 21
      End Dialog

Note that the "List_Box$()" string array has been truncated to "List."
The following WordBasic error message occurs if you run the macro
while it contains this truncation:

   Err=100
   Syntax Error

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 770,
787-791

Additional reference words: w4wmacro macrode.exe 2.00 2.0a 2.00a
 errmsg 2.0b 2.0a-CD 2.00b 2.00a-CD



WinWord: NextField and UpdateField Do Not Update All Fields
Article ID: Q81488
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If the Field Codes command is not chosen on the View menu in Microsoft
Word for Windows, using the WordBasic commands NextField and
UpdateFields may not update all of the fields in your document.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New, then choose the OK button.

2. Press CTRL+F9 to insert a pair of field braces. Within the braces,
   type the following:

      Fillin "Test 1"

3. Press the RIGHT ARROW key to move outside the braces, then press
   ENTER to move to the next line.

4. Press CTRL+F9 to insert a second pair of field braces. Within the
   braces, type the following:

      Fillin "Test 2"

5. From the Tools menu, choose Macro. (In version 1.x, choose Edit
   from the Macro menu.) Type "Test" (without the quotation marks) in 
   the Macro Name box, then choose the Edit button. Type the following 
   macro:

      Sub MAIN
      StartOfDocument
      ViewFieldCodes 0
      NextField
      UpdateFields
      NextField
      UpdateFields
      End Sub

6. From the Window menu, choose Arrange All. Place the insertion point
   in the document window, and choose the Start button.



Skipping over Test 1, Word prompts you for Test 2 twice. The function
works correctly if the FILLIN field is not the first character of the
document; the find next field function (F11) cannot find a field in
the first position of a document.

Microsoft is researching this problem and will post new information
here as it becomes available.

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 
2.00c  w4wmacro w4wfield



Word for Windows: Input Macro Command Truncates After a Comma
Article ID: Q81514
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

Summary:

The Input macro command in WordBasic truncates text if your input text
contains any commas. In WordBasic macros, the Input command accepts
text that you enter on the status bar in Microsoft Word for Windows.
If you use one or more commas in the text and print the text to the
status bar or insert it into a document as part of the macro, the
following problems occur:

 - In Word for Windows version 1.x, the text is truncated from the
   character immediately preceding the first comma to the end of the
   input text.

 - In Word for Windows version 2.0, the text is truncated from the first
   comma to the end of the input text.

 - In Word for Windows version 6.0, the text is truncated from the first
   comma to the end of the input text.

More Information:

To correct this problem, replace the commas entered on the status bar
with semicolons. If you insert the input text into a document, you can
then replace the appropriate semicolons with commas.

Steps to Reproduce Problem
--------------------------

1. Create the following macro:

    SUB Main
    Input a$
    Print a$
    END Sub

2. From the File menu, choose New, then choose the OK button. From the
   Tools menu, choose Macro, select the macro created in step 1, and
   choose the Run button.

3. On the status bar, Word prompts you to enter text with the "?"
   prompt.

4. Type "Doe, John" (without the quotation marks), and press ENTER.

The results appear on the status bar as follows:



In Word for Windows 1.x:

   Do

In Word for Windows 2.0:

   Doe

In Word for Windows 6.0:

   Doe

Additional reference words: 1.0 1.1 1.1a 1.00 1.10 1.10a 2.0a 2.00
2.00a 2.00b 2.00c 2.00a-Cd w4wmacro cut off 6.00



Macro to Choose Local or Network Templates at File New Command
Article ID: Q81695
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

The NEWMACRO.DOC file included with Microsoft Word for Windows version
2.0 contains a macro called NetworkTemplateStorage; this macro prompts
you to select network or local templates when you use the File New
command.

NOTE: This is a built in feature in Word for Windows version 6.0. By
choosing Options from the Tools menu and selecting the File Locations
tab, you can select different directories for User Templates and
Workgroup templates.

MORE INFORMATION
================

Note: Before installing this macro, make a backup copy of your
NORMAL.DOT file in case the results of this procedure are not
satisfactory.

To install the NetworkTemplateStorage macro, use the following steps:

1. From the File menu, choose Open. Select the Word for Windows
   directory in the Directories box, select the file NEWMACRO.DOC from
   the File Name box, then choose the OK button.

2. From the list of macros under Macro Name, select
   NetworkTemplateStorage, and choose the Install button.

3. When prompted, select the template and menu that you want to add
   the macro to, then choose the OK button.

4. The Save dialog box appears and allows you to save changes to any
   open documents. Choose the OK button or the Cancel button.

5. When you exit Word for Windows, be sure to choose the Yes button in
   response to the prompt "Do you want to save the global glossary and
   command changes?"

Note: In step 3 above, if you choose to add this macro to the File
menu, the File New command is renamed FileNew. Note that FileNew has
no key combination (accelerator key) assigned to it. If no top-level
menu was chosen in step 3 above, the menus appear to be unchanged.

The first time you run the NetworkTemplateStorage macro or choose the



File New (FileNew) command, Word prompts you for the network and local
template directories. Thereafter, FileNew opens a dialog box where you
can select either network or local templates before the usual New
dialog box appears and you choose a template.

Be sure to consider the following facts before installing the
NetworkTemplateStorage macro:

 - NEWMACRO.DOC writes DOT-PATH1= and DOT-PATH2= (corresponding to the
   local and network template directories) in the [Microsoft Word 2.0]
   section of your WIN.INI even if you only choose the Demo button and do
   not actually install the macro.

 - The FileNew routine, installed with the NetworkTemplateStorage
   macro, replaces the default File New command even if you choose
   another top-level menu (such as Edit). This occurs even if you chose
   to add the macro to no menus at all.

 - The procedures outlined on page 720 of the "Microsoft Word for
   Windows User's Guide" to reset the menus or to remove the FileNew
   command from a menu do not work correctly. If you choose the Reset All
   button in the Options dialog box (accessed by choosing Options from
   the Tools menu and selecting the Menus category), the menu(s) is
   restored, but the default File New command is not restored. Similarly,
   if you use the use the Options dialog box to reassign the default File
   New command to the menu, the FileNew macro, installed by the
   NetworkTemplateStorage macro, is not replaced.

The only way to delete the FileNew functionality installed with the
NetworkTemplateStorage macro is to delete the FileNew macro from the
Global Macros list in the Macro dialog box and delete the DOT-PATH1=
and DOT-PATH2= lines from the [Microsoft Word 2.0] section of your
WIN.INI file.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 720, 810

Additional reference words: w4wmacro w4wnetwork w4wtemplate
2.00 2.00a 2.00a-CD 2.00b 2.00c
context entry line



WinWord: Macro to Print Style Name Next to Each Paragraph
Article ID: Q81733
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you can display the style names used in
a document as a view option only. There is no built-in feature that
inserts the style name of each paragraph next to that paragraph and
print out that information.

MORE INFORMATION
================

Word for Windows has a Style Area Width option that opens a style name
area on the left side of a document window to display style names.
This option is for on-screen viewing only. The style names do not
appear in print preview, and they do not print. To display the name of
each style used in a document for display purposes only, do the
following:

Word for Windows Version 6.x
----------------------------

1. From the Tools menu, choose Options.

2. Select the View tab, and type a value for the
   Style Area Width.

Word for Windows Version 2.x
----------------------------

1. From the Tools menu, choose Options.

2. From the list of Categories, select View, and type a value for the
   Style Area Width.

Word for Windows Version 1.x
----------------------------

1. From the View menu, choose Preferences.

2. Type a measurement for the Style Width option.

If you want to print the style name for each paragraph, use the
following macro to insert the name of each style next to each
paragraph in the current document.



Word for Windows Version 6.x
----------------------------

Sub MAIN
StartOfDocument
Insert StyleName$() + ">> "
EditFind "^p", .Direction = 0            'Searches for next paragraph
CharRight
While EditFindFound() And Not AtEndOfDocument()
        Insert StyleName$() + ">> "      'Inserts the Stylename and >>
        EditFind "^p", .Direction = 0    'Finds next Para 
        CharRight
Wend
End Sub

Word for Windows Version 2.x
----------------------------

Sub MAIN
EndOfDocument
Insert " "      'error trap in case no text in last paragraph
num = CountStyles()          'Counts the number of current styles
For x = 1 To num
StartOfDocument
Style$ = StyleName$(x)       'Finds the name of the Style number
EditFindStyle .Style =  Style$   'Sets the search up for the style
EditFind "", .Direction = 2      'Searches for any occurrence of style
While EditFindFound()
        CharLeft
        Insert Style$ + ">> "          'Inserts the Stylename and >>
        EditFind "", .Direction = 2    'Finds next Para with the 
stylename
Wend
Next x     'goes to the next style
EndOfDocument
EditClear -1   'removes space inserted to avoid endless loop
End Sub

Word for Windows Version 1.x
----------------------------

Sub MAIN
EndOfDocument
Insert " "      'error trap in case no text in last paragraph
num = CountStyles()          'Counts the number of current styles
For x = 1 To num
StartOfDocument
Style$ = StyleName$(x)       'Finds the name of the Style number
EditSearch .Search = "^y " + Style$, .Direction = 2  'Searches for style

While EditSearchFound()
        CharLeft
        Insert Style$ + ">> "          'Inserts the Stylename and >>
        EditSearch .Search = "^y " + Style$, .Direction = 2  'Finds next
Wend
Next x     'goes to the next style



EndOfDocument
EditClear -1   'removes space inserted to avoid endless loop
End Sub

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, page 729

Additional reference words: w4wmacro 
1.0 1.1 1.1a 2.0a 1.00 1.10 1.10a 2.00 2.00a 2.00b 2.00c 6.00



DDE with International Versions of Word for Windows
Article ID: Q81734
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

You can use dynamic data exchange (DDE) to communicate directly with
any version of Microsoft Word for Windows, including international
versions. However, if the syntax of the macro commands in the
international version is unknown, or if the DDE syntax used needs to
communicate with multiple international versions, you must use the
SendKeys command.

MORE INFORMATION
================

Although macros from one version of Word for Windows are translated
automatically when a file moves from one version to another (for
example, from English to German), you cannot send macro commands in
"language-transparent" form to any version of Word for Windows.

If you send the following command to Word for Windows:

   FilePrint.NumCopies=2

the macro works correctly in the English version, but it does not work
correctly in the German version. In the German version, the command
must read as follows:

   DteiDruck.Exemplare=2

WORKAROUND
==========

You can send the SendKeys statements through DDE because they are part
of the WordBasic language and are not translated for any language
version. This provides access to any specific dialog box in any
localized version of Word for Windows based on the keystrokes used to
invoke the desired command.

To call FilePrint and print two copies of the active document in any
language version of Word for Windows version 2.0, use the following
lines:

   SendKeys "%-{right}{down 10}{enter}"
   SendKeys "2"

Note: Word for Windows versions 1.x and 2.x differ in their menu



structure; therefore, to send the above command to any language
version of Word for Windows version 1.x, use the following lines:

   SendKeys "%-{right}{down 7}{enter}"
   SendKeys "2"

Reference(s):

"Using WordBasic," by WexTech Systems and Microsoft, Chapter 5

"Word for Windows and OS/2 Technical Reference," Chapter 8

Additional reference words: 1.0 1.1 1.1a 2.00 1.00 1.10 1.10a 2.00
2.00a w4wmacro 6.00



WinWord 2.0: Compiled TOC Entry Acquires Extra Tab Stop
Article ID: Q81776
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
---------------------------------------------------------------------

SYMPTOMS
========

In Word 2.0, 2.0a, 2.0a-CD, 2.0b, and 2.0c, a compiled Table of
Contents(TOC) entry contains an extraneous tab stop, formatted
approximately .38 or .25 inch from the left indent, if the text that
the entry was compiled from contains a tab character in the middle of
the text.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

For example, if you format the text "Microsoft  ->  Word for Windows"
(where "->" represents a tab character) with the Heading 1 style, the
compiled TOC entry will contain a manually inserted tab stop, which is
visible on the ruler and in the Tabs dialog box at .38 inch. This extra tab
stop is not included in the TOC 1 style that the compiled entry is
formatted with.

WORKAROUND
==========

After compiling the table of contents, use the following steps:

Word 2.0b and 2.0c
------------------

1. Highlight the entire Table of Contents to select it.

2. Press CTRL+Q to remove any manual paragraph formatting.

Word 2.0 and 2.0a
-----------------



1. Position the insertion point in the first TOC entry.

2. Press CTRL+Q to reset the paragraph to the defaults defined in the
   TOC style.

3. Repeat this process for each TOC entry.

   You can use the following macro to automate this process:

         Sub MAIN
         fCodes = ViewFieldCodes()
         ViewFieldCodes 0
         For toc = 1 To 8
           StartOfDocument
           EditFindStyle .Style = "toc" + Str$(toc)
           EditFind .Find = "", .Direction = 2, .Format = 1
           While EditFindFound()
             ResetPara
             CharRight 1
             EditFindStyle .Style = "toc" + Str$(toc)
             EditFind .Find = "", .Direction = 2, .Format = 1
           Wend
         Next toc
         ViewFieldCodes Abs(fCodes)
         End Sub

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New, then choose the OK button. Press
   ENTER to create an additional blank line.

2. Type "This is a" (without the quotation marks), press the TAB key,
   then type "test" (without the quotation marks).

3. With the insertion point positioned in the text, choose the Heading 1
   style from the Style box on the tool bar, and press ENTER.

4. Position the insertion point in the first line of the document.

5. From the Insert menu, choose Table of Contents, and choose the OK
   button. This generates a table of contents based on all heading styles
   in the document.

6. Position the insertion point in the first TOC entry. Note that there are
   three tab markers on the ruler. The TOC 1 style, by default, has only
   two tab stops defined.

7. From the Format menu, choose Tabs. Note the extraneous tab setting
   at .38 inch in the Tab Stop Position box.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 552-557



Additional reference words: w4wformat 2.0a 2.00 2.00a number bullet
2.0b 2.0a-CD 2.00b 2.00a-CD w4wmacro



Using MsgBox Statement to Display Multiple Lines of Text
Article ID: Q81788
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you can use the WordBasic MsgBox
command to post a message or the value of a WordBasic string variable.
To post more than one line of information, use character 13 or
"Chr$(13)", to insert a paragraph mark within the message box.

MORE INFORMATION
================

The following macro posts the contents of each string variable,
First$, Second$, and Third$, on separate lines:

   Sub MAIN
   First$ = "Red"
   Second$ = "Green"
   Third$ = "Blue"
   nl$ = Chr$(13)
   MsgBox First$ + nl$ + Second$ + nl$ + Third$
   End Sub

The above macro results in a message box that displays the following
lines of text:

   Red
   Green
   Blue

If the WordBasic variables are not string variables, you can use the
Str$() function to return the string representation of the numeric
variable. For example, the following macro posts the numbers 1 and 2
(the values of the n and m variables) in a message box:

   Sub MAIN
   n = 1
   m = 2
   nl$ = Chr$(13)
   MsgBox Str$(n) + nl$ + Str$(m)
   End Sub

The following macro demonstrates the use of character 13 to
display two lines of text in a message box:

   Sub MAIN



   MsgBox "Line One of the message box" + Chr$(13) + "Line Two"
   End Sub

The above macro results in a message box that displays the following
lines of text:

   Line One of the message box
   Line Two

REFERENCES
==========

"Using WordBasic," by WexTech Systems and Microsoft, page 257

Additional reference words: w4wmacro 2.00 2.0a 2.00a 2.0 1.00 1.0 1.10
1.1 1.10a 1.1a nnew line Chr$ MsgBox message box



WordBasic: Determining the Current Page and Section Number
Article ID: Q81791
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you can use the WordBasic SelInfo
function to return information about the current selection. For
example, you can use the SelInfo function to determine the current 
page and section number for the insertion point position or the 
selected text. The SelInfo() function is not available in Word for
Windows version 1.x.

MORE INFORMATION
================

The following macro posts the current page and section number in a
message box:

Sub MAIN
Section = SelInfo(2)
Page = SelInfo(3)  'Physical page number
MsgBox "Page" + Str$(Page) + Chr$(160) + "Section" + Str$(Section)
End Sub

The syntax for SelInfo() is as follows:

   n = SelInfo(Type)

There are 36 different arguments or types for the SelInfo function in
Word 6.0 (30 arguments in Word version 2.x). Type number 2 returns 
the section number containing the selection. Type number 3 returns 
the physical page number in the document containing the selection. 
Type number 1 returns the logical page number for the current page. 
In otherwords, physical page 4 may be logical page number 23.

REFERENCES
==========

"Using WordBasic," by WexTech Systems and Microsoft, page 277

Additional reference words: w4wmacro 2.00 2.0a 2.00a 6.00



Using Windows Calls to Write to a Private Text File
Article ID: Q81792
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

In Microsoft Word for Windows version 2.x, you can use the Microsoft 
Windows WritePrivateProfileString call within a WordBasic macro to 
write to an .INI file other than the WIN.INI file.

The SetPrivateProfileString command was added to Word version 6.0.
Use SetPrivateProfileString to define or redefine a setting in a 
private settings file. A settings file is a text file like WIN.INI 
that your macros can use for storing and retrieving settings. 

Word for Windows 2.x
====================

Warning: The following information is provided "as is" without
warranty of any kind, either expressed or implied, including but not
limited to the implied warranties of merchantability and/or fitness
for a particular purpose. Using Windows calls to read and write to a
private text file is an alternative to the following standard
WordBasic file input/output statements and functions:

   Close          Open...For...As
   Eof()      Print
   Input      Read
   Input$()       Seek
   Lof()      Write

According to the Microsoft Windows Software Development Kit
documentation, the WritePrivateProfileString function has the
following parameters:

   BOOL WritePrivateProfileString(lpszSectionName, lpszKeyName,
   lpszString, lpszFileName)

   LPCSTR lpszSectionName;  section name
   LPCSTR lpszKeyName;      keyname
   LPCSTR lpszString;       string to add
   LPCSTR lpszFileName;     initialization file name

   [section name]
   keyname=string to add

The following WordBasic macro demonstrates the use of the Windows
WritePrivateProfileString function:

   Declare Function WritePrivateProfileString Lib \
   "kernel"(lpApplicationName$, lpKeyName$, lpString$, lpFileName$)\



   As Integer

   Sub MAIN
   a = WritePrivateProfileString("Section", "Printer", \
   "Text to Add", "C:\WINWORD\TEXT.INI")
   End Sub

The above WordBasic macro writes out the following information to the
TEXT.INI file in the C:\WINWORD directory:

   [Section]
   Printer=Text to Add

The WritePrivateProfileString function copies a character string into
the specified section of the specified initialization file. The return
value is TRUE (1) if the function is successful or FALSE (0) if an
error occurs.

If the FileName parameter does not contain a fully-qualified path for
the file, this function searches the Windows directory for the file.
If the file does not exist, this function creates the file in the
WINDOWS directory. If FileName parameter contains a fully-qualified
path and the file does not exist, this function creates the file. The
specified directory must already exist.

Note: To add a string to the WIN.INI file use the WordBasic
"SetProfileString" function.

REFERENCES
==========

Microsoft Windows Software Development Kit, Vol. 1, page 4-462 through
page 4-464

Additional reference words: GetPrivateProfileString 2.00 2.00a
w4wmacro



Using Windows Calls to Read from a Private Text File
Article ID: Q81793
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

In Microsoft Word version 2.x for Windows, you can use the Microsoft 
Windows GetPrivateProfileString call within a WordBasic macro to read
information from an .INI file other than the WIN.INI file.

The GetPrivateProfileString function was added to Word version 6.0.
Use GetPrivateProfileString to return a setting from a private 
settings file. A settings file is a text file such as WIN.INI that 
your macros can use to store and retrieve settings.

Word for Windows 2.x
====================

According to the Microsoft Windows Software Development Kit
documentation, the GetPrivateProfileString function has the following
parameters:

   INT GetPrivateProfileString(lpszSectionName, lpszKeyName,
lpszDefault,
   lpszReturnBuffer, cbReturnBuffer, lpszFileName)

   LPCSTR lpszSectionName;    section name
   LPCSTR lpszKeyName;        keyname
   LPCSTR lpszDefault;        default return string
   LPSTR lpszReturnBuffer;    variable assignment for INI information
   int cbReturnBuffer;        size of the destination buffer
   LPCSTR lpszFileName;       initialization filename

   [section name]
   keyname=string to read

The following WordBasic macro demonstrates the use of the Windows
GetPrivateProfileString function:

   Declare Function GetPrivateProfileString Lib "kernel" \
   (lpApplicationName$, lpKeyName$, lpDefault$, lpReturnedString$, \
   nSize As Integer, lpFileName$)  As Integer

   Sub MAIN
   a = GetPrivateProfileString("Section Name", "keyname", "", Temp$,\
   255,"H:\WINWORD\TEXT.INI")
   MsgBox Temp$
   End Sub

The above macro reads the contents the TEXT.INI file and posts the
contents of "keyname=" heading in a message box.



The GetPrivateProfileString function reads a character string from the
specified section of the specified initialization file. The return
value is the number of characters copied into the buffer if successful
or 0 (zero) if unsuccessful.

Note: To obtain a string from the WIN.INI file use the WordBasic
"GetProfileString" function.

REFERENCES
==========

"Microsoft Windows Software Development Kit," Vol. 1, page 4-199
through page 4-200

Additional reference words: WritePrivateProfileString 
w4wmacro 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00



Paragraph Formatting Affects DropCap Macro Results in WinWord
Article ID: Q81860
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

The DropCap macro included in the Microsoft Word for Windows 
NEWMACRO.DOC file works correctly only on single-spaced text that is not 
indented. The DropCap macro produces varying results depending on the 
formatting of the paragraph to which you want to apply the macro. The 
possible results are described below.

This functionality was changed in Word version 6.0 for Windows.

More Information:
 
 - If you set a left indent, the macro positions the character
   correctly but does not position the frame around the character. 
  
 - If you set the Line Spacing option to At Least 1.5 Li or 2 Li, 
   Double, or 1.5 Lines, you will receive the following error message:

      This is not a valid integer
    
 - If you set the Line Spacing option to Exactly XXX (where "XXX" is a
   point value or number of lines), DropCap positions the frame
   correctly but does not position the character correctly.
    
 - If you set the Line Spacing option to At Least YYY (where "YYY" is a
   point value or number of lines greater than but not equal to 2
   lines), you can move the frame and character to the correct
   position by dragging the frame surrounding the character.

 - If the character is in a Word for Windows table, the following
   error message will occur: 

      WordBASIC error 509 "Command is Unavailable"
  
The DropCap macro works correctly only if you set the Line Spacing
option to Auto, Single, At Least 0 Li, or At Least 1 Li; and the From
Left box under Indentation is set to 0 (zero).

These problems were corrected in Word for Windows 6.0. The new Drop Cap 
(not a macro) feature takes into account variations in line spacing and 
indentation, and is not available when attempting to insert into 
a table cell. To insert a Drop Cap, in Word 6.0, choose Drop Cap from 
the Insert menu.

Additional reference words: w4wformat



w4wmacro 2.00 2.00a 2.00a-CD 2.00b 2.00c



Incorrect Word Wrapping with the PostScript Printer Driver
Article ID: Q67102
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When you use the PostScript printer driver PSCRIPT.DRV with the
default screen fonts that come with Windows, Microsoft Word for
Windows produces incorrect line endings with the AvanteGarde, Bookman,
Helvetica-Narrow, Modern, NewCenturySchlbk, Palatino, Roman, Script,
Symbol, TmsRmn, ZapfChancery, and ZapfDingbats fonts. Word does
generate correct line endings with the Courier and Helv fonts when you
use the default screen fonts that come with Windows.

This problem does not occur if you are using TrueType fonts in the
Microsoft Windows operating system version 3.1; however, using
standard PostScript printer fonts without the correct screen fonts in
Windows 3.1 generates the same problem.

This problem was corrected in Word version 6.0 for Windows.

More Information:

With the right margin at 6.5 inches and a 10-point font size, the
following fonts wrap before the 6.5-inch margin:

   Font                  Wraps At
   ----                  --------

   AvanteGarde             6.125 inches
   Bookman                 5.125 inches
   Modern                  6.125 inches
   NewCenturySchlbk        5.5 inches
   Palatino                5.75 inches
   Roman                   5.375 inches
   Script                  6 inches
   Symbol                  6.125 inches
   Tms Rmn                 6 inches
   ZapfDingbats            4.375 inches (when displaying as the symbol 
font)

With the right margin at 6.5 inches and a 10-point font size, the
following fonts wrap before the 6.5-inch margin:

   Font                    Wraps At
   ----                    --------

   Helvetica-Narrow        7.75 inch
   ZapfChancery            7.125 inch



Note: These numbers may vary if you use third-party screen fonts or
different point sizes.

Reference(s):

"Microsoft Word for Windows User's Reference," version 1.x, pages 31,
123-125

Additional reference words: w4wprint w4wmerge 1.0 1.1 1.1a 1.00 1.10
1.10a 2.0 2.00 3.10



Using "And", "Or", "Attn" in an IF Statement in Print Merge
Article ID: Q68043
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

When you compile a print merge in Word for Windows, you may want to
place a specific word in front of another word in certain
circumstances. For example, you may want to place the word "and" in
front of the wife's name when the husband's name is present, as
follows:

   John
   Jane
   John and Jane

The following nested IF statement will meet that condition:

   {If {husb} <> "" "{husb} {if {wife} <> "" "and {wife}"}""{wife}"}

You can alter this statement for "or", "attn", etc. by substituting
the bookmark {company} (for husb), {contact} (for wife) and
substituting "attention" (without the quotation marks) or any other
appropriate word.

Additional reference words: w4wmerge 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c 6.00 wm_word



SKIPIF No Longer Functions Properly if Used With NEXT Field
Article ID: Q69319
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

The SKIPIF field successfully skips specified data records to create
individual documents for each data record. However, SKIPIF does not
work properly when combined with the NEXT field.

MORE INFORMATION
================

The SKIPIF field compares a data item against specified guidelines
made about a data record. If the comparison is TRUE, the present data
record is skipped, and Word for Windows does not print it. The next
record is selected and compared. If the comparison is FALSE, the data
record is printed, and Word for Windows moves on to check the next
record.

SKIPIF successfully skips specified data records to create individual
documents for each data record. The following example illustrates
this:

   {data c:\\winword\\mydoc.doc}{skipif {zip} = "98000"}{name}
   {street}
   {city}, {state}  {zip}

This example successfully skips data records that have a zip code of
98000 and prints each data record that does not have a 98000 zip code
on a new sheet of paper.

Because the SKIPIF field does not function properly with the NEXT
field, if you try to use the SKIPIF and NEXT fields to create a list
or address labels, Word for Windows does not print or skip data
records properly. The following example illustrates this:

   {data c:\\winword\\mydoc.doc}{skipif {zip} = "98000"}{name}
   {street}
   {city}, {state}  {zip}

   {next}{skipif {zip} = "98000"}{name}
   {street}
   {city}, {state}  {zip}

This example results in erratic placement of data records in your
document or an empty print merged document.



Additional reference words: 6.00 w4wmerge w4wfield skipif next wm_word 



Example IF Fields for Print Merging in Word for Windows
Article ID: Q70131
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

The following are examples of IF statements for print merging and the
logic for each statement.

1. {if {party}="R" "Republican" "Democrat or Other"}

   If "party" is equal to "R", enter "Republican" (first option is
   positive). If it is not equal to "R", enter "Democrat" or "Other"
   (second option is negative).

2. {name}
   {if{party}<>"R" "" "Republican
   "}{City}

   If "party" is not equal to "R", enter nothing. If "party" is equal
   to "R", enter "Republican". This line will also suppress the blank
   line left by a non-R result.

3. {if{party}="R" "Republican" {if{party"="D" "Democrat"} {if
   {party} ="O" "Other"}}

   If "party" is equal to "R", enter "Republican". If "party" is "D",
   enter "Democrat". If "party" is equal to "O", enter "Other". If
   "party" is none of these, it will be blank.

4. {if{party}="R" "{party}epublican and family" {if{party}="D"
   "{party}emocrat and relatives" {if{party}="O" "{party}ther"}}}

   If "party" is equal to "R" then enter the value of "party" and
   "epublican and family". If "party" is equal to "D" then enter the
   value of "party" and "emocrat and relatives". If "party" is equal
   to "O" enter the value of "party" and "ther". If "party" is not
   "D", "R", or "O", it will be blank.

5. {if{party}="R" {if{name}="George Bush" {if{city}="Washington
   D.C." "President"}}}

   If "party" is equal to "R" and "name" is "George Bush" and "city"
   is "Washington  D.C.", enter "President". If all the conditions
   aren't met leave it blank.

Sample Data Document
--------------------

NAME,PARTY,CITY
George Bush,R,Washington D.C.



George McGovern,D,Rapid City
Gorgeous George,O,Hollywood
King George,K,London

Special Note: Field codes and bookmarks are not case sensitive; for
example, NAME would print merge to {naME}. However the results are
case sensitive. In these examples if the codes said {if {party}="r"
"Republican"} and the data document had the "r" capitalized (R), it
would be considered to be a non-r and print nothing.

Additional reference words: 6.00 w4wmerge w4wfield wm_word 



Print Merge Even/Odd Records in WinWord Form Letters
Article ID: Q71382
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

To print only the ODD records in a print merge, place a NEXT field
code at the end of the form letter.

The following is an example:

   {fname} {lname}
   {company}
   {street}
   {city}, {state} {zip}

   Dear {fname},

   Here are the things that you need for the party....

   Sincerely,

   Jane Doe
   {next}

To print EVEN records, insert a second DATA field at the beginning of
the document, or use the NEXT statement as described above. If you use
the NEXT statement, choose Print Merge from the File menu, then choose
to merge from records 2 through x.

MORE INFORMATION
================

Word for Windows Version 2.0
----------------------------

In Word for Windows 2.0, the NEXT statement performs the same
function; however, please note the following:

 - When you activate the field codes, the main document field codes
   appear differently from the codes appear in 1.x. For example,

      {MERGEFIELD name}{MERGEFIELD address}
 
 - When the field codes are not active, the main document field code 
   names appear as follows:

      (<<name>>  <<address>>)



Note: The chevron symbols ( << and >> ) appear smaller in Word for
Windows version 2.0.

REFERENCES
==========

"Using Word for Windows," Que Publishing

Additional reference words: 6.00 w4wmerge w4wfield 1.0 1.00 1.1 1.10
1.1a wm_word 1.10a 2.00 skip miss



Using MERGEREC to Number Print Merge Records
Article ID: Q71829
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

The MERGEREC field can be used to automatically number the records in
a Word for Windows print merge document.

MORE INFORMATION
================

The MERGEREC field can be used in the main document of a print merge
in Word for Windows to automatically number the records being merged.
This field updates with the Print Merge command (from the File menu,
choose Print Merge) and inserts the number of the current print merge
record into the merged document.

To use the MERGEREC field:

1. Press CTRL+F9 to insert field braces {} in the main document where
   the merged record number is to be placed.

2. Type the word MERGEREC. (This is not case sensitive.)

3. From the File menu, choose Print Merge. Choose either Print or New
   Document to print the merged document or display it on the screen.

If you are merging multiple records into a table (for example, to
print labels) a MERGEREC field should be placed in each cell of the
table following the NEXT or NEXTIF field. The NEXT or NEXTIF field
will increment the result of the MERGEREC field and number each record
in the table.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," page 102.

"Microsoft Word for Windows Technical Reference," page 173.

"Microsoft Word for Windows and OS/2 Technical Reference," page 364.

Additional reference words: 6.00 w4wmerge w4wfield wm_word 



Word for Windows: Suppressing Blank Spaces in Print Merge
Article ID: Q72441
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When performing a print merge in Microsoft Word for Windows, a blank 
space displays and prints if one field on a line is blank. A common 
example of this situation is a line with three name fields, such as the 
following:

   {FNAME} {MI} {LNAME}
 
In a record where all three fields are filled, the merged record
spacing is correct, as in the following example:
 
   James R. Wood

In a record where the middle initial field {MI} is blank, an extra
space occurs in the merged record, as in the following example:

   Susan  Peterson
 
Note: There are two spaces between the {FNAME} and {LNAME} results.

More Information:

You can eliminate this extra space by using the following conditional
statement:

   {FNAME} {IF {MI} <> "" "{MI} "}{LNAME}

Note: To enter the field brackets ({}), choose Field from the Insert
menu (or press CTRL+F9).

Reference(s):

"Microsoft Word for Windows User's Reference," pages 97-98, and 200
"Microsoft Word for Windows and OS/2 Technical Reference," pages 41-42

Additional reference words: w4wmerge w4wfield 1.00 6.00
1.10 1.10a 2.00 2.00a 2.00b 2.00a-CD wm_word



Merged Cells in Header Record Causes Error in Print Merge
Article ID: Q72893
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

If you merge two or more cells in the header record (the first row) of
a print merge data table, hidden separators still exist in the merged
cell. The presence of these separators produces an error message
during the print merge. In Microsoft Word for Windows 1.x the error
is:

   Not a Valid Bookmark Name

In Word for Windows 2.x the error is:

   Word has detected a field in the header record which is not valid.
   This error must eventually be corrected in order to complete a
   successful print merge.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

The hidden separators are used by the Split Cells feature of Word.
This feature allows Word to split the cells at the same point that
they merged.

To remove the separators in Word for Windows version 1.0, 1.1, or
1.1a, follow these steps:

1. Select the first row of the table.

2. From the Insert menu, choose Table To Text, and select Comma
   Delimited.



3. Remove the extra comma that appears where the two cells were
   merged. For example:

      FROM    name,addr,state,,zip
      TO      name,addr,state,zip

4. Select the line of text again.

5. From the Insert menu, choose Table.

This procedure converts the text back into the table format and
removes the hidden separators, allowing the print merge to run without
the "Not a valid Bookmark Name:" error.

In Word for Windows version 2.0, the error message box gives you an
option to "Fix Error Now." If you choose this option, Word places the
insertion point in the cell that was merged, but the cell does not
appear to have any errors.

To remove the separator in Word for Windows version 2.0, follow these
steps:

1. Select the First row of the table.

2. From the Table menu, choose Convert Table to Text, and select Comma
   Delimited.

3. Remove the extra comma that appears where the two cells were
   merged. For example:

      FROM    name,addr,state,,zip
      TO      name,addr,state,zip

4. Select the line of text again.

5. From the Table menu, choose Convert Text to Table.

Reference(s):

"Microsoft Word for Windows User's Reference," version 1.x, pages
197-200, 368-370

Additional reference words: 1.00 1.10 1.10a 2.00 w4wmerge 2.0a 2.00a
w4wtable 2.0b 2.0a-CD 2.00b 2.00a-CD



Nested Fields in IF Statement Always Update in WinWord
Article ID: Q74053
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

All fields nested within an IF statement are updated during the
evaluation of that IF statement, regardless of whether the IF
statement proves TRUE or FALSE. In the following example

   {IF test="yes" "{fillin "response one"}" "{fillin "response two"}"}

both fillin fields are updated, prompting you twice. Only one prints,
based on the result of the IF statement. This happens because Word for
Windows updates fields from the inside out. Both of the fillin fields
get updated before the IF statement test is performed. This
functionality is by design.

More Information:

This behavior can create challenges if you need to selectively perform
FILLIN or ASK statements during a print merge. You can do such tasks
by using a different logical structure than the one above. The
following example

   {fillin {if test = "yes" "response one" "response two"}}

prompts you with "response one" if test is "yes", and "response two"
if test is "no". This allows conditional fillin prompts without
getting multiple prompts.

Reference(s):

"Microsoft Word for Windows and OS/2 Technical Reference," page 335

Additional reference words: w4wfield w4wmerge 1.0 1.1 1.1a 2.0 1.00
1.10 1.10a 2.00 2.0a 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD wm_word 6.00



Recorded Macro to Print Merge to Printer Requires SendKeys
Article ID: Q74913
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

The SendKeys macro command is required in a macro to print merge a
document to the printer in Microsoft Word for Windows. Without the
SendKeys macro command, the Print dialog box remains on the screen.
This problem occurs because Word for Windows does not have control
over the File Print dialog box; therefore, you must send all relevant
keystrokes using the SendKeys command.

MORE INFORMATION
================

If a macro is recorded to merge a document to the printer, the macro
has the following commands (there may be different values for the
parameters, depending on your choices in the dialog boxes):

Sub MAIN
FilePrintMerge .MERGERECORDS = 0, .From = "", \
.To = "", .PRINT
FilePrint .Type = 0, .NumCopies = "1", .Range = 0,\
.From = "", .To = "", .Reverse = 0, .Draft = 0,\
.UpdateFields = 0, .PaperFeed = 8, .Summary = 0, \
.Annotations = 0, .ShowHidden = 0, .ShowCodes = 0,\
.FileName = ""
End Sub

Note: The backslashes (\) indicate the command is continued on the
next line. Do not include the backslashes in your macro.

For the macro to work correctly, the following command must be
inserted before the FilePrintMerge command:

   SendKeys "{enter}", -1

Multiple Copies
---------------

If you want to print more than one copy of your merged document, use
the following SendKeys command to modify the Copies box in the File
Print dialog box:

   SendKeys "N{ENTER}", -1

Note: "N" is the number of copies you want to print.



REFERENCES
==========

"Microsoft Word for Windows Technical Reference," pages 88-90

"Microsoft Word for Windows and OS/2 Technical Reference," pages
251-253

Additional reference words: w4wmacro w4wmerge 1.00 1.10 1.10a 2.00
2.00a 2.00a-CD 1.x appears automatic 6.00



Incorrect Merge Results with Conditional IF Statement
Article ID: Q75623
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

When you use the Microsoft Word for Windows print merge feature, the
results may be incorrect when using a conditional IF statement.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this
problem and will post more information here in the Microsoft Knowledge
Base as it becomes available.

MORE INFORMATION
================

If the following three conditions are true, a print merge
may produce incorrect results:

1. The header contains a word that is also the first word of a field
   in a data record.

      Example:   name,honors,list,class
                      John,Dean List,Honors List,Math
                                     ^^^^^^^^^^^

2. This same data record contains a blank field for this header.

      Example:   name,honors,list,class
                       John,,Honors List,Math
                            ^

3. An IF condition is used for the field that contains data with the
   first word that is the same as a header.

      Example:   {if{list}<>"" "{list}<return>
                 "}

Steps to Reproduce Problem
--------------------------

1. Insert a table as follows:

      --------------------------------------------------



      |name|honors     |List       |Class      |teacher|
      |-------------------------------------------------
      |Twan|Dean's List|Honors List|Math       |Speller|
      --------------------------------------------------
      |Joe |           |Late List  |Honors Math|Tuck   |
      --------------------------------------------------
      |Mike|Class Clown|Honor Roll |           |Smart  |
      --------------------------------------------------

2. Save the file as DATA1.DOC.

3. From the File menu, choose New, then OK.

4. Create a form letter as follows:

      {data c:\\winword\\data1.doc}

      {name}
      {if{honors}<>"" "{honors}<return>
      "}{list}
      {if {class}<>"" "{class}<return>
      "}{teacher}

5. Save the file as MAIN1.DOC.

6. From the File menu, choose Print Merge, then choose Print or New
   Document to see the results.

   Desired Result
   --------------

      Page 1          Page 2          Page 3
      Twan            Joe                     Mike
      Dean's List                             Class Clown
      Honors List     Late List               Honor Roll
      Math                    Honors Math
      Speller                 Tuck                    Smart

   Actual Result
   -------------

      Page 1          Page2           Page 3
      Twan                    Joe                     Mike
      Dean's List     Late List               Honor Roll
      Honors List     Tuck                    Smart
      Math
      Speller

Both the Honors and Class merge fields are used in conditional IF
statements and produce no merge results under the above conditions,
even when the record contains data for these fields.

Additional reference words: w4wmerge w4wfield 2.0 2.00 2.0a 2.00a 2.0b
2.0a-CD 2.00b 2.00a-CD 2.00c 6.00



Paragraph Mark Always Inserted in Field With Table as Result
Article ID: Q77825
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows versions 1.x and 2.x, any field that
displays a table as a result also displays a paragraph mark preceding
the table. The paragraph mark displays because although a field can be
inserted into the middle of a paragraph, a table cannot be contained
within a paragraph. The paragraph mark at the beginning of the field
prevents the table from inserting into the middle of the paragraph.

This paragraph mark cannot be deleted or modified.

Status:

This problem has been corrected in Word version 6.0 for Windows.

More Information:

This behavior makes it impossible to use DDE or DDEAUTO links to an
Excel file to create a data file for use in a Word for Windows print
merge.

For more information on print merge errors caused by DDE or DDEAUTO
links to Excel, query on the following words:

   valid and bookmark and name and dde

Additional reference words: w4wfield w4wmerge 1.00 1.10 1.10a 2.00 1.0
w4wtable 1.1 1.1a 2.0 2.0a 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD



WinWord: Blank Lines Are Not Suppressed in Print Merge
Article ID: Q77982
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Word for Windows, if you try to suppress a blank line in a print 
merge document containing a field that may or may not contain data, and 
a paragraph mark follows the field in the merge document, Word 
suppresses the blank line. However, if a newline character follows the 
field, the blank line is not suppressed.

If the field does not have the keyword MERGEFIELD, it will also be
suppressed. For example:

   {MERGEFIELD first}
   {last}
   Hello World!

If the "last" field does not have any data in it, the blank line will
print. If the "first" field does not any data in it, the blank line will 
be suppressed.

More Information:

The Print Merge command in Word 2.0 includes the option to automatically
suppress blank lines created by empty data fields, including the blank 
line created by a linefeed. This feature allows you to preserve the 
option to include a blank line after a field that may or may not contain 
data.

When setting up labels using the MAILLABL.DOT template, you should 
always select New Paragraph rather than New Line in the Layout Mailing 
Labels dialog box. This ensures that Word can suppress blank lines.

Steps to Reproduce Problem
--------------------------

1. Create a data document (make sure that you include a field that may
   or may not contain data, such as "address2").

2. From the File menu, choose New. Select MAILLABL from the Use
   Template box. Choose the OK button.

3. Select the type of address labels desired from the Product Number
   box. Choose the OK button.

4. Choose the Multiple Label button.



5. Select the data file from the Attach Data File Name box, and choose
   the OK button.

6. In the Layout Mailing Labels dialog box, select the merge field
   name that may or may not contain data (in this example, "address2") 
   in the Field Name box. Select New Line in the Special Character box.
   Choose the Add button, and choose the OK button.

7. From the File menu, choose Print Merge. Choose the Merge button.

8. In the Treatment of Blank Lines Caused By Empty Fields box, select
   Skip Completely.

9. In the Merge Results box, choose Merge to New Document.

If "address2" is followed by a newline character, the blank line is
not suppressed when "address2" is an empty field. If "address2" is
followed by a carriage return, the blank line is suppressed.

To repair a document that has already been created with the newline
character, use the following steps:

1. From the Edit menu, choose Replace.

2. Type "^n" (without the quotation marks) in the Find What box.

3. Type "^p" (without the quotation marks) in the Replace With box.

4. Choose the Replace All button.

Word searches for all newline characters and replaces them with
paragraph marks.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 661-664

Additional reference words: w4wmerge 2.00



Comma is Selected in Blank Field in WinWord Data Document
Article ID: Q78085
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SYMPTOMS
========

In Word for Windows version 2.0, if you attempt to correct a print
merge error that occurs when a data document contains a blank header
field, the comma following the blank field is highlighted if the data
document is comma-delimited.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

If you perform a print merge in Word for Windows 2.0 with a data
document that contains a blank field in the header field, the
following error message appears:
  
   Word has detected a field name in the header record which is not
   valid. This error must eventually be corrected in order to complete a
   successful Print Merge.
 
The options to "Fix Error Now," "Fix Error Later," or "Help" also
appear. Choosing "Fix Error Now" results in the data file displaying
on the screen with the insertion point positioned in the header record
where the missing field should be inserted. If the file is
tab-delimited or in a table, the insertion point correctly positioned,
and you can type the field name. 

If the data file is comma-delimited, the comma that follows the empty
field position is highlighted. Typing the field name at this point
results in more errors to the header record because the comma may be
replaced by the typing, or positioned incorrectly. You should position
the insertion point between the commas (in the blank field position)
before typing the missing field name.



Additional reference words: w4wmerge 2.00 2.0a 2.00a 2.0b 2.0a-CD
2.00b 2.00a-CD 



Can't Access Record Selection Box in WinWord 2.0 Print Merge
Article ID: Q78228
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, if you perform a print merge with a
main document that is set up with a record selection rule and the
field name used in the rule no longer exists in the data document, you
cannot access the Record Selection dialog box to change this rule.

MORE INFORMATION
================

WORKAROUND
==========

To bring up the Record Selection dialog box, use one of the following
procedures:

 - Correct the data document by changing the modified field name back to
   the original name or by adding the modified field name to the existing
   field names.

 - If the wrong data file is attached, remove it from the main document by
   choosing Print Merge from the File menu and choosing Remove Attachments.
   Then choose Attach Data File, and select the correct data file to attach
   to the main document.

 - Select and copy all of the text from the current document
   (excluding the final paragraph mark) and paste it into a new document
   and re-attach the data file.

Steps to Reproduce Problem
--------------------------

1. Open or create a print merge main document in Word for Windows with
   the field names "name" and "address".

2. From the File menu, choose Print Merge. Choose the Merge button, and
   choose the Record Selection button.

3. From the Field Name box, select Name. From the Is box, select Equal To,
   and type "Bob" (without the quotation marks) in the Compare To box.

4. Choose the Add Rule button, then choose the OK button.

5. Choose the Close button to exit the Print Merge dialog box.



6. Change the Name field in the data document to "firstname."

7. Switch back to the main document and repeat step 2.

Choosing the Record Selection button now has no effect. The button flashes,
and the focus and default buttons return to the OK button. It does not
bring up the Record Selection dialog box to edit or remove the applied
rule. The data document must be edited to add the field name used in the
rule, or a data document that contains the field name used in the rule must
be attached to the main document.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," pages 609-630, 634, 670

Additional reference words: w4wmerge 2.00 pmh helper w4wfield 2.00a
2.00a-CD 2.00b



Edited MERGEFIELD Results Do Not Affect Fields in WinWord
Article ID: Q78655
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======
In Microsoft Word for Windows, the results of a MERGEFIELD field 
typically display the name of the field from the data document. You can 
edit the displayed results of this field, but doing so does
not change the field itself.

STEPS TO REPRODUCE PROBLEM
==========================

Word version 6.0 for Windows
----------------------------

1. Type "mergefield hello" (without the quotation marks).

2. Select the above words, and press CTRL+F9.

3. Press the F9 key.
    
4. Turn off the field codes. To do this, from the Tools Options View 
   menu, look for an X next to Field Codes. If there is an X next to
   Field Codes, choose Field Codes to turn this option off.
   
5. Select the word "hello," but do not include the MERGEFIELD chevrons
   in your selection.
 
6. Press the DEL key and type the word "bye" (without the quotation
   marks).

7. Choose Field Codes from the Tools Options View menu to activate the 
   field codes.
 
With field codes active, the field reads {mergefield hello}. With
field codes turned off, the field result reads <<bye>>. To restore the
field to normal, select it, and press F9.
 
Word version 2.0 for Windows
----------------------------

1. Type "mergefield hello" (without the quotation marks).

2. Select the above words, and press CTRL+F9.

3. Press the F9 key.
    



4. Turn off the field codes. To do this, from the View menu, look for
   a check mark next to Field Codes. If there is a check mark next to
   Field Codes, choose Field Codes to turn this option off.
   
5. Select the word "hello," but do not include the MERGEFIELD chevrons
   in your selection.
 
6. Press the DEL key and type the word "bye" (without the quotation
   marks).

7. Choose Field Codes from the View menu to activate the field codes.
 
With field codes active, the field reads {mergefield hello}. With
field codes turned off, the field result reads <<bye>>. To restore the
field to normal, select it, and press F9.

Microsoft is researching this problem and will post more information
here as it becomes available.

Reference(s):
 
"Microsoft Word for Windows User's Guide," version 2.0, page 749

Additional reference words: w4wmerge w4wfield 2.00 2.00a-CD 2.00b 6.00 
wm_word 



Use of "AND" and "OR" with Print Merge Selection Rules
Article ID: Q79266
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======
 
With the Print Merge Helper (PMH) in Microsoft Word for Windows, you
can define "rules" that determine whether or not a specific record is
included in the print merge. It is important to understand the
difference between the English language meaning of "AND" and the
logical meaning of "AND" to use these rules effectively.

MORE INFORMATION
================
  
The English language meaning of "AND" is equivalent to the logical
meaning "OR." For example, suppose you have a data file that includes
a STATE field and you want to perform a print merge of the records for
the STATE fields of North Carolina and Washington. In English, you say
"Include the records for North Carolina AND for Washington."
Logically, however, the statement is written as "Include the records
where STATE is North Carolina OR STATE is Washington."
  
When you use a logical "AND," both conditions must be true in order
for the expression to be evaluated as true. If you write the statement
"to include the records where STATE is North Carolina AND STATE is
Washington," it is logically impossible for both conditions to be true
in the same record. The state cannot be both North Carolina and
Washington; it has to be one or the other. Below is a chart that
describes how logical "AND" and "OR" are evaluated.
 
   If X=A OR Y=B        If EITHER is true, the record is included.
   If X=A AND Y=B       If BOTH are true, the record is included.

REFERENCES
==========
 
"Microsoft Word for Windows User's Guide," version 2.0, pages 634, 670

Additional reference words: 2.00 w4wmerge w4wfield



WinWord: Print Merge Result Incorrect on Last Record
Article ID: Q80656
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, using section formatting during a print
merge causes the last record to be incorrect.

WORKAROUND
==========

To work around this problem, you can use a frame rather than section
formatting. Formatting the frame instead of the section corrects this
problem. Select the fields you want to format, choose Frame from the
Insert menu, choose Frame from the Format menu, and select the desired
formatting options.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New, and choose the OK button.

2. From the File menu, choose Print Merge. Choose the Attach Data File
   button, then choose the Create Data File button.

3. Type "Name" (without the quotation marks), and choose the Add
   button. Type "Address" (without the quotation marks), choose the
   Add button, and choose the OK button.

4. Save the file as DATA1.DOC. Add three records to the data file.
   (Use the TAB key to move to the next cell, and to add records.)



5. After adding three records, choose the large "M" on the print merge
   bar. This moves you to the main document.

6. Choose the Insert Merge Field button, select the NAME field, and
   press the OK button. Press ENTER, select the ADDRESS field, and choose
   the OK button.

7. Select the two fields. From the Format menu, choose Section Layout.
   In the Vertical Alignment box, select the Center option button, then
   choose the OK button.

8. Choose the Print Merge to New File button.

9. From the File menu, choose Print Preview, and move to the last page
   of the document.

The last record is incorrect.

Word for Windows Version 1.x
----------------------------

This problem also occurs in the Word for Windows versions 1.0, 1.1,
and 1.1a. To work around the problem in version 1.x, select the text
you want to format in the main document, choose Position from the
Format menu, and select the desired formatting options.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, page 390

"Microsoft Word for Windows User's Reference," version 1.x, page 262

Additional reference words: tool bar 1.00 1.10 1.10a 2.00 2.0a 2.00a
2.0b 2.0a-CD 2.00b 2.00a-CD w4wmerge



Large Excel Sheet Becomes Tab- and Comma-Delimited for Merge
Article ID: Q81085
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b
   2.0c
 - Microsoft Excel for Windows, versions 3.0 and 4.0
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

If you use a Microsoft Excel spreadsheet as the data document for a
print merge in Microsoft Word for Windows and you specify a range that
includes more than 31 columns or a large number of rows, Word
generates the following error message if the data you are merging
contains commas:

   There are more fields in record x than merge fields in the header
   record. Do you want to continue with the Print Merge?

If you choose the Yes button in response to this question, your data
is merged incorrectly.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

If you use an Excel spreadsheet for a print merge data document, Word
converts the spreadsheet to Word for Windows format during the merge
process. Normally a spreadsheet is converted to a Word for Windows
table; however, Word tables are limited to 31 columns. As a result,
spreadsheets containing more than 31 columns are converted to
tab-delimited documents for print merges. In addition, spreadsheets
containing a large number of rows, but less than 31 columns, are also
converted to tab-delimited text. The number of rows that triggers the
change from table-delimited to tab-delimited varies depending on the
complexity of the spreadsheet.

Word inserts tabs in place of cell boundaries, but it uses both the
tabs and any commas in the data as delimiters during the print merge.



Word considers the commas to be delimiters, rather than text, because
the List Separator designated in the Control Panel International
dialog box is a comma when the country setting is United States.

Workarounds
-----------

To make Word treat commas as text, rather than delimiters, use one of
the following options:

 - Place quotation marks around text in the spreadsheet that contains
   any commas (for example, "Acme, Inc.").

 - Place a backslash character (\) in the spreadsheet before the comma
   (for example, Acme\, Inc.). Word does not merge the backslash but does
   treat the comma as text, rather than a delimiter.

 - Save the spreadsheet in Excel in CSV (comma-separated value) format,
   and use the CSV file for the print merge data document.

Note: This problem occurs in Excel version 4.0 and earlier.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 620-624

Additional reference words: w4wmerge w4wtable w4wexcel 2.00 2.00a
2.00a-CD 2.00b 2.00c



WinWord 2.0: Avery Laser Label Information
Article ID: Q81937
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

The following is a reproduction of the information found on the back
of the retail package of Avery Laser Labels. The MAILLABL.DOT file,
which is a mailing label template that ships with Microsoft Word for
Windows versions 2.x, only gives the Avery Product Code and a brief
description of each label. The template does not list the dimensions for
each label, which makes the template difficult to use if you do not have
Avery brand labels.

NOTE: In Word for Windows version 6.0, Avery label dimensions are
included as part of the label feature.

MORE INFORMATION
================

Some of the product codes listed below do not appear in the MAILLABL
template listing. They are included here (designated with an asterisk
[*]) with a reference for the label numbers that duplicate their
layout.

Avery Laser Labels
------------------

Product Code      Label Size (HxW)   Number of Columns  Labels Per 
Sheet
------------      ----------------   -----------------  ----------------

5066              2/3" x 3 7/16"          3               30
5095* (use 5395)
5096              2 3/4" x 2 3/4"         3               9
5097              1 1/2" x 4"             2               12
5160              1" x 2 5/8"             3               30
5161              1" x 4"                 2               20
5162              1 1/3" x 4"             2               14
5163              2" x 4"                 2               10
5164              3 1/3" x 4"             2               6
5165              8 1/2" x 11"            1               1
5182* (use 5165)
5196              2 3/4" x 2 3/4"         3               9
5197              1 1/2" x 4"             2               12
5198              1 2/3" x 3 1/2"         2               12
5199 (Face)       1 5/6" x 3 1/16"        2               10
5199 (Spine)      2/3" x 5 13/16"         1               15



5260              1" x  2 5/8"            3               30
5261              1"  x  4"               2               20
5262              1 1/3" x 4"             2               14
5266              2/3" x 3 7/16"          2               30
5267 same as: LSK-5 11436
                  1/2" x 1 3/4"           4               80
5282* (use 5165)
5345              2" x 4"                 2               10     
5352* (use 5663)
5366* (use 5266)
5383              2 1/6" x 3 1/2"         2               8
5384              3"  x  4"               2               6
5385              2 1/6" x 4"             2               8
5386              3"  x  5"               1               3
5388              3"  x  5"               1               3
5389              4"  x  6"               1               2
5395              2 1/3" x 3 3/8"         2               8
5660              1" x 2 5/8"             3               30
5662              1 1/3" x 4 1/4"         2               14
5663              2" x 4 1/4"             2               10
5766* (use 5266)
5883              2 1/6" x 3 1/2"         2               8
5895              2 1/3" x 3 3/8"         2               8
5896              2 3/4" x 2 3/4"         3               9
5897              1 1/2" x 4"             2               12

International Labels in Millimeters and Inches
----------------------------------------------

Product Code   Label Size        Number of Columns    Labels Per Sheet
------------   ----------        -----------------    ----------------

7160           38.1mm x 63.5mm         3                 21
               (1 1/2") x (2 1/2")
7161           46.56mm x 63.5mm        3                 18
               (1.83") x (2 1/2")
7162           33.87mm x 99.06mm       2                 16
               (1 1/3") x (3.90")
7163           38.10mm x 99.06mm       2                 14
               (1 1/2") x (3.90")
7164           71.97mm x 63.5mm        3                 12
               (2.83") x (2 1/2")
7165           67.73mm x 99.06mm       2                 8
               (2 2/3") x (3.90")
7166           93.13mm x 99.06mm       2                 6
               (3 2/3") x (3.90")
7167           289.05mm x 199.60mm     1                 1
               (11 1/3") x (7.85")
7562           33.87mm x 99.06mm       2                 16
               (1 1/3") x (3.90")
7563           38.10mm x 99.06mm       2                 14
               (1 1/2") x (3.90")
7565           67.73mm x  99.06mm      2                 8
               (2 2/3") x (3.90")
7651           21.17mm x 38.1mm        5                 65
               (0.83") x (1 1/2")
7654-F         46.58mm x 76.2mm        2                 12



               (1.83") x (3")
7654-S         16.93mm x 144.78mm      1                 16
               (0.67") x (5.69")

Notes
-----

There are several Avery numbers whose specifications match other
numbers in the list. The different numbers are caused by packaging
quantities, label colors, or similar factors that do not affect the
layout of the labels.

Label sheets 5096, 5196, and 5896 contain 12 small labels at the
bottom in addition to the nine referenced in the list above. These
labels are not included in the automatic setup of the label sheet.

If the labels you use contain printed borders, you may need to adjust
the paragraph formatting of the information contained in the table
cells with the following steps:

1. Use the MAILLABL template to set up your labels as desired.

2. From the Table menu, choose Select Table.

3. From the Format menu, choose Paragraph. Use the Indentation From
   Left setting to position the text away from the left side of the
   labels.

If you need to move the text down in each cell, you must do this
individually for each cell. You can either add blank lines above the
first line in each cell, or use paragraph formatting to set spacing
above the first line in each cell.

REFERENCES
==========

Avery, Commercial Product Division: back of Avery Laser Label retail
box

Additional reference words: w4wlaserjet w4wmerge 2.00 2.00a 2.00a-cd 
2.00b 2.00c 2.00c-cd third party 3rdparty cross w4wtemplate



WinWord 2.0: Avery Dot-Matrix Label Information
Article ID: Q81938
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

The following is a reproduction of the information found on the back
of the retail package of Avery Dot Matrix Labels. The MAILLABL.DOT
file, which is a mailing label template that ships with  Microsoft
Word for Windows versions 2.0 and 2.0a, gives only the option to
choose Laser Labels when running Microsoft Windows version 3.0. The
template provides the Avery Product Code and a brief description of
each label. The template does not list the dimensions for each label,
which makes the template difficult to use if you do not have Avery
brand labels.

NOTE: In Word for Windows version 6.0, the dimensions of the Avery 
labels are included as part of the label feature.

MORE INFORMATION
================

Avery Dot Matrix Labels
-----------------------

Product Code   Label Size (HxW)   Number of Columns
------------   ----------------   -----------------

4010           15/16" x 3 1/2"         1
4011           1 7/16" x 4"            1
4013 (use 4145)
4065 (use OML 101)
4143           15/16" x 4"             2
4144           15/16" x 2 1/2"         3
4145           15/16" x 3 1/2"         1
4146           1 7/16" x 4"            1
4160           2 7/16" x 3 1/2"        1
4161           2 15/16" x 4"           1
4162           15/16" x 3 1/2"         1
4163           15/16" x 3 1/2"         1
4166           5" x 3"                 1
4167           6" x 3 1/2"             1
4168           4" x 2 1/6"             1
4169           5" x 3"                 1
4240           1 1/4" x 4 3/4"         1
4241           2 3/4" x 2 3/4"         1
4249           15/16" x 3 1/2"         1
4250           15/16" x 3 1/2"         1



4251           15/16" x 3 1/2"         1
4253           15/16" x 3 1/2"         1
4254           15/16" x 3 1/2"         1
4255           7/16" x 3 1/2"          1
4256           7/16" x 3 1/2"          1
4257           7/16" x 3 1/2"          1
4258           7/16" x 3 1/2"          1
4259           7/16" x 3 1/2"          1
4266           7/16" x 3 1/2"          1
4301 (use 4603)
4400 (use 4010)
4600           15/16" x 3 1/2"         1
4601           15/16" x 3 1/2"         1
4602           15/16" x 3 1/2"         2
4603           15/16" x 3 1/2"         3
4604           1 7/16" x 4"            1
4605           1 7/16" x 4"            2
4606           1 1/4" x 4 3/4"         1
4607           2 3/4" x 2 3/4"         1
4609           3/8" x 1 1/2"           5
4610           15/16" x 2 1/2"         3
4611           15/16" x 4"             2
4612           2 15/16" x 4"           2

International (UK) Labels in Millimeters & Inches
-------------------------------------------------

Product Code   Label Size (HxW)   Number of Columns
------------   ----------------   -----------------

OML 099        49mm x 70mm             1
               (1 15/16)" x (2 3/4")
OML 101        24mm x 102mm            1
               (15/16") x (4")
OML 102        37mm x 102mm            1
               (1 7/16") x (4")
OML 103        49mm x 102mm            1
               (1 15/16") x (4")
OML 104        37mm x 127mm            1
               (1 7/16") x (5")
OML 105        49mm x 127mm            1
               (1 15/16") x (5")
OML 202        37mm x 102mm            2
               (1 7/16") x (4")
OML 203        49mm x 102mm            2
               (1 15/16") x (4")
EAL 04         37mm x 89mm             2
               (1 7/16") x (3 1/2")
FAB 03         36.1mm x 69mm           2
               (1 7/16") x (2 3/4")

International (French) Labels in Millimeters & Inches
-----------------------------------------------------

Product Code   Label Size (HxW)   Number of Columns
------------   ----------------   -----------------



Tab1 89.23     23.40mm x 89.0mm        1
               (0.92") x (3 1/2")
Tab1 89.36     36.1mm  x 89mm          1
               (1.42") x (3.5")
Tab1 102.36    36.1mm  x 102mm         1
               (1.42") x (4.01")
Tab1 107.23    23.4mm  x 107mm         1
               (0.92") x (4.21")
Tab1 107.36    36.1mm  x 107mm         1
               (1.42") x (4.21")
Tab1 107.49    48.8mm  x 107mm         1
               (1.92") x (4.21")
EXPE 120.74    74.0mm  x 120           1
               (2.91") x (4.72")
Tab1 125.74    74.0mm  x 125mm         1
               (2.91") x (4.92")
Tab2 89.23     23.4mm  x 89mm          2
               (0.92") x (3.50")
Tab2 89.36     36.1mm  x 89mm          2
               (1.42") x (3.50")
Tab2 107.23    23.4mm  x 107mm         2
               (0.92") x (4.21")
Tab2 107.36    36.1mm  x 107mm         2
               (1.42") x (4.21")
Tab1 85.108    108mm   x 85mm          1
               (4.25") x (3.34")

Note: If the labels you use contain printed borders, you may need to
adjust the paragraph formatting of the information contained in the
table cells as follows:

1. Use the MAILLABL template to set up your labels as desired.

2. From the Table menu, choose Select Table.

3. From the Format menu, choose Paragraph. Use the Indentation From
   Left setting to move the text away from the left side of the labels.

If you need to move the text down in each cell, you must do this
individually for each cell. You can either simply add blank lines
above the first line in each cell, or use paragraph formatting to set
spacing above the first line in each cell.

REFERENCES
==========

Avery, Commercial Product Division: back of Avery Laser Label retail
box

Additional reference words: w4wlaserjet w4wmerge 2.00 2.00a 2.00a-cd 
2.00b 2.00c 2.00c-cd third party 3rdparty cross w4wtemplate



Printing Labels on the Toshiba 351 Causes Premature Form Feed
Article ID: Q87126
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you print labels using the Toshiba P351 universal printer driver
version 1.1 when you are running Microsoft Word for Windows in
Microsoft Windows operating system version 3.1, Word sends a form feed
after the first three labels are printed. This problem is caused by
the Toshiba P351 printer driver (TOSHIBA.DRV).

More Information:

Workaround
----------

You can use a PRINT field at the top of the print merge main document
to set the correct form length for your labels. To do this, use the
following steps:

1. Open the print merge main document.

2. At the beginning of the document, insert the following PRINT field:

      {PRINT "<ESC>F18"}

Note: To create the field characters {}, press CTRL+F9. To create the
<ESC> character, press ALT+027 on the numeric keypad.

The number following <ESC>F (18 in the sample PRINT field above) is
the form length in 1/6-inch (or one-line) increments. To determine the
correct number for your labels, choose Page Layout from the Format
menu, select the Size And Orientation option button, and multiply the
value in the Height box by six. The result is the form length you
should type in the PRINT field. For example, if you use Avery label
No. 4145, the page Height is set to 3 inches; therefore, 18 is the
value you type in the PRINT field.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 657-665

Additional reference words: 2.00 2.00a 3.10 p 351 p-351 win31 phoneref 
6.00 wm_word 
w4wmerge w4wprint



WinWord: Print Merge Produces a Full Page of Labels
Article ID: Q88374
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

If you select a range of records when you are performing a print merge
to create mailing labels, Microsoft Word for Windows merges a full
page of labels. The first record on the page is the first record of
the selected range, but Word for Windows continues merging labels
until the page is filled, rather than stopping with the last record of
the selected merge range. The print merge operation creates full pages
only when you create mailing labels, even if the selected range does
not fill the entire page.

For example, if your mailing label main document contains 30 labels
and you choose to merge records 1 through 20, Word for Windows merges
records 1 through 30 to create a full page of labels. Similarly, if
you choose to merge records 1 through 40, Word for Windows merges
records 1 through 60 to create two full pages of labels.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this problem
and will post new information here in the Microsoft Knowledge Base as it
becomes available.

MORE INFORMATION
================

To work around this problem, use one of the following methods:

Workaround 1
------------

1. In place of a merge field, insert the following IF field in your
   print merge main document:

      {IF {MERGEREC} <= {MAXRECORDS} {MERGEFIELD FIELD1}}

2. Insert the following field at the start of your print merge main
   document:

      {SET MAXRECORDS N}

   where "N" is the number of records to merge. For example, if you want



   to print records 1 through 20, N=20.

3. From the File menu, choose Print Merge. Choose the Merge button. In
   the Print Records box, type the range of records and choose the OK
   button.

Workaround 2
------------

1. In your print merge data document, add a field named "Rec_Num." For
   information on adding a new field to a data file, refer to page 618 of
   the "Microsoft Word for Windows User's Guide."

2. Use the Rec_Num field to number the records in your data document.

3. Activate the mailing label main document.

4. From the File menu, choose Print Merge. Choose the Merge button.

5. Choose the Record Selection button.

6. In the Field Name box, select Rec_Num. In the Is box, select Less
   than or Equal to. In the Compared To box, type "5" (without the
   quotation marks). Choose the Add Rule button.

7. In the Field Name box, select Rec_Num. In the Is box, select
   Greater than or Equal to. In the Compared To box, type "2" (without
   the quotation marks). Choose the Add Rule button.

8. Choose the OK button.

9. Complete the print merge.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, page 618

"Microsoft Word for Windows User's Reference," version 1.x, pages 1-3,
197-200

Additional reference words: 6.00 w4wmerge 1.00 1.10 1.10a 2.00 2.00a wm_word 
2.00a-CD



How to Use Wildcards to Perform Selective Print Merge
Article ID: Q88679
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you can use the asterisk (*) and the
question mark (?) wildcard characters as part of a selective print
merge operation. These wildcards function in Word for Windows similar
to the way they function in Microsoft MS-DOS (that is, they act as a
substitute for a letter, number, or string).

MORE INFORMATION
================

The asterisk (*) wildcard character represents a whole word or a group
of characters, regardless of length. For example, "D*" (without the
quotation marks) represents any group of characters that begins with
the letter D, regardless of the length of the string. And, "*D"
represents any group of characters that ends with the letter D,
regardless of its length.

Note: You cannot search for a string that both begins with an asterisk
and ends with an asterisk; therefore, "*D*" is an invalid selection
criteria.

The question mark (?) wildcard represents a single character. For
example, "?D" represents any string that contains one character before
the letter D, such as "ID." And, "?D?" represents any string with one
character before and one character after the letter D, such as "IDE."

While the asterisk (*) wildcard character can successfully merge data
that begins with numbers, the question mark (?) wildcard character
cannot. For example, you could use "98*" during a print merge, but not
"98???".

Using Wildcards to Perform Selective Print Merge
------------------------------------------------

Note: In the following samples, create the field braces by pressing
CTRL+F9.

 - To select records whose First_Name merge field begins with "D", use
   the following syntax in your print merge main document:

      {if {First_Name}="D*" "{First_Name}"}

 - To select records whose First_Name merge field ends with "D":



      {if {First_Name}="*D" "{First_Name}"}

 - To selectively merge those records whose First_Name merge field
   begins with "D" and contain four characters:

      {if {First_Name}="D???" "{First_Name}"}

Note: In a Word for Windows print merge operation, the characters
inside the quotation marks are case sensitive. In the above examples,
records whose First_Name merge field contains "D" would be found,
whereas records whose First_Name merge field contains "d" would not be
found.

For information on using wildcards to perform a selective print merge
in which a numeric character follows the wildcard, query on the
following words in the Microsoft Knowledge Base:

   numeric and w4wmerge and wildcard and incorrect

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 637-644

"Microsoft MS-DOS User's Guide and Reference," version 5.0, pages 73-75

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD wild
card cards w4wmerge w4wfield pmh helper conditional



Incorrect Results Using Wildcards in Selective Print Merge
Article ID: Q88774
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

If you use wildcard characters, such as the asterisk (*) or question
mark (?), in the criteria for a selective print merge operation, the
results of your print merge may be incorrect or incomplete. This
problem occurs if you use wildcards followed by an ordinal number in
numeric format to define the selection criteria in the NEXTIF, SKIPIF,
or IF fields.

MORE INFORMATION
================

Word for Windows evaluates ordinal numbers in numeric format, such as
24th or 21st, as integers instead of text. This leads to incorrect
print merge results when an ordinal number follows a wildcard.

For example, the following statements may produce incomplete or
incorrect print merge results because a numeric ordinal number follows
the wildcard (?):

   {skipif {MERGEFIELD address} <> "????24th Ave."}
   {nextif {MERGEFIELD address} <> "????21st Ave."}

However, the following statements produce correct and complete print
merge results because non-ordinal alphabetic or numeric characters, or
ordinal numbers in alphabetic format follow the wildcard (?):

   {skipif {MERGEFIELD address} <> "????Microsoft Way"}
   {nextif {MERGEFIELD address} <> "????39 Stars Street"}
   {nextif {MERGEFIELD address} <> "????Twenty-First Street"}

Workarounds
-----------

To work around this behavior, change the syntax of numeric records to
alphabetic. The following is an example:

   "235 24th Ave." becomes "235 Twenty-Fourth Ave."
   "235 21st Ave." becomes "235 Twenty-First Ave."

 -or-

In the data document, place the data that contains a numeric ordinal
number in a separate field so that it can be evaluated without using



wildcard characters. The following is an example:

   -----------------------            ------------------------------
   |ADDRESS              |            |STREET1   | STREET2         |
   |---------------------|  becomes   |----------|-----------------|
   |235 24th Ave.        |            |235       | 24th Ave.       |
   |---------------------|            |----------|-----------------|
   |235 21st Ave.        |            |235       | 21st Ave.       |
   -----------------------            ------------------------------

For more information on using wildcards to perform a selective print
merge in Word for Windows, query on the following words in the
Microsoft Knowledge Base:

   w4wmerge and wildcard and selective and records

Additional reference words: 6.00 2.00 2.00a 2.00a-CD w4wmerge conditional 
wm_word 



Word: Print Merge Does Not Include Tables or Graphics
Article ID: Q89314
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When you perform a print merge in Word for Windows, any table or
linked graphic that is the result of a conditional IF field is not
displayed in the resulting merged documents. To use tables or linked
graphics as the result of a conditional print merge statement, use the
appropriate method below.

This functionality was changed in Word version 6.0 for Windows.

Merging the Table or Graphic Directly
-------------------------------------

Use this method when you want to print only the table or graphic.

Define a glossary entry that contains the table or linked
graphic, then conditionally merge one of two glossaries.

1. Select the table you want to merge and choose Glossary from the
   Edit menu. Type "table" (or another appropriate name, without the
   quotation marks) as the glossary name and choose the Define button.

2. Select the text or field that you want to merge if the condition is
   false. Choose Glossary from the Edit menu. Type "false" (or another
   appropriate name, without the quotation marks) as the glossary name
   and choose the Define button.

3. Insert a field with the following syntax:

      {GLOSSARY {IF <CONDITION><OP>"<CONDITION>" "TRUE GLOSSARY NAME"
      "FALSE GLOSSARY NAME"}}

      For example:

      {GLOSSARY {IF {MERGEFIELD EMPLOYEES}>="100" "TABLE" "FALSE"}}

4. Select the field and press the F9 key before you perform the print
   merge the first time (it should only be necessary to update the
   field only once).

   Note: You must have a glossary defined for the false result or the
   error message

      Error! No glossary entry specified



   will appear in place of the field when you merge. If you want no
   result when the condition is false, define some hidden text as your
   false glossary (be sure you do not include a paragraph mark in the
   glossary entry).

Merging a Document That Contains a Table or Graphic
---------------------------------------------------

Use this method when the table or graphic is part of another document
you insert using an INCLUDE field.

Page 643 of the "Microsoft Word for Windows User's Guide" gives
instructions for including a document during a print merge. If the
included document contains tables and/or graphics, they do not display
in the resulting merged documents when you follow these instructions.

If you reverse the order of the nested fields so the IF conditional
field is nested within the INCLUDE field, Word for Windows displays
the tables and graphics correctly.

A field with the following syntax will allow Word to evaluate a
condition and include one of two documents. Either document may
contain tables or graphics.

   {INCLUDE {if <CONDITION><OP>"<CONDITION>" "TRUE FILENAME" "FALSE
   FILENAME"}}

Note: You must specify a file for Word to include, even when the
condition is false. If no file is specified for Word to import when
the condition is false, the following error message prints on the form
letter:

   Error! Filename Not Specified

The following are examples of the fields for versions 2.x and versions
1.x  of Word for Windows.

Word for Windows versions 2.0, 2.0a, 2.0a-CD, and 2.0b
------------------------------------------------------

   {INCLUDE {IF {MERGEFIELD order}>"100" "C:\\DIRNAME\\LETTER1.DOC"
   "C:\\DIRNAME\\LETTER2.DOC"}}

Using this field, Word for Windows includes the text in LETTER1.DOC if
the amount in the data field "order" is more than 100. If the amount
of the order is less than 100, Word will include LETTER2.DOC. Any
table or graphic in LETTER1.DOC or LETTER2.DOC will be correctly
displayed in the resulting merged documents.

Word for Windows versions 1.0, 1.1, and 1.1a
--------------------------------------------

   {INCLUDE {IF {REF order}>"100" C:\\DIRNAME\\LETTER1.DOC
   C:\\DIRNAME\\LETTER2.DOC}}

Reference(s):



"Microsoft Word for Windows User's Guide," version 2.0, pages 268-271,
639-645

Additional reference words: docerr 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD
w4wtable 2.00b w4wmerge w4wfield missing



WinWord: Word Returns to Main Document After Opening Data File
Article ID: Q89510
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In a Microsoft Word for Windows print merge main document, when you
choose the Edit Data File button on the print merge bar, Word for
Windows sometimes opens the data file and then immediately returns to
the main document window. This problem will occur if your main
document contains an AutoOpen macro, which runs when Word for Windows
opens the data document. To edit the data file, you must choose the
Edit Data File button again.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

The AutoOpen macro runs only if the data file is not open in Word for
Windows when you choose the Edit Data File button. If you choose the
Edit Data File button while the data document is open in Word for
Windows, the AutoOpen macro is not activated and Word does not return
immediately to the main document. As a result, you should only
experience this problem the first time you choose the Edit Data File
button in any Word session.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b datafile
w4wmacro w4wmerge pmh



WinWord: How to Use Dates as Print Merge Selection Criteria
Article ID: Q89532
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you can perform a selective print merge
based on a list of dates. You can selectively print merge based on
such criteria as a group of months, days of months, years or
combinations of all three. For example, you can perform a selective
print merge based on a list of names and birthdates.

In addition, you can instruct Word for Windows to change the date
format of data in the merged document.

MORE INFORMATION
================

To use the selective merge function:

1. Set up the data document. For example:

      FRIENDS,BIRTHDATE
      Raquel Tejeda,10-5-1940
      Norma Jean Baker,6/1/1926
      Marion Michael Morrison,5/26/1907

   Note: You can use either backslashes or dashes in the dates. If
   your data document is formatted as a table, you can also spell out
   the date (for example, "June 1, 1926").

2. Set up the main document:

   a. {if {MERGEFIELD Birthdate \@ "MMMM"}="October" "{MERGEFIELD
      Friends} {MERGEFIELD Birthdate \@ "MMMM d, yyyy"}"}

      This example merges records for people born in October. The
      Birthdate field is formatted as "October 5, 1940", regardless
      of the data format of the data document (October 5, 1940, or
      10/5/1940, or 10/5/40).

   b. {if {MERGEFIELD Birthdate \@ "MM"}="10" "{MERGEFIELD Friends}
      {MERGEFIELD Birthdate}"}

      This example works the same as example a, except that the Birthdate
      prints exactly as it appears in the data document.

   c. {if {MERGEFIELD Birthdate \@ "yy"}="40" "{MERGEFIELD Friends}



      {MERGEFIELD Birthdate \@ "MM dd, yy"}"}

      This example merges records for people born in 1940. The Birthdate
      field is formatted as "10/5/40."

   d. {if {MERGEFIELD Birthdate \@ " yyyy"}="October 5, 1940"
      "{MERGEFIELD Friends} {MERGEFIELD Birthdate \@ "d-MMM-yy"}"}

      Same result as example 3 above, except that the Birthdate prints in
      "5-October-40" format.

   e. {if {MERGEFIELD Birthdate \@ "MMMM d, yyyy"}="October 5, 1940"
      "{MERGEFIELD Friends} {MERGEFIELD Birthdate}"}

      Merges only the records of people born on October 5, 1940.

The above examples do not illustrate all possible selective merge
combinations or date formats. To view all possible DATE field
switches, choose field from the Insert menu. In the Insert Field Type
box, select Date. All the possible date switch combinations appear in
the Instructions box.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 609-656,
751

Additional reference words: 6.00 2.00 2.00a 2.00a-CD 2.00b w4wfield wm_word 
w4wmerge conditional pmh



Comma in Quoted Text Causes Conversion to Two Columns in Table
Article ID: Q89831
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In a Word for Windows comma- or tab-delimited document, when a quoted
text field contains a comma (used as punctuation), Word for Windows
breaks the quoted text into two columns when you convert it to a
table. The text to the left of the comma is placed in the first column
and the text to the right of the comma is placed in the second column.
This occurs because Word for Windows does not differentiate between
commas used as delimiters and commas used as punctuation.

When you convert such text to a table, you must merge the two columns
with the Merge Cells command.

MORE INFORMATION
================

The following is a sample comma-delimited data document:

   Andy Slagg,"Ashland, OR",97520
   Walt Moore,"Santa Monica, CA",97007
   Dave Fay,"Bellevue, WA",98005

The following table resembles the table you would get by selecting the
text above and choosing Insert Table from the Table menu (in versions
1.0, 1.1 and 1.1a of Word for Windows, choose Table from the Insert
menu):

   ----------------------------------------------
   |Andy Slagg   |"Ashland       |OR"    |97520  |
   |Walt Moore   |"Santa Monica  |CA"    |97007  |
   |Dave Fay     |"Bellevue      |WA"    |98005  |
   ----------------------------------------------

If Word for Windows converted the text in quotation marks correctly,
the table would look like this:

   -------------------------------------------
   |Andy Slagg   |Ashland, OR        |97520  |
   |Walt Moore   |Santa Monica, CA   |97007  |
   |Dave Fay     |Bellevue, WA       |98005  |
   -------------------------------------------

Workaround
----------



1. In the comma-delimited data file, select all the data records.

2. From the Table menu, choose Insert Table.

3. To merge the two columns that contain the separated data, select
   both columns and choose Merge Cells from the Table menu. Note that
   Word for Windows inserts a paragraph mark in the text of the merged
   columns.

4. From the Edit menu, choose Replace. In the Find What box type "^p"
   (without the quotation marks). In the Replace With box type ", " (a
   comma and a space, without the quotation marks). Choose the Replace
   All button.

5. In the Find What box, type a quotation mark ("). Clear the contents
   of the Replace With box (it should be blank). Choose the Replace
   All button. Choose the Close button.

Reference:

"Word for Windows User's Guide," version 2.0, pages 257-258, 265, 314-
318

Additional reference words: 6.00 2.00 2.00a 2.00a-CD 2.00b w4wmerge
1.00 wm_word w4wtable 1.10 1.10a split breaks broken



WinWord: Use of ASK and FILLIN Fields and \o Switch
Article ID: Q90010
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:
 
This article discusses the following issues regarding the use of ASK
and FILLIN fields in a Word for Windows print merge operation:
 
 - Using the \o switch to cause Word to prompt you only once for
   input.
 
 - Choosing the Cancel button or pressing ESC when prompted for ASK or
   FILLIN input.
 
 - How to print the results of ASK and FILLIN fields while suppressing
   blank lines in your merged documents.
 
More Information:
 
ASK Field
---------
 
The ASK field prompts you to type text, which it assigns to a bookmark
name. During a print merge, the ASK field prompts you for input before
printing each merged document, which allows you to customize each
merged document. The ASK field itself has no result; the result is
assigned to the bookmark. You must insert a separate field to
reference the bookmarked information you typed in response to the ASK
prompt. Example:
 
   {ASK BookmarkName "Message Text"}{REF BookmarkName}
 
In this example, the ASK field prompts you for input, which it assigns
to the bookmark named BookmarkName. The REF field inserts the input in
your merged document.
 
FILLIN Field
------------
 
The FILLIN field prompts you for text that is used as the FILLIN field
result. During a print merge, the FILLIN field prompts you for input
before printing each merged document, which allows you to customize
each merged document.
 
Using the \o Switch
-------------------
 
When you add the \o switch to a Word for Windows FILLIN or ASK field,



Word for Windows prompts for input only once, before printing the
first document during a print merge, rather than once for each print
merge document. Word for Windows uses the same information in each
merged document. Examples:
 
   {FILLIN "Batch Number" \o}
   {ASK BookmarkName "Message Text" \o}{REF BookmarkName}
 
What Happens When You Choose the Cancel Button or Press ESC?
------------------------------------------------------------
 
If you previously typed something in the ASK or FILLIN field dialog
box, that text remains in the dialog box for the next prompt. If you
choose the Cancel button (or, in Word for Windows version 2.0, press
the ESC key) to skip an ASK field, Word uses the previously-typed text
as the current value of the ASK field bookmark.
 
Note: In versions 1.0, 1.1, or 1.1a of Word for Windows, if you press
ESC in an ASK or FILLIN field dialog box, the print merge stops.
 
Canceling an ASK or FILLIN field dialog box only cancels the prompt
for input; it does NOT delete the previously-typed input. If you don't
want any value assigned to a FILLIN field or to an ASK field bookmark,
you must press the DEL key to delete the previously-typed text, and
then choose the OK button. In Word version 6.0, a space must be
inserted to create blank results
 
ASK and FILLIN Field Results Don't Print If You Suppress Blank Lines
--------------------------------------------------------------------
 
In versions 2.0, 2.0a, 2.0a-CD, and 2.0b of Word for Windows, the
result of a FILLIN field or ASK field bookmark is not inserted in your
merged document if you check the Skip Completely option under
Treatment of Blank Lines Caused by Empty Fields in the Print Merge
dialog box. In other words, suppression of blank lines by the Word for
Windows Print Merge Helper cancels the result of an ASK or FILLIN
field.
 
Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
2.0a-CD, and 2.0b of Word for Windows. We are researching this problem
and will post new information here as it becomes available.
 
Workarounds
-----------
 
 - If you are not concerned with blank lines appearing in your merged
   documents, select the Print Blank Lines option in the Print Merge
   dialog box.
 
   -or-
 
 - If you want to suppress the printing of blank lines, insert a
   conditional IF statement. When you perform the print merge, select 
   the Print Blank Lines option in the Print Merge dialog box. In the 
   example below, a blank link resulting from an empty {company} field 
   is suppressed with the following instructions:
 



   {MERGEFIELD name}
   {IF {company}<>"" "{company}[SHIFT+ENTER]
   "}{FILLIN "Batch Number" \o}
 
Note: Press SHIFT+ENTER to create a newline character. Do not type
"[SHIFT+ENTER]" in the field. Press CTRL+F9 to create the field
brackets.
 
For more information on ASK and FILLIN fields:
 
 - Search for "fields: print merge", "ask field", or "fillin field"
   using the Help menu in version 2.0 of Word for Windows.
 
Reference(s):
 
"Microsoft Word for Windows User's Guide," version 2.0, pages 646-651
 
Additional reference words: w4wmerge w4wfield 1.00 1.10 1.10a 2.00
2.00a 2.00a-CD 2.00b pmh missing appear data 6.0 wm_word



Print Merge Error Message: Syntax Error in Field Condition
Article ID: Q90460
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Word for Windows, the following error messages occur during a print
merge operation if a condition is missing from a NEXTIF, IF, or SKIPIF
field or if the field does not contain proper spacing:

   There is a syntax error in a field condition.

   Syntax error in field condition.

More Information:

Use NEXTIF, IF, and SKIPIF fields in a print merge main document to
specify the conditions under which a record should be merged. In the
following example, Word for Windows only merges records if the ZIP
field contains "98008:"

   {NEXTIF zip = 98008}
   {name}
   {street}
   {city}, {state} {zip}

Missing Condition
-----------------

Switch to field codes view and verify that each NEXTIF, IF, and SKIPIF
field in the document contains a condition. If you do not specify a
condition, the error messages occur and the print merge operation
stops.

The following example demonstrates an incorrectly used NEXTIF field:

   {NEXTIF zip}

The following example demonstrates a correctly used NEXTIF field:

   {NEXTIF zip = 98008}

Incorrect Spacing
-----------------

The error messages occur if the spacing in any NEXTIF, IF, or SKIPIF
field is incorrect. Each field must contain a space between each
expression and the operator. In the following example, there must be a
space between "NEXTIF" and "zip", between "zip" and "=" and between



"=" and "98008":

   {NEXTIF zip = 98008}

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 640-641,
753

"Microsoft Word for Windows User's Reference," version 1.x, pages 199,
424

Additional reference words: w4wmerge  1.00 1.10 1.10a 2.00
2.00a 2.00a-cd 2.00b errmsg err msg



Print Merge Error Message with Field in Header or Footer
Article ID: Q92569
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Word for Windows, the following error message sometimes occurs when you
check your print merge main document for errors:

   Record does not contain enough fields, or is missing one or more
   commas or tabs.

Word displays this error message for each of the first ten data records.

CAUSE
=====

This happens if your main document contains one of the following fields in
the header or footer:

 - PAGE
 - EQ
 - EMBED
 - TIME
 - DATE
 - GLOSSARY
 - GOTOBUTTON

Even though Word displays the above error message up to ten times, no
errors occur when you perform the print merge operation, and the resulting
merged documents are correct.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

More Information:

You can use the Only Check For Errors option in the print merge helper to



check your main and data documents for potential print merge errors. For
example, Word notifies you if your main document contains a MERGEFIELD
field that is not defined in the attached data file.

WORKAROUND
==========

 - You can unlink some fields, such as EMBED fields, before you check for
   errors without any loss of functionality. For example, if your header or
   footer contains an embedded MS Draw object, unlink the field result;
   this does not prevent you from editing the object in Microsoft Draw. If
   you cannot unlink all fields in your header or footer, use the next
   workaround.

 -or-

 - Because the document merges correctly, you can ignore the error
   messages.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 630-631

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b w4wmerge
 errmsg err msg picture graphic logo



Print Merge Error Using Linked Information As Data Document
Article ID: Q92599
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

In Word for Windows, if you use a document that contains a link to external
information as your print merge data document, errors occur when you
perform a print merge operation. In version 2.0 of Word for Windows, the
following error message occurs:

   Word has detected a field name in the header record that is not valid.
   This error must eventually be corrected to complete a successful print
   merge.

In versions 1.x of Word for Windows, the following error message occurs:

   Not a valid bookmark name

This article describes how you can use information from an external
database in your print merge data document.

This problem was corrected in Word version 6.0 for Windows.

More Information:

The print merge operation fails when your data document contains a link to
an external database (such as Microsoft Excel) because Word for Windows
inserts a paragraph mark before the LINK field (the DDEAUTO field in
versions 1.x of Word for Windows). The paragraph mark renders your data
document invalid.

Word for Windows, versions 2.0, 2.0a, 2.0a-CD, and 2.0b
-------------------------------------------------------

DATAFILE.DOT is a template supplied with Word for Windows that contains
macros you can use in your print merge data document to create a dynamic
link to an external database. These macros insert the LINK field in the
footer and paste the LINK field results in the body of your document. This
eliminates the leading paragraph mark described above.

Note: To minimize memory and Windows resource demands, Microsoft Excel (or
another external database application) should be running while you perform
these steps. If you encounter low-memory error messages, quit and restart
Word for Windows.

Method 1: Link from the Windows Clipboard
-----------------------------------------



1. Start Microsoft Excel and open the data file.

2. Select the range of cells you want to use in your Word for Windows data
document. From the Edit menu, choose Copy.

3. Start Word for Windows. From the View menu, choose Normal.

4. From the File menu, choose New. Select Datafile in the Use Template box
   and choose the OK button.

5. Do one of the following:

    - Choose the L button on the print merge bar.

   -or-

    - From the Tools menu, choose Database Management Tools. Choose the
      Link to Ext. Database button. Choose the Create Link From Clipboard
      button. In the Data Type box, select Formatted Text (RTF) and choose
      the Paste Link button. Choose the Yes button when the following
      message appears:

      Updating the DDE link will delete the contents of your document. Do
      you want to continue?

   -or-

    - From the Edit menu, choose Paste Special. Choose the OK button when
      the following message appears:

         Word does not support standard Dynamic Data Exchange links to
         print merge documents. Use the following dialog box to set up a
         print merge DDE link.

Method 2: Create a Manual Link
------------------------------

1. Repeat steps 1 through 4 from Method 1 above.

2. Do one of the following:

    - Choose the L button on the print merge bar.

   -or-

    - From the Tools menu, choose Database Management Tools. Choose the
      Link To Ext. Database button. Choose the Create Link Manually button.

       Note: If you want Word for Windows to format the data as a table,
       select Rich Text Format in the Data Format box. If you want Word to
       format the data as tab-delimited text, select Unformatted Text in
       the Data Format box.

   -or-

    - From the Edit menu, choose Paste Special. Choose the OK button when
      the following message appears:



      Word does not support standard Dynamic Data Exchange links to
      print merge documents. Use the following dialog box to set up
      a print merge DDE link.

3. Choose the Yes button when the following message appears:

      Updating the DDE link will delete the contents of your document.
      Do you want to continue?

Note on Methods 1 and 2
-----------------------

Word for Windows does not automatically update the links you created using
Methods 1 and 2 above. Use the steps below to manually update the links:

1. Open the data document you created in Methods 1 and 2 above.

2. Do one of the following:

    - Choose the L button on the print merge bar.

   -or-

    - From the Tools menu, choose Database Management Tools. Choose the
      Link To Ext. Database button.

3. Choose the Update Current Link button. Choose the Yes button when the
   following message appears:

      Updating the DDE link will delete the contents of your document.
      Do you want to continue?

Word for Windows, Versions 1.0, 1.1, and 1.1a
---------------------------------------------

There is no way to use a linked document as a print merge data file in
versions 1.x of Word for Windows, so you must create your data file using
one of the following workarounds:

 - Save the Excel file in either Excel 2.1 format or as a comma-delimited
   text file and use that file as the print merge data document.

-or-

 - Instead of choosing Paste Link from the Edit menu, choose Paste to make
   an unlinked copy of the Excel document in the Word for Windows data
   document.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 616-624

"Microsoft Word for Windows User's Reference," pages 197-200, 201-203

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
w4wmerge pmh helper  err msg errmsg





Embedded Object Opens in MS Draw from Merged Document
Article ID: Q93734
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

If your print merge main document contains an embedded object, Word for
Windows unlinks the EMBED field and inserts the field result in the merged
document as a graphic image. As a result, if you double-click the image in
the merged document, Word launches Microsoft Draw instead of the original
server application.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wmerge
w4wfield ole equation editor art graph chart client linking embedding



Cannot Replace Next Page Section Break Followed by Table
Article ID: Q94130
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

If your Word for Windows document contains a next-page or continuous
section break followed by a table and there is no paragraph mark
between the section break and the table, you cannot find or replace
that section break using the Replace command. 

WORKAROUND
==========

If you want to replace such section breaks, insert a paragraph mark
between the table and section break.

STATUS
======

Microsoft has confirmed this to be a problem in the above listed
versions of Word for Windows. Microsoft is researching this problem
and will post more information here as it becomes available.

MORE INFORMATION
================

This problem frequently occurs when you create mailing labels for use
in a print merge operation. After you create the mailing labels using
MAILLABL.DOT, you may unsuccessfully attempt to remove the section
breaks from your mailing labels main document using the Replace
command (this is sometimes done to create a mailing list). To replace
these section breaks, you must first position the insertion point at
the top of the main document and insert a paragraph mark above the
first label.

To insert a paragraph mark between a table and preceding section
break, do the following:

1. Position the insertion point at the beginning of the first cell in
   the table.

2. Press CTRL+SHIFT+ENTER.

-or-

From the Table menu, choose Split Table. Word inserts a page break and
a paragraph mark between the section break and the table. Delete the



page break.

Note: If you are removing the section breaks in order to create one
large table, this procedure does not work. Each table will be
separated by a paragraph mark that you cannot remove using the Edit
Replace command. You can manually delete these paragraph marks or, if
your table does not contain other paragraph marks, you can use the
Edit Replace command to search for the paragraph marks and replace
them with paragraph marks formatted for Exactly 0.1-inch line
spacing.

Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
2.0a-CD, 2.0b, and 2.0c of Word for Windows. We are researching this
problem and will post new information here as it becomes available.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 257-258, 262-
266

Additional reference words: w4wtable w4wmerge
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Typing Two-Digit Number in From Box Cancels Print Merge
Article ID: Q95615
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   and 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

Word for Windows incorrectly cancels a print merge operation if you
choose the Record Selection button, choose the OK button, and then type
a two-digit number in the From box in the Print Merge dialog box.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

WORKAROUND
==========

This problem does not occur if you select the All Print Records option
or if you type a single-digit number in the From box.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. From within a print merge main document, choose Print Merge from
   the File menu. Choose the Merge button.

2. Choose the Record Selection button and then choose the OK button.

    -or-

   Choose the Record Selection button, add a rule and then choose the
   OK button.

3. In the Print Merge dialog box, select the From option. In the From
   box, type a two-digit number (such as 15). As soon as you type the
   second digit (this can be any character or number), the Print Merge



   dialog box closes and the print merge operation stops.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wmerge



How to Save Disk Space when Using Inserted Objects
Article ID: Q95656
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

In Word for Windows, inserted objects use up a large amount of disk
space. For objects that you use repeatedly in the same type of
document (such as a graphic in letterhead), you can save disk space by
placing the object in a print merge data file. You can then set up
your document as a print merge main document and insert a MERGEFIELD
field to reference the object in the data document. To print the
document, choose the Print Merge command from the File menu (instead
of the Print command).

To create a letterhead template that contains a graphic at the top of
the page, use the following procedure.

To create the data file:

1. Create a new document based on the NORMAL template.

2. Type a field name such as "graphic" (without the quotation marks)
   and press the ENTER key.

3. From the Insert menu, choose Picture. Select the graphic you want
   to appear on the letterhead and choose the OK button.

4. You now have a valid data file that contains one field named
   "graphic" and one data record (the graphic). Save and close this
   file.

To create the main document:

1. Create a new document based on the NORMAL template.

2. From the File menu, choose Print Merge.

3. Choose the Attach Data File button. Select the data file you
   created in the above section and choose the OK button.

4. Choose the Insert Merge Field button on the print merge bar. Choose
   the OK button to insert the graphic MERGEFIELD field in your
   document. The graphic now appears at the top of your document.

5. Type any other boilerplate text you want to appear in your
   document.



6. From the File menu, choose Save. Select Document Template from the
   Save File As Type list. In the File Name box, type a filename with
   a .DOT extension (for example, LETHEAD.DOT) and choose the OK
   button.

7. Close the template file.

To use the template:

1. From the File menu, choose New.

2. In the Use Template box, select the template you created in the
   section above (such as LETHEAD.DOT) and choose the OK button.

3. Type the letter.

4. Save the file. Notice that a MERGEFIELD field appears in place of
   the graphic.

5. To print the letter, choose the Merge to Printer on the print merge
   bar.

MORE INFORMATION
================

Another way to save disk space when you are using inserted objects is
to use the LoadSmall and SaveSmall macros from the NEWMACRO.DOC file.
For information on the LoadSmall and SaveSmall macros, query on the
following words in the Microsoft Knowledge Base:

   description and savesmall and loadsmall and w4wmacro

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 612-627

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wmerge
image space large too big filesize size 6.00



EQ, AUTONUM, and SYMBOL Fields Are Blank in Print Merge
Article ID: Q95658
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When you use an EQ, AUTONUM, or a SYMBOL field in a print merge data
document, this field is printed as a blank space in your Word for
Windows merged document.

These fields are printed as blank spaces because when Word performs a
print merge operation it unlinks the fields and places only the result
in the merged documents. Since Word cannot unlink an EQ, AUTONUM, or a
SYMBOL field, it cannot place a result in the merged document; the
missing result appears as a blank space.

Similarly, if you nest a SYMBOL field in an IF field, as in the
following example, the SYMBOL field does not display or print in a
print merge:

   {IF {MERGEFIELD CODE} <> "" "{SYMBOL 183 \f "Symbol"} {MERGEFIELD
   CODE}"}

This problem was corrected in Word version 6.0 for Windows

Workarounds
-----------

For SYMBOL fields:

Instead of inserting a SYMBOL field, create the symbol by pressing
ALT+NNNN (where NNNN is the ANSI character code of the symbol).

For AUTONUM fields:

Instead of using an AUTONUM, AUTONUMLGL, or AUTONUMOUT field, renumber
the paragraphs using one of the options in the Numbered List dialog
box of the Bullets And Numbering command (located on the Tools menu).

For EQ (Equation) fields:

Use the Microsoft Equation Editor to insert the equation as an EMBED
field; the EMBED field will continue to be displayed even after it is
unlinked during a print merge operation.

More Information:

The EQ, AUTONUM, and SYMBOL fields are in a class of fields called
display fields. The result of such fields depends on the presence of



the field. You cannot unlink such fields from their result, so Word
inserts a blank space in place of the result when it unlinks the field
during a print merge operation.

Note: You cannot unlink an EQ, AUTONUM or a SYMBOL field by pressing
CTRL+SHIFT+F9.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wmerge
w4wfield



Word Incompletely Sorts Table Column That Contains a Comma
Article ID: Q95960
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

A column sorts incorrectly in Word for Windows if the Separator option
or Field Number setting in the Tools Sorting dialog box (Utilities
Sorting dialog box in Word versions 1.x) is wrong or if the text
contains more than one type of data delimiter (table, comma, or tab)
recognized by Word. To obtain accurate sorting results, the Separator
option and Field Number setting must be correct in the Sorting dialog
box, and the column must contain only one type of delimiter.

For example, if you sort a table and the text in the key field
contains numbers with commas as thousands separators (such as
1,000,000), Word ignores the text following the first comma and
performs the sorting operation on the text preceding the comma. This
happens because the selection contains two data-delimiter types (table
and comma). In this case, you must delete the commas so the selection
contains a single type of data delimiter.

This problem was corrected in Word version 6.0 for Windows.

More Information:

In Word, you can base your sort on a column of information in a table
or in a comma- or tab-delimited portion of a document. Word for
Windows does not sort correctly if your information contains more than
one kind of data delimiter.

Workaround 1
------------

Change the list separator character using the following steps:

1. Open the Windows Control Panel and choose the International icon.

2. In the Separator box, type a character other than one of the
   delimiter characters, such as a semicolon (;).

  Note: Changing the list separator character may affect some functions
  in other applications such as Microsoft Excel. If this happens, use
  Workaround 2 instead.

Workaround 2
------------

  Note: This workaround produces incorrect sorting results if the 



  column contains more than one kind of data delimiter.

Use the following steps to correctly sort a column: 

1. Open or create a document that contains a table or a comma- or tab-
   delimited selection. Select the column of text on which you want to
   base the sort. For information on selecting a column of text, see
   page 106 in "Microsoft Word for Windows User's Guide."

2. From the Tools menu, choose Sorting (in Word versions 1.x, choose
   Sort from the Utilities menu).

3. For the sorting order, select Ascending or Descending.

4. From the Key Type list, select Alphanumeric, Numeric, or Date as
   appropriate.

5. Although your selected text may not contain any commas or tabs,
   select the Comma or the Tab option button as the separator to
   represent how the selection is separated from the rest of the data.

6. Although your selected text may include only one column of text
   without commas or tabs, type the value in the Field Number box that
   represents the position of the column. For example, if a tab
   precedes the selected column, type 2 in the Field Number box.

7. Choose the OK button.

  Note: If you select incorrect settings in steps 5 or 6 above, Word
  either does not sort the data or sorts it incorrectly.

We are researching this problem and will post new information here in
the Microsoft Knowledge Base as it becomes available.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 299-300

"Microsoft Word for Windows User's Reference," version 1.x, pages 328-
330

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 
2.00c w4wtable w4wmerge



Print Merge Data Document Can Contain More Than 2000 Fields
Article ID: Q96243
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
SUMMARY
=======
 
In theory, a Word for Windows print merge data document can contain an
unlimited number of fields in the header row, even though a main
document cannot contain more than 2000 fields (including MERGEFIELD
fields and other fields). In practice, print merge performance
degrades in proportion to an increase in the number of fields in the
header row. The configuration of your computer and available memory
may also limit the number of fields you can insert in your data
document.

MORE INFORMATION
================

If you create your data document using Microsoft Excel, the maximum
number of data fields is 256. If you use a Word table, the maximum
number of data fields is 31. Use a delimited text format to create a
data document that contains more than 256 data fields.
  
REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 611-622,
811

Additional reference words: 6.00 2.00 2.00a 2.00a-CD 2.00b 2.00c
w4wmerge wm_word datafile.dot operating limitations



Data File Character Formatting Not Retained in Merged Document
Article ID: Q96247
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
In Word for Windows, if a print merge data document contains text with
different character formatting, that text may appear incorrectly in
the merged document. This happens because text merged from the data
file takes on the formatting you apply to the corresponding field in
the main document. As a result, the format of the MERGEFIELD field in
the main document overrides any formatting you applied in the data
document.
 
For example, if you insert a trademark symbol in your data document by
pressing ALT+0226 and formatting the character for the Symbol font,
Word replaces the Symbol font character formatting with that of the
MERGEFIELD field in the main document when you perform the print merge
operation. In the merged document, an accented uppercase A character
appears instead of the trademark symbol (if the MERGEFIELD field is
formatted with a font other than Symbol).
 
Workaround
----------
 
For the data field that contains special character formatting, insert
a REF field in your main document instead of a MERGEFIELD field. For
example, in place of the following MERGEFIELD field
 
   {MERGEFIELD FIELDNAME}
 
insert the following REF field instead:
 
   {REF FIELDNAME}
 
Word retains the data document formatting for the results of the REF
field, which preserves the special character formatting.
 
The drawback to this workaround is that the print merge helper does
not detect errors or suppress blank lines for this field. If you use
this workaround, you must suppress blank lines and resolve any print
merge errors manually for the REF field.
 
For information on suppressing blank lines when not using MERGEFIELD
fields, query on the following words in the Microsoft Knowledge Base:
 
   winword and suppress and blank and line and 1.1
 
Reference(s):



 
"Microsoft Word for Windows User's Guide," version 2.0, pages 153,
628-656
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wfield
monotype sorts symbol wingdings dingbats zapfdingbats w4wmerge changes
changed 6.00 wm_word



Cannot Specify Range When Attaching Microsoft Excel Data File
Article ID: Q96378
----------------------------------------------------------------------
The information in this article applies to:

- Microsoft Word for Windows, versions 2.00, 2.00a, 2.00b, 2.00c
- Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

If a Microsoft Excel spreadsheet is attached to a Word for Windows
print merge main document and the spreadsheet is still an open
document, Word for Windows does not ask you to select a new range of
cells.

This problem was corrected in Word version 6.0 for Windows.

More Information:

A Microsoft Excel spreadsheet can be used as a print merge data file.
In Microsoft Excel a block, or range, of cells can be defined and
given a name. When you attach the Microsoft Excel file to the print
merge main document, Word for Windows prompts you to specify which
range you want to use .

If you want to attach a different range of cells to the same print
merge main document, you must first detach the spreadsheet and then
re-attach it. However, if you leave the spreadsheet file open in Word
for Windows, the dialog box to select a range does not appear, and
Word uses the range that was previously specified.

The Microsoft Excel spreadsheet (data file) remains open in Word if
you choose Edit Data File from the print merge toolbar and then do not
close the document window that is created.

Workaround:

Close the Microsoft Excel document window in Word before re-attaching
the Microsoft Excel file (data file).

Additional reference words: check 2.00 2.00a 2.00b 2.00c w4wmerge



Remove Attachments Unavailable in Print Merge Main Document
Article ID: Q96743
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
In Microsoft Word for Windows, the Remove Attachments button is
unavailable in a print merge main document if that main document is
attached to another main document as a data file and that file is
open. 

For example, if DOC2 is both a main document in relation to DOC3 and a
data document in relation to DOC1, the Remove Attachments button is
unavailable in DOC2 if DOC1 is open. If you want to remove attachments
from DOC2, you must close DOC1 or activate DOC1 and remove DOC2 as an
attached data document.
 
    --------           --------           --------
   |  DOC1  |         |  DOC2  |         |  DOC3  |
   |        |         |        |         |        |
   |        |         |  Main  | ------> |  Data  |
   |  Main  | ------> |  Data  |         |        |
   |        |         |        |         |        |
    --------           --------           --------

This problem was corrected in Word version 6.0 for Windows.
 
 
More Information:
 
Although it is not practical, theoretically you can create a "chain"
of documents using the print merge feature. For example, DOC1 can be a
print merge main document with DOC2 attached as the data file. DOC2,
however, can also be a main document with DOC3 attached as a data
file.
 
The print merge feature in Word is not designed to chain documents
together in the above manner. You should avoid using a Word document
as both a main and data document.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wmerge



Error Merging when Data File Is Microsoft Excel CSV or Text
Article ID: Q96921
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-cd, 2.0b, 2.0c, 6.0
 - Microsoft Excel for Windows, versions 4.0, 4.0a
-------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word, if you use a Microsoft Excel file saved in the CSV
or Text file format for the data file in a print merge document, you
may receive one of the following error messages during the merge if
the last column in the data file does not contain data in at least
every 16th record:

   Word Version 2.0
   ----------------

   There are fewer fields in record <N> than mergefields in header
   record. Do you want to continue with the Print Merge?

   Where <N> is the number of the first record of a 16-row block of
   records in which the last column contains no data.

   Word Version 1.x
   ----------------

   Number of fields does not match number of names in record N.
   Continue with Print Merge?

   Where <N> is the number of the first record of a 16-row block of
   records in which the last column contains no data.

Workarounds
-----------

To work around this problem, do one of the following:

 - If you do not need to use the CSV or Text file format (in order to
   avoid errors due to commas within the data, for example) save the
   Microsoft Excel file in the Microsoft Excel file format.

   -or-

 - If you must use the CSV or Text format, verify that the last column
   in the file contains some input in at least every 16 rows
   throughout the file. (If necessary, you can add spaces or other
   characters in every 16th cell, or you can reorder the columns in
   the worksheet so that the last column on the worksheet always
   contains information.)



MORE INFORMATION
================

In Microsoft Excel, if you save a file in Text or CSV format,
Microsoft Excel places tabs or commas between each column of the
worksheet. However, if the cells in the last column contain no data,
the extra comma or tab indicating the blank field for that record is
stripped off when the file is saved.

Microsoft Excel saves text files in 16-row blocks. Therefore, if all
the cells in the last column in a 16-row block are empty, Microsoft
Excel saves that area as if the column did not exist. No tabs or
commas are saved for that 16-row block of cells.

Additional reference words: w4wmerge w4wexcel 1.00 1.10 1.10a 2.00 wm_word 
2.00a 2.00a-cd 2.00b 2.00c 6.00



Conditional Alphanumeric Merge May Yield Incorrect Results
Article ID: Q97484
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
A print merge operation may yield incorrect results if you use a
conditional statement to evaluate alphanumeric data when the first
character of the data is numeric. This happens because conditional
statements (IF fields) evaluate only the first two characters of a
numeric string.
 
More Information:
 
For example, using the sample data file below, the following
conditional statement incorrectly yields a true result for the first
and second records, although only the second record satisfies the
condition:
 
   {IF {MERGEFIELD TEST} = "1AB" "This is true"}
 
Note: The IF field evaluated only the first two characters (1A) of the
numeric string.
 
Sample Data File
----------------
 
   ---------------------------------
   |  Rec_Num  |   Name   |  Test  |
   ---------------------------------
   |     1     |John      |1AA     |
   ---------------------------------
   |     2     |Bill      |1AB     |
   ---------------------------------
   |     3     |Fred      |2AA     |
   ---------------------------------
   |     4     |George    |ABC     |
   ---------------------------------
 
Workaround
----------
 
Word version 2.0
----------------
 
If your alphanumeric data contains entries that begin with a numeric
character, use the print merge Record Selection feature to perform a
conditional merge of the data. By setting record selection rules, you
can merge only data records that meet the criteria you specify.



 
The disadvantage of this workaround is that you must perform multiple
print merge operations if your main document contains more than one
conditional statement for alphanumeric fields. In this case, you must
modify your main document for each condition, change the Record
Selection settings to evaluate each condition individually and then
perform a separate print merge operation. The functionality of the
Record Selection feature differs from that of an IF field, so you must
modify your print merge procedure accordingly.
 
For example, the following procedure uses the Record Selection feature
to perform a conditional print merge of the sample data file above.
This procedure replaces the following conditional statement:
 
   {IF {MERGEFIELD TEST} = "1AB" "This is true"}
 
1. Attach the data file to the main document and then activate the
   main document.
 
2. From the File menu, choose Print Merge, and then choose the Merge
   button.
 
3. Choose the Record Selection button.
 
4. From the Field Name list, select Test.
 
5. From the Is list, select Equal To.
 
6. In the Compared To box, type "1AB" (without the quotation marks)
   and then choose the Add Rule button. Choose the OK button.
 
7. Complete the print merge operation. For record 2, "This is true"
   should appear in the merged document.
 
Word version 1.x
----------------
 
1. Sort your data file based on the field that contains entries that
   begin with a numeric character.
 
2. Number your data records.
 
3. Insert a conditional field, such as IF or NEXTIF, to print merge
   the correct data records.
 
Reference(s):
 
"Microsoft Word for Windows User's Guide," version 2.0, pages 633-645

"Microsoft Word for Windows User's Reference," version 1.0, pages
197-199
 
Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c numbers strings w4wmerge w4wfield alphabetic 6.00 wm_word



"Bookmark Not Defined" Replaces Print Merge ASK Field Result
Article ID: Q97485
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
The following error message prints in place of bookmark information
 
   Error! Bookmark not defined.

if you define a bookmark in a print merge main document using an ASK
field and then perform a print merge operation in which you select the
Skip Completely option to suppress the printing of blank lines. Word
for Windows loses the bookmark and stops printing the bookmark
information in your merged document after the first occurrence of
blank line suppression. 

In other words, when Word suppresses the printing of a blank line, it
does not retain the ASK field results, so this information does not
print in subsequent merged records.  

This problem was corrected in Word version 6.0 for Windows.

Workaround
----------
 
Turn off the Skip Completely option in the Print Merge dialog box.
 
 -or-
 
Replace paragraph marks in your main document with newline characters
(press CTRL+ENTER).
 
Note: Both workarounds disable the suppression of blank lines.
 
Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
2.0a-CD, 2.0b, and 2.0c of Word for Windows. This problem was corrected
in Word version 6.0 for Windows.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wfield
w4wmerge errmsg err msg
 \*



Print Merge Helper Creates Single-Column Table
Article ID: Q97792
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
When you create a data file by choosing the Create Data File button in
the File Print Merge dialog box, Word for Windows may produce a
single-column table, regardless of the number of fields that you
designate. This problem occurs if the List Separator box is blank. To
set the list separator character, choose the International icon in the
Windows Control Panel window.

When using Word for Windows 6.0 and the List Separator value is empty
in the International section of Control Panel, there is an infinite
number of default field name that appear in the Create Data file
window.  Ultimately, a datafile (of this many fields) can not be
created.
 
More Information:
 
The table that results when the List Separator box is blank contains
only the first field. If you use a different character as the list
separator, Word correctly produces a multiple-column table in most
instances (some list separator characters may produce a single-column
table; if that happens, change to a different list separator
character).

The default list separator value for the English (U.S.) language is a
comma.

If the List Separator box already contains a comma, rename the     
winword.ini file and restart Word, and the Print Merge Helper will     
produce a multi-column table as expected.
 
Reference(s):
 
"Microsoft Word for Windows User's Guide," version 2.0, pages 612-615,
619-620
 
"Microsoft Windows User's Guide," version 3.1, pages 170-171
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wmerge
pmh



Err Msg: Number of Fields Does Not Match Number of Records...
Article ID: Q97941
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

This article lists several causes of the following error message,
which may occur when you perform a print merge operation in Word for
Windows:

Word Version 2.0
----------------

   There are fewer fields in record <N> than merge fields in the
   header record. Do you want to continue with the Print Merge?

Word Version 1.x
----------------

   Number Of Fields Does Not Match Number Of Names In Record <N>.
   Continue Print Merge?

If you choose the Yes button, one or more of your merged documents may
contain incorrect, missing, or misplaced data.

MORE INFORMATION
================

If the above error message occurs, check the following in your print
merge data document:

1. Your data file may contain an extra character, such as a paragraph
   mark, space, tab or other character, after the last record, as
   shown in the following example:

      Name,Street,Address
      John Major,10 Downing St.,"London, England"
      <paragraph mark>

   Word treats the extra characters as an additional record and
   produces an extra merged record. This extra merged record may
   contain only the main document text, or it may be blank. To
   eliminate the extra merged record, delete the extra characters at
   the end of your data file.

   Tip: When your data document contains an extra character after the
   last record, the number <N> in the above error message is one
   number greater than the total number of records in your data file.



   For example, if your data file contains three records, the error
   message states "...record 4."

2. One or more records in your comma-delimited or tab-delimited data
   document may contain a comma or tab as punctuation. In the
   following example, the comma in "London, England" causes the error
   message:

      Name,Street,Address
      John Major,10 Downing St.,London, England

   To use a comma or tab as punctuation in a comma- or tab-delimited
   document, enclose the field in quotation marks, as shown in the
   following example:
 
      Name,Street,Address
      John Major,10 Downing St.,"London, England"

   Word reads a comma or tab in quotation marks as text instead of as
   a delimiter. The quotation marks do not print.

3. If your data document is a Word table, one or more of the rows may
   contain more cells than the first row of the table. Remove the
   extra cells so each row contains the same number of cells as the
   first row of the table.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 612-620

"Microsoft Word for Windows User's Reference," version 1.x, pages 131-
132, 197

Additional reference words: 6.00 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD
2.00b wm_word 2.00c w4wmerge errmsg



Calculations with Print Merge Causes Errors
Article ID: Q98836
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

In Word For Windows, you can include numeric values in a print merge
data file to use in calculations in the main document. If any of the
fields in the data file are blank, however, one of two error messages
may appear in the merged document:

   !Unexpected End of Expression

-or-

   !Syntax Error

WORKAROUND
==========

 - Make sure that all the fields used for calculations contain data.
   Type 0 (zero) in any blank field.

   The drawback to this workaround is that it could become tedious to
   maintain for large data files.

 -or-

 - In the calculation field in your main document, insert an IF
   statement that tests whether the field is blank. The following IF
   statement uses the value from the data file when the field is not
   blank; otherwise it uses 0 for the calculation:

      {= {if {MERGEFIELD num1} <> "" {MERGEFIELD num1} 0} +
      {if {MERGEFIELD num2} <> "" {MERGEFIELD num2} 0}}

   Note: To create the curly field brackets, press CTRL+F9.

For more information on using IF statement in a print merge, consult
pages 639-645 in the Word for Windows "User's Guide."

REFERENCES
==========

"User's Guide," version 2.0, pages 639-645

Additional reference words: 6.00 2.00 2.00a 2.00a-CD 2.00b 2.00c
w4wmerge wm_word



Err Msg in Place of REF Field Result: Bookmark Not Defined
Article ID: Q98895
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
If you type nothing in response to an ASK field prompt, Word for
Windows records a nul value, which may cause the following error
message to appear as the result of the REF field that references the
nul ASK field result in versions 2.0 and 1.0:
 
   Error! Bookmark not defined.

In version 6.0, the message is

  Error! Reference source not found.
 
This happens because you cannot assign a bookmark to a nul value. A
bookmark must represent a value, such as a selection or the insertion
point (the insertion point is not the same as a nul value).
 
Workaround 1
------------
 
To prevent the above error message from appearing, insert a SET field
before the ASK field, as shown in the example below. The SET field
assigns the insertion point, or no selection (""), to the bookmark
(instead of a nul value) so the error message does not occur.
 
   {SET address2 ""}{ASK address2 "What is the second line of
   the address?"}{ref address2}
 
This workaround assigns a blank value to the bookmark that Word can
insert if a different value is not later assigned using the ASK field.
 
Note: The \d (default) ASK field switch has no effect on this
workaround.
 
Workaround 2
------------
 
Insert an IF field that compares the reference to the ASK field
bookmark with a reference to an intentionally undefined bookmark. If
the bookmarks are the same (which means that both produce the "Error!
Bookmark not defined" error message), Word inserts an alternate
result.
 
Note: Be sure to choose a unique bookmark name as the intentionally
undefined bookmark. If this bookmark name is later assigned to a



value, the workaround fails.
 
In the following example, which illustrates this workaround, "xxxx" is
an undefined bookmark name. If the value of the mybkmark bookmark is
nul, Word inserts "No name given" as the result of the IF field.
 
   {ASK mybkmark "Type your name:"}
 
Insert the following IF field in place of the REF field that
references the ASK bookmark results:
 
   {IF {mybkmark} = {xxxx} "No name given" {mybkmark}}
 
Reference(s):
 
"User's Guide," version 2.0, pages 477-478, 640-644, 646-650
 
Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c 6.00 w4wfield errmsg err msg w4wmerge print merge wm_word



FILLIN Field Dialog Box Blank During Print Merge
Article ID: Q98897
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
When you use the FILLIN field in a print merge document to prompt for
information to print on each record, Word for Windows does not always
display what was typed in the previous FILLIN dialog box. This happens
if the Skip Completely option is selected in the Print Merge dialog
box and if Word skipped a blank line in the previous record. In other
words, when Word suppresses the printing of a blank line, it does not
retain the FILLIN field results, so this information does not appear
as the default response the next time the FILLIN dialog box appears.

This problem was corrected in Word version 6.0 for Windows. To
obtain new or updated Microsoft products, call Microsoft End User
Sales at (800) 426-9400. If you are outside the United States,
contact the Microsoft subsidiary for your area. To locate your
subsidiary,  call Microsoft International Customer Service at (206)
936-8661.
 
Workaround
----------
 
 - Use the \d switch in the FILLIN field, which displays the same
   default response each time instead of the response you typed in the
   previous FILLIN dialog box.
 
 -or-
 
 - Cancel the selection of the Skip Completely option in the Print
   Merge dialog box.
 
 -or-
 
 - Replace paragraph marks in your main document with newline characters
   (press CTRL+ENTER to create a newline character).
 
NOTE: The last two workarounds disable the suppression of blank lines.
 
Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
2.0a-CD, 2.0b, and 2.0c of Word for Windows. This problem was corrected in 
Word version 6.0 for Windows.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wfield
w4wmerge errmsg err msg error message



Page Numbering Starts at 1 for Each Print Merged Document
Article ID: Q99814
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When you perform a print merge operation in Word for Windows, page
numbers start at 1 for each merged record, even if you select the
Continue From Previous Section option in the main print merge
document.

This problem was corrected in Word version 6.0 for Windows.

Use one of the following workarounds to set continuous page numbering
in the merged document:

Workaround 1
------------

Insert the following field in the header or footer of your main
document and merge the results directly to the printer (instead of
merging the results to a new document). The limitation of this
workaround is that each merged document must contain the same number
of pages.

   {=((({mergerec}-1)*<number of pages in merged document>)+{page})}

Note: In the above expression, if you want to use a NUMPAGES field in
place of the <number of pages in merged document> value, you must
unlink it before you perform the print merge operation. For more
information on using the NUMPAGES field in a print merge operation,
query on the following words in the Microsoft Knowledge Base:

   numpages and w4wmerge and result and merged

Workaround 2 (Word Version 2.0, 2.0a, 2.0a-CD, 2.0b, and 2.0c only)
-------------------------------------------------------------------

This method consecutively numbers the pages of your merged document if
your main document is no longer than one page. This method works only
if your data file is in Word table format.

 1. Open the print merge data document.

 2. From the File menu, choose Template.

 3. Select the DATAFILE template from the Attach Document To list and
    choose OK.



 4. Choose the N button on the toolbar.

    -or-

    From the Tools menu, choose Database Management Tools. Select the
    Number Records option. Word adds a Rec_Num field as the first
    field in your data file.

 5. Choose the M button on your toolbar to activate the main document.

    -or-

    From the File menu, choose Print Merge and choose the Edit Main
    Document button.

 6. From the View menu, choose Header/Footer. Select Header or Footer,
    depending on whether you want the page numbers to appear at the
    top or bottom of each page, and choose OK.

 7. Choose the Insert Merge Field button on the print merge bar.

    -or-

    Press ALT+SHIFT+F.

 8. Select Rec_Num from the Print Merge Fields list and choose OK.

 9. Choose the Close button in the header/footer pane.

10. From the File menu, choose Print Merge. Choose the Merge button.

11. In the Print Merge dialog box, choose OK. The merged document
    contains continuous page numbers.

Workaround 3
------------

This method modifies the rich-text format (RTF) code of the main
document.

 1. Open the main document. From the View menu, choose Header/Footer.
    Select Header or Footer, depending on whether you want the page
    numbers to appear at the top or bottom of each page, and choose
    OK.

 2. Press CTRL+F9 to insert field brackets. Type "Page" (without the
    quotation marks) in the brackets.

 3. Choose the Close button in the header/footer pane.

 4. From the File menu, choose Print Merge. Choose the Merge button.

 5. Select the Merge To New Document option and then choose OK.

 6. The merged document (named Form LettersN) should now be active.
    From the File menu, choose Save As.



 7. From the Save File As Type list, select Rich Text Format (.rtf).

 8. In the File Name box, type "TEST.RTF" (without the quotation
    marks), and choose OK.

 9. From the File menu, choose Open. Select the TEST.RTF file and
    choose OK. In the Convert File dialog box, select Text Only and
    choose OK.

10. From the Edit menu, choose Replace. In the Find What box, type
    "\pgnrestart" (without the quotation marks). Clear the Replace
    With box and then choose the Replace All button.

11. From the File menu, choose Close. Choose the Yes button when Word
    prompts you to save changes to the file.

12. From the File menu, choose Open. Select the TEST.RTF file and
    choose OK. When Word prompts you to convert the file from Rich
    Text Format (.rtf), choose OK. The merged document now contains
    consecutive page numbering.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 616-628,
677-679

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c w4wmerge



Main Document Header Prints on Envelope During Print Merge
Article ID: Q99817
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

If you add an envelope to a print merge main document that contains a
header, the header prints on all but the first envelope if you select
the Merge To New Document option in the Print Merge dialog box. 

Microsoft is researching this problem and will post new information
here in the Microsoft Knowledge Base as it becomes available.

By contrast, the header does not print on the envelopes when you
select the Merge To Printer option or when you print merge only the
envelope by printing from page 0 to page 0.

More Information:

Although this problem usually occurs when your print merge main
document includes an envelope, it can also occur when your print merge
main document contains multiple sections. If the first section does
not contain a header and the last section does contain a header, the
header from the last section of the previous form letter prints as the
header of the first section of all but the first form letter. Again,
this happens only when you select the Merge To New Document option
when you perform the print merge operation. It does not occur when you
print merge the document to the printer.

Workaround
----------

1. Position the insertion point on the envelope page.

   -or-

   Position the insertion point in the first section of your main
   document (for non-envelope occurrences of this problem).

2. From the View menu, choose Header/Footer. Select Header and choose
   the OK button.

3. In the header, press the SPACEBAR to insert a space.

The envelope (or the first section) now contains a section that
consists of a single space, which prevents the previous header from
printing in the wrong place.

Reference(s):



"User's Guide," version 2.0, pages 120-121, 631-632

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wmerge



Cannot Remove Header File Attachment from Main Document
Article ID: Q105709
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========
 
If your Word for Windows mail merge ("print merge" in Word 2.x) main
document is attached to both a header file and data file, you cannot
remove a single attachment without removing both attachments. For
example, if you want to remove the header file attachment when you add
a header record to your data document, you must remove both the header
and data document, then reattach the data document.
 
For information on attaching data and header documents to a mail merge
main document in Word 6.0, search for "mail merge" using the Help
menu.
 
STATUS
======
 
We are researching this problem and will post new information here in
the Microsoft Knowledge Base as it becomes available.
 
REFERENCES
==========
 
"Microsoft Word for Windows User's Guide," version 2.0, pages 629-630
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00
printmerge w4wmerge remove replace change datafile headerfile
mailmerge mail formletter maillabel catalog reattach wm_word



Shortcut Key Combinations for Mail/Print Merge Tools
Article ID: Q105712
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.1
-------------------------------------------------------------------

SUMMARY
=======

This article contains a list of the key combinations (shortcut keys)
you can use to choose buttons on the Mail Merge toolbar (the Print
Merge toolbar in Word 2.x). These toolbars are available only in a
mail merge main document ("print merge" document in Word 2.x).

MORE INFORMATION
================

Key Combination        Description
---------------        -----------

ALT+SHIFT+F            Insert merge field
ALT+SHIFT+E            Edit data file
ALT+SHIFT+K            Check merge
ALT+SHIFT+N            Merge to new document
ALT+SHIFT+M            Merge to printer

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00
w4wmerge wm_word



Print Merge Err Msg: "Requested First Record Is Beyond End..."
Article ID: Q105822
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========
 
Word for Windows may issue the following error message when you
perform a print merge operation on selected records (for example, from
record 10 to record 15):
 
   The requested first record is beyond the end of the print merge
   data file.
 
CAUSE
=====
 
This problem is frequently seen with large comma-delimited dBASE
files. The problem results from misplaced field delimiters. For
example, in the following sample data document, there is a misplaced
quotation mark between Bob and Smith in the first record (the second
record is a valid record):
 
   name, address
   "Bob "Smith", "111 Main St"
   "Sue Jones", "222 Main St"
 
STATUS
======
 
Microsoft has confirmed this to be a problem in versions 2.x of Word
for Windows. This problem was corrected in version 6.0 of Word for
Windows.
 
WORKAROUND
==========
 
Remove all the misplaced quotation marks.
 
Additional reference words: mail merge 2.00 2.00a 2.00a-CD 2.00b
2.00c W4WMERGE



Main Document Header Prints on Envelope During Print Merge
Article ID: Q105841
----------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------
 
SYMPTOMS
========
 
If you add an envelope to a print merge main document that contains a
header, the header prints on all but the first envelope if you select
the Merge To New Document option in the Print Merge dialog box. By
contrast, the header does not print on the envelopes when you select
the Merge To Printer option or when you print merge only the envelope
by printing from page 0 to page 0.
 
STATUS
======
 
Microsoft has confirmed this to be a problem in Word for Windows. We
are researching this problem and will post new information here in the
Microsoft Knowledge Base as it becomes available.
 
MORE INFORMATION
================
 
Although this problem usually occurs when your print merge main
document includes an envelope, it may also occur when your print merge
main document contains multiple sections. If the first section does
not contain a header and the last section does contain a header, the
header from the last section of the previous form letter prints as the
header of the first section of all but the first form letter. Again,
this happens only when you select the Merge To New Document option
when you perform the print merge operation. It does not occur when you
print merge the document to the printer.
 
WORKAROUND
==========
 
1. Position the insertion point on the envelope page.
 
   -or-
 
   Position the insertion point in the first section of your main
   document (for non-envelope occurrences of this problem).
 
2. From the View menu, choose Header/Footer. Select Header and choose
   the OK button.
 
3. In the header, press the SPACEBAR to insert a space.
 



The envelope (or the first section) now contains a section that
consists of a single space, which prevents the previous header from
printing in the wrong place.
 
REFERENCES
==========
 
"Microsoft Word for Windows User's Guide," version 2.0, pages 120-121,
631-632
 
Additional reference words: 6.00 2.00 2.00a 2.00a-CD 2.00b 2.00c
w4wmerge wm_word w4wenvelope



How to Merge Conditional Number of Records to the Same Page
Article ID: Q105888
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

In Word for Windows, you can merge a conditional number of records to
the same page.

MORE INFORMATION
================

To merge a conditional number of records to the same page, use a
combination of SET, IF, and NEXTIF fields. For example, you could use
this method to merge all records with the same name to one page in the
merge and create a new page in the merge when a new name is
encountered in the data file.

The following example uses a data file with employee names (Employee)
and projects they are working on (Projects). The Check field is used
in the datafile to mark the last record of a particular name.

Sample Data File:

Employee     Project     Check
John Doe     4578j
John Doe     86785x
John Doe     543p          1
Jane Doe     87x
Jane Doe     89976m        1
Sam Smith    7897r
Sam Smith    857t
Sam Smith    78974x
Sam Smith    7868p         1

The main document should be set up as follows, with a copy of the
conditional statements equal to the maximum number of projects for
each employee (four in the above example):

Employee     Project
{MERGEFIELD Employee}     {MERGEFIELD Project}{set duplicate {if
{MERGEFIELD Check}="1" "off" "on"}}{nextif {mergefield check}=""}{if
{duplicate}="on" "P
t{MERGEFIELD Project}"}{set duplicate {if {MERGEFIELD Check}="1"
"off" "on"}}{nextif {mergefield check}=""}{if {duplicate}="on" "P
t{MERGEFIELD Project}"}{set duplicate {if {MERGEFIELD Check}="1"
"off" "on"}}{nextif {mergefield check}=""}{if {duplicate}="on" "P
t{MERGEFIELD Project}"}{set duplicate {if {MERGEFIELD Check}="1"



"off" "on"}}{nextif {mergefield check}=""}{if {duplicate}="on" "P
t{MERGEFIELD Project}"}

Where "P" represents a paragraph mark that would push the next Project
to a new line and "t" represents a tab character that would align the
next project under the previous project.

The resulting merge document would appear as follows:

Employee     Project
John Doe     4578j
             86785x
             5436435p
--- Page Break ---
Jane Doe     87x
             89976m
--- Page Break ---
Sam Smith    7897r
             857t
             78974x
             7868p

Additional reference words: w4wmerge w4wfield 1.00 1.10 1.10a 2.00
2.00a 2.00a-cd 2.00b 2.00c 6.00 wm_word



Blank Line Suppression When Using FILLIN field
Article ID: Q106652
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------

SUMMARY
=======

If you are using a FILLIN field in Word for Windows, and do not enter
any information into the FILLIN message box, the line in the document
that holds the field code will still exist (and will be blank). To
have the blank line suppressed if no information is entered in the
FILLIN field message box, use one of the two methods below.

Method 1
--------

1. Using the following example as a model, insert the following lines
   somewhere in your document, before the location where the
   information generated by the FILLIN fields will go. These lines
   assign FILLIN values to bookmarks. These bookmarks will be
   referenced later in the document where the information will
   actually appear.

      {set name "{fillin "enter name"}"}
      {set company "{fillin "enter company"}"}
      {set address "{fillin "enter address"}"}
 
2. Enter the following lines at the location in the document where you
   want the information to appear.

      {if name <> "" "{name}
      "}{if company <> "" "{company}
      "}{if address <> "" "{address}
      "}

Method 2
--------

The results of this method are identical to the results of Method 1.
The SET statements have been incorporated into the conditional
statements.

   {set name {fillin "enter name"}}{if name <> "" "{name}
   "}{set company {fillin "enter company"}}{if company <> "" "{company}
   "}{set address {fillin "enter address"}}{if address <> "" "{address}
   "}

When you select the whole document (choose Select All from the Edit menu)
and press F9 to update the fields, you will be prompted for each piece



of information. If you leave one or more of the pieces of information
blank, the line containing its FILLIN field will be suppressed.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 474 and 672

Additional reference words: 2.00 2.00a 6.00 2.00a-CD 2.00b 2.00c
2.00c-CD 6.00 w4wfield w4wmerge



Manual Page Breaks Ignored When Document Is Printed
Article ID: Q37799
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, manual page breaks are ignored when you
print if they are formatted as hidden text and the Show Hidden Text
option is not selected.
 
To correct this problem, choose one of the following procedures:
 
1. From the File menu, choose Print. Choose the Options button and
   select the Include Hidden Text check box.

  -or-
 
2. Select the page break. From the Format menu, choose Character and
   clear the Hidden check box.

Additional reference words: w4wprint 1.00 1.10 1.10a 2.00 2.00a 6.00 
wm_word 
2.00a-CD 2.00b 2.00c 



Printing Color Text on a Non-Color Printer in Word for Windows
Article ID: Q37817
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:
 
In Microsoft Word for Windows, when formatting text for color and
printing to a non-color printer, the printed results may vary somewhat
depending on the printer you have selected in the File Printer Setup
command.

On some printers, such as the Hewlett-Packard (HP) LaserJet, your text
always prints regardless of the color assigned to the text, with the
exception of white. On other non-color printers, such as the Epson
FX-85, certain colors may print while others may not.

For example, using the Epson 9-pin driver on the Epson FX-85 printer,
text that is formatted black, green, red, or yellow prints, while text
that is formatted blue, cyan, magenta, or white does not print. The
results when printing to non-color printers are dependent upon the
Windows printer driver being used. Some drivers may interpret the
colors differently than others, so text formatted with certain colors
may not print.

Additional reference words: w4wprint 1.0 1.00 1.1 1.10 1.1a 1.10a 2.00 
6.00 wm_word 2.00a 2.00a-CD 2.00b 2.00c 



Position Formatting Ignored When Printing from Outline View
Article ID: Q41737
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:
   

In Microsoft Word for Windows, if you print from outline view,
position formatting is ignored. Absolutely positioned objects (APOs)
are included in the document as normal text. To Print a Document with 
the APO's positioned properly, use normal or page layout view

Additional reference words: w4wprint 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD  
6.00 wm_word 2.00b 2.00c



Using the ANSI Extended Character Set in Word for Windows
Article ID: Q47534
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

Microsoft Word for Windows uses the ANSI extended character set. The
extended character set is accessed using decimal codes 128-255. To
access the ANSI extended character set, turn on NUM LOCK and hold down
ALT. On the numeric keypad, type 0 (zero) followed by the decimal
number for the character.

Note: In the ANSI chart, characters 128-159 are graphic, foreign, or
Greek characters. If you want to use your computer's default display
characters for these codes, and/or send these codes to your printer,
use the method described above, but omit typing the zero in front of
the decimal number for the character.

Foreign characters for Western European countries are part of the ANSI
character set. For other foreign character sets, you must have the
font installed that contains the foreign characters, and you must have
a display driver and printer driver that can render the characters.

A table of the ANSI character set can be found in Appendix C of the
"Microsoft Word for Windows User's Reference" version 1.0 manual on
pages 427-428.

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 
6.00 wm_word 
2.00c  w4wprint 



Text Beyond Right Margin Even with Display As Printed On
Article ID: Q47858
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

Under certain circumstances, text extends past the right margin when
the Display As Printed option is selected. This occurs due to screen
font limitations; the font(s) assigned to the text cannot be
accurately represented on the screen. This problem occurs when a font
assigned to the text uses a screen font that is larger than the font
will actually print. Word for Windows will attempt to match a screen
font as closely as possible, but if an exact match is not found, and
the screen font is bigger than the printed font that will be used,
text extends beyond the right margin setting on the screen.

Display As Printed represents line breaks as they will be printed. In
doing this, it is sometimes necessary to extend a line beyond the
displayed right margin.

This problem was corrected in Word version 6.0 for Windows.

Additional reference words: w4wprint 1.0 1.1 1.1a 1.00 1.10 1.10a  2.0 
2.00



WinWord Margin Definitions: Inside, Outside, Gutter, Mirror
Article ID: Q48909
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

In Word for Windows, the following definitions apply to the
options available from the Format menu after choosing Page Setup:

1. Inside: Margins on the left of odd-numbered pages, on the right of
   the even-numbered pages. This is typically used to set up a binding
   margin. This option is labeled Left when Facing Pages is not
   selected.

2. Outside: Margins on the right of odd-numbered pages, on the left of
   even-numbered pages. This is typically used to set up a sidehead
   margin. This option is labeled Right when Facing Pages is not
   selected.

3. Gutter: Positive decimal measurement for adding a binding margin to
   the inside edge of pages when printing on only one side of each
   page.

4. Facing Pages: Causes inside and outside margins to alternate
   between odd-numbered and even-numbered pages when pages are printed
   on both sides. When Facing Pages is selected, the Leftoption
   changes to the Inside option, and the Right option changes to the
   Outside option.

In Word For Windows version 1.0 and 1.1 the following are margin
definitions apply to options available from the Format menu after
choosing Document:

1. Inside: Margins on the left of odd-numbered pages, on the right of
   the even-numbered pages. This is typically used to set up a binding
   margin. This option is labeled Left when Mirror Margins is not
   selected.

2. Outside: Margins on the right of odd-numbered pages, on the left of
   even-numbered pages. This is typically used to set up a sidehead
   margin. This option is labeled Right when Mirror Margins is not
   selected.

3. Gutter: Positive decimal measurement for adding a binding margin to
   the inside edge of pages when printing on only one side of each
   page.

4. Mirror Margins: Causes inside and outside margins to alternate
   between odd-numbered and even-numbered pages when pages are print on



   both sides. When Mirror Margins is selected, the Left option changes
   to the Inside option, and the Right option changes to the Outside
   option.

Additional reference words: w4wprint 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD  
6.00 wm_word 2.0-0b 2.00c 



Enlarging and Shrinking Font Size Using Hot Keys
Article ID: Q50172
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

You can change the size of selected characters by using hot keys in
Word for Windows. The font can be enlarged or reduced to any defined
font size of the current font in the selected text. The printer driver
currently in use determines the available sizes for the font.

Word version 6.0
----------------

The following quick Key combinations change the font:

Change the font size                                   CTRL+SHIFT+P
Increase the font size to the next available size      CTRL+SHIFT+>
Decrease the font size to the previous available size  CTRL+SHIFT+<
Increase the font size by 1 point                      CTRL+]
Decrease the font size by 1 point                      CTRL+[

Word version 1.x and 2.x
------------------------
To increase the font size to the next larger defined size, press
CTRL+F2. To decrease the font size to the next smaller defined size,
press CTRL+SHIFT+F2. If no larger or smaller size is available and you
attempt to increase or decrease the size, the font size remains the
same.

For more information on fonts, see page 123 of the "Microsoft Word for
Windows User's Reference."

Additional reference words: w4wprint 1.00 1.10 1.10a 2.00 2.00a 2.00a- 
6.00 wm_word CD 2.00b 2.00c



Correcting Line Spacing Offset by Superscripts and Subscripts
Article ID: Q59485
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, the baseline for line spacing is
dependent on superscript and subscript characters. For this reason,
when you superscript characters, Word appears to drop the current and
subsequent lines down by the distance of the superscript; when you
subscript characters, Word drops the subsequent lines down by the
distance of the subscript (3 points by default). There is no simple
method to correct for this problem; however, you can use the
workarounds listed below.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Superscript
-----------

Word for Windows 2.0 and 2.0a
-----------------------------

Applying superscript formatting does not have any line spacing effect
on the paragraphs above or below the current paragraph. The
superscript text may disappear from the current display, but it does
print in the correct location.

Word for Windows 1.x
--------------------

Format paragraphs containing superscript formatting with a line
spacing measurement of -1. This maintains the line spacing throughout
the paragraphs for all superscript formatting.

Subscripting
------------

Word for Windows 2.x
--------------------

Applying subscript formatting does not have any line spacing effect on
the paragraphs above or below the current paragraph. The subscript
text may disappear from the current display, but it does print in the
correct location.

Word for Windows 1.x



--------------------

To adjust the line spacing of subscript text, use the following steps:

1. Insert a hard carriage return at the end of the line containing the
   subscript text and at the end of the line below the subscript text.
   This allows you to treat the first line of subscript text as a
   separate paragraph.

2. Format the line (paragraph) containing the subscript text with a
   line spacing measurement equal to the point size minus the distance 
of
   the subscript formatting. For example, if your paragraph is formatted
   with a 12-point font and the first line contains 3-point subscript
   formatting, format the first line with a line spacing setting of -
9pt.

Some fonts display differently on screen than in printed output. For
example, the Courier 12-point font sometimes displays a word on one
line on the screen, but the word appears on the subsequent line when
you print. In these cases, place the hard returns on the ends of the
lines as they actually print, as opposed to how they display on
screen.

Note: The workaround for subscript formatting produces incorrect line
spacing if either of the hard carriage returns is missing.

Additional reference words: w4wprint 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c 



3.6 Point Font on the HP Great Start Cartridge in Word
Article ID: Q64399
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

The Hewlett-Packard (HP) Great Start Cartridge supports a Letter
Gothic 3.6 font in portrait orientation. This point size does not
appear in the points box because Microsoft Word for Windows requires a
point-size measurement from 4 to 127.

To use the 3.6 font, enter a 4 in the points box. This will result in
correct font output from the printer.

This same font appears in Microsoft Write and Excel as 3.5. Since both
of these applications round to the nearest half, this behavior is
considered normal.

Additional reference words: w4wprint 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD  
6.00 wm_word 2.00b 2.00c



Setting the Default Font in Word for Windows
Article ID: Q64423
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

Times Roman (Tms Rmn) is the default font for Microsoft Word for
Windows 2.0 even if Tms Rmn is not available on the current printer. If
the current printer does not support Tms Rmn, it is best to change the
default font for all new documents.

Word versions 2.0 and 6.0 for Windows query the printer driver for the
the best Roman family font from the driver and use this as the
the default font. If there is not an internal Roman font available
(as in the case of the Hewlett-Packard LaserJet II printers), Courier
is selected as the default font with a 10 point size. The default
point size is always 10 point, while the font depends upon the
printer driver selection.

To change the default font in Word for Windows version 1.0, 1.1, or
1.1a, modify the Normal template (NORMAL.DOT) file by following these
steps:

1. From the Format menu, choose Define Styles.

2. Choose the Normal style.

3. Choose the Character button.

4. Set the desired default font and size. Choose the OK button.

5. Choose the Options button.

6. Select the Add To Template option.

7. Choose the OK button.

When closing Word for Windows, you are prompted to save "Global
Glossary and Command Changes" changes. Choose Yes to modify the
NORMAL.DOT.

The global default font for Word version 2.0 and 6.0 for Windows is
defined in the Normal style of the NORMAL.DOT template. The
NORMAL.DOT template is used if you do not specify another template.
To change the style of the default font, follow these steps:

1. From the File menu, choose New.

2. Select Document in the New box and select Normal in the Use



   Template box. Choose the OK button.

3. From the Format menu, choose Character (Font in 6.0).

4. Choose the font name, point size, and any attributes that you
   want as defaults for documents based on the NORMAL.DOT file
   or Normal template.

5. Choose the Use as Default... (Default... in 6.0) button.  The 
   following message results:

       Do you want to change the font for the Normal style to
       (fontname)?

    This change affects all new documents based on the NORMAL template.

6. Choose Yes to confirm that you want all documents you create that
    are based on the current template to reflect this change to the 
    Normal style.

7. From the File menu, choose Save All, and choose Yes to save the
   global glossary and command changes. (Word 6.0 will not prompt you
   to save the changes to the NORMAL.DOT unless you have the option
   "Prompt to Save NORMAL.DOT" checked under Tools, Options, Save
   Tab.)

Reference(s):

"Microsoft Word for Windows User's Reference," version 1.1, pages
346-348

Additional reference words: 1.00 1.10 1.10a w4wprint changing 2.00 6.00 
wm_word 2.00a 2.00a-CD 2.00b 2.00c



Printing a Page Border with PostScript in Word for Windows
Article ID: Q64703
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

The following field code may be used to print a page border on a
PostScript printer:

   {print \p page "clippath 2 setlinewidth stroke"}

This particular code will use the last rectangular clipping path set
by Microsoft Word for Windows and print a solid line around the path
with a width (2 point) set by the Setlinewidth command.

Note: This example will work best for full page borders when the
document has no text or has graphics formatted as absolute positioned
objects (APO). You must include this sample field on each page that
you want to print a border on. The field can be inserted anywhere on
the page -- even in a table.

Reference(s):

"Microsoft Word for Windows User's Reference." (Document Number OB
14328-0990) Page 104.

Additional reference words: w4wfield w4wprint 1.00 1.10 1.10a 2.00 6.00 
wm_word 2.00a 2.00a-CD 2.00b 2.00c 



Using Word for DOS 5.00 Bitstream Fonts with Word for Windows
Article ID: Q64712
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

It is possible to use Bitstream fonts with Microsoft Word for Windows
that were designed for Word for DOS version 5.00. However, they must
first be re-created using Bitstream's FontWare installation package
for the version of Windows that you have.

Using Bitstream soft fonts not created specifically for Windows may
cause bold or other undesirable characters. Reinstalling the fonts
with Bitstream's FontWare installation package for Windows will
provide correct font display and printing.

For additional information, contact Bitstream technical support at (617)
497-7514.

Additional reference words: w4wprint wdprint 2.00 2.00a 2.00a-CD 2.00b 
6.00 wm_word 2.00c  1.00 1.10 1.10a 



Large Gaps Between Italic Capital and Small Capital Letters
Article ID: Q65178
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you format text with both small
capital letters (small caps) and capitalized italic letters, large
gaps between the capitalized italics and small capitals appear. This
problem is caused by the overhang of the italic character. The text
still prints correctly.

The font kerning feature of Word version 6.0 does not affect this 
problem.

More Information:

Steps to Reproduce Problem
--------------------------

1. Type "Hello. How Are You?"

2. Select the line. From the Format menu, choose Character, and select
   the Italic and Small Caps check boxes.

Large gaps appear between the first letter, which is a capitalized
italic letter, and the rest of the word.

Microsoft has confirmed this to be a problem in Word for Windows We
are researching this problem and will post new information here as it
becomes available.

Additional reference words: w4wprint 1.00 1.10 1.10a 2.00 2.00a 2.0b 
6.00 wm_word 
2.0a-CD 2.00b 2.00a-CD 



Using the {print} Field with Dot-Matrix Printers and Winword
Article ID: Q65837
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

You can use the {print} field with a dot-matrix printer only if
the commands sent in the {print} field do not take the printer out
of graphics mode.

Note: Most commands sent to a dot-matrix printer through the {print}
field will take the printer out of graphics mode. For a list of
commands that will not take the printer out of graphics mode, consult
your printer owner's manual or contact the manufacturer.

For more information on the {print} field, refer to Page 104 of the
"Microsoft Word for Windows User's Reference" guide.

Additional reference words: w4wprint w4wfield 1.00 1.10 1.10a 2.00 6.00 
wm_word 2.00a 2.00a-CD 2.00b 2.00c 



Print Key Assignments Prints Only Reassignments of Keys
Article ID: Q65868
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

If you choose Print from the File menu and select Key Assignments in
the Print dialog box, Microsoft Word for Windows prints only those key
assignments that have been reassigned from their defaults.

Word for Windows currently does not have the ability to print default
key assignments.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 116

"Microsoft Word for Windows User's Reference," version 2.0, page 275

Additional reference words: w4wprint docerr 1.00 1.10 1.10a 2.00 2.00a 
6.00 wm_word 2.00a-CD 2.00b 2.00c 



HP LaserJet Com-10 Error Messages When Printing Envelopes
Article ID: Q66044
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
---------------------------------------------------------------------

The "PE Load Com-10" error message shown on the printer display
may occur when you attempt to print an envelope from Microsoft Word
for Windows to a Hewlett-Packard (HP) LaserJet series printer. The
error message indicates that the printer received a command to
manually feed an envelope. Com-10 represents the envelope size. This
error occurs when you have specified the manual tray through the
Windows Control Panel setting. To print an envelope, you must select
Envelope as the paper source when using the envelope tray.

The error message "PF Feed Com 10" is a request for the envelope to be
inserted in the manual-feed envelope slot. This error will occur,
causing the printer to go off line until the envelope is inserted.
Once the envelope is inserted, the print job will continue.

"PC Load Com-10" is an error message that occurs when Envelope is
selected as your paper source and you are using the manual envelope
feed. This error requires a "level 07" reset, which can be enacted by
holding the Reset button on the printer for about two seconds.

"EC Load Com-10" occurs when the envelope tray size specified is not
the same as what is currently installed in the printer or if the
envelope tray is empty. Load the correct envelope tray and/or fill the
tray with envelopes.

Whenever the envelope tray is inserted into the printer, you may
receive the message "PE Tray=Com-10" on the printer display. This
message represents the size of the envelope tray. If this message does
not clear in 10 seconds, you must reset the printer to the correct
envelope size through the printer's Control Panel.

Additional reference words: 6.00 w4wprint 1.00 1.10 1.10a 2.0 2.00
2.0a wm_word 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD  w4wenvelope



WinWord: Reverse Print (White on Black) with LaserJet III
Article ID: Q66093
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

You can use the Microsoft Word for Windows PRINT field to use the
reverse printing capabilities of the Hewlett-Packard (HP) LaserJet III
printer. This procedure requires the following steps:
 
1. Define and create a black rectangle.

2. Change the opaque mode of the graphic image.

3. Set the palette color to white for the image.

The following is an example:

   {print " *p300x220Y *c1500a600b*c0P *v0n1O *v1T"}
   Test Text
   {print  *v0T}

Note: Read the above as:

   CTRL+F9 print space quotation mark ALT+027 *p
   three zero zero x two two zero Y ALT+027 *c one five zero
   zero a six zero zero b * c zero P ALT+027 * v zero n one O
   ALT+027 *v one T endquote. Type the Test Text. CTRL+F9
   print space ALT+027 *v zero T.

The first character before the asterisk, is the screen representation
of the ALT+027 (ESC) character. The first section *p300x220Y sets the
cursor at the default margin position of Word for Windows (1.25 Left,
1.00 Top). The second section *c1500a600b draws a rectangle with the
dimensions of 1500 and 600 dots (at 300 dpi - 5 x 3). The *c0P fills
the rectangle with black. *v0n1O sets the transparency mode. The *v1T
sets the palette color to white. All characters after this code are
white until reset by the *v0T.

Chapter 12 of the "HP LaserJet III Technical Reference Manual"
discusses these commands in detail. For more information, contact
Hewlett-Packard's Personal Peripherals Assist Line at (208) 323-2551.

Reference(s):

"HP LaserJet III Technical Reference Manual," Chapter 12

Additional reference words: w4wprint w4wfield 1.0 1.1 1.1a 1.00 1.10 
6.00 wm_word 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 





Columns Print Crookedly When Aligned Using Spaces in WinWord
Article ID: Q66917
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

If you try to line up columns of text using spaces, the columns may
print unevenly. The usual cause of this problem is that a proportional
font (such as Tms Rmn) is being used. Lining up columns using spaces
and proportional fonts is unpredictable. This is caused by slight
differences in screen and printer fonts or in the case of TrueType,
differences in screen resolution and printer resolution cause rounding
errors that, by the end of a line, may change its width 2-4
characters.

1. Line up the columns using tabs or a table rather than spaces.

2. Use a nonproportional font such as Courier.

Also, make sure that you use a font and point size supported by the
default printer. If Windows is forced to substitute a font, it may
affect the spacing.

Additional reference words: w4wprint w4wtable 2.00 2.00a 6.00 wm_word 
2.00a-CD 2.00b 2.00c



Incorrect Word Wrapping with the PostScript Printer Driver
Article ID: Q67102
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When you use the PostScript printer driver PSCRIPT.DRV with the
default screen fonts that come with Windows, Microsoft Word for
Windows produces incorrect line endings with the AvanteGarde, Bookman,
Helvetica-Narrow, Modern, NewCenturySchlbk, Palatino, Roman, Script,
Symbol, TmsRmn, ZapfChancery, and ZapfDingbats fonts. Word does
generate correct line endings with the Courier and Helv fonts when you
use the default screen fonts that come with Windows.

This problem does not occur if you are using TrueType fonts in the
Microsoft Windows operating system version 3.1; however, using
standard PostScript printer fonts without the correct screen fonts in
Windows 3.1 generates the same problem.

This problem was corrected in Word version 6.0 for Windows.

More Information:

With the right margin at 6.5 inches and a 10-point font size, the
following fonts wrap before the 6.5-inch margin:

   Font                  Wraps At
   ----                  --------

   AvanteGarde             6.125 inches
   Bookman                 5.125 inches
   Modern                  6.125 inches
   NewCenturySchlbk        5.5 inches
   Palatino                5.75 inches
   Roman                   5.375 inches
   Script                  6 inches
   Symbol                  6.125 inches
   Tms Rmn                 6 inches
   ZapfDingbats            4.375 inches (when displaying as the symbol 
font)

With the right margin at 6.5 inches and a 10-point font size, the
following fonts wrap before the 6.5-inch margin:

   Font                    Wraps At
   ----                    --------

   Helvetica-Narrow        7.75 inch
   ZapfChancery            7.125 inch



Note: These numbers may vary if you use third-party screen fonts or
different point sizes.

Reference(s):

"Microsoft Word for Windows User's Reference," version 1.x, pages 31,
123-125

Additional reference words: w4wprint w4wmerge 1.0 1.1 1.1a 1.00 1.10
1.10a 2.0 2.00 3.10



Word for Windows: Borders Don't Print on Plotters
Article ID: Q68368
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

Microsoft Word for Windows does not print paragraph or table borders
to a plotting device.

More Information:

Word for Windows prints borders as bitmapped images to all output
devices. The Windows plotter driver does not print bitmap images. It
can harm the hardware if such an image is printed. Therefore, borders
do not print from Word for Windows to a plotting device.

Additional reference words: w4wprint plotter support 1.00 1.10 1.10a 
6.00 wm_word 2.00 2.00a 2.00a-CD 2.00b 2.00c 7475 7550 PLOTTER 
HPPLOT.DRV HPPLOT



Statistics Update Not Available with Printer on None
Article ID: Q68481
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, the Update button is unavailable if the
printer selected in Printer Setup is not connected to a port ("PRD
file driver on None"). In Word for Windows versions 1.0, 1.1, and
1.1a, you can access the Update button by choosing Summary Info from
the Edit menu and choosing the Statistics button. To access the Update
button in version 2.0, choose Summary Info from the File menu and
choose the Statistics button. 

If you choose the Update button, Word for Windows attempts to
repaginate and display the number of pages in the document. With a
printer selection on None, or without an installed printer, Word for
Windows cannot repaginate based on the printer's capabilities. Word
can repaginate based on Normal style, which is Tms Rmn, but this is
not sufficient to update the statistics in the Summary Info dialog
box.

Note that the Print and Print Preview options in the File menu are
also unavailable when you are connected to a printer on None.

This is only true if you are using Windows 3.0, since Windows 3.1
requires any printer installed to be connected to a port.

Additional reference words: w4wprint 1.0 1.1 1.1a 1.00 1.10 1.10a 2.0  
6.00 wm_word 2.00 gray grey dimmed



No Footer/Header on Even Page
Article ID: Q68618
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

If you use the Different Odd And Even Pages option when you
choose Header/Footer from the Edit menu, and you have inserted an Odd
Page section break after an odd page, no even header or footer will
be placed on the preceding even page.

More Information:

Do the following:

1. Create a three-page document.

2. Choose Header/Footer from the Edit menu and check Different
   Odd And Even Pages.

   Type different footer text for odd and even pages.

3. Insert an Odd Page section break after the third page (use the
   Insert Break command).

The fourth page of the document will not print or display an even
footer.

Additional reference words: w4wprint odd section break 6.00 wm_word 



Macro to Print Current Page in Word for Windows
Article ID: Q69519
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, and 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

You can use the following version-specific methods to print the
current page only (that is, the page where the insertion point
resides) of a Microsoft Word for Windows document.

Word for Windows Version 2.0 and 6.0
------------------------------------

1. From the File menu, choose Print.

2. Choose the Current Page button in the Range dialog box, and choose
   the OK button.

The following WordBasic macro instruction prints the current document
page:

   FilePrint .Range = 2

Word for Windows Versions 1.x
-----------------------------

Method 1
--------

Note: This method is intended for use in single section documents.
Before you begin, make sure that nothing is selected in the document.

1. From the Macro menu, choose Edit. Type a name for the macro (for
   example, currentpage).

2. Press ENTER or choose the OK button.

3. In the resulting macro window, type the following macro text:

   Sub MAIN
   EditGoto "\Page"
   FilePrint .Range = 1
   GoBack
   End Sub

4. From the File menu, choose Close, and choose Yes to save changes to
   your macro. From the Macro menu, choose Run, or assign the macro to a
   key or menu.

Method 2
--------



1. From the Macro menu, choose Edit. Type a name for the macro (for
   example, currentpage).

2. Press ENTER or choose the OK button.

3. In the resulting macro window, type the following macro text:

   Sub MAIN
   StartOfLine
   UtilRepaginateNow
   InsertField .Field = "Page"
   CharLeft 1, 1
   UnLinkFields
   PageNum$ = Selection$()
   EditClear
   FilePrint .Range = 2, .From = PageNum$, .To = PageNum$
   End SUB

4. From the File menu, choose Close, and choose Yes to save changes to
   the your macro. To run the macro, from the Macro menu, choose Run, or
   assign the macro to a key or menu.

Additional reference words: w4wmacro w4wprint active range 1.1a 1.00
wm_word 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Descenders Cut Off in Table Using Adobe Postscript Cartridge
Article ID: Q69731
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

Character descenders in tables are cut off when printed with the Adobe
PostScript cartridge on a Hewlett-Packard (HP) LaserJet II when
Adobe's Font Foundry software is installed.

Occasionally, the tops and bottoms of ascending or descending
characters may be clipped on the screen; however, they will print
correctly. For more information on this, query on the words:

  clipped
  ascending
  descending
  characters
  word
  windows

More Information:

The Adobe PostScript cartridge comes with PostScript software, which
includes Font Foundry. The Font Foundry installation generates
.PFM font metrics files and inserts corresponding soft font lines into
the printer section of the WIN.INI file as follows:

   Softfonts=n
   Softfont1=c:\psfonts\pfm\po__10H.pfm,c:\pclfonts\po__10H.sfp
   Softfont2=c:\psfonts\pfm\po__12h.pfm,c:\pclfonts\po__12h.sfp
   ...
   Softfontn=c:\psfonts\pfm\po_____.pfm,c:\pclfonts\po_____.sfp

These files are not necessary to print with the PostScript cartridge
from Windows and Word for Windows.  These soft font lines should be
removed from the WIN.INI file for the text to print properly in tables
in Word for Windows.

For further information, contact Adobe Systems, Inc. at (415) 961-4992.

Reference(s):

"User's Guide for the Adobe Cartridge Products," pages 62-66.

Adobe product support technician, (415) 961-4992.

Additional reference words: w4wprint w4wtable 6.00 wm_word 



No Header in WinWord Print Preview When Using Bin Feeder
Article ID: Q70017
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When printing a document with a Bin Feeder selected in the File
Printer Setup dialog box in Word for Windows, a header will not print
or appear in print preview unless it is specified to print 1 inch or
farther from the top of the page.

More Information:

Some printers (such as 9-pin and 24-pin printers) offer the paper feed
selections of tractor feed or bin feeder. When you print a document
using a bin feeder, the paper is scrolled up 1 inch automatically
before printing begins. Because of this functionality, a header will
not print inside that 1 inch area at the top of the paper. Because the
default setting for the header is 0.5 inch from the top of the paper,
the header will not display in print preview or print unless it is
manually set to print 1 inch or farther from the edge of the page.

Solution:

To display the header in print preview and print it, do one of the
following:

Word for Windows 6.x
--------------------
1. From the File menu, choose Page Setup, select the paper source
   tab, and set the source to tractor feed.

2. Format the document for a top margin that is greater than 1 inch.
   Then choose the Margins tab from the File Page Setup menu. 
   Change  From Edge measurement for the header to 1 inch or greater.

Word for Windows 2.x
--------------------
1. From the format menu, choose Page Layout, select the paper source
   button, and set the source to tractor feed.

2. Format the document for a top margin that is greater than 1 inch.
   Then choose Header/Footer from the View menu, select Options and
   change the Distance From Edge for the header to 1 inch or greater.

Word for Windows 1.x
--------------------
1. From the File menu, choose Printer Setup, select Setup and select
   Tractor Feed for the Paper Feed.



   -or-

2. Format the document for a top margin that is greater than 1 inch.
   Then choose Header/Footer from the Edit menu, select Options and
   change the Distance From Edge for the header to 1 inch or greater.

To Illustrate:

1. Set up one of the Windows 9-pin or 24-pin printers through the
   Control Panel.

2. In Word for Windows use the appropriate commands to set the paper
   source to the bin feeder.

3. Verify that the Distance from Edge measurement for the header is
   smaller than one inch.  Type in an example header.

4. From the File menu, choose Print Preview. Note that the header does
   not display at the top of the page.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 148, 149.

Additional reference words: w4wformat 6.00 wm_word 
w4wprint 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 



Keystrokes to Insert Page Number, Date, and Time in WinWord
Article ID: Q70018
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When you are in the header/footer pane of a document, the Page Number,
Date of Printing, and Time of Printing fields may be inserted by using
keystrokes instead of using a mouse to select the Date, Time, and Page
icons on the header/footer icon bar.

The keystrokes to insert the fields are:

   ALT+SHIFT+P (inserts Page Number)
   ALT+SHIFT+D (inserts Date of Printing)
   ALT+SHIFT+T (inserts Time of Printing)

More Information:

These keystrokes may also be used in a document without activating
the header/footer.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 147 and 150.

Additional reference words: w4wprint w4wfield 1.00 1.10 1.10a 2.00 6.00 
wm_word 2.00a 2.00a-CD 2.00b 2.00c 



Bin/Tray Selection on HP LaserJet IIP and IIIP
Article ID: Q71008
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

The Hewlett-Packard (HP) LaserJet IIP and IIIP have an optional lower
cassette (LC) tray that you can install underneath the printer. If the
LC tray is installed, the printer defaults to the paper source
selection setting TRAY=LC ONLY. Bin selection from the Printer Setup
dialog box does not work if this setting is activated. (You can access
the Printer Setup dialog box by choosing Printer Setup from the File
Menu.)

To properly use the bin selection settings for both the LaserJet IIP
and IIIP, set the tray selection on the printer to TRAY=BOTH. To reset
the tray selection on the printer follow these steps:

1. If the ONLINE light is on, push the button to turn it off.

2. Press the menu button until the display shows the TRAY=selection.

3. Press the PLUS SIGN key (+) until the selection changes to
   TRAY=BOTH.

4. Press the ENTER key.

5. Press the ONLINE key to restore the printer to READY mode.

Reference(s):

LaserJet IIP Printer, "Technical Reference Manual," 8/89, Edition 1,
pages 5-7

Additional reference words: w4wprint 1.0 1.1 1.1a 1.00 1.10 1.10a  2.0 
6.00 wm_word 2.00 2.0a 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD envelope MP 
Multi-purpose



HP LaserJet Cartridge Characters Cut in Half in WinWord
Article ID: Q74637
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

If one of the font characters on a cartridge loaded into a
Hewlett-Packard (HP) LaserJet printer is being cut in half on a
Microsoft Word for Windows printout, follow these steps:

1. Turn the printer off.

2. Take the cartridge(s) out of slot(s) in printer.

3. Re-seat the cartridge(s).

4. Turn the printer back on.
 
Additional reference words: w4wprint w4wfont 1.00 1.10 1.10a 2.00 2.00a  
6.00 wm_word 2.00a-CD 2.00b 2.00c 



Automatic Paper Tray Switching on HP LaserJet in WinWord
Article ID: Q75758
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Word for Windows Version 6.0
----------------------------

To switch paper trays in Microsoft Word for Windows version 6.0,
choose Page Setup from the File menu, then choose the Paper Source
tab. You can select a paper source in the First Page and Other
Pages boxes. The options that appear in these boxes are those
available for the printer currently selected in the Print dialog
box. In the Apply To box, select the Whole Document or the This Point
Forward option. If you select This Point Forward, Word will force a
section break (which will also produce a page break).

Word for Windows Version 2.0
----------------------------

To switch paper trays in Microsoft Word for Windows version 2.0,
choose Page Setup from the Format menu, then choose the Paper Source
button. You can select a paper source in the First Page and Other
Pages boxes. The options that appear in these boxes are those
available for the printer currently selected in the Print Setup dialog
box. In the Apply To box, select the Whole Document or the This Point
Forward option. If you select This Point Forward, Word will force a
section break (which will also produce a page break).

Word for Windows Version 1.x
----------------------------

When you are printing a Word for Windows document, you can switch
paper trays automatically on a Hewlett-Packard (HP) LaserJet printer
by using the PRINT field and HP LaserJet escape codes.

More Information:

You can use the PRINT field, described on page 104 of the "Microsoft
Word for Windows User's Reference," to embed printer control codes in
a Word document. These codes go directly to the printer's processor.
Enter the PRINT field as the very first item on the first page (or
first of a series of pages) that you want to print from another tray.
To do this, use the following steps:

1. Press CTRL+F9, and type PRINT between the braces ({}).

2. Press the SPACEBAR once.



3. Type the escape character, 027, and type a double quotation mark.
   Enter the code used to switch trays, and another double quotation
   mark. The entire decimal code for Paper Feed Selection is as
   follows:

      027"&l#H"

   The result should appear as follows:

      {PRINT 027"&l#H"}

   where "#" is the numeric code of the feed option desired. The
   following is the list of the feed option numeric code and the
   corresponding feed option:

   Code    Feed Option
   ----    -----------

   0       page eject
   1       upper tray feed
   2       manual feed
   3       manual envelope feed
   4       lower tray
   6       envelope feeder (lower cassette on IIIP)

For example, the complete code to change the paper feed to manual is:

   {print 027"&l2H"}

The inserted fields will command the printer to print the following
pages from the bin specified by the numeric code of the feed option
inside the field.

This method was tested on the HP IIP and IIIsi, and the Panasonic
KX-P4450 and 4450i. The codes work as advertised with the HP printers;
however, the codes cause the Panasonic printers to print reversed.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 218-242

"Microsoft Word for Windows User's Reference," version 1.x, page 104

"The LaserJet Handbook" (Bennett & Randall, Brady Books, 1990, page
370

Additional reference words: w4wprint w4wfield 1.0 1.1 1.1a 1.00 1.10 
6.00 wm_word 1.10a 2.00



Auto Line Spacing with Brother HL-8 Printer Driver
Article ID: Q77013
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

Documents formatted for the font Brougham, point size 12, and "Auto"
line spacing in Microsoft Word for Windows are incorrectly spaced when
using the Brother HL-8 printer driver (BROHL.DRV).

More Information:

The Brother HL-8 printer emulates the Hewlett-Packard (HP) LaserJet
Series II. The Brother's internal Brougham font is equivalent to the
LaserJet's Courier font, which is normally spaced at 6 lines per inch.
The Brother driver sets "Auto" line spacing for the Brougham 12-point
font to 5 lines per inch instead of 6 lines per inch.

Workaround:

To obtain the correct line spacing when using the Brougham 12-point
font, format the text for "Single" line spacing instead of "Auto" in
the Format Paragraph menu.

Brother has confirmed this to be a problem with its BROHL.DRV driver
version 1.0, which is included in the Microsoft Windows version 3.0
Supplemental Driver Library.

Reference(s):

Printer Driver Liaison Testing
"Microsoft Word for Windows User's Reference," pages 174-175.

Additional reference words: w4wprint 1.00 1.10 1.10a 3.00 2.00 2.00a 
6.00 wm_word 2.00a-CD 2.00b 2.00c 



WinWord: Creating Special Characters with Overstrike
Article ID: Q77829
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you may want to use a character that is
not supported by the ANSI character set or by your printer. You can
create such characters by combining two characters using the
overstrike capabilities of the Equation field.

MORE INFORMATION
================

To insert the field characters (braces) from the keyboard, press
CTRL+F9.

The field {eq \o(o,-)} produces an "o" with a line through it. You
must apply superscript character formatting to the '-' to position it
above the "o".

Note the following important parts of the above equation field:

 - "eq" tells Word for Windows it is an equation field.

 - "\o" is the code for overstrike.

 - "(o,-)" tells Word for Windows to overstrike the "o" with the "-".

Horizontal lines of different sizes and vertical positions are also
available to supplement the dash and underline characters found on the
keyboard. Others include the Times Roman characters 150 (em dash) and
151 (en dash) and the Symbol characters 45 (similar to a keyboard
dash, but longer) and 190. The em and en dashes are also available in
most standard fonts. The Symbol character 190 is the longest available
horizontal line character.

Another example of the overstrike capibilities, is the European "S" with
a dash (-) superscripted above. Use the following eq field to create
this character:

   {eq S\d\ba5()\s\up8(-)}

This equation takes the uppercase "S" character moves the (-)
character back by 5 points and then superscripts by 8 points.

Note: If the characters do not overstrike correctly, a country other
than the United States may be selected in the International dialog



box. To change the country configuration, choose the Control Panel
icon in Program Manager, choose the International icon, and select
United States under Country. The characters should then overstrike
correctly.

For more information on inserting special characters in your Word for
Windows document, see pages 153-155 of the "Microsoft Word for Windows
User's Guide," version 2.0. Refer to pages 427 and 428 of the
"Microsoft Word for Windows User's Reference," version 1.x, to find
other possible combinations of characters. Similar information is
available in the "Microsoft Windows User's Guide," version 3.0, pages
567-570.

For more information on obtaining a list of the available characters,
including the extended characters on a given printer font, query on
the following words in the Microsoft Knowledge Base:

   extended and character and test and macro

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.x, pages 85,
135, 138-139, 352, 427-428

"Microsoft Word for Windows User's Guide," version 2.0, pages 144,
146, 747-748, 752-756, 758

"Microsoft Windows User's Guide," version 3.0, pages 567-570

Additional reference words: w4wprint w4wfont 1.0 1.1 1.1a 2.00 1.00
1.10 1.10a long short vowel sounds vowels dictionary pronunciation



Printing to a File Repeatedly Prompts for Filename
Article ID: Q78121
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0
-------------------------------------------------------------------

Summary:

With Windows 3.0, if you print a Microsoft Word for Windows version
2.0 document containing mixed portrait and landscape orientations to a
file, Word prompts you for a new filename each time the orientation
changes throughout the document. If you print the same document with
Windows 3.1, Word will prompt you for only one filename.

More Information: 

With Windows 3.0, when you print to a printer, each change of
orientation is sent to the printer as a separate print request. The
same behavior occurs if you print to a file; however, Word for Windows
prompts you for a filename for each change of orientation throughout
the document. For example, if you have a document that changes
orientation five times, when you print that document to a file, Word
prompts you to enter a filename five times.

Make sure that you enter different filenames each time you are
prompted. If you enter the same filename each time, Word for Windows
overwrites the previous file, and only the last portion of your
document is saved.

With Windows 3.1, the entire document is sent as one print request. If
you print to a file, Word will prompt you once for an output filename,
regardless of the number of different orientations in the document.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00 
wm_word w4wprint



Accessing Character Sets Internal to Your Printer in WinWord
Article ID: Q78652
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

Because Microsoft Windows and Microsoft Word for Windows use the ANSI
character set, character sets available from your printer (also called
symbol sets) may not be directly accessible or viewable; however, you
can print most of these characters by using a PRINT field in a Word
for Windows document.

Some characters, such as the printer control characters, are not
accessible and cannot be printed. Word usually differentiates these
characters from accessible characters by displaying them in a
different color.

MORE INFORMATION
================

To access the printer's character sets, you need to know the escape
sequence for the character set you want to access, the escape sequence
for the default character set of the printer, and the character number
of the symbol you want to print. This information is usually found in
the back of your printer manual.

Steps to Access Printer Character Sets with a PRINT Field
---------------------------------------------------------

1. Place the insertion point at the beginning of the line in which you
   want the special character to appear.

2. Press CTRL+F9 to insert a field code. Between the field braces,
   type "print" (without the quotation marks), followed by the escape
   sequence of the character set you want to access. Place the escape
   sequence within quotation marks. For example, on the Hewlett-Packard
   (HP) LaserJet IIIp printer, the escape sequence to access the PC-8
   character set is "ESC(10U" (to include the "ESC" part of the code, 
   use the ALT+027 key combination. It appears as a vertical line). The 
   Word for Windows PRINT field appears on-screen as follows:

      {print "|(10U"}

   Note: The | character appears as a box when using Windows 3.1.
   Note: The PRINT field codes must appear on the left margin so that
   they do not send linefeeds to the printer.

3. Position the insertion point where you want the special character



   to print in the sentence. Press ALT+0 plus the character's decimal
   value on the numeric keypad (with NUM LOCK turned on). Note that the
   screen displays either a vertical line or the ANSI equivalent symbol
   because the screen font displays only ANSI characters. For example, 
   to print the "smiley" face symbol (available in the PC-8 character
   set on an HP LaserJet IIIp printer), type "ALT+0001" (without 
   the quotation marks). A vertical line appears on the screen, as 
   shown in the following example:
  
      {print "|(10U"}This is the smiley face symbol for the
      PC-8 character set |.

   Note: The vertical bar that follows the above text indicates the
   position where the smiley face symbol prints.

4. At the beginning of the next line, press CTRL+F9 to insert a field.
   Between the braces, type "print" (without the quotation marks)
   followed by the escape sequence (within quotation marks) of the
   default character set. For example, to return to the default 
   character set of the HP LaserJet IIIp printer (Roman8), you need the
   sequence "ESC(8U" (to include the "ESC" portion of the code,
   press ALT+027).

   {print "|(10U"}This is the "smiley" face symbol from the
   PC-8 character set |.
   {print "|(8U"}

In Word for Windows version 1.x, you can enter the escape sequence
into the PRINT field by selecting Print from the Insert Field menu and
typing the ALT+027 key combination in the Field Code box. You can also
enter the PRINT field directly on-screen by pressing CTRL+F9 and
typing the characters within the field braces.

In Word for Windows version 2.0, you must enter the escape sequence
directly on-screen by pressing CTRL+F9 and typing the characters
within the field braces because the Insert Field menu option does not
accept the ALT+027 key combination; therefore, it cannot insert the
escape sequence into the PRINT field.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, page 752

"Microsoft Word for Windows User's Reference," version 1.x, page 352

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 
6.00 wm_word 2.00c  w4wfont w4wprint



WinWord Printer Setup Changes the Default Printer in Windows
Article ID: Q78800
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, changing the printer using the Print
Setup command (Printer Setup in version 1.x) changes the default
printer for the Microsoft Windows environment.

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose Print Setup (Printer Setup in version
   1.x).

2. Select a configured printer other than the currently selected one.

3. Open the Windows Control Panel, and choose the Printers icon.

The default printer is now the printer you selected in step 2.

Microsoft is researching this problem and will post new information
here as it becomes available.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 122-123
"Microsoft Word for Windows User's Reference," version 1.x, page 271
"Microsoft Windows Graphical Environment User's Guide," version 3.0,
page 170

Additional reference words: w4wprint 1.00 1.10 1.10a 2.00 2.0a 2.00a   
6.00 wm_word 2.00b 2.00a-CD



Creating Envelopes in WinWord 2.0 with an Okilaser 840 Printer
Article ID: Q79023
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions  2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
Summary:

The Create Envelope command in Microsoft Word for Windows version 2.0 
(or Envelopes and Labels in Word 6.0) does not provide correctly printed 
envelopes if you set the Okidata Okilaser 840 printer as a PostScript 
printer using the OL840518.WPD printer driver from the Microsoft Windows 
version 3.0 Supplemental Driver Library or the Microsoft Windows 
operating system version 3.1.

More Information:

You can set the Okidata Okilaser 840 printer to emulate a PostScript
printer or the Hewlett-Packard (HP) LaserJet Series II printer. When
set as a PostScript printer, the Okilaser can emulate the Apple
LaserWriter printer, or you can install the OL840518.WPD printer
driver to provide direct PostScript support for the Okilaser 840.
However, if you use OL840518.WPD, Word cannot print envelopes
correctly.

Workaround
----------

To use the Apple LaserWriter or HP LaserJet II emulation and print
envelopes, use the appropriate method below:

 - For PostScript emulation, set the Okilaser 840 as an Apple
   LaserWriter, and feed the envelope into the printer with the return
   address edge entering the printer first.

 - For HP LaserJet Series II emulation, feed the envelope into the
   printer with the return address edge entering the printer last.

   Note: To use the LaserJet mode with Windows 3.1, you should use the
   Okidata 800 driver.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 118-123

Additional reference words: 2.00 w4wprint laser jet tool bar 6.00 
wm_word toolbar button tools sdl win31 3.10 w4wenvelope 6.00 oki



Superscript or Subscript Text Displays Truncated in WinWord
Article ID: Q79089
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, superscript and subscript characters
may appear truncated on the display. This is a result of the screen
font; the superscript and subscript characters do print correctly.

STATUS
======
 
Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.
 
To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Versions 1.x of Microsoft Word for Windows position superscript and
subscript characters by adjusting the entire line spacing relative to
the additional space required by the character. Versions 2.0x of Word
for Windows position superscript and subscript characters without
adjusting line spacing; this can cause the top or bottom of the
characters to appear truncated. The visible range, measured from the
base line for ascenders and descenders in a screen font, is set by the
manufacturer of the font; superscript and subscript characters may
intrude on the top or bottom of the range and display truncated on the
screen. This is a problem with screen display only; it does not affect
the printed characters in Word for Windows.

TrueType fonts exhibit this problem, and Adobe Type Manager (ATM) may
exhibit it. Other font packages may or may not truncate superscript
and subscript characters on the screen, depending on their
specifications.

Note:  According to Adobe Technical Support, versions of ATM prior to
2.0 have not been tested and are not guaranteed compatibility under
Windows 3.1.

WORKAROUND



==========

If you want to view all the superscript and subscript characters, use
an EQ field to format superscripts and subscripts. This method
duplicates the line spacing behavior of versions 1.x of Word for
Windows. The following is a sample EQ field to subscript a character
by 3 points:

   {eq \s\do3(1)}

This field forces Word to adjust the line spacing for the entire line.
Note: To create field braces, press CTRL+F9, then type the field
contents.

If you want the line spacing to be fixed when you use this equation,
type a minus sign in front of the number in the Line Spacing box
(which is found in the Paragraph dialog box). This forces absolute
spacing.

For more information on line spacing with superscript and subscript
characters:

 - Search for "field" and "formulas" using the the Help menu.

 - Query on the following words in the Microsoft Knowledge Base:

      line and spacing and offset and superscript and subscript
      and w4wprint

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.x, pages 135-
140

"Microsoft Word for Windows User's Guide," version 2.0, pages 146-147

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
w4wfont cut off



WinWord: Page Setup Orientation Overrides Print Setup Setting
Article ID: Q79645
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Setting the orientation of a document (portrait or landscape mode) in
the Microsoft Word for Windows version 6.0 Page Setup dialog box
overrides any selection made in the Print Setup dialog box.

More Information:
 
You can set the orientation of each page of your document individually
with the following steps:

1. From the File menu, choose Page Setup.
 
2. Select Size and Orientation. Select the Portrait or Landscape
   option in the Orientation box, and choose the OK button.

You can set the overall page orientation of your document with the
following steps:

1. From the File menu, choose Print Setup. Select Setup.
  
2. Select Portrait or Landscape in the Orientation box and choose the
   OK button.

Word for Windows does not change the orientation setting in the Print
Setup dialog box; it simply bypasses that setting for the current
print job.

Additional reference words: w4wformat 6.00 wm_word 
w4wprint 2.00 2.00a 2.00a-CD 2.00b 2.00c



WinWord: Envelopes Don't Print with Reverse Print Order Option
Article ID: Q79905
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows version 2.0, if you choose the Create
Envelope command when the Reverse Print Order option is selected,
envelopes do not print. Word acts as if it is printing; however, the
printer is inactive. To run the Create Envelope command, choose the
Envelope button on the tool bar or choose the command from the Tools
menu.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

WORKAROUND
==========

To work around this problem, use one of the following methods:

 - From the Tools menu, choose Options, select the Print category, and
   clear the Reverse Print Order check box. Choose the OK button.

 - From the Tools menu, choose Create Envelope, select the Add to
   Document button, then print it using the File Print command.

HP DeskJet
----------

The HP DeskJet printer outputs printed pages in reverse order. The
Reverse Print Order option causes pages to be printed in the correct
order. However, if you select this option, envelopes do not print
using the Create Envelope command.

If your printer is an HP DeskJet, you can modify the
ToolsCreateEnvelope macro to clear the Reverse Printer Order option
when creating an envelope and then select the option again after the



envelope prints. To modify the ToolsCreate Envelope macro, add the
lines "ToolsOptionsPrint .Reverse=0" and "ToolsOptionsPrint
.Reverse=1" to the macro, as follows:

Sub Main
ToolsOptionsPrint .Reverse = 0
Dim dlg As ToolsCreateEnvelope
GetCurValues dlg
x = Dialog(dlg)
If x = - 1 Then ToolsCreateEnvelope dlg
ToolsOptionsPrint .Reverse = 1
End Sub

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 117-122

Additional reference words: 2.00 w4wprint w4wmacro hewlett packard 500
plus jam feed backward toolbar dj w4wenvelope



WinWord 2.0: Envelope Feeder Option Unavailable with ATM
Article ID: Q80150
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

If Microsoft Word for Windows is running when Adobe Type Manager (ATM)
is active and the driver is the PCL/HP LaserJet driver, the "Printer's
Envelope Feeder has been Installed" option is always unavailable.
Envelope options are accessed by selecting the Tools menu, choosing
Options, and choosing the Print icon.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This functionality was changed
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

To make the "Printer's Envelope Feeder has been Installed" option
available, you must turn off ATM. Then choose Options from the Tools
menu, select the Print category, and select the "Printer's Envelope
Feeder has been Installed" option in the Envelope Options box.

Note:  According to Adobe Technical Support, versions of ATM prior to
2.0 have not been tested and are not guaranteed compatibility under
Windows 3.1.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 732

Additional reference words: gray grey w4wprint soft font w4wfont
button create 2.00 2.00a 2.00a-CD 2.00b 2.00c 



Scalable HP Fonts Show in Font Installer, Not in Applications
Article ID: Q81038
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you install scalable fonts using the Hewlett-Packard (HP) Font
Installer and are using the MS-DOS SUBST command, you receive the
following error message:

   PCL/HP Font Installer - Scalable printer font file not built!

You may have ignored this error message when it displayed because the
scalable printer fonts appear to install correctly; they display in
the installed font box of the HP Font Installer. However, these same
printer fonts do not appear on the Font list of Microsoft Word for
Windows or any other Windows-based application.

More Information:

There are two causes of the above error message:

 - Bad data or missing headers have corrupted the font being used to
   create the printer file.

  -or-

 - The MS-DOS SUBST drive was typed with an extra backslash character
   (\). For example, if you substitute "Z:" for "D:\PCLFONTS," the
   following line appears in your AUTOEXEC.BAT file:

      SUBST Z: D:\PCLFONTS

If you type "Z:\" (without the quotation marks) instead of "Z:" when
prompted by the HP Font Installer to type the drive and path for the
scalable screen font and scalable printer font, the Font Installer
installs the scalable screen font correctly; but when it tries to
create and install the scalable printer font, it displays the
"Scalable printer font file not built!" error message.

If you use substituted drives for the printer font directory, you must
NOT type an extra backslash at the end of the drive letter (for
example, type "Z:" instead of "Z:\"). If the problem persists after
you correct the substituted drive names, try using the actual path
(for example, "D:\PCLFONTS" instead of "Z:").

If you are not using substituted drives and the above solutions do not
work, the printer font file may be corrupt. Try installing the font
from the original disk. If you don't have the original disk, contact



the font manufacturer for an updated copy.

Additional reference words: hppcl5a.drv IFW w4wprint w4wfont 6.00 
wm_word 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wlaserjet 
typeface w_win3



Printing Multiple Pages with Single-Sheet Feed to a Dot Matrix
Article ID: Q81084
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

When you print a multiple-page document to a dot-matrix printer using a
single-sheet feed, Windows Print Manager stalls the print job after each
page. Print Manager receives a "Paper Out" message from the printer that
causes it to stall. You can use the macros below in Word for Windows to
pause the print job between each page so you can add paper.

MORE INFORMATION
================

The following macros prompt you for the number of pages you want to print.
Then they determine the number of pages in your document and display the
following message:

   Ready to print page X. Press OK when the paper is loaded?

Choose the OK button to print the listed page or choose the Cancel button
to terminate the print job.

WARNING: ANY USE BY YOU OF THE CODE PROVIDED IN THIS ARTICLE IS AT
YOUR OWN RISK. Microsoft provides this macro code "as is" without
warranty of any kind, either express or implied, including but not
limited to the implied warranties of merchantability and/or fitness
for a particular purpose.

Macro for Word for Windows Version 6.0
--------------------------------------

Sub Main
  StartOfDocument
  FileSummaryInfo .Update
  Dim dlg As DocumentStatistics
  GetCurValues dlg
  Pages = Val(dlg.Pages)
  ncopies = 0
  On Error Resume Next
  ncopies = Val(InputBox$("Print how many copies of each page?"))
  If Not Err Then
    Err = 0
    For x = 1 To Pages
      For i = 1 To nCopies
        If MsgBox("Ready to print copy" + Str$(i) + " of page" + Str$(x) \
          + ".  " + "Press OK when the paper is loaded?", 1) Then



          FilePrint .Range = 3, .From = Str$(x), .To = Str$(x)
        Else
          i = nCopies
          x = Pages
        End If
      Next
    Next
  End If
End Sub

Macro for Word for Windows Version 2.0
--------------------------------------

Sub Main
  StartOfDocument
  fView = ViewFieldCodes()
  If fView <> 0 Then ViewFieldCodes
  InsertField "numpages"
  CharLeft 1, 1
  UpdateFields
  Pages = Val(Selection$())
  EditClear
  ncopies = 0
  On Error Resume Next
  ncopies = Val(InputBox$("Print how many copies of each page?"))
  If Not Err then
    Err = 0
    For x = 1 To Pages
      For I = 1 to nCopies
        If MsgBox("Ready to print copy" + Str$(i) + " of page" + Str$(x) \
          + ".  " + "Press OK when the paper is loaded?", 1) Then
          FilePrint .Range = 3, .From = Str$(x), .To = Str$(x)
        Else
          i = nCopies
          x = Pages
        End If
      Next
    Next
  End If
  If fView <> 0 Then ViewFieldCodes
End Sub

Macro for Word for Windows Versions 1.x
---------------------------------------

Sub MAIN
  StartOfDocument
  Dim dlg As ViewPreferences
  GetCurValues dlg
  prefer = dlg.ShowAll
  If prefer <> 0 Then dlg.ShowAll = 0
  ViewPreferences .ShowAll = dlg.ShowAll
  fview = ViewFieldCodes()
  If fview <> 0 Then ViewFieldCodes
  InsertField "numpages"
  CharLeft 1, 1
  UpdateFields



  pages = Val(Selection$())
  EditClear
  ncopies = 0
  On Error Resume Next
  ncopies = Val(InputBox$("Print how many copies of each page?"))
  If Not Err Then
    Err = 0
    For x = 1 To pages
      For I = 1 to nCopies
        If MsgBox("Ready to print copy" + Str$(i) + " of page" + Str$(x) \
          + ".  " + "Press OK when the paper is loaded?", 1) Then
          FilePrint .Range = 2, .From = Str$(x), .To = Str$(x)
        Else
          I = nCopies
          x = Pages
        End If
      Next
    Next
  End If
  If fview <> 0 Then ViewFieldCodes
  If prefer <> 0 Then dlg.ShowAll = 1
  ViewPreferences .ShowAll = dlg.ShowAll
End Sub

Note: You can run this macro instead of the default FilePrint macro to
print multiple pages using single-sheet feed.

REFERENCES
==========

"Microsoft Word for Windows and OS/2 Technical Reference," pages 63,
66, 203, 280, 283
"Using WordBasic," by WexTech Systems and Microsoft, pages 45-49, 226,
234

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c
w4wmacro w4wprint dmp  offline ready epson



WinWord: White Text with Black Shading Prints as Black Text
Article ID: Q81144
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you print white text on a shaded
black background (sometimes referred to as reverse video), the entire
paragraph may print as a solid black box.

More Information:

The following are the two major reasons that white text on a black
background prints in black:

 - The printer does not support white text. Most Hewlett-Packard PCL
   Level 4 printers (or compatible printers) and dot-matrix printers do
   not support the printing of white text. This includes all printers
   that use the EPSON24.DRV, IBMPRO24.DRV, and HPPCL.DRV Windows printer
   drivers.

  -or-

 - The printer supports white text, but the printer driver has an
   incompatibility with 256-color video drivers. Some printer drivers
   cannot print reverse text when a 256-color video driver is installed
   in Microsoft Windows. A driver known to have this problem is the HP
   LaserJet Series III driver HPPCL5A.DRV (versions prior to 3.85).
   Installing HPPCL5A.DRV version 3.85, which ships with version 2.0 of
   Word for Windows, or updating to version 3.86 of this driver corrects
   the problem.

An application note containing the HP PCL/HP LaserJet III driver
version 30.3.86 for Windows version 3.0 is available. To obtain this
application note, call Microsoft Product Support Services at (206)
454-2030. The application note number is WW0505.

This information applies to version 31.3.89 of the HP LaserJet III
driver (HPPCL5A.DRV), which ships with Windows 3.1.

Workaround for Word 6.0:
------------------------

1. Select the text to be printed in reverse color of the background

2. From the Format menu select Font and choose White from the Color 
   drop-down dialog.

3. From the Format menu select Borders and Shading and choose the 



   Shading dialog tab. Choose the Custom button and in the Background 
   dialog choose Dk Blue.

4. From the File menu select Print.  Choose Printer. Choose Options.
   select the option "Print Truetype as graphics". Choose OK

Workaround for Word 2.0:
------------------------

1. Select the text to be printed in reverse color of the background

2. From the Format menu select Character and choose White from the Color 
   drop-down dialog.

3. From the Format menu select Border and choose the Shading button.
   Choose the Custom button and in the Background dialog choose Dk Blue.

4. From the File menu select Print Setup.  Choose Setup. Choose Options
   select the option "Print Truetype as graphics". Choose OK

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 377-379,
459-460

Additional reference words: w4wfont w4wlaserjet w4wprint 30.3.85 2.00 
6.00 wm_word 2.00a 2.0a pcl4



WinWord Cannot Print Character 160 (ALT+0160)
Article ID: Q81148
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, when you press ALT+0160 (from the
numeric keypad), a degree symbol displays on the screen in most fonts
when you view nonprinting characters. This character does not display
when you turn off the viewing of nonprinting characters, nor does it
preview or print.

MORE INFORMATION
================

Character 160 is reserved by Word for Windows for the nonbreaking
space.

To correctly access the degree character in Word for Windows, use the 
Symbol command from the Insert menu.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 60, 90-91,
153-155.
"Microsoft Word for Windows User's Reference," version 1.x, pages 35, 
52,
177, 266, 352-353.

Additional reference words: w4wfont 1.00 1.10 1.10a 6.00 wm_word 
2.00 2.00a 2.00a-CD 2.00b 2.00c  w4wprint ansi ascii code



WinWord: Printing an Em Dash Using an Outline-Style Font
Article ID: Q81227
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

If you print the em dash character with an outline-style font,
Microsoft Word for Windows may print the character with a series of
vertical lines dissecting the outlined em dash. If you print the same
character in Microsoft Windows Write, it will print correctly.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this
problem and will post more information here in the Microsoft Knowledge
Base as it becomes available.

MORE INFORMATION
================

Word for Windows prints the em dash as a series of overlapping dashes,
rather than a single character. If you print the em dash using an
outline-style font, the left and right edges of each overlapping dash
be visible inside the printed dash and will print. This overlapping
will not be visible if you use a solid font.

Steps to Reproduce Problem
--------------------------

1. From the Control Panel in Windows, choose the Printers icon, and
   activate the HP LaserJet Series II printer (PCL / HP LaserJet). If 
   you are using the Microsoft Windows operating system version 3.1,
   you can activate the universal printer driver for the HP LaserJet
   Series II version 1.1.
  

2. Install the Hewlett-Packard AG soft font set using the printer
   driver's soft font installer. This font set includes the Helv Outline
   font in point sizes 14, 18, 24, 30, 36.

3. In the Format Character dialog box of Word for Windows, select the
   Helv Outline font and an available font size.

4. With NUM LOCK turned on, press ALT+Keypad 0150 to insert the em
   dash.



5. From the File menu, choose Print, then choose the OK button.

If you activate the Hewlett-Packard Series III printer (HPPCL5A) in
step 1 above, Word for Windows will print a solid em dash, rather than
an outlined em dash.

REFERENCES
==========

"Microsoft Windows User's Guide," version 3.0, pages 158-161, 168

"Microsoft Word for Windows User's Guide," version 2.0, page 92

Additional reference words: w4wfont hollow broken 1.00 1.10 1.10a 2.00 
6.00 wm_word 
2.00a w4wlaserjet w4wprint



Superscript and Subscript Underline Misaligns in WinWord 2.0
Article ID: Q81418
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, the underline for superscript and
subscript text does not align with the underline for normal text.

WORKAROUND
==========

To work around this problem, create an equation field using the
overstrike function to underscore words or phrases that contain
super/subscripted characters, as in the following example:

   Syntax: {eq \o(Text,Underscore characters)}

   {eq \o(Apple,_____)}
    
In the syntax above, "Text" is the string containing superscript text
to be underlined, and "Underscore characters" is the actual characters
to be used to underscore the "Text" characters. The braces for the
equation field are created by pressing CTRL+F9. Type the text between
the braces.
  
Note: The underscore character may not match the one used by Word's
underline character format command. You may need to experiment with
different underscore characters (different font, point size, and so
forth) to achieve a continuous underscore effect.

STEPS TO REPRODUCE PROBLEM
==========================

1. Type some text in a Word for Windows version 2.0  document.
 
2. Select a portion of the text.

3. From the Format menu, choose Character.

4. From the Super/subscript list box, select superscript.

5. Select all of the text in your document.

6. From the Format menu, choose Character.

7. From the Underline list box, select Single.



Microsoft has confirmed this to be a problem in Word for Windows
versions 2.x and 6.0. We are researching this problem and will post
new information here as it becomes available.

Additional reference words: w4wfont w4wprint w4wfield 2.00 2.00a 6.00 
wm_word 2.00a-CD 2.00b 2.00c 



WinWord: Cannot Print Character 255 (ALT+255) with HPPCL5A.DRV
Article ID: Q81474
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, character 255 (ALT+0255 or the last
symbol in the Insert Symbol dialog box) may not print if you are using
the Hewlett-Packard (HP) LaserJet Series III driver, HPPCL5A.DRV, and
the character is formatted for a downloadable, bitmapped, soft font.

More Information:

The HPPCL5A.DRV printer driver is unable to recognize the 255th
location in a bitmapped soft font. When a bitmapped soft font is
downloaded to the printer, the character is not sent and therefore is
not printed on the page. This problem does not occur with scalable
soft fonts.
  
To work around this problem, HP recommends using one of the following
methods:

 - Format the character for an internal font, system font, or scalable
   soft font.

  -or-
 
 - Download the bitmapped soft font from outside Microsoft Windows,
   then designate it as a permanent soft font using the HP download
   utility. To use the HP download utility, follow these steps:
  
   1. In the Control Panel, choose the Printers icon.
  
   2. Select the HP LaserJet III in the Installed Printers box, choose
      the Configure button, then choose the Setup button. 
   
   3. In the HP LaserJet III box, choose the Fonts button. Select the
      soft font, and select the "*Permanent" option.

Additional reference words: 1.00 1.0 1.10 1.1 1.10a 1.1a 2.0 2.00 2.0a 
6.00 wm_word 2.00a w4wprint soft blank missing



PostScript WIN.INI Setting for WinWord Landscape Orientation
Article ID: Q83741
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, it is sometimes necessary to use
printer heuristics to change the way Word works with a printer driver.
These heuristics should be added to the [Microsoft Word 2.0] section
of the WIN.INI file and only apply to Word for Windows.

The Microsoft Windows operating system version 3.1 has a WIN.INI
setting for PostScript orientation that applies to all Windows
applications. You can use this setting instead of a heuristic in the
[Microsoft Word 2.0] section.

There are no WIN.INI settings for Word version 6.0 for Windows.  These
settings are contained in the WINWORD.OPT

More Information:

By default, Windows version 3.1 PostScript drivers rotate landscape
orientation 90 degrees. Previous Windows 3.0 drivers and Windows 2.x
PostScript drivers rotate landscape orientation 270 degrees. To change
this rotation, add the following line in the WIN.INI file in the
[ModelName,Port] section (where "ModelName"is your printer):

   LandscapeOrient=<angle>

The default setting is 90. To achieve the landscape orientation of
older drivers, use 270.

You may want to try the above setting if you experience the following
problems:

 - Envelopes or labels print upside down in Windows 3.1 but print
   correctly in Windows 3.0.

  -or-

 - Envelope addresses are positioned incorrectly or print off the edge
   of the envelope.

Note: This setting affects all Windows applications. This workaround
may cause problems in other applications. If you experience problems,
consider using a different workaround.

For more information, query on the following words in the Microsoft
Knowledge Base:



   landscape and WIN.INI

Reference(s):

"Microsoft Windows Resource Kit," version 3.1, PRINTERS.WRI

Additional reference words: 2.00 2.00a w4wprint win31 4019 feed
 w4wenvelope



WinWord: Strikethrough Formatting Misaligns with Small Caps
Article ID: Q83885
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, strikethrough character formatting does
not print or display correctly when applied to text formatted with
small caps. The strikethrough formatting on text formatted with small
caps does not align with the strikethrough formatting on other text.
This causes a jagged, crooked line through text that contains both
small caps formatting and other character formatting. Similarly,
strikethrough character formatting applied to lowercase small caps
does not align with strikethrough character formatting applied to
uppercase small caps of the same font and size.

MORE INFORMATION
================

Strikethrough formatting applied to text with small caps formatting is
positioned higher than strikethrough formatting applied to text
without small caps formatting. Strikethrough formatting also misaligns
on small caps of varying point sizes, uppercase letters, numbers, and
punctuation characters (commas, apostrophes, periods, and so forth).

WORKAROUND
==========

Word for Windows version 6.0
-----------------------------

If you need to apply strikethrough formatting to text with small caps in 
Word for Windows version 6.0, you can change the small caps to allcaps 
with a smaller point size. In Word for Windows version 6.0, 
strikethrough character formatting applied to text formatted with all 
caps prints correctly.

Strikethrough formatting is applied to deleted text when you choose the 
Revisions command from the Tools menu. strikethrough formatting applied 
in this manner aligns incorrectly.  With revision marks enabled, 
strikethrough formatting is applied to text that you delete by pressing 
the DELETE key or by pressing the BACKSPACE key.

Word for Windows Version 2.0
----------------------------

If you need to apply strikethrough formatting to text with small caps
in Word for Windows version 2.0, you can change the small caps to all



caps with a smaller point size. In Word for Windows version 2.0,
strikethrough character formatting applied to text formatted with all
caps prints correctly.

Strikethrough formatting is applied to deleted text when you choose
the Revision Marks command from the Tools menu. Strikethrough
formatting applied in this manner aligns correctly. With revision
marks enabled, strikethrough formatting is applied to text that you
delete by pressing the DELETE key or by pressing the BACKSPACE key.

Word for Windows Version 1.x
----------------------------

In Word for Windows versions 1.0, 1.1, and 1.1a, strikethrough
formatting is not available as a character format. Strikethrough
formatting is applied by choosing Revision Marks from the Utilities
menu. With revision marks enabled, strikethrough formatting is applied
to text that you delete by pressing the DELETE key or by pressing the
BACKSPACE key.

Note: In Word for Windows version 1.x, strikethrough formatting
applied to the spaces between words displays and prints higher than
strikethrough formatting applied to other characters. In Word for
Windows version 2.0, strikethrough formatting aligns consistently on
spaces and other characters.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 144-146

Additional reference words: w4wfont w4wprint 2.00 2.00a 1.00 1.10 6.00 
wm_word 1.10a 1.1a 2.0b 2.0a-CD 2.00b 2.00a-CD



WinWord: Envelopes Print in Landscape on Panasonic KX-P1124
Article ID: Q84041
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you print a size 10 envelope using
the PANSON9.DRV or PANSON24.DRV printer driver for Microsoft Windows
operating system version 3.1, Word incorrectly prints the envelope in
landscape orientation. Word correctly prints size 9 envelopes in
portrait orientation.

Microsoft has confirmed this to be a problem in the Panasonic printer
drivers PANSON9.DRV and PANSON24.DRV for Microsoft Windows version
3.1. We are researching this problem and will post new information
here as it becomes available.

Word for Windows version 6.0 does not use printer hueristics to contol
printer functionality.  To change printer functionality choose Options
from the Envelopes and Lables dialog box.  Under the Envelope Options
dialog box categoty Printing Options you can set the Feed method
(orientation and location) of the envelope.

More Information:

This problem occurs in the following Panasonic printers:

PANSON24.DRV PANSON9.DRV
------------ -----------

KX-P1123 KX-P1180
KX-P1124 KX-P1180i
KX-P1624 KX-P1191
KX-P1695
KX-P4420

Workaround
----------

You can set a printer heuristic in Word version 2.0 or 2.0a for
Windows to force all envelopes to print in portrait orientation using
these Panasonic printer drivers. Use the following steps to set this
heuristic in your Windows WIN.INI file:

1. From the Tools menu, choose Options.

2. Under Category, select WIN.INI. Select Microsoft Word 2.0 in the
   Application box.



3. In the Option box, type "PANSON24" (without the quotation marks).

4. In the Setting box, type "+65" (without the quotation marks).

5. Choose the Set button, then choose the Close button.

Additional reference words: win31 w4wprint 
KXP KXP1124 kxp1123 kxp1180 kxp1180 kxp1180i kxp1624 kxp1695 kxp4420
kxp1191 toolbar tool bar create ToolsCreateEnvelope w4wenvelope 
2.00 2.00a 3.10



WinWord: Restoring Drag and Drop Printing Functionality
Article ID: Q84048
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In the Microsoft Windows operating system version 3.1, you lose the
ability to perform drag and drop printing of Microsoft Word for
Windows version 2.0 or 6.0 documents from the Windows File Manager if 
you delete or sufficiently modify the Windows REG.DAT file or the 
OLE2.REG file in Winword 6.0. To restore the REG.DAT settings that 
enable you to perform drag and drop printing of Word for Windows 
documents, you must either rerun the Word for Windows Setup program or 
manually edit the REG.DAT file.

More Information:

Winword 6.0:
------------

Winword 6.0 by default self registers itself when the program is
started, if this does not happen the recommended method to restore the 
OLE2.REG settings is to reinstall Word for Windows using the Custom 
Installation option. To do this, use the following steps:

1. Start the Word for Windows Setup program. 

2. When prompted to choose a type of installation, choose the Custom
   Installation button.

3. Select the Microsoft Word check box. Clear all other check boxes,
   and choose the Setup button.

Word for Windows is now reinstalled and the OLE2.REG settings are 
restored.

Winword 2.X:
------------

The recommended method to restore the REG.DAT settings is to reinstall
Word for Windows using the Custom Installation option. To do this, use
the following steps:

1. Start the Word for Windows Setup program. For more information on
   using the Setup program, see pages 8-11 in the "Microsoft Word for
   Windows Getting Started" manual.

2. When prompted to choose a type of installation, choose the Custom
   Installation button.



3. Select the Microsoft Word check box. Clear all other check boxes,
   and choose the Setup button.

Word for Windows is now reinstalled and the REG.DAT settings are 
restored.

For more information on the default REG.DAT settings for Word for
Windows, query on the following words in the Microsoft Knowledge Base:

   default and values and regedit.exe and reg.dat

Reference(s):

"Microsoft Windows Resource Kit," version 3.1, pages 359-365, 454

"Microsoft Word for Windows Getting Started," version 2.0, pages 8-11

Additional reference words: 2.00 2.00a 6.0 w4wsetup w4wprint cannot 6.00 
wm_word registration



Lines of Text Truncated When Printing to NEC Pinwriter P7
Article ID: Q84298
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if the top margin of your document is 
less than 0.7-inch and you are using the NEC Pinwriter P7 printer driver 
that ships with the Microsoft Windows operating system version 3.1, the 
first paragraph of your document will be truncated if the printer is 
configured for manual paper feed.

More Information:

Word versions 2.x or 6.0
------------------------

To correct this problem, use the following steps:

1. From the File menu, choose Print Setup. 

2. In the Printer box, select the Pinwriter P7, and choose the Setup
   button. 

3. In the Paper Source box, select either Tractor or Cut Sheet
   Feeder:Bin 1. 

4. Choose the OK button twice.

Word for Windows 6.0 will return an error message when you print a 
document saying that the margins are outside the unprintable regions of 
the  printer.  If you choose the "Fix" option, Word will increase the 
margins to the minimum settings for the printer so that text will not be 
cut off.

Note:If you are having margin problems when using manual feed or sheet 
feeder options with dot-matrix printers, there may be an updated driver 
available from the WDL.

For more information on which printers have an updated driver, query 
on:

unprintable and regions dot and matrix

These updated drivers have a margins button in the printer driver which 
which take into account the different start position of the print head 
when using paper sources.  To use this new feature, follow these steps:

1. set the paper source in Word to match the correct paper source you 
are using with your printer.



2. From the Control Panel, choose Printers.

3. Choose Setup and change the paper source to match what you are using 
   with your printer.

4. Choose Options.

5. Choose Margins.

6. Click the Default button and press OK to back out of the dialog 
   boxes.

7. Your document should now print correctly.

For more information on the NEC Pinwriter, query on the following
words in the Microsoft Knowledge Base:

   nec and pinwriter and top and margin and windows

Additional reference words: 2.00 2.00a truncate w4wprint chopped 6.00 
wm_word missing cut off incomplete w_win3



HP III with PS Cartridge: Envelopes Print from Left Not Center
Article ID: Q84324
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

If you are using Microsoft Word for Windows in the Microsoft Windows
operating system version 3.1 and you want to print an envelope to a
Hewlett-Packard (HP) LaserJet III that has a PostScript cartridge, you
must add the printer heuristic setting PSCRIPT=800 to the WIN.INI
file. To do this, use the following steps:

1. From the Tools menu, choose Options, and select the WIN.INI
   Category.

2. Check the Startup Options box for an entry that begins PSCRIPT=. If
   no such entry exists, delete the text in the Option box, and type
   "PSCRIPT" (without the quotation marks). Press TAB to move to the
   Setting box, and type "800" (without the quotation marks).

   If there is a PSCRIPT= entry, select that entry in the Startup
   Options box, and change the value in the Setting box to "800"
   (without the quotation marks).

3. Choose the Set button, then choose the Close button.

Word for Windows version 6.0 does not use printer hueristics to contol
printer functionality.  To change printer functionality choose Options
from the Envelopes and Labels dialog box.  Under the Envelope Options
dialog box categoty Printing Options you can set the Feed method
(orientation and location) of the envelope.

More Information:

Unless you add the heuristic setting PSCRIPT=800 to the WIN.INI file,
envelopes will print as if they should be fed from the left, rather
than the center. This problem occurs in Windows 3.1 when the HP
LaserJet III PostScript printer is selected. Envelopes print correctly
if another PostScript printer, such as the Apple LaserWriter IINT, is
selected.

The heuristic 800 is a combination of 512 (force landscape), 256
(don't call DeviceCapabilities) and 32 (rotate landscape in the
opposite direction).

Additional reference words: w4wprint w4wlaserjet laser jet incorrect
wrong blank pacific page w4wenvelope 2.00 2.00a 2.00a-CD 2.00b 2.00c



WinWord: Margins Set Outside Printable Area of the Page
Article ID: Q84647
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you set your document margins closer to the edge of the paper than
your printer is capable of printing, Microsoft Word for Windows
returns the following warning message for each copy you send to the
printer:

   Margins set outside printable area of page.

Choose the OK button when you receive the above error message.

Most laser printers, such as the Hewlett-Packard (HP) LaserJet, cannot
print closer to the edge of the paper than 0.25 inch. Some laser
printers, such as the HP LaserJet Series II, require 0.5-inch margins.
Most PostScript and dot-matrix printers have their own internal
printer driver setting for margins.

The error message will also appear if a table extends beyond the
margin boundaries.

Word for Windows 6.0 gives you an option to "fix" the margins.  When you 
tell Word 6.0 to "fix" the margins, it increases any margins which are 
outside the unprintable region to their minimum settings.

Note: To determine what the document margins can be set to, start
Windows Write from the Accessories group.

1. From the Document menu select Page Layout.

2. Set one of the margins to zero (0) and choose the OK button.

Write will display a message box with the minimum margins.

More Information:

To correct this problem, return to your document, and use the
following steps:

1. From the Format menu, choose Page Setup (Document in version 1.x).
   Reset any margins that are less than 0.25 inch to 0.25 inch or 
larger.

2. Choose the OK button.

In Word for Windows 6.0, choose the "Fix" option when you get the error 



message.

Note: After you increase the margins, the message should not appear.
If the error message appears again, set the margins to 0.5 inch.

PostScript
----------

If you receive the warning message when you are printing to a
PostScript printer, you may need to change the printer driver margin
setting. To do this, use the following steps:

1. From the File menu, choose Print Setup (Printer Setup in version
   1.x) Select the PostScript printer, and choose the Setup 
button.(Control Panel - Printers - Setup in Word 6.0). 

2. Choose the Options button. In the Margins box, select None. Choose
   the OK button three times to return to the document.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 122-123

"Microsoft Word for Windows User's Reference," version 1.x, pages
271-272, 417

"Microsoft Word for Windows Printer Guide," version 1.x, pages 8, 13

Additional reference words: w4wprint  errmsg err msg 1.0 1.1 6.00 
wm_word 1.1a 2.0a 1.00 1.10 1.10a 2.00 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD 
6.00



Envelope Feeder Option Unavailable with Bitstream FaceLift
Article ID: Q85030
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

If Microsoft Word for Windows is running in the Microsoft Windows
operating system version 3.1 when Bitstream FaceLift version 2.0 is
active and the PCL/HP LaserJet driver (HPPCL.DRV) is being used, the
"Printer's Envelope Feeder has been Installed" option will be
unavailable. If you use the Create Envelope command to print an
envelope to the printer's envelope feeder (for example, the HP
LaserJet Series IID printer) when this option is unavailable, the
envelope text will print in portrait orientation to a regular paper
bin. The printer's envelope feeder will not be accessed.

Printer heuristics have no effect on this behavior.

This functionality was changed and is no longer a problem in Word 
version 6.0

More Information:

To make the "Printer's Envelope Feeder has been Installed" option
available, you must first turn off FaceLift. You can then choose
Options from the Tools menu, select the Print category, and select the
"Printer's Envelope Feeder has been Installed" option in the Envelope
Options box.

If you remove the HPPCL.DRV printer driver from the Windows Control
Panel and reinstall it while Bitstream FaceLift is active, a dialog
box will appear asking if you want the driver to use Bitstream
FaceLift. If you choose the No button, the "Printer's Envelope Feeder
has been Installed" option will be available in Word for Windows.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 732

Additional reference words: gray grey w4wprint soft font w4wfont
toolbar tool bar Hewlett Packard win31 unidrv.dll w4wenvelope



How Word for Windows Uses a Math Coprocessor
Article ID: Q85241
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Microsoft Word for Windows uses a math coprocessor for the following
functions:

 - Field calculations
 - Tools Calculate command
 - Tools Sorting command
 - Macro language functions that require floating-point calculations
   to obtain a result
 - Selecting certain records to merge during a print merge

More Information:

A math coprocessor does not enhance the overall operating speed of
Word for Windows. It also does not affect the speed of printing or
displaying a document. The only noticeable speed improvements occur
when you perform the above functions.

Additional reference words: w4wprint 1.00 1.10 1.10a increase faster co- 
6.00 wm_word processor 80287 80387 2.00 2.00a 2.00a-CD 2.00b 2.00c 



How to Print Envelopes on the Epson EPL-7500 Printer
Article ID: Q85461
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

The envelope address will print too high on the envelope if you are 
running Word for Windows 2.0 in the Microsoft Windows operating system 
version 3.1 and you print an envelope on an Epson EPL-7500 in HP 
LaserJet II emulation mode using the Create Envelope command.

More Information:

To print envelopes correctly on an Epson EPL-7500, use the Windows 
version 3.1 Epson EPL-7500 PostScript (WPD) printer driver. Epson 
PostScript printer drivers are available in the Microsoft Windows Driver 
Library (WDL), which you can download from the Microsoft Download 
Service (MSDL) and CompuServe.

If you want to print envelopes with your Epson EPL-7500 in HP LaserJet
emulation mode in Windows version 3.1, you must use the HP LaserJet 
Series II printer driver and set a printer heuristic. Envelopes print 
correctly on this printer if you are using Windows version 3.0; no 
heuristic setting is required.

Word for Windows 6.0 does not use printer heuristics to change the way 
an envelope feeds into the printer.  To modify the way an envelope feeds 
into the printer, Choose Envelopes and Labels from the Tools menu. 
Choose the Envelopes dialog tab and press the Options button.  Choose 
the Printing Options dialog tab.  Choose the envelope feed method for 
your printer and press the OK button.  

To set the printer heuristic for Word 2.0, add the following line to the 
[Microsoft Word 2.0] section of the WIN.INI file:

   HPPCL=768

  Note: Heuristic 768 is a combination of heuristic 256 (Avoid Using
  DeviceCapabilities) and heuristic 512 (Force Landscape).

For information on setting printer heuristics, query on the following 
words in the Microsoft Knowledge Base:

   newmacro.doc and functionality and printer and heuristics

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 118-120, 
810



Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 3.10 
w4wprint w4wlaserjet position wrong left feed incorrect w4wenvelope



WinWord: Text from Page 1 Prints on Envelope Added to Document
Article ID: Q85692
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

If you add an envelope to a document whose first character is
formatted for hidden text in Microsoft Word for Windows, some of the
text from the first page of your document will print on the envelope.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

In Word for Windows, you can add an envelope to a document by choosing
the Add To Document button in the Create Envelope dialog box. Word for
Windows adds the envelope text to the beginning of your document and
inserts a section break between the envelope and the start of your
document. Word assigns page number zero (0) to the envelope text.

If the first character of your document is formatted for hidden text,
the section break that Word inserts when you choose the Add To
Document button will also be formatted for hidden text. When you print
or preview the document, Word will ignore the hidden section break and
print text from the first page of your document on the envelope.

WORKAROUND
==========

To work around this problem, use one of the following methods:

 - From the View menu, choose Normal. Select the section break. From the
   Format menu, choose Character, clear the Hidden Text check box, and
   choose the OK button.

   Note: You must select the entire section break; you cannot remove



   hidden text character formatting if the insertion point is simply
   positioned on the line containing the section break.

 -or-

 - Before you add the envelope to your document, position the insertion
   point at the beginning of your document, and type a space or press
   ENTER. Select this character. From the Format menu, choose Character,
   clear the Hidden Text check box, and choose the OK button. When you
   add the envelope, Word will not format the section break as Hidden
   Text and no text from the first page will print on the envelope.

Additional reference words: 2.00 2.00a w4wprint wrong missing
landscape toolbar w4wenvelope



HP IIIsi Err Msg: "EE Load Com10" When Printing Envelopes
Article ID: Q85699
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

If you print an envelope from Microsoft Word for Windows to a Hewlett-
Packard (HP) LaserJet Series IIIsi printer with an envelope feeder, the 
printer will display the following error message if the envelope tray is 
not set for the correct envelope size:

   EE LOAD COM10

Change the More Information paragraph to:

More Information:

Notes: 

Winword 6.0:
------------

This article assumes that the paper source is envelope.  From the File
menu, choose Page Setup, select the Paper Source tab.  Make sure that 
Envelope is selected, then choose the OK button.

Winword 2.X:
------------

This article assumes that the "Printer's Envelope Feeder has
been Installed" check box is selected. From the Tools menu, choose
Options. Under Category, select Print. Make sure that the "Printer's
Envelope Feeder has been Installed" check box is selected, then choose
the OK button.

If the envelope tray on the HP LaserJet Series IIIsi is set correctly,
the following message will appear when you print an envelope using the
Create Envelope command in Word for Windows:

   EE TRAY = COM 10

To set the correct envelope size on your HP LaserJet Series IIIsi, use
the following steps:

1. Remove the envelopes from the envelope feeder, then reinsert them.
   The following message should appear on the printer:

      EE TRAY = <envelope size>

2. Press the plus sign (+) and/or minus sign (-) keys on the printer
   until "COM 10" appears, then press the ENTER key on the printer.



When you change envelopes, turn on the printer, or print to the
envelope tray, the printer will display the "EE Tray = COM 10"
message.

For more information on how to change settings on your printer, refer
to the HP LaserJet Series IIIsi manual.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 118-121,
732

Additional reference words: 2.00 2.00a  w4wprint w4wlaserjet 6.00 
wm_word errmsg err msg form feed continue w4wenvelope w_print



Envelope Incorrectly Prints in Landscape on Canon BJ Printers
Article ID: Q85755
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------

Summary:

If you use the Create Envelope command in Microsoft Word for Windows 2.0
to print an envelope to the Canon Bubble-Jet BJ_10ex, the BJ-200, the
BJ-300, or the BJ-330 printer, the envelope incorrectly prints in
landscape orientation.

More Information:

To correctly print an envelope to the Canon Bubble-Jet BJ_10ex, the
BJ-200, the BJ-300 or the BJ-330 with Word 2.0, use one of the following 
methods:

 - Set one of the following printer heuristics in the [Microsoft Word
   2.0] section of the Windows WIN.INI file:

      CANON10E=+1

       -or-

      BJ200=+1

       -or-

      CANON330=+1  (for the BJ-300 or BJ-330 printers)

   If you set the above printer heuristics, envelopes print correctly
   in protrait orientation when you choose the Create Envelope
   command.

  -or-

 - Load the envelopes from the bottom of the BJ_10ex printer. There is
   a slot in the bottom of the Bubble-Jet BJ_10ex printer that is wide
   enough to accept standard business envelopes in portrait orientation.
   If you use this slot, you must manually position the top of the
   envelope using the "FWD ADJ" control on the printer; the printer does
   not automatically load the envelope to the correct location from the
   bottom slot. If you use this method, the envelopes will print in
   portrait orientation.

   Note: The top paper slot on this printer is too narrow to load
   standard 9-inch (number 10) envelopes in portrait orientation.

   Note for BJ-200 users: The BJ-200 requires setting the paper feed 



   lever to, Envelope  (an icon by the lever) and moving the green 
   lever on the print cartridge all the way to the right.

For information on setting printer heuristics, query on the following
words in the Microsoft Knowledge Base:

   newmacro.doc and setprinterheuristic and changing

Word for Windows 6.0 does not use printer heuristics to change the way 
an envelope feeds into the printer.  To modify the way an envelope feeds 
into the printer, Choose Envelopes and Labels from the Tools menu. 
Choose the Envelopes dialog tab and press the Options button.  Choose 
the Printing Options dialog tab.  Choose the envelope feed method for 
your printer and press the OK button.  

Canon has confirmed this to be a problem with their BJ-200 printer
driver version 1.0, supplied by Canon with the printer.

The Canon BJ-200 printer driver version 1.0 product included here is
manufactured by Canon, a vendor independent of Microsoft; we make no
warranty, implied or otherwise, regarding this product's performance
or reliability.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 810

Additional reference words: w4wenvelope w4wprint 2.00 6.00 wm_word 
2.00a 2.00a-CD 2.00b 2.00c bj10ex bj200 bj300 bj330 tool bar toolbar
bubblejet 6.00



"Call to Undefined Dynalink" Error with Old Printer Drivers
Article ID: Q85887
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

If the Microsoft Windows operating system version 3.1 accesses a
Windows version 3.0 printer driver, the following error message may be
displayed:

   Application Error - Call To Undefined Dynalink

You must remove any Windows 3.0 printer drivers and install the
appropriate Windows version 3.1 printer driver(s) to correct this
problem.

More Information:

For instructions on removing an installed printer drivers and
installing a new printer driver, refer to pages 201-206 and page 214
of the "Microsoft Windows User's Guide" for Windows 3.1.

Note: You must remove duplicate printer driver entries from the
Installed Printers list. If you do not, you will be unable to install
a new Windows 3.1 printer driver from the Windows disks.

Note: Be sure to search all drives and directories for outdated
printer drivers. This is especially important if you are running Word
on a network, where printer drivers may be stored in multiple
directories.

For information on other causes of the "Call to Undefined Dynalink"
error message, query on the following words in the Microsoft Knowledge
Base:

   call and undefined and dynalink and shell.dll

Reference(s):

"Microsoft Windows User's Guide," version 3.1, pages 201-206, 214

"Microsoft Windows Resource Kit," version 3.1, pages 426-428

Additional reference words: 3.00 3.10 old w4wprint  win31 2.00 6.00 
wm_word 2.00a 2.00a-CD 2.00b 2.00c 



Cannot Print Outside 1" Bottom Margin Using PANSON24.DRV
Article ID: Q86056
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you set the bottom margin of a 
document to less than 1 inch and the Panasonic KX-P1123 or KX-P1124 
printer is selected in the Print Setup dialog box, (or File Print dialog 
box in Word 6.0), Word will stop printing one inch from the bottom of 
the page. This problem occurs when you are running Word in the Microsoft 
Windows operating system version 3.1; it does not occur if you are 
running Word in Microsoft Windows version 3.0.

More Information:

If PANSON24.DRV is the active printer driver, Word will select the
Default Tray option as the paper source. Word uses the Auto Sheet
Feeder, which causes text to stop printing 1 inch from the bottom of
the page, as the default paper tray.

Workaround
----------

To force Word to print text to the bottom of the page, change the
Paper Source setting to Tractor with the following steps:

In Word 6.0:
------------
1. From the Format menu, choose Page Setup.

2. Select the Paper Source dialog tab.

3. In the First Page box, select Tractor. In the Other Pages box,
   select Tractor. Choose the OK button.

4. From the Control Panel, choose Printers

5. Choose the setup button

6. Change the paper source to tractor

In Word 2.0:
------------
1. From the Format menu, choose Page Setup.

2. Select the Paper Source option button.

3. In the First Page box, select Tractor. In the Other Pages box,



   select Tractor. Choose the OK button.

4. From the file menu, choose Print Setup

5. Choose the setup button

6. Change the paper source to tractor

Note:If you are having margin problems when using manual feed or sheet 
feeder options with dot-matrix printers, there may be an updated driver 
available from the WDL.

For information as to which printers have an updated driver, query:

   unprintable and regions dot and matrix

These updated drivers have a margins button in the printer driver which 
which take into account the different start position of the print head 
when using paper sources.  To use this new feature, follow these steps:

1. set the paper source in Word to match the correct paper source you 
   are using with your printer.

2. From the Control Panel, choose Printers.

3. Choose Setup and change the paper source to match what you are using 
   with your printer.

4. Choose Options.

5. Choose Margins.

6. Click the Default button and press OK to back out of the dialog 
   boxes.

7. Your document should now print correctly.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 230

Additional reference words: w4wprint truncate cut2.00 2.00a 2.00a-CD  
6.00 wm_word 2.00b



Color Graphics Preview in Color with Noncolor Printer Driver
Article ID: Q86059
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, color graphics display in color in print 
preview even if the active printer does not support color printing. The 
printer output is not affected by the incorrect display.

More Information:

Microsoft has confirmed this to be a problem in Word for Windows
We are researching this problem and will post new information here as it 
becomes available.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wprint  
6.00 wm_word 



OkiLaser 400 Message: COM 10 ENVELOPE, MANUAL FEED REQUEST
Article ID: Q86075
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you use the Create Envelope command 
(or Envelopes and Labels in Word 6.0) to print an envelope to an 
OkiLaser 400 printer, the following message will be displayed on the 
printer:

   COM 10 ENVELOPE, MANUAL FEED REQUEST

More Information:

The envelope slot on the Okidata OkiLaser 400 is a single-sheet,
manual feed mechanism. After you place an envelope into the manual
feeder, you must press the Form Feed button on the printer to begin
printing.

For more information on the manual feed features of the OkiLaser 400
printer, refer to the printer manual.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 118,
120-121

Additional reference words: w4wprint  2.00 2.00a 2.00a-CD 2.00b 6.00 
wm_word 
w4wenvelope



WinWord 2.0: Printing Envelopes to HP LaserJet Plus Printers
Article ID: Q86272
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you are running Word for Windows in the Microsoft Windows operating
system version 3.1 and you print an envelope to a Hewlett-Packard (HP)
LaserJet Plus printer using the CreateEnvelope command in Word 2.0 the 
envelope address will print too high on the envelope.

More Information:

Word for Windows 6.0 does not use printer heuristics to change the way 
an envelope feeds into the printer.  To modify the way an envelope feeds 
into the printer, Choose Envelopes and Labels from the Tools menu. 
Choose the Envelopes dialog tab and press the Options button.  Choose 
the Printing Options dialog tab.  Choose the envelope feed method for 
your printer and press the OK button.  

To print envelopes correctly on an HP LaserJet Plus in Windows 3.1, with 
Word 2.0, you must set a printer heuristic. To do this, add the 
following line to the [Microsoft Word 2.0] section of the WIN.INI file:

   HPPCL=+4

When you set this heuristic, envelopes print correctly when you feed
them on the right side of the paper tray.

You can use the SetPrinterHeuristic macro, which is included in the
NEWMACRO.DOC file that ships with version 2.0 of Word for Windows, to
add this heuristic to the WIN.INI file. You can also add this
heuristic by choosing Options from the Tools menu and selecting the
WIN.INI category. Refer to page 810 of the "Microsoft Word for Windows
User's Guide" for more information on editing the WIN.INI file.

Note: You can set heuristic 768 (HPPCL=768) to print envelopes by
feeding them through the center of the paper tray. However, there is
no paper guide on this paper tray, so center-fed envelopes may be
inconvenient.  Heuristic 768 is a combination of heuristic 256 (Avoid
Using DeviceCapabilities) and 512 (Force Landscape).

Windows version 3.0
-------------------

If you print an envelope on an HP LaserJet Plus using the Create
Envelope command in Windows 3.0, the envelope address will print
correctly without a printer heuristic.



Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 118,
120-121, 732, 810

Additional reference words: 2.00 2.00a 3.00 3.10 w4wprint w4wlaserjet 
6.00 wm_word position w4wenvelope



Printing Underline Formatting with Generic/Text Only Driver
Article ID: Q86285
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you apply underline formatting to text in Microsoft Word for
Windows and print the text using the Generic/Text Only printer driver
included with Microsoft Windows operating system version 3.1, the
underlined text will cause the line to be double spaced. In other
words, an extra blank line will appear before the next line will
print.

More Information:

The above behavior results from using the Auto setting in the Line
Spacing box. To work around this situation, use a fixed line spacing
instead of Auto. To change the line spacing in the document, select
the text, choose Paragraph from the Format menu, and use one of the
following steps:

 - In version 6.0 of Word for Windows, select Exactly in the Line
   ..Spacing box.  In the At Box, select 1.3 li for single spacing.

 - In version 2.x of Word for Windows, select Exactly in the
   Line Spacing box. In the At box, select the number of lines you want
   to use for spacing (for example, 1 li).

 - In version 1.x of Word for Windows, select the word "Auto" in the
   Line box, press BACKSPACE, then type to "-1 li" (without the 
   quotation marks).
  
Microsoft has confirmed this to be a problem with the Generic/Text
Only printer driver. We are researching this problem and will post new
information here as it becomes available.

Note: The About box in the Generic/Text Only printer driver indicates
version 3.1.

Additional reference words: w4wprint 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 
6.00 wm_word 2.00b 3.10



Printing to the Panasonic KX-P4420 on Nonstandard Paper Sizes
Article ID: Q86311
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if the settings in the Page Setup
dialog box are incorrect and you are using a custom paper size, text
may print incompletely on the Panasonic KX-P4420 printer. For example,
on a 5-by-8-inch page, text may print at the left and right edges of
the page but not in the middle of the page.

This problem was corrected in Word version 6.0 for Windows.

More Information:

In Word for Windows, to print correctly on custom paper sizes using
the Panasonic KX-P4420 printer, choose Page Setup from the Format
menu, and change the settings as described below.

Note: These settings are for 5-by-8-inch paper. Substitute your paper
size in the Height and Width boxes.

Landscape Orientation
---------------------

1. From the Format menu, choose Page Setup. Select the Size and
   Orientation option button, and select the following settings:

   Paper Size:      Custom Size
   Width:           8"
   Height:          5"
   Orientation:     Landscape

2. Select the Paper Source option button. In the First Pages and Other
   Pages boxes, select Manual Feed. Choose the OK button.

Portrait Orientation
--------------------

1. From the Format menu, choose Page Setup. Select the Size and
   Orientation option button, and select the following settings:

   Paper Size:      Custom Size
   Width:           5"
   Height:          8"
   Orientation:     Portrait

2. Select the Paper Source option button. In the First Pages and Other



   Pages boxes, select Manual Feed. Choose the OK button.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 230

Additional reference words: w4wprint 2.00 2.00a 2.00a-CD 2.00b



Words Wrap in Cell Differently on Screen Than When Printed
Article ID: Q86572
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD and 2.0b
 - Microsoft Windows operating system, versions 3.0 and 3.1
---------------------------------------------------------------------

Summary:

In versions 2.0, 2.0a, 2.0a-cd and 2.0b of Microsoft Word for Windows,
text in a table cell may appear to wrap differently in various zoomed
views. At views greater than approximately 96 percent, text may appear
to fit on one line, but at views less than or equal to 96 percent, the
text wraps. The text prints as it is displayed in the lower percentage
view.

In version 1.x of Word for Windows, there is no View Zoom command;
however, text may sometimes wrap on a printout when it does not appear
to wrap on the screen.

This problem was corrected in Word version 6.0 for Windows.

More Information:

This problem occurs with certain combinations of fonts, column widths,
and numbers of characters on the line.

Steps to Reproduce Problem
--------------------------

1. From the Table menu in version 2.0 or 2.0a, choose Insert Table.
   From the Insert menu in version 1.x, choose Table. Choose the OK
   button to insert a 2-column, 1-row table.

2. Position the insertion point in the first table cell, and change the
   font to Times New Roman 10-point.

3. From the Table menu in version 2.0 or 2.0a, choose Column Width.
   From the Format menu in version 1.x, choose Table. Type 1.47" in the
   Width of Column box, then choose the OK button.

4. In the cell, type the following:

      +1 800 846 9726 Voice

5. From the View menu in version 2.0 or 2.0a, choose Zoom. Under
   Magnification, select the Custom option button, select 85% in the
   corresponding box, then choose the OK button. (Skip this step if you
   are using version 1.x.)

6. Notice that the word "voice" wraps to the second line.



7. From the View menu, choose Zoom. Under Magnification, select the
   100% option button, then choose the OK button. Notice that the word
   "voice" moves back up to the first line of the cell.

8. From the File menu, choose Print, and choose the OK button. Notice
   that the text prints with the word "voice" wrapped to the second 
   line.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 316,
334, 348

"Microsoft Word for Windows User's Reference," version 1.x, pages 365,
367

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a incorrect
w4wprint wrong WYSIWYG 2.0b 2.0a-CD 2.00b 2.00a-CD 



WinWord 2.0: Printing Envelopes to Brother Laser Printers
Article ID: Q86707
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When you print an envelope to a Brother HL-8 or HL-8e laser printer
using the Create Envelope command in Microsoft Word for Windows 2.0, the
envelope address may print too high on the envelope.

More Information:

Word for Windows 6.0 does not use printer heuristics to change the way 
an envelope feeds into the printer.  To modify the way an envelope feeds 
into the printer, Choose Envelopes and Labels from the Tools menu. 
Choose the Envelopes dialog tab and press the Options button.  Choose 
the Printing Options dialog tab.  Choose the envelope feed method for 
your printer and press the OK button.  

To print envelopes correctly on a Brother HL-8 or HL-8e with Word 2.0, 
you must set a printer heuristic. If you are using the HPPCL.DRV printer 
driver and the Brother printer is emulating an Hewlett-Packard (HP) 
LaserJet Series II, the following line must be added to the [Microsoft 
Word 2.0] section of the WIN.INI file:

   HPPCL=768

If you are using the PCL4X.DRV printer driver designed for Brother
laser printers, the following line must be added to the [Microsoft
Word 2.0] section of the WIN.INI file:

   PCL4X=768

Heuristic 768 is a combination of heuristic 256 (Avoid Using
DeviceCapabilities) and 512 (Force Landscape).

You can use the SetPrinterHeuristic macro, which is included in the
NEWMACRO.DOC file that ships with Word for Windows, to add this
heuristic to the WIN.INI file. You can also add this heuristic by
choosing Options from the Tools menu and selecting the WIN.INI
category. Refer to page 810 of the "Microsoft Word for Windows User's
Guide" for more information on editing the WIN.INI file.

If you are running Word for Windows 2.0 in Microsoft Windows version 3.0
and you print an envelope on a Brother HL-8 or HL-8e laser printer using 
the Create Envelope command, the envelope address prints correctly 
without a printer heuristic.

According to Brother, the Brother HL-8 and HL-8e laser printers can



emulate the HP LaserJet Series II. The HP LaserJet Series II printer
driver is available on the Windows 3.1 installation disks. Brother
laser printer drivers are available on the Microsoft Windows Driver
Library (WDL), which you can download from the Microsoft Download
Service (MSDL) and CompuServe.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 118,
120-121, 732, 810

Additional reference words: w4wprint w4wlaserjet 2.00 2.00a 3.10 6.00 
wm_word w4wenvelope



Printing Labels on the Toshiba 351 Causes Premature Form Feed
Article ID: Q87126
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you print labels using the Toshiba P351 universal printer driver
version 1.1 when you are running Microsoft Word for Windows in
Microsoft Windows operating system version 3.1, Word sends a form feed
after the first three labels are printed. This problem is caused by
the Toshiba P351 printer driver (TOSHIBA.DRV).

More Information:

Workaround
----------

You can use a PRINT field at the top of the print merge main document
to set the correct form length for your labels. To do this, use the
following steps:

1. Open the print merge main document.

2. At the beginning of the document, insert the following PRINT field:

      {PRINT "<ESC>F18"}

Note: To create the field characters {}, press CTRL+F9. To create the
<ESC> character, press ALT+027 on the numeric keypad.

The number following <ESC>F (18 in the sample PRINT field above) is
the form length in 1/6-inch (or one-line) increments. To determine the
correct number for your labels, choose Page Layout from the Format
menu, select the Size And Orientation option button, and multiply the
value in the Height box by six. The result is the form length you
should type in the PRINT field. For example, if you use Avery label
No. 4145, the page Height is set to 3 inches; therefore, 18 is the
value you type in the PRINT field.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 657-665

Additional reference words: 2.00 2.00a 3.10 p 351 p-351 win31 phoneref 
6.00 wm_word 
w4wmerge w4wprint



Meaning and Use of WIN31PRINT Switch in WIN.INI File
Article ID: Q87283
-------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a and 2.0a-CD,
   2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------

Summary:

The WIN31PRINT switch, located in the [Microsoft Word 2.0] section of
the Microsoft Windows WIN.INI file, enables or disables the additional
printing capabilities included in Windows version 3.1 printer drivers.
This function is enabled by default (equivalent to WIN31PRINT=1). If
disabled by adding a WIN31PRINT=0 entry, Word for Windows does not use
the new printing capabilities built into Windows version 3.1; this means
that Word prints the same as when it runs in Windows version 3.0.

More Information:

When WIN31PRINT is enabled (either by default or by adding the
WIN31PRINT=1 line to the WIN.INI file), the EXTDEVMODE printer driver
call is enabled. In this mode, Word for Windows can print multiple
orientation documents in the same print job, and can use TrueType
fonts.

When WIN31PRINT is disabled (WIN31PRINT=0), the EXTDEVMODE printer
driver call is disabled and the DEVICEMODE call is enabled.

In Word for Windows 6.0, this setting is enabled by default (Word uses 
the advanced Win 3.1 features).  To disable it, you add the line:

   Flags=+2

under the appropriate printer section in the Winword6.ini file.  This 
will make Word send mixed orientation pages as separate print jobs.

Word version 6.0 is shipped with a macro that adds this entry into the 
Winword6.ini.  To use this macro, follow these steps:

1. From the File menu choose Templates.

2. Choose Attach.

3. Select the MACRO60.DOT file and click OK.

4. From the Tools menu, choose Macro.

5. Choose SetPrintFlags and press Run.

6. Set or Clear the checkbox next to "Send Mixed Pages as Multiple Print 
   Jobs".



7. Press OK to exit the Macro and add the setting to the Winword6.ini.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 803-810

Additional reference words: 2.00 2.00a win31 w4wprint w4wfont ttf true 
6.00 wm_word 
type



Print Preview Incorrect with Shaded Frame on top of Border
Article ID: Q87321
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

If you position a shaded frame over a portion of a bordered paragraph
in Microsoft Word for Windows, the shaded frame appears to overlay the
frame when you view the page in Print Preview. When you print the
page, the border prints on top of the shaded frame.

This problem was corrected in Word version 6.0 for Windows.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. Create a new document in Word for Windows. Using the steps on page
   367 of the "Microsoft Word for Windows User's Guide," create a
   border around the page.

2. From the Insert menu, choose Frame. Drag to create a 2-inch by
   2-inch frame. Choose the Yes button if prompted to switch to Page
   Layout view.

3. From the Format menu, choose Border. Choose the Shading button.

4. In the Foreground and Background boxes, select a color other than
   Auto. Choose the OK button twice.

5. Position the shaded frame so that it overlaps part of the page
   border you created in step 1 above.

6. From the File menu, choose Print Preview. Notice that the shaded
   frame overlaps the page border.

7. Choose the Print button and print this document.

Notice that the page border overlaps the shaded frame.

Note: If you are printing to a PostScript printer and you chose Black
in the Foreground and Background boxes in step 4 above, a portion of
the shaded frame prints reversed (white on black). This does not occur
with other printers such as the HP LaserJet Series printers.

For more information on frames and positioning, query on the following



words in the Microsoft Knowledge Base:

   frame and overlap and winword

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 367,
393-397

Additional reference words:2.00 2.00a 2.00a-cd 2.00b 2.00c apo
w4wgraphics w4wprint superimpose opaque transparent under
behind front



WinWord 2.0: Default Font Changes When Switching Printers
Article ID: Q87363
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, if you have not selected the Use
TrueType As Default check box (accessed by choosing Options from the
Tools menu and choosing the Print category), the default Roman and
Swiss family font designation changes whenever you activate a
different printer in the Print Setup dialog box. If you select the Use
TrueType As Default check box, the default Roman and Swiss family font
does not change when you switch to a different printer.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.
More Information:

MORE INFORMATION
================

When the Use TrueType As Default check box is not selected, Word for
Windows selects the closest printer font for the default Roman and
Swiss fonts. For example, if your default font is Times and you are
printing to a Hewlett-Packard (HP) LaserJet Series III printer, whose
default Roman font is CG Times, Word formats your document for CG
Times instead of Times.

This process is less straightforward when your printer does not
contain a true Roman family font. If your default font is a Roman font
such as CG Times, Word for Windows changes the default font to the
closest non-Roman font. For example, if you have an HP LaserJet Series
II printer with no cartridges, Word selects Courier as the default
font because the HP LaserJet Series II has no Roman-family equivalent
to CG Times.

You can force Word for Windows to use a TrueType font as the default
font, regardless of the printer font, by selecting the Use TrueType As



Default check box. When this option is selected, the default Roman and
Swiss fonts stay the same no matter which printer you select. Use the
following steps to select this option:

1. From the Tools menu, choose Options.

2. Under Category, select Print.

3. Select the Use TrueType As Default check box, then choose the OK
   button.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c  w4wprint 
w4wfont
changes ttf true type win31



Printing Problems with the IQ Engineering Font Cartridges
Article ID: Q87627
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you are running Microsoft Word for Windows in Microsoft Windows
operating system version 3.1 and you are using the IQ Engineering font
cartridges, you may experience problems with incorrect screen font or
printer font substitution. Also, the cartridge name may not be
displayed in the Print Setup dialog box.

This article provides information about the IQ Engineering font
cartridges and troubleshooting information for the above problems.

More Information:

Problems and Workarounds
------------------------

1. The IQ Super Cartridges are not always listed as installed
   cartridges in the Print Setup dialog box. This problem occurs if the
   cartridge is not selected or if it is incorrectly installed. Use the
   installation instructions at the end of this article to reinstall and
   select the cartridge. Also, delete the WINWORD.INI file, which is
   located in the Word for Windows program directory.

2. Incorrect screen fonts may be used for some IQ Super Cartridge
   fonts. This problem occurs because the Super Cartridges do not 
   provide matching screen fonts for their printer fonts. If you are
   using Super Cartridge 1 or 2, which contain bitmapped fonts, Word
   for Windows uses the closest matching screen fonts currently 
   installed in Windows. As a result, the screen display of these
   fonts is not always "what you see is what you get."

   If you are using Super Cartridge 3, which contains scalable PCL-5
   fonts, and you have Hewlett-Packard (HP) Intellifonts or Adobe Type
   Manager version 2.0 or higher, matching screen fonts are available
   from IQ Engineering.

3. The IQ Cooper Black Super Cartridge font is sometimes substituted
   for internal printer fonts when the point size is above 24 points and
   the text extends to two pages or more. IQ Engineering is researching
   this problem. To print with the internal printer font instead of the
   IQ Cooper Black font, cut one-page selections of your document and
   paste them into a new document for printing as a series of one-page
   documents.

Information About Super Cartridges



----------------------------------

IQ Engineering provides a wide variety of font cartridges for use with
HP Series II and III printers, 100 percent-compatible PCL-4 and PCL-5
laser printers, and HP DeskJet printers.

IQ Engineering font cartridges come with software printer drivers (PCM
files). When installed correctly, the Super Cartridges appear in the
Cartridges list of the Print Setup dialog box. Use the following
instructions to install your Super Cartridges:

1. In Program Manager, choose the Control Panel icon.

2. Choose the Printers icon.

3. Choose the Setup button, then choose the Fonts button.

4. In the HP Font Installer window, choose the Add Fonts button (the
   Add button in Windows version 3.0).

5. Place the IQ Engineering disk in your disk drive. In the Add Fonts
   box, type the drive letter for your disk drive (for example, type
   "B:\"). Choose the OK button.

6. Select your Super Cartridge and choose the OK button.

7. You should now see the Super Cartridge name in the Installed Fonts
   box.

8. Choose the Exit button to close the Font Installer window.

9. Select your Super Cartridge in the Cartridge box and choose the OK
   button. Choose the Close button, then close the Control Panel.

For more information about Super Cartridges, contact IQ Engineering at
the following address and telephone number:

   IQ Engineering
   605 North Pastoria Ave
   Sunnyvale, CA 98486
   Phone: 800-765-3668
   Customer Service: 408-733-1661

The products included here are manufactured by IQ Engineering, a
vendor independent of Microsoft; we make no warranty, implied or
otherwise, regarding these products' performance or reliability.

Reference(s):

"Microsoft Windows User's Guide," version 3.1, pages 201-205

Additional reference words: 2.00 2.00a 2.00a-cd 3.10 tshoot 6.00 wm_word 
troubleshooting w4wprint w4wlaserjet third party 3rdparty win31



Divide by Zero Error Message in Two-Page Print Preview
Article ID: Q87881
--------------------------------------------------------------------
The information in this article applies to

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

If you are running Microsoft Word for Windows in Microsoft Windows
operating system version 3.1, you may receive the error message
"Divide by Zero or Overflow Error." This error message is displayed if
you choose the Two Pages button in print preview, you are using the
standard VGA video driver, and your document contains one or more of
the following thirteen TrueType Symbol fonts at 7 points or fewer:

   {SYMBOL 215 \f "Symbol"}
   {SYMBOL 216 \f "Symbol"}
   {SYMBOL 217 \f "Symbol"}
   {SYMBOL 218 \f "Symbol"}
   {SYMBOL 227 \f "Symbol"}
   {SYMBOL 228 \f "Symbol"}
   {SYMBOL 229 \f "Symbol"}
   {SYMBOL 230 \f "Symbol"}
   {SYMBOL 235 \f "Symbol"}
   {SYMBOL 236 \f "Symbol"}
   {SYMBOL 237 \f "Symbol"}
   {SYMBOL 238 \f "Symbol"}
   {SYMBOL 243 \f "Symbol"}

When you choose the OK button to close the error message, Word for
Windows closes and all unsaved changes to your document are lost.

CAUSE
=====

This problem is caused by the standard VGA video driver that ships
with Windows 3.1; this driver does not allow Word for Windows to
display the symbols listed above with the TrueType Symbol font in
two-page print preview if a small point size is selected. The error
does not occur if you use one-page print preview or a different video
driver.

STATUS
======
 
Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.
 
To obtain new or updated Microsoft products, call the Microsoft Sales



Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

WORKAROUND
==========

 - Switch to a different video driver using the Windows Setup program.

  -or-

 - Use one-page print preview only.

  -or-

 - If possible, create the symbol using a different ANSI character
   code. Many characters in the Symbol font are assigned to more than one
   character code. For example, you can insert the copyright symbol by
   pressing ALT+0227 or ALT+0211. The first character code causes the
   "Divide By Zero" error message, but the second does not.

Steps to Reproduce Problem
--------------------------

Versions 2.0, 2.0a, and 2.0a-CD of Word for Windows
---------------------------------------------------

1. Change the font size to 7 points or fewer.

2. From the Insert menu, choose Symbol, select the copyright symbol
   from the bottom row.

 -or-

   Change the font to Symbol. Press ALT+Keypad 0227 to insert the
   copyright symbol.

3. From the File menu, choose Print Preview. If you are already in
   two-page preview mode, the error message occurs immediately. If you
   are in one-page preview mode, choose the Two Pages button.

Versions 1.0, 1.1, and 1.1a of Word for Windows
-----------------------------------------------

1. Change the font size to 7 points or fewer.

2. Change the font to Symbol. Press ALT+Keypad 0227 to insert the
   copyright symbol.

3. From the File menu, choose Print Preview. If you are already in
   two-page preview mode, the error message occurs immediately. If you
   are in one-page preview mode, choose the Two Pages button.

REFERENCES
==========



"Microsoft Word for Windows User's Guide," version 2.0, pages 153-155

"Microsoft Windows User's Guide," version 3.1, page 179

Additional reference words:  w4wprint w4wfont
hangs crashes hung crashed locked quit stop screen errmsg err msg
1.00 1.10 1.10a 1.x 2.00 2.00a 2.00a-cd



TrueType Fonts in Small Point Sizes Are Displayed Incorrectly
Article ID: Q87983
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a, and
   2.0a-CD
 - Microsoft Windows operating system version 3.1
-----------------------------------------------------------------------

Summary:

At font sizes 8 points or smaller, TrueType fonts may be incorrectly
displayed in Microsoft Word for Windows documents. The text sometimes
extends beyond the right margin and is not viewable in normal view,
page layout view, or print preview. In tables, text may be truncated
at the right cell boundary. Although the screen display is incorrect,
these fonts are printed correctly.

This problem was corrected in Word version 6.0 for Windows.

More Information:

This problem occurs because the TrueType screen fonts are not scaled
to a small enough size. If Word for Windows is in page layout view or
if the Line Breaks And Fonts As Printed check box is selected, the
screen fonts are too wide and extend beyond the right edge of the
page. In a table, Word for Windows does not display any text that
extends beyond the right edge of the cell.

Workaround
----------

To work around this problem, use one of the following methods:

 - Format the text with a larger point size, such as 9 points.

  -or-

 - In version 2.0, 2.0a, or 2.0a-CD of Word for Windows, deactivate the
   Line Breaks and Fonts as Printed option. To do this, choose Options
   from the Tools menu. Under Category, select View, then clear the Line
   Breaks And Fonts As Printed check box, and choose the OK button.

   In version 1.0, 1.1, or 1.1a of Word for Windows, deactivate the Show
   All option. To do this, choose Preferences from the View menu, clear
   the Show All check box, then choose the OK button.

   Note: These options are unavailable in page layout view (page view in
   version 1.x of Word for Windows). To use this workaround, switch to
   normal view.

Microsoft has confirmed this to be a problem in versions 1.0, 1.1,
1.1a, 2.0, 2.0a, and 2.0a-CD of Word for Windows. We are researching
this problem and will post new information here as it becomes



available.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 729

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD
w4wfont w4wprint cut off wrap beyond boundary after past true type



Error Message Printing Envelope on Microtek MTP-306 Printer
Article ID: Q88007
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When you print an envelope to a Microtek MTP-306 printer using the
Create Envelope command in Microsoft Word for Windows 2.0 or Tools 
Envelopes and Labels in Word 6.0, the following error message may 
appear on the LCD display of the printer if you are using the PostScript 
printer driver that ships with Microsoft Windows operating system 
version 3.1 (PSCRIPT.DRV, version 3.5):

   Wrong Size Paper

More Information:

This error message occurs when you use the Create Envelope command (or 
Envelopes and Labels command in Word 6.0) to print a second envelope; 
the first envelope prints correctly.

Workaround
----------

Select the Manual mode button on the printer before you print the
second envelope.

Steps to Reproduce Problem
--------------------------

1. In a Word for Windows document, print an envelope using the Create
   Envelope command (or Envelopes and Labels in Word 6.0).

2. Open another Word for Windows document and print it.

3. While the document opened in step 2 is active, print another
   envelope using the Create Envelope command (or Envelopes and Labels 
   in Word 6.0).

The "Wrong Size Paper" error message appears on the printer.

For more information on the Microtek MTP-306 printer, contact Microtek
technical support at (310) 352-3300.

The Microtek MTP-306 is manufactured by Microtek Lab Incorporated, a
vendor independent of Microsoft; we make no warranty, implied or
otherwise, regarding this product's performance or reliability.

Reference(s):



"Microsoft Word for Windows User's Guide," version 2.0, pages 120-121

Additional reference words: 2.00 2.00a 2.00a-cd w4wprint 6.00 wm_word 
errmsg err msg



White Line Appears in Shaded Text with PostScript Printers
Article ID: Q88817
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, when you print a document that contains
paragraph shading and you are using the PSCRIPT.DRV PostScript printer
driver version 3.5, 3.51, 3.52, 3.53, 3.54, or 3.55 for Microsoft 
Windows operating system version 3.1, a thin white horizontal band may 
appear across the shaded paragraphs.

More Information:

Workarounds
===========

To avoid this problem, follow the appropriate procedure below.

If the shaded paragraphs are not in a table cell
------------------------------------------------

Decrease the size of the font to 10 points or smaller.

-or-

Decrease the line spacing of the paragraphs (if possible) as follows:

1. Select the shaded paragraphs.

2. From the Format menu, choose Paragraph.

3. Set the line spacing to Exactly 12pt or 13pt.

If the shaded paragraphs are in a table cell
--------------------------------------------

1. Select the cells to be shaded.

2. From the Format menu, choose Border

3. Choose Shading

4. In the Shading dialog box, set the Pattern option to Clear, set the
   Foreground option to Yellow, and set the Background option to
   Yellow.

   Note: The color yellow produces 5-percent shading and will not
   create a white band.



If you are using a PostScript print command to shade a table cell, try
the following:

 - Insert a PRINT field in the cell with the following syntax

      {print \p cell "wp$box .89 setgray fill"}

   where the braces ({}) are created by pressing CTRL+F9. The
   PostScript printer will interpret this code and apply shading to
   the cell containing this field.

For more information on the use and limitations of embedding PRINT 
fields
in a Word for Windows document and PostScript shading commands, query
on the following words in the Microsoft Knowledge Base:

   postscript and shade and tables and field

Steps to Reproduce Problem
--------------------------

1. Type 13 to 16 lines of text in a new Word for Windows document.

2. From the Edit menu, choose Select All.

3. From the Format menu, choose Borders. Choose the Shading button. In
   the Pattern box, select 5 percent and choose the OK button.

4. Print the page to a PostScript printer using the PostScript printer
   driver.

Microsoft has reproduced this problem on the Hewlett-Packard (HP)
LaserJet Series IIISi PostScript printer, QMS ColorScript 100, and the
IBM 4029 PS printer. We are researching this problem and will post new
information here as it becomes available.

Additional reference words: win31 w4wprint 2.00 2.00a 2.00a-CD corrupt
6.00 wm_word w4wtable garbage band clear gap missing incomplete skips
w4wpostscript 3.10



SYMBOL Field May Not Print If Character Spacing is Condensed
Article ID: Q89284
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, and 2.0b
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you choose Symbol from the Insert
menu and select a font other than Normal Text in the Symbols From box,
the symbol does not print if you apply condensed spacing character
formatting to it. Similarly, if you choose Bullets And Numbering from
the Tools menu and choose the New Bullet button, symbols from a font
set other than Normal Text do not print if they contain condensed
spacing character formatting.

Symbols from the Normal Text font set print correctly when you apply
condensed spacing character formatting.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Workarounds
-----------

 - Select the SYMBOL field that contains condensed spacing character
   formatting. From the Format menu, choose Character. In the Spacing
   box, select Normal, then choose the OK button.

  -or-

 - Insert the symbol using the ANSI character code and then format the
   character for the appropriate font. For example, to insert a 
   Microsoft Windows symbol, choose Character from the Format menu, 
   select WingDings in the Font box, and choose the OK button. Press 
   ALT+Keypad 0255 to create the Microsoft Windows symbol. If you apply 
   condensed spacing character formatting to this symbol, created using 
   the ANSI character code instead of a SYMBOL field, the symbol prints 
   correctly.

Steps to Reproduce Problem
--------------------------

1. From the Insert menu, choose Symbol.

   -or-

   From the Tools menu, choose Bullets And Numbering. Select the Bullets
   option button and choose the New Bullet button.

2. In the Symbols From box, select any font except Normal Text.



3. Select any symbol and choose the OK button.

4. Select the symbol you inserted in step 3 above. From the Format
   menu, choose Character.

5. In the Spacing box, select Condensed, then choose the OK button.

6. Print the document. 

The symbol does not print.

Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
2.0a-CD, and 2.0b of Word for Windows. This problem was corrected in 
Word version 6.0 for Windows.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b w4wfield
w4wprint missing blank printer



WinWord: Paragraph Borders Overlap with Multiple Columns
Article ID: Q89303
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you create a multiple-column Microsoft Word for Windows document
and apply border formatting to the left and right sides of the
paragraphs, the borders may overlap between the columns. This problem
occurs if the value of the Space Between Columns setting is zero (0)
inches. In page layout view, the overlapping borders are not
displayed. In print preview, the overlapping borders are displayed as
they appear when printed.

This article describes a method for adding a left border to the
left-most column, a right border to the right-most column, and a
single line between each column on a page.

More Information:

The following method is a modification of the instructions for
creating a page border on page 367 of the "Microsoft Word for Windows
User's Guide." This method allows you to edit your document without
affecting the placement of borders.

Workaround for Word 6.0
-----------------------
1. From the Format menu, choose Columns. Select the Number Of Columns 
   and enter a number in the Space Between box like .25. Select the Line 
   between checkbox, then choose the OK button.

2. From the File menu, choose Page Setup. Choose the Margins dialog tab. 
   Type a minus sign before the measurement in the Top box.

   Note: If your document already contains a header, type a minus sign
   before the measurement in the Bottom box, rather than the Top box.

3. In the Header box under From Edge, type the same measurement as the 
   top margin. (For example, if the top margin is 1 inch, the Header 
   From Edge setting should be 1 inch as well).

   Note: If your document already contains a header, set the Footer
   measurement under From Edge equal to the bottom margin. Choose the OK 
   button.

4. From the View menu, select Header and Footer (switch to Footer if the
   document already contains a header), and choose the OK button. Select
   the paragraph mark in the header pane. From the Format menu, choose
   Paragraph. In the Line Spacing box, select Exactly. In the At box,



   type the distance between the top and bottom margins. To calculate
   the  At value, subtract the top and bottom margin from the vertical 
   page height. (For example, if you have an 8.5-inch-by-11-inch page in
   portrait view with 1-inch top and bottom margins, type 9" in the At
   box). Choose the OK button.

5. From the Format menu, choose Borders and Shading. In the Border box, 
   select the left and right sides of the sample paragraph. In the Line 
   box, select a border style, and choose the OK button.

Workaround for Word 2.0
-----------------------

1. From the Format menu, choose Columns. Select a value in the Number
   Of Columns and the Space Between boxes. Select the Line Between check
   box, then choose the OK button.

2. From the Format menu, choose Page Setup. Select the Margins option
   button, type a minus sign before the measurement in the Top box, and
   choose the OK button.

   Note: If your document already contains a header, type a minus sign
   before the measurement in the Bottom box, rather than the Top box.

3. From the View menu, choose Normal. From the View menu, choose
   Header/Footer. In the Header box under From Edge, type the same
   measurement as the top margin. (For example, if the top margin is 1
   inch, the Header From Edge setting should be 1 inch as well).

   Note: If your document already contains a header, set the Footer
   measurement under From Edge equal to the bottom margin.

4. In the Header/Footer box, select Header (select Footer if the
   document already contains a header), and choose the OK button. Select
   the paragraph mark in the header pane. From the Format menu, choose
   Paragraph. In the Line Spacing box, select Exactly. In the At box,
   type the distance between the top and bottom margins. To calculate 
   the At value, subtract the top and bottom margin from the vertical 
   page height. (For example, if you have an 8.5-inch-by-11-inch 
   page in portrait view with 1-inch top and bottom margins, type 9" in
   the At box). Choose the OK button.
  
5. From the Format menu, choose Border. In the Border box, select the
   left and right sides of the sample paragraph. In the Line box, select
   a border style, and choose the OK button.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 367,
572-574

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b w4wprint
overlays top overwrites 6.00



Word: Paper Will Not Feed from HP DeskJet Printer
Article ID: Q89317
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When you use the Hewlett-Packard (HP) DeskJet HPDSKJET.DRV printer
driver (which is supplied with Microsoft Windows operating system
version 3.1) to print from Microsoft Word for Windows, paper will not
feed from the DeskJet paper bin if the printer driver settings differ
from the following:

   Paper Size: Letter 8.5 x 11
   Paper Source: Auto Sheet Feeder

This situation occurs regardless of the bin option settings you select
in Word for Windows (when you choose Page Setup from the Format menu).

Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
2.0a-CD, 2.0b, 6.0 of Word for Windows. We are researching this problem
and will post new information here as it becomes available.

More Information:

If the printer driver settings differ from those listed above, the
rollers on the printer will spin, but the printer will not pick up
paper from the tray. The rollers eventually stop spinning and the
printer stops, but the ready light is turned off. You may receive a
the following Windows error message:

   Printer not ready

Word for Windows is designed to override the printer driver settings,
so printing should be directed by the settings in the Page Setup
dialog box.

Steps to Reproduce Problem
--------------------------

1. In Word for Windows, choose Print Setup from the File menu. Select
   the HP DeskJet printer driver and choose the Setup button.

2. In the Paper Size box, select Envelope #10 4 1/8 x 9 1/2. In the
   Paper Source box, select Envelope Manual Feed.

3. Choose the OK button twice.

4. From the Format menu, choose Page Setup.



5. Under Size and Orientation, select Letter 8 1/2 x 11 in the Paper
   Size box.

6. Under Paper Source, select Auto Sheet Feed or Default Tray in the
   First Page and Other Pages boxes. Choose the OK  button.

7. Print the document.

Additional reference words: 3.10 3.00 w4wprint 2.00 2.00a 2.00a-cd 6.00 
wm_word 2.00b win31  errmsg err msg w4wenvelope



WinWord: Embedding Fonts Within a Word for Windows Document
Article ID: Q89533
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Microsoft Windows TrueType fonts included with Microsoft Windows
operating system version 3.1 can be embedded or packaged in a document
and transported from one machine to another that does not have the
embedded font. Once transported to another machine, the embedded fonts
are available for use.

Only TrueType fonts that have the proper licensing bits set (meaning
that the font vendor has given permission for the font to be used as
an embedded font) can be embedded in a document. An application must
have special support for installation and embedding of TrueType fonts
upon reaching the destination machine.

Microsoft Word for Windows does not support the embedding of TrueType
fonts within a document file. When you transport a Word document from
one machine to another, TrueType fonts must be present on both
machines.

If you want to print a Word document that contains TrueType fonts on a
machine that does not have TrueType fonts installed, print your
document to file. Take the print file to the other machine and use the
MS-DOS COPY command with the /b parameter to print the file. For
example, at the MS-DOS prompt, type the following:

   COPY /b <filename> LPT1:

For more information on the MS-DOS COPY command, refer to pages
389-393 of the "Microsoft MS-DOS User's Guide and Reference" for
MS-DOS version 5.0.

Note: Version 3.0 of Microsoft PowerPoint for Windows supports the
embedding of TrueType fonts within presentation files.

REFERENCES
==========

"Microsoft MS-DOS User's Guide and Reference," version 5.0, pages
389-393

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
w4wprint w4wfont ttf



WinWord: PacificPage Cartridge Problems with HP IID and IIID
Article ID: Q89539
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When you use the PacificPage Cartridge version 3.0 with a
Hewlett-Packard (HP) LaserJet Series IID and IIID, you may experience
the following problems when you print envelopes or when you print from
the manual feed tray.

Bin Selection
-------------

The PacificPage cartridge does not support bin selection on the HP
IID. If you try to print a multiple-section document where different
pages are set to pull from the upper and lower bins, the PacificPage
cartridge causes the printer to print from the upper tray every time.

The PacificPages PostScript cartridge for the HP LaserJet Series II
using the HP IID PostScript printer driver for Windows 3.1 also does
not does not correctly support bin selection.

Printing Envelopes
------------------

If you try to print envelopes using the envelope feeder and you select
the Envelope Feeder option (from the Tools menu, choose Options, and
then select the Print category in Word 2.0 or Tools/Envelopes and 
Labels/Options/Printing Options/Feed From Envelope in Word 6.0), the 
envelope is printed from the upper tray and does not recognize the 
envelope feeder. The PacificPage cartridge does not allow the envelope 
feeder to be recognized at the time of the print job.

Note: Using the Apple LaserWriter NT or II NTX does not correct either
of the above problems.

More Information:

According to Pacific Data Products Technical Support, a new revision
of the PacificPage PE cartridge that offers greatly enhanced
paper-handling features is in development. For more information about
the new cartridge, contact Pacific Data Products at the following
telephone numbers:

   Sales Information: (619) 587-4690
   Technical Support: (619) 597-3301

The PacificPage cartridge is manufactured by Pacific Data Products, a



vendor independent of Microsoft; we make no warranty, implied or
otherwise, regarding this product's performance or reliability.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b w4wprint 6.00 
wm_word PSCRIPT.DRV w4wpostscript w4wlaserjet w4wenvelope 6.00



WinWord: Bitstream TypeCity Cartridge Fonts Print Incorrectly
Article ID: Q89804
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

Sometimes Bitstream TypeCity cartridge fonts print incorrectly in
Microsoft Word for Windows. This problem occurs if you exit Word and
restart the application without exiting and restarting Microsoft
Windows operating system version 3.1. The printed fonts resemble the
Windows Roman font. TypeCity cartridge fonts print correctly during
the first Word session after starting Windows.

This problem does not occur in Windows Write or Microsoft Excel for
Windows.

MORE INFORMATION
================

TypeCity version 1.0 is a Bitstream product composed of a printer
cartridge and a setup disk containing matching screen fonts. The setup
program adds TypeCity to the list of cartridges in the printer driver
Setup dialog box. Setup also adds TypeCity font names to the Installed
Fonts list in the HP Soft Font Installer dialog box.

The TypeCity setup program prompts you to specify what software
programs to install TypeCity for. It offers the following list:

   LetterPerfect 1.0
   Microsoft Windows 2.x/3.0
   Microsoft Word for MS-DOS, 5.0
   Microsoft Word for MS-DOS, 5.5
   WordPerfect 5.0
   WordPerfect 5.1

Note: The list does not include Windows version 3.1 as a setup choice.

Workaround
----------

To work around this problem, place the following switch in the
[Microsoft Word 2.0] section of the Windows WIN.INI file:

   Win31Print=0

This switch allows Word for Windows to print in Windows version 3.1
the same as when it runs in Windows version 3.0. For more information
on this switch, query on the following words in the Microsoft



Knowledge Base:

   winword and win31print

The TypeCity products included here are manufactured by Bitstream, a
vendor independent of Microsoft; we make no warranty, implied or
otherwise, regarding these products' performance or reliability.

For more information about TypeCity, contact Bitstream at the
following telephone numbers:

   Bitstream technical support: (617) 497-7514
   Main number: (617) 497-6222
   Enduser Sales & Information: (800) 522-3668

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b win31 w4wfont
w4wprint type city



WinWord: FILLIN Fields in Header Updated at Print or in Views
Article ID: Q89863
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

By design, Word for Windows updates FILLIN fields located in the
header or footer when you print a document, print merge a document to
the printer or to a new document, or switch to print preview or page
layout view. These fields are updated even if the Update Fields check
box is cleared in the Tools Options Print dialog box.

Workaround
----------

To work around this problem, use an ASK field instead of a FILLIN
field to insert text in your header or footer. Insert the ASK field in
the body of the document. In the header or footer, insert a field
reference to the ASK field bookmark. An ASK field prompts you for
information when you update the field, but it is not automatically
updated when you print the document (unless you select the Update
Fields check box in the Tools Options Print dialog box).

To place information in the header with an ASK field:

1. In the body of your document, type:

      {ASK bookmark_name "Text to appear in InputBox"}

   Note: To create field brackets ({}), press CTRL+F9. These ASK
   fields are not visible when you print your document.

2. From the View menu, choose Header/Footer (in versions 1.0, 1.1 or
   1.1a of Word for Windows, choose Header/Footer from the Edit menu).
   Select Header and choose the OK button. In the header window,
   insert the following field:

      {ref bookmark_name}

3. On the header option bar, choose the Close button.

4. Select the entire document and update the fields by pressing the F9
   key. When the ASK field prompts you for information, type the
   appropriate text and choose the OK button.

5. From the File menu, choose Print. The bookmark text appears in your
   document header.

Reference(s):



"Microsoft Word for Windows User's Guide," version 2.0, pages 475-478

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 
6.00 wm_word 
w4wfield w4wprint 3.00 3.10



WinWord 2.0b: Cannot Print After Setup Over Earlier Version
Article ID: Q90187
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, version 2.0b
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------

Summary:

If you install version 2.0b of Word for Windows over an earlier
version, you may be unable to print a document or envelope from Word
for Windows. To print, you must exit Word for Windows, rename or
delete the WINWORD.INI file from the WINWORD program directory, and
then restart Word for Windows.

More Information:

When you attempt to print, Word for Windows responds normally (the
Printing dialog box appears) and no error message appears. The
document does not print, however, nor does it appear in the Windows
Print Manager. After you disable the WINWORD.INI file and restart Word
for Windows, the problem no longer occurs.

This problem does not occur on all systems. Microsoft has confirmed
this to be a problem in version 2.0b of Word for Windows when printing
on the Hewlett-Packard (HP) DeskJet and DeskJet 500 printers using either
the Windows version 3.1 printer driver (HPDSKJET.DRV) or the HP printer
driver (DJ500C.DRV) for Windows version 3.1.

We are researching this problem and will post new information here as it
becomes available.

Additional reference words: 2.00b w4wprint nothing missing disappears
w4wenvelope corrupt invalid



Divide by Zero or Overflow Error with Linotronic Print Driver
Article ID: Q90193
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Word for Windows, if you print to a Linotronic printer using the
Linotronic PostScript printer driver version 3.52, 3.53, or 3.55 for
Microsoft Windows operating system version 3.1 and set a Custom Paper
Size (such as 8 inches by 10 inches), you may receive this error
message:

   System Error
   Divide by zero or overflow error

When you choose the OK button, Word for Windows closes and you lose
any unsaved work.

Microsoft has confirmed this to be a problem using the Linotronic 
printer driver versions 3.52,[C 3.53 and 3.55 for Windows version 3.1, 
the NEC 95 using driver version 3.53. This problem was corrected in Word 
version 6.0 for Windows.

More Information:

The following lists the Linotronic printer drivers that cause this
problem:

File Name       Date       Size     Printer
--------------------------------------------------------

L100_425.WPD    6-24-92    4885     Linotronic 100
L200230&.WPD    6-24-92    5182     Linotronic 200/230
L300_471.WPD    6-24-92    5315     Linotronic 300 v47.1
L300_493.WPD    6-24-92    5182     Linotronic 300 v49.3
L330_52&.WPD    6-24-92    5182     Linotronic 330
L500_493.WPD    6-24-92    5486     Linotronic 500
L530_52&.WPD    6-24-92    5486     Linotronic 530
L630_52&.WPD    6-24-92    5384     Linotronic 630

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b w4wprint
w4wpostscript pscript.drv  errmsg err msg crash crashes
crashed hang hangs hung locked



WinWord Err Msg: "EC Load COM 10" when Printing Envelopes
Article ID: Q90296
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Word for Windows, if you print an envelope to the Hewlett-Packard
(HP) LaserJet Series III printer using the HPPCL5A.DRV printer driver
version 31.3.89 for Windows version 3.1 and the Printer's Envelope
Feeder Has Been Installed option is selected in Word 2.0 (or 
Tools/Envelopes and Labels/Options/Printing Options/Feed From Envelope 
in Word 6.0), the following message appears on the printer:

   EC Load Com 10

The envelope prints from the manual feed paper source if you press the
Continue button on the printer, but the envelope address prints too
high on the envelope.

More Information:

To print envelopes to the HP LaserJet Series III from the manual feed
tray without having to press the Continue button on the printer, make
sure the Printer's Envelope Feeder Has Been Installed option is clear
in the Print Options dialog box (from the Tools menu, choose Options
and select the Print category in Word 2.0). (In Word 6.0 Choose 
Tools/Envelopes and Labels/Options/Printing Options/Feed From = Manual.) 
When you print the envelope, the printer automatically takes the 
envelope from the manual feed tray if the envelope is preloaded. If the 
envelope is not preloaded, the following message appears on the printer:

   MF Feed Com 10

As soon as you place an envelope in the manual feed tray, the printer
detects the envelope and pulls it from the tray. This happens even if
you select Envelope under Paper Source in the Page Setup dialog box.

Additional reference words: HPPCL5A.DRV 2.00 2.00a 2.00a-CD 2.00b 6.00 
wm_word 
w4wprint errmsg err msg error w4wlaserjet w4wenvelope



Error Message Printing Envelopes to Citizen GSX-145 Printer
Article ID: Q90729
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
If you use the Create Envelope command in Word for Windows to print an
envelope to a Citizen GSX-145 printer, the printer feeds the envelope
two or three inches, then a Windows Printer Error message occurs and
the envelope does not print. This happens when you use the Citizen
GSX-145 printer driver (CIT24US.DRV, version 1.0) supplied with
Windows version 3.1.
 
This problem does not occur in Windows version 3.0.
 
To successfully print envelopes on a Citizen GSX-145 printer from Word
for Windows, select the Citizen GSX-140 printer model instead.
 
More Information:
 
The Windows Printer Error message ("Cannot write to LPT1:") occurs
when the printer displays a "paper out" error.
 
For more information on printing envelopes to the Citizen GSX-140
printer, query on the following words in the Microsoft Knowledge Base:
 
   citizen and gsx and 140 and envelopes and winword
 
Additional reference words: w4wprint w4wenvelope 2.00 2.00a 2.00a-CD 
6.00 wm_word 
2.00b 2.00c 



Envelopes Merge Incorrectly Using HP PostScript Cartridge Plus
Article ID: Q90731
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
SUMMARY
=======
 
In Word for Windows, envelopes print merge incorrectly using the
Hewlett-Packard (HP) PostScript Cartridge Plus and the Windows version
3.1 HP LaserJet Series IIID PostScript printer driver version 3.5 or
3.51. If you print merge more than one envelope, the first envelope
prints from the envelope feeder and subsequent envelopes print from
the default tray. Moreover, the text prints backwards, so you must
hold the envelope up to a mirror to read it.

MORE INFORMATION
================
 
Microsoft has confirmed this to be a problem in the PostScript printer
driver versions 3.5 and 3.51 for Windows version 3.1 (PSCRIPT.DRV).
This problem was corrected in the PostScript printer driver versions
3.52 and 3.53. Microsoft has created an application note that contains
this updated version of the PostScript printer driver. To obtain this
application note, titled "PostScript Printer Driver Version 3.53"
(WW0593), call Microsoft Product Support Services at (206) 454-2030.
This application note can also be obtained from the Windows Driver
Library (WDL) through the Microsoft Download Service (MSDL) at (206)
936-6735.
 
The HP PostScript Cartridge Plus product included here is manufactured
by Hewlett-Packard, vendor independent of Microsoft; we make no
warranty, implied or otherwise, regarding these products' performance
or reliability.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, page 121

Additional reference words: 6.00 w4wprint w4wpostscript appnote
wm_word w4wenvelope 2.00 2.00a 2.00a-CD 2.00b 2.00c



WinWord Err Msg: EC Load Exec when Using HP LaserJet III
Article ID: Q90832
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:

In Word for Windows, if you format a document for Executive paper
size, the document prints incorrectly on a Hewlett-Packard (HP)
LaserJet Series III printer if the paper source is not set to Manual
Feed. The HP LaserJet Series III printer displays the following error
message to request an Executive paper tray:
 
   EC Load Exec
 
To correctly print a document formatted for Executive paper size,
select Manual Feed under Paper Source in the Page Setup dialog box.
 
More Information:
 
On the HP LaserJet Series III printer, the automatic paper feed trays
position the paper on the left side of the printing path. The manual
paper feed tray positions the paper in the center of the printing
path. If you press the Continue button on your printer to print from
the manual feed tray despite the above printer message, your document
prints too far left on the page. For example, the left margin is small
or nonexistent, while the right margin is too large.
 
When you select Executive Paper Size under Size and Orientation in the
Print Setup dialog box, Word for Windows does not automatically switch
the Paper Source settings to Manual Feed, even though it prints as if
you were feeding the paper from the Manual Feed tray. This means you
must select the Manual Feed setting yourself.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wprint 
6.00 wm_word lcd



Outline View Prints Continuous Sections on Separate Pages
Article ID: Q91054
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

In outline view, if you print a Microsoft Word for Windows document
that contains continuous section breaks, a page break occurs at each
continuous section break. In outline view, continuous section breaks
are interpreted as next page section breaks.

This problem was corrected in Word version 6.0. New or updated Microsoft 
products can be obtained by calling Microsoft End User Sales at (800) 
426-9400. If you are outside the United States,contact the Microsoft 
subsidiary for your area. To locate your subsidiary, call Microsoft 
International Customer Service at (206)
936-8661.

More Information:

Steps to Reproduce Problem
--------------------------

1. Create a new Word for Windows document that contains three short
   paragraphs. (The document should not exceed one page in length.)

2. Between each paragraph, insert a continuous section break. (To do
   this, choose Break from the Insert menu, select the Continuous option
   button, and choose the OK button.)

3. From the View menu, choose Page Layout or Normal. (In versions 1.x
   of Word for Windows, choose Page from the View menu.)

4. Print the document. Notice that all paragraphs print on one page.
   Print preview also displays one page.

5. From the View menu, choose Outline.

6. Print the document. Notice that a page break occurs at each
   continuous section break, which causes the document to print on three
   pages. Print preview also displays three pages.

Microsoft is researching this problem and will post new information
here as it becomes available.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 509-519



Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c  w4wprint break



Word for Windows: How to Create Crop Marks
Article ID: Q92600
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

Word for Windows includes no automatic feature that adds crop marks to your
document. This article presents two methods you can use to create crop
marks in your Word for Windows document.

More Information:

Crop marks are short lines at the corners of a page that show where the
outer edges of the paper should be trimmed:

       |               |
   ____|               |____

           Document
             Page

   ____                 ____
       |               |
       |               |

Below are two methods you can use to create crop marks in your Word for
Windows document. Method 1 is easier to set up; however, you may not be
able to position the crop marks close enough to the text of the document.
Method 2 allows greater precision in the positioning of the crop marks;
however, as mentioned earlier, Method 2 is more difficult to set up.

The companion disk for "Word for Windows 2.0 Macros," by Russell Borland,
includes a macro to create crop marks called InsertCropMarks. For more
information about this macro, which is located in EDITMAX.DOC, see page 440
of "Word for Windows 2.0 Macros".

Method 1: Insert a Three-Column Table in Header and Footer
----------------------------------------------------------

Using this method, you can create crop marks by inserting a three-column,
one-row table in the header and footer of your document and adding borders.

1. In the document header, insert a table that contains one row and three
   columns.

2. Select column 2. From the Table menu, choose Column Width. In the Width
   Of Column 2 box, type the distance between the left and right margin



   (for example, type 6 inches if your left and right margins are 1.25
   inches and your paper width is 8.5 inches). Choose the OK button.

3. Set the column width of columns 1 and 3 to 0.5 inches.

4. Select the entire table. From the Table menu, choose Row Height. In the
   Indent From Left box, type -.5". In the Height Of Row box, select
   Exactly. In the At box, type .5" and choose the OK button.

    Note: You can vary the position of your crop marks by adjusting the
    Indent From Left setting and the column width of columns 1 and 3. The
    column width of columns 1 and 3 must be the same. The Indent From Left
    setting must be the negative of the column width setting (for example,
    if the column width is 1", the Indent From Left setting must be -1").

5. Select column 1 and apply a right and bottom border. Select column 3 and
   apply a left and bottom border. The header table should look like this:

        |               |
   _____|               |_____

6. Copy the header and paste it into the footer.

7. In the footer table, change the border formatting in columns 1 and 3.
   Apply a top and right border to column 1. Apply a top and left border to
   column 2. The footer table should look like this:

   _____                 _____
        |               |
        |               |

Method 2: Create Four Framed, Single-Cell Tables
------------------------------------------------

  Note: These instructions are for use in versions 2.0, 2.0a, 2.0a-CD, and
  2.0b of Word for Windows only.

1. From the View menu, choose Header/Footer. Select Header and choose the
   OK button.

2. Insert two single-cell tables in the header. Apply the following table
   and border formatting to each table:

   a. From the Table menu, choose Column Width. In the Width Of Column 1
      box, select .5 inches. In the Space Between Cols box, select 0 inches
      and choose the OK button.

   b. From the Table menu, choose Row Height. In the Indent From Left box,
      select 0 inches. In the Height Of Row 1 box, select Exactly. In the
      At box, type a value, such as .5 inches, that represents the distance
      from the top edge of the paper where you want the top crop marks to
      appear. (For example, if you want a crop mark to appear .5 inches
      from the top edge of the paper, type .5" in the At box.) Choose the
      OK button.

   c. Select the first table. From the Format menu, choose Border. Select
      one of the line styles. Select the bottom and right sides in the



      Border box and choose the OK button.

   d. Select the second table. From the Format menu, choose Border. Select
      one of the line styles. Select the bottom and left sides in the
      Border box and choose the OK button.

3. Frame the tables. Choose the No button when Word for Windows asks if you
   want to switch to page layout view.

   a. Select the first table. From the Format menu, choose Frame. Select
      the following frame options and choose the OK button:

         Horizontal Position: Left
            Relative To: Page
            Distance from Text: 0"
         Vertical Position: 0"
            Relative To: Page
            Distance from Text: 0"

   b. Select the second table. From the Format menu, choose Frame. Select
      the following frame options and choose the OK button:

         Horizontal Position: Right
            Relative To: Page
            Distance from Text: 0"
         Vertical Position: 0"
            Relative To: Page
            Distance from Text: 0"

4. From the View menu, choose Header/Footer. Select Footer and choose the
   OK button.

5. Insert two single-cell tables in the footer. Apply the following table
   and border formatting to each table:

   a. From the Table menu, choose Column Width. In the Width Of Column 1
      box, select .5 inches. In the Space Between Cols box, select 0 inches
      and choose the OK button.

   b. From the Table menu, choose Row Height. In the Indent From Left box,
      select 0 inches. In the Height Of Row 1 box, select Exactly. In the
      At box, type a value, such as .5 inches, that represents the distance
      from the bottom edge of the paper where you want the bottom crop
      marks to appear. (For example, if you want a crop mark to appear .5
      inches from the top edge of the paper, type .5" in the At box.)
      Choose the OK button.

   c. Select the first table. From the Format menu, choose Border. Select
      one of the line styles. Select the top and right sides in the Border
      box and choose the OK button.

   d. Select the second table. From the Format menu, choose Border. Select
      one of the line styles. Select the top and left sides in the Border
      box and choose the OK button.

3. Frame the tables. Choose the No button when Word for Windows asks if you
   want to switch to page layout view.



   a. Select the first table. From the Format menu, choose Frame. Select
      the following frame options and choose the OK button:

         Horizontal Position: Left
            Relative To: Page
            Distance from Text: 0"
         Vertical Position: Bottom
            Relative To: Page
            Distance from Text: 0"

   b. Select the second table. From the Format menu, choose Frame. Select
      the following frame options and choose the OK button:

         Horizontal Position: Right
            Relative To: Page
            Distance from Text: 0"
         Vertical Position: Bottom
            Relative To: Page
            Distance from Text: 0"

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 313-342, 361-
380, 389-420, 571-584

"Word for Windows 2.0 Macros," Russell Borland, Microsoft Press, 1992, page
441

Additional reference words: w4wformat wm_word
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
cropmark w4wprint 2.00c insertcropmarks



List of Internal Scalable Fonts in HP LaserJet 4
Article ID: Q93194
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

This article lists the 45 internal scalable printer fonts (35
Intellifont, 10 TrueType) supplied with the Hewlett-Packard (HP)
LaserJet 4 printer. The article also lists the 35 PostScript fonts
supplied with the optional Adobe Postscript Level 2 SIMM package.

More Information:

These internal scalable fonts are printer fonts, not screen fonts.
This means Windows displays the Intellifont fonts using available screen
fonts as substitutes unless you install Intellifont screen fonts.

Note: All the fonts in these lists are scalable, except where noted.

   PCL Fonts (35 Intellifont)
   --------------------------

   Courier
   CG Times
   CG Times Bold
   CG Times Italic
   CG Times Bold Italic
   CG Omega
   CG Omega Bold
   CG Omega Italic
   CG Omega Bold Italic
   Coronet
   Clarendon Condensed
   Univers Medium
   Univers Bold
   Univers Medium Italic
   Univers Bold Italic
   Univers Medium Condensed
   Univers Bold Condensed
   Univers Medium Condensed Italic
   Univers Bold Condensed Italic
   Antique Olive
   Antique Olive Bold
   Antique Italic
   Garamond Antiqua
   Garamond Halbfett
   Garamond Kursiv
   Garamond Kursiv Halbfett
   Marigold



   Albertus Medium
   Albertus Extra Bold
   Courier Bold
   Courier Italic
   Courier Bold Italic
   Letter Gothic
   Letter Gothic Bold
   Letter Gothic Italic

   The HP LaserJet 4 also includes the Line Printer font. This font is
   not scalable. It is available in the 8.5 points (16.67 pitch) size
   only.

   PCL Fonts (10 TrueType)
   -----------------------

   Arial
   Arial Bold
   Arial Italic
   Arial Bold Italic
   Times New
   Time New Bold
   Times New Italic
   Times New Bold Italic
   Symbol
   Wingdings

   PostScript Fonts
   ----------------

   The following PostScript Typeface Fonts are available if you
   installed the optional Adobe Postscript Level 2 SIMM on your HP
   LaserJet 4.

   ITC Avant Garde Gothic Book
   ITC Avant Garde Gothic Book Oblique
   ITC Avant Garde Gothic Demi
   ITC Avant Garde Gothic Demi Oblique
   ITC Bookman Demi
   ITC Bookman Demi Italic
   ITC Bookman Light
   ITC Bookman Light Italic
   Courier
   Courier Bold
   Courier Bold Oblique
   Courier Oblique
   Helvetica
   Helvetica Bold
   Helvetica Bold Oblique
   Helvetica Oblique
   Helvetica Narrow
   Helvetica Narrow Bold
   Helvetica Narrow Bold Oblique
   Helvetica Narrow Oblique
   New Century Schoolbook Bold
   New Century Schoolbook Bold Italic
   New Century Schoolbook Italic



   New Century Schoolbook Roman
   Palatino
   Palatino Bold
   Palatino Bold Italic
   Palatino Italic
   Symbol
   Times Bold
   Times Bold Italic
   Times Italic
   Times Roman
   ITC Zapf Chancery Medium Italic
   ITC Zapf Dingbats

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wfont 6.00 
wm_word w4wprint laserjet4 hp4



How to Send Printer Escape Codes from a WinWord Document
Article ID: Q93658
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

In Word for Windows, you can use one of the following methods to send
an instruction, or printer escape sequence, to your printer:

 - Insert a PRINT field in your document that contains the printer 
   escape codes. Example:

      {PRINT "<printer instructions>"}

-or-

 - Type the printer escape sequence in your document and format it for a
   printer font.

MORE INFORMATION
================

There are limitations and drawbacks to each of the above methods,
depending on which printer driver you use. Neither method is guaranteed
to work on every printer.

Limitations of the PRINT Field
------------------------------

When you insert a PRINT field, Word calls an escape in the printer
driver that sends the printer instruction text to the printer. If the
escape in the printer driver malfunctions, the PRINT field may produce
incorrect or no results.

  Note: The PRINT field does not affect your page layout because Word
  treats a PRINT field as nonprinting characters.

Limitations of Typing Printer Information Directly in Your Document
-------------------------------------------------------------------

When you type printer information directly in your document, Word treats
the escape sequence text as normal text. This means that Word 
incorporates
the text in your document page layout.

When you print the document, the printer interprets the escape sequence
text as printer instructions and does not print it. Your printer may
misinterpret the escape sequence if Word does not send the entire string



contiguously. For example, if you apply justified paragraph formatting,
Word sends other characters to adjust the line length, thereby changing
the escape sequence string.

For information on the PRINT field, search for Print Field using the 
Help menu in version 2.0 of Word for Windows.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.x, page 104

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 1.00 1.10 
6.00 wm_word 1.10a w4wfield w4wprint



Cannot Print from Mixed Bins to Canon LBP-8 III or IV Printer
Article ID: Q93731
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-cd, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------

Summary:

A Word for Windows document formatted for mixed-bin printing may print 
from the wrong bins when you use the Canon LBP-8 III and LBP-8 IV 
printer driver version 3.09 (LBPIII.DRV), which is supplied with Windows 
version 3.1.

Specifically, if you format the first page of your document to print 
from the upper tray and format the second page to print from the lower 
tray, the first page prints correctly. The second page prints from the 
manual tray. On the printer LCD display, the message "PF LOAD LETTER" 
appears and the printer waits for you to insert a piece of paper. This 
happens regardless of the Paper Source setting in the Print Setup dialog 
box or Page Setup dialog box.

More Information:

To print the first page of your document from the upper tray and 
subsequent pages of your document from the lower tray, use the 
instructions below to insert the following PRINT field at the beginning 
of the second page:

   {PRINT <ALT+27> "[2q"}

1. At the beginning of the second page, press CTRL+F9 to create field
   brackets.

2. Type "print " (without the quotation marks). Be sure to type a space
   after "print".

3. Press ALT+27 on the numeric keypad.

4. Type a space, then type "[2q" (WITH the quotation marks).

5. Select the field, and format the field for an internal printer font 
   such as Courier.

Reference(s):

"Canon User Reference Manual," Chapter 14, page 103

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c mixed second 
6.00 wm_word 
w4wprint wrong escape sequence



Word for Windows: Watermark Prints on Top of Document Body
Article ID: Q94086
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Word for Windows, objects on the page print in the order in which 
they appear. Therefore, if you have text or graphics in the body of your
document above the location of a watermark in your header, the header 
will print on top of the document body.

Workaround
----------

Crop the image in the header to add white space above it, so that the 
image begins at the top of the header. It will now print behind the 
document.

Microsoft has confirmed this to be a problem in Word versions 1.x and 
2.x. This problem was corrected in Word version 6.0 for Windows.

More Information:

Steps to Reproduce Problem
--------------------------

1. From the Format menu, choose Page Setup (Document in Word versions 
   1.x), and insert a minus sign in front of the top margin value. This
   indicates an exact measurement that you do not want adjusted to
   accommodate a long header.

2. From the View menu (the Edit menu in Word 1.x), choose Header/Footer,
   and set the header distance from the edge equal to the top margin
   (without a minus sign). Choose the OK button to view the header.

3. Insert a WordArt object or text in a large point size, and position
   it so that it does not begin at the top of the header (for example,
   press ENTER a few times above the object or text to move it down).

4. In the body of the document, insert graphics or text. From the File
   menu, choose Print Preview, and note that the object or text in the
   header is shown behind the document body.

5. Choose the Cancel button to close Print Preview, then choose Page 
   Layout (Page in Word 1.x) from the View menu and note that in this  
   view, the object or text in the header is also shown behind the 
   document body.

6. From the File menu, choose Print.



   The object or text from the header prints on top of the document body
   instead of behind it, as indicated in print preview and page layout
   view.

Reference(s):

"Microsoft Word for Windows User's Guide," pages 573, 577.
"Microsoft Word for Windows User's Reference," pages 146-148.

Additional reference words: layer overprint overlap overlay wrong
incorrect w4wprint 1.00 1.10 1.10a 1.x 2.00 2.00a 2.00a-CD 2.00b 2.00c



Incorrect Font and No Graphics Print Using Turbo 25 Cartridge
Article ID: Q95064
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
When you print to a Hewlett-Packard (HP) LaserJet Series II, IIP, IID,
or compatible printer while the Turbo 25 Cartridge is installed, the
cartridge may cause TrueType or printer-resident fonts to remap to the
Turbo 25 graphics symbol set. Further, no graphics print while this
cartridge is installed.
 
UDP Data Products, Inc., manufacturers of the Turbo 25 Cartridge, have
confirmed this to be a problem with the cartridge. According to its
technical support representative, UDP is working on a printer driver
to correct these problems. For information on obtaining this updated
printer driver, contact UDP Technical Support at (800) 888-4413.
 
The Turbo 25 Cartridge is manufactured by UDP Data Products, Inc., a
vendor independent of Microsoft; we make no warranty, implied or
otherwise, regarding this product's performance or reliability.
 
More Information:
 
The Turbo 25 Cartridge contains 143 fonts.
 
Workarounds
-----------
 
To Print Graphics Only
---------------------
 
Remove the Turbo 25 cartridge from the printer and use the HP LaserJet
Series II, IIP, or IID printer driver for Windows version 3.1.
 
To Print Turbo 25 Fonts Only and No Graphics
--------------------------------------------
 
Install the HP LaserJet Series III printer driver and install the
Turbo 25 cartridge. Using this configuration, you can print Turbo 25
fonts, but you cannot print graphics.
 
To Print Turbo 25 Fonts with Graphics
-------------------------------------
 
Install the Turbo 25 cartridge, then select HP - ProCollection from
the Cartridges list in the Print Setup dialog box. Using this
workaround, you can access 65 of the 143 fonts on the Turbo 25
cartridge.



 
Additional reference words: w4wprint w4wlaserjet w4wfont 3rdparty 3rd 
6.00 wm_word party third hpiii hpii ljiii ljii 2.00 2.00a 2.00b 2.00c 
2.00a-CD



Problems Printing with TurboScript III PostScript Cartridge
Article ID: Q95174
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:

If you are using the TurboScript III PostScript cartridge, you will
experience problems with using mixed-bin printing, printing envelopes,
and using TrueType fonts when you print to the Hewlett-Packard (HP)
IID or IIID with the PostScript printer driver version 3.5-3.55 and
the HP IID (HP_IID522.WPD) or IIID (HP_3D522.WPD) description file. 
 
More Information:
 
HP IID POSTSCRIPT (HP_IID522.WPD)
---------------------------------
 
Bin Selection
-------------
 
Bin-selection codes are not properly interpreted by the TurboScript
III. Documents or pages formatted to print from the lower tray will
always print from the upper tray.
 
Envelopes
---------
 
Envelopes will not print from the envelope tray with the envelope
feeder option turned on in the Tools Options Print dialog box in Word 
2.0.  In Word 6.0, this option is chosen by choosing Envelopes and 
Labels from the Tools menu.  Choose the envelopes dialog tab, and choose 
options. Choose the Printing Options dialog tab.  The Feed From box 
should not be set as Envelope (Envelope Feeder)   The envelope will be 
pulled from the upper tray because the envelope feeder option is being 
improperly interpreted by the cartridge if the envelope feeder is 
enabled.
 
Fonts
----- 

TrueType fonts will not print properly in landscape orientation. The
fonts will sometimes print on top of each other.
 
Workaround
----------
 
Remove the cartridge from the HP IID and use the printer in native PCL
mode.
 



HP IIID POSTSCRIPT (HP_3D522.WPD)
--------------------------------
 
The following error message will occur when a documented is printed on
this printer:
 
   Offending Command = setduplexmode
   Error = nametype : rangecheck
   Stack =
 
The following error message will occur when an envelope is printed on
this printer:
 
   Offending Command = setduplexmode
   Error = nametype : undefined
   Stack =
         0
         2
         false
 
These errors occur because the HP IIID .WPD file sends a duplexing
command that is not properly interpreted by the TurboScript III.
 
Workaround
----------
 
Turn off the printer, remove the TurboScript III cartridge, and use
the printer in native PCL mode. You can also use the HP III PostScript
printer driver, which does not send a duplexing code, and thus avoid the
"Offending Error" command.
 
Note: Using the HP III PostScript driver will take away bin selections
normal to the HP IIID because the HP III has only one paper tray.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c  6.00 
wm_word 
w4wpostscript w4wprint true type  w4wenvelope



Printing Envelopes with the HP DeskJet 550C
Article ID: Q95403
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
In Word for Windows, when you use the Create Envelope command to print
a Number 10 envelope using the Hewlett-Packard (HP) DeskJet printer
driver (DESKJETC.DRV) version 3.0 or 3.1 on the HP DeskJet 550C printer, 
the envelope may print incorrectly. If you set a printer heuristic 
(+544), envelopes may print correctly. To ensure that your envelope 
prints correctly every time, however, use one of the following printer
drivers supplied by Microsoft and set a printer heuristic (+544): 

 - Microsoft HP DeskJet 550C (monochrome) printer driver version 2.0
   (HPDSKJET.DRV). This driver ships with Windows for Workgroups.
 
 - Microsoft HP DeskJet printer driver version 2.1 (HPDSKJET.DRV)
   dated 12/07/92, available from the MSDL.
 
Word for Windows version 6.0 does not use printer hueristics to contol 
printer functionality.  To change printer functionality choose Options 
from the Envelopes and Lables dialog box.  Under the Envelope Options 
dialog box categoty Printing Options you can set the Feed method 
(orientation and location) of the envelope.

More Information:
 
Microsoft recommends that you use the Microsoft HP DeskJet 550C
(monochrome) printer driver version 2.0 or printer driver version 2.1
to print envelopes using the Create Envelope command in Word for
Windows. When you use one of these Microsoft printer drivers, you must
set the HPDSKJET=+544 printer heuristic to print envelopes correctly.
See the "Printer Heuristic DESKJETC=+544 and HPDSKJET=+544" section
below for information.
 
 - The HPDSKJET.DRV version 2.0 printer driver is supplied with
   Microsoft Windows for Workgroups version 3.1.
 
 - The HPDSKJET.DRV version 2.10 printer driver is available via modem
   from the MSDL (Microsoft Download Service), at (206) 936-6735.
 
For more information about the MSDL, query on the following words in
the Microsoft Knowledge Base:
 
   WDL.TXT and MSDL and library and information and Win3
 
Troubleshooting Incorrect Envelope Output
-----------------------------------------



 
When your envelope prints incorrectly, one of the following occurs:
 
 - Word displays the following error message:
 
      Margins are set outside of the Unprintable Region.
 
   If you choose the OK button, your envelope prints in the correct
   position, but the address may be truncated.
 
-or-
 
 - The envelope address does not print on the envelope at all. When
   this  happens, the envelope may be printing on the left instead of 
   the right side of the printer. To determine whether the envelope 
   address is printing on the left side of the printer or not at all, 
   print the envelope on a piece of letter-sized paper.
 
-or-
 
 - Using the printer driver version 2.10, the envelope must placed into
   the paper tray the opposite direction of the diagram in the paper
   tray of the printer. If the envelope is placed in the tray
   correctly, the address will print in the opposite corner of the
   envelope.
 
If nothing prints on the letter-sized paper, check the following:
 
1. From the Tools menu, choose Options. Under the Print Category, make
   sure these settings are correct:
 
   a. The Reverse Print Order option should be cleared.
 
   b. The Draft Output option should be cleared.
 
2. Note: This setting applies only to the Microsoft HP DeskJet 550c
   printer driver versions 1.2 (DESKJET.DRV), 2.0 (HPDSKJET.DRV), and
   2.10 (HPDSKJET.DRV)
 
   From the File menu, choose Print Setup. Select the DeskJet printer
   and choose the Setup button. The Resolution setting should be 300 
   DPI.
 
3. If the envelope feeds through the printer blank, check to ensure
   that the 1.1 (DESKJET.DRV) version of the driver is not being used.
   This driver shipped with Windows version 3.1. This driver does not
   support the DeskJet 550.
 
Printer Heuristic DESKJETC=+544 and HPDSKJET=+544
-------------------------------------------------
 
If your envelope address prints on the left instead of the right side
of the printer, heuristic DESKJETC=+544 may correct the problem. This
printer heuristic sometimes, but not always, prints envelopes
correctly on the DeskJet 550c. Heuristic 544 forces Windows to print
the envelope in reverse landscape orientation. Without this printer
heuristic, the DeskJet 550c prints envelopes in portrait mode by



default. The following are the heuristics used for the HP DeskJet
550c:
 
 - Using the printer driver DESKJET.DRV from HP:  Deskjetc=+544
 
 - Using either printer driver from Microsoft:    HPDSKJET=+544
 
For information on setting printer heuristics, query on the following
words in the Microsoft Knowledge Base:
 
   newmacro.doc and functionality and printer and heuristics
 
HP DeskJet 550C Printer Driver Notes
------------------------------------
 
 - HP DeskJet printer driver version 3.0 (DESKJETC.DRV) is supplied by
   HP for use with Windows versions 3.0 and 3.1.
 
 - HP DeskJet printer driver version 2.0 (HPDSKJET.DRV) is supplied by
   Microsoft for use with Windows version 3.1.
 
 - HP DeskJet printer driver version 2.10 (HPDSKJET.DRV) is supplied
   by Microsoft for use with Windows version 3.1.

The DESKJETC.DRV printer driver is manufactured by Hewlett-Packard, a
vendor independent of Microsoft; we make no warranty, implied or
otherwise, regarding this product's performance or reliability.
Contact Hewlett-Packard Technical Support at (208) 323-2551.
 
Hewlett-Packard has confirmed a problem with inconsistent envelope
printing using their driver.
 
The HP printer drivers included here are manufactured by vendors
independent of Microsoft; we make no warranty, implied or otherwise,
regarding these products' performance or reliability.

Reference(s):

"HP Deskjet 550C User's Guide," pages 2-13 to 2-15.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 3.10 win31
deskjet 550c chopped off w4wprint hpdj



Current Page Option Doesn't Print or Prints Wrong Page
Article ID: Q96865
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

Sometimes Word for Windows prints the wrong page or prints nothing
when you select the Current Page print range option. This may happen
under the following conditions:

 - Your document contains hidden text,

   -and-

 - The View Hidden Text option is turned on,

   -and-

 - The Include Hidden Text With Document print option is turned off,

   -and-

 - You are in normal or page layout view.

CAUSE
=====

When you select the Current Page print range option, Word determines
which page to print based on the page number on the status bar. This
page number includes visible hidden text, even though this text is not
printed. Word then repaginates the document for printing (thereby
accounting for the non-printing hidden text) and prints the page
number of the repaginated text, which may no longer correspond to the
page where the insertion point is located (the current page).

Word does not display an error message when this happens.

WORKAROUND
==========

Before you print using the Current Page print range option, clear the
Hidden Text option in the View Options dialog box. When you clear this
option, the page number on the status bar will correspond to the
current page.

MORE INFORMATION
================



The following sample document demonstrates this behavior:

Page 1: regular text
Page 2: hidden text (visible)
Page 3: regular text
Page 4: regular text

Nothing Prints
--------------

If you position the insertion point on page 4 of and select the
Current Page print range option in the Print dialog box, Word
determines that it should print page 4. However, after repagination,
the document contains no page 4, so a blank page prints.

Wrong Page Prints
-----------------

If you position the insertion point on page 3 and select the Current
Page print range option in the Print dialog box, Word determines that
it should print page 3. After repagination, page 4 becomes page 3, so
the wrong page is printed.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 115,
149

Additional reference words: check 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00 
wm_word w4wprint



Italic Symbol Characters Printed with Extra Space on Right
Article ID: Q96868
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c 
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------

SYMPTOMS
========

In Word for Windows, if you place an italicized TrueType symbol
character, like a bullet, next to another italicized TrueType font,
extra blank space will appear after the Symbol character on screen and
when the document is printed.  This  occurs when you are using a
Postscript printer with the PSCRIPT.DRV printer driver versions 3.5
through 3.55.

Note: This problem does not occur in Windows Write.

STATUS
======

Microsoft has confirmed this to be a problem in Microsoft Word for
Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, and 2.0c. We are
researching this problem, and will post more information here in the
Microsoft Knowledge Base as it becomes available.
This problem has been corrected in Word version 6.0 for Windows.

WORKAROUND
==========

To avoid the extra space after the Italicized Symbol character, remove the
italic character formatting.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 18-19

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wprint



Error Sending Keys to FilePrinterSetup with No Default Printer
Article ID: Q96923
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

You can change printer driver settings such as resolution, paper
orientation, and paper size with a Microsoft WordBasic macro that
includes the SendKeys command.

Word Versions 1.x
-----------------

If no default printer has been set or no printer is active, a macro
that uses the SendKeys command to access a printer driver in Word
version 1.x for Windows will cause an unrecoverable application error
(UAE) (if you are using Microsoft Windows version 3.0) or a general
protection (GP) fault (if you are using Windows version 3.1).

Word Versions 2.0 Through 2.0c
------------------------------

When you are using the SendKeys command in Word versions 2.0 through
2.0c for Windows, and there is no active printer, you will receive the
following error message:

   WordBasic Err = 102, Command Failed

MORE INFORMATION
================

WARNING: ANY USE BY YOU OF THE CODE PROVIDED IN THIS ARTICLE IS AT
YOUR OWN RISK. Microsoft provides this macro code "as is" without
warranty of any kind, either express or implied, including but not
limited to the implied warranties of merchantability and/or fitness
for a particular purpose.

The SendKeys command should only be used to change settings that are
not available in the Page Setup dialog box (from the Format menu,
choose Page Setup) of Word version 2.0 for Windows. For example, the
following macro automates the process of changing the duplex option in
the HP LaserJet IIISi printer driver:

   Sub MAIN
   SendKeys "%o", - 1                 'Options button
   SendKeys "%l{enter}{enter}", - 1   'chooses long side and OK button
   FilePrintSetup .Printer = "HP LaserJet IIISi on LPT1:", .Setup
   End Sub



REFERENCES
==========

"Using WordBasic" by WexTech Systems, Inc. and Microsoft Corporation,
Microsoft Press, 1992.

Additional reference words: w4wmacro w4wprint send keys 1.00 1.10
1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00



Printing Multiple Files from Find File Incorrect with Duplex
Article ID: Q97013
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

When you print multiple files using the Find File command, Word for
Windows sends the files to the printer as a single print job. As a
result, duplex printing does not work correctly.

STATUS
======

Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
2.0a-CD, 2.0b, 2.0c  of Word for Windows. This problem was corrected
in Word version 6.0 for Windows.

MORE INFORMATION
================

If you select two documents (for example, DOC1.DOC and DOC2.DOC) in
the Find File dialog box and choose to print them using the Duplex
Printing option, if DOC1.DOC contains an odd number of pages, the
first page of DOC2.DOC will be printed on the back of the last page of
DOC1.DOC. This occurs even if both documents contain Odd Page section
breaks. Word for Windows should begin printing DOC2.DOC on a new sheet
of paper.

WORKAROUND
==========

To work around this problem, do either of the following:

 - When you use the Duplex Printing option, print one file at a time.

   -or-

 - At the end of each document, insert a printer escape code to force
   the printer to eject the paper after each file is printed. If you
   are using a Hewlett-Packard (HP) LaserJet Series IIIsi printer,
   follow the steps below to insert such a printer escape code in your
   document. For all other printers, refer to your printer manual or
   contact the printer manufacturer.

How to Insert a Printer Escape Code to Force a Form Feed
--------------------------------------------------------

1. Press CTRL+END to position the insertion point at the end of the



   file.

2. From the Format menu, choose Character. In the Font box, select
   Courier (Courier is the default printer font for the HP LaserJet
   Series IIIsi; if you use a different printer, select the default
   font for that printer).

3. Press CTRL+F9 to insert field code brackets. Type the following
   inside the field code brackets:

      PRINT "<ALT+027>^l1O"

   Note: Press ALT+027 on the numeric keypad to insert the printer
   escape character. A vertical line or a box appears on the screen.
   In the above printer code, "l" is lowercase letter L, "1" is the
   numeral one, and "O" is uppercase letter O.

4. Press CTRL+END to position the insertion point at the end of the
   file. Press CTRL+F9 to insert field code brackets. Type the
   following inside the field code brackets:

      PRINT "<ALT+027>&l0O"

   Note: "l" is lowercase letter L, "0" is the numeral zero, and "O"
   is uppercase letter O.
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wprint
sequence back previous



Quality Not As Good with IBM QuietWriter III Printer
Article ID: Q97039
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------

Summary:

When you print to an IBM QuietWriter III from Word for Windows, the
quality of printer-resident fonts may be lower than when you print to
this printer from another application. This reduced quality occurs
because the Windows version 3.1 printer driver for the QuietWriter III
does not support Enhanced printing quality, which produces the
highest-quality output of printer-resident fonts. The Windows version
3.1 printer driver only supports the Draft and Quality output levels.

Workaround
----------

To print from Word with the Enhanced printing quality level, send the
following printer command code at the beginning of your print job

   ESC I 3

where "3" is the value 3, not ASCII 3.

To send this printer command code, use the following procedure to
insert a PRINT field at the beginning of your Word document:

1. Press CTRL+HOME to position the insertion point at the beginning of
   your document.

2. Press CTRL+F9 to insert field brackets.

3. Press ALT+0027 on the numeric keypad. A vertical pipe character (|)
   appears in your document.

4. Press I (uppercase letter I).

5. Press ALT+0003 on the numeric keypad.

More Information:

WordPerfect prints to the QuietWriter III using the Enhanced printing
quality mode, which gives darker, crisper output for printer-resident
fonts.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wprint 
6.00 wm_word  
w4wfont built-in



Equation Editor Symbols Appear Distorted
Article ID: Q97688
-----------------------------------------------------------------
The information in this article applies to:

 - Microsoft Equation Editor, version 1.0
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-----------------------------------------------------------------

SYMPTOMS
========

Equation Editor uses a preferences file (EEPREFS.PRE) to store its
size and position information. If you find that the symbols in the
Equation Editor are distorted both on the screen and when you print
(for example, certain symbols are replaced by strange shapes), the
EEPREFS.PRE file may have become corrupted.

WORKAROUND
==========

To eliminate this problem, follow these steps:

1. From the File menu, choose Exit And Return To <filename> to exit
   Equation Editor.

2. Switch to File Manager or the MS-DOS prompt and rename or delete
   the EEPREFS.PRE file in the Windows directory.

3. Return to Word and from the Insert menu, choose Object.

4. Select Equation, and choose OK to start Equation Editor.

Equation Editor should now appear in the default size and position
(centered on screen), and should no longer show any character
corruption. When Equation Editor creates a new preferences file, it
returns to the default size and position settings.

MORE INFORMATION
================

The EEPREFS.PRE file is stored in the Windows directory and is updated
each time you run Equation Editor. If you delete or rename the file,
Equation Editor rebuilds it the next time it is run. EEPREFS.PRE has a
file size of 261K. Although the date changes each time you run the
application, the size of the file does not change. It is a binary file
and cannot be viewed by a text editor such as Notepad. When this file
becomes corrupt, the Equation Editor does not function correctly,
causing strange output to the screen and the printer.

Additional reference words: 1.00 2.00 2.00a 2.00a-CD 2.00b 2.00c  6.00 
wm_word 
garbage junk eeprefs.pre blob circle equation editor cloud applet 



eq ed math type ole tshoot missing ruler w4wprint 6.00



Shaded Table Prints with White Vertical Gridlines
Article ID: Q97794
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows version 2.0, 2.0a, 2.0a-cd, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
If you print a Word for Windows table that contains shading using a
Hewlett-Packard (HP) LaserJet Series II or III printer driver, the
table may print with white vertical gridlines between the shaded table
cells.
 
These vertical gridlines do not display on the screen.
 
We are researching this problem and will post new information here in
the Microsoft Knowledge Base as it becomes available.

Additional reference words: w4wprint 2.00 2.00a 2.00a-CD 2.00b 2.00c 
6.00 wm_word 



Header Does Not Print Using HPPCL5MS.DRV
Article ID: Q97865
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========

In Word for Windows, some headers that print using version 31.3.89 of
the Hewlett-Packard (HP) Series III printer driver (HPPCL5A.DRV) may
not print at all when you use version 2.0 or 2.1 of the driver
(HPPCL5MS.DRV).
 
This problem has been reproduced in Word for Windows when printing a
header with the following formatting:

   Option                       Setting
   ------------------------------------ 

   Header/Footer From Edge:    .25 inch
   Font Size:                   Greater than 12 points
   Paragraph Line Spacing       Exactly 1 line
 
WORKAROUND
==========

If you change the Line Spacing setting to Auto or increase the From
Edge setting, the header prints.
 
STATUS
======

We are researching this problem and will post new information here in
the Microsoft Knowledge Base as it becomes available.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wprint 
6.00 wm_word 



Using the HP Envelope Tray on a LaserJet Series II Printer
Article ID: Q97946
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------

Summary:

This article contains the procedure for printing from Word for Windows
to a Hewlett-Packard (HP) LaserJet Series II printer using the HP
envelope tray. You should use the HP LaserJet Series II printer driver
(HPPCL.DRV) version 2.0 or later.

Word version 6.0:
-----------------

 1. Remove the letter paper tray from the printer and insert the
    envelope tray.

 2. In Word, choose Print from the File menu.

 3. Choose the Printer Button, select HP LaserJet Series II and then
    choose "Set as Default printer" and choose the close button twice.

 4. From the Tools menu, choose Envelopes and Labels

 5. Type the address text and then choose the Add To Document button.

 6. From the File menu, choose Page Setup.

 7. Select Paper Source.

 8. From the First Page list, select Upper Tray and then choose OK.

 9. To print the envelope, choose Print from the File menu.

10. Select Range of 0.

11. Choose OK.

12. You must hit the continue button on the face plate of the printer.

Word version 2.X
----------------

 1. Remove the letter paper tray from the printer and insert the
    envelope tray.

 2. In Word, choose Printer Setup from the File menu.



 3. From the Printer list, select HP LaserJet Series II and then
    choose OK.

 4. From the Tools menu, choose Create Envelope.

    -or-

    Choose the Envelope button on the toolbar.

 5. Type the address text and then choose the Add To Document button.

    Note: The envelope does not feed from the envelope tray unless you
    add the envelope to your Word document.

 6. From the Format menu, choose Page Setup.

 7. Select Paper Source.

 8. From the First Page list, select Upper Tray and then choose OK.

 9. To print the envelope, choose Print from the File menu.

10. Select Pages. In the From and To boxes, type "0" (zero, without
    the quotation marks).

11. Choose OK.

More Information:

Word version 6.0
----------------

By using the HP laserjet IID driver, the user will not have to hit the 
continue button when printing the envelope.However the IID driver will 
print courier as the font on the envelope, Word 6.0 cannot override this 
from happening.

Word version 2.x
----------------

The HP envelope tray is not the same as the HP envelope feeder, so the
Envelope option does not affectthe envelope tray. In fact, when you use 
the HP LaserJet Series II printer driver, this option is unavailable in 
the Tools Options Print dialog box.

If you print using the HP LaserJet Series IID printer driver, the
envelope prints in the wrong orientation. Neither the "Printer's
Envelope Feeder Has Been Installed" option nor printer heuristics
corrects the orientation. You can print an envelope in the correct
orientation using the LaserJet IID printer driver if you add the
envelope to the document, but the envelope text prints in Courier.

This also happens if you select the "Print TrueType As Graphics"
option in the printer driver Setup Options dialog box. The address
will print in the correct orientation when added to the document, but
in a Courier font. 



Additional reference words: w4wprint Hewlett Packard 2.00
2.00a 2.00a-CD 2.00b 2.00c 6.00 true type



First Page Does Not Print Duplexed on HP IIID or IIIsi Printer
Article ID: Q98276
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------

Summary:

A Hewlett-Packard (HP) LaserJet Series IIID or IIIsi printer will not
print the first page of a Word for Windows document duplexed if:

 - You are using the HPPCL5MS.DRV version 2.0 or 2.1 printer driver.

   -or-

 - You are using the PSCRIPT.DRV postscript printer driver, any version.

   -and-

 - Your document is formatted for mixed-tray printing.

The previous printer driver, version 31.3.89 (HPPCL5A.DRV), which is
supplied with Windows version 3.1, correctly prints duplex on the
first page of a mixed-tray document.

This problem occurs when you select different trays from the First
Page and Other Pages lists in the Format Page Setup dialog box.

Use one of the following workarounds to print correctly in duplex mode
on a the HP LaserJet Series IIID or IIIsi printer:

Workaround 1
------------

Note: Use HPPCL5MS.DRV version 2.0 or 2.1 for this workaround.

1. Insert a Next Page section break at the end of the second page of
   your document.

2. Position the insertion point in the first section.

3. From the Format menu, choose Page Setup and select the Paper Source
   option button.

4. From both the First Page and Other Pages lists, select the same
   tray (the tray from which you want to print pages 1 and 2) and then
   choose OK.

5. Position the insertion point in the second section.

6. From the Format menu, choose Page Setup and select the Paper Source



   option button.

4. From both the First Page and Other Pages lists, select the same
   tray (the tray from which you want to print the remaining pages of
   the document) and then choose OK.

Workaround 2
------------

Note: Use HPPCL5MS.DRV version 2.0 or 2.1 for this workaround.

If the section break described in workaround 1 is not suitable, you
can print the document as two separate print jobs, as described below:

1. Print pages 1 and 2 as the first print job. In the Format Page
   Setup dialog box, select Paper Source, and select the same tray in
   the First Page and Other Pages lists.

2. Print the remaining pages as the second print job. In the Format
   Page Setup dialog box, select Paper Source, and select the same
   tray in the First Page and Other Pages lists.

Workaround 3
------------

Use the previous printer driver, version 31.3.89, to print the
document. This printer driver is supplied with Windows version 3.1.

  Note: In Microsoft Windows for Workgroups version 3.1, the filename
  of this printer driver is changed from HPPCL5A.DRV to HPPCL5MS.DRV.
  If you want to use version 31.3.89 of the driver with Windows for
  Workgroups, manually decompress the HPPCL5A.DR_ file from the
  Windows version 3.1 disk and then rename the file to HPPCL5MS.DRV.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wprint 
6.00 wm_word 
IIID IIISi hpiiid hpiiisi hplj



Paper Jam Occurs Printing Legal Size Paper on HP LaserJet III
Article ID: Q98834
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

Sometimes a paper jam occurs when you print on legal size
(8.5-by-14-inch) paper from Word for Windows on a Hewlett-Packard (HP)
LaserJet Series III printer. The paper begins to feed into the
printer, but then it stops feeding and the paper jam occurs.

This problem occurs when you print using the manual feed tray if the
following message appears on the LCD display on the printer:

   PC LOAD LEGAL

This message is a prompt for you to insert the legal paper tray in the
printer. If you do not insert a legal paper tray and instead manually
feed a sheet of legal paper and then press the Continue button on the
printer to override the prompt, the printer expects letter size
(8.5-by-11-inch) paper. As a result, the paper feed mechanism stops
after it feeds the first 11 inches of the paper and the jam occurs.

Note: By contrast, the paper jam problem does not occur if the
following message appears on the printer, which is a prompt for you to
manually feed a piece of legal size paper:

   PF LOAD LEGAL

Workaround
----------
Use the procedure below to change the Paper Source settings to Manual
Feed for all pages. This workaround overrides the printer driver paper
source settings.

1. From the File menu (Format menu in Winword 2.X), choose Page Setup.

2. Select the Paper Source.

3. Select Manual Feed from the First Page and Others Pages lists and
   choose OK.

Reference(s):

"User's Guide," version 2.0, pages 231-232

Additional reference words: w4wprint w4wlaserjet 2.00 2.00a 2.00a-CD 
6.00 wm_word 
2.00b 2.00c HPPCL5A.DRV HPPCL5MS.DRV





Printing Envelopes on the Panasonic KX-P4450 or 4450i Printers
Article ID: Q100199
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------

SUMMARY
=======

This article contains instructions you can use to print envelopes in
Word for Windows using the Create Envelope command on a Panasonic
KX-P4450 or KX-P4450i printer with the following configurations:

 - KX-P4450 using PCL4X.DRV version 1.10 and optional envelope tray

 - KX-P4450i using PCL4X.DRV version 1.10 and optional envelope tray
   or manual feed slot on standard paper tray

 - KX-P4450i using HP LaserJet Series IID printer driver

 - KX-P4450 using HP LaserJet Series IID printer driver

MORE INFORMATION
================

The Panasonic KX-P4450 and KX-P4450i printers recognize the optional
envelope tray only when it is in the lower paper tray slot. The
KX-P4450i also has a manual feed slot on top of the standard paper
tray that you can use to print envelopes.

The envelope tray accommodates the following range of envelope
dimensions:

   Height:  3 1/4 inches  to  4 7/16 inches
   Length:  8 inches      to  10 inches

For best results, you should use the Panasonic KX-P4450/4450i printer
driver version 1.10 (PCL4X.DRV), available on the Windows Driver
Library (WDL). You should also use version 3.1.2 or later of the
Windows Universal Printer Driver (UNIDRV.DLL). For information on
obtaining the WDL, query on the following words in the Microsoft
Knowledge Base:

   obtain and msdl and information and wdl.txt

No printer heuristics are necessary to print envelopes (or to perform
any other printing procedure) on either printer. You should remove any
"PCL4X" printer heuristic settings from the [Microsoft Word 2.0]
section of your WIN.INI file.

KX-P4450 Using PCL4X.DRV Version 1.10



=====================================

You must always modify the settings on the front panel of the
Panasonic KX-P4450 to correctly print envelopes using the Create
Envelope command in Word. This is necessary because the printer cannot
recognize any command to reset paper source and orientation settings
when the envelope tray is installed.

Printer Setup
-------------

Use the following instructions to set up the KX-P4450 to print
envelopes in Word:

1. Install the PCL4X.DRV driver, using the instructions in the
   "Installing a Printer Driver" section of the PRINTER.TXT file,
   supplied with the printer driver.

2. Start Word.

3. From the File menu, choose Print Setup. Select Panasonic KX-P4450
   from the Printer list and then choose the Setup button.

4. In the printer driver dialog box, choose the Options button. Select
   the Print True Type as Graphics option and then choose OK three
   times to return to the Word document.

   Note: This step is necessary for all documents (not just for
   envelopes) if you want to print using any TrueType fonts. 
   This printer cannot print downloaded TrueType fonts.

Print Envelopes
---------------

1. Install the envelope tray in the lower paper tray slot on the
   printer.

2. Press the Online button on the printer so the Online light is off.

3. Press the Reset button on the front panel of the printer to
   initialize the envelope tray.

4. Press the Online button so the Online light is on. The printer is
   now in Panasonic LP (Landscape) mode.

5. Use the Create Envelope command in Word to create and print your
   envelopes.

Reset the Printer for Normal Document Printing
----------------------------------------------

After you print envelopes to the envelope tray, you must reset the
printer manually using the following procedure. If you do not reset
the printer before you print a normal document (in either portrait or
landscape orientation), the document text begins printing at the
location where an envelope would begin printing.



1. Press the Online button on the printer so the Online light is off.

2. Press the Format button on the printer.

3. Press the UP ARROW button on the printer to select the Portrait
   setting.

4. Press the large Enter button on the printer and then press the Exit
   button.

5. Press the Online button so the Online light is on.

Alternate Method for Resetting Printer for Document Printing
------------------------------------------------------------

1. Remove the envelope tray.

2. Press the Online button on the printer so the Online light is off.

3. Press the Reset button on the front panel of the printer to re-
   initialize the printer without the envelope tray.

4. Press the Online button so the Online light is on.

KX-P4450i Using PCL4X.DRV Version 1.10
======================================

You do not need to manually reset the Panasonic KX-P4450i to print
envelopes using the envelope tray. This printer automatically resets
the origin location, paper source, and orientation settings after you
print an envelope or a document using a different paper tray or
Page Setup settings.

On the KX-P4450i, if you insert an envelope in the manual feed slot on
top of the standard paper tray, the printer feeds from that source to
print an envelope even if the envelope tray is installed.

KX-P4450i Using the HP IID Printer Driver
=========================================

If the PCL4X.DRV version 1.10 printer driver is not available, you can
print envelopes in Word using the HP LaserJet Series IID printer
driver. This printer driver accesses either paper tray and prints
envelopes correctly on the Panasonic KX-P4450i printer.

KX-P4450 Using the HP IID Printer Driver
========================================

When you print envelopes on the KX-P4450 using the HP LaserJet Series
IID printer driver, you must reset the printer manually using the
procedures described above in the "KX-P4450 Using PCL4X.DRV Version
1.10" section.

If you print envelopes (or any other document in landscape
orientation) on the KX-P4450 using the HP LaserJet Series IID printer
driver, you can only use the built-in printer fonts (Courier and
LinePrinter). The KX-P4450 is similar to the HP LaserJet Series II



printer in that it cannot internally rotate fonts for landscape
printing; both printers use landscape fonts that are built into the
printer. When you use the HP IID printer driver, which relies on the
printer to rotate fonts to landscape, the KX-P4450 substitutes its
internal landscape printer fonts.

For information on changing the default envelope fonts, query on the
following words in the Microsoft Knowledge Base:

   changing and envelope and text and formatting and 2.0 and winword

Additional reference words: 6.00 2.00 2.00a 2.00a-CD 2.00b 2.00c
w4wprint wm_word w4wenvelope PCL4X.EXE zip zipped Download Service
hewlett-packard



Using the Optional Envelope Tray on the Panasonic KX-P4420
Article ID: Q102127
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   and 2.0c
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------

SYMPTOMS
========

When you use the Panasonic KX-P4420 printer driver to print envelopes
from Word for Windows, you cannot access the optional envelope tray.
This behavior occurs because the Panasonic KX-P4420 printer emulates
the Hewlett-Packard (HP) LaserJet Series II printer, which does not
support an optional envelope tray. Windows uses the HP LaserJet Series
II printer driver (HPPCL.DRV) to support the Panasonic 4420 printer.

WORKAROUND
==========

To print envelopes to the optional envelope tray on the Panasonic
KX-P4420, use the HP LaserJet Series IID printer driver instead. The
Series IID supports an envelope tray. You do not need to set a printer
heuristic in the [Microsoft Word 2.0] section of your WIN.INI file.

MORE INFORMATION
================

Use the following instructions to print envelopes from the optional
envelope tray on the Panasonic KX-P4420 printer:

1. Install version 2.1 or later of the HP LaserJet Series IID printer
   driver (HPPCL.DRV). If you have a version of the driver earlier than
   2.1, you can obtain an updated printer driver from the Windows
   Driver Library (WDL). For information about obtaining the WDL, query
   on the following words in the Microsoft Knowledge Base:

      wdl.txt and obtain and msdl and win31

2. In the Print Options dialog box, select the Printer's Envelope
   Feeder Has Been Installed option and choose OK (to open the Print 
   Options dialog box, choose Options from the Tools menu, then select 
   the Print icon in the Category list).

3. Insert the envelope tray into the normal paper tray slot on the
   printer. The "Envelope #10" message appears on the printer
   display.

4. Press the Enter button on the printer to switch the printer online.

5. In Word, choose the Envelope button on the toolbar, and then choose
   the Print Envelope button. The printer pulls an envelope from the



   envelope tray and prints it correctly.

NOTE: If you install the HP LaserJet Series IID printer driver and
print using the normal paper tray, all paper source settings except
Manual Feed pull from the normal paper tray. Manual feed print jobs
pull from the manual feed tray.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 118-121

Additional reference words: w4wprint 2.00 2.00a 2.00a-CD 2.00b 2.00c
w4wprint 4420 pkx p4420 kxp4420 laserjet



SetPrinterHeuristic Macro Sets "winspool=x" for All Printers
Article ID: Q104036
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows NT operating system version 3.1
 - Microsoft Windows NT Advanced Server version 3.1
-------------------------------------------------------------------

SYMPTOMS
========

When Word for Windows is running with Windows NT, if you use the
SetPrinterHeuristic macro (supplied with Word in NEWMACRO.DOC) to set
a printer heuristic, the macro defines the following heuristic, no
matter which printer driver is active

   winspool=x

where "x" represents the heuristic value.

As a result, every printer uses the heuristic setting, and you cannot
define unique heuristics for individual printers. In other words, a
printer heuristic is an application-wide setting instead of a
printer-specific setting when you run Word with Windows NT.

CAUSE
=====

When a Windows-based application (such as Word) queries the operating
system for the name of the currently active printer driver, Windows NT
always replies with "winspool" instead of the actual name of the
printer driver. When you run the SetPrinterHeuristic macro, Word uses
the printer driver name supplied by the operating system to create
printer heuristic settings. Therefore, all printers appear to have the
same driver name (winspool) to Word with Windows NT.

STATUS
======
 
Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.
 
To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================



The Word for Windows printer heuristic design is based on the Windows
version 3.1 convention that refers to a printer using its unique
printer driver name. As a result, you can set a heuristic for each
printer when you run with Windows version 3.1. This functionality is
not available when you run Word with Windows NT.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wprint
w4wmacro winnt



Thick Dotted Line Drawing Displays Vertically Elongated
Article ID: Q105029
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, version 6.0
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========
 
When you use the Word for Windows drawing tools to draw a thick dotted
line (4 points or larger), the line displays vertically elongated, or
stretched, if you are using the Generic/Text Only printer driver.
 
CAUSE
=====
 
When you use the Generic/Text Only printer driver, the printer
metafile is the only representation available to display the drawing
on the screen. The Generic/Text Only printer driver uses a resolution
of 6 dots per inch (dpi) vertically and 120 dpi horizontally, so the
dotted line appears distorted on the screen.
 
Graphic images do not print on most printers that use the Generic/Text
Only printer driver. On the printers that do print graphics, however,
the printed result is usually correct. On some dot-matrix printers
with non-square pixels, the pixels in the drawing may print as ovals.
 
STATUS
======
 
This problem does not affect PostScript or laser printers that use
the Hewlett-Packard (HP) Printer Control Language (HPPCL).
 
We are researching this problem and will post new information here in
the Microsoft Knowledge Base as it becomes available.
 
Additional reference words: 6.00 layer stretch stretched skew skewed
dxpinch dypinch too long ovoid w4wprint



Document Does Not Print After Annotations Deleted
Article ID: Q105442
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========
 
A document that once had annotations that were subsequently deleted
will not print if Annotations is selected in Print Options. (If no
annotations have been inserted into a document, the document will
print with Annotations selected.)
 
STATUS
======

Microsoft has confirmed this to be a problem in Word 2.x for Windows.
This problem was corrected in Word 6.0 for Windows.

WORKAROUND
==========
 
Do the following before you print your document:

1. From the Tools menu, choose Options. Choose the Print category.

2. Under Include With Document, clear the Annotations option.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c W4WPRINT
TSHOOT printing



GP Fault Printing Document with Many Fonts
Article ID: Q105565
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========
 
If you print a Word for Windows document that contains a large number
of downloadable fonts, a general protection (GP) fault error may
occur.
 
CAUSE
=====
 
You are using the Windows Universal Printer Driver (UNIDRV.DLL)
version 3.1.2 or earlier and your Word document contains more than 64
downloadable fonts, such as TrueType fonts. The problem also occurs
when you print using the Windows PostScript printer driver
(PSCRIPT.DRV) version 3.56 or earlier and your document contains more
than 256 downloadable fonts.
 
STATUS
======
 
Microsoft has confirmed this to be a problem in UNIDRV.DLL version
3.1.2 and earlier and in PSCRIPT.DRV version 3.56 and earlier. This
problem was corrected in version 3.1.3 of UNIDRV.DLL and in version
3.57 of PSCRIPT.DRV.
 
The corrected printer drivers are supplied with Word 6.0. Setup
automatically installs them if you have a previous version of either
driver. As a result, this problem will only occur in Word 6.0 if you
replace the updated printer drivers with the older, problem drivers.
 
If you do not have Word 6.0, you can obtain these new printer drivers
from the Windows Driver Library (WDL). For information about obtaining
the WDL, query on the following words in the Microsoft Knowledge Base:
 
   wdl.txt and obtain and msdl and win31
 
WORKAROUNDS
===========
 
 - To avoid the GP fault errors using the problem printer drivers,
   decrease the number of fonts in your document.
 
   -or-
 
 - If your document contains mostly TrueType fonts, turn on the "Print



   TrueType as Graphics" option. This reduces the number of downloadable
   fonts. The drawback to this workaround is that it increases printing
   time.
 
MORE INFORMATION
================
 
In both UNIDRV.DLL and PSCRIPT.DRV, the GP fault error occurs when the
printer driver copies conflicting font cache information during the
ResetDC() call. Specifically, the driver fails to copy the value of
the sMaxDLSlots variable, so it incorrectly resets the sMaxDLSlots
variable to the default value (32 for UNIDRV.DLL and 128 for
PSCRIPT.DRV). This default value does not cause a problem until your
document contains more than 64 fonts (256 fonts for PSCRIPT.DRV).
 
Note: The sMaxDLSlots variable indicates the total number of entries
(used or empty) in the font downloading list.
 
Additional reference words: 6.00 w4wprint 2.00 2.00a 2.00a-CD 2.00b
2.00c win31 globalalloc snumdownfonts lpdownfontlist hdownfontlist
gpf hang hung crash crashed locks locked frozen freezes crashing quit
quits stopped wm_word



Cell Border Extends Farther Left/Right Than Shading in Table
Article ID: Q106074
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========
 
If a table contains a border and shading, the border may extend
farther than the length of the cell.
 
STATUS
======
 
We are researching this problem and will post new information here in
the Microsoft Knowledge Base as it becomes available.
 
WORKAROUND
===========
 
Insert a column at the beginning of the shading that is .01-inch wide
and has 0 inches of space between columns. Format this column for
shading but not with a border. This will cause the shading and the
border to be aligned.
 
Additional reference words: 6.00 column shade tables past w4wprint print



Printing to a File Using the WordBasic FilePrint Statement
Article ID: Q106250
----------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
    2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------
 
WARNING: ANY USE BY YOU OF THE CODE PROVIDED IN THIS ARTICLE IS AT
YOUR OWN RISK. Microsoft provides this macro code "as is" without
warranty of any kind, either express or implied, including but not
limited to the implied warranties of merchantability and/or fitness
for a particular purpose.

Word 6.0 for Windows
====================
 
The FilePrint statement in Word 6.0 for Windows includes parameters to
allow you to print a document to a file. The FilePrint parameters for
printing to a file are listed below.
 
   .PrintToFile    If 1, sends printer instructions to a file.
 
   .PrToFileName   If PrintToFile = 1, this parameter specifies the
                   path and filename of the file to print to.
  
   .AppendPrFile   If PrintToFile = 1, this parameter specifies
                   whether  to overwrite or append to the file if it
                   already exists:
 
                      0 (zero) Overwrite
                      1        Append
 
The following command prints the contents of the current document to
a file.
 
   FilePrint .PrToFileName = "C:\Temp\Filename.ext", .Type = 0, \
   .PrintToFile = 1
 
If you later want to print the contents of the print file, use the
following Copy syntax at the MS-DOS prompt:
 
   copy /b <filename> LPT1:
 
For more information on the MS-DOS COPY command, refer to pages
389-393 of the "Microsoft MS-DOS User's Guide and Reference" for
MS-DOS version 5.0.
 
Word 2.x for Windows
====================
 
The FilePrint statement in Word 2.x for Windows does not include a
parameter to indicate the print filename (.PrToFileName). To print the



contents of the current document to a specific file without being
prompted with the filename dialog box, use the SendKeys statement
before the FilePrint command. For example:
 
Sub MAIN
SendKeys "C:\Temp\Filename.ext"        'the filename to print to
SendKeys "{Enter 2}"                   'Send 2 Returns
FilePrint .Type = 0, .PrintToFile = 1
End Sub
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00
w4wprint w6macroexample w4wmacro wm_word



Printer Error "MP LOAD COM10" Printing Envelope in Windows NT
Article ID: Q106471
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows NT operating system version 3.1
-------------------------------------------------------------------

SYMPTOMS
========

When printing an envelope from Word 2.x or 6.0 for Windows under
Windows NT to a Hewlett-Packard (HP) LaserJet IIP or LaserJet IIIP,
the printer will display the following message:

   MP LOAD COM10

Even when you have an envelope loaded into the MP (manual feed) tray,
pressing the Online button will not resume printing. You must press
and hold down the ALT key while pressing the Form Feed/Continue key.

CAUSE
=====

By default, Windows NT will not select the manual feed tray for
envelopes when printing on envelope size paper from any Windows
application.

RESOLUTION
==========

Use the following steps to associate envelope size paper with the
manual feed tray so that Windows NT will know to select the manual
feed tray when envelopes are printed:

1. Start Windows NT Print Manager.

2. Bring the desired printer window to the front.

3. From the File menu, choose Properties.

4. Under the Source option, choose Manual Paper Feed.

5. Under the Name option, choose Envelope #10.

6. Choose OK.

7. Choose the OK button in the Properties window.

MORE INFORMATION
================

Through Windows NT Print Manager, an administrator can assign



particular paper sizes to particular paper bins on the printer. For
instance, the administrator can specify that all letter-size pages
printed from an application come from the upper tray, no matter which
tray the document is formatted for.

More information on forms and how to set them is available in the
"Microsoft Windows NT System Guide," pages 201 through 202.

REFERENCES
==========

"Microsoft Windows NT System Guide," pages 187-189, 201-202

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00
w4wprint wm_word w_nt



F7 Does Not Spell Check the Entire Word for Windows Document
Article ID: Q65229
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Pressing the F7 function key in Word for Windows versions 1.0, 1.1,
and 1.1a does not perform exactly the same command as choosing
Spelling from the Utilities menu.

In Word for Windows version 2.0, pressing the F7 key also differs
from choosing Spelling from the Tools menu.

In Word for Windows version 2.0, pressing F7 checks only the current
selection or the word closest to the insertion point, as in versions
1.0, 1.1, and 1.1a. However, after a single word has been checked, the
message "XXXX" is spelled correctly. Do you want to continue checking
the remainder of document?" appears. When a selection of text has been
checked by pressing F7, the message "Word finished checking the
selection. Do you want to continue checking the remainder of
document?" appears.

Pressing the F7 key always gives you the option to continue checking
the rest of the document.

If you choose Spelling from the Utilities menu in Word for Windows
versions 1.x, Word performs a spelling check on the selected text
only. If no text is selected, the entire document is spell checked.

If you choose Spelling from the Tools menu in Word for Windows version
2.0, only the selected text is spell checked. However, the option to
continue checking the rest of the document appears after the selected
text is checked. If no text is selected, choosing Tools Spelling runs
the spelling check for the entire document.

Word for Windows 6.0
---------------------

If the insertion point is on or near a word and you press F7 in Word
for Windows 6.0 to spell check, the spell checker will flag the next
word that it does not find in the dictionary. If you have a word
selected that is spelled correctly, Word will display the message,
"Word finished checking the selection. Do you want to continue
checking the remainder of the document." If the word is misspelled
and you press F7 while the misspelled word is selected Word will flag
the word. After the user has performed a change or ignore on the word
the message, "Word finished checking the selection. Do you want to
continue checking the remainder of the document?".



REFERENCES
==========

"Microsoft Word for Windows User's Reference," page 334

Additional reference words: w4wproof 1.0 1.1 1.1a 1.00 1.10 1.10a 2.0
wm_word 2.00



Replaced Words Lose Revision Marks Using Spelling Checker
Article ID: Q69712
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

When misspelled words that have been marked for revision are replaced
by the Spelling utility in Word for Windows, the correctly spelled
word that is inserted will not be marked if Mark Revisions is no
longer turned on.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. Open a new file in Word for Windows.

2. Type a few lines of text and choose Revision Marks from the
   Utilities menu.

3. Choose Mark Revisions and OK.

4. Type a few more lines of text in the document and misspell a word.
   Notice that new text is marked.

5. From the Utilities menu, choose Revision Marks menu and turn off Mark
   Revisions. Choose OK.

6. From the Utilities menu, choose Spelling and choose the Start
   button. When the misspelled word appears, choose Suggest and OK.

Notice the replaced word is no longer marked. Replaced words loose
their revision marks.



REFERENCES
==========

"Microsoft Word for Windows User's Reference," pages 294, 295

Additional reference words:  w4wproof 1.00 1.10 1.10a speller check 
2.0 2.00 



Highlight Removed with CTRL+ESC When Checking Spelling
Article ID: Q69948
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

When checking the spelling of a single word in Word for Windows,
switching to the Task List in Windows 3.00 causes the highlight to
disappear even though the word's spelling may still be checked.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. Enter a misspelled word in a Word for Windows document.

2. Highlight the word.

3. If you are using Word for Windows 1.00, 1.10 or 1.10a, choose
Spelling from the Utilities menu and select Start.

If you are using Word for Windows 2.0, choose Spelling from the
Tools menu.

4. Press CTRL+ESC to bring up the Task List in Window 3.00.

5. Return to Word by clicking the Word for Windows icon with the mouse
   or choosing it from the Task List.

Notice the word is no longer highlighted. However, this does not
affect Spelling functionality. If you continue with the Spelling
dialog box, any selected button (for example, Ignore, Cancel) will
apply to the misspelled word.



REFERENCES
==========

"Microsoft Word for Windows User's Reference," pages 331-334.

Additional reference words:  w4wproof 1.0 1.1 1.1a 1.00 1.10 1.10a 2.0
2.00



Word: Hidden Paragraph Mark Not Ignored with F7 Spelling Check
Article ID: Q77148
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

If two words are separated by a hidden paragraph mark and hidden text
is not displaying in Microsoft Word for Windows, the paragraph mark
will not be ignored if the insertion point is in the first or second
word and F7 is pressed to check the spelling of the combined word.
Only the first word before the hidden paragraph mark will be checked.
If the combined word is an incorrect spelling, the word will not be
flagged as incorrect if the F7 key is used.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

The F7 key can be used to check the spelling of a single word. If two
words are separated by hidden text such as punctuation, line breaks,
or fields, the hidden text will be ignored if F7 is used to check the
spelling of the combined word unless the hidden text is a paragraph
mark.

The paragraph mark will be ignored in Word for Windows versions 1.0,
1.1, and 1.1a if you use the Spelling command on the Utilities menu
and in Word for Windows version 2.0 if you use the Spelling command on
the Tools menu to check the spelling of the combined word.

Steps to Reproduce Problem in Word for Windows Versions 1.x
-----------------------------------------------------------

1. Type "hidden" and press ENTER.
2. Type "text" on the new line.
3. Select the paragraph mark after "hidden" and format it as hidden
   (press CTRL+H).



4. From the View menu, choose Preferences and clear the Hidden Text and
   Show All check boxes.
5. Position the insertion point in front of the "x" in "text".
6. Press F7.

Steps to Reproduce Problem in Word for Windows version 2.0
------------------------------------------------------

1. Type "hidden" and press ENTER.
2. Type "text" on the new line.
3. Select the paragraph mark after "hidden" and format it as hidden
   (press CTRL+H).
4. From the Tools menu, choose Options and select the View icon.
5. Under Nonprinting Characters, clear the Hidden Text and All check
   boxes.
6. Position the insertion point in front of the "x" in "text".
7. Press F7.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.0, pages
331-334.

Additional reference words: w4wproof 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b



Grammar Check Feature Also Flags Spelling Errors in WinWord
Article ID: Q77951
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

By default, the grammar checking feature in Microsoft Word for Windows
checks for spelling errors as well as grammatical errors.

MORE INFORMATION
================

Checking for spelling errors during the grammatical proofing is an
option you can disable. To do this, follow the steps below:

Word for Windows 6.0
--------------------

1. From the Tools menu, choose Options.

2. Choose the Grammar Tab.

3. Clear the "Check Spelling" check box option.

4. Choose the OK button to exit the Options
   dialog box.

Word for Windows 2.x
----------------------------

1. From the Tools menu, choose Options.

2. From the Category box, select Grammar.

3. Choose the Customize Settings button.

4. In the Grammar box, clear the Spelling Errors check box.

5. Choose the OK button.

6. Choose the OK button again to exit the Options dialog box.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," pages 289, 734-735

Additional reference words: flag deselect de-select un-check w4wproof



wm_word 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00



WinWord 1.x Doesn't Flag Words Containing Numbers as Incorrect
Article ID: Q78227
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Microsoft Word for Windows version 1.x does not indicate that a word
is misspelled if it contains a number. Word for Windows version 2.0 and
6.0 do not flag combinations of numbers that contain only one letter,
such as 3a or 40K; however, it considers words that include at least
one number and more than one letter to be misspelled.

More Information:
  
You can illustrate this difference with the following procedures:

Word for Windows version 2.0 and 6.0
------------------------------------
 
1. Type the misspelled word "eve4" (without the quotation marks).
 
2. From the Tools menu, choose Spelling or choose the spell checker
    button from the Toolbar or press F7.
 
Word for Windows flags the word as misspelled.

Word for Windows version 1.x
----------------------------
 
1. Type the misspelled word "eve4" (without the quotation marks).
 
2. From the Utilities menu, choose Spelling.
 
Word for Windows does not flag the word as misspelled.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 331-334
"Microsoft Word for Windows User's Guide," pages 277-281

Additional reference words: w4wproof 1.0 1.1 1.1a 1.00 1.10 1.10a 2.00
wm_word 6.00



Words in WinWord Exclude Dictionary Not Flagged as Incorrect
Article ID: Q78340
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you can create an Exclude dictionary to
contain words that you want the spelling checker to flag as incorrect even
though the words are not normally considered misspelled.

MORE INFORMATION
================

Words contained in an Exclude dictionary should be flagged as
misspelled in Word for Windows documents when you run the spelling
checker. The following are reasons why a word in an Exclude dictionary
may not be flagged as incorrect:

 - The Exclude dictionary is in a different directory than the main
   dictionary.

 - The Exclude dictionary does not have an .EXC extension and the same
   filename as the main dictionary. For example, if the main dictionary
   is SP_AM.LEX, the Exclude dictionary must be SP_AM.EXC.

Versions 2.00 and 2.00a Only
-----------------------------

 - The word is contained in both an Exclude and a custom dictionary.
   After Word for Windows checks the Exclude dictionary, it checks the
   custom dictionary. If Word for Windows finds the word in both
   dictionaries, it considers the word to be spelled correctly.

   Note: This information does not pertain to Word for Windows
   versions 2.00a-cd, 2.00b, and 2.00c. These versions will exclude a
   word that is contained in the Exclude dictionary even if the word
   is found in the custom dictionary.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," page 283

Additional reference words:  w4wproof 2.00 wrong 6.00 wm_word 



WinWord Thesaurus Only Checks First Word in Delimited String
Article ID: Q79179
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

The thesaurus in Microsoft Word for Windows checks the first word of any
string of words separated by delimiters. A delimiter is defined as any
character used to bridge one or more words together so that no spaces exist
between the individual words. Common delimiters include the following
characters:

   / \ * , : ; . & # @ () [] {}

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. In a new document, type the following lines of text:

      Light/Dark/Night/Day

      Light,Dark,Night,Day

      Light Dark Night Day

2. Position the insertion point on the first occurrence of the word
   "Day."

3. From the Tools menu, select Thesaurus. The Thesaurus checks the
   word "Light" instead of the word "Day."

4. Repeat steps 2 and 3 for each line of text.



5. The Thesaurus command only checks the correct word for the line
   with spaces separating the words.

To work around this problem, separate the words with a space, run
Thesaurus, and then remove the space.

Additional reference words:  w4wproof 2.00 lists utility 6.00 wm_word 



WinWord: No Proofing Highlighted if Two Languages Are Selected
Article ID: Q79482
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you select a section of text that
contains formatting for two or more languages and choose Language from
the Format menu, the Mark Selected Text As box highlights No Proofing
as the default option.

More Information:
 
The language names should be unavailable to indicate that more than
one language is contained in the selected text. If you unintentionally
select the No Proofing option, the selected text will not be checked
if you subsequently run the Spelling or Grammar commands.

Steps to Reproduce Problem
--------------------------

1. Open a new document, and type two words.
     
2. Select the first word. From the Format menu, choose Language,
   select a language, and choose the OK button. Repeat this process with
   the second word, but format the second word with a different language. 

   In Word for Windows 6.0 choose Language from the Tools menu.

3. Select both words.
  
4. From the Format menu (Tools menu in Word 6.0), choose Language.
 
The No Proofing option is highlighted in the Mark Selected Text As
box.

NOTE:  In Word for Windows 6.0, none of the language options are 
selected by default to represent the fact that there is more than one 
language format selected in the highlighted text.

Additional reference words: w4wproof 2.00 grayed greyed dimmed wm_word 



Number of Words in WinWord 2.0 Spelling Checker and Thesaurus
Article ID: Q80136
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows version 2.0, the United States English
main dictionary, which is used by the spelling checker, contains
104,000 words. The United States English thesaurus contains 24,000 key
words and 200,000 synonyms.

In Word version 6.0, the Main dictionary contains 106,000 words. The
Thesaurus has 44,000 key words and 458,000 synonyms.

Additional reference words: 6.00 w4wproof 2.00 2.00a 2.00a-CD 2.00b 2.00c



WinWord: 546-Character Limit in the Grammar Command
Article ID: Q80426
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, the Grammar command checks the grammatical
structure of the first 110 words (based on 5 characters per word) or 546
characters per sentence. Any grammatical errors occurring after the 546
character limit are ignored.
 
Steps to Reproduce Problem
--------------------------
 
1. From the File menu, choose New, and choose the OK button.
  
2. Type a sentence with more than 546 characters, and include a
   grammatical error.

3. From the Tools menu, choose Grammar.
 
The Grammar command only selects the first 546 characters. Below the
suggestions box in the Grammar dialog box, the following comment
appears:
 
   Sentence was too long to process for grammatical structure.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 285-6

Additional reference words: 2.00 w4wproof wm_word 



Spell Checker Does not Recognize French Contraction
Article ID: Q81100
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows version 2.0, the spell checker will not
recognize the French contraction "si".

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Steps to Reproduce Problem
--------------------------

1. Type "s'il vous s'elle" (without the quotation marks).

2. Select this text.

3. From the Format menu, choose Language, and select French.

4. From the Tools menu, choose Spelling.

Results: The spell checker does not recognize "s'il" or "s'elle".

The spell checker should recognize these two contractions as it does
others. The following reflexive verbs followed by words beginning with
vowels are recognized as valid contractions by the spell checker: se,
sa, ma, me, ta, te, ce, le, la. The prepositions ne and de are also
recognized.

Additional reference words:  w4wproof 2.00



WinWord: Spelling Checker Does Not Ignore Words in Uppercase
Article ID: Q81747
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Microsoft Word for Windows' spelling checker does not ignore repeated
words entered as all uppercase letters, even if the Ignore Words In
UPPERCASE option is selected. The spelling checker flags all repeated
words, regardless of case.

This behavior is by design. Words entered in all uppercase letters are
not checked for spelling if the Ignore Words In UPPERCASE option is
selected, but all words are checked to determine if they are repeated
words.

Note: Words entered in lowercase letters, or a combination of
uppercase and lowercase letters, and formatted with All Caps or Small
Caps character formatting are not considered to be in uppercase.
Uppercase words are those words that are entered as all uppercase
letters or changed to all uppercase letters using the Change Case key
combination (SHIFT+F3).

REFERENCES
==========

"Microsoft Word for Windows User's Guide", version 2.0, pages 151,
280-281, 733

Additional reference words: w4wproof 2.00 2.00a 2.00a-CD 2.00b 2.00c
6.00 wm_word capitals



Corruption with Macro Run on ToolsGrammar and ToolsSpelling
Article ID: Q82251
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

If you run a macro that calls a modeless dialog box such as
ToolsSpelling or ToolsGrammar in Microsoft Word for Windows 
unexpected results occur if you use ToolsMacro to run the command
rather than calling the command directly.

MORE INFORMATION
================

A modeless dialog box is one that you can activate and switch away
from by clicking another active window. For example, you can click
your document to switch away from the dialog box. The Spelling and
Grammar commands have this type of dialog box.

A modal dialog box is a one that requires you to choose the OK or
Cancel button to close the dialog box before you can switch to another
action, window, or dialog box.

WORKAROUND
==========

To avoid any unexpected results when calling a modeless dialog box,
use the command directly. In a macro, use the ToolsSpelling and
ToolsGrammar commands rather than ToolsMacro "ToolsSpelling" or
ToolsMacro "ToolsGrammar."

Steps to Reproduce Problem
--------------------------

1. In a new document, type "This is an sentence." (without the
   quotation marks).

2. Create and run the following macro:

   Sub MAIN
   SendKeys "%c"
   ToolsMacro .Name = "ToolsGrammar", .Run, .Show = 0
   Insert "yo"
   End Sub

The document becomes corrupt. The text reads "Thisis," but the cursor
cannot go past the second letter. You cannot select the entire
document.



Note: This behavior occur on the first try.

It is expected that the word "an" should be replaced with "a," and the
selection should not be altered. The "yo" should not be inserted until
after the dialog box has been exited. The problem is that "yo" is
inserted underneath the dialog box before the change is made, but the
dialog box does not lose the focus. This problem occurs with any
modeless dialog box.

Any macro that uses ToolsMacro .Run on a modeless dialog box
(ToolsSpelling, ToolsGrammar) will experiencee similar problems.

Additional reference words:  w4wproof w4wmacro 2.00 2.00a 2.00a-CD
wm_word 2.00b



Using Other Word Dictionaries with Word for Windows 2.0
Article ID: Q83070
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Word for Windows 6.0
-----------------------

Microsoft Word version 6.0 for Windows cannot use the Word version 1.x
for Windows dictionary or the Microsoft Word for MS-DOS dictionary. If
you try to use one of these dictionaries in Word version 6.0 for
Windows, one of the following error messages will be displayed:

    C:\WINWORD\LEX-AM.DLL is not a valid Spelling dll.

  -or-

   Word Cannot Start The Speller

Word for Windows 2.x
----------------------

Microsoft Word version 2.0 for Windows cannot use the Word version 1.x
for Windows dictionary or the Microsoft Word for MS-DOS dictionary. If
you try to use one of these dictionaries in Word version 2.0 for
Windows, one of the following error messages will be displayed:

   Word cannot open the spelling file
   C:\WINWORD\SP_AM.LEX for English (US)

  -or-

   Word Cannot Start The Speller

More Information:

Word version 1.x for Windows can use the Word for MS-DOS English,
British, legal, and medical dictionaries. Word version 1.x for Windows
cannot use the Word version 2.0  or 6.0 for Windows dictionary. If you
try to use the version 2.0 or 6.0 dictionary in version 1.x, the error
message "Out of local memory" will be displayed.

English dictionary files for Word version 5.5 for MS-DOS and Word
version 1.1a for Windows are titled as follows:

   Word 5.5 for MS-DOS: SPELL-AM.LEX
   Word 1.1a for Windows: LEX-AM.DLL



Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 275-283

Additional reference words:  w4wproof spell proof proofing 
tools tool bar toolbar 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.0



Spelling Checker Doesn't Suggest Replacing "i" with "I"
Article ID: Q84271
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, the spelling checker and the grammar
checker do not suggest changing a lowercase "i" to an uppercase "I"
when "i" is used as a word.

More Information:

Workaround
----------

You can use the Edit Replace command to find all occurrences of " i "
and replace those words with " I ." Be sure to type a space (press
SPACEBAR) before and after the lowercase "i" and the uppercase "I" to
avoid replacing lowercase "i" characters that are found within words.

Steps to Reproduce Problem
--------------------------

1. Type the following sentence in a Word for Windows document:

      How may i help you?

2. From the Tools menu, choose Spelling. (In Word for Windows version
   1.x, choose Spelling from the Utilities menu).

The spelling checker indicates that the spell check is complete
without suggesting that the lowercase "i" be replaced with an
uppercase "I."

Note: The Word for Windows version 2.0 Grammar command also does not
suggest this replacement even if the Spelling Errors option is
selected.

Microsoft has confirmed this to be a problem in Word for Windows
versions. Word for Windows version 6.0 is now able to correct this problem
through the use of the Auto Correct feature.  For more information on
how to use the Auto Correct feature please see your Word for Windows
User's Guide documentation.  This feature will allow users to create an
Auto Correct feature that will automatically change the "i" with an "I"
by adding this as one of the Auto Correct features.

Additional reference words:  w4wproof 1.00 1.10 1.10a 2.00 2.00a  wm_word 
speller 2.0b 2.0a-CD 2.00b 2.00a-CD 6.0



WinWord: Problems Checking Words with Mixed Capitalization
Article ID: Q84537
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c 6.0
 - Microsoft Windows operating system version 3.0 and 3.1

--------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, the Ignore All, Change, and Change All
buttons in the Spelling dialog box work incorrectly for words
containing mixed capitalization.

MORE INFORMATION
================

The following example illustrates the problems associated with using
the Spelling command on words with mixed capitalization:

1. In a Word for Windows document, type the following:

   fLap 1
   fLap 2
   fLap 3
   fLap 4
   flap

2. From the Tools menu, choose Spelling.

When you run the spelling checker, the first instance of "fLap" is
flagged as a capitalization error. The spelling checker suggests
"flap" in the Change To box. The chart below lists the results of
choosing the Ignore, Ignore All, Change, and Change All buttons.

Button               Result
------               ------

Ignore               Correctly finds the next occurrence of "fLap"
                     and identifies it as a capitalization error.

Ignore All           Incorrectly flags "flap" as a capitalization
                     error and suggests "fLap" in the Change To box.

Change               Correctly changes the first occurrence of "fLap"
                     and incorrectly identifies the next occurrence of
                     "fLap" as "Not in Dictionary" (it should be flagged
                     as a capitalization error).

Change All           Correctly changes the first occurrence of "fLap"
                     and incorrectly skips over all other occurrences



                     of "fLap" without changing them. (This problem does
                     not occur in Word for Windows 6.0)

STATUS
======

Microsoft has confirmed this to be a problem in Microsoft Word for
Windows. We are researching this problem and will post new information
here as it becomes available.

Workaround
----------

To work around this problem, use the Replace command to change all
occurrences of a word containing mixed capitalization. Be sure the Match
Case and Match Whole Word Only check boxes are selected.  

REFERENCES
==========

"Microsoft Word for Windows Users Guide," version 2.0, pages 255,
260-261, 275-283

Additional reference words: w4wproof 6.00 2.00 2.00a speller checking
wm_word skips find missed capitalize capitalized uppercase upper case
match



Spelling Checker Does Not Ignore Repeated Words with Numbers
Article ID: Q85200
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

Even if the Words With Numbers check box is selected under Ignore in
the Options dialog box, the spelling checker does not ignore repeated
words that contain numbers. In Microsoft Word versions 2.0 and 2.0a
for Windows, the spelling checker flags all repeated words, regardless
of their content. This behavior is by design.

MORE INFORMATION
================

If the Words With Numbers check box is selected, Word for Windows does
not flag the first word in a pair of words containing numbers. Word
for Windows DOES flag the second word in the pair as a repeated word.
The Words With Numbers option does not affect how Word flags repeated
words.

For example, if a document contains "HP3D HP3D" and you select the
Words With Numbers check box, the spelling checker ignores the first
occurrence of "HP3D"; however, it flags the second occurrence of
"HP3D" because it is a repeated word.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, 280-281, 733

Additional reference words:  w4wproof proofing tools  wm_word 
speller spell checking tool bar toolbar 2.00 2.00a 2.00a-CD 2.00b 
2.00c



WinWord: Spelling Checker Updates Fields in Headers & Footers
Article ID: Q85456
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

If you perform a spell check in a Microsoft Word for Windows document that
contains headers and/or footers, any fields in the headers and/or footers
will be updated.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. From the View menu, choose Header/Footer. Select Header, and choose
   the OK button to open the header pane.

2. Press CTRL+F9 to insert the braces (field characters), and type the
   following within the braces:

      fillin "What is your name?"

3. If the header/footer bar is being displayed, choose the Close
   button to close the header pane.

4. In the body of the document, type the following:

      This is a test.

5. From the Tools menu, choose Spelling.

The FILLIN field in the header is updated, which causes a dialog box
asking for your name to appear.



REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 277,
573, 752

Additional reference words:  w4wproof 2.00 2.00a w4wfield speller 
spelling check checker 2.0b 2.0a-CD 2.00b 2.00a-CD 



Words Beginning or Ending with "#" in Custom Dictionary
Article ID: Q86033
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you add a word that begins or ends with the number sign character
(#) to the custom dictionary in version 2.0 or 2.0a of Microsoft Word
for Windows, the word will not be recognized when you choose Spelling
from the Tools menu; Word will still flag the word as misspelled.

More Information:

When you run the spelling checker in a document and add a word to the
custom dictionary, Word should no longer flag that word as incorrect.
If you add a word that begins with a number sign to the custom
dictionary, the word will be successfully added to the dictionary.
However, when you run the spelling checker on this word, Word will
continue to flag the word as misspelled, as if the word is not in the
custom dictionary.

Also, if you add a word that begins or ends with a number sign to the
custom dictionary, Word will ignore subsequent occurrences of the
word. If you run the spelling checker a second time, every occurrence
of the word will be flagged as incorrect unless you choose the Ignore
All button.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 277,
281-283

Additional reference words:  w4wproof speller proofing tools grammar
wm_word pound sign  2.00 2.00a 2.00a-CD 2.00b 6.00



WinWord: Deleting Words from Custom Dictionaries
Article ID: Q86557
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you can customize the spelling
dictionary by adding words not contained in the main dictionary. Added
words are stored in a text file with the default filename CUSTOM.DIC
in the WINDOWS\MSAPPS\PROOF directory.

More Information:

Word for Windows 6.0
--------------------

Deleting words from custom dictionaries has been made even easier
in Word for Windows 6.0. From the Tools menu, choose Options.  Choose
the Spelling tab. Choose the custom dictionary you want to edit and then
choose the edit button. The custom dictionary file will automatically
appear in a word document. Remove/add the desired word to the dictionary
file and then choose Save from the File menu.

Adding other custom dictionaries is easy. From the Tools menu, choose
Options.  Choose the Spelling tab.  Choose the Add button in the custom
dictionary section.  You can name your custom dictionary any name with any
extension you'd like.  The only restriction is that you stay with the 8.3
DOS naming convention.

Word for Windows 2.x
---------------------

To delete words from the CUSTOM.DIC file, open the file with a text
editor, such as Microsoft Windows Notepad, and locate the word you
want to delete. Delete the word as you would any text, then save the
CUSTOM.DIC file. The spelling checker will no longer reference the
word.

Adding other custom dictionaries is easy. From the Tools menu, choose
Options. Under Category, select Spelling. Under Custom Dictionaries,
choose the Add button. Type a name for the dictionary in the Add
Dictionary dialog box, then choose the OK button.

You can remove words from any custom dictionary with the process
outlined for CUSTOM.DIC.

Additional reference words:  w4wproof 2.00 2.00a 2.00a-CD  wm_word 
2.00b 2.00c  entry entries



With Insertion Point Between Words, Repeated Words Not Flagged
Article ID: Q87108
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, the spelling checker ignores repeated
words if you run the Spelling command when the insertion point is
positioned directly to the left of the second instance of the repeated
word.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this
problem, and will most more information here in the Microsoft
Knowledge Base as it becomes available.

MORE INFORMATION
================

Workaround
----------

To avoid this problem, position the insertion point at the beginning
of the document before you choose the Spelling command. If the
insertion point is not positioned directly to the left of the second
instance of a repeated word, the spelling checker does flag repeated
words.

Steps to Reproduce Problem
--------------------------

1. Open a new file in Word for Windows.

2. Type the following text:

      repeated words not not flagged

3. Position the insertion point directly to the left of the letter "n"
   in the second instance of the word "not."

4. From the Tools (Utilities in version 1.x) menu, choose Spelling.

5. Choose the Yes button when you are prompted to continue checking at
   the beginning of the document.



The spelling checker does not flag the repeated word.

Note: There must be a space between the repeated words "not" and
"not." You must position the insertion point right next to the letter
"n" of the second instance of "not" to reproduce this problem. If the
space between the two words is between the insertion point and the
second instance of "not," the spelling checker operates correctly.

Additional reference words: w4wproof 1.00 1.10 1.10a 2.00 2.00a cursor
wm_word repetition 2.00a-CD 2.00b 6.00



Misspelled Words Not Selected in Footer by Spelling Checker
Article ID: Q87295
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When the Microsoft Word for Windows spelling checker is launched using
a WordBasic macro, it does not select words it flags as misspelled in
the header or footer text.

However, if you run the spelling checker by choosing Spelling from the
Tools menu, it will select the flagged word in the header or footer as
expected.

This problem was corrected in Word version 6.0 for Windows.

More Information:

When you run the spelling checker as part of a WordBasic macro, it
finds unrecognized words, displays the word in the Spelling dialog
box, and displays the header or footer window that contains the
unrecognized word, but it does NOT select the unrecognized word.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 275-278

Additional reference words:  w4wproof 2.00 2.00a 2.00a-CD 2.00b 
w4wmacro



Cancel Button Returns to Grammar Checker from Spelling Checker
Article ID: Q87302
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, if the grammar checker calls the
spelling checker and you choose the Cancel button in the Spelling
dialog box, the grammar checker resumes. Word for Windows does not
return to the document at this point because the spelling checker is
running secondary to the grammar checker.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

If the Spelling Errors grammar option is selected, Word for Windows
checks the spelling for each sentence before it checks the grammar. If
the spelling checker dialog box appears and you choose the Cancel
button, Word for Windows only cancels the spelling checker dialog box,
not the entire grammar checking operation.

To disable the Spelling Errors option for the grammar checker, do the
following:

1. From the Tools menu, choose Options. From the Category list, select
   Grammar. Choose the Customize Settings button.

2. In the Grammar box, deselect the Spelling Errors option and choose
   the OK button twice.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 289,
734-735



Additional reference words: w4wproof 



Spelling Checker Incorrectly Flags Second Instance of Word
Article ID: Q87315
-----------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, and
   2.0b
 - Microsoft Windows operating system versions 3.0, 3.0a, and 3.1
-----------------------------------------------------------------

Summary:

The spelling checker in Microsoft Word for Windows incorrectly flags a
second instance of a word as a repeated word if

   ).

follows the first instance of the word. The spelling checker does not
recognize the period (.) as a separator in the first sentence if the
period is preceded by a parenthesis. For example:

   ...(file). File ...

If you delete the closing parenthesis, the spelling checker does not
flag the second instance of "file" as a repeated word. For example:

   ...file. File ...

This functionality was changed in Word version 6.0 for Windows.

More Information:

The period is not a word delimiter for spell checking. This is because
several languages use periods in the middle of words. For example, the
Italian abbreviation for Mrs. for instance is Sig.ra. Parenthesis, on
the other hand, are delimiters.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 275-278

Additional reference words: w4wproof 
2.00 2.00a 2.00a-cd speller spell 2.00b



Grammar Checker Incorrectly Flags "Well-Established"
Article ID: Q87316
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0, 3.0a, and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, if you run the grammar checker on a
sentence that contains the hyphenated phrase "well-established," the
grammar checker flags this phrase as incorrect. The following grammar
checker message appears in the Suggestions box:

   Consider well-established instead of the hyphenated form.

If you choose the Change button, the grammar checker replaces "well-
established" with "well-established," which causes the same suggestion
to appear again in an infinite loop.

The grammar checker should suggest "well established," which is the
unhyphenated form of the phrase.

Note: To see this feature function correctly, run the grammar checker
on a sentence that contains "poorly-established".

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 284-287,
733-735

Additional reference words: 2.00 2.00a 2.00a-cd hyphen w4wproof



All Caps Character Formatting Ignored By Spelling Checker
Article ID: Q87569

--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, if you type a word with incorrect
capitalization (such as "tHis") and then format the word for All Caps
character formatting by choosing Character from the Format menu or by
pressing CTRL+A (so that the word appears as "THIS"), the Spelling
command flags the original word as misspelled. The spelling checker
does not recognize the All Caps character formatting; therefore, the
word is flagged as if All Caps character formatting had not been
applied.

This problem does not occur if you press SHIFT+F3 to change the case
of the word to all capital letters.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

WORKAROUND
==========

Use the SHIFT+F3 key combination to change the case of a word to all
capital letters. For more information on SHIFT+F3, refer to page 151
of the "Microsoft Word for Windows User's Guide."

Steps to Reproduce Problem
--------------------------

1. In a Word for Windows document, type "tHis" (without the quotation
   marks).



2. From the Tools menu, choose Spelling. Notice that the spelling
   checker flags "tHis" for improper capitalization.

3. Select "tHis" and press CTRL+A to apply All Caps character
   formatting. The word should appear as "THIS."

4. From the Tools menu, choose Spelling. Notice that the spelling
   checker flags "tHis" for improper capitalization as if you had not
   applied the All Caps character formatting.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, page 151

Additional reference words: w4wproof 2.00 2.00a 2.00a-cd speller
checking wrong checked w4wfont ignored 2.00b



Infinite Loop Spell Checking "RE: Testt" Using Grammar Checker
Article ID: Q88372
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------
Summary:

In Microsoft Word for Windows, if you type the text string "RE: Testt"
in response to a FILLIN or ASK field prompt and a pound sign (#) is
directly to the right of the field, when you run the Grammar command
with the Spelling Errors check box selected, the string "Testt#" is
flagged as a misspelled word. If you choose the Ignore All button,
Word for Windows becomes caught in a hanging loop; you must press
CTRL+ALT+DEL to exit this loop.

Microsoft has confirmed this to be a problem in versions 2.0,
2.0a,and 2.0a-CD of Word for Windows. This problem was corrected in
Word for Windows version 6.0. 

More Information:

This problem does not occur if you choose the Add button or the Change
button. Also, if you delete the text "RE:" or the pound sign, the loop
does not occur. You can also avoid this problem by clearing the
Spelling Errors check box in the Customize Grammar Settings dialog
box.

Note: The spelling checker in Word for Windows, which is activated by
choosing Spelling from the Tools menu, does not cause this problem.

Steps to Reproduce Problem
--------------------------

1. From the Insert menu, choose Field. Under Insert Field Type, select
   Fill-in, type a prompt, and choose the OK button.

2. Select the FILLIN field and press F9 to update the field. In the
   dialog box, type "RE: Testt" (without the quotation marks), and choose
   the OK button.

3. Type "#" (without the quotation marks) immediately after the FILLIN
   field. The field should appear as follows:

      {fillin "Enter Text"}#

   Note: If you clear the View Field Codes command, the line appears as
   follows:

      RE: Testt#

4. From the Tools menu, choose Options. Under Category, select



   Grammar, then choose the Customize Settings button. Under Grammar,
   select the Spelling Errors check box, then choose the OK button.

5. From the Tools menu, choose Grammar. When the grammar checker flags
   "Testt#," choose the Ignore All button.

"Microsoft Word for Windows User's Guide for version 2.0", pages
284-286, 472-475, 484-486, 648, 651-652, 752

Additional reference words:  w4wproof 2.00 2.00a 2.00a-CD speller hang 
hangs crash hung stop stops w4wfield locks lock locked reboot soft boot
infinite



Word Err Msg: The <Proofing Tool> Is in Use
Article ID: Q89545
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

One of the following error messages may occur in Word for Windows when
you run the spelling checker, thesaurus, hyphenator, or grammar
checker:

   Error Message                             Error Message Number
   -----------------------------------------------------------------

   The spelling checker is in use.                    1255
   The thesaurus is in use.                           1311
   The hyphenator is in use.                          1343
   The grammar checker is in use.                     1289

These error messages occur if the proofing tool is running in another
instance of Word for Windows. They also occur if you used the proofing
tool in a previous Word for Windows session at the time when an
unrecoverable application error (UAE) or general protection (GP) fault
occurred.

More Information:

When you run one of the proofing tools, Word for Windows reads the
appropriate .DLL file into memory and creates a temporary (.TMP) file
on the hard drive. When the proofing operation is completed, Word for
Windows erases the .TMP file and removes the .DLL from memory. If a
fatal application error occurs and you restart Word for Windows
without exiting and restarting Windows, the .DLL file remains in
memory and Word for Windows assumes the proofing tool is already
running.

To eliminate the error message after a UAE or GP fault occurs, quit
Windows to clear the .DLL file from memory. If the error message
persists after you restart Windows and Word for Windows, exit Windows
again and delete all .TMP files from your hard drive.

Word for Windows 6.0
--------------------

The above error messages will only appear for the grammar checker and the 
thesaurus in Word for Windows version 6.0.  This is because the grammar
checker and the thesaurus are not shared tools which other programs can
access.  The spell checker and the hyphenator are shared utilities which can
be accessed by other programs therefore, allowing for multiple instances to
run at the same time.



Additional reference words:  w4wproof 2.00 2.00a 2.00a-CD 2.00b 6.00 wm_word 
hyphenate tools win31



WinWord Err Msg: Text Formatted with No Proofing Was Skipped
Article ID: Q89646
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Windows, if part or all of your document is formatted
with no language reference, when you run either the Spell Checker or
the Grammar Checker, you receive the following message:

   The Spelling Check is complete.
   Text formatted with (no proofing) was skipped.

In order to use the Spell Checker, a language must be specified. Word
for Windows uses the default language unless you specifically format
part or all of your document with no language. Word for Windows skips
any text formatted in this way, since it does not have a language to
check against.

Steps to Reproduce Problem
--------------------------

1. In a new Word document, type some misspelled text.

2. From the Edit menu, choose Select All to select the text.

3. From the Format menu, choose Language.

4. In the Mark Selected Text As list box, select the [no proofing]
   option.

5. In your test document, press the HOME key to position the cursor at
   the beginning of the sentence.

6. From the Tools menu, choose Spelling to start the spelling checker.

   You receive the message:

      The Spelling Check is complete.
      Text formatted with (no proofing) was skipped.

Note: You won't receive this message unless you select the text. If
you simply choose [no proofing] from the Language dialog box with no
text selected, and then run the Spell or Grammar Checker, Word for
Windows defaults to your original language.

To correct this paragraph formatting
------------------------------------



1. Select any paragraphs in your documents formatted as [no proofing],
   or from the Edit menu, choose Select All to select your entire
   document.

2. From the Format menu, choose Language, and then select English
   (US).

3. Run the Spell Checker again.

   The misspelled words will be correctly flagged.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 295-296

Additional reference words:  w4wproof 2.00 2.00a 2.00a-cd 2.00b  wm_word 
speller errmsg err msg error 6.00



Grammar Checker Gives Wrong Suggestion for "-ize" Suffix
Article ID: Q90510
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If the grammar checker flags a misspelled word ending in "ize" (such
as "reallize") when the Spelling Errors and the Jargon Words options
are selected in the Customize Grammar Settings dialog box, you may
receive the following error message:

   Avoid jargon words like <word>.

This error message is displayed incorrectly. The grammar checker
should really flag this word as misspelled.

Note: If the grammar checker first flags a different misspelled word,
it correctly flags the word ending in "ize" as a misspelled word.

Microsoft has confirmed this to be a problem in Microsoft Word for
Windows versions 2.x. This problem was corrected in Word for Windows 
version 6.0. To obtain new or updated Microsoft products, call Microsoft
Consumer Sales at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661

More Information:

To avoid the incorrect error message, clear the Jargon Words option in
the Customize Grammar Settings dialog box:

1. From the Tools menu, choose Options. Select the Grammar category
   and choose the Customize Settings button.

2. In the Grammar box, clear the Jargon Words option and choose the OK
   button twice.

Steps to Reproduce Problem
--------------------------

1. Type the following sentence in a new Word for Windows document:

      I did not reallize I made a mistake.

2. From the Tools menu, choose Options. Select the Grammar category
   and choose the Customize Settings button.

3. In the Grammar box, select the Jargon Words and Spelling Errors



   options and choose the OK button twice.

4. From the Tools menu, choose Grammar. The grammar checker flags the
   misspelled word "reallize" and displays the following suggestion:

      Avoid jargon words like reallize.

4. Choose the Cancel button in the Grammar dialog box.

5. In the sentence you typed in step 1 above, change the word "did" to
   "didd" (without the quotation marks).

6. From the Tools menu, choose Grammar. The grammar checker flags the
   word "didd" as a misspelled word. Choose the Change button. The
   grammar checker now correctly flags "reallize" as a misspelled
   word.

Additional reference words: w4wother w4wproof proofing tools
checking 2.00 2.00a 2.00a-CD 2.00b 2.00c



Spelling Checker Does Not Suggest from Custom Dictionary
Article ID: Q90512
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows version 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

The spelling checker in Word for Windows version 2.0c does not routinely 
display suggestions from your custom dictionary when it flags a 
misspelled word. Word for Windows lists suggestions from the custom 
dictionary only if you add a wildcard character to the word in the 
Change To box.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

The following is an example of how you can use wildcard characters 
(* or ?) to display suggestions from your custom dictionary.

1. Type the word "coz" (without the quotation marks) in a Word for
   Windows document. Select the word. From the Tools menu, choose
   Spelling.

2. The spelling checker flags this word as misspelled. Choose the Add
   button to place this word in the active custom dictionary.

3. Type the word "cozz" (without the quotation marks). Select the word
   and choose Spelling from the Tools menu. Note that the word "coz"
   does not appear in the Change To box.

4. In the Change To box, type "coz*" (without the quotation marks).
   Choose the Suggest button. The word "coz" appears at the bottom of
   the Change To list. The word is not in alphabetical order because
   the spelling checker adds words from the custom dictionary to the
   bottom of the list.

Using Wildcard Characters with the Spelling Checker



---------------------------------------------------

You can use wildcard characters (* or ?) to specify any single
character or group of characters. This method broadens the list of
suggestions in the Change To box. For example, if you do not know
if "surprise" or "surprize" is correct, type "surpri?e" (without
the quotation marks) in the Change To box and choose the Suggest
button. If you type "Occur*" (without the quotation marks) Word for
Windows suggests all words that begin with "occur".

REFERENCES
==========

"Microsoft Word for Windows User's Guide,"  for version 2.0, pages
275-283

Additional reference words: w4wproof missing not listed incomplete
2.00b 2.00c 



Spelling Checker Does Not Recognize Table Cell as Delimiter
Article ID: Q91173
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

The Microsoft Word for Windows spelling checker does not recognize
table cell separators as delimiters. If adjacent table cells contain
the same word or a decimal number, the Spelling command flags the
second word as a repeated word.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

For example, the spelling checker flags the occurrences below because
there is no period or comma between the two numbers or words.

---------------------------
| 6.0        | 6.0         |
---------------------------
| red        | red         |
---------------------------

WORKAROUND
==========

To work around this behavior, you can apply No Proofing Language
formatting to your table, which causes the spelling checker to ignore
the table. To do this, use the following steps:

1. From the Table menu, choose Select Table.

2. From the Format menu, choose Language.

3. In the Mark Selected Text As box, select (no proofing), then choose



   the OK button.

Additional reference words:  w4wproof 2.00 2.00a 2.00a-CD 2.00b Table 
Speller w4wtable checking spell check repeated skip



Add Button Unavailable in the Spelling Dialog Box
Article ID: Q94087
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, the Add button in the Spelling dialog box 
isunavailable (grayed out) if the custom dictionary currently being used 
isread only or in a read-only directory. The Add button is unavailable
because such a file cannot be modified.

The default name and location of the custom dictionary are as follows:

   C:\WINDOWS\MSAPPS\PROOF\CUSTOM.DIC

If the CUSTOM.DIC file is read only or if the PROOF subdirectory is read
only, you cannot add new words to the custom dictionary file.

More Information:

Word uses the following procedure to search for the spelling checker:

1. Word looks for the custom dictionary in the directory indicated in 
   the [MS Proofing Tools] section of the WIN.INI file. By default, the 
   directory and filename are C:\WINDOWS\MSAPPS\PROOF\CUSTOM.DIC.

2. If Word does not find the file there, Word looks in its own program
   directory.

3. If Word does not find the CUSTOM.DIC file there, Word asks you if you
   want to create a new custom dictionary and states the path where it
   intends to put the file.

4. Even if you choose the No button when Word asks if you want to create 
a
   new custom dictionary, Word creates one anyway.

5. If the path where Word intends to create CUSTOM.DIC is not valid, 
   Word places the new CUSTOM.DIC file in the Word program directory.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 276-283,
733-734, 805

"Microsoft Word for Windows User's Reference," version 1.x, pages 331-
334



Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b wm_word 
w4wproof proofing tools speller checking greyed g
rey gray



Can't Edit Selected Text when Grammar/Spelling Macro Modified
Article ID: Q94768
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, when you run the Grammar command
or the Spelling command from a modified macro, you must exit the
Grammar or Spelling dialog box before you can edit information in the
document window.

More Information:

When the Grammar command identifies a sentence for grammatical errors or
when the Spelling checker identifies a questionable word, you can make
changes directly in your document while the Grammar or Spelling dialog box
is present. The Spelling and Grammar dialog boxes behave this way because
they are modeless dialog boxes: it is not necessary to cancel out of these
dialog boxes to make changes in your document. However, if you run the
Grammar command or the Spelling command from a modified macro, you must
first cancel the Grammar or Spelling dialog box in order to make changes
directly in your document.

Steps to Reproduce Problem
--------------------------

1. From the Tools menu, choose Macro.

2. In the Macro dialog box, under Show, verify that the Commands option is
   selected.

3. Under Macro Names, choose the ToolsGrammar macro and choose the Edit
   button.

4. Edit the macro to read as follows (delete the word "Super"):

      Sub Main
      ToolsGrammar
      End Sub

5. From the File menu, choose Close. When you are prompted to save the
   changes to global:ToolsGrammar, choose the Yes button.

6. In a new document, type the following text:

      Walking in a park.

7. From the Tools menu, choose Grammar.



8. When the sentence is selected with the grammar dialog in the foreground,
   try selecting text somewhere in the selected text (outside of the
   Grammar dialog box).

The system will beep, indicating that the document cannot be edited while
the Grammar dialog box is on the screen.

This same situation occurs if you edit the ToolsSpelling macro and choose
the Spelling command from the Tools menu.

Note: You will experience a similar situation when the Spelling Checker is
run from the Grammar checker; you will not be able to edit the document
until the Spelling dialog box is canceled.

Additional reference words:  w4wproof w4wmacro 2.00 2.00a 2.00a-cd  wm_word 
2.00b 2.00c 6.00



Error Message: The Custom Dictionary <filename> Is Unavailable
Article ID: Q98304
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

The following error message may occur when you use the spelling
checker in Word for Windows 6.0:

The custom dictionary <Path\dictionary name> is unavailable

This error message can occur because the user has previously specified
the custom dictionary in found under Tools/Options/Spelling and the
file has either been deleted or moved.

The following error message may occur when you use the spelling
checker in versions 2.0, 2.0a, 2.0a-CD, 2.0b, or 2.0c of Word for
Windows:

   The custom dictionary <Path\dictionary name> is unavailable.

This error message can occur in the following two situations:

1. The custom dictionary named in the error message is not a text
   file.

2. If the custom dictionary is located on a network, another user may
   be using the dictionary. They may be adding a word to it using the
   spelling checker, or they may have the dictionary file open in Word.

In Word versions 1.x, the following error message may occur:

   Error Writing to User Dictionary

For information on this error message, see the "Word Version 1.x"
section at the end of this article.

Workaround 1: Save Dictionary File in Text Only Format
------------------------------------------------------

To use your custom dictionary with Word for Windows, it must be in
Text Only file format. If it is not in this format, do the following:

1. Open the dictionary file.

2. From the File menu, choose Save As.

3. In the Save File As Type box, select Text Only (*.txt).



4. In the File Name box, type a new name with a .DIC extension, and
   choose OK.

5. The name of your usable dictionary is now different than the name
   referenced on the CUSTOM DICT N= line in the [MS Proofing Tools]
   section of the WIN.INI file. The dictionary name and its WIN.INI 
   reference must match, so you can either rename the dictionary file
   or change the WIN.INI reference to the new dictionary filename.

Workaround 2: Change Network Custom Dictionary to Read-Only
-----------------------------------------------------------

If you are on a network, you can change the file attributes of the
custom dictionary file to Read-Only or change the network users'
rights to Read-Only. This workaround allows multiple users to access
the custom dictionary at the same time and avoids the error message.
The drawback to this workaround is that nobody can add words to the
custom dictionary.

As an alternative, you could create a separate custom dictionary file
for each network user.

More Information:

Word for Windows, Versions 2.0, 2.0a, 2.0a-CD, 2.0b, 2.0c
=========================================================

If you continue to use the spelling checker after you receive the
above error message, the Add button in the Spelling dialog box is
unavailable. To add a word to a custom dictionary, you can select a
different dictionary from the Add Words To list (if one is listed), or
you can choose the Options button in the Spelling dialog box and open
a different custom dictionary or create a new one.

If you create a new custom dictionary, Word adds the following line to
the [MS Proofing Tools] section of your WIN.INI file

   Custom Dict N=C:\WINDOWS\MSAPPS\PROOF\<filename>.DIC

where N is a number from 1 through 4.

Note: If you do not have an \MSAPPS\PROOF subdirectory, Word places the
custom dictionary file in the Word program directory.

If you cancel the unavailable dictionary selection from the Custom
Dictionaries list in the Spelling Options dialog box, Word deletes the
dictionary name from the Custom Dict N reference in the [MS Proofing
Tools] section of the WIN.INI file and moves the remaining selected
custom dictionaries to the top Custom Dict N positions. For example,
if you deselect CUSTOM.DIC, Word removes it from the Custom Dict 1
reference and moves the current custom dictionaries to the top
positions, as shown in the following sample WIN.INI entry:

   [MS Proofing Tools]
   Custom Dict 1=C:\WINDOWS\MSAPPS\PROOF\LETTERS.DIC
   Custom Dict 2=C:\WINDOWS\MSAPPS\PROOF\NEW_DICT.DIC



   Custom Dict 3=

Note: In the above sample, LETTERS.DIC and NEW_DICT.DIC are selected
in the Custom Dictionaries list in the Spelling Options dialog box.

To see which custom dictionaries are open--or selected in the Custom
Dictionaries list in the Spelling Options dialog box--do the
following:

1. From the Tools menu, choose Spelling.

2. In the Spelling dialog box, look in the Add Words To box. The
   filename(s) in this box are open custom dictionaries. This list
   corresponds to the completed Custom Dict N references in the
   WIN.INI file (for example, based on the above sample WIN.INI file,
   LETTERS.DIC and NEW_DICT.DIC would appear in the Add Words To box).

Word Versions 1.x
=================

If a user dictionary file is in a file format other than text only or
if somebody else is using the file over a network, Word cannot read
the file, but no error message occurs until you attempt to add a word
to that dictionary.

The error message:

   Error Writing to User Dictionary

also occurs in Word versions 1.x if you attempt to add a word to the
CUSTOM.DIC file for Word versions 2.0, 2.0a, 2.0a-CD,  2.0b, and 2.0c.

The error message:

   Cannot Create STDUSER.DIC

will occur when trying to invoke the spelling checker in Word for
Windows on a network if the subdirectory where the spelling checker
DLL files are located is marked as read only. This happens because
Word attempts to make the update dictionary in the same subdirectory
as the spelling checker and is prevented from doing so by the system.

One solution is to move all the spelling checker files into a
subdirectory that the user has read-write privileges in and specify
that subdirectory in the UTIL-PATH under the Microsoft Word section of
the WIN.INI file.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 276-283,
733-734, 805

"Microsoft Word for Windows User's Reference," version 1.x, pages 224,
331-334.

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
wm_word 2.00c 6.00 w4wproof proofing tools speller checking gray grey



grayed greyed



GP Fault in Header/Footer After Running ToolsSpelling in Macro
Article ID: Q99980
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========

If you run a macro that performs the ToolsSpelling command, and if the
spelling checker flags a misspelled word in the document header or
footer, a general protection (GP) fault (or GPF) occurs in Word for
Windows when you open the header or footer pane from normal view after
the spelling check is complete. The GP fault may occur as soon as you
open the header or footer for viewing, or it may not occur until you
edit the header or footer.
 
STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.
 
WORKAROUND
==========

Instead of using the ToolsSpelling command in a macro, run the
ToolsSpelling macro using the ToolsMacro command instead. You can use
the following command in your macro in place of the ToolsSpelling
command:
 
   ToolsMacro "ToolsSpelling", .Run
 
For more information on running the ToolsSpelling command from a
macro, query on the following words in the Microsoft Knowledgebase:
 
   toolsspelling and macro
 
MORE INFORMATION
================
 
When you run the ToolsSpelling command from a macro, as described
above, the GP fault occurs whether you choose one of the Change
buttons or one of the Ignore buttons in the Spelling dialog box.



Furthermore, the GP fault occurs regardless of whether the spelling
checker runs in normal or page layout view. The error occurs only if
you view or edit the header or footer in normal view after the
spelling checker flagged a misspelled word in the header or footer.
 
Additional reference words: GP Fault GPF error hang hung crash crashed
locks locked frozen freezes crashing quit quits stopped 2.00a 2.00a-cd
2.00b 2.00c w4wproof



How to Remove Word for Windows Custom Dictionaries
Article ID: Q100370
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
SUMMARY
=======

Once you create a custom dictionary in Word for Windows using the
Tools Options Spelling command, you cannot remove the custom
dictionary simply by deleting its reference in the [MS Proofing Tools]
section of the Windows WIN.INI file. If the custom dictionary file
remains in one of the following locations, Word finds the file and
adds its reference back to WIN.INI next time you start Word:
 
      Note: Word searches for the .DIC file in the order listed.
 
 - The TOOLS-path directory (set in the [Microsoft Word 2.0] section
   of WIN.INI).
 
 - The custom dictionary path (set by the PROOF setting in the
   [MSAPPS] section of WIN.INI; the default setting is
   C:\WINDOWS\MSAPPS\PROOF). Word does not search for .DIC files 
   in any subdirectories of the custom dictionary path.
 
 - The Word program directory (set by the PROGRAMDIR setting in the
   [Microsoft Word 2.0] section of WIN.INI).
 
When Word searches for dictionary files in the above locations, it
adds any file with a .DIC filename extension to the WIN.INI file as a
custom dictionary.
 
Workaround
----------
 
To remove a custom dictionary, you must delete the .DIC file, rename
it with a different file extension, or move it to a location other
than one of those listed above so Word does not find it when you
start the program.
 
MORE INFORMATION
================

For example, if you delete the following line from the [MS Proofing
Tools] section of your WIN.INI file but do not delete or move the .DIC
file to a different location, Word adds the entry back to WIN.INI next
time you start the program:
 
   Custom Dict 1=C:\WINDOWS\MSAPPS\PROOF\CUSTOM.DIC



Word for Windows 6.0
--------------------

The information for the active dictionaries in Word for Windows 6.0 is kept
under Tools/Options/Spelling just like version 2.0, however, custom
dictionary properties are different in determining the active dictionary
and for adding and deleting the dictionary.

To properly delete a custom dictionary in Word for Windows 6.0, choose
Options from the Tools menu. Select the Spelling tab. Choose the dictionary
you want to delete from the list. This does not actually delete the
dictionary rather it only deletes the reference. Unlike version 2.0, Word
will not reference that dictionary in the next session of Word for Windows.
Then delete the dictionary file from the disk.

Errors Generated
----------------------

If the user deletes or moves the dictionary file without removing the
reference under Tools/Options/Spelling and then tries to spell check,
an error will occur:

There is no custom dictionary C:\WINWORD6\CUSTOM.DIC.  Do you want to
create it?

If you choose "YES", Word will create a custom dictionary, place it in
the WINWORD6 directory and place the reference under
Tools/Options/Spelling.  If the user chooses, "NO" and no previous
references for custom dictionaries exists in the custom dictionary
list then Word will not flag the user and the "Add" button will be
gray in the Spelling dialog box.  If, however, the user chooses "NO"
and there are previous references to dictionaries that have been moved
or deleted, Word will create a new custom.dic file named after the
last referenced custom dictionary and place it in the WINWORD6
directory.

For example, if you have dictionary called (and in this order):

custom.dic 
john.dic 

and you move or delete these files and then try to spell check without
removing the references in the Spelling options dialog box, you will
be warned that the custom dictionary cannot be found two seperate
times one right after the other and asked if you want to create the
custom dictionary.  If you say "NO", Word will create a dictionary
called:

john.dic

and place it in the WINWORD6 directory.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wproof wm_word 



No Prompt to Save Changes After Running Spelling Checker
Article ID: Q102189
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========

Word for Windows does not prompt you to save changes to a document
when you close the document after you run the spelling checker if you
change spelling only in the footnote. 

CAUSE
=====

This happens because Word does not change the document status to
"dirty" (that is, flag the file as changed) if the only change you
make is to the footnote during a spelling check operation. 

STATUS
======

We are researching this problem and will post new information here in the
Microsoft Knowledge Base as it becomes available.

WORKAROUND
==========

You must save the file before you close it to keep these changes.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wproof



Proofing Tools Do Not Check Text Modified with Revision Marks
Article ID: Q102444
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========
 
Word for Windows will not proof text that has been modified using
Revision Marks in Word for Windows. The proofing tools will check new
text that has been added to the document and does not check modified
text even if you turn off Revision Marks.

CAUSE
=====

This behavior is by design.
 
MORE INFORMATION
================
 
If you type the word "spel" in a document, turn Revision Marks on,
select the word and press the DEL key, a line will appear through the
word indicating that the word is to be deleted from the document.
Therefore, to Word, the text does not exist. If you try to proof the
misspelled word, the proofing tools will not proof the text for
errors.
 
This is a function of both Revision Marks and the proofing tools in
Word for Windows.
 
Additional reference words: w4wproof 2.00 2.00a 2.00b 2.00a-CD 2.00c



Error Message: The Custom Dictionary Is Not Available
Article ID: Q104691
-------------------------------------------------------------------
The information in this article applies to:

  - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
    2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
SUMMARY
=======
 
This article describes three possible causes for the following error
message in Word for Windows:
 
   The Custom dictionary is not available.
 
This error message can occur for the following reasons. (The first two
are documented in online Help, but the third is undocumented.)
 
 - The custom dictionary file is not in text file format.
 
 - Another application is using the custom dictionary file.
 
   NOTE: For more information about the above two causes, search for 
   "error messages" using the Help menu.
 
 - The custom dictionary file may be damaged.
 
MORE INFORMATION
================
 
If your custom dictionary file is damaged, you may need to re-create
it using the following steps:
 
1. Choose the New button on the Standard toolbar (on the
    toolbar in Word 2.0) to create a new document.
 
2. From the Insert menu, choose File.
 
3. Select the custom dictionary file, located in the <Windows>\MSAPPS\PROOF 
   subdirectory (where <Windows> is the name of your Windows
   directory), and then choose OK.
 
   NOTE: Custom dictionary files have a .DIC filename extension.
 
4. If prompted, convert the file from Text Only.
 
5. From the File menu, choose Save.
 
6. Type a filename, with a .DIC extension.
 
7. In the Save File As Type box, select Text Only and then choose OK.
 



8. Close the file. 

Your re-created custom dictionary file is now ready to use.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00 wm_word 
w4wproof docerr



Grammar Checker Posts Incorrect Readability Statistics
Article ID: Q105579
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.1
-------------------------------------------------------------------

SYMPTOMS
========

The readability statistics displayed after Word has completed a
grammar check may be incorrect or display zeros.

CAUSE
=====

The following are possible reasons for the statistics being incorrect:

 - The text being grammar checked is formatted for superscript or
   subscript character formatting.

 - The text being checked was formatted for all caps using CTRL+A,
   SHIFT+F3, or by choosing the All Caps effect in the Format Font
   dialog (Format Character dialog in Word versions 2.x).

 - The text being checked is a one-line paragraph with no punctuation
   mark at the end of the sentence.

 - The text has been formatted for "No proofing" in the Tools Language
   dialog (Format Language dialog in Word version 2.x).

Additional reference words: wm_word 2.00 2.00a 2.00b 2.00c 2.00a-CD
2.00c-CD 6.00 zeros proofing all caps superscript punctuation w4wproof



Readability Statitistics Do Not Display
Article ID: Q105696
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.1
-------------------------------------------------------------------
 
SYMPTOMS
========
 
If you are grammar checking text in a document that is formatted for
either superscript or subscript character formatting, the Word 2.x
grammar checker will not display the readability statistics, even if
the "Show Readability Statistics after Proofing" option is turned on.
(To locate this option, choose Options from the Tools menu, and choose
the Grammar category.)

In Word 6.0, the readability statistics MAY not display, even if the
"Show Readability Statistics" option is turned on, depending on other
factors. (To locate this option, choose Options from the Tools menu,
and select the Grammar tab.)

CAUSE
=====

Word for Windows is unable to calculate the readability statistics.

STATUS
======
 
We are researching this problem and will post new information here in
the Microsoft Knowledge Base as it becomes available.
 
REFERENCES
==========
 
"Microsoft Word for Windows User's Guide," version 2.x, pages 284-286
 
Additional reference words: 2.00 2.00a 2.00b 2.00c 2.00a-CD 2.00c-CD
6.00 w4wproof



How to Uninstall MasterWord by ALKI Software
Article ID: Q107502
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------

SUMMARY
=======

MasterWord is an add-on program produced by ALKI software that enhances the
functionality of Word for Windows, adding additional tools, toolbar
buttons, and additional online help enhancements. MasterWord includes the
following enhancements and tools:

 - Versatile and customizable floating toolbar
 - Customizable keyboard assignments of up to four letters long
 - MasterWord Manager, allowing ease in moving or copying of macros, styles
   and glossaries
 - Additional, useful macros
 - Extended File command capabilities such as additional features added to
   the File Open command
 - Template selector with additional buttons to choose desired templates
 - Built-in button editor

Unistalling MasterWord
======================

MasterWord installs a host of files onto your hard drive that will rename
WINWORD.HLP, WINHELP.EXE, and four DLL files that are installed into the
Windows directory. If rather than disabling an individual feature you want
to uninstall all of MasterWord, follow these steps:

1. Delete the contents of the MasterWord program directory (by default,
   C:\MASTER).

2. Delete the contents of the TEMPLATE subdirectory of the MasterWord
   program directory.

3. Delete from your Word program directory the LANGUAGE.DOT, CONTROL.DOT,
   AND HANDY.DOT files.

4. Delete the WINWORD.HLP, CMDREF.HLP, AND MWTOOLS.HLP files from the Word
   program directory. Then restore the original version of the Word for
   Windows help file, either by renaming the file WINWORD0.HLP to
   WINWORD.HLP or by running Word's Setup program. (You are able to use the
   rename method only if you instructed MasterWord's Setup program to
   rename rather than delete Word's original help.)

5. Delete the following files from your Windows directory: MWAPPLIB.DLL,
   BUTTONED.DLL, MWHELP.DLL, AMAKEDIR.DLL, AND PATHBUTT.DLL.

6. If you are using Windows 3.0 rather than Windows 3.1, you may want to



   restore the 3.0 version of the Help program. To do this, delete
   WINHELP.EXE and WINHELP.HLP from your Windows directory, then rename the
   WINHELP.EX1 file WINHELP.EXE, and rename the WINHELP.HL1 file
   WINHELP.HLP. (This only works if MasterWord's Setup program renamed the
   files in the first place.)

7. Delete the NORMAL.DOT file in your Word directory, unless it contains
   non-MasterWord macros and assignments that you want to retain. If you
   want to keep your NORMAL.DOT file, delete from it the MasterWord macros
   listed in Chapter 6. You can also use the instructions on page 155 to
   remove unwanted menu and Toolbar assignments.

MORE INFORMATION
================

The MasterWord products included here are manufactured by ALKI, a vendor
independent of Microsoft; we make no warranty, implied or otherwise,
regarding this product's performance or reliability.

REFERENCES
==========

"MasterWord Tools and Help," page 158, "Unistalling MasterWord"

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00 w4wproof



Using Foreign Language Proofing Tools in Word for Windows
Article ID: Q107539
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.1
-------------------------------------------------------------------

SUMMARY
=======

In Word for Windows, you can format text in a document so Word uses a
foreign language dictionary whenever you run the proofing tools on a
document. (NOTE: Not all foreign languages support all of the proofing
tools.)

For information on obtaining foreign language proofing tools, query
on the following words in the Microsoft Knowledge Base:

   alki and foreign and language and word and 6.00 and windows

MORE INFORMATION
================

To use a foreign language proofing tool in Word for Windows, you must
locate the foreign proofing tool file in the following possible
areas:

 - The Word for Windows program directory (usually, "C:\WINWORD")

 - The TOOLS-path statement in the [Microsoft Word 2.0] section of the
   WIN.INI file for version 2.x

 - The TOOLS-path statement in the WINWORD6.INI file also located in the
   Word for Windows program directory (usually, "C:\WINWORD") for version
   6.0

 - The individual proofing tools paths located in the [Microsoft Word 2.0]
   section of the WIN.INI for version 2.x and the WINWORD6.INI file for
   version 6.0

   For example:

   Version 2.x
   -----------

   [Microsoft Word 2.0]
    Hyphenate 1036,0=C:\WINWORD\HYPH.DLL,C:\WINWORD\PROOF\HY_FR.LEX
    Spelling 1036,0=C:\WINWORD\SPELL.DLL,C:\WINWORD\PROOF\SP_FR.LEX
    Thesaurus 1036,0=C:\WINWORD\THES.DLL,C:\WINWORD6\PROOF\TH_FR.LEX
    Grammar 1036,0=C:\WINWORD\PROOF\GR_FR.DLL,C:\WINWORD\PROOF\GR_FR.LEX

   NOTE: The "1036" is the language code for French. The same entries may



   appear in the WINWORD6.INI file for version 6.0.

Installation
============

Version 6.0
-----------

To correctly install or add a foreign language proofing tool for version
6.0, follow the instructions included with the ALKI Software Foreign
Language Proofing Tools set. You can manually add the aforementioned
proofing tool lines to the WINWORD6.INI file if the foreign proofing tools
already exist on your system. The statements in the WINWORD6.INI file point
Word for Windows to the actual location, and Word will display an error
message if it cannot find the necessary files.

Version 2.x
-----------

To correctly install or add a foreign language proofing tool, follow the
instructions on page 3 of Chapter 2 in the "Microsoft Word for Windows
Proofing Tools" manual for version 2.x or follow the installation
instructions that come with the ALKI foreign language proofing tools.

Using the Foreign Proofing Tools
================================

To flag a selection of text to use the foreign proofing tools, select the
text you want to spell check using the foreign dictionary, and choose
Language from the Format menu in version 2.x, or choose Language from the
Tools menu in version 6.0. You can choose the specific language from the
list of languages in the Mark Selected Text As option. The proofing tools
now automatically switch to the designated proofing tools files to match
the language the text is formatted in. You can verify the proofing tools'
language has switched by looking at the title of the proofing tools dialog
box.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00 w4wproof



Running Word for Windows Setup in the Background
Article ID: Q77666
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

You can run Microsoft Word for Windows Setup in the background if you
want to continue working on your computer during installation.

MORE INFORMATION
================

If you press CTRL+ESC during the installation, the Task List displays
and you can switch to another application such as Excel.
 
Working in another application slows the installation process
somewhat; however, you can continue to work during the installation of
Word. Setup runs without any problems in the background.

Additional reference words: w4wsetup 2.00 2.00a 2.00a-CD 2.00b 2.00c wm_word 



Cannot Install Word for Windows 2.0 From MS-DOS Prompt
Article ID: Q78466
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0 and 6.0
--------------------------------------------------------------------

SUMMARY
=======

Microsoft Word must be installed from within Microsoft Windows.

Word 6.0
--------

Microsoft Word 6.0 for Windows must be installed from within Windows
3.1. If you attempt to install Word for Windows from a MS-DOS prompt you
receive the following message:

   Use File-Run from Program Manager to start Microsoft Setup

Word 2.x
--------

Microsoft Word 2.x for Windows must be installed from the Windows
version 3.0 or 3.1. If you attempt to install Word for Windows from the
MS-DOS prompt, you receive the following error message:

   This program requires Microsoft Windows version 3.0 or higher.

MORE INFORMATION
================

To properly install Word for Windows, choose one of the following 
methods:
 
 - From the Windows Program Manager's File menu, choose Run, and type
  "a:\setup" (without the quotation marks).

 -or-
  
 - Start Windows and the Word for Windows setup program together by
   inserting the Setup disk in drive A and typing "win a:\setup"
   (without the quotation marks) at the MS-DOS prompt.

 -or-

- Place the Word for Windows setup disk in drive A or B.  From the
  Windows File Manager change to drive A or B and double click on
  SETUP.EXE.setup.exe.

REFERENCES
==========



"Microsoft Word for Windows Getting Started," pages 8-9
"Microsoft Word for Windows Jump Start," page 1
Microsoft Word for Windows version 2.0 Setup Disk

Additional reference words: 2.00 w4wsetup wm_word 



WinWord: Restoring Drag and Drop Printing Functionality
Article ID: Q84048
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In the Microsoft Windows operating system version 3.1, you lose the
ability to perform drag and drop printing of Microsoft Word for
Windows version 2.0 or 6.0 documents from the Windows File Manager if 
you delete or sufficiently modify the Windows REG.DAT file or the 
OLE2.REG file in Winword 6.0. To restore the REG.DAT settings that 
enable you to perform drag and drop printing of Word for Windows 
documents, you must either rerun the Word for Windows Setup program or 
manually edit the REG.DAT file.

More Information:

Winword 6.0:
------------

Winword 6.0 by default self registers itself when the program is
started, if this does not happen the recommended method to restore the 
OLE2.REG settings is to reinstall Word for Windows using the Custom 
Installation option. To do this, use the following steps:

1. Start the Word for Windows Setup program. 

2. When prompted to choose a type of installation, choose the Custom
   Installation button.

3. Select the Microsoft Word check box. Clear all other check boxes,
   and choose the Setup button.

Word for Windows is now reinstalled and the OLE2.REG settings are 
restored.

Winword 2.X:
------------

The recommended method to restore the REG.DAT settings is to reinstall
Word for Windows using the Custom Installation option. To do this, use
the following steps:

1. Start the Word for Windows Setup program. For more information on
   using the Setup program, see pages 8-11 in the "Microsoft Word for
   Windows Getting Started" manual.

2. When prompted to choose a type of installation, choose the Custom
   Installation button.



3. Select the Microsoft Word check box. Clear all other check boxes,
   and choose the Setup button.

Word for Windows is now reinstalled and the REG.DAT settings are 
restored.

For more information on the default REG.DAT settings for Word for
Windows, query on the following words in the Microsoft Knowledge Base:

   default and values and regedit.exe and reg.dat

Reference(s):

"Microsoft Windows Resource Kit," version 3.1, pages 359-365, 454

"Microsoft Word for Windows Getting Started," version 2.0, pages 8-11

Additional reference words: 2.00 2.00a 6.0 w4wsetup w4wprint cannot 6.00 
wm_word registration



How WinWord Uses the REG.DAT File in Windows 3.1
Article ID: Q87714
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

Microsoft Word for Windows uses information from the Registration
Database file (REG.DAT) for its object-linking-and-embedding (OLE)
activities. In Microsoft Windows operating system version 3.1, REG.DAT
provides the information used by File Manager and Print Manager to
support drag-and-drop functionality. When you first install Windows
3.1, the REG.DAT file contains information about all the OLE
applications included with Windows. You should never move or delete
REG.DAT; doing so can result in loss of functionality in File Manager,
Program Manager, and applications that support OLE.

MORE INFORMATION
================

The Word for Windows Setup program updates the REG.DAT file by adding
information about the program and the OLE server applications
(Microsoft Graph, Microsoft Draw, Microsoft WordArt, and Microsoft
Equation Editor) that ship with Word for Windows. During network
installation, Setup updates REG.DAT for the server or workstation,
depending on where Windows is installed. If your WINDOWS directory is
flagged as read only, Word for Windows Setup cannot update the REG.DAT
file, nor can it copy the OLE server application files to the WINDOWS
subdirectories. If this occurs, Word for Windows Setup generates an
error message.

If you cannot launch the OLE server applications from Word for
Windows, you may need to update REG.DAT. To do this, use the
Registration Info Editor (REGEDIT.EXE) program, which ships with
Windows 3.1. You can also reconstruct the REG.DAT file by running Word
for Windows Setup to reinstall the program.

Important Note: If you move any OLE server applications, you must
update the REG.DAT file so that Word for Windows can locate them.

To update REG.DAT using REGEDIT.EXE, use the steps below.

Note: Be sure to make a backup copy of the REG.DAT file before you use
these instructions.

1. From the Program Manager File menu, choose Run.

2. In the Command Line box, type "REGEDIT" (without the quotation
   marks), then choose the OK button.



3. Under Registered File Types, select the file type you want to
   update (for example, Word Document).

4. From the Edit menu, choose Modify File Type.

5. Type the correct location in the Command box, or choose the Browse
   button to locate the program file. (For example, for Word Document,
   locate the WINWORD.EXE file.) Choose the OK button.

6. From the File menu, choose Exit. Your changes are written to the
   REG.DAT file at this time.

Note: CheckFree software uses a non-Windows-related file called
REG.DAT. Be sure to select the correct REG.DAT file if you have both
Windows and CheckFree. CheckFree is manufactured by CheckFree
Corporation, a vendor independent of Microsoft; we make no warranty,
implied or otherwise, regarding this product's performance or
reliability.

README.DOC
----------

Page 3 of the Word for Windows README.DOC file contains information
about problems you can experience if another application uses the OLE
servers and modifies the REG.DAT file.

REFERENCES
==========

Microsoft Word for Windows, version 2.0, README.DOC, page 3

"Microsoft Word for Windows User's Guide," version 2.0, pages 803, 810

"Microsoft Windows Resource Kit," version 3.1, pages 359, 361-363, 454

Additional reference words: 2.00 2.00a 2.00a-CD msapps applet msdraw
wm_word msgraph win31  w4wsetup



Error Messages During Word Setup Caused by Anti-Virus Software
Article ID: Q93277
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, and 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

If virus-protection software is running on your computer when you start the
Setup program for Word for Windows, you may receive one or more of the
following error messages and sometimes your computer may stop responding
(hang):

   Unexpected DOS Error 5

   Setup Initialization Error

   Divide overflow

   Sharing Violation

   Insufficient Memory or Disk Space

   Error Reading from Drive A

   Cannot Detect setup.exe on Drive A

Before running the Setup program, you should disable any virus-scanning
software in the CONFIG.SYS and the AUTOEXEC.BAT files and reboot (restart)
your computer. This applies to new installations as well as upgrades. After
you run the Setup program, re-enable the virus-scanning software and reboot
your machine to allow the virus software to run normally.

Note: These error messages may also occur if not enough memory or disk
space is available on your computer.

More Information:

The above error messages have occurred while these anti-virus software
programs are running when you start the Word Setup program:

   VDEFEND (PC Tools Deluxe version 7.1)

   VSAFE, by Central Point Software

   PC Cillin

   Norton AntiVirus 2.0, by Symantec Corporation

To disable a command line in your AUTOEXEC.BAT or CONFIG.SYS file, add the
MS-DOS REM command at the beginning of the command line. To automate this



task, you can use the REMAuto or REMConfig macros from the PSS.DOC file,
supplied with Word versions 2.0a, 2.0b, 2.0a-CD and 2.0c. For more
information on the REM command, see your MS-DOS documentation.

Notes on VSAFE and VDEFEND
--------------------------

If you are using SMARTDRV.EXE version 4.0, load it after VSAFE or VDEFEND.

VSAFE adds the following line to the WIN.INI:

   load=mwavtsr.exe

Note: The Setup program for Microsoft Windows operating system version 3.1
also fails with VSAFE or VDEFEND installed.

The virus-protection products included here are manufactured by vendors
independent of Microsoft; we make no warranty, implied or otherwise,
regarding these products' performance or reliability.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wsetup wm_word 
hung crash lock reboot 3rdparty third errmsg err m
sg  locked
crash 3.10 vsafe.sys vsafe.com utilities stopped crashing crashed
locks frozen freezes crashing gpf uae smartdrive



Workstation Installation Option Not Available During Setup
Article ID: Q94066
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Sometimes the Workstation Installation option does not appear when you
run the Word for Windows Setup program after you ran a successful
Server Installation. This usually happens for one of the following two
reasons:

1. You did not choose the Server Installation option the first time you ran
   Setup.

   After a successful server installation, the Word for Windows program
   directory should contain 76 files and 10 subdirectories. If the
   directory contains a different number of files and subdirectories, you
   may have problems when you run the Setup program again. If your Word for
   Windows directory does not contain the correct number of files and
   directories, run another server installation, then run a workstation
   installation.

2. Setup did not correctly update the WWORD20.INF file.

   During the server installation, Setup should have added three items to
   the WWORD20.INF file:

      [Workstation] section

      User name

      Company name

   If Setup did not add the [Workstation] section, you can add it to the
   end of WWORD20.INF using any text editor. The entry should read as
   follows:

      [Workstation]
      Yes

   This setting causes Setup to offer the Workstation Installation option
   even if you did not previously run a server installation. Be sure to run
   a server installation before running a workstation installation.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 793-802

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wnetwork wm_word
w4wsetup unavailable configuration





Required Windows Versions for Word for Windows
Article ID: Q94846
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, and 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Microsoft Word 6.0 for Windows requires Windows 3.1 to run.

Microsoft Word 2.0 for Windows requires Windows version 3.0 or later
running in standard or enhanced mode. If Windows 3.0 is installed and
running in real mode, the following message will be displayed when you
try to start Word:

   This application requires standard or enhanced mode Windows.

For additional information about running Windows in real, standard, or
enhanced mode, see the "Microsoft Windows User's Guide."

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wsetup wm_word 
6.00



How to Insert a Paragraph Before a Table at Top of Document
Article ID: Q37857
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c  
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

In Word for Windows, if you create a table at the beginning of  a
document and attempt to insert paragraph marks before the table, the 
paragraph marks are placed in the first cell of the table rather than 
before the table.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

WORKAROUND
==========
 
Use one of the following procedures to insert paragraph marks before a
table at the beginning of a document:

1. Place the insertion point in the top-left cell of the table and
   press CTRL+SHIFT+ENTER.

   -or-

2. Position the insertion point in the first row of the table. From
   the Table menu, choose Split Table. Word inserts a paragraph above
   the table.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 1.x, page 318

Additional reference words: w4wother above w4wtable 1.00 1.10 1.10a 2.00 
2.00a 2.00a-CD 2.00b 2.00c 



Text in Table Appears in Columns in Word for Windows
Article ID: Q47597
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0  
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

If the text in the cells of a table appears in columns instead of
normal lines, the cell of the table may have paragraph formatting that
includes an indent that is larger than the width of the column.

MORE INFORMATION
================

There are two methods to determine and correct this problem:

1. Check the ruler by doing the following:

   a. Select the problem paragraph.

   b. Activate Paragraph mode by pressing CTRL+SHIFT+F10.

   Small triangles appear under the numbers on the ruler. The triangle
   on the right points left, and the triangle on the left points
   right, so that they point at each other. If this is not the case,
   the left paragraph indent is currently set larger than the cell
   width. The left triangle has two parts, which can be moved
   separately. The top section indicates the first-line indent and the
   bottom section indicates the left paragraph indent.

   The triangles can be moved with a mouse or the keyboard. When using
   the keyboard, the LEFT and RIGHT ARROW keys are used to position
   the ruler cursor, represented by a rectangular box on the ruler.
   Once the cursor is moved, do the following:

   a. To change the left or right paragraph indents, press either the
      "L" or "R" key (respectively) to move the indents to the current
      cursor position.

   b. To change the first-line indent, press the "F" key to move the
      first-line indent to the current cursor position.

   Using the mouse to position the left and right indents is
   accomplished by pointing at the appropriate triangle and, holding
   the left mouse button down, dragging it to the new position on the
   ruler, as follows:

   a. To set a first-line indent, move the left indent to the position
      desired for the first-line indent.



   b. To move just the left margin indicator (the bottom section of
      the triangle), hold the SHIFT key down and drag it back to the
      left.

2. Select the problem paragraph. From the Format menu, choose
   Paragraph. If there are measurements in the From Left, From Right,
   or From First Line text boxes in the Indents group box, the
   measurements should be reduced or removed.

If the problem occurs only on the first line of a paragraph, the cause
is a first-line indent that is too large for the cell width.

Additional reference words: 6.00 w4wformat w4wtable 1.00 1.10 1.10a
2.00 wm_word 2.00a 2.00a-CD 2.00b 2.00c



Table Runs into Margin in Word for Windows Print Preview
Article ID: Q49485
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c  
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

The maximum allowable length of a table cell is one page. If a cell
exceeds one page in length, Word for Windows truncates all text beyond
the first page of the cell when it is printed.

In print preview, the table cell appears to run into the bottom margin
of the page. This indicates the cell is longer than the page and will
be truncated when printed. Note that only the text that fits between
the set margins will actually be printed. Word for Windows will not
actually print all the text seen in print preview for the page that
contains the cell.

This problem was corrected in Word version 6.0 for Windows.

Additional reference words: long w4wtable 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c 



Deleting a Table from a Word for Windows Document
Article ID: Q49865
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:
  
After you insert a table into a Word for Windows document file, there
are three ways to delete it:

Word for Windows Versions 2.0 and 6.0
-------------------------------------
   
1. Select the table or section of rows. From the Table menu, choose
   Delete Rows.
  
2. Select the table or section of table. From the Table menu, choose
   Convert Table to Text, and choose either Paragraph Marks, Tabs, or
   Commas. Press ENTER.
  
3. Select the table or section of the table and at least one paragraph
   marker below the table. Press the DEL key.

Word for Windows Version 1.x
----------------------------
    
1. Select the table or a portion of the table. From the Edit menu,
   choose Table (ALT+D A), and choose the Delete button.
  
2. Select the table or section of table. From the Insert menu, choose
   Table To Text (ALT+I T), select Paragraphs from the Convert Table To
   dialog box, and press ENTER.
 
3. Select the table or section of the table and at least one paragraph
   marker below the table. Press the DEL key.

Insert Table To Text converts the table format to text format without
deleting the text contained in the table. Each cell in the table is
converted into a separate paragraph.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 167, 369-370
"Microsoft Word for Windows User's Guide," page 328

Additional reference words: w4wformat w4wtable 1.00 1.10 1.10a 2.00
2.00a 2.00a-CD 2.00b 2.00c



Merging Cells in a Word for Windows Table
Article ID: Q50911
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0  
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:
  
In Microsoft Word for Windows, only cells in the same row can be
merged. Cells that are in different rows cannot be merged. Also, if
cells have been previously merged, you must split the cells and then
remerge them in the desired combination.

More Information:
 
To merge two or more cells in the same row, use the following steps:

Word for Windows Version 2.x and 6.0
------------------------------------
 
1. Select the cells that you want to merge.
 
2. From the Table menu, choose Merge Cells.
 
Word for Windows Versions 1.x
-----------------------------
 
1. Select the cells that you want to merge.

2. From the Edit menu, choose Table, and select Merge Cells.

Reference(s):

"Microsoft Word for Windows User's Guide," page 329
"Microsoft Word for Windows User's Reference," page 368

Additional reference words: w4wtable 1.00 1.10 1.10a 2.00 2.00a
2.00a-CD 2.00b 2.00c 



Aligning Table Columns in Word for Windows
Article ID: Q52071
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Uneven table column widths can be vertically aligned (so that all
table cells have the same width) in Microsoft Word for Windows by
using one of the following methods:

Word version 6.0
----------------

In Word for Windows version 6.0, you can align columns by doing
the following:

1. With the insertion point in a table, do one of the following:

   a. Position the mouse pointer over the column boundary.  When 
      the mouse pointer changes to a double vertical bar, two headed 
      arrow, drag the column boundary to the right or left, or double-
      click the column boundary to automatically resize the column.

   b. Point to the column marker on the horizontal ruler above the
      column boundary you want to adjust.  When the pointer changes
      to a horizontal two headed arrow, hold down the mouse button.  
      Word will display a dotted line that can be dragged right or left.

Word version 2.x
----------------

In Word for Windows version 2.0, follow the steps below:

1. To align columns using a mouse, do the following:

   a. Position the insertion point in the cell to align. From the Table
      menu, choose Select Column.

   b. Click and drag the appropriate gray "T" marker on the ruler until
      the columns of cells are the correct width.

2. To align columns using the keyboard:

   a. Select the entire column by pressing the SHIFT+ARROW keys.

   b. From the Table menu, choose Column Width (ALT+A, W).

   c. Type a measurement for the width of the column.



Word version 1.x
----------------

In Word for Windows version 1.x, follow these steps:

1. To align columns using a mouse, do the following:

   a. Select the column cells or the entire column to align.

   b. Click the ruler view button (|_|_|) on the Toolbar so that the
      table cell markers appear as "T"s on the ruler.

   c. Click and drag the appropriate column or table cell marker until
      the column of cells is the appropriate width.

2. To align columns using a keyboard, do the following:

   a. Select the entire column by pressing the SHIFT+ARROW keys.

   b. Press ALT T, A to bring up the Format Table dialog box.

   c. Enter the column width in the Width Of Column box and select the
      Apply To Selection check box if it is not already selected.

Additional reference words: w4wtable 1.00 1.10 1.10a 2.00 2.00a 6.00 
wm_word 2.00a-CD 2.00b 2.00c



Merged Cells in a Table Cannot Be Merged with Other Cells
Article ID: Q58892
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows versions 1.x, if two cells in a table
are merged together into another cell by choosing the Table command
from the Edit menu and choosing the Merge Cells button, the cell that
contains the merged cells cannot be merged with another cell. The
Merge Cells button will be dimmed (grayed) in the Edit Table dialog
box.

To split previously merged cells, choose Table from the Edit menu and
choose the Split Cells button.

In Word for Windows version 2.0, to merge two cells together choose
the Merge Cells command from the Table menu.  When two cells have been
merged together the Merge Cells command will change to Split Cells if
you try to merge cells that have already been merged.

To split previously merged cells, choose Split Cells from the Table
menu.

This problem was corrected in Word version 6.0 for Windows.

Additional reference words: w4wtable unavailable 1.00 1.10 1.10a 2.00
2.00a 2.00a-CD 2.00b 2.00c



Table Cell Formatting with Borders Is Inconsistent
Article ID: Q60847
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------
 
Summary:

Microsoft Word for Windows is not consistent when formatting borders
in a table. The formatting of a cell will overwrite the formatting of
the cells to the right and left, but may not overwrite the formatting
of the adjacent cells above and below.
 
More Information:
 
The following sample steps reproduce this problem:
 
Example 1
---------

1. Format row 2 with a Single Top border.

2. Format row 1 with a Bottom border of None.

Result: A Single border appears between rows 1 and 2.
 
Example 2
---------

1. Format row 2 with a Single Top border

2. Format row 1 with a Thick Bottom border.

3. Format row 1 with a Bottom border of None.

Result: No border appears between rows 1 and 2.

Additional reference words: w4wformat w4wtable 6.00 wm_word 



Word for Windows: Table Formatting Options are All Blank
Article ID: Q63730
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you select a table column or columns
that contain different row or cell lengths, the options for formatting
the table (Width of Column, Space Between Cols, Indent Rows, and
Minimum Row Height) are left blank. Because the properties of the
selected rows are different, the editing options are left blank.

Reference(s):

"Microsoft Word for Windows User's Reference," version 1.x, pages 371,
372

Additional reference words: w4wtable 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD
6.00 wm_word 2.00b 2.00c



Footnote References Renumbered in Word for Windows Tables
Article ID: Q65846
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When using footnotes in a table, it is possible that the numbering for
individual footnotes may change as new footnotes are added within the
table. This will occur anytime a footnote reference is inserted to the
right and above an existing footnote reference.

This renumbering is automatic and should not cause any problems unless
you make references to the original numbering by directly typing the
reference. When you refer to footnote references in a table, use the
field code FTNREF. This will always reflect the proper footnote
reference as additional footnotes are inserted into the table.

For example, insert the following field to create a cross reference to
a footnote:

   {FTNREF BookmarkName}

In the above example, BookmarkName is a bookmark that you place on the
footnote reference number in the document, not in the footnote pane.

Footnote reference numbering in tables is based on a top-down,
left-to-right scheme. This is because each cell of the table is
considered to be a paragraph. Since it is possible that the table may
be changed to text, the numbering of the footnotes must reflect the
ordering of the paragraphs after conversion to text.

Consider the following sample table. Each entry, ftx, represents the
order in which the footnote references are inserted.

|---------------------------------------------------------------|
|ft1            |ft4            |               |               |
|               |               |               |               |
|---------------------------------------------------------------|
|ft2            |               |               |               |
|               |               |               |               |
|---------------------------------------------------------------|
|               |ft5            |               |               |
|               |               |               |               |
|---------------------------------------------------------------|
|ft3            |               |               |               |
|               |               |               |               |
|---------------------------------------------------------------|

After entering ft3, your footnote reference area would be listed in



the following order, as expected:

   _____________
   1 this is the reference for ft1
   2 this is the reference for ft2
   3 this is the reference for ft3

When ft4 is inserted the numbering will change to the following:

   _____________
   1 this is the reference for ft1
   2 this is the reference for ft4
   3 this is the reference for ft2
   4 this is the reference for ft3

ft4 becomes reference 2 because it is in the row before ft2 and will
be the second paragraph of text when the table is converted to text.

After inserting ft5, the numbering will be as follows:

   _____________
   1 this is the reference for ft1
   2 this is the reference for ft4
   3 this is the reference for ft2
   4 this is the reference for ft5
   5 this is the reference for ft3

ft5 is also in a row above the cell containing ft3.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 749

Additional reference words: w4wfield 2.00a 2.00b 2.00a-cd 2.00c 2.00  
6.00 w4wtable wm_word



Columns Print Crookedly When Aligned Using Spaces in WinWord
Article ID: Q66917
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

If you try to line up columns of text using spaces, the columns may
print unevenly. The usual cause of this problem is that a proportional
font (such as Tms Rmn) is being used. Lining up columns using spaces
and proportional fonts is unpredictable. This is caused by slight
differences in screen and printer fonts or in the case of TrueType,
differences in screen resolution and printer resolution cause rounding
errors that, by the end of a line, may change its width 2-4
characters.

1. Line up the columns using tabs or a table rather than spaces.

2. Use a nonproportional font such as Courier.

Also, make sure that you use a font and point size supported by the
default printer. If Windows is forced to substitute a font, it may
affect the spacing.

Additional reference words: w4wprint w4wtable 2.00 2.00a 6.00 wm_word 
2.00a-CD 2.00b 2.00c



Underlining Superscripted Characters
Article ID: Q69332
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Word for Windows, when you apply underscore character formatting to
a line that contains superscripted characters, the underscore moves up
with the superscripted characters. Although this behavior is by
design, it may not always be the desired effect. This article
describes several methods you can use to keep the underscore in line
with nonsuperscripted text.

This functionality was changed in Word version 6.0 for Windows.

More Information:

To underscore text containing superscripted characters, you can do the
following (in each example, x3 is x cubed, 3 is superscripted):

1. Use overstrike to underline as follows:

   a. Type and underscore text that is not superscripted.
   b. Place the insertion point at the location for the
      superscripted text.
   c. From the Insert menu, choose Field.
   d. Select Formula and then Overstrike.
   e. Insert the superscripted text and one underlined nonbreaking space
      for each superscripted character between the parentheses in the
      field to obtain:

         {eq \O (3,_)}.

      In this example, the three is formatted for superscript.

2. If there is no comma in the expression to be underscored, use the
   Formula Box command as follows:

   a. From the Insert menu, choose Field.
   b. Select Formula and then Box.
   c. Type the expression to be underlined in the field as follows:

         {eq \x \bo(x3)}

      In this example, the three is formatted for superscript.

3. If the superscripted text is on its own line, the text can be put
   into a table as follows:



   a. Highlight text.
   b. From the Insert menu, choose Table.
   c. Select 1 Column and 1 Row.
   d. From the Format menu, choose Table.
   e. Select Border Bottom Single.

4. A more complex solution using the Formula Displace command is as
   follows:

   a. Type and underscore the text preceding the superscripted text.
   b. From the Insert menu, choose Field.
   c. Select Formula and then Displace.
   d. Modify the field to read 

         {eq \d \fon \li()}

      where n is the point size for the superscripted text.

   e. Repeat step b and c.
   f. Modify this field to read 

         {eq \d \ban()}

      where n is the same point size used in the first field.

   g. Type and superscript the text to be superscripted and underlined.
   h. A sample end result for x3 (x cubed) would be

         x{eq \d \fo8 \li()}{eq \d \ba8()}3 

      where x is underscored and 3 is formatted for superscript and 
      8 point size.
   i. Another example: This formula underlines "text", which is
      formatted for superscript. Create the "_" characters, which
      are nonbreaking space characters with underline character
      formatting, by pressing CTRL+SHIFT+SPACEBAR. Select the
      characters and apply underline formatting (press CTRL+U).

         {eq text \d\ba18()______}

      Note: Adjust "text", "18" or "______" for your use.
      
Additional reference words: w4wfield 1.00 1.10 1.10a 2.00 2.00a w4wtable
2.00a-CD 2.00b high low raise lower 



Preventing Page Breaks in Word for Windows Tables
Article ID: Q69415
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Microsoft Word for Windows adds a page break between rows of a table if 
the table is too long to fit on the page. To force Word to keep the 
table together, do the following:

Word version 6.0
----------------

1. Select the table.

2. From the Insert menu, choose Frame.

3. From the Format menu, choose Frame.

4. Type or choose the desired positions in the Horizontal and Vertical
   dialogs.

5. Choose the OK button.

Word versions 1.x, 2.x
----------------------

1. Select the entire table.

2. From the Format menu, choose Paragraph.

3. In versions 1.x, select the With Next check box under Keep Paragraph.
   In versions 2.0 and 2.0a, select the Keep With Next check box under
   Pagination.

More Information:

The maximum length of a single cell or row of cells in a table is one 
page; therefore, even if the table is formatted to be one unit on a 
single page, Word places a page break between rows if a single cell or a 
row of cells is too long to fit between the top and bottom margins of 
the page. To correct this problem, you can adjust the top and bottom 
margins so that the table fits on the page, or you can absolutely 
position the table on the page to override the margin settings. To 
position the table, use the following steps:

Word version 2.x
----------------



1. Select the table.

2. From the Insert menu, choose Frame.

3. From the Format menu, choose Frame.

4. Type or choose the desired positions in the Horizontal and Vertical
   dialogs.

5. Choose the OK button.

Word version 1.x
----------------

1. From the Format menu, choose Position.

2. Under Horizontal, select Left and select Relative To Margin rather 
   than Relative To Column.

Additional reference words: w4wformat 6.00 wm_word 
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 
w4wtable 2.00c



Descenders Cut Off in Table Using Adobe Postscript Cartridge
Article ID: Q69731
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

Character descenders in tables are cut off when printed with the Adobe
PostScript cartridge on a Hewlett-Packard (HP) LaserJet II when
Adobe's Font Foundry software is installed.

Occasionally, the tops and bottoms of ascending or descending
characters may be clipped on the screen; however, they will print
correctly. For more information on this, query on the words:

  clipped
  ascending
  descending
  characters
  word
  windows

More Information:

The Adobe PostScript cartridge comes with PostScript software, which
includes Font Foundry. The Font Foundry installation generates
.PFM font metrics files and inserts corresponding soft font lines into
the printer section of the WIN.INI file as follows:

   Softfonts=n
   Softfont1=c:\psfonts\pfm\po__10H.pfm,c:\pclfonts\po__10H.sfp
   Softfont2=c:\psfonts\pfm\po__12h.pfm,c:\pclfonts\po__12h.sfp
   ...
   Softfontn=c:\psfonts\pfm\po_____.pfm,c:\pclfonts\po_____.sfp

These files are not necessary to print with the PostScript cartridge
from Windows and Word for Windows.  These soft font lines should be
removed from the WIN.INI file for the text to print properly in tables
in Word for Windows.

For further information, contact Adobe Systems, Inc. at (415) 961-4992.

Reference(s):

"User's Guide for the Adobe Cartridge Products," pages 62-66.

Adobe product support technician, (415) 961-4992.

Additional reference words: w4wprint w4wtable 6.00 wm_word 



Centering a Table Horizontally on the Page in Word for Windows
Article ID: Q69861
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, to center a table horizontally (left to
right) on the page, do the following:

Word version 6.0
----------------

1. Place the cursor within a cell of the table.

2. From the Table menu select Cell Height and Width.

3. From the Row dialog set the Alignment button to Center and choose OK.

Word versions 1.x and 2.x
-------------------------

1. Place the cursor within a cell of the table.

2. In Word version 2.0, choose Row Height from the Table menu. In
   previous versions of Word for Windows, choose Table from the Format
   menu.

3. Set the alignment for the rows (Align Rows) to Center.

4. In Word versions 1.x, select Whole Table under Apply To.

More Information:

You can also position a table horizontally on the page with the Format
Position command. To do this, choose Position from the Format menu and
select the following settings:

   Horizontal: Center     Vertical: Inline
   Relative To: Margin    Relative To: Margin

   Paragraph Width: Auto

Note: Using the Format Position command to position the table will
allow text to wrap around the table if there is room.

Additional reference words: w4wformat 6.00 wm_word 
1.0 1.1 1.1a 1.00 1.10 1.10a 2.00 2.00a
w4wtable position



WinWord Err Msg: Error: Illegal Paste into Table
Article ID: Q69945
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

If you try to paste a cell from Microsoft Excel into a Microsoft Word
for Windows table, you will receive one of the following messages:

Word Version 2.x, 6.0
---------------------

You cannot paste this selection into a table

Word Version 1.0, 1.1, or 1.1a
------------------------------

Error: Illegal paste into table

Information from Excel is imported in a table format, and you cannot
insert a table into a table. The information from Excel can be pasted
into any normal paragraph.

Reference(s):

"Microsoft Word for Windows User's Reference," version 1.x, pages
188-194

Additional reference words: w4wexcel w4wtable
1.00 1.10 1.10a  2.00 2.00a 2.00a-CD 2.00b 2.00c



Reversing Rows in a Table in Word for Windows
Article ID: Q70988
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

A quick way to move rows in a table is to use ALT+SHIFT+UP ARROW or
DOWN ARROW.

For example:

1. Select the row that needs to be switched.

2. Press ALT+SHIFT+UP ARROW or DOWN ARROW.

3. The rows will be switched according to the direction of the arrow
   used.

More Information:

This same procedure will work with lines of text or paragraphs. It
will not work, however, with the RIGHT ARROW or LEFT ARROW keys.

Reference(s):

"Inside Word for Windows" by Cobb Group.

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b  
6.00 wm_word 2.00c w4wtable



Formula in Table Produces Error in WinWord
Article ID: Q70990
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If the result of a formula is too long (wide) to fit within a table
cell, "Error!" will display in the Word for Windows table cell.

Text that is typed within a cell will word wrap when the end of the
cell is reached. However, this is not true for the results of
formulas that are entered into table cells.

For example:

   {eq \F(10000,45345)}

If the width of the table cell is set to .5 inch, the above formula
will result in "Error!". If the width of the cell is increased to .75
inch with the Format Table command, the following fraction will
appear:

   10000
   -----
   45345

The width of the table cell needs to be wide enough to accommodate
the result of the entered formula.

Additional reference words: w4wfield w4wtable
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00 wm_word



Line Spacing Changes Row Height of Inserted Table in WinWord
Article ID: Q71512
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

An inserted table in a Word for Windows document bases its row height
on the line spacing values specified in the Paragraph dialog box. (To
access this dialog box choose Paragraph from the Format menu). By
default, Word uses those values found under the current Normal style.
To change this option follow these steps:

1. Select the table.

2. From the Format menu, choose Paragraph and set the values under
   Spacing to the desired height.

Note: The paragraph line spacing option does not affect the value of
the Minimum Row Height option in the Table dialog box (accessed by
choosing Table from the Format menu). Paragraph line spacing affects
the spacing between lines and the height of the table row.

More Information:

In Word version 6.0 for Windows the spacing of a table can be set from
the Table menu by selecting Cell Height & Width and setting the
measurement.

In Word for Windows version 2.0, you access the option to change
the Minimum Row Height by choosing Row Height from the Table menu.

Reference(s):

"Microsoft Word for Window's User's Reference," pages 133 and 254

Documentation for Word for Windows 2.0 will be provided at a
later date.

Additional reference words: 1.0 1.1 1.1a 1.00 1.10 1.10a 2.0 2.00 w4wtable



Creating Side-By-Side Tables in Word for Windows
Article ID: Q71532
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

Word for Windows does not have an automatic feature that allows the
generation of side-by-side tables. It is possible to simulate this
effect with the Format Position command.

PROCEDURE
---------

Word for Windows Version 2.0 and later
--------------------------------------

1. Create a small table (table #1) by choosing the table tool from the
   tool bar, or choose Insert Table from the Table menu.

2. Create another table (table #2) with a paragraph mark between the
   two tables.

3. Select Table #1 by placing the cursor anywhere in the table and
   pressing ALT+Keypad 5, making sure the NUM LOCK key is off.

   -or

   Click with the left mouse button from the first cell in the table
   and drag it to the end of the table.

4. From the Insert menu, choose Frame.

5. Select Table #2 two (as described above) and choose Frame from
   the Insert menu.

Now that you have inserted both tables into a frame, you can click and
drag the tables to whatever position you want while in page view, as
well as position them side by side. The way to know whether or not you
have properly framed the tables is to place your mouse cursor on the
edge of the table and if it turns into a four-way directional arrow,
then you have positioned the table properly.

Word for Windows Version 1.0 and 1.1
------------------------------------

1. Insert the first table into a document.

2. Highlight the table and choose Position from the Format menu. Type



   a number for the Horizontal Position and Paragraph Width and choose
   OK.

3. Insert the second table.

4. Highlight this table and choose Position from the Format menu. Type
   a number for the Horizontal Position that corresponds to the
   position next to the first table. Type a Paragraph Width that will
   allow it to fit alongside the first table and choose OK.

It is also possible to use this technique to simulate tables that have
cells with different heights along the same row. To create this,
follow the steps listed above. Position the tables so that the right
border of the first table is at the same horizontal position as the
left border of the second table, so that they appear as one table.

For another method of creating the side-by-side table effect, query on
the following words:

   table and side and by and word and windows

REFERENCES
==========

"Microsoft Word for Windows User's Reference," page 370

Additional reference words: 6.00 w4wformat 1.00 2.00 2.0 1.10 1.1 1.0
wm_word 1.10a 1.1a w4wtable toolbar



Using the {Autonum} Field Inside a WinWord Table Cell
Article ID: Q72064
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When using the {autonum} field to number several paragraphs inside a
single cell in a table, each paragraph displays the same number.

More Information:

The {autonum} field is used to number paragraphs, incrementing each
new paragraph in sequence automatically. However, when the {autonum}
field is used to number individual paragraphs in a table cell, each
paragraph is numbered with the same number.

Steps to Reproduce Problem
--------------------------

1. Insert a table into a document with any number of rows and columns.

2. Type several paragraphs in one cell of the table. Insert the
   {autonum} field in front of each paragraph in the cell either 
manually
   or using the Utilities Renumber command (in version 1.x).

3. Display the result of the field codes. Note that each
   paragraph is numbered 1.

The same action performed outside a table cell, or with each paragraph
in a different cell produces the expected results of sequentially
numbered paragraphs. The cell is treated as a paragraph in the case of
the {autonum} field code, even though formatting each paragraph in a
cell separately is allowed.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 226-230

Additional reference words: w4wfield 1.00 1.10 1.10a 2.00 6.00
w4wtable wm_word



Can't Toggle Case in Table with SHIFT+F3 or ChangeCase Macro
Article ID: Q72549
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

When you select one or more cells of a table in Microsoft Word for
Windows and attempt to toggle the case of characters by pressing
SHIFT+F3 or running the ChangeCase macro, the computer beeps,
indicating that the command is unavailable.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

WORKAROUND
==========

To use SHIFT+F3 or the ChangeCase macro to change the case of
characters in a table, the text entries must be selected individually
(that is, without selecting the cell marker).

To change all the entries in a table at once, use one of the following
workarounds:

Workaround 1
------------

1. Select the table and the paragraph mark that immediately follows
   the table.

2. Press SHIFT+F3 to toggle the case to the desired format.

Workaround 2
------------

1. Select the table.

2. From the Insert menu, choose Table To Text.



3. Press SHIFT+F3 to toggle the case to the desired format.

4. From the Insert menu, choose Table, select the number of rows and
   columns, and choose the OK button. The text is converted back to table
   format with the desired case.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," version 1.x, page 378

Additional reference words: w4wformat w4wtable w4wmacro  uppercase
lowercase 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Merged Cells in Header Record Causes Error in Print Merge
Article ID: Q72893
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

If you merge two or more cells in the header record (the first row) of
a print merge data table, hidden separators still exist in the merged
cell. The presence of these separators produces an error message
during the print merge. In Microsoft Word for Windows 1.x the error
is:

   Not a Valid Bookmark Name

In Word for Windows 2.x the error is:

   Word has detected a field in the header record which is not valid.
   This error must eventually be corrected in order to complete a
   successful print merge.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

The hidden separators are used by the Split Cells feature of Word.
This feature allows Word to split the cells at the same point that
they merged.

To remove the separators in Word for Windows version 1.0, 1.1, or
1.1a, follow these steps:

1. Select the first row of the table.

2. From the Insert menu, choose Table To Text, and select Comma
   Delimited.



3. Remove the extra comma that appears where the two cells were
   merged. For example:

      FROM    name,addr,state,,zip
      TO      name,addr,state,zip

4. Select the line of text again.

5. From the Insert menu, choose Table.

This procedure converts the text back into the table format and
removes the hidden separators, allowing the print merge to run without
the "Not a valid Bookmark Name:" error.

In Word for Windows version 2.0, the error message box gives you an
option to "Fix Error Now." If you choose this option, Word places the
insertion point in the cell that was merged, but the cell does not
appear to have any errors.

To remove the separator in Word for Windows version 2.0, follow these
steps:

1. Select the First row of the table.

2. From the Table menu, choose Convert Table to Text, and select Comma
   Delimited.

3. Remove the extra comma that appears where the two cells were
   merged. For example:

      FROM    name,addr,state,,zip
      TO      name,addr,state,zip

4. Select the line of text again.

5. From the Table menu, choose Convert Text to Table.

Reference(s):

"Microsoft Word for Windows User's Reference," version 1.x, pages
197-200, 368-370

Additional reference words: 1.00 1.10 1.10a 2.00 w4wmerge 2.0a 2.00a
w4wtable 2.0b 2.0a-CD 2.00b 2.00a-CD



Sort Only Uses First 65 Characters of Sort Key Text in WinWord
Article ID: Q73430
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

The Sort command in Microsoft Word for Windows uses only the first 65
characters of the sort key text to determine the sort order.

The sort key text is the text in a sort record that follows a
specified number of key separators. For example, if a three-column
table is sorted by the second column, column two is the sort key, and
only the first 65 characters of the text in each record in column two
are used to sort the table.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 328-330

Additional reference words: 1.10 1.1a 1.10a 2.00 2.00a 2.00a-CD 2.00b  
6.00 wm_word 2.00c w4wtable



Copying and Pasting Cells Replaces Text in Table in WinWord
Article ID: Q73539
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If a cell marker is included in a table selection when you copy the
contents of a cell in Microsoft Word for Windows, the contents of the
target cell are replaced if you use the Edit Paste command. If you
copy and paste multiple cells into a cell, the copied cells replace
the contents of the target cell and each cell corresponding to the
copied selection.
 
To paste text into a cell without replacing the existing text, you
must select only the text within a cell before copying to the
Clipboard. You cannot select the whole cell. This requires that you
copy and paste the contents of each cell individually.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 361-373

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b  
6.00 wm_word 2.00c w4wtable



Excel Data Pastes into Word for Windows Right Aligned
Article ID: Q75101
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Data from Microsoft Excel will generally paste and paste link into
Microsoft Word for Windows in table format as right-aligned text. This
can cause a problem if you attempt to use tabs within the table.

More Information:

When data is imported from Microsoft Excel, the paragraph format of
the data is right-aligned (default Excel format for numbers).
Therefore, when you insert a decimal tab into a table of cells that
have been pasted or paste linked from Excel, the tab may not
automatically align. In some cases, the data may move into an adjacent
column, until you apply left alignment to those cells.

If you are dealing with tabs in a table and are experiencing some
unpredictable results, verify that the paragraph alignment is set to
left.

Additional reference words: right aligned 1.00 1.10 1.10a 2.00 w4wtable 
6.00 wm_word 



Paragraph Inserted with Paste Linked Spreadsheet from Excel
Article ID: Q75717
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------
Summary:

If you bring a Microsoft Excel spreadsheet into a Microsoft Word for
Windows document using the Paste Link command, a blank paragraph is
inserted above the table. The paragraph mark cannot be selected or
deleted; however, the spacing can be reduced. The blank paragraph does
not appear if you bring the spreadsheet into Word for Windows using
the regular Paste command.

More Information:

Workaround
----------

To reduce the spacing around the inserted paragraph, use the following
steps:

1. Position the insertion point to the left of the paragraph mark.
   (You cannot select the mark only.)

2. From the Format menu, choose Paragraph.

3. Change line spacing from Auto to -0.04 li or -0.01".

Steps to Reproduce Problem
--------------------------

1. Create a spreadsheet in Excel.

2. Select a range of cells to insert into Word for Windows.

3. From the Edit menu, choose Copy.

4. Start Word for Windows. From the Edit menu, choose Paste Link.

5. Choose the OK button.

Note: If the field code is displaying rather than the desired
information, clear the Field Codes command on the View menu. In Word
1.x, also verify that the Show All option is not selected in the
Preferences dialog box.

A blank paragraph is inserted immediately above the table. This
paragraph is not present if the field code is displayed.

Reference(s):



"Microsoft Word for Windows User's Reference," version 1.x, pages
178-179

Additional reference words: 1.0 1.1 1.1a 2.0 2.0a 1.00 1.10 1.10a 2.00 
6.00 wm_word w4wtable 2.00a w4wfield



Format Border From Text Not an Option for Tables
Article ID: Q76465
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, the Border command on the Format menu has 
a From Text option that allows you to set the distance in points between 
the text and the border. This option is available only when placing a 
border around a paragraph. You cannot set a distance from text when 
bordering table cells or pictures. 

When you choose Border from the Format menu to format the border of a
table cell or picture, the From Text option is dimmed (not available).

Additional reference words: grayed greyed 2.00 w4wtable 6.00 wm_word 



Word for Windows Returns Incorrect Number of Columns
Article ID: Q77133
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
---------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, if you select the rows of a column and
the end-of-row markers and choose Table from the Format menu, Word
returns an incorrect result for the number of columns.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Steps to Reproduce Problem
--------------------------

1. From the Insert menu, choose Table to insert a table with one row
   and two columns.

2. Select all the columns in the the row and the end-of-row markers.

3. Choose Format Table.

In Word for Windows 2.0 follow these steps:

1. From the Table menu, choose Insert Table to insert a table with
one row and two columns.

2. Select all the columns in the the row plus the end of row
markers.

3. From the Table menu, choose Column Width.

The dialog box displays the width of columns 1-3, even though only two
columns exist in the table.

Additional reference words: w4wformat 1.00 1.10 1.10a 2.0 2.00 2.0a
2.00a 2.0b w4wtable 2.0a-CD 2.00b 2.00a-CD



\Cell Bookmark Does Not Select Correct Cell in WinWord
Article ID: Q77145
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, the WordBASIC macro language uses the
"\cell" bookmark to select the entire contents of a cell in a table
where you position the insertion point.

If a series of cells are highlighted in a table, the first cell in the
upper-left corner of the highlighted area should be selected. However,
if there are cells in the table to the left of the highlighted area,
the bookmark selects the first cell in the table row that contains the
highlighted area even though that cell was not part of the highlighted
area. This is contrary to the description of the \cell bookmark
described on page 106 of the "Word for Windows and OS/2 Technical
Reference" and on page 89 of "Using WordBasic."

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Steps to Reproduce Problem:
---------------------------

1. Create a 3 x 3 table in Word for Windows and type something in each
   cell.

2. Highlight the rightmost two columns and run the following macro:

      Sub Main
      EditGoTo .destination = "\cell"
      End Sub

3. Notice that an incorrect cell is highlighted.

REFERENCES



==========

"Using WordBasic," page 89

"Microsoft Word for Windows Technical Reference," page 21

"Microsoft Word for Windows and OS/2 Technical Reference," pages
104-106

Additional reference words: w4wmacro w4wtable cmpbookmarks 1.00 1.10
1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Border on Hidden Table is Not Hidden in Word for Windows
Article ID: Q77487
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if a table contains a border and you
format the table as Hidden, the border is not hidden. The border
continues to display and print.

More Information:

Table cell marks cannot be hidden. Because the cell marks also act as
the paragraph mark for the last paragraph in the cell, the paragraph's
properties are also not hidden. Therefore, because borders are a
paragraph property, they cannot be hidden in a table.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 32-34, 153,
371-372

Additional reference words: 1.00 1.10 1.10a 2.00  6.00 wm_word 
w4wtable box frame picture blank 2.00 2.00a 2.00a-CD 2.00b 2.00c



Text Disappears In Table Cell or Frame in Word for Windows
Article ID: Q77685
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you reach the boundary of a frame or
the maximum row height of a table cell, any text that exceeds the
boundary or limit does not display or print.

More Information:

In Word for Windows version 1.x, you can set an exact height for a
table cell with the by choosing Table from the Format menu. Type a
negative measurement in the Minimum Row Height box to set the desired
row height to exactly that positive measurement setting. For example,
if you want a row height of .25-inch, type "-.25" (without the
quotation marks). If the typing in the table cell exceeds the exact
measurement set, the overflow text does not display or print. To
correct this problem, remove the minus sign from the row height
measurement.

In Word for Windows version 2.0, you can set an exact height for a
table cell by choosing Row Height from the Table menu, selecting the
Exactly option in the Height of Row box, and selecting or typing a
measurement for the row height in the At box. As in version 1.x, if
the typing in the table cell exceeds the exact measurement set, the
overflow text does not display or print.

In Word for Windows version 6.0 you can set an exact height for a
table cell by choosing the Table menu and selecting Cell Height 
and Width and then selecting the Exactly option under Height of Rows 
and specifying a measurement for the row height in the At box.  As in 
version 1.x and 2.x, the overflow text does not display or print.

In version 2.0, when overflow text exists in a cell, the bottom gridline 
in the cell darkens and thickens to indicate that the cell is full.  
In version 6.0, the bottom gridline does not darken and thicken to 
indicate the cell is full.  To display overflow text in a table cell in 
Word for Windows versions 2.0 and 6.0, choose Row Height from the 
Table menu and change the Height of Row selection from Exactly
to At Least. To remove overflow text from a frame in version 2.0 and 
6.0, change to normal view and edit the text. You can display overflow
text in a frame in version 2.0 by increasing the maximum frame size.
To do this, choose Frame from the Format menu and adjust the Size
Width and Height settings.

Note: In Word for Windows 2.0 and 6.0, text in a frame that exceeds the 
page boundary does not display in page layout view or print. Frame 



length cannot exceed one page and cannot contain page breaks.

Additional reference words: missing chopped clipped 1.0 1.00 1.1 1.10
6.00 wm_word w4wtable 1.1a 1.10a 2.0 2.00 2.0a 2.00a 2.0b 2.0a-CD
2.00b 2.00a-CD



Paragraph Mark Always Inserted in Field With Table as Result
Article ID: Q77825
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows versions 1.x and 2.x, any field that
displays a table as a result also displays a paragraph mark preceding
the table. The paragraph mark displays because although a field can be
inserted into the middle of a paragraph, a table cannot be contained
within a paragraph. The paragraph mark at the beginning of the field
prevents the table from inserting into the middle of the paragraph.

This paragraph mark cannot be deleted or modified.

Status:

This problem has been corrected in Word version 6.0 for Windows.

More Information:

This behavior makes it impossible to use DDE or DDEAUTO links to an
Excel file to create a data file for use in a Word for Windows print
merge.

For more information on print merge errors caused by DDE or DDEAUTO
links to Excel, query on the following words:

   valid and bookmark and name and dde

Additional reference words: w4wfield w4wmerge 1.00 1.10 1.10a 2.00 1.0
w4wtable 1.1 1.1a 2.0 2.0a 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD



Shading Not Imported into Word for Windows 2.0 from Excel
Article ID: Q77903
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you copy cells from a Microsoft Excel for Windows spreadsheet
through the Clipboard into version 2.x of Microsoft Word for Windows,
the cells do not retain shading. 

This problem was corrected in Word version 6.0 for Windows.

The following are four possible workarounds for this problem:

 - Use the Edit Copy Picture command in Excel to copy a bitmap image of
   the spreadsheet to the Clipboard:

   1. In Excel, select the cells to be copied.

   2. While holding the SHIFT key, choose Copy Picture from the Edit
      menu.

   3. In Word for Windows, paste the Excel selection.

 - In Excel, copy the spreadsheet to the Clipboard:

   1. In Excel, select the spreadsheet to be copied.

   2. From the Edit menu, choose Copy.

   3. From the Edit menu in Word, choose Paste Special, select Picture 
      or Bitmap as the format, and paste the worksheet image as a 
      picture.

 - In Excel, place the spreadsheet in the Clipboard using an OLE server
   application:

   1. In Excel, select the spreadsheet to be copied.

   2. From the Edit menu, choose Copy.

   3. From the Edit menu in Word, choose Paste Special and select Excel
      Worksheet Object.

 - Format the table after you insert it into Word.

More Information:

This problem occurs because Excel does not include the shading when it



places the table on the Clipboard. Word can pull shaded text from the
Clipboard. To illustrates this, follow the steps below:

1. Start Word.

2. Insert a table.

3. Format a cell in the table as shaded.

4. Copy the table to the Clipboard.

5. Quit Word and then restart Word.

6. From the Edit menu, choose Paste to insert the table into a
   document.

The pasted item is shaded. Quitting Word demonstrates that Word can
copy information sufficient to support shading on the Clipboard.

Steps to Reproduce Problem
--------------------------

1. Start Excel.

2. Type some information in a cell.

3. Format the cell as shaded.

4. Copy the cell to the Clipboard.

5. From the Edit menu, choose Paste to insert the cell back into
   Excel. The cell is shaded.

6. Quit Excel and then restart Excel.

7. From the Edit menu, choose Paste again.

The pasted item is not shaded. The information that Excel places on
the Clipboard does not contain shading information in a format that
other applications can use.

Reference(s):

"Microsoft Word for Windows User's Reference," pages 202-203

Additional reference words: w4wformat
link embed dde 2.00  w4wtable



Items Cannot Be Framed Within a Table in Word for Windows
Article ID: Q78150
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you cannot frame items within a table. 
Depending upon the conditions, different results occur when you attempt 
to frame items in a table. The results of four
different scenarios are listed below.

More Information:

Scenario #1 - Framing a Picture with Only the Picture Selected
--------------------------------------------------------------

1. From the Table menu, choose Insert Table, or select the Table
   button on the tool bar. Format the table with two columns and two
   rows.

2. Position the insertion point in a table cell. From the Insert menu,
   choose Picture. Select a picture to insert, and choose the OK button.

3. Select the picture by clicking inside the picture. Small square
   boxes appear around the picture. 

4. From the Insert menu, choose Frame.

Result: The Frame option is not available.

Scenario #2 - Framing a Picture If the Whole Cell is Selected
-------------------------------------------------------------

1. Repeat steps 1 and 2 in Scenario #1. Select the whole cell by
   placing the insertion point before the picture and holding down the
   SHIFT key while you press the RIGHT ARROW key twice, or by clicking
   and dragging the insertion point until the whole cell is selected.

2. From the Insert menu, choose Frame.

Result: The whole row is framed and can be positioned.

Scenario #3 - Selecting the Whole Cell Including Text
-----------------------------------------------------

1. Repeat steps 1 and 2 in Scenario #1. Enter text within a cell and
   select it. With the insertion point at the beginning of the text
   within the cell, press SHIFT+END, or click and drag the mouse until
   the whole cell is selected.



2. From the Insert menu, choose Frame.

Result: The entire row is framed and can be positioned.

Scenario #4 - Selecting Only the Text Within a Cell
---------------------------------------------------

1. Repeat steps 1 and 2 in Scenario #1. Enter text within a cell and
   select the text only (do not include the end-of-cell marker in the
   selection).

2. From the Insert menu, choose Frame.

Result: The Frame option is not available.

Reference(s):

"Microsoft Word for Windows User's Guide," pages 314-323, 393-397

Additional reference words: w4wformat w4wtable 6.00 wm_word 
2.00 2.00a 2.00a-CD 2.00b 2.00c



Border Information not Pasted into Other Cells in WinWord
Article ID: Q78472
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:
 
In Microsoft Word for Windows, cutting and pasting or copying a single
table cell does not carry the cell border information to the new
location in the same table or in a new table.  

More Information:

In Word for Windows version 6.0 and 2.0, cell information is only 
transferred to the Clipboard if you select the entire row before 
choosing Copy from the Edit menu. If you select a single cell and copy 
or cut, only the text information is placed on the Clipboard. This also 
happens with the drag-and-drop method of moving text from one place to
another.

In Word for Windows version 1.x, cell border information is not
preserved for rows or single cells placed on the Clipboard.
   
Note: If you copy or cut a cell and paste the results outside a table,
the cell border information does carry over. This happens in both Word
for Windows versions 1.x, 2.0 and 6.0.

Microsoft has confirmed this to be a problem in Word For Windows. We
are researching this problem and will post new information here as it
becomes available.

References:

"Microsoft Word for Windows User's Guide," version 2.0, page 321
"Microsoft Word for Windows User's Reference," version 1.x, page 366

Additional reference words: 1.00 1.10 1.10a 2.0 2.0a 2.00a 2.0b w4wtable 
6.00 wm_word 2.0a-CD 2.00b 2.00a-CD 



Word for Windows: Updating Fields in a Table
Article ID: Q78523
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:
 
In Microsoft Word for Windows version 2.0, to update a field in a
table, you must select one of the following:
  
   The entire table (ALT+Keypad 5)
 
  -or-
  
   The field to be updated

  -or-
   
   The entire row of cells containing the field
 
If you make any other selections, Word produces a beep, and the
following error message displays on the status bar:
 
  Word cannot update fields in this selection.

In Word for Windows version 1.x, no error message displays; however,
the field does not update unless your selection matches one of those
listed above.

This problem was corrected in Word version 6.0 for Windows.

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 
2.00c w4wtable



Leader Characters Lost When Converting from Table Back to Text
Article ID: Q78666
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you convert tabs with leader
characters to a table, and then convert them back to text, the leader
characters are lost.

Microsoft is researching this problem and will post more information
here as it becomes available.

Additional reference words: dot dash 1.0 1.00 1.1 1.10 1.1a 1.10a 2.0
6.00 wm_word w4wtable 2.00 2.0a 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD



WinWord: Edit Undo Command Is Incorrect After Deleting Columns
Article ID: Q78687
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

After deleting a 1-column table in Microsoft Word for Windows, if you 
view the Edit menu, the Undo command reads "Undo Delete Rows" even 
though you chose Delete Columns from the Table menu.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Steps to Reproduce Problem
--------------------------

1. From the Table menu, choose Insert Table.
 
2. Set the Number of Columns to 1 and the Number of Rows to 2.

3. Choose the OK button.

4. Select the table column.

5. From the Table menu, choose Delete Columns.
 
6. View the Edit menu.
 
The first command on the Edit menu reads "Undo Delete Rows" instead of
"Undo Delete Columns." 

Additional reference words: 2.00 2.00a w4wtable



WinWord Table Inserted into Frame Appears Above Frame Border
Article ID: Q78810
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows version 2.0, if you insert a table into
a frame, Word displays the inserted table above the border of the
frame. Although it may not appear so, the table is contained within
the frame. You can verify this by clicking the frame. Handles should
appear around both the table and the frame's border.

This problem was corrected in Word version 6.0 for Windows.

Steps to Reproduce Problem
--------------------------

1. Open a new document. From the View menu, choose Page Layout.
 
2. From the Insert menu, choose Frame. Click and drag your mouse to
   size the frame.
 
3. Position the insertion point inside the frame. From the Table menu,
   choose Insert Table, and choose the OK button to accept the default
   table settings.
 
Word inserts the table above the frame, and a border displays where
the frame is expected to be.

Workaround
-----------
  
To avoid this awkward display, insert your table first, then select
the table and insert a frame. This results in the table displaying
within the frame borders.

Additional reference words: 2.00 w4wtable



Selecting Table in Outline View Causes Anchor Point to Change
Article ID: Q79000
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you select a portion of a table
using the keyboard while in outline view, the anchor position of the
original insertion point is lost.

More Information:

Steps to Reproduce Problem
--------------------------

1. From the View menu, choose Outline.

2. Type the following lines:

      one
      two
      three

3. Press ENTER. From the Table menu (Insert menu in version 1.x),
   choose Insert Table (Table in version 1.x), and choose the OK button
   to insert a 2-row, 3-column table.

4. Position the insertion point in front of "two."

5. Press SHIFT+DOWN ARROW to select to the bottom of the table, then
   press SHIFT+UP ARROW to clear the selection to the original insertion
   point.

As soon as the selection includes a table row, the anchor position is
lost because that row becomes the new anchor. In outline view, you
cannot clear a selection back to the original insertion point.

Microsoft has confirmed this to be a problem in Word for Windows
version 2.0, 2.0a, 2.0a-CD, 2.0b, 2.0c, 6.0. We are researching this 
problem and will post new information here as it becomes available.

"Microsoft Word for Windows User's Guide," version 2.0, pages 315-318,
441

Additional reference words:  1.00 1.10 1.10a cursor 6.00 wm_word 
w4wtable 2.00 2.00a 2.00a-CD 2.00b 2.00c



Paragraph-Delimited Text Converts to 1-Column Table in WinWord
Article ID: Q79021
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
tem versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows version 2.0, if you select
paragraph-delimited text to insert into a table, Word for Windows
inserts the text into a 1-column table.

This problem was corrected in Word version 6.0 for Windows.

MORE INFORMATION
================

If you select text that is separated by paragraphs, commas, or tabs to
insert into a table, Word for Windows determines the correct number of
columns automatically. However, if the text is separated only by
paragraph marks, Word for Windows will convert the text to a 1-column
table.

Workaround
----------

The following macro prompts you for the number of columns and then
automatically determines the number of rows for the selected text
before inserting the table:

   Sub MAIN
    col$=InputBox$("How many columns?")
    TableInsertTable .ConvertFrom=0, .NumColumns=val(col$)
   End Sub

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 317-318

Additional reference words: w4wmacro w4wtable  toolbar
2.00 2.00a 2.00a-CD 2.00b 2.00c



WinWord: Cannot Use Edit Repeat Table Formatting with Ruler
Article ID: Q79130
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When using the ruler mode and a mouse to format a table in Microsoft
Word for Windows, The Repeat Table Formatting command is not available
on the Edit menu.

More Information:

Steps to Reproduce Problem
--------------------------

Word Version 2.x and 6.x
------------------------
  
1. From the Table menu, choose Insert Table. Specify a 2-column, 
   2-row table, and choose the OK button.
 
2. From the View menu, choose Ruler if it is not already selected. If
   it already checked (selected), press ESC to cancel.

3. The table-width markers display by default.
  
4. Select the first cell of the table, and drag the table-width marker
   on the ruler to change its width.

5. Select the first cell of the second row, and open the Edit menu.
  
The Repeat command on the Edit menu reads "Repeat Insert Table." You
cannot repeat a cell or column formatting change that was made with
the ruler.

Word Version 1.x
----------------
  
1. From the Insert menu, choose Table. Specify a 2-column, 2-row
   table, and choose the OK button.
 
2. From the View menu, choose Ruler if it not already selected. If it
   is already checked (selected), press ESC to cancel.
 
3. Choose the Ruler icon (at the far-right end of the ruler) to
   display the table width markers.
 
4. Select the first cell of the table, and drag the table-width marker
   on the ruler to change its width.



5. Select the first cell of the second row, and open the Edit menu.
  
The Repeat Formatting command is not viewable on the Edit menu.

Microsoft has confirmed this to be a problem in Word for Windows
versions 1.x, 2.x and 6.0. We are researching this problem and will post 
new information here as it becomes available.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 316, 331-
333

"Microsoft Word for Windows User's Reference," version 1.x, page 369

Additional reference words: w4wformat w4wtable 6.00 wm_word 
repeat 2.00 2.00a 2.00a-CD 2.00b 2.00c 1.00 1.10 1.10a 1.1a 6.00 



WinWord: Repeat Key Does Not Remember Original Action
Article ID: Q79178
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, pressing the F4 key repeats
the last action performed. However, if you choose Border from the
Format menu in a table and then press F4 in a paragraph, Word for
Windows repeats the action as a paragraph border instead of a table
border if you press F4 in another table.

More Information:

Steps to Reproduce Problem
--------------------------

1. From the Table menu, choose Insert Table, and choose the OK button.
   Repeat this command so that your document includes two tables. Press
   ENTER several times to insert some blank lines.

2. Select one of the tables. From the Format menu, choose Border,
   select any border, and choose the OK button.

2. Select a blank line, and press F4 to repeat the border in that
   paragraph.

3. Select the second table, and press F4 to repeat the border.

Word for Windows formats the second table with a paragraph border (the
border surrounds around each cell), rather than a table border.
Pressing F4 in a paragraph changes the attributes of the Format Border
command from a table orientation to paragraph orientation.

Microsoft is researching this problem and will post new information
here as it becomes available.

Additional reference words: 2.00 w4wtable 6.00 wm_word 



Inserting a Frame Around a Table Row in Word for Windows 2.0
Article ID: Q79188
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, framing a row in a table
may rearrange the contents of the entire table. The default formatting
for frames includes text wrapping around the frame; therefore, the
next row may wrap around the inserted frame.

Steps to Reproduce Problem
--------------------------
    
1. From the Table menu, choose Insert Table. Set up a 1-column, 3-row
   table, and choose the OK button.
    
2. From the Table menu, choose Cell Height and Width (Column Width in 
   Word 2.0), set the column widths to 2 inches, and choose the OK 
   button.
 
3. Select the second row. From the Insert menu, choose Frame.
 
The third row wraps to the right of the second row.

Workaround
----------
 
To work around this problem, insert the frame around the row. With the
frame selected, choose Frame from the Format menu, and choose None
(ALT+N) for Text Wrapping.

Additional reference words: 2.00 w4wtable 6.00 wm_word 



Tables with 11 or 13 Columns Create Multiple Series Graphs
Article ID: Q79232
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:
 
In Microsoft Word for Windows version 2.0, graphs based on tables with
11 or 13 columns display more than one data series.

This problem is corrected in Word version 6.0 for Windows.
 
Steps to Reproduce Problem
--------------------------
  
1. From the Table menu, choose Insert Table. Set up a 1-row, 11-column
   table, and choose the OK button.

2. Type a number in each of the cells of the table.
  
3. From the Table menu, choose Select Table.
    
4. From the Insert Menu, choose Object, select Microsoft Graph, and
   choose the OK button.
   
Word for Windows includes a second data series on the graph. This
series begins with the representation of column 11 following the
representation of the column 1. The column 11 representation displays
in a different color than the first data series.

Additional reference words: 2.00 chart w4wtable



Screen Scrolls When Moving Cursor into a Tall Table Cell
Article ID: Q79281
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, pressing the arrow keys to move into a
table that includes a tall row of cells may cause the screen to
scroll; however, the insertion point does not move until you press the
arrow key several times.

More Information:

Steps to Reproduce Problem
--------------------------
 
Word for Windows Version 2.0
----------------------------
  
1. From the Table menu, choose Insert Table, and create a 3-row,
   3-column table. Choose the OK button.
  
2. Type a long paragraph (30-40 words) in the bottom middle cell.
 
3. Press CTRL+END to move to the end of the document.
 
4. Press the UP ARROW key.
 
Word for Windows Version 1.x
----------------------------
 
1. From the Insert menu, choose Table, and create a 3-row, 3-column
   table. Choose the OK button.

2. Type a long paragraph (30-40 words) in the bottom middle cell.
 
3. Press CTRL+END to move to the end of the document.

4. Press the UP ARROW.

Microsoft has confirmed this to be a problem in Word for Windows
versions 1.0, 1.1, 1.1a, and 2.0. This problem is corrected in
Microsoft Word version 6.0 for Windows.
 
Additional reference words: 1.0 1.1 1.1a 1.00 1.10 1.10a 2.00 w4wtable



WinWord: Page Setup Selects Additional Area of Table
Article ID: Q79331
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows version 2.x, if you choose Page Setup
from the Format menu with the insertion point in a table, Word for
Windows selects either a complete row or additional rows.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Steps to Reproduce Problem
--------------------------

1. From the Table menu, choose Insert Table. Create a 3-row, 3-column
   table, and choose the OK button.

2. Position the insertion point in the second row of the table. From
   the Table menu, choose Select Row. Note that only row two is 
selected.

3. From the Format menu, choose Page Setup.

4. Choose either the Cancel button or the OK button.

Both the second and third rows are now selected. If the insertion
point is active in only one cell of the table, Word selects the entire
row containing that cell when you choose Page Setup.

Microsoft has confirmed this to be a problem in Word for Windows
version 2.x. This problem was corrected in Word version 6.0 for Windows.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 230, 320

Additional reference words: w4wformat 2.00 2.00a 2.00a-CD 2.00b 2.00c 
w4wtable



Revision Bars Display and Print on Top of Text in the Margin
Article ID: Q79385
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, revision marks print over text that 
extends into the document's margins.

More Information:

If you select the Mark Revisions option in the Revision Marks dialog
box and select Left, Right, or Outside in the Revision Bars box,
revision marks display and print slightly outside of the document's
margin. If the document's text or table cells extend into the margins
(as with a negative left or right paragraph indent), the revision
marks print over the top of the text that extends into the margins.

Steps to Reproduce Problem
--------------------------
 
1. From the View menu, choose Page Layout unless it is already chosen.
   If it is already chosen, press ESC.

2. From the Tools menu, choose Revision Marks.

3. In the Revision Bars box, select Right, select the Mark Revisions
   box, and choose the OK button.

4. From the Table menu, choose Insert Table. Choose the OK button to
   accept the default table settings.

5. Position the insertion point in the farthest right-hand column of
   the table. From the Table menu, choose Column Width. Add an inch to
   the column's width, and choose the OK button. (For example, if the
   column width is 3 inches, change it to 4 inches).
 
6. Type text in one cell of the column until the text wraps several
   lines.

The revision bar now appears as a vertical line through the text to
the right of the cell. If you set the Revision Bar box to Left, the
revision bar displays over the top of text or table cells that extend
beyond the left margin. The printout and print preview view have a
display similar to to page layout view.

Microsoft has confirmed this to be a problem in Microsoft Word for
Windows versions 2.0 and 6.0. We are researching this problem and will 
post new information here as it becomes available.



Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 604-605

Additional reference words: 2.00 overstrike border w4wtable 6.00 wm_word 



Cell Border May Cause Distortion of WinWord Table
Article ID: Q79451

--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows version 2.0, if a table contains shaded
borders and cells, the shaded cells may appear distorted, and the
table may not adjust to accommodate the borders on-screen or in the
printed output.  This occurs in version 3.0 and 3.1 of Windows.

In Microsoft Word for Windows version 2.0, if a table contains shaded
borders and cells, the shaded cells may appear distorted, and the
table may not adjust to accommodate the borders on-screen or in the
printed output. This occurs both in Windows 3.0 and Windows 3.1.

This problem was corrected in Word version 6.0 for Windows.

Steps to Reproduce Problem
--------------------------

1. Open a New document. From the Table menu, choose Insert Table.

2. Create a 3-column, 3-row table, and choose the OK button.

3. Select columns 1 and 2. From the Format menu, choose Border, and
   then choose the Shading button.

4. Select the Custom option. In the Patterns box, select 30%, and
   choose the OK button twice.

5. Select column 3. From the Format menu, choose Border, and select a
   thick border from the Line box. Choose the OK button.
 
6. From the Table menu, remove the table gridlines by clicking the
   Gridlines command.

Extra shading may appear at the top of the cells without borders.
Also, the space identifying the break between the two columns of cells
without borders does not extend to the top of the table.
 
Remove the table gridlines for an accurate representation of what will
actually print. The table may or may not print with distortion
depending on how the table is formatted with shading and/or borders.

Microsoft is researching this problem and will post new information
here as it becomes available.



Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 377-379

Additional reference words: 2.00 w4wtable



WinWord: Page and Column Breaks Inserted into Table Cell
Article ID: Q79493
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you delete the paragraph mark between
a page or column break and a table, Word moves the page or column
break into the first table cell as a block symbol.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Page breaks and column breaks do not store paragraph properties and
are not treated as paragraph marks. If you remove a paragraph mark,
Word moves the page break or column break into the first cell of the
table as a block character. Section breaks do store paragraph
properties and are treated as paragraph marks; therefore, they do not
exhibit this problem.

Steps to Reproduce Problem
--------------------------

1. Open a new document.
 
2. From the Insert menu, choose Break, select Page Break, and choose
   the OK button.
   
3. From the Table menu in version 2.0, choose Insert Table, accept the
   default settings, and choose the OK button. From the Insert menu in
   version 1.x, choose Table, accept the default settings, and choose
   the OK button.

4. Select the paragraph mark immediately above the table and delete
   it.

A block symbol appears in the first cell of the table.

Microsoft has confirmed this to be a problem in Word for Windows
versions 1.0, 1.1, 1.1a, and 2.0. This problem was corrected in Word 
version 6.0 for Windows.

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 
2.00c w4wtable



GetBookmark$() Used with EditGoto Returns Incorrect Value
Article ID: Q79559
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, using the WordBasic commands
GetBookmark$() and EditGoto with the \Cell bookmark returns the cell
value of the previous column. It should return the cell value of the
current column.

This problem was corrected in Word version 6.0 for Windows.

More Information:

Workaround
----------

The following WordBasic macro yields the contents of the current
column instead of the contents of the previous column:

   Sub MAIN
   If PrevCell() Then NextCell
   Print GetBookmark$("\Cell")
   End Sub

Steps to Reproduce Problem
--------------------------

The following macro illustrates this problem:

1. From the Table menu, choose Insert Table (in version 2.0). From the
   Insert menu, choose Table (in version 1.x). Insert a 2-column, 1-row
   table, and type some text in each cell. Select the second cell.

2. From the Tools menu, choose Macro, and type a name for a new macro.
   Choose the Edit button.

3. Type the following macro in the macro editing window:

      Sub MAIN
      EditGoto .Destination = "\Cell"
      Print GetBookmark$("\Cell")
      End Sub

4. From the File menu, choose Close. Choose Yes when prompted to save
   changes to the macro.

5. From the Tools menu, choose Macro. Select the macro you just



   created, and choose the Run button.

6. Notice the value displayed in the status bar is from column 1, not
   column 2.

Microsoft has confirmed this to be a problem in Word for Windows. This 
problem was corrected in Word version 6.0 for Windows.

Reference(s):

"Microsoft Word for Windows and OS/2 Technical Reference," pages 156-
157, 192, 226, 238, 241

"Microsoft Word for Windows Technical Reference," pages 42, 62, 78,
83-84

Additional reference words: w4wmacro 1.x 1.00 1.10 1.10a 2.00 2.0a
w4wtable 2.00a 2.0b 2.0a-CD 2.00b 2.00a-CD



WinWord: Calculating Table Values Relative to Current Cell
Article ID: Q79586
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Word for Windows, you can use fields to calculate values in table
cells. You can also reference the cells relative to the cell
containing the field so that rows or columns can be deleted from or
added to the table without affecting the resulting calculation.

More Information:

The Expression field is used to perform mathematical calculations. For
example, if you have the following table

   --------------------------------
   |   1   |   2   |   3   |      |
   --------------------------------
   |   4   |   5   |   6   |      |
   --------------------------------

and you want to insert the row totals in the fourth column, you can
insert the following field in the last cell of each row:

   {=sum([rc-3:rc-1])}

Note: To create the field braces, press CTRL+F9.

This field calculates the sum of the values in the current row. To do
this, the field adds the values from two columns to the left of the
current column through the entire current row (one column to the left
of the current column). The references to the cells that you add are
relative to the cell containing the field.

This method allows you to add or delete rows and maintain a correct
sum; you can also add or delete columns without affecting the
calculation.

To total all cells in the current row except the row containing the
field total, insert the following field in the cell where you want the
total to appear:

   {=sum([c])-sum([rc])}

The advantage of this expression is that you do not need to modify it
if you add or delete columns from your table.

In Word for Windows 6.0, this feature can be accessed through the 



Table... Formula menu.  This gives the option to choose relative cells 
to the left, right, above, and below the current cell.  For more 
information, see the online help.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 306-308

"Microsoft Word for Windows User's Reference," version 1.x, pages
95-96

Additional reference words: w4wfield w4wtable 6.00 wm_word 
add subtract multiply divide  relation math
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Numbering Columns or Creating Page Numbers for Folded Pages
Article ID: Q79592
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you can number the columns on a
multiple-column page by inserting field codes in the document's header
or footer. Using this method, you can simulate the pagination of
folded pages (as for a brochure, pamphlet, booklet, leaflet, or program).

More Information:

You can achieve the numbering scheme diagrammed below by inserting the
following line at the left edge of your document's header or footer

   {={page}+{={page}-1}*1+0}

and the following line at the right edge of the header or footer:

   {={page}+{={page}-1}*1+1}

The results are as follows:

           page 1                    page 2
    -------------------       -------------------
   | pg 1    .    pg 2 |     | pg 3    .    pg 4 |
   |         .         |     |         .         |
   |         .         |     |         .         |
   |         .         |     |         .         |
   |         .         |     |         .         |
   |         .         |     |         .         |
   |         .         |     |         .         |
    -------------------       -------------------

You can use the following generic formula to simulate page numbering
for any number of columns:

   page + ((page-1) * n) + m

In this formula, "page" equals the current page field value, "n"
equals the number of columns - 1, "m" equals the column position - 1,
and the first column starts at zero. Insert the above formula in the
header or footer, positioning each formula at the desired location
above or below the appropriate column.

For two-column page numbering, use the following formula:

   {={page}+{={page}-1}*1+0}  1,3,5,...



   {={page}+{={page}-1}*1+1}  2,4,6,...

For three-column page numbering, use the following formula:

   {={page}+{={page}-1}*2+0}  1,4,7,...
   {={page}+{={page}-1}*2+1}  2,5,8,...
   {={page}+{={page}-1}*2+2}  3,6,9,...

For four-column page numbering, use the following formula:

   {={page}+{={page}-1}*3+0}  1,5,9,...
   {={page}+{={page}-1}*3+1}  2,6,10,...
   {={page}+{={page}-1}*3+2}  3,7,11,...
   {={page}+{={page}-1}*3+3}  4,8,12,...

If you want the numbering to start with 0 for the first column, make
the following changes:

1. In the first formula, change the starting value of "m" to equal the
   value of "n" used in that formula. Increase "m" by increments of 1 in
   each additional formula (as in the original formula examples).

2. From the View menu, choose Header/Footer. Choose the Page Numbers
   button. Change the Start At value to 0.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 421-431

"Microsoft Word for Windows User's Reference," version 1.x, pages
246-247

"Take Word for Windows to the Edge," (ISBN 1-56276-079-3) by Guy
Gallo, Ziff-Davis Press, page 362

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
6.00 wm_word w4wtable 2.00c w4wfield table same multiple



Insert Table Appears Available with Framed Row Selected
Article ID: Q79638
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows version 2.0, if you insert a frame
around a row of a table, the Insert Table option on the Table menu
should appear gray to indicate it is unavailable; however, the command
appears black, even though it is not an available command.

This problem was corrected in Word version 6.0 for Windows.

Steps to Reproduce Problem
--------------------------

1. From the Table menu, choose Insert Table, and choose the OK button
   to accept the default settings.

2. Select a row of the table.

3. From the Insert menu, choose Frame. If Word prompts you to switch
   to page layout view, choose the Yes button.

4. From the Table menu, choose Insert Table.

Nothing occurs when you choose Insert Table; no error message
displays. This option should appear gray to indicate that the command
is not available.

Microsoft has confirmed this to be a problem in Word for Windows
version 2.0. This problem was corrected in Word version 6.0 for Windows.

Additional reference words: 2.00 w4wtable



WinWord: Inserted Objects Marked as Revisions to the Document
Article ID: Q79740
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, inserted tables and pictures are
flagged as revisions if you select the Mark Revisions option. In Word
for Windows version 6.0 and 2.0, inserted objects and frames are also 
flagged
with revision marks.

More Information:

If you select the Mark Revisions option and insert a table, picture,
object, or frame, Word for Windows flags the resulting insertion as a
revision to the document. However, the Mark Revisions option does not
flag any formatting changes applied to existing characters,
paragraphs, or borders.

Steps to Reproduce Problem
--------------------------

1. Open an existing document.

2. From the Tools menu (in version 6.0 and 2.0), choose Revision Marks. 
   From the Utilities menu (in version 1.x), select Revision Marks.

3. Select the Mark Revisions option, and choose the OK button.

4. From the Table menu (in version 6.0 and 2.0), choose Insert Table. 
   From the Insert menu (in version 1.x), choose Table. Accept the 
   default settings, and choose the OK button.

Word for Windows flags the inserted table with revision marks.

Additional reference words: 1.0 1.1 1.1a 1.00 1.10 1.10a 2.00 w4wtable 
6.00 wm_word 



WinWord: Table Cannot be Selected from the Style Area
Article ID: Q79785
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you cannot manipulate or select a table 
from within an expanded style area.

More Information:

Steps to Reproduce Problem
--------------------------
 
1. Open a Word for Windows document. From the View menu, choose
   Normal.
 
2. From the Tools menu, choose Options. Select the View category, and
   set the Style Area Width to 1". Choose the OK button.
 
3. From the Table menu, choose Insert Table, and choose the OK button
   to accept the default settings.
 
4. Position the mouse pointer above the left border of the table until
   it becomes a column marker. Hold down the left mouse button, and drag
   the column marker into the style area.

At this point, the table cannot be selected from the style area.
Clicking the mouse makes the cursor become a column marker.

Microsoft is researching this problem and will post new information
here as it becomes available.

Additional reference words: area split line pointer 2.00 w4wtable 6.00 
wm_word 



Paragraph Indenting Produces Incorrect Results in Tables
Article ID: Q79866
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you press CTRL+T, CTRL+G, CTRL+M, or
CTRL+N with one or more cells selected in a table, the entire row or
group of rows containing the selected cells takes on the indent
formatting. If you select an entire column, the whole table becomes
formatted with the indent.

This problem was corrected in Word version 6.0 for Windows.

More Information:

CTRL+T produces a hanging indent, and CTRL+G cancels a hanging indent.
CTRL+N nests paragraphs, and CTRL+M removes nested paragraphs. These
key combinations affect the selected paragraph(s) or the paragraph
containing the insertion point when you press the key combination.

If you select more than one cell in a table, the entire row or group
of rows containing the selected cells is indented to match the
formatting of the selected cells. If you select an entire column of
text, then the entire table is indented to match the formatting of the
selected cells; however, if you use the mouse to format the paragraphs
by moving the first line indent and paragraph indent markers on the
ruler, only the selected text is affected. To adjust indents on the
ruler, the ruler must be in the mode that displays the triangular
indent markers.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 166-177,
322-323

"Microsoft Word for Windows User's Reference," version 1.x, pages
361-372, 404-405

Additional reference words: w4wformat
indentation align alignment 1.0 1.00 1.1
w4wtable 1.10 1.1a 1.10a 2.00



WinWord: Cannot Insert a Bookmark with a Table Column Selected
Article ID: Q80025
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you select a column in a Microsoft Word for Windows table, you
cannot insert a bookmark into the document. This limitation occurs
because a table column is not contiguous.

A bookmark must be contiguous text. If you have a 2-column, 2-row
table and you select the first column only, the Insert Bookmark
command is dimmed (unavailable). The same result occurs if you select
the second column only. You must select the entire table, a complete
row, or a group of complete rows to access the Insert Bookmark
command.

Additional reference words: 1.x 1.0 1.1 1.1a 2.0 1.00 1.10 1.10a 2.00 
6.00 wm_word w4wtable



Table Cell Greater Than One Page Will Print Over Footer
Article ID: Q80308
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows versions 1.x and 2.0, text contained in
a footer will be over-printed if you have a single-row table
containing text that extends past the footer's position. Single-row
tables will allow you to add text without breaking to another page.
Word will continue to print this text on a single page until it
reaches the unprintable region, as defined by the printer driver.

STATUS
======

This problem was corrected in Word version 6.0 for Windows.

Steps to Reproduce Problem
==========================

In Word for Windows 2.0
-----------------------

1. Open a new document in Normal view.

2. From the View menu, choose Header/Footer. Select Footer and choose
   the OK button. Enter some sample text and choose the Close button.

3. From the Table menu, choose Insert Table. Accept the defaults and
   choose the OK button.

4. Within the table, type in text until the text extends past the
   footer position on the page. The Status Bar will show the current
   insertion point position. On a standard 8.5-inch x 11-inch sheet of
   paper, any text running past the 11-inch position is sufficient for
   this operation.

5. From the File menu, choose Print Preview. The text within the table
   cell will overlap and combine with the text from the footer. It
   will print the way it looks in Print Preview.

In Word for Windows 1.x
-----------------------

1. Open a new document in Normal view.

2. From the Edit menu, choose Header/Footer. Select Footer and



   choose the OK button. Enter some sample text and choose the Close
   button.

3. From the Insert menu, choose Table. Accept the defaults and choose
   the OK button.

4. Within the table, type in text until the text extends past the
   footer position on the page. The Status Bar will show the current
   insertion point position. On a standard 8.5-inch x 11-inch sheet of
   paper, any text running past the 11-inch position is sufficient for
   this operation.

5. From the File menu, choose Print Preview. The text within the table
   cell will overlap and combine with the text from the footer. It
   will print the way it looks in Print Preview.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 314-316.

"Microsoft Word for Windows User's Reference," version 1.0, pages
367 and 369.

Additional reference words: 1.00 1.10 1.10a 2.00 w4wtable



WinWord: Page Width Zoom Doesn't Display Items Beyond Margins
Article ID: Q80427
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows versions 2.X and 6.0, when you choose the
Page Width button in the Zoom dialog box, Word for Windows does not 
display any portion of the document that extends beyond the margins.

More Information:

If you run the Zoom command and choose the Page Width button, Word for
Windows scales the editing view so you can see the width of the page,
from left margin to right margin. If Word calculated the Zoom
percentage so that you could see everything that might extend past the
margins, the processing time would be increased. Word is designed to
not display items that extend beyond the margins.

Workaround
----------

In Word for Windows 6.0, to view items that extend beyond the margins in 
a Word for Windows document, from the View menu, choose Zoom and select 
the Page Width "Zoom To" selection.  Choose the OK button. In Word for 
Windows 2.0, choose Zoom from the View menu, select either a Custom 
setting or the Whole Page button.

Steps to Reproduce Problem
--------------------------
 
1. From the File menu, choose New, and choose the OK button. From the
   Table menu, choose Insert Table, select 7 in the Number of Columns
   box, and choose the OK button.

2. From the Table menu, choose Select Table.

3. In  Word for Windows 6.0, from the Table menu, choose Cell Height and 
   Width. Select the column tab and set the width of Columns to 1".  
   Choose OK. In Word for Windows 2.0, from the Table menu, choose 
   Column Width, select 1" in the Width of Columns box, and choose the 
   OK button.

4. In Word for Windows 6.0, from the View menu, choose Zoom and select 
   the Page Width "Zoom To" selection. In Word for Windows 2.0, from the 
   View menu, choose Zoom, and choose the Page Width button. Choose the 
   OK button.

The page is zoomed so that both margins fit on the screen. The right



columns of the table are not completely visible because they extend
beyond the right margin.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 453-456

Additional reference words: 2.00 w4wtable 6.00 wm_word 



WinWord: Edit Go To Command May Produce Error Message
Article ID: Q80549
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows versions 1.x and 2.x, if you insert a
2-column, 3-row table, select the first row, and press the Go To key
(F5), you receive the following error message when using the \sel
command:

   This Bookmark does not exist

You can choose Go To from the Edit menu in versions 1.x and 2.x to use
the Go To command. In Word for Windows versions 1.1 and 1.1a, the
opposite is true. Pressing the F5 key works correctly; however, if you
choose Go To from the Edit menu, Word for Windows versions 1.1 and
1.1a generate the above error message.

This problem was corrected in Word version 6.0 for Windows.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, page 96

"Microsoft Word for Windows User's Reference," version 1.x, page 19

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c w4wtable



WinWord: Changing Column Width Without Resizing Entire Table
Article ID: Q80550
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows version 2.0, you can change the column
width for a cell or group of cells without changing the width of the
entire table. To do this, use the following steps:
  
1. Select the cell or group of cells for which you want to change
   column width.
  
2. Select to the column gridline to the right of the cell or group of
   cells. (The mouse pointer becomes a double arrow after a successful
   selection.)
 
3. Hold down the SHIFT key, and drag the gridline to its new location.

In Word for Windows 6.0, it is not necessary to hold SHIFT to retain the 
entire table width while changing the width of a column or columns in 
the table.

Reference(s):
 
"Microsoft Word for Windows User's Guide," version 2.0, pages 331-335

Additional reference words: 2.00 w4wtable



WinWord: Cell Line Layout Lost When Converting Table to Text
Article ID: Q80598
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you convert a multicolumn table to
text, the layout will be lost if the table contains one or more cells
with text that wraps around to another line.

More Information:

In Word for Windows version 2.x and 6.0, you can convert a table to
text by selecting the table and choosing the Convert Table to Text
command from the Table menu. In Word for Windows versions 1.x, you can
do this by choosing the Table To Text command from the Insert menu.

To preserve the line layout of the table, save it in "text with
layout" format. (In the Word 2.0 File Save As dialog box, select the
Text With Layout (*.ans) option; in the Word 1.x File Save As dialog
box, select the Text With Layout (PC-8) option). Then, open the text
with layout file and convert it to normal Word format.

Example
-------

----------------------------------------------------------------|
|one|two                                    |three|four|five|six|
|---------------------------------------------------------------|
| 1 |now is the time for all good men to    |  3  |  4 |  5 | 6 |
|   |come to the aid of their party.  now is|                   |
|   |time for all good men to come to the   |                   |
----------------------------------------------------------------|

If you select this table and convert it from Table to Text, the
resulting text will look like the following:

one                  two        three   four    five    six
  1     now is the time for all good men to come to the aid of their party.
now is the time for all good men to come to the 3   4   5   6

Note: The multiple-line cell that wrapped within the table cell now
wraps across the entire line, distorting the original appearance of
the text.

If you save the table in text with layout format, it retains its
appearance when it is reopened and converted to normal Word format, as
follows:



one     two                             three   four    five    six
1       now is the time for all           3     4       5       6
        good men to come to the
        aid of their party.  Now
        is the time for all good
        men to come to the

Note: In Word 1.x, after you save the document using the Text With
Layout (PC-8) option, when you open it again, Word suggests that you
convert from Text Only format. Make sure you change the selection to
Text With Layout (PC-8) so Word will perform the correct conversion.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 318,
675-676

"Microsoft Word for Windows User's Reference," version 1.x, pages 99,
121, 283, 366, 369-370

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c conv w4wtable



Word for Windows: Adjusting Merged Cell Widths in a Table
Article ID: Q80599
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

When cells are merged in a table in Microsoft Word for Windows
versions 1.x and 2.0, the resulting merged cell will be formatted in
the same manner as the first column selected in the merge. For
example, if columns 1, 2, and 3 of a row are merged into a single
cell, the resulting cell will take on the characteristics of column 1
for all future formatting changes performed using the mouse.

When the mouse is used to adjust column widths, the entire column will
be affected unless only one cell is specifically selected. When the
menus are used to adjust column widths, the change will be made only
to the cell that the cursor is in or to the cell(s) that are selected.

Microsoft has confirmed this to be a problem in Word for Windows
versions 1.x and 2.0. We are researching this problem and will post
new information here as it becomes available.

More Information:

Steps to Reproduce Problem
--------------------------

1. In Word for Windows 2.0 and 6.0, choose Insert Table from the Table 
   menu. Enter 3 for the number of columns and 3 for the number of rows.
   Leave the column width set to auto. Choose the OK button. In Word
   for Windows 1.x, choose Table from the Insert menu.

2. Select the cells in row 2 column 1 and row 2 column 2.

3. In Word for Windows 2.0 and 6.0, choose Merge Cells from the Table 
   menu. In Word for Windows 1.x, choose Table from the Edit menu, then
   choose the Merge Cells button.

4. Place the cursor in row 1 column 1. In Word for Windows 2.0, choose
   Column Width from the Table menu. In Word for Windows 1.x, choose
   Table from the Format menu. Type ".5" for the width of column 1.
   Choose the OK button.

   Note that only the one cell's width is affected. Rows two and three
   have not changed at all.

   In Word for Windows 6.0, choose Table/Cell Height and Width/Column.
   Change the width of column 1 to ".5".  Press the OK button.  The 
   result will change the entire first column's width changes.  By 



   selecting the cell first and performing the same steps as indicated 
   above, the other cells and row widths will not be affected.

5. In Microsoft Word for Windows 2.0 and 6.0, choose Undo Column Width
   from the Edit menu. In Word for Windows 1.x, choose Undo Edit Table 
   from the Edit menu.

6. With the cursor still in row 1 column 1, position the mouse pointer
   on the column separator of row 1 column 1 and row 1 column 2. Note
   that the pointer changes to a gridline cursor in Word for Windows
   2.0. With this cursor, click and drag the column separator to the
   left about half an inch. In Word for Windows 1.x, click the column
   marker (or "T") on the ruler and drag it to the left about half an
   inch.

In Word 1.x and 2.0, the entire first column's width changes. This was 
fixed in Word for Windows 6.0 so that the merged cells are not affected
at all.If you first select just the row 1 column 1 cell before dragging 
the column separator, the other rows will not be affected in any version 
of Winword.

To prevent the entire first column's width from changing in Word 2.0,
hold the shift key down while performing the same steps as above.

Additional reference words: 1.00 1.10 1.10a 2.00 1.0 1.1 1.1a w4wtable 
6.00 wm_word 



WinWord: Replace Command Doesn't Change Table Formatting
Article ID: Q80612
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

If you create a table that does not contain any text in Microsoft Word
for Windows and then apply paragraph formatting to it, the Edit
Replace command does not replace the formatting. Formatting in an
empty table cell is retained in the end-of-cell marker rather than the
paragraph mark. The Replace command identifies formatting contained
only in text or paragraph markers.

To work around this problem, you can manually select the table and
change the formatting characteristics.

More Information:

Steps to Reproduce Problem
--------------------------

Word for Windows Version 2.0
----------------------------

1. From the File menu, choose New, and choose the OK button.

2. From the Tools menu, select Options. From the Category list, select
   the View icon, and select the Table Gridlines and All options. Choose
   the OK button.

3. Type some text in the document, and press ENTER.

4. From the Table Menu, choose Insert Table. Accept the default
   values, and choose the OK button.

5. Select the entire document by pressing CTRL+Keypad 5.

6. From the Format menu, choose Character, select Bold, and choose the
   OK button. The entire document has bold formatting.

7. From the Edit menu, choose Replace. In the Find What box, press the
   CTRL+B key combination to search for bold formatting. The word "Bold"
   appears below the selection box. In the Replace With box, press the
   CTRL+I key combination to replace with italic formatting. The word
   "Italic" appears below the selection box. Choose the Replace All
   button and then the Close button.

8. All of your text and paragraph marks now have italic formatting;
   however, if you type text within one of the blank table cells, the



   text has bold formatting.

Word for Windows Version 1.x
----------------------------

1. From the File menu, choose New, and choose the OK button.

2. From the View menu, choose Preferences. Select the Table Gridlines
   and Show All options. Choose the OK button.

3. Type some text in the document, and press ENTER.

4. From the Insert Menu, choose Table. Accept the default values, and
   choose the OK button.

5. Select the entire document by pressing CTRL+Keypad 5.

6. From the Format menu, choose Character, select Bold, and choose the
   OK button. The entire document has bold formatting.

7. From the Edit menu, choose Replace. In the Search For box, press
   the CTRL+B key combination to search for bold formatting. The word
   "Bold" appears below the selection box. In the Replace With box, press
   the CTRL+I key combination to replace with italic formatting. The word
   "Italic" appears below the selection box. Clear the Confirm Changes
   option, and choose the OK button.

8. All of your text and paragraph marks have italic formatting;
   however, if you type text within one of the blank table cells, the
   text has bold formatting.

This problem does not occur if text or paragraph marks previously
exist in the table cell. Text or a paragraph mark provide a
recognizable search item for the Replace command.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 263-4

"Microsoft Word for Windows User's Reference," version 1.x, pages
289-90

Additional reference words: w4wformat wm_word
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00  w4wtable



Table Extends Beyond Right Margin After Increasing Margins
Article ID: Q80695
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you insert a table in a Microsoft Word for Windows document and
increase the left or right margin setting, the table does not resize
to fit within the new margins. It retains its original width and
extends over the right margin.

More Information:

When you insert a table in a Word for Windows document and accept the
default column width, Word sizes the table's columns so that the table
is the same width as the width between the current section's right and
left margin settings. If you change the left margin, right margin, or
the number of columns, Word does not resize the table to fit within
the new page or column margins. You must make column-width adjustments
separately.

Reference(s):

"Microsoft Word for Windows User's Reference," version 1.x, page 361

"Microsoft Word for Windows User's Guide," version 2.0, page 333-334

Additional reference words: 1.10 1.00 2.00 1.10a 1.0 1.1 1.1a w4wtable 
6.00 wm_word 



Word for Windows: Subscript Text Is Cutoff in a Table
Article ID: Q80759
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, if you apply subscript character
formatting to text within a table, the bottom portion of the subscript
text is cut off on the display and in the printed document. This
problem occurs regardless of the setting selected in the Line Spacing
box.

If you are running Word for Windows in Microsoft Windows operating
system version 3.1, tables cut off the bottom portion of the subscript
text on the display. Printed results depend on the print driver. For
example, the PostScript print driver version 3.5 cuts off the
subscript text, while the Hewlett-Packard LaserJet III driver version
3.89 prints the subscript text correctly.

WORKAROUND
==========

To work around this problem, format the line containing the subscript
formatting with the following line spacing:

Word for Windows version 2.0
----------------------------

1. From the Format menu, select Paragraph.

2. In the Spacing box, select .05 li in the After box, then select 3
   pt or a larger value in the At box, and choose the OK button.

Word for Windows version 6.0
----------------------------

1. From the Format menu, select Paragraph.

2. Be sure the Indents and Spacing tab is selected.

3. In the Spacing box, type in 1 point (the default increment if you
   click on the up & down arrows is 6 points). This will correct the
   problem even if the subscript is not on the last line of text in the
   cell.

Microsoft has confirmed this to be a problem in Word versions 2.x and 
6.0 for Windows. We are researching this problem and will
post new information here as it becomes available.



REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 146-147,
315-318

Additional reference words: 2.00 2.00a w4wfont truncates cropped 6.00 
wm_word w4wtable 2.00a-CD 2.00b



Word for Windows: Setting Column Width to Auto in Tables
Article ID: Q80833
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

In Word versions 2.0, 2.0a, 2.0a-CD, 2.0b, and 2.0c, if you select a
column(s) or cell(s) and type "auto" (without the quotation marks) in the
Width Of Columns box, you will receive the following error message:

   This is not a valid measurement.

Note: In versions 1.x of Word, setting the width of a column or cell to
Auto was permitted so that you could adjust the width of column(s) or
cell(s) within the margins.

STATUS
======

This problem was corrected in Word version 6.0 for Windows.

MORE INFORMATION
================

The Auto setting evenly divides the width of the table among the columns.
In Word for Windows version 2.0, you can use any of the following three
methods to set column or cell width to Auto.

Method 1
--------

1. Set the rightmost edge of the table at the desired position.

2. Hold down the CTRL key while dragging the column marker of the column
   that is to the left of the columns you want to adjust.

Note: The above method does not adjust columns based on margins; it resizes
the columns without changing the user-defined size of the table. The space
between the column you are sizing and the end of the table is divided
equally among the columns to the right of the column marker. Use the
procedure below to adjust the columns based on the margins of the document.

Method 2
--------

Use the steps below to create a macro that adjusts the selected column(s)
or cell(s) to Auto based on the margin settings within the document section
where the table is located.



1. From the Tools menu, choose Macro, type a macro name, and choose the
   Edit button.

2. Insert the following line between the Sub Main and End Sub:

      TableColumnWidth .ColumnWidth = "0"

To run this macro on the selected column(s) or cell(s) of the table, choose
Macro from the Tools menu.

Note: This macro can be assigned to a menu or to a toolbar button.

Method 3
--------

Note: This method works if the text in the table is not enclosed in
quotation marks with commas used as punctuation within the quotation marks.
If this is not the case, Word for Windows will break the text enclosed in
quotation marks into two columns when you convert it to a table.

1. Select the entire table.

2. From the Table menu, choose Convert Table To Text. In the Convert Table
   To Text dialog box, select the Commas option and choose the OK button.

3. Select the comma-delimited text. From the Table menu, choose Convert
   Text To Table. The table contains evenly-sized cells and extends from
   the left to the right margin.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, page 333

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wmacro w4wtable



Word for Windows: Paragraph Formatting Within Table Cells
Article ID: Q80917
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

When you insert a table in a Microsoft Word for Windows document, each
cell in the table assumes the paragraph formatting of the paragraph
where the insertion point is located when you insert the table. This
behavior may produce unexpected results in the display of text in the
table. To check the formatting specified for the paragraph containing
the insertion point, choose Paragraph from the Format menu.

More Information:

A common example of this problem occurs when the paragraph containing
the insertion point is formatted with a non-zero left or right indent.
If you insert a table at this point, each cell contains indents, and
the contents of the cells may align unexpectedly. When you apply an
indent to table cells, the indent is measured from the boundary of
each cell, not from the document margin.

With the ruler's indent scale active, you can view the ruler to check
for paragraph indents before you insert the table. You can also check
for indents in individual cells after you insert the table. If more
than one cell in the table is selected, the ruler reflects the indents
for the top-left cell of the selection, and the triangular indent
markers are unavailable, signifying that they do not apply to the
whole selection.

For a more precise view of the indents choose Paragraph from the
Format menu, and consider the follow conditions:

 - If the left indent is less than the cell width and the combined
   indents are greater than the width of the cell, any text in the cell
   appears in a one-character wide column, positioned at the left indent.

 - If the left indent is larger than the width of the cell, no text
   displays, regardless of the value of any other indents.

 - If the indent values are smaller than the width of the cell (but not
   zero), the indents are made from the left and/or right cell boundaries
   (just as normal paragraphs are indented from the left and/or right
   margins).

Word for Windows Version 2.0
----------------------------

If you use the Format Paragraph command to set left and/or right



paragraph indents for an existing table cell and the indents you
specify narrow the cell or paragraph to less than approximately
.7-inch, you receive the following error message:

   This indent is too large.

If you attempt to set a first-line indent beyond the end of the cell
or paragraph (as determined by the right indent), you receive the same
error message.

You do not receive any error messages if you use the ruler to set the
same paragraph indents.

Word for Windows Versions 1.x
-----------------------------

In Word for Windows version 1.x, you can specify any left, right, or
first-line paragraph indent value(s) within an existing table cell,
regardless of its relationship to the cell width and regardless of
whether you set the indents using the ruler or the Format Paragraph
command. No error messages appear in reference to conflicts in table
cell indentations. In Word version 1.x, the error message "Indentation
too large" appears only in reference to settings that conflict with
page margin and width settings.

Workaround
-----------

You can quickly reset all paragraph indents affecting a table by using
the following steps:

1. With the insertion point positioned in the table, select the whole
   table by pressing ALT+Keypad 5 (with NUM LOCK off).

2. From the Format menu, choose Paragraph.

3. Type 0 (zero) in all three Indent boxes, and choose the OK button.

While paragraph indents are probably the most common cause of
misalignment in table cells, other paragraph formatting can affect
table cells. For more information on table formatting, query on the
following words in the Microsoft Knowledge Base:

   paragraph and line and spacing and table and row and winword

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 49,
162-170, 322-324

"Microsoft Word for Windows User's Reference," version 1.x, page 367

Additional reference words: w4wformat wm_word
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00
w4wtable errmsg



Err Msg: "! Invalid Character Setting" in Expression Field
Article ID: Q81059
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you receive the error message

   "! Invalid Character Setting"

as the result of a Microsoft Word for Windows Expression
field, you need to change the character used for the decimal or list
separator in the Microsoft Windows version 3.0 Control Panel.

More Information:

The character you use for a List Separator and the character you use
for a Decimal Separator are set for all Windows-based applications
under the International settings in the Windows Control Panel. The
characters used by default depends on the Country settings you have
selected. Some characters are invalid as list or decimal separators.
The invalid characters will vary depending on the country setting. For
example, when the Country is set to United States, any character other
than a period is invalid as a decimal separator.

Steps to change the settings for these characters from Word for
Windows:

1. Activate the Control menu by pressing ALT+SPACEBAR.

2. From the Control menu, choose Run. Select Control Panel and choose
   the OK button.

3. Choose the International icon from the Control Panel window.

4. Select the character in the List Separator box and type the correct
   symbol.

5. In the Number Format box, choose the Change button. Select the
   character in the Decimal Separator box and type the correct symbol.
   Choose the OK button twice.

Reference(s):

"Microsoft Windows User's Guide," version 3.0, pages 182, 186
"Microsoft Word for Windows User's Guide," version 2.0, pages 306-311,
749

Additional reference words: 2.00  errmsg err msg calculate sum  6.00



wm_word w4wtable calculation calculating spreadsheet table results



Large Excel Sheet Becomes Tab- and Comma-Delimited for Merge
Article ID: Q81085
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b
   2.0c
 - Microsoft Excel for Windows, versions 3.0 and 4.0
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

If you use a Microsoft Excel spreadsheet as the data document for a
print merge in Microsoft Word for Windows and you specify a range that
includes more than 31 columns or a large number of rows, Word
generates the following error message if the data you are merging
contains commas:

   There are more fields in record x than merge fields in the header
   record. Do you want to continue with the Print Merge?

If you choose the Yes button in response to this question, your data
is merged incorrectly.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

If you use an Excel spreadsheet for a print merge data document, Word
converts the spreadsheet to Word for Windows format during the merge
process. Normally a spreadsheet is converted to a Word for Windows
table; however, Word tables are limited to 31 columns. As a result,
spreadsheets containing more than 31 columns are converted to
tab-delimited documents for print merges. In addition, spreadsheets
containing a large number of rows, but less than 31 columns, are also
converted to tab-delimited text. The number of rows that triggers the
change from table-delimited to tab-delimited varies depending on the
complexity of the spreadsheet.

Word inserts tabs in place of cell boundaries, but it uses both the
tabs and any commas in the data as delimiters during the print merge.



Word considers the commas to be delimiters, rather than text, because
the List Separator designated in the Control Panel International
dialog box is a comma when the country setting is United States.

Workarounds
-----------

To make Word treat commas as text, rather than delimiters, use one of
the following options:

 - Place quotation marks around text in the spreadsheet that contains
   any commas (for example, "Acme, Inc.").

 - Place a backslash character (\) in the spreadsheet before the comma
   (for example, Acme\, Inc.). Word does not merge the backslash but does
   treat the comma as text, rather than a delimiter.

 - Save the spreadsheet in Excel in CSV (comma-separated value) format,
   and use the CSV file for the print merge data document.

Note: This problem occurs in Excel version 4.0 and earlier.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 620-624

Additional reference words: w4wmerge w4wtable w4wexcel 2.00 2.00a
2.00a-CD 2.00b 2.00c



Excel Dialog Box Pastes as Tabs and Numbers in WinWord
Article ID: Q81151
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

Dialog boxes created with version 3.0 or 4.0 of the Microsoft Excel
Dialog Editor are not directly compatible with Microsoft Word for
Windows WordBasic.  When used with WordBasic, these Excel dialog boxes
appear as tabs and numbers.

MORE INFORMATION
================

Version 2.0 of Word for Windows comes with a Dialog Editor that works
correctly with WordBasic. To use dialog boxes created with the Excel
Dialog Editor in a WordBasic document, these dialog boxes must first
be converted to version 2.0 Word for Windows dialog boxes.

To determine which Dialog Editor you are using, choose About Dialog
Editor from the File menu. The following table lists the Dialog Editor
version numbers for Excel and Word:

Product Name                  Dialog Editor Version Number
------------                  ----------------------------

Word for Windows 2.0          2.40.0018
Excel for Windows 3.0         3.00
Excel for Windows 4.0         4.00

For more information on the Word for Windows Dialog Editor, query on
the following words in the Microsoft Knowledge Base:

   w4wmacro and dialog and editor

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 787-92

Additional reference words: w4wmacro word basic 1.00 1.10 1.10a 2.0
w4wtable 2.00 2.0a 2.00a wm_word 6.00



Word for Windows: Creating a Chart from Data Stored in a Table
Article ID: Q81713
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you can create a chart based on data 
stored in a table. To create a chart, follow the steps below:

1. From the Table menu, choose Insert Table, accept the default
   settings, and choose the OK button.

2. Type some numeric data into the table.

3. Position the insertion point somewhere inside the table.

4. From the Table menu, choose Select Table.

5. Click the Chart icon on the tool bar. This opens the Microsoft
   Graph program. If you exit Microsoft Graph and select Yes to update
   the document, the graph is inserted into your document below the
   table.

6. To edit or change the chart, double-click it.

Note: The table data and the chart are NOT linked. If you change the
table data you must re-create the chart.

Reference(s):

"Microsoft Graph User's Guide," version 3.0, page 16-27

"Microsoft Word for Windows User's Guide," version 2.0, page 340

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wtable 
6.00 wm_word 



WinWord: PAGEREF Field with Special Bookmarks Produces Error
Article ID: Q81958
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

Using PAGEREF fields in conjunction with the special predefined
bookmarks in Microsoft Word for Windows generates a "Bookmark not
defined" error.

More Information:

The PAGEREF field inserts the page number of a bookmark for
cross-reference purposes; however, with the predefined bookmarks, the
page numbers do not work correctly. These bookmarks are defined as
reserved and do not display in the Bookmark dialog box. You can use
these bookmarks with the Edit Go To command.

The special bookmarks include the following:

   \Sel, \PrevSel1, \PrevSel2, \StartOfSel, \EndOfSel, \Line, \Char,
   \Para, \Section, \Doc, \Page, \StartOfDoc, \EndOfDoc, \Cell, \Table,
   and \HeadingLevel.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 746, 749

"Using WordBasic," by WexTech Systems and Microsoft, pages 88-89

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c w4wtable w4wfield 6.00 wm_word



WinWord: Macro to Count Number of Rows in a Table
Article ID: Q82085
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

There is no automatic feature in Microsoft Word for to count the number of
records in a table; however, you can create a simple macro to display this
information on the status bar.

MORE INFORMATION
================

The WordBasic function SelInfo allows you to display the number of
rows within a table. The syntax for this function is as follows:

   n=SelInfo(Type)

For this example, "Type" is set to "15" (without the quotation marks).
Type 15 is the value for the number of rows in a table. For more
information on SelInfo, refer to pages 277-278 of "Using WordBasic,"
by WexTech Systems and Microsoft.

To create a macro to display the number of rows within a table, follow
these steps:

1. From the Tools menu, choose Macro. Type a name in the Macro Name
   box, and choose the Edit button.

2. Below the SubMain line, type "Print SelInfo(15)" (without the
   quotation marks).

3. From the File menu, choose Save All. Choose the Yes button in
   response to the prompt, "Save Global Glossary and Command Changes ?"

4. From the File menu, choose Close.

5. Position the insertion point anywhere within your table. From the
   Tools menu, choose Macro. Select your macro, and choose the Run
   button.

The number of rows in the table should display on the left-hand side
of the status bar.

REFERENCES
==========

"Using WordBasic," by WexTech Systems and Microsoft, pages 277-278



Additional reference words: 2.00 2.00a 2.0a w4wmacro w4wtable



Tab-Delimited Text Converted to Table Format in WinWord 2.0
Article ID: Q82183
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you convert text separated by tabs to 
table format, the resulting table does not reformat from margin to 
margin. The table columns display based on the width between the tab 
stops. (If no tabs are set, the column width is determined by the 
default tab settings.)

More Information:

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New, then choose the OK button.

2. Type a word, press the TAB key, type another word, press the TAB
   key, type another word, then press ENTER.

3.  Repeat step 2.

4.  From the Edit menu, choose Select All.

5.  From the Table menu, choose Convert Table to Text.

The table consists of three columns, and the column width is
determined by the tab stops.

Note: This behavior does not occur in Word for Windows version 1.x;
tab-delimited text converts to a table the width of the text area.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wtable 
6.00 wm_word 



WinWord 2.0: Macro to Remove Shading Does Not Work
Article ID: Q82958
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

If you create a macro in Microsoft Word for Windows select multiple
paragraphs and remove any shading in the selection, the macro does not
remove the shading unless the entire selection is shaded. If the
entire selection contains shading, the macro removes the shading
correctly; however, if only a part of the selection contains shading,
the macro does not remove the shading.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this
problem and will post more information here in the Microsoft Knowledge
Base as it becomes available.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

Example 1: Shading in Table Cells
---------------------------------

1. From the File menu, choose New, and choose the OK button.

2. From the Tools menu, choose Macro.

3. Type "UnShadeTable" (without the quotation marks) in the Macro Name
   box, and choose the Edit button.

4. In the macro-editing window, type the following macro:

      Sub Main
      TableSelectTable
      FormatBorder .FromText = "", .ApplyTo = 3, .Shadow = 0, \
      .TopBorder =  0, .LeftBorder = 0, .BottomBorder = 0, \
      .RightBorder = 0, .HorizBorder =  0, .VertBorder = 0, \
      .TopColor = 0, .LeftColor = 0, .BottomColor = 0, \
      .RightColor = 0, .HorizColor = 0, .VertColor = 0, \
      .Pattern = 0, .Foreground = 0, .Background = 0
      End Sub



5. From the File menu, choose Close. Choose the Yes button when
   prompted to save changes to the macro.

6. In the document, create a multi-column, multi-row table. (From the
   Table menu, choose Insert Table; or, choose the Table button on the
   tool bar.)

7. Select several cells in the table. From the Format menu, choose
   Border, select a border, then choose the Shading button. Select the
   Custom option button, select an percentage from the Pattern box, and
   choose the OK button twice.

8. From the Tools menu, choose Macro, select UnShadeTable, and choose
   the Run button.

Word removes the borders from the cells, but the shading remains.

Example 2: Shading in Paragraphs
--------------------------------

1. From the File menu, choose New, and choose the OK button.

2. From the Tools menu, choose Macro.

3. Type "UnShade" (without the quotation marks) in the Macro Name box,
   and choose the Edit button.

4. In the macro-editing window, type the following macro:

      Sub Main
      EditSelectAll
      FormatBorder .FromText = "1 pt", .ApplyTo = 0, .Shadow = 0, \
      .TopBorder =  0, .LeftBorder = 0, .BottomBorder = 0, \
      .RightBorder = 0, .HorizBorder =  0, .VertBorder = 0, \
      .TopColor = 0, .LeftColor = 0, .BottomColor = 0, \
      .RightColor = 0, .HorizColor = 0, .VertColor = 0, \
      .Pattern = 0, .Foreground = 0, .Background = 0
      End Sub

5. From the File menu, choose Close. Choose the Yes button when
   prompted to save changes to the macro.

6. In the document, type four paragraphs, and apply different amounts
   of shading to each paragraph. (From the Format menu, choose Border,
   then choose the Shading button to access the Shading dialog box.)

7. From the Tools menu, choose Macro, select UnShade, and choose the
   Run button.

The macro runs, but the paragraph shading remains.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, page 377-379,
764-765



Additional reference words: w4wmacro w4wtable 2.00 2.00a 2.00a-CD
2.00b 2.00c



SelInfo(15) Returns Incorrect Number of Rows in WinWord Table
Article ID: Q83071
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

If you use the SelInfo() WordBasic macro command to return the number
of rows in a Microsoft Word for Windows table, the command always 
returns "1" if one of the following conditions exists:

 - The insertion point is positioned at the start of the first cell in
   the table.

  -or-

 - The table is not the first item in the document.

The SelInfo() argument type 15 returns the number of rows in the table
if the selection is within a table; if the selection is not in a
table, the function returns "-1."

MORE INFORMATION
================

Workaround
----------

If the user selects the table first, before SelInfo is called, then
Word will always display the correct number of rows.  Example:

   Sub Main
   n = SelInfo(15)
   If n = - 1 Then
   MsgBox "Cursor is not in a table"
   Else
   TableSelectTable
   MsgBox "table rows" + Str$(SelInfo(15))
   EndIf
   End Sub

Steps to Reproduce Problem
--------------------------

 1. From the File menu, choose New, and choose the OK button. Press
    ENTER a few times to create some blank lines.

 2. From the Table menu, choose Insert Table.



 3. In the Number of Rows box, select 5.

 4. Choose the OK button to create a 2-column, 5-row table.

 5. From the Tools menu, choose Macro.

 6. Type a name in the Macro Name box, and choose the Edit button.

 7. On the blank line between the Sub MAIN and End Sub statements,
    type the following:

       MsgBox "Table Rows: " + Str$(SelInfo(15))

 8. From the Window menu, choose Arrange All.

 9. Press CTRL+F6 to switch back to the document. The insertion point
    should be positioned in the first cell of the table.

10. Choose the Start button on the macro-testing bar.

   Note: The message box incorrectly displays "Table Rows: 1." The
   message box should display "Table Rows: 5" because there are 5 rows 
   in the table.

11. Press the TAB key to move to the second column in the table.

12. Choose the Start button on the macro-testing bar.

The message box correctly displays "Table Rows: 5." Microsoft has
confirmed this to be a problem in Microsoft Word for Windows versions
2.0, 2.0a, 2.0b, 2.0c and 6.0. We are researching this problem and will
post new information here as it becomes available.

REFERENCES
==========

"Using WordBasic," by WexTech Systems and Microsoft, pages 277-278

Additional reference words: 2.00 2.00a w4wtable count cell 6.00 wm_word 
w4wtable 2.00b 2.00a-CD



WinWord: Referencing Expression Fields from Separate Tables
Article ID: Q83204
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, you can use a bookmark to refer to a
cell which is in a different table.

More Information:

When working with expression fields in a table, you cannot use cell
reference codes (R1C1 or A1, for example) to refer to a cell from a
different table.

To reference an expression from a different table, you can apply a
bookmark to the expression. Whether you apply the bookmark to the
expression or its result, Word inserts the result when you reference
the bookmark. This reference can be included in an expression placed
in a separate table. For example, create the following expression in a
table:

   |----------|----------------------|
   |2         |{=product ([r1c1])*3} |
   |----------|----------------------|

Note: To create the field braces, press CTRL+F9.

Position the insertion point within the field braces, and press F9 to
update the field. 

In versions 1.0 and 2.0:

From the View menu, clear the Field Codes command

In version 6.0:

From the Tools menu, choose Options. Choose the View tab. Put an x in 
the Field Codes check box.

The result of the expression should display in the table, as in the
following example:

   |-------|---------------|
   | 2     |6              |
   |-------|---------------|

Select the expression. From the Insert menu, choose Bookmark. Type
"test" (without the quotation marks), and choose the OK button. Insert



a second table, and type the following expression in a cell:

   {=test*2}

The bookmark "test" references the result from the first table (that
is, 6). The result of the second expression is 12.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 306-311

Additional reference words: 1.0 1.00 1.1 1.10 1.1a 1.10a 2.0a 2.00 6.00
w4wtable 2.00a w4wtable w4wfield add calculate math equation wm_word



WinWord: DOWN ARROW Skips Next Row After Selecting Table Cell
Article ID: Q83207
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you select a table cell with the Go
To command, type the reserved bookmark "\Cell" in the Go To box, and
press the DOWN arrow key to navigate to the next table row, the
insertion point may move down two rows rather than moving to the next
row.

More Information:

Steps to Reproduce Problem
--------------------------

1. From the Table menu in Word for Windows version 2.0, choose Insert
   Table. From the Insert menu in Word for Windows version 1.x, choose
   Table.

2. Select 3 in the Number of Columns box, and choose the OK button.

3. From the Edit menu, choose Go To.

4. In Word 1.x & 2.x --Type "\Cell" (without the quotation marks), and 
   choose the OKbutton. The first table cell is now selected.

5. Press the DOWN ARROW key to move the insertion point to the second
   row. The insertion point is placed correctly in the second row.

6. Press the UP ARROW key to move the insertion point back to the
   first row.

7. Repeat steps 3-4.

The insertion point is now located in the third row of the table
rather than the second row. Microsoft has confirmed this to be a
problem in Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0,
2.0a, 2.0a-CD, 2.0b, 2.0c, 6.0. We are researching this problem and will
post new information here as it becomes available.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 315-318,
741-742

"Using WordBasic," by WexTech Systems and Microsoft, pages 88-89



Additional reference words: w4wtable 1.00 1.10 1.10a w4wtable 6.00
wm_word 2.00 2.00a 2.00a-CD 2.00b 2.00c



Macro to Determine If Cursor is Within a WinWord Table
Article ID: Q83730
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When writing Microsoft Word for Windows WordBasic macros, you may need
to know whether or not the insertion point is positioned within a Word
for Windows table. The following macro posts a message box stating
whether or not the insertion point is within a Word for Windows table.
It uses the SelInfo command to determine if the insertion point is
within a table. This command is not available in Word for Windows
version 1.x.

   Sub MAIN
   n = SelInfo(12)
   If n = -1 Then
   MsgBox "Cursor is in a table"
   Else
   MsgBox "Cursor is not in a table"
   End If
   End Sub

More Information:

n = SelInfo(Type)
-----------------

The SelInfo() command returns various types of information about the
current selection. There are 30 different arguments (types) for the 
SelInfo
command. Type number 12 returns -1 if the selection is within a table.

Reference(s):

"Using WordBasic," by WexTech Systems and Microsoft, page 277-278

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wmacro
selinfo w4wtable 6.00 wm_word



Err Msg: Word Found No Valid Records to Sort
Article ID: Q84673
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

If you select a portion of a table column in Microsoft Word for
Windows, and the Sort Column Only option in the Sorting dialog box is
not selected, when you run the Tools Sorting command (Utilities Sort
in versions 1.x), the following error message will appear:

   Word found no valid records to sort

This error message will also be displayed if you attempt to sort a
single cell that contains multiple paragraphs when the end-of-cell
marker is included in the selection. To sort multiple paragraphs in a
single cell, make a selection that includes the text of the paragraphs
but excludes the end-of-cell marker.

More Information:

To sort a column selection in a table, the Sort Column Only option
must be selected in 2.X and the Field Number option must be set to 1. In
Word for Windows 6.0 the opion for sorting a table column is automatic.
The Sort option on the Table menu changes to reflect the possible sort
option.

Additional reference words: 2.00 2.00a 2.0 2.0a 1.1 1.10 1.00 1.10a 6.00
wm_word w4wtable 1.x 1.1a 1.0  errmsg err msg



Extra Paragraph Mark Above INCLUDE Field at Top of Document
Article ID: Q85489
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you select the Link To File check
box and insert a file at the beginning of a document, Word will add an
additional paragraph mark to the beginning of the document if the
inserted file begins with a table. You cannot delete this additional
paragraph mark.

Note: The additional paragraph mark is not displayed when the Field
Codes command is checked.

If you insert a file that begins with a table at the start of a
document and do NOT select the Link To File check box, Word will not
add the additional paragraph mark to the beginning of the document.

More Information:

To insert a file into a Word for Windows document, use one of the
following methods:

 - From the Insert menu, choose File. Select the file in the File Name
   box. If desired, select the Link To File check box (in Word for
   Windows version 1.x, select the Link check box). Choose the OK 
   button.

  -or-

 - Press CTRL+F9 to insert braces (field characters) in your document.
   Type "INCLUDE <filename>" (without the quotation marks) inside the
   braces. For more information on the INCLUDE field, refer to pages
   244-248 of the "Microsoft Word for Windows User's Guide."

Workaround
----------

If the extra paragraph mark disrupts the page layout of your document,
you can change the paragraph line spacing setting to 0.01 inch. From
the Format menu, choose Paragraph. In Word versions 2.x and 6.0, select 
Exactly in the Line Spacing box, and type "0.01" (without the quotation 
marks) in the At box. In Word 1.x, type "-0.01" (without the quotation 
marks) in the Line Spacing box. Choose the OK button.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 244-248



Additional reference words: 1.0 1.00 1.10 1.1 1.1a 1.10a 2.00 2.00a 6.00 
wm_word 
2.0a w4wfield linked w4wtable extra



Text Containing Fields Does Not Convert Correctly to Table
Article ID: Q85709
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you try to convert text that
contains one or more fields to a table, the resulting table may
contain only one column.

This problem was corrected in Word version 6.0 for Windows.

More Information:

If you convert tab-delimited or comma-delimited text to a table and
the first row of text consists of fields or the results of fields,
Word for Windows will generate only one table column.

In version 2.0 of Word for Windows, if the text is tab-delimited and
contains at least one field, a one-column table will be generated. If
the text is comma-delimited, when you choose to convert the text to a
table, a dialog box will prompt you to specify a delimiter. If you
select the Commas option button, the conversion will work correctly.

In versions 1.0 and 1.1 of Word for Windows, if the text is tab-
delimited or comma-delimited and the text contains at least one field,
a one-column table will be generated. The delimiter option buttons in
the Insert Table dialog box will be unavailable.

Workaround
----------

To convert fields and the results of fields to a table with the
correct number of rows and columns, use one of the following methods:

 - In Word 2.0, replace the tabs with commas. Select the text and
   fields, then choose Convert Text to Table from the Table menu.

  -or-

 - Unlink the fields after you update them by positioning the insertion
   point within the field(s) and pressing CTRL+SHIFT+F9. In version 2.0,
   select the text, and then choose Convert Text to Table from the Table
   menu. In version 1.x, select the text, and then choose Table from the
   Insert menu.
   
   Note: This workaround will not work for {SYMBOL XXX \f "Symbol"}
   fields.



Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 257-258,
265, 316-318, 757

"Microsoft Word for Windows User's Reference," version 1.x, pages 88,
366, 370

Additional reference words: 1.1a 2.0a 1.00 1.10 1.10a 2.00 2.00a
w4wtable w4wfield conversion incorrect wrong dimmed 2.0b 2.0a-CD 2.00b
2.00a-CD



Bookmark Command Unavailable If End-Of-Cell Mark Is Selected
Article ID: Q86467
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if the end-of-cell mark in a table cell
is selected, the Bookmark command on the Insert menu will be
unavailable. The reserved bookmark \SEL is also not available.

Note: If you select an entire table or an entire row of the table, the
Bookmark command will be available.

More Information:

Workaround
----------

To work around this problem, cancel the selection of the end-of-cell
mark.

Steps to Reproduce Problem
--------------------------

Example 1:

1. From the Table menu, choose Insert Table, then choose the OK button
   to accept the default settings.

2. Type some text into one of the table cells.

3. Select the text and the end-of-cell mark.

4. Go to the Insert menu.

The Bookmark command is not available.

Example 2:

1. From the Table menu, choose Insert Table, then choose the OK button
   to accept the default settings.

2. Position the insertion point in one of the table cells.

3. From the Insert menu, choose Field. Under Insert Field Type, select
   either Fill-In or Ask. In the Field Code box, type a bookmark name,
   and choose the OK button. Type the text for your prompt in the dialog
   box that appears, then choose the OK button again.



4. Select the field code and the end-of-cell mark. Press the Update
   Fields key (F9).

The following error message appears in the status bar:

   Word cannot update fields in this selection.

Example 3:

1. From the Table menu, choose Insert Table, then choose the OK button
   to accept the default settings.

2. Type some text into one of the table cells.

3. Select the text and the end-of-cell mark.

4. Create a macro that uses the reserved bookmark \SEL that copies its
   contents to another bookmark name.

5. Run the macro with the cell text and the end-of-cell mark
   selected.

The following error message appears:

   Bookmark does not exist.

Reference(s):

"Microsoft Word For Windows User's Guide," version 2.0, page 315

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00cEndOfCell  
6.00 wm_word greyed grayed out w4wtable dimmed



Wrapped Text Pasted from Excel to WinWord No Longer Wraps
Article ID: Q86678
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Excel for Windows, versions 3.0 and 4.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Wrapped text from a Microsoft Excel for Windows spreadsheet no longer
wraps if you paste it into Microsoft Word for Windows. Instead, the
text in Word for Windows displays an underscore character (_) where
the lines break for the wrap in Excel.

More Information:

Workaround
----------

To work around this problem in version 2.0 or 2.0a of Word for
Windows, do the following:

 - From the Edit menu, choose Paste Special. Under Data Type, select
   Unformatted Text (rather than Formatted Text), then choose the Paste
   button.

To work around this problem in version 1.x of Word for Windows, do the
following:

 - Select the pasted spreadsheet in Word. From the Edit menu, choose
   Replace. Substitute paragraph marks for the underscore characters.

Steps to Reproduce Problem
--------------------------

1. In Excel, select the cells you want to paste into Word. From the
   Format menu, choose Alignment. Select the Wrap Text check box, then
   choose the OK button.

2. In a cell, type 123, press ALT+ENTER, then type 456. Select the
   cell.

3. From the Edit menu, choose Copy.

4. Switch to Word.

5. From the Edit menu, choose Paste.

The cell in the table in Word reads 123_456.

Microsoft is researching this problem and will post new information



here as it becomes available.

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a w4wtable 6.00 
wm_word 



Exact Row Height Does Not Record Correctly with Macro Recorder
Article ID: Q86738
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

Setting a table row height to an exact value in Microsoft Word for
Windows cannot be recorded correctly using the Record Macro command.
In Word for Windows, you can set a table row height to an exact
measurement so that the row height changes when you add or delete text
in the cell. However, when this action is recorded and played back
with the macro recorder, the row height is not set to the exact
setting.

MORE INFORMATION
================

Workaround
----------

A macro recorded to set an exact row height in a table incorrectly
sets a negative line spacing value. To set an exact row height in a
table with a macro, either edit the recorded macro, or use the macro
editor to write the macro, rather than record it. An example of the
macro command that correctly sets an exact row height to 3li in a
table is as follows:

   TableRowHeight .RulerStyle = "0", .LeftIndent = "0" + Chr$(34), \
   .LineSpacingRule = 2, .LineSpacing = "3 li", .Alignment = 0

The recorded macro sets the .LineSpacing value to "-3li" and sets the
table row height to "At Least 3li" instead of "Exactly 3li."

Steps to Reproduce Problem
--------------------------

1. Open a new document. From the Table menu, choose Insert Table. In
   the Number Of Rows box, select 2; in the Number of Columns box, 
   select. Choose the OK button.

2. Position the insertion point in the first row. From the Tools menu,
   choose Record Macro.

3. Type "Table" (without the quotation marks) in the Record Macro Name  
   box, then choose the OK button.

4. From the Table menu, choose Row Height. Under Height Of Row 1,
   select Exactly. In the At box, select 3li, then choose the OK button.



5. From the Tools menu, choose Stop Recorder.

6. Position the insertion point in the second row of the table. From
   the Tools menu, choose Macro.

7. In the Macro Name box, select Table (the macro recorded above),
   then choose the Run button.

8. Position the insertion point in the second row of the table. From
   the Table menu, choose Row Height.

Notice that the Row Height value is now set to At Least 3li instead of
Exactly 3li as was recorded.

Microsoft has confirmed this to be a problem in versions 2.x and 6.0
of Word for Windows. We are researching this problem and will post new
information here as it becomes available.

Additional reference words: 2.00 2.00a w4wmacro w4wtable 6.00 wm_word 



Framed, Linked Excel Worksheet Duplicates Itself When Dragged
Article ID: Q86791
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0b, 2.0b
   2.0c, 6.0
 - Microsoft Windows operating system, versions 3.0 and 3.1
 - Microsoft Excel for Windows, versions 3.0 and 4.0
---------------------------------------------------------------------
Summary:

In Microsoft Word for Windows, if you frame a linked Microsoft Excel
for Windows worksheet, then drag the frame to another location on the
page, the worksheet may be duplicated when you update the link. The
second copy of the worksheet is no longer linked, so you cannot update
it.

More Information:

The problem is related to dragging the framed worksheet to a location
on the same line or above the location where it was originally framed.
If you frame the linked Excel for Windows worksheet when the View
Field Codes option is not selected, the framed worksheet can be moved,
but the underlying LINK field is not moved with it. When you later
update the LINK field, a new copy of the worksheet appears on the same
line where the worksheet was originally framed. This new copy is not
framed.

Microsoft has confirmed this to be a problem in Microsoft Word for
Windows versions 2.x and 6.0. We are researching this problem and
will post new information here as it becomes available.

Workaround
----------

You can avoid this problem by using the Format Frame command to
position the frame instead of using the mouse to click and drag the
frame to its new position.

 -or-

Use the following steps to make sure you frame the LINK field when you
frame the Excel worksheet:

1. From the View menu, select the Field Codes option. You can now see
   the LINK field to the Excel for Windows worksheet.

2. Select the entire LINK field.

3. From the Insert menu, choose Frame. Choose the Yes button if Word
   prompts you to switch to Page Layout view.

     NOTE: The frame is the width of the current column. If necessary,
     change the width and/or height of the frame.



4. From the View menu, clear the Field Codes option. You can now see
   the framed Excel for Windows worksheet. Select the frame and, using
   the mouse, drag it to a new location on the page.

5. From the View menu, select the Field Codes option. Notice that the
   LINK field appears inside the positioned frame.

Steps to Reproduce Problem
--------------------------

 1. Open or create a spreadsheet in Excel for Windows with at least two
    rows and columns containing data.

 2. Select the worksheet. From the Edit menu, choose Copy.
 
 3. Switch to Word for Windows and create a new document. Press ENTER
    several times to insert some paragraph marks.

 4. From the Edit menu, choose Paste Special.
 
 5. In the Data Type box, select Formatted Text (RTF) and choose the
    Paste Link button.

 6. Position the insertion point in the linked table. From the Table
    menu, choose Select Table.

 7. From the Insert menu, choose Frame. Choose the Yes button if Word
    prompts you to switch to Page Layout view.

 8. From the View menu, check the Field Codes command. Notice that the
    LINK field is visible, and the table disappears. The LINK field is
    not framed.

 9. From the View menu, clear the Field Codes option.

10. With the mouse, drag the framed table up to the top margin,
    centered on the page.

11. From the View menu, select the Field Codes option. Notice that the
    table AND a LINK field are now visible. The LINK field is not
    framed and is located at the original insertion point.

12. From the View menu, clear the Field Codes option.

13. From the Edit menu, choose Links. Select the first item in the
    Links box and choose the Update button. Notice that two identical
    tables are visible, one centered at the top margin and one at the
    left margin.

    If you make changes in the Excel for Windows spreadsheet, the
    positioned table is NOT updated because it is no longer linked.

Additional reference words: w4wfield  2.00 2.00a 2.00a-CD 2.00b  6.00
w4wtable wm_word



WinWord: Cannot Find or Replace Styles in Empty Table Cells
Article ID: Q86798
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, you can use the Edit Find and Edit
Replace commands to find and/or replace paragraphs formatted with a
specific style. However, these commands cannot find or replace styles
in an empty table cell. By choosing the Styles button in the Replace
or the Find dialog box, you can search for a specific style. However,
if there are empty table cells in your document, neither command can
find a style in those cells.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 260-264

Additional reference words: w4wformat 2.00 2.00a w4wtable



WinWord: Fonts in Table Appear to Have Superscript Formatting
Article ID: Q87088
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, and 2.0a
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, if you use TrueType fonts with small
point sizes in a table, the text may appear to have superscript
formatting. This problem occurs with certain printer fonts and point
sizes smaller than 10 points.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

WORKAROUND
==========

To work around this problem, use the following steps:

1. Select the text that appears to have superscript formatting.

2. From the Format menu, choose Paragraph.

3. In the Line Spacing box, change the setting from Auto to Single.

Additional reference words: w4wformat 1.00 1.10 1.10a 2.00 2.00a
superscripted w4wtable



GP Fault Occurs When You Insert a File into a Framed Table
Article ID: Q87436
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, a General Protection (GP) fault error
is generated if you do the following:

1. In Word for Windows, create a new file, and type several lines of
   text. Select a portion of the text.

2. From the Insert menu, choose Bookmark. Type a name for the
   bookmark, and choose the OK button.

3. From the File menu, choose Close. When prompted, choose the Yes
   button to save changes to the file.

4. Create another new file. From the Table menu, choose Insert Table,
   and choose the OK button. Position the insertion point in the table.
   From the Table menu, choose Select Table.

5. From the Insert menu, choose Frame.

6. Position the insertion point in the framed table. From the Insert
   menu, choose File. Select the file you saved in step 3. In the Range
   box, type the name of the bookmark you inserted in step 2. Check the
   Link To File check box and choose the OK button.

More Information:

Microsoft is researching this problem and will post new information
here as it becomes available.

Additional reference words: 2.00 2.00a GPF win31 2.00a-cd 2.00b w4wtable 
6.00 wm_word 



WinWord: Frame Containing Table Becomes Incorrectly Bordered
Article ID: Q88425

--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you apply a frame to a paragraph
that contains a table, either the table becomes bordered and the frame
does not, or the frame becomes bordered and every cell of the table is
bordered individually.

This problem was corrected in Word version 6.0 for Windows.

More Information:

If a table is the first item inside a frame, selecting the frame and
applying a border produces a border around the table only. However, if
the table is not the first item inside a frame, selecting the frame
and applying a border produces a border around the frame and around
each individual cell of the table.

Workaround
----------
Leave a blank space for the table and frame the text. The text and space
for the table are bordered. Then separately frame the table and move it
into the space in the first frame. The text and table are boxed and and
individual table cells are not bordered.

Steps to Reproduce Problem
--------------------------

1. From the Insert menu, choose Table. In the Number Of Rows and
   Number Of Columns boxes, select 4, then choose the OK button.

2. Position the insertion point below the table and press ENTER three
   times.

3. Select the table and two paragraph marks below the table.

4. From the Insert menu, choose Frame.

5. Select the frame by clicking the mouse when the mouse pointer is a
   four-headed arrow.

6. From the Format menu, choose Border. Under Preset, select Box, then
   choose the OK button.

   The table becomes selected when you choose the Border command, and 



   the border is applied to the table only.

7. From the Edit menu, choose Undo.

8. Position the insertion point in the first cell of the table and
   press CTRL+SHIFT+ENTER to insert a paragraph mark above the table
   inside the frame.

9. Repeat steps 5 and 6.

The frame becomes bordered, as well as each individual cell of the
table.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 316,
363, 393

Additional reference words: apo 2.00 2.00a 2.00a-CD w4wtable



WinWord: Macro to Find Tables in WinWord Documents
Article ID: Q88540
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

You can use the EditGoto statement in Word version 6.0 to move to the
next table in your document. The "t" identifier is used to specify a
table. The following statement moves the insertion point to the first
cell in the next table.

 EditGoTo "t+"   'moves to the next table

You can use the EditFind command to search for a number of special
characters. However, this command cannot be used to locate a table in
a Word for Windows document. To search for tables in a document, use
the following macro:

Word Version 2.x
----------------

Sub MAIN
StartOfDocument
While CmpBookmarks("\sel", "\endofdoc")  'While loop
 n = SelInfo(12)              'Returns -1 if in table
 If n = - 1 Then              'If -1 is returned post message
  choice = MsgBox("Table found, find next table?", 4)
  If choice = 0 Then Goto bye
  If choice = - 1 Then        'If OK pressed, find next.
   TableSelectTable
   CharRight 1
  EndIf
 Else
  LineDown  'If no table found, line down 1
 End If
Wend
bye:
End Sub

MORE INFORMATION
================

The above macro uses a While Wend loop to search through the document
for tables. The macro uses the SelInfo command to determine if the
cursor is in a Word for Windows table. SelInfo(12) will return a -1 if
the selection is in a Word for Windows table, and Word displays a
message box with the text "Table Found." If the selection does not
contain a table, the macro will move the cursor to the next line in



the document.

Note: Microsoft provides macros "as is" without warranty of any kind,
either expressed or implied, including but not limited to the implied
warranties of merchantability and/or fitness for a particular purpose.

REFERENCES
==========

"Using WordBasic," by WexTech Systems and Microsoft, pages 277-278,
333

Additional reference words: w4wmacro w4wtable
2.00 2.00a



White Line Appears in Shaded Text with PostScript Printers
Article ID: Q88817
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, when you print a document that contains
paragraph shading and you are using the PSCRIPT.DRV PostScript printer
driver version 3.5, 3.51, 3.52, 3.53, 3.54, or 3.55 for Microsoft 
Windows operating system version 3.1, a thin white horizontal band may 
appear across the shaded paragraphs.

More Information:

Workarounds
===========

To avoid this problem, follow the appropriate procedure below.

If the shaded paragraphs are not in a table cell
------------------------------------------------

Decrease the size of the font to 10 points or smaller.

-or-

Decrease the line spacing of the paragraphs (if possible) as follows:

1. Select the shaded paragraphs.

2. From the Format menu, choose Paragraph.

3. Set the line spacing to Exactly 12pt or 13pt.

If the shaded paragraphs are in a table cell
--------------------------------------------

1. Select the cells to be shaded.

2. From the Format menu, choose Border

3. Choose Shading

4. In the Shading dialog box, set the Pattern option to Clear, set the
   Foreground option to Yellow, and set the Background option to
   Yellow.

   Note: The color yellow produces 5-percent shading and will not
   create a white band.



If you are using a PostScript print command to shade a table cell, try
the following:

 - Insert a PRINT field in the cell with the following syntax

      {print \p cell "wp$box .89 setgray fill"}

   where the braces ({}) are created by pressing CTRL+F9. The
   PostScript printer will interpret this code and apply shading to
   the cell containing this field.

For more information on the use and limitations of embedding PRINT 
fields
in a Word for Windows document and PostScript shading commands, query
on the following words in the Microsoft Knowledge Base:

   postscript and shade and tables and field

Steps to Reproduce Problem
--------------------------

1. Type 13 to 16 lines of text in a new Word for Windows document.

2. From the Edit menu, choose Select All.

3. From the Format menu, choose Borders. Choose the Shading button. In
   the Pattern box, select 5 percent and choose the OK button.

4. Print the page to a PostScript printer using the PostScript printer
   driver.

Microsoft has reproduced this problem on the Hewlett-Packard (HP)
LaserJet Series IIISi PostScript printer, QMS ColorScript 100, and the
IBM 4029 PS printer. We are researching this problem and will post new
information here as it becomes available.

Additional reference words: win31 w4wprint 2.00 2.00a 2.00a-CD corrupt
6.00 wm_word w4wtable garbage band clear gap missing incomplete skips
w4wpostscript 3.10



Word: Print Merge Does Not Include Tables or Graphics
Article ID: Q89314
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When you perform a print merge in Word for Windows, any table or
linked graphic that is the result of a conditional IF field is not
displayed in the resulting merged documents. To use tables or linked
graphics as the result of a conditional print merge statement, use the
appropriate method below.

This functionality was changed in Word version 6.0 for Windows.

Merging the Table or Graphic Directly
-------------------------------------

Use this method when you want to print only the table or graphic.

Define a glossary entry that contains the table or linked
graphic, then conditionally merge one of two glossaries.

1. Select the table you want to merge and choose Glossary from the
   Edit menu. Type "table" (or another appropriate name, without the
   quotation marks) as the glossary name and choose the Define button.

2. Select the text or field that you want to merge if the condition is
   false. Choose Glossary from the Edit menu. Type "false" (or another
   appropriate name, without the quotation marks) as the glossary name
   and choose the Define button.

3. Insert a field with the following syntax:

      {GLOSSARY {IF <CONDITION><OP>"<CONDITION>" "TRUE GLOSSARY NAME"
      "FALSE GLOSSARY NAME"}}

      For example:

      {GLOSSARY {IF {MERGEFIELD EMPLOYEES}>="100" "TABLE" "FALSE"}}

4. Select the field and press the F9 key before you perform the print
   merge the first time (it should only be necessary to update the
   field only once).

   Note: You must have a glossary defined for the false result or the
   error message

      Error! No glossary entry specified



   will appear in place of the field when you merge. If you want no
   result when the condition is false, define some hidden text as your
   false glossary (be sure you do not include a paragraph mark in the
   glossary entry).

Merging a Document That Contains a Table or Graphic
---------------------------------------------------

Use this method when the table or graphic is part of another document
you insert using an INCLUDE field.

Page 643 of the "Microsoft Word for Windows User's Guide" gives
instructions for including a document during a print merge. If the
included document contains tables and/or graphics, they do not display
in the resulting merged documents when you follow these instructions.

If you reverse the order of the nested fields so the IF conditional
field is nested within the INCLUDE field, Word for Windows displays
the tables and graphics correctly.

A field with the following syntax will allow Word to evaluate a
condition and include one of two documents. Either document may
contain tables or graphics.

   {INCLUDE {if <CONDITION><OP>"<CONDITION>" "TRUE FILENAME" "FALSE
   FILENAME"}}

Note: You must specify a file for Word to include, even when the
condition is false. If no file is specified for Word to import when
the condition is false, the following error message prints on the form
letter:

   Error! Filename Not Specified

The following are examples of the fields for versions 2.x and versions
1.x  of Word for Windows.

Word for Windows versions 2.0, 2.0a, 2.0a-CD, and 2.0b
------------------------------------------------------

   {INCLUDE {IF {MERGEFIELD order}>"100" "C:\\DIRNAME\\LETTER1.DOC"
   "C:\\DIRNAME\\LETTER2.DOC"}}

Using this field, Word for Windows includes the text in LETTER1.DOC if
the amount in the data field "order" is more than 100. If the amount
of the order is less than 100, Word will include LETTER2.DOC. Any
table or graphic in LETTER1.DOC or LETTER2.DOC will be correctly
displayed in the resulting merged documents.

Word for Windows versions 1.0, 1.1, and 1.1a
--------------------------------------------

   {INCLUDE {IF {REF order}>"100" C:\\DIRNAME\\LETTER1.DOC
   C:\\DIRNAME\\LETTER2.DOC}}

Reference(s):



"Microsoft Word for Windows User's Guide," version 2.0, pages 268-271,
639-645

Additional reference words: docerr 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD
w4wtable 2.00b w4wmerge w4wfield missing



Column Width in Table Changes After Moving/Cutting and Pasting
Article ID: Q89327
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, if you change the width of a table
column and move or cut that column and paste it to another position in
the table, Word changes the column width to match the width of the
column located to the left of the new position.

STATUS
======

Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
2.0a-CD, 2.0b, and 2.0c of Word for Windows. This problem was corrected
in version 6.0 of Word for Windows.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. In a new Word for Windows document, insert a 6 column by 3 row
   table.

2. Position the insertion point in the third column.

3. From the Table menu, choose Select Column.

4. From the Table menu, choose Column Width. In the Width
   Of Column 3 box, select .5" and choose the OK button.

5. From the Edit menu, choose Cut.

6. Position the insertion point in the fifth column. From the Edit
   menu, choose Paste Columns. Note that the column width of the
   pasted column is the same as that of the fourth column.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b different loses 
6.00 wm_word w4wtable



WinWord: Using NextCell() to Test for Last Cell in Table
Article ID: Q89377
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Using the Microsoft WordBasic NextCell() command, the following macro
determines if the insertion point is within the last cell of a Word
for Windows table.

 Sub MAIN
 x = NextCell()
  If x = 0 Then
   MsgBox("Last cell in the table.")
   Else
   PrevCell
  End If
 End Sub

More Information:

The function form of the NextCell() command returns 0 (zero) if there
is no next cell in the table. This may be useful for avoiding the
addition of a new row in a table.

The NextCell() command moves the insertion point to the next cell in
the table and assigns the return value to the variable named "x". The
value 0 (zero) is returned if there is not a next cell in the table.
The above macro posts a message if current cell is the last cell in
the table. The MsgBox command can be replaced by other WordBasic
commands depending on the purpose of the macro. The PrevCell command
returns the insertion point to its original location before the
NextCell() command was executed.

If the NextCell() command is used when the insertion point is not
within a table, a "Command is unavailable" error is posted. The
following macro uses the SelInfo command to first determine if the
insertion point is within a table.

Sub MAIN
n = SelInfo(12)    'Returns -1 if insertion point is in a table
 If n = - 1 Then
  x = NextCell()
   If x = 0 Then
    MsgBox("Last cell in the table.")
    Else
    PrevCell
   End If
 End If



End Sub

Note: The SelInfo command is not available in versions 1.x of Word for
Windows.

Reference(s):

"Using WordBasic," by WexTech Systems and Microsoft, page 259 and 277

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 
6.00 wm_word w4wtable w4wmacro determine final NextCell SelInfo



UAE or GP Fault Occurs When Inserting Index or TOC in Table
Article ID: Q89459
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, a fatal application error occurs in any
of the following three situations. In all cases, a cell or group of
cells in a table must be selected, but no cells in the first column of
the table can be selected.

 - Insert a Table of Contents using heading paragraphs when no text in
   the document is formatted with those heading styles.

 - Insert a Table of Contents based on TC fields when there are no TC
   fields in the document.

 - Insert an Index when there are no Index Entries (XE fields) in the
   document.

Note: No application error occurs if no cell marker is selected in the
table or if the selection includes a cell in the first column of the
table.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

In Microsoft Windows operating system version 3.1, the following fatal
application error occurs:

   General Protection Fault (GPF)

In Windows version 3.0, the following fatal application error occurs:

   Unrecoverable Application Error (UAE)



Steps to Reproduce Problem
--------------------------

Important Note: These steps result in a fatal application error (UAE
or GPF). Word for Windows closes and all unsaved information is lost.
In addition, Windows does not recover resources previously allocated
to Word for Windows, so you should exit and restart Windows after this
error occurs.

1. Create a new document. From the Table menu, choose Insert Table and
   choose the OK button.

2. Press TAB to position the insertion point in the second column of
   the table.

3. Press SHIFT+RIGHT ARROW once to select the cell in the second
   column. Notice that no cells in the first column are selected.

4. From the Insert menu, choose either Table Of Contents or Index and
   choose the OK button. When the "No paragraphs found" error message
   occurs, choose the OK button. Notice that the GPF or UAE fatal
   application error occurs.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b  crash
w4wtable crashes hangs hang stops exits shut down loses



How to Open Word for Windows Table in Microsoft Excel Q+E
Article ID: Q89789
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
 - Microsoft Q+E for Microsoft Excel for Windows, versions 3.0
   and 4.0
--------------------------------------------------------------------

Summary:

To format a Word for Windows table so that you can use it in Q+E for
Microsoft Excel:

1. In Word for Windows, open the document that contains the table you
   want to use in Q+E. Select the entire table. From the Table menu,
   choose Convert Table To Text (in versions 1.0, 1.1 and 1.1a of Word
   for Windows, choose Text To Table from the Insert menu). Select the
   Commas option and choose the OK button.

   Note: If your table contains commas as punctuation, select the Tabs
   option instead of the Commas option in the Convert Table To Text
   dialog box.

2. Save the file in the Text Only file format.

3. Start Q+E. From the File menu, choose Open.

4. In the Source box, select Textfile and choose the Options button.

5. In the Open Options dialog box, select the IBM PC and Character
   Delimited Values options. In the Delimiter Character box, type ","
   (without the quotation marks).

   Note: If you selected tabs instead of commas in step 1 above, type
   "tab" (without the quotation marks) in the Delimiter Character box
   instead.

   Select the First Line Contains Field Names option if your table
   contains field names in the first row. Choose the OK button.

7. Select your text file from the list of files and choose the OK
   button. The text records from the Word for Windows table should
   appear as separate records in a Q+E Query.

8. If you want to save the text file in Q+E database file format,
   choose Save As from the File menu. Type a filename (Q+E uses the
   .DBF extension by default). Select dBaseFile in the Destination box
   and choose the OK button.

Reference(s):



"Q+E for Microsoft Excel User's Guide," version 4.0, pages
137-139, 141

"Microsoft Word for Windows User's Guide," version 2.0, pages 318,
675-679

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b  
6.00 wm_word w4wtable



How to Determine the Position of a Cell Within a Table
Article ID: Q89807
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

To determine the position (row and column number) of a cell in a
table, follow the procedure below or use the macro below it.

Procedure
---------

1. Position the insertion point in a table cell.

2. From the Table menu, choose Row Height. The row number is "X" in
   the Height Of Row <X> box title. Choose the Cancel button.

3. From the Table menu, choose Column Width. The column number is "X"
   in the Width Of Column <X> box title. Choose the Cancel button.

Macro
-----

   Sub Main
   MaxCol = SelInfo(18)
   Row = SelInfo(13)
   Col = SelInfo(16)
   If(Row = - 1) Or(Col > MaxCol) Then
      Print "Selection not in Table"
   Else
      Print "Row " ; Row ; ",  Column " ; Col
   End If
   End Sub

To use the above macro, position the insertion point in a table cell
and run the macro. The row and column number appear on the status line
in the following format:

   Row x, Column x

If the cursor is not in a table cell when you run the macro, the
following error message appears on the status line:

   Selection not in Table

NOTE: Information provided in this document is provided "as is"without
warranty of any kind, either expressed or implied, including but not
limited to the implied warranties of merchantability and/or fitness for
a particular purpose.

Additional reference words: w4wmacro number w4wtable 3.10 win31



2.00 2.00a 2.00a-CD 2.00b 2.00c 6.00



Comma in Quoted Text Causes Conversion to Two Columns in Table
Article ID: Q89831
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In a Word for Windows comma- or tab-delimited document, when a quoted
text field contains a comma (used as punctuation), Word for Windows
breaks the quoted text into two columns when you convert it to a
table. The text to the left of the comma is placed in the first column
and the text to the right of the comma is placed in the second column.
This occurs because Word for Windows does not differentiate between
commas used as delimiters and commas used as punctuation.

When you convert such text to a table, you must merge the two columns
with the Merge Cells command.

MORE INFORMATION
================

The following is a sample comma-delimited data document:

   Andy Slagg,"Ashland, OR",97520
   Walt Moore,"Santa Monica, CA",97007
   Dave Fay,"Bellevue, WA",98005

The following table resembles the table you would get by selecting the
text above and choosing Insert Table from the Table menu (in versions
1.0, 1.1 and 1.1a of Word for Windows, choose Table from the Insert
menu):

   ----------------------------------------------
   |Andy Slagg   |"Ashland       |OR"    |97520  |
   |Walt Moore   |"Santa Monica  |CA"    |97007  |
   |Dave Fay     |"Bellevue      |WA"    |98005  |
   ----------------------------------------------

If Word for Windows converted the text in quotation marks correctly,
the table would look like this:

   -------------------------------------------
   |Andy Slagg   |Ashland, OR        |97520  |
   |Walt Moore   |Santa Monica, CA   |97007  |
   |Dave Fay     |Bellevue, WA       |98005  |
   -------------------------------------------

Workaround
----------



1. In the comma-delimited data file, select all the data records.

2. From the Table menu, choose Insert Table.

3. To merge the two columns that contain the separated data, select
   both columns and choose Merge Cells from the Table menu. Note that
   Word for Windows inserts a paragraph mark in the text of the merged
   columns.

4. From the Edit menu, choose Replace. In the Find What box type "^p"
   (without the quotation marks). In the Replace With box type ", " (a
   comma and a space, without the quotation marks). Choose the Replace
   All button.

5. In the Find What box, type a quotation mark ("). Clear the contents
   of the Replace With box (it should be blank). Choose the Replace
   All button. Choose the Close button.

Reference:

"Word for Windows User's Guide," version 2.0, pages 257-258, 265, 314-
318

Additional reference words: 6.00 2.00 2.00a 2.00a-CD 2.00b w4wmerge
1.00 wm_word w4wtable 1.10 1.10a split breaks broken



Spelling Checker Does Not Recognize Table Cell as Delimiter
Article ID: Q91173
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

The Microsoft Word for Windows spelling checker does not recognize
table cell separators as delimiters. If adjacent table cells contain
the same word or a decimal number, the Spelling command flags the
second word as a repeated word.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

For example, the spelling checker flags the occurrences below because
there is no period or comma between the two numbers or words.

---------------------------
| 6.0        | 6.0         |
---------------------------
| red        | red         |
---------------------------

WORKAROUND
==========

To work around this behavior, you can apply No Proofing Language
formatting to your table, which causes the spelling checker to ignore
the table. To do this, use the following steps:

1. From the Table menu, choose Select Table.

2. From the Format menu, choose Language.

3. In the Mark Selected Text As box, select (no proofing), then choose



   the OK button.

Additional reference words:  w4wproof 2.00 2.00a 2.00a-CD 2.00b Table 
Speller w4wtable checking spell check repeated skip



WinWord: Can't Restore Table Deleted When Using Revision Marks
Article ID: Q91207
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

Summary:

In a Microsoft Word for Windows document, if you select the Mark
Revisions check box in the Revision Marks dialog box and then delete a
table using the Delete Rows or Delete Columns commands on the Table
menu, Word for Windows deletes the table instead of marking it for
deletion. 

If you subsequently choose the Undo Revisions button in the
Mark Revisions dialog box, Word for Windows does not restore the
deleted table. In Word version 6.0 for Windows if you choose Undo
from the Edit menu the Table will be restored.

More Information:

Workaround
----------

When you select the table, select the paragraph mark above and below
the table as well. Press the DEL key to mark the selection for
deletion. Notice that when you select non-table text, the Delete
Columns and Delete Rows commands are unavailable on the Table menu.
When you use this workaround, you can use the Undo Revisions button to
restore the deleted table.

Steps to Reproduce Problem
--------------------------

1. In a new Word for Windows document, choose Insert Table from the
   Table menu. Choose the OK button to accept the default settings.

2. Type some text in each cell.

3. From the Tools menu, choose Revision Marks. Select the Mark
   Revisions check box, then choose the OK button.

4. From the Table menu, choose Select Table. From the Table menu,
   choose Delete Rows. Notice that Word for Windows completely deletes
   the table instead of marking it for deletion.

5. From the Tools menu, choose Revision Marks. Choose the Undo
   Revisions button. Choose the Yes button when Word asks if you want to
   undo all revisions, then choose the Close button.

Word does not restore the table, and you cannot retrieve the table.



Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 604-607

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b disappears
w4wtable recover wm_word



WinWord: Border Splits Over Page Break
Article ID: Q91663
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c 
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if a paragraph or table with border
formatting extends over a page break, the border is split and the
following formatting problems occur:

 - The portion of the paragraph on the first page lacks a bottom border
   and the remainder of the paragraph on the next page lacks a top
   border.

   -and-

 - The portion of the table on the first page either lacks a bottom
   border or has the inside border applied to the bottom.

   -and-

 - The remainder of the table on the next page either lacks a top
   border or has the inside border applied to the top.

This problem was corrected in Word version 6.0 for Windows if you
apply the border to the bottom cell of one page and the top cell of
the following cell at the same time. If you apply the border to the
bottom cell of one page and then apply the border to the top cell of
the next page the above listed problem will occur.

More Information:

Workaround - Bordered Paragraph
-------------------------------

To work around this problem with a bordered paragraph, insert a paragraph
mark at the end of the first page to break the paragraph into two
paragraphs. This allows each paragraph to maintain a complete border.

Workaround - Bordered Table
---------------------------

To work around this problem with a bordered table, do one of the
following:

 - Position the insertion point in the first row on the second page and
   press CTRL+SHIFT+ENTER to split the table. Select the last row at
   the bottom of the first page and reapply the bottom border, then
   select the first row at the top of the next page and reapply the



   top border.

   Note: Reapplying the borders without splitting the table does not
   complete the border at the top of the second page.

   -or-

 - If you cannot split the table, select the two rows that span the
   page break and use the Format Border command to add a border to the
   bottom and top of the page.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 318,
362-364

"Microsoft Word for Windows User's Reference," version 1.x, pages
20-22, 369

Additional reference words: w4wformat
box line incomplete broken 1.00 1.10 1.10a
w4wtable 2.00 2.00a 2.00a-CD 2.00b



WordBasic: Selecting Table Columns and Rows
Article ID: Q93036
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

The Microsoft Word for Windows WordBasic macro language provides 
commands
for selecting columns or rows in Word for Windows tables.

Word Version 2.0
----------------

The WordBasic macro language in Word 2.0 includes the following commands
for selecting columns or rows in a Word for Windows table:

   TableSelectColumn
   -----------------

   Selects the column containing the insertion point in a table. The
   CharRight and CharLeft commands with the Select parameter specified
   (such as CharRight 1,1) can be used to extend the selection.

   TableSelectRow
   --------------

   Selects the row containing the insertion point in a table. The 
   LineDown command and LineUp commands with the Select parameter 
   specified (such as LineDown 1,1) can be used to extend the selection.

Note: Before executing a WordBasic table command, you may need to 
determine if the insertion point is within a table. To do this, use 
SelInfo(12), which returns -1 if the insertion point is within a table. 
For example, the following TableSelectRow command will be executed only 
if the insertion point is within a table:

   If SelInfo(12) Then TableSelectRow

Word Versions 1.x
-----------------

The WordBasic macro language in Word 1.x includes the StartofRow, 
EndOfRow,
StartOfColumn, and EndOfColumn commands for selecting rows and columns 
in
Word for Windows tables.

To select an entire table row in Word 1.x, use the following commands:



   REM Selects Table Row
   Sub MAIN
   StartOfRow
   EndOfRow 1
   End Sub

To select an entire table column in Word 1.x, use the following 
commands:

   REM Selects Table Column
   Sub MAIN
   StartOfColumn
   EndOfColumn 1
   End Sub

Reference(s):

"Microsoft Word for Windows Technical Reference," page 165-166

"Using WordBasic," by WexTech Systems and Microsoft, pages 300-301

Additional reference words: w4wmacro 1.00 1.10 1.1a 2.00 2.00a w4wtable 
6.00 wm_word 2.00a-CD 2.00b TableSelectRow TableSelectColumn



Cannot Replace Next Page Section Break Followed by Table
Article ID: Q94130
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

If your Word for Windows document contains a next-page or continuous
section break followed by a table and there is no paragraph mark
between the section break and the table, you cannot find or replace
that section break using the Replace command. 

WORKAROUND
==========

If you want to replace such section breaks, insert a paragraph mark
between the table and section break.

STATUS
======

Microsoft has confirmed this to be a problem in the above listed
versions of Word for Windows. Microsoft is researching this problem
and will post more information here as it becomes available.

MORE INFORMATION
================

This problem frequently occurs when you create mailing labels for use
in a print merge operation. After you create the mailing labels using
MAILLABL.DOT, you may unsuccessfully attempt to remove the section
breaks from your mailing labels main document using the Replace
command (this is sometimes done to create a mailing list). To replace
these section breaks, you must first position the insertion point at
the top of the main document and insert a paragraph mark above the
first label.

To insert a paragraph mark between a table and preceding section
break, do the following:

1. Position the insertion point at the beginning of the first cell in
   the table.

2. Press CTRL+SHIFT+ENTER.

-or-

From the Table menu, choose Split Table. Word inserts a page break and
a paragraph mark between the section break and the table. Delete the



page break.

Note: If you are removing the section breaks in order to create one
large table, this procedure does not work. Each table will be
separated by a paragraph mark that you cannot remove using the Edit
Replace command. You can manually delete these paragraph marks or, if
your table does not contain other paragraph marks, you can use the
Edit Replace command to search for the paragraph marks and replace
them with paragraph marks formatted for Exactly 0.1-inch line
spacing.

Microsoft has confirmed this to be a problem in versions 2.0, 2.0a,
2.0a-CD, 2.0b, and 2.0c of Word for Windows. We are researching this
problem and will post new information here as it becomes available.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 257-258, 262-
266

Additional reference words: w4wtable w4wmerge
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c



Space Between Fields When Table Converted to Text with Commas
Article ID: Q94353
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When you convert a Word for Windows table to text and separate the text
with commas, Word adds an extra space after each comma.

More Information:

Workarounds
-----------

1. Convert the table to text.

2. Select Separate Text With Tabs.

3. Use the Replace command on the Edit menu to replace the tabs with
   commas.

-or-

1. Convert the table to text.

2. Select Separate Text With Commas.

3. Use the Replace command to replace the comma+space combination with 
   just a comma.

Steps to Reproduce Problem
--------------------------

1. From the Table menu, choose Insert Table.

2. Set Number Of Columns to 3, Number Of Rows to 1, and choose the OK
   button.

3. Type a word in each cell.

4. From the Table menu, choose Select Table.

5. From the Table menu, choose Convert Table To Text.

6. Select Separate Text With Commas and choose the OK button.

Result: Word inserts extra spaces, one after each comma separating the
words. This will cause problems if the converted table is a Word for
Windows data document used in a print merge, since the header record 



(first row in the data document) cannot contain any spaces.

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-cd 2.00b 
6.00 wm_word 
w4wtable 2.00c



Some Empty Excel Spreadsheet Cells Are Merged in WinWord Table
Article ID: Q94982
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

When you paste a Microsoft Excel spreadsheet in Word for Windows,
sometimes Word merges two Excel cells into one table cell. This
happens if both of the following are true in the Excel spreadsheet:

 - The information in the left cell does not fit in the column (the
   text word wraps, or it is truncated).

-and-

 - The right cell is blank.

Workarounds
-----------

 - Type a space in the blank Excel spreadsheet cells before you copy
   and paste them in Word.

-or-

 - In Word, choose Paste Special from the Edit menu. Select
   Unformatted Text from the Data Type list and choose the Paste button.
   This pastes delimited text in your Word document, which you can 
   select and convert to a Word table.

Steps to Reproduce Problem
--------------------------

1. In an Excel spreadsheet with default column width settings, type
   "this is a test" (without the quotation marks) in cell A1.

2. Press TAB twice and type "123" (without the quotation marks) in
   cell C1. Cell B1 should be blank.

3. Select A1 through C1 (three cells). From the Edit menu, choose
   Copy.

4. Switch to Word for Windows. In a Word document, choose Paste from
   the Edit menu. Notice that only two cells appear in Word instead of
   three. Word has merged cells A1 and B1.

We are researching this problem and will post new information here in
the Microsoft Knowledge Base as it becomes available.



Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c empty  6.00 
wm_word w4wtable missing together



How to Center Text Vertically in a Table Row
Article ID: Q95097
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:
 
There is no feature in Word for Windows that centers text vertically
in a table cell. However, you can use the Spacing Before paragraph
format to simulate this feature.
 
To simulate centering text vertically in a table cell, subtract the
number of lines of text in the cell from the row height. Divide the
difference by 2. Use the result as the value of the Spacing Before
paragraph format that you apply to the first paragraph in the cell.
 
Example
-------
 
The row height of the table cell is five lines and the text to be
centered is one line:
 
1. Subtract one line from the row height (5 - 1 = 4).
 
2. Divide the difference by 2 (4 / 2 = 2).
 
3. From the Format menu, choose Paragraph. Select 2 li in the Spacing
   Before box and choose the OK button.
 
Reference(s):
 
"Running Word for Windows, Version 2," Russell Borland, Microsoft
Press, 1992, page 273
 
  Note: This reference instructs you to press CTRL+O (where O is the
  letter O) to center a row vertically. This only works when the row
  height is three lines because it adds one line of space above the
  text.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wtable 
6.00 wm_word 



Promoting and Demoting Text in Outline View
Article ID: Q95101
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Word for Windows, it is possible to promote and demote lines in
outline view, but it is not possible to promote or demote tables in
outline view.

More Information:

In outline view, to promote a line of text to the next level up,
select the paragraph you want to promote by by pressing the extend key
(F8) and do one of the following:

 - Press ALT+SHIFT+LEFT ARROW

   -or-

 - Choose the Left Arrow button in the Outline view tool bar at the top
   of the screen.

To demote a line to the next level down, select the paragraph you
want to demote and do one of the following:

 - Press ALT+SHIFT+RIGHT ARROW

   -or-

 - Click the right arrow icon in the outline view icon bar.

Note: To promote and demote lines in Word for Windows, the lines must
be formatted with Heading styles 1-9.

Tables Are Not Promotable/Demotable in Outline View
---------------------------------------------------

Tables are not promotable or demotable in Word for Windows versions
1.x, 2.0, 2.0a, 2.0b, 2.0c, 6.0. When you attempt to promote or demote a
table in Word for Windows, the computer will respond with a beep.

You cannot promote or demote a table; tables are special entities in
Word for Windows and cannot be manipulated as normal text.

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00b 2.00c 6.00
wm_word w4wtable table tables outline promote level next key view



Word Incompletely Sorts Table Column That Contains a Comma
Article ID: Q95960
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

A column sorts incorrectly in Word for Windows if the Separator option
or Field Number setting in the Tools Sorting dialog box (Utilities
Sorting dialog box in Word versions 1.x) is wrong or if the text
contains more than one type of data delimiter (table, comma, or tab)
recognized by Word. To obtain accurate sorting results, the Separator
option and Field Number setting must be correct in the Sorting dialog
box, and the column must contain only one type of delimiter.

For example, if you sort a table and the text in the key field
contains numbers with commas as thousands separators (such as
1,000,000), Word ignores the text following the first comma and
performs the sorting operation on the text preceding the comma. This
happens because the selection contains two data-delimiter types (table
and comma). In this case, you must delete the commas so the selection
contains a single type of data delimiter.

This problem was corrected in Word version 6.0 for Windows.

More Information:

In Word, you can base your sort on a column of information in a table
or in a comma- or tab-delimited portion of a document. Word for
Windows does not sort correctly if your information contains more than
one kind of data delimiter.

Workaround 1
------------

Change the list separator character using the following steps:

1. Open the Windows Control Panel and choose the International icon.

2. In the Separator box, type a character other than one of the
   delimiter characters, such as a semicolon (;).

  Note: Changing the list separator character may affect some functions
  in other applications such as Microsoft Excel. If this happens, use
  Workaround 2 instead.

Workaround 2
------------

  Note: This workaround produces incorrect sorting results if the 



  column contains more than one kind of data delimiter.

Use the following steps to correctly sort a column: 

1. Open or create a document that contains a table or a comma- or tab-
   delimited selection. Select the column of text on which you want to
   base the sort. For information on selecting a column of text, see
   page 106 in "Microsoft Word for Windows User's Guide."

2. From the Tools menu, choose Sorting (in Word versions 1.x, choose
   Sort from the Utilities menu).

3. For the sorting order, select Ascending or Descending.

4. From the Key Type list, select Alphanumeric, Numeric, or Date as
   appropriate.

5. Although your selected text may not contain any commas or tabs,
   select the Comma or the Tab option button as the separator to
   represent how the selection is separated from the rest of the data.

6. Although your selected text may include only one column of text
   without commas or tabs, type the value in the Field Number box that
   represents the position of the column. For example, if a tab
   precedes the selected column, type 2 in the Field Number box.

7. Choose the OK button.

  Note: If you select incorrect settings in steps 5 or 6 above, Word
  either does not sort the data or sorts it incorrectly.

We are researching this problem and will post new information here in
the Microsoft Knowledge Base as it becomes available.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 299-300

"Microsoft Word for Windows User's Reference," version 1.x, pages 328-
330

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 
2.00c w4wtable w4wmerge



Vertical Justification Causes Space Between Table Rows
Article ID: Q98275
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

When you select the Justified Vertical Alignment option in the Format
Section Layout dialog box, Word for Windows may insert extra space
between table rows in Print Preview or when you print the document.
This space does not appear on the screen in any view.

Word inserts extra space between each row of a table to justify the
table between the top and bottom margins.

To remove the extra spaces between the table rows, change the Vertical
Alignment section layout setting from Justified to Top.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wtable 
6.00 wm_word expands expanded gridlines justified



How to Create Table Column Headings in a Multiple-Page Table
Article ID: Q98506
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

This article contains instructions you can use to join a Word for
Windows table in a header with a table in the body of the document to
make them appear as a continuous table when printed.

This functionality has been added to Word version 6.0 for Windows.

More Information:

When you use the procedures in this article, two tables result, one in
the header and one in the document body. They appear as one table when
you print the document. The table in the header appears at the top of
each page, so you can use this technique to create column headings in
a multiple-page table.

Word for Windows, Versions 2.0, 2.0a, 2.0a-CD, 2.0b, 2.0c
---------------------------------------------------------

1. In the header of your document, insert the table rows you want to
   appear at the top of each page.

2. From the Format menu, choose Page Setup. Select the Margins option
   button.

3. Type a minus sign (-) before the top margin setting to make it a
   negative number and then choose OK. For example, if your top margin
   setting is 1 inch, change it to -1 inch. The minus sign sets a fixed
   top margin that is not pushed down by the header.

4. From the View menu, choose Header/Footer. Select Header in the
   Header/Footer list.

5. In the Header From Edge box, type the top margin minus .19 inch.
   For instance, type .81" for a 1-inch top margin. This measurement
   is usually correct when you add a single row table to the header
   that contains a single row of 12-point or smaller text. For a table
   with additional lines, rows or larger text, you must adjust the
   value that you subtract from the top margin setting. You can adjust
   this setting as necessary. To adjust the space between the table and the
   header, format the line spacing of the paragraph following the table in
   the header.

 In header under table, format the Paragraph marker to a
4 pt.. don't leave default.



   The following table lists Header From Edge settings for common
   margin values:

                                       Header From
      Top Margin      Change to       Edge Setting
      ----------      ---------       ------------

         2.0"           -2.0"                1.81"
         1.5"           -1.5"                1.31"
         1.0"           -1.0"                 .81"
         0.5"           -0.5"                 .31"

   Note: You can specify the Header From Edge setting to the
   hundredths place (for example, .73 inch).

6. If the table contains border formatting, you must remove the bottom
   portion of the border using the following steps:

   a. Select the table.

   b. From the Format menu, choose Border.

   c. On the Border diagram, select the bottom border.

   d. Select None in the Line box to remove the bottom border and then
      choose OK.

7. Switch to page layout view so you can check the relationship of the
   table in the header to the table in the body of the document. Adjust
   the Header From Edge value as necessary, using the instructions in
   step 5 above.

Word for Windows, Versions 1.x
------------------------------

1. In the header of your document, insert the table rows you want to
   appear at the top of each page.

2. From the Format menu, choose Document. Type a minus sign (-) before
   the top margin setting to make it a negative number and then choose
   OK. For example, if your top margin setting is 1 inch, change it to
   -1 inch. The minus sign sets a fixed top margin that is not pushed
   down by the header.

3. From the Edit menu, choose Header/Footer. Select Header and then
   choose the Options button.

4. In the Header Distance From Edge box, type the top margin minus .1
   inch. For instance, type .81" for a 1-inch top margin.

5. If the table contains border formatting, you must remove the bottom
   portion of the border using the following steps:

   a. From the Format menu, choose Table.

   b. Select None from the Bottom list and then choose OK.



6. Switch to page view and check the relationship of the table in the
   header to the table in the body of the document. Adjust the Header
   Distance From Edge value as necessary, using the instructions in
   step 4 above and step 5 in the "Word Version 2.0" section.

Reference(s):

"Microsoft Word for Windows User's Reference," version 1.x, pages
361-372

"Microsoft Word for Windows User's Guide," version 2.0, pages 364-376

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b
2.00c w4wtable column heading running head



IF Field Won't Display Table or Linked Graphic as Result
Article ID: Q99683
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
Summary:
 
You cannot insert a table or a linked graphic into a Word document as
the result of an IF field that contains INCLUDE, IMPORT, or GLOSSARY
fields.
 
Workaround
----------
 
To display a linked graphic or a table as the result of a conditional
IF field, nest the IF field inside an INCLUDE, IMPORT, or GLOSSARY
field, so that the IF field updates first. For example, you could nest
the fields as follows:
 
   {INCLUDE {IF conditionalTest table.doc falseResult}}
 
More Information:
 
The following examples illustrate the problem that occurs when you try
to insert a linked graphic or table as the result of an INCLUDE,
IMPORT, or GLOSSARY field nested inside an IF field.
 
In the following examples, a table or a linked graphic is used as
results in an IF field. TABLE.DOC is a file that contains a table.
"Glossary table" is a glossary entry that contains a table.
PICTURE.WMF is a Windows metafile graphic. "Glossary picture" is a
glossary entry containing a linked graphic.
 
   {if conditionalTest {include TABLE.DOC} falseResult}
   {if conditionalTest {glossary table} falseResult}
   {if conditionalTest {import PICTURE.WMF} falseResult}
   {if conditionalTest {glossary picture} falseResult}
 
If conditionalTest is true in any of the above examples, the table or
picture will not display when you update the field. Any text above or
below the table in either TABLE.DOC or the table glossary will display
correctly. Any text above or below the graphic in the picture glossary
will display correctly. Embedded graphics and graphics that are not
linked will display correctly.
 
For more information on importing graphics as the result of a
conditional field, query on the following words in the Microsoft
Knowledge Base:
 
   importing and graphics and condition



 
Microsoft has confirmed this to be a problem in Word for Windows,
versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 2.0a-CD, 2.0b, 2.0c, 6.0. We are
researching this problem and will post new information here in the
Microsoft Knowledge Base as it becomes available.
 
Reference(s):
 
"Microsoft Word for Windows User's Reference," version 1.0, pages
97-99
 
Additional reference words: w4wtable w4wfield 1.00 1.10 1.10a 2.00 6.00 
wm_word 2.00a 2.00a-cd 2.00b 2.00c



Pressing Tab Does Not Advance Cursor to Next Cell in Table
Article ID: Q105440
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========
 
If the insertion point is in a table following a section break,
pressing TAB may move the insertion point to the next tab stop
position within the same cell rather than moving to the next cell.
 
STATUS
======
 
Microsoft has confirmed this to be a problem in Word version 2.x for
Windows. This problem was corrected in Word 6.0 for Windows.
 
Steps to Reproduce Problem
--------------------------
 
1. In a new document in normal view, press ENTER.

2. From the Table menu, choose Insert Table.

3. From the Table menu, choose Select Table.

4. From the Format menu, choose Page Setup. Select "Size and
   Orientation" and under Orientation, select Landscape. In the Apply
   To list, select Selected Text. Choose OK.

5. Press TAB (the insertion point will be in the first cell).

The insertion point moves to the next tab stop position and not to the
next cell as expected.
 
WORKAROUND
==========
 
Manually select the table including the paragraph mark that follows,
rather than choosing Select Table from the Table menu in step 3 above.
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c W4WTABLE
NEXTCELL



Vertical Cell Alignment Not Supported in Word for Windows
Article ID: Q105915
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Word for Windows does not support vertical alignment for table cells.

For example, if you copy cells from a Microsoft Excel spreadsheet that
are formatted for Center or Bottom vertical alignment, and then paste
them into a Word document, the height of the cell remains the same,
but Word places the text at the top of the cell. In other words, the
vertical alignment formatting is lost.

Additional reference words: 6.00 w4wformat w4wtable



Word for Windows: Merging Styles from Other Documents
Article ID: Q35588
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

To merge styles created in a Microsoft Word for Windows document with
those in another document, open the document to which you want to copy
the styles and do the following:

Word for Windows version 6.0
----------------------------

1. From the Format menu, choose Style.

2. Choose the Organizer button.

3. On the To: side of the dialog, choose the Close File button to close
   the file listed. The Close File button will change to an Open File
   button, choose this button.

4. Select or type in the name of the file from which you would like to
   copy styles. You can choose Word Document or Document Template from
   the List Files of Type box.

5. Choose OK.

6. Select the style or styles you would like to copy to your open
   document and choose the Copy button. Choose Yes or Yes to All when
   prompted to overwrite existing styles.

7. When all desired styles have been copied, choose Close.

Word for Windows version 2.x
----------------------------

1. From the Format menu, choose Styles.

2. Choose the Define button.

3. Choose the Merge button.

4. Select or type in the name of the file from which you would like to
   copy styles. You can choose Word Document or Document Template from
   the List Files Of Type box.

5. Choose OK.

6. Choose Yes to the message "Merging will replace the current styles
   with new styles of the same name. Do you want to replace the styles?"



7. Choose the Close button.

Word for Windows version 1.x
----------------------------

1. From the Format menu, choose Define Styles.

2. Choose the Options button.

3. Choose the Merge button.

4. Select the name of the file from which you would like to copy the
   styles.

5. Choose OK.

6. Choose Yes to the message "Merge replaces styles with the same name. 
   Continue?"

7. Choose the Close button.

The styles from the selected document will now be included in the open 
document.

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-cd 2.00b 
wm_word 2.00c  2.00c-cd 6.00 w4wtemplate 



Changes to Template in One Document Apply to All in WinWord
Article ID: Q41315
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

Changes to menus and key assignments carry over to documents based on
the same template. Menu settings are stored with the template, not
with each document. If you change the template while in one document,
close that document, and open a previous document created with the
same template, the changes are reflected in the new document.
 
Note: If Word cannot find the template file, Word returns the message
"Unable to open template" and uses the normal menus.

Additional reference words: 1.0 1.1 1.1a 2.0 1.00 1.10 1.10a 2.00 wm_word 
w4wtemplate



Copying Single Style to Another Template in Word for Windows
Article ID: Q48112
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Microsoft Word for Windows versions 1.x and 2.x do not have a feature
that allows a single style to be copied from a document or template to
another document or template. 

NOTE: Word for Windows version 6.0 has this capability built-in.

To copy a single defined style from a template that you are not using in
your current document in Word versions 1.x and 2.x, do the following:

1. From the File menu, choose Open to open a file based on the
   template that has the desired style.

2. Locate a paragraph of text that has the desired style applied to
   it. From the Edit menu, choose Copy to copy the text to the
   Clipboard, and close the document.

3. Return to your current document. From the Edit menu, choose Paste
   to paste the copied text.

4. After pasting the desired style into the current document, choose
   Define from the Format menu and choose Style. Highlight the style
   that was pasted into the document.

5. Do one of the following:

   Word for Windows Version 2.0
   ----------------------------

   Choose Define, select the Add to Template check box, and choose OK.

   -or-

   Word for Windows Version 1.0 and 1.1
   ------------------------------------

   Choose Options, select the Add to Template check box, and choose OK.

The pasted style becomes part of the current document's template.

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-cd 2.00b
2.00c 2.00c-cd w4wtemplate



Finding Links to Document Templates in Word for Windows
Article ID: Q58472
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

The following information details how to determine what template is
attached to a Microsoft Word for Windows document.
  
To find the name and location of the template attached to a document,
follow a procedure below:

Procedure for Word for Windows version 6.0
-------------------------------------------

 - From the File menu choose Templates. The attached template is listed
   below Document Template. To attach another template, choose Attach and
   select another template from the list box of files.

Procedure for Word for Windows version 2.x
-------------------------------------------
  
 - From the File menu, choose Template. The attached template is listed
   below "Attach Document To:". To attach another template, choose a
   template name from the list box of templates.

Procedure for Word for Windows version 1.x
------------------------------------------- 
 
1. From the Format menu, choose Document.
 
2. If the Template box is blank, a global or normal template is being
   used. If another template is being used, it displays in the Template
   box.

3. The first template listed is the linked template to the active
   document.

Alternative Procedure for Word for Windows versions 1.x, 2.x and 6.0
--------------------------------------------

   1. From the File menu (Edit menu in version 1.x), choose Summary Info. 
  
   2. Choose the Statistics button in the Summary Info dialog box.
 
   3. The third line of the Statistics dialog box is labeled Template.
      The template name displays on this line. It contains the full
      path of the drive and directory in which it resides.

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-cd 2.00b
wm_word 2.00c 2.00c-cd 6.00 w4wtemplate





Word Cannot Open the Existing NORMAL.DOT
Article ID: Q58891
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======
 
In Microsoft Word for Windows you may receive the error message:
 
   Word cannot open the existing NORMAL.DOT.

-or-

   Cannot open existing NORMAL.DOT.

MORE INFORMATION
================

The following are possible causes for this problem:
 
 - There is not enough available memory to open the NORMAL.DOT file.
   Close all applications you are not currently using. Remove any
   memory-resident programs loaded.

 - The file NORMAL.DOT may be corrupted. Try renaming NORMAL.DOT and
   reloading Word for Windows.
  
 - NORMAL.DOT has been saved as a document file and is no longer a
   template.

Additional reference words: w4wtemplate 1.00 1.10 1.10a 2.0 2.00 wm_word 
6.00



Glossary Point Size Not Retained in Word for Windows
Article ID: Q65220
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, and 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

The character point size in a Microsoft Word for Windows file may be
lost when you retrieve a glossary entry. This problem occurs if the
default font size for the template is set to a point size other than
10-point.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Glossary entries formatted with a 10-point font, return with the same
point size as defined by the Normal style of the NORMAL.DOT template.
For example, if the Normal style for NORMAL.DOT is Helv 12, a glossary
that was formatted as Tms Rmn 10 is retrieved as Tms Rmn 12.

Note: A 10-point glossary item returns with the correct point size during
the session in which it was created; however, after exiting and restarting
Word for Windows or, by selecting the File menu and choosing Save All, the
10-point glossary entry returns in the point size specified by the Normal
style.

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c
w4wtemplate



Merged Styles Not Retained with Some WinWord Documents
Article ID: Q68317
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, and 2.0a
 - Microsoft Windows operating system, versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, styles do not remain in some documents
after being merged from a template. For example, if you merge styles
into a document using the steps below, the new style formatting is
applied to your document during the session; however, it may be lost
after the document is closed and then reopened.

Note: This problem is most common with documents converted from the
Microsoft Word for MS-DOS file format to Word for Windows.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

Versions 1.x of Word for Windows
--------------------------------

1. From the Format menu, choose Define Styles.

2. Choose the Options button, then choose the Merge button.

3. Choose the From Template button.

Versions 2.0 and 2.0a of Word for Windows
-----------------------------------------

1. From the Format menu, choose Styles.

2. Choose the Define button, then choose the Merge button.



3. Choose the From Template button.

WORKAROUND
==========

As an alternative to merging styles from a template, you can manually
change the existing styles by choosing Define Styles from the Format
menu.

Another way to work around this problem is to add an AutoOpen macro
that merges the styles from the template whenever you open the
document.

Another possible workaround to this problem is to save the document in
rich-text format (RTF) after merging the styles from the template. To
save a document in RTF, do the following:

Version 2.0 of Word for Windows 
-------------------------------

1. From the File menu, choose Save As.

2. In the Save File As Type box, select Rich Text Format (*.rtf). 

3. Change the name of the file in the File Name box, and choose the OK
   button.

4. Close the current document and open the file that was just saved in
   rich-text format.

Versions 1.x of Word for Windows 
--------------------------------

1. From the File menu, choose Save As.

2. Choose the Options button.

3. In the File Format box, select RTF.

4. Change the name of the file in the Save File Name box, and choose
   the OK button.

5. Close the current document and open the file that was just saved in
   rich-text format.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 205-208

"Microsoft Word for Windows User's Reference," version 1.x (Document
Number OB 14328-0990), pages 340 and 347

Additional reference words: w4wformat 1.00 1.10 1.10a 2.00 2.00a
w4wtemplate disappear missing





File Find Print Option Uses Built-In Print Macro Only
Article ID: Q69761
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

If you choose Print from the File Find dialog box, Word for Windows
uses its built-in Print macro instead of the Global or Template
FilePrint macro. For example, if you modify the FilePrint macro to
always check Update Fields and choose Print from File Find, the
FilePrint macro you modified is not used. Word for Windows uses the
built-in Super FilePrint instead.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. We are researching this problem,
and will post more information here in the Microsoft Knowledge Base as it
becomes available.

Additional reference words: w4wmacro filefind w4wtemplate 1.00 1.10
1.10a wm_word 2.00 2.00a 2.00a-CD 2.00b 2.00c



WinWord Err Msg:'Word cannot open document template'
Article ID: Q69870
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

Word for Windows returns the error:

   Word cannot open this template 

when you try to open a document if the template (.DOT file) the
document was based on has been moved, renamed, or deleted.

Note: The name of the original template can be found from the File
menu by selecting Summary Info and choosing the Statistics button.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Word for Windows looks to the WINWORD directory for the .DOT file a
document is based on unless a line has been added to the WIN.INI
showing its new location.

If you want to move your .DOT files to another directory, and you 
have Word for Windows versions 1.00, 1.10 and 1.10a, add the following
line to the [Microsoft Word] section of the WIN.INI: 

 [MICROSOFT WORD] 
DOT-PATH=PATHNAME   (i.e. DOT-PATH=C:\USERNAME) 

 If you want to move your .DOT files to another directory, and you
have Word for Windows versions 2.0, choose Options from the Tools menu
and select WIN.INI for the Category.  Make sure the application
selected is Microsoft Word 2.0.  In the Option box, type DOT-PATH and in
the Setting box, type the path (i.e. C:\USERNAME) and choose the Set



button.  Choose the Close button. 

Additional reference words:  2.0 2.00 w4wtemplate



Resetting Default Menus for Individual Templates in WinWord
Article ID: Q69873
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

It is possible to reset default menus in a specific template after you
have redefined the menus.

MORE INFORMATION
================

To reset the menus to their original format for a template after you
have redefined the menus:

Word for Windows version 6.0
----------------------------

1. Open the template.

2. Choose Customize from the Tools menu.

3. Choose the Menus tab and verify that the open template is selected in
   the Save Changes In: option.

4. Choose the Reset All button.

5. Choose Close

Word for Windows version 2.0
----------------------------

1. Open the template.

2. Choose Options from the Tools menu.

3. Choose Template for the Context.

4. Choose the Reset All button.

5. Choose Close

Word for Windows versions 1.0, 1.10 and 1.10a
---------------------------------------------

1. Open that template.

2. From the Macro menu, choose Run.



3. Select MacroAssignToMenu and choose OK.

4. Select Template in the Context box.

5. Select Reset All.

This restores the template back to the original menu options. At this
point, you can save the document template. Remember to save global
glossary changes when you exit Word for Windows versions 1.0 and 2.0 and 
if prompted in version 6.0.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," page 196

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-cd 2.00b
wm_word 2.00c 2.00c-cd w4wtemplate



Auto Macros in Word for Windows
Article ID: Q70991
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

Word for Windows reserves special names for macros that you can create
to alter aspects of Word's behavior. These are called auto macros.
AutoExec, AutoNew, AutoOpen, AutoClose, and AutoExit are the auto
macros in Word for Windows.

MORE INFORMATION
================

Word recognizes a macro whose name begins with "Auto" as a macro that
runs automatically when the situation to which it applies arises. You
supply the actual steps for the auto macro by either writing or
recording the macro.

You can prevent an auto macro from running by holding down the Shift
key when you perform the action that triggers the macro.

Description of Auto Macros
--------------------------

AutoExec        The AutoExec macro runs when you start Word.
                This macro makes it easy to instruct Word to
                automatically make adjustments when you start
                Word. For example, you can create an AutoExec
                macro that will automatically change the default
                directory when Word for Windows is opened.
                For more information on how to change the default
                directory, query on the words:

                   changing and default and directory and word and
                   windows

                You can prevent AutoExec from running by typing

                   winword /m

                when you start Word.

AutoNew         The AutoNew macro runs after you create a
                new document based on a current template.
                For example, an AutoNew macro could be created
                to update all the fields in a document, attached
                to a template of choice, and then executed when



                a new document is opened based on that template
                of choice. To base a new document on a template,
                first select File from the menu bar then New from
                the File menu. Now select New document and
                specify which template the document will be
                based on under Use Template. You now have a new
                document based on a selected template.

AutoOpen        The AutoOpen macro runs after you open a file with
                the File Open or File Find command, or from the list
                of the last four documents that were opened found at
                the bottom of the File menu.

AutoClose       The AutoClose macro runs when you close a document.

AutoExit        The AutoExit macro runs when you quit Word.

REFERENCES
==========

"Microsoft Word for Windows Technical Reference," pages 7-8

"Microsoft Word for Windows and OS/2 Technical Reference," pages 97-99

"Using WordBasic," by WexTech Systems and Microsoft, pages 84-87.

Additional reference words: 1.0 1.1 1.1a 1.00 1.10 1.10a w4wmacro wm_word 
w4wtemplate filefind 2.0 2.00 6.00



Word for Windows: Storing Formatted Text as a Glossary Item
Article ID: Q72547
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

If you select and define text as an AutoText entry (version 6.0) or
glossary entry (versions 1.0 and 2.0) in Microsoft Word for Windows,
the formatting of the resulting glossary entry depends on two factors:
 
1. A text selection that contains a paragraph mark is treated
   differently than a text selection without a paragraph mark.

2. Word distinguishes manual formatting from formatting that is
   applied as part of a style.

MORE INFORMATION
================

Defining a Glossary from a Selection
That Does Not Contain a Paragraph Mark
--------------------------------------

If the text you select to store in the glossary is less than a full
paragraph, Word stores both the text and all the character formatting
that you've applied manually to that text. Word does not store any
character formatting that is the result of a style nor does it store
any paragraph formatting.

Defining a Glossary from a
Selection That Does Contain a Paragraph Mark
--------------------------------------------

If the text you select to store in the glossary includes a paragraph
mark, Word stores both the text and the style that's associated with
it. Any manual character and/or paragraph formatting you apply is also
stored in the glossary in addition to the style formatting.
 
When you insert the glossary text into a document, Word includes the
entry's style. If the document into which the glossary is inserted
does not have a style of the same name stored in the template, Word
adds that style to the document.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," pages 141-142



Additional reference words: 1.0 1.1 1.1a 1.00 1.10 1.10a 2.0 2.00  wm_word 
w4wtemplate 6.00



New Template Based on Normal Does Not Copy Styles
Article ID: Q74722
---------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0 
 - Microsoft Windows operating system versions 3.0 and 3.1
---------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, new templates that are based on the 
Normal template do not copy the user-defined style definitions or 
modified automatic styles from that template. Only the default styles
that  appear when the Normal template has not been modified will be
copied  into the new template. When creating a new template based on a 
template other than Normal, all style definitions will be copied from
that  template.

MORE INFORMATION
================

To include all style definitions when creating a new template based on
Normal, one of the following options must be taken.

Option 1
--------

Create a new document based on Normal and save it as a template
as follows:

1. From the File menu, choose New Document based on Normal.

2. From the File menu, choose Save As, choose the Options button, and
   select Document Template as the file format.

When the file is created as a Document based on Normal, it will copy
all the styles from the Normal template.

Option 2
--------

Word for Windows version 6.0
----------------------------

Copy the desired styles from the Normal template into the new template 
using the Organizer dialog available by choosing Style from the Format 
menu.

Word for Windows versions 1.x and 2.x
-------------------------------------

Merge the styles from the Normal template into the new template based 



on Normal.

REFERENCES
==========

"Microsoft Word for Windows User's Reference," page 345

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-cd 2.00b
wm_word 2.00c 2.00c-cd w4wtemplate 6.00



Style Shortcut Keys Not Reflected in Template
Article ID: Q77547
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, any shortcut keys that you
assign to styles in a document are not reflected in the document
template unless you add the styles to the template file.

This problem was corrected in Word version 6.0 for Windows.

MORE INFORMATION
================

If you assign a shortcut key to a style within a document, the key
assignments are not added to the document template file unless you
select the Add to Template option. The key assignments are valid in
the current document, but new documents that are based on the template
file do not include the key assignments.

To record the shortcut key assignments in the template file, follow
these steps:

1. From the Format menu, select Style.

2. Choose the Define button. Assign a shortcut key to a style if a key
   assignment has not already been made by selecting the style name from
   the drop-down list box, choosing a shortcut key, and clicking on the
   Assign button.

3. Select the check box labeled Add to Template (ALT+E).

4. Choose the Apply button.

Any changes made to the selected style, including the shortcut key
assignment are now reflected in the template file.

STATUS
======

Microsoft has confirmed this to be a problem in Word for Windows
versions 2.x. This problem was corrected in Word version 6.0 for
Windows.

Additional reference words: 2.00 2.00a w4wmacro 2.00a-CD 2.00b
w4wtemplate



Custom Table Insertion with Text to Table in WinWord 2.0
Article ID: Q78763
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, converting text to a table is an
automatic process that does not allow you to specify the desired
number of rows or columns. However, you can install the
ManualInsertTable macro from the NEWMACRO.DOC file, included with Word
for Windows version 2.0 and usually found in the program directory, to
provide this functionality.

This functionality was changed in Word version 6.0 for Windows.

MORE INFORMATION
================

NEWMACRO.DOC contains a macro called ManualInsertTable that allows you
to specify the number of rows and columns desired when converting text
to a table in Word for Windows version 2.0. This macro emulates the
functionality of the Insert Table command in Word for Windows version
1.x. NEWMACRO.DOC allows you to install this macro by using the
following steps:

1. Open the file NEWMACRO.DOC.

2. This file contains a list box of optional macros, descriptions of
   the macros, and the ability to demonstrate and/or install each macro.

3. From the list of macros, select ManualInsertTable.

4. Choose the Install button.

5. An "Install ManualInsertTable to" dialog box appears. Select the
   desired template and menu to contain the macro, and choose the OK
   button.

Word installs the macro on the template and menu you selected and
automatically saves the macro. Word returns you to the list box of
available macros to choose another macro or to exit.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 316-318

Additional reference words: w4wmacro w4wtemplate 2.00 2.00a 2.00a-CD 2.00b



2.00c



AutoNew Macro Does Not Run When You Start Word for Windows
Article ID: Q79054
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

If you have an AutoNew macro in the NORMAL.DOT template and you start
Microsoft Word for Windows, a new document is created, but the AutoNew
macro does not run.

MORE INFORMATION
================

The AutoNew macro only runs if you open a new document after starting
Word for Windows.  The AutoExec macro will run when starting Word for
Windows.

For more information on AutoNew, search for "auto macros" and
"Creating macros that run automatically" using the Help menu.

REFERENCES
==========

"Microsoft Word Technical Reference," pages 97-98

TECHREF.DOC, Microsoft Word for Windows version 1.x

Additional reference words: 6.00 execute 2.00 w4wmacro w4wtemplate wm_word 



Can't Exit Second Instance of WinWord Without a Global Save
Article ID: Q79135
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

When editing a global macro in a second instance of Microsoft Word for
Windows, this second instance does not close as expected if you choose No
when prompted to overwrite the NORMAL.DOT template that is open in the
first instance of Word for Windows. Choosing No cancels the File Exit
command and returns you to the second instance of Word for Windows.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------
  
1. Start Word for Windows version 2.0, and minimize it to an icon.
   Start a second instance of Word for Windows.
   
2. From the Tools menu, choose Macro (in the second instance of Word).
   In the Show box, select Commands. Select AllCaps from the Macro 
   Name box, and choose the Edit button. At the beginning of the "Super
   AllCaps" line in the macro, type "REM " (without the quotation 
   marks). Make sure you include a space after REM. 

3. From the File menu, choose Exit.
    
4. Choose the Yes button when Word prompts you to save changes to
   Global:AllCaps.
 
5. Choose the Yes button again when Word prompts you to save the
   global glossary and command changes. The following message appears
   in a dialog box:



 
      This document is a copy of a file that was being edited by another
      Word session. Changes may have been saved to the original file.
 
      Do you want to save the document using the original name and
      overwrite other possible changes?
 
6. Choose the No button. The File Save dialog box appears with
   NORMAL.DOT in the File Name box. Change this name to NORMAL2.DOT.
  
7. Word saves the new template; however, Word returns to the second
   instance of Word instead of exiting the program.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 267-268,
273, 765

Additional reference words: 2.00 2.00a 2.00a-cd 2.00b 2.00c 2.00c-cd 
w4wmacro w4wtemplate



Template Directory Changes After Aborted CBT Start
Article ID: Q79510
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows version 2.x, opening a document after
receiving an error message in the Learning Word tutorial may result in
the following error message:

   This document template does not exist.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

WORKAROUND
==========

To work around this problem and open a new document, exit Word for
Windows, and restart the program.

Additional reference words:  w4wtutorial 2.00 2.00 2.00a 2.00a-CD 2.00b
2.00c w4wtemplate



WinWord: Assigning Passwords to Template Files
Article ID: Q79644
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you can assign a password to protect 
custom templates. You cannot assign a password to templates
that come with Word for Windows; however, if you create your own
templates based on the program templates, the option to assign a
password becomes available.

This is not a problem in Word for Windows version 6.0. It is possible to 
assign a password to templates that come with Word for Windows 
version 6.0.

MORE INFORMATION
================

Any document based on a password-protected template requires the
password to access the template. If the document is used on another
computer without the password-protected template available, the file
generates an error message stating XXXX.DOT is not found, where XXXX
is the name of the template the document is based on.

When this error displays, choosing the OK button causes the document
to use the normal template, and the document is not protected with the
template password.

To display the contents of the document that is based on the
password-protected template, use the following steps:

1. From the File menu, choose File Find. Select the document in the
   list.

2. Choose the OK button when Word prompts you for the password.

3. Choose the OK button when prompted for the password a second time.

4. Choose the Options button. Under List File Names With, select
   Content, and then choose the OK button.

The contents of the document display on the screen.

For information on password protecting documents see Protecting
Documents from Changes in the "Microsoft Word for Windows User's
Guide."



REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 78-79

Additional reference words: 2.00 protection 6.00 w4wtemplate wm_word 



Unspiking Does Not Clear Template of Spiked Glossary Items
Article ID: Q79928
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1

--------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, deleting the glossary entry called Spike 
does not clear the NORMAL.DOT template of Spike glossary item(s). Spike 
is a special glossary entry in which you can collect text and graphics 
from various locations in a document, and insert them as a group in 
another location.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

In Word for Windows, there are two ways to delete Spike glossary items. 
Choose one of the following methods:

 - From the Edit menu, choose Glossary. Select Spike, and choose the
   Delete button.

  -or-

 - Use the Unspike key combination (CTRL+SHIFT+F3) to remove text or
   graphics that you no longer want to include in the Spike. Select the
   words you want to include, and press CTRL+F3 to create the new Spike.

Steps to Reproduce Problem
--------------------------

 1. In a new document, type in the word "ONE" (without the quotation
   marks).

 2. Select the text, and press CTRL+F3.



 3. From the File menu, choose Exit.

 4. Choose the Yes button when prompted to save global glossary and
    command changes.

 5. Start Word for Windows again.

 6. Press CTRL+SHIFT+F3. Word removes "ONE" from the Spike and inserts
    it in the document.

 7. Exit Word for Windows again.

 8. Choose the No button when prompted to save changes.

 9. Start Word for Windows again.

10. Press CTRL+SHIFT+F3.

Word inserts the Spike glossary item "ONE." The Unspike function does
not delete Spike glossary entries. This is also a problem in Word for
Windows version 1.x.

For more information on using the Spike, search for "Spike" using the
Help menu.

ref
"Microsoft Word for Windows User's Guide," version 2.0, pages 271-272

Additional reference words: 2.00 w4wtemplate



Cannot Copy Over NORMAL.DOT When Running Word for Windows
Article ID: Q79931
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows, you cannot save a document or template 
(other than the NORMAL.DOT being used) with the filename 
NORMAL.DOT to the directory the templates are stored in.

MORE INFORMATION
================

For example, you cannot open the file NORMAL.DOT from one version of
Word for Windows and save it as NORMAL.DOT in a running version of
Word for Windows in order to convert and use the default template in
the newer version.
 
NORMAL.DOT is the default template in Word for Windows. If you run 
Word for Windows and NORMAL.DOT is not found, Word for Windows 
creates the file. In Word for Windows version 6.0, this file is saved 
upon exit even if no changes have been made to it. In Word for Windows 
version 2.0, if there is nothing in this file (such as a macro, glossary 
change, or global style change) when the session ends, the file is not 
saved. 

This file is considered open while you run Word for Windows; therefore, 
you cannot replace this file with another while Word for Windows is 
running.

Steps to Reproduce Problem
--------------------------

The following steps assume that your system contains two versions of
Word for Windows, one stored in C:\WINWORD and one stored in 
C:\WW2:

1. From the WW2 directory, start Word for Windows.

2. From the File menu, choose Open.

3. Open the file C:\WINWORD\NORMAL.DOT.

4. From the File menu, choose Save As.

5. In the File Name box, type "C:\WW2\NORMAL.DOT" (without the
   quotation marks), and choose the OK button.



The error message "Word cannot give a document the same name as an
open document." appears on the screen.

If conversion is necessary to use another template as the NORMAL.DOT
in the running version of Word for Windows, use the following
procedure:

1. Verify that Word for Windows is not running.
 
2. In MS-DOS or File Manager, copy C:\WINWORD\NORMAL.DOT to
   C:\WW2\NORMAL.DOT.
 
3. From the WW2 directory, start Word for Windows.

This causes the version of Word for Windows started from the WW2
directory to convert and use the NORMAL.DOT file that you copied into
the WW2 directory in step 2 (assuming there is no User-Dot-Path in the 
WINWORD6.INI file (Dot-Path in the WIN.INI file for Word for Windows 
version 2.0) redirecting the template directory).

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 698-699,
718
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2.00b wm_word 2.00a-CD 6.00



WinWord: Cannot Assign a Shortcut Key with the Numeric Keypad
Article ID: Q79984
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, you cannot assign a shortcut key to a
macro using a number from the numeric keypad.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose New, and choose the OK button.

2. From the Tools menu, choose Record Macro.

3. Type a name for the macro.

4. In the Shortcut Key box, select the Ctrl check box, and verify the
   Shift check box is NOT selected. Position the insertion point in the
   Key box, and type the number 1 on the numeric keypad.

5. Type a few lines of text in your document.

6. From the Tools menu, choose Stop Recorder.

7. Activate the macro by pressing CTRL+Keypad 1.

The system just beeps. If you activate the macro by pressing CTRL+1
using the number 1 on the top of the keyboard, rather than the numeric
keypad, the macro runs correctly.

This feature works correctly in Word for Windows version 1.x. If you
convert a template from version 1.x that contains a macro shortcut key
assigned to the numeric keypad, the macro works correctly in version



2.0 using the numeric keypad assignment.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b w4wmacro
w4wtemplate



WinWord: Avoiding Password Prompt Using FileNew Command
Article ID: Q80090
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In a Microsoft Word for Windows macro, if you use the FileNew command to 
create a new document or template based on a password-protected 
template, you receive a prompt for the template's password. The only way 
to avoid receiving this prompt is to have the specified template already 
open.

MORE INFORMATION
================

In Word for Windows macros, the FileOpen command may use a PASSWORDDOC 
and/or a PASSWORDDOT field to provide the password for the given 
document and/or the template that it is based on. The FileNew
command does not have either of these fields; therefore, when you
create a new document or template based on a specific template, you
cannot specify a password inside the macro to avoid the password
prompt.

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c  wm_word 
w4wmacro wordbasic statement protection
w4wtemplate



Automating Form Templates Without Using ASK or FILLIN Fields
Article ID: Q80551
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, the normal procedure for automating
form templates is to use a series of ASK or FILLIN fields in
conjunction with an AutoNew macro. (For more information on this
procedure refer to the "Microsoft Word for Windows User's Guide,"
version 2.0, pages 480-484, or the "Microsoft Word for Windows User's
Reference," page 188.) With this procedure, responses are restricted
to a total character value of 255 per dialog box. If your automated
form requires greater response flexibility and/or the response dialog
boxes are not desired, the method below may prove effective.

Note: Word for Windows version 6.0 uses Form fields to get around the 
character restriction in Ask and Fillin fields.

To use blank fields to automate form templates, use the following
steps:

1. From the File menu, choose New, and choose the OK button.

2. Type the following information, pressing ENTER several times after
   each entry:

      Name:

      Address:

      Phone Number:
  
3. Press CTRL+F9 to create a set of field code braces for each entry.
   Your form should appear as follows:

      Name:  {}

      Address:  {}

      Phone Number:  {}
 
   Note: These braces are hidden unless you choose Field Codes from the
   View menu. As long as the braces do not contain any spaces or
   characters, they do not generate any error messages.
 
4. With the field code braces positioned after each question, you can
   use the F11 key to move quickly to each question. The SHIFT+F11 key



   combination moves your insertion point to the previous question.
 
5. From the File menu, choose Save As. Assign the new form template a
   name. In Word for Windows version 2.0, select Document Template
   (*.DOT) from the Save File as Type list, and choose the OK button. In
   Word for Windows version 1.x, choose the Options button, choose
   Document Template from the File Format list, and choose the OK 
   button.

MORE INFORMATION
================

You can further automate the above process by adding an AutoNew 
macro that alerts the user (with a message box) that the F11 and the
SHIFT+F11 keys are available for navigation within the form.
Additionally, you can use the insertion of bookmark names
corresponding to the empty field code braces to customize navigation
to individual questions. For example, in the above procedure, choose
Field Codes from the View menu to display the hidden braces. Select
the braces beside the Address field. From the Insert menu select
Bookmark. In the Bookmark Name field, type "Address" (without the
quotation marks) and choose the OK button. You can use the GoTo key
(F5) to position the insertion point at any specified question.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 480-84,
730, 742, 753-54

"Microsoft Word for Windows User's Reference," version 1.x, pages
19-20, 84-89, 188, 215

Additional reference words: w4wmacro w4wfield w4wtemplate
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 2.00c-cd



Incorrect Filename Appears When Saving UNC-Opened Template
Article ID: Q80762
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you choose Save As from the File menu 
to save a template opened through Universal Naming Convention (UNC), an 
incorrect filename appears in the File Name box.

This problem was corrected in Word version 6.0 for Windows.

Note: This problem occurs only on networks that support UNC.

More Information:

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose Open.
 
2. In the File Name box, type the UNC filename, then choose the OK
   button. The following is an example:

      \\SERVER\SHARE\DIRECTORY\TEMPLATE.DOT

3. From the File menu, choose Save As.

Word for Windows inserts a drive letter BEFORE the UNC path, as in the
following example:

   C:\\SERVER\SHARE\DIRECTORY\TEMPLATE.DOT

Additional reference words: 2.00 2.00a 2.00a-cd 2.00b 2.00c 2.00c-cd
w4wnetwork w4wtemplate



Macro Editing Commands Available When Template Is Read-Only
Article ID: Q80785
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

If you open a read-only template in Microsoft Word for Windows, the
Edit, Rename, Delete, and Set (Set is in Word for Windows version 1.x
only) macro options do not appear unavailable (dimmed). If you make
changes to any template macros, Word doesn't display an error message
to warn that changes cannot be made to the template until you try to
save the template.

MORE INFORMATION
================

When using a read-only template, such as one on a network, the options
to Rename, Delete, Edit or Set are available. In Word for Windows
version 2.0, the Rename, Delete, and Edit buttons are available in the
Tools Macro dialog box when the Show Template Macros option is
selected. In Word for Windows version 1.x, the Delete, Rename, and Set
buttons are available in the Macro Edit dialog box when the Global
Context is selected. However, if you use any of the above buttons to
make changes to macros in a read-only template and choose the File
Save command, you receive the error following message:

   File is read-only. (version 1.x)

   This file is read-only. (version 2.0)

The Save As dialog box displays, and you can save the changes to a new
filename.

Additional reference words: 2.00 1.00 1.10 1.10a 1.0 1.1 1.1a  wm_word 
w4wtemplate w4wnetwork w4wmacro greyed ghost unavailable 6.00



Word for Windows: Print Merge to Xerox Self-Adhesive Labels
Article ID: Q80808
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Microsoft Word for Windows version 2.x does not ship with a template
to print labels on Xerox self-adhesive labels. Word for Windows does
not have an option for printing to 33 labels (3x11) on a single page;
however, the following steps create a print merge document that does
print 33 labels on an individual page:
    
1. From the File menu, choose New, select NORMAL, and choose the OK
   button.
   
2. From the Table menu, choose Insert Table, set up create 3-column,
   11-row table, and choose the OK button.
  
3. From the Table menu, choose Select Table.
  
4. From the Table menu, choose Row Height, select Exactly in the
   Height of Rows 1-11 box, and type 5.9l li in the At box. From the   
   Table menu, choose Column Width, type 2.80" in the Width of Columns 
   1-3 box, and type 0" in the Space Between Cols box.
   
5. From the Format menu, choose Page Setup, and select the Margins
   option button. Type 0" in the Top and Bottom boxes, then type .25" in
   the Left box, and .01" in the Right box.
  
6. From the File menu, choose Print Merge, then choose the Attach Data
   File button, select the desired file, and choose the OK button.
 
7. Starting on the first line inside each column, insert your merge
   fields.
   
8. From the File menu, choose Print Merge, and press the Merge button.
   Select the desired options, and choose the OK button.
  
9. Word displays a message stating that your margins are outside the
   printable area. Choose the Yes button to continue printing.

Note: Because Xerox labels require that printing begins
three-sixteenths of an inch from the top and left edges, the margins
must be set outside the printable area of the page.

Note: Word for Windows version 6.0 allows for creation of custom size 
labels.

ref
"Microsoft Word for Windows User's Guide," version 2.0, pages 313-330



Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c 
3 x 11 w4wtemplate



Word for Windows: Glossary Management Macros
Article ID: Q80838
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

This article contains four macros to automate the management and
movement of glossary entries in Microsoft Word for Windows version
2.0.

Note: This is a built-in feature in Word for Windows version 6.0.

MORE INFORMATION
================

Macro 1 copies all glossary entries (with formatting) from the global
template (NORMAL.DOT) to the document template. This macro assumes 
the following conditions:

 - The active document is blank (if Show All is active, one paragraph
   mark displays).

 - The active document is based on a template other than NORMAL.DOT.
   Check the Template dialog box for this information.

Note: This article refers to "document template" as the template
attached to the active document.

For more information about templates and glossaries:

 - Refer to pages 273 and 705-706 in the "Microsoft Word for Windows
   User's Guide."

  -or-

 - Search for "Chapter Listing" and "Customizing Word" using the Help
   menu.

Macro 1
-------

Sub MAIN
For N = 1 To CountGlossaries(0)
  EditGlossary .Name = GlossaryName$(N, 0), .Context = 0,\
     .Insert
  EditSelectAll
  CharLeft 1, 1
  EditGlossary .Name = GlossaryName$(N, 0), .Context = 1,\
      .Define
  EditClear
Next



End Sub

For more information about EditGlossary, GlossaryName$(), and
CountGlossary(), search for "WordBasic Programming Language" using 
the
Help menu.

Macro 2 contains a reversal of the .Context = X information in Macro
1. In all other respects, Macros 1 and 2 are the same. All assumptions
for Macro 1 also apply to Macro 2.

Macro 2
-------

Sub MAIN
For N = 1 To CountGlossaries(1)
   EditGlossary .Name = GlossaryName$(N, 1), .Context = 1,\
      .Insert
   EditSelectAll
   CharLeft 1, 1
   EditGlossary .Name = GlossaryName$(N, 1), .Context = 0,\
      .Define
   EditClear
Next
End Sub

Macro 3 copies all glossary entries from the global template to the
document template. This macro is much faster than the previous macros;
however, formatting IS lost.

Note: SetGlossary statement is limited to 255 characters.  A dialog
box will appear, informing of what glossary items not copied. Use
macros 1 or 2 for large glossaries.

Macro 3
-------

Sub MAIN
For N = 1 To CountGlossaries(0)
        A$ = GetGlossary$(GlossaryName$(N, 0), 0)
        If Len(A$) < 256 Then
             SetGlossary GlossaryName$(N, 0), A$, 1
        Else
             MsgBox "The glossary named " + GlossaryName$(N, 0) + \
             " is to large to copy"
        End If
Next
End Sub

To go from document template to global template, replace each of the
zeros with the number one (1), and replace the number one (1) on the
SetGlossary line with a zero (0).

Macro 4 deletes all glossary entries from a template. Use a zero (0)
for the global template and the number one (1) for a document
template. The following macro deletes all global glossaries:



Macro 4
-------

Sub MAIN
For N = 1 to CountGlossaries(0)
   EditGlossary .Name = GlossaryName$(N, 0), .Context = 0,\
      .Delete
Next
End Sub

Additional reference words: 2.00 2.00a 2.00a-cd 2.00b 2.00c 2.00c-cd 
w4wmacro copy move w4wtemplate



WinWord: Canceling Template Dialog Box Doesn't Cancel Change
Article ID: Q80881
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In the Template dialog box of Microsoft Word for Windows, if you
select a different option button under Store New Macros and Glossaries
As and choose the Cancel button, Word does NOT cancel the change.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

1. From the File menu, choose Template.

2. Select a different option button under Store New Macros and
   Glossaries As. Do NOT choose the OK button.

3. Choose the Cancel button.

4. From the File menu, choose Template again.

Note that the option selected in step 2 is active.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 489,
700-701

Additional reference words: 2.00 2.00a 2.0 2.0a 2.00a-CD 2.00b
w4wtemplate





WordBASIC Err=514 Using the MacroCopy Statement
Article ID: Q80983
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows version 2.x, if you use the MacroCopy
WordBasic command to reference templates that have not been saved,
Word generates the following error message:

   WordBASIC Err=514
   Document not open

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

MORE INFORMATION
================

When you create a new template, Word for Windows assigns it a default
name (for example, Template1 or Template2). If you use an unsaved
template's default name as an argument for the MacroCopy statement,
you receive the above WordBasic error message.

To work around this problem, save templates with appropriate filenames
before using them with the MacroCopy command.

Additional reference words: 2.00 2.00a 2.00a-cd 2.00b 2.00c 2.00c-cd 
w4wmacro errmsg msg w4wtemplate



WinWord: ToolsMacro .Run Does Not Follow Context Hierarchy
Article ID: Q81027
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

In the Microsoft Word for Windows version 2.x WordBasic macro
language, the ToolsMacro .Run command is not designed to follow the
context hierarchy prescribed for the execution of Word for Windows
macros. This is because the command corresponds to the Macro dialog
box where the context is selected with an option button in the Show
box.

In Word for Windows version 6.0, the ToolsMacro .Run command has an
argument that is designed to follow the context hierarchy.

MORE INFORMATION
================

When you run a Word for Windows macro from the command line (ie. if
you start Word by typing "WIN WINWORD /mMyMacro" at the MS-DOS
prompt), Word looks for the macro first in the document template, then
in NORMAL.DOT, and finally in the built-in commands. This hierarchy
holds even if the macro has the same name as a built-in command (such
as FilePrint).

When you run a Word for Windows macro that has the same name as a
built in command by calling its name in another macro, Word runs the
built-in command.

If you run a macro using the ToolsMacro .Run WordBasic command and do
not specify the .Show argument, the macro runs in the context
specified the last time the you chose Macro from the Tools menu.

Word for Windows version 6.0
-----------------------------

If you run a macro using the ToolsMacro .Run command with the .Show
argument 0, the macro will run according to Word's macro searching
hierarchy. In the following example, Word looks for the macro first in
the document template, then in NORMAL.DOT, and finally in the built-in
commands.

   ToolsMacro .Name = "mymacro", .Show = 0, .Run

Word for Windows version 2.0
----------------------------



If you run a macro using the ToolsMacro .Run command without the .Show
argument AND have not previously chosen Macro from the Tools menu, the
.Show argument defaults according to the .Store argument in the
Template dialog box (accessed by choosing Template from the File
menu). The .Store argument corresponds to the options in the Store New
Macros And Glossaries As box. The .Store argument corresponds as
follows to the .Show argument:

   File Template                  Tools Macro
   -------------                  -----------
   Store New Macros and
   Glossaries as:                 Show:
      Global                         Global
      Template                       Template
      Prompt for Each New            Previous Setting

If you want Word for Windows to follow the Template, Global, Built-in
Command context hierarchy for macro execution in Word for Windows
version 2.0 (assuming the name is not the same as a built-in command),
run your macro by calling its name rather than using the ToolsMacro
statement.

REFERENCES
==========

"Using WordBasic," by WexTech Systems and Microsoft, pages 210, 308

"Microsoft Word for Windows User's Guide," version 2.0, pages 705-706

Additional reference words: 2.00 2.00a 2.00a-cd 2.00b 2.00c 2.00c-cd
wm_word 6.00 w4wmacro wrong w4wtemplate



NORMAL.DOT Template File Not Found in WinWord Directory
Article ID: Q81693
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows version 2.0, a physical NORMAL.DOT
template file does not appear in the Word for Windows directory until
you have made a change to the Normal template and saved it.

In Word for Windows version 6.0, a physical NORMAL.DOT template file is
created after exiting the program the first time.

MORE INFORMATION
================

To force Word for Windows version 2.0 to create a NORMAL.DOT file, follow
the steps below:

1. From the File menu, choose New, then choose the OK button.

2. Type "one" (without the quotation marks), and select it.

3. From the Edit menu, select Glossary. In the Glossary Name box, type
   "one" (without the quotation marks).

4. From the File menu, choose Save All. Choose No when prompted to
   save document changes. Choose Yes when prompted to save the global
   glossary and command changes.

At this point, a physical NORMAL.DOT file is created in the Word for
Windows version 2.0 directory.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, page 698

Additional reference words: 2.00 2.00a 2.00a-cd 2.00b 2.00c 2.00c-cd
6.00 wm_word w4wtemplate



Macro to Choose Local or Network Templates at File New Command
Article ID: Q81695
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SUMMARY
=======

The NEWMACRO.DOC file included with Microsoft Word for Windows version
2.0 contains a macro called NetworkTemplateStorage; this macro prompts
you to select network or local templates when you use the File New
command.

NOTE: This is a built in feature in Word for Windows version 6.0. By
choosing Options from the Tools menu and selecting the File Locations
tab, you can select different directories for User Templates and
Workgroup templates.

MORE INFORMATION
================

Note: Before installing this macro, make a backup copy of your
NORMAL.DOT file in case the results of this procedure are not
satisfactory.

To install the NetworkTemplateStorage macro, use the following steps:

1. From the File menu, choose Open. Select the Word for Windows
   directory in the Directories box, select the file NEWMACRO.DOC from
   the File Name box, then choose the OK button.

2. From the list of macros under Macro Name, select
   NetworkTemplateStorage, and choose the Install button.

3. When prompted, select the template and menu that you want to add
   the macro to, then choose the OK button.

4. The Save dialog box appears and allows you to save changes to any
   open documents. Choose the OK button or the Cancel button.

5. When you exit Word for Windows, be sure to choose the Yes button in
   response to the prompt "Do you want to save the global glossary and
   command changes?"

Note: In step 3 above, if you choose to add this macro to the File
menu, the File New command is renamed FileNew. Note that FileNew has
no key combination (accelerator key) assigned to it. If no top-level
menu was chosen in step 3 above, the menus appear to be unchanged.

The first time you run the NetworkTemplateStorage macro or choose the



File New (FileNew) command, Word prompts you for the network and local
template directories. Thereafter, FileNew opens a dialog box where you
can select either network or local templates before the usual New
dialog box appears and you choose a template.

Be sure to consider the following facts before installing the
NetworkTemplateStorage macro:

 - NEWMACRO.DOC writes DOT-PATH1= and DOT-PATH2= (corresponding to the
   local and network template directories) in the [Microsoft Word 2.0]
   section of your WIN.INI even if you only choose the Demo button and do
   not actually install the macro.

 - The FileNew routine, installed with the NetworkTemplateStorage
   macro, replaces the default File New command even if you choose
   another top-level menu (such as Edit). This occurs even if you chose
   to add the macro to no menus at all.

 - The procedures outlined on page 720 of the "Microsoft Word for
   Windows User's Guide" to reset the menus or to remove the FileNew
   command from a menu do not work correctly. If you choose the Reset All
   button in the Options dialog box (accessed by choosing Options from
   the Tools menu and selecting the Menus category), the menu(s) is
   restored, but the default File New command is not restored. Similarly,
   if you use the use the Options dialog box to reassign the default File
   New command to the menu, the FileNew macro, installed by the
   NetworkTemplateStorage macro, is not replaced.

The only way to delete the FileNew functionality installed with the
NetworkTemplateStorage macro is to delete the FileNew macro from the
Global Macros list in the Macro dialog box and delete the DOT-PATH1=
and DOT-PATH2= lines from the [Microsoft Word 2.0] section of your
WIN.INI file.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 720, 810

Additional reference words: w4wmacro w4wnetwork w4wtemplate
2.00 2.00a 2.00a-CD 2.00b 2.00c
context entry line



Glossary Entry with Normal Style Doesn't Maintain Alignment
Article ID: Q81742
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

In Microsoft Word for Windows, if you format an autotext (known as 
glossary entry in Word 2.0) entry with Normal style and then directly 
format it with an alignment that differs from the Normal style, the 
autotext entry loses the direct alignment formatting if you save the 
template. After saving the template, text inserted from the autotext 
entry is formatted with the Normal style alignment rather than the 
alignment you originally assigned to the autotext entry.

Microsoft has confirmed this to be a problem in Microsoft Word for
Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 2.0b, 2.0c, and 6.0. We are
researching this problem and will post new information here as it
becomes available.

More Information:

Workaround
----------

Format the text with a unique
style prior to defining as autotext. When the autotext is
expanded, the style is included with the expanded text.

1. Type the desired autotext text on a blank paragraph line.

2. Apply the desired alignment formatting to the text.

3. Press CTRL+Shift+S (CTRL+S in Word 2.0) to activate the Style box
   on the ribbon.

4. Type a unique style name (preferably the same name that you want to
   use for the autotext name), and press ENTER.

5. Select the paragraph.

6. From the Edit menu, choose AutoText (Glossary in Word 2.0). In the 
   Name box, type a unique name (preferably the same name entered in 
   step 4), and choose the Add (Define in Word 2.0) button.

7. From the File menu, choose Save All. Choose the Cancel or No button 
   when prompted to save the current document. Choose the Yes button in
   response to the prompted to save changes to global template.

The next time the autotext is expanded, the text is formatted



according to the uniquely-defined style.

Steps to Reproduce Problem
--------------------------

 1. From the File menu, choose New, then choose the OK button.

 2. Change the Normal style alignment to Justified with the following
    steps:

    a. From the Format menu, choose Style, and select Normal in the 
       Style box.

    b. In Word 6.0, choose the Modify button and from the Format drop-
       down box choose Paragraph. In Word 2.0, choose the Define button, 
       then choose the Paragraph button.

    c. In the Alignment box, select Justified, then choose the OK 
       button.

    d. Check the Add To Template.
   
    e. Choose the Change button (Word 2.0 only). Choose the Yes button 
       is response to the prompt "Do you want to change the properties 
       of the standard style?"

    f. Choose the Apply button.

    g. From the File menu, choose Save All. Choose the Cancel or No 
       button when prompted to save the current document. Choose the Yes 
       button in response to the prompted to save changes to global 
       template.

 3. Type the desired AutoText text on a blank paragraph line.

 4. Press CTRL+L to left-align the text.

 5. Select the current paragraph.

 6. From the Edit menu, choose AutoText, type "test" (without the
    quotation marks) in the Name box, and choose the Add
    button.

 7. Test the AutoText in the current document. On a blank line
    formatted with the Normal style (paragraph alignment is justified),
    type "test" (without the quotation marks), and press F3 to expand 
    the AutoText entry.

 8. Position the insertion point in the inserted text. Note that it is
    left-aligned, as expected.

 9. From the File menu, choose Save All. Choose the Cancel or No button 
    when prompted to save the current document. Choose the Yes button in
    response to the prompted to save changes to global template.

10. Repeat step 7.



Position the insertion point in the text inserted in step 10. Note
that the alignment is now justified.

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 267-269,
700-704

"Microsoft Word for Windows User's Reference," version 1.x, pages
141-142, 69-70

Additional reference words: w4wformat w4wtemplate 6.00 wm_word 
1.00 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c wrong stored expand



WinWord 2.0: Avery Laser Label Information
Article ID: Q81937
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

The following is a reproduction of the information found on the back
of the retail package of Avery Laser Labels. The MAILLABL.DOT file,
which is a mailing label template that ships with Microsoft Word for
Windows versions 2.x, only gives the Avery Product Code and a brief
description of each label. The template does not list the dimensions for
each label, which makes the template difficult to use if you do not have
Avery brand labels.

NOTE: In Word for Windows version 6.0, Avery label dimensions are
included as part of the label feature.

MORE INFORMATION
================

Some of the product codes listed below do not appear in the MAILLABL
template listing. They are included here (designated with an asterisk
[*]) with a reference for the label numbers that duplicate their
layout.

Avery Laser Labels
------------------

Product Code      Label Size (HxW)   Number of Columns  Labels Per 
Sheet
------------      ----------------   -----------------  ----------------

5066              2/3" x 3 7/16"          3               30
5095* (use 5395)
5096              2 3/4" x 2 3/4"         3               9
5097              1 1/2" x 4"             2               12
5160              1" x 2 5/8"             3               30
5161              1" x 4"                 2               20
5162              1 1/3" x 4"             2               14
5163              2" x 4"                 2               10
5164              3 1/3" x 4"             2               6
5165              8 1/2" x 11"            1               1
5182* (use 5165)
5196              2 3/4" x 2 3/4"         3               9
5197              1 1/2" x 4"             2               12
5198              1 2/3" x 3 1/2"         2               12
5199 (Face)       1 5/6" x 3 1/16"        2               10
5199 (Spine)      2/3" x 5 13/16"         1               15



5260              1" x  2 5/8"            3               30
5261              1"  x  4"               2               20
5262              1 1/3" x 4"             2               14
5266              2/3" x 3 7/16"          2               30
5267 same as: LSK-5 11436
                  1/2" x 1 3/4"           4               80
5282* (use 5165)
5345              2" x 4"                 2               10     
5352* (use 5663)
5366* (use 5266)
5383              2 1/6" x 3 1/2"         2               8
5384              3"  x  4"               2               6
5385              2 1/6" x 4"             2               8
5386              3"  x  5"               1               3
5388              3"  x  5"               1               3
5389              4"  x  6"               1               2
5395              2 1/3" x 3 3/8"         2               8
5660              1" x 2 5/8"             3               30
5662              1 1/3" x 4 1/4"         2               14
5663              2" x 4 1/4"             2               10
5766* (use 5266)
5883              2 1/6" x 3 1/2"         2               8
5895              2 1/3" x 3 3/8"         2               8
5896              2 3/4" x 2 3/4"         3               9
5897              1 1/2" x 4"             2               12

International Labels in Millimeters and Inches
----------------------------------------------

Product Code   Label Size        Number of Columns    Labels Per Sheet
------------   ----------        -----------------    ----------------

7160           38.1mm x 63.5mm         3                 21
               (1 1/2") x (2 1/2")
7161           46.56mm x 63.5mm        3                 18
               (1.83") x (2 1/2")
7162           33.87mm x 99.06mm       2                 16
               (1 1/3") x (3.90")
7163           38.10mm x 99.06mm       2                 14
               (1 1/2") x (3.90")
7164           71.97mm x 63.5mm        3                 12
               (2.83") x (2 1/2")
7165           67.73mm x 99.06mm       2                 8
               (2 2/3") x (3.90")
7166           93.13mm x 99.06mm       2                 6
               (3 2/3") x (3.90")
7167           289.05mm x 199.60mm     1                 1
               (11 1/3") x (7.85")
7562           33.87mm x 99.06mm       2                 16
               (1 1/3") x (3.90")
7563           38.10mm x 99.06mm       2                 14
               (1 1/2") x (3.90")
7565           67.73mm x  99.06mm      2                 8
               (2 2/3") x (3.90")
7651           21.17mm x 38.1mm        5                 65
               (0.83") x (1 1/2")
7654-F         46.58mm x 76.2mm        2                 12



               (1.83") x (3")
7654-S         16.93mm x 144.78mm      1                 16
               (0.67") x (5.69")

Notes
-----

There are several Avery numbers whose specifications match other
numbers in the list. The different numbers are caused by packaging
quantities, label colors, or similar factors that do not affect the
layout of the labels.

Label sheets 5096, 5196, and 5896 contain 12 small labels at the
bottom in addition to the nine referenced in the list above. These
labels are not included in the automatic setup of the label sheet.

If the labels you use contain printed borders, you may need to adjust
the paragraph formatting of the information contained in the table
cells with the following steps:

1. Use the MAILLABL template to set up your labels as desired.

2. From the Table menu, choose Select Table.

3. From the Format menu, choose Paragraph. Use the Indentation From
   Left setting to position the text away from the left side of the
   labels.

If you need to move the text down in each cell, you must do this
individually for each cell. You can either add blank lines above the
first line in each cell, or use paragraph formatting to set spacing
above the first line in each cell.

REFERENCES
==========

Avery, Commercial Product Division: back of Avery Laser Label retail
box

Additional reference words: w4wlaserjet w4wmerge 2.00 2.00a 2.00a-cd 
2.00b 2.00c 2.00c-cd third party 3rdparty cross w4wtemplate



WinWord 2.0: Avery Dot-Matrix Label Information
Article ID: Q81938
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

The following is a reproduction of the information found on the back
of the retail package of Avery Dot Matrix Labels. The MAILLABL.DOT
file, which is a mailing label template that ships with  Microsoft
Word for Windows versions 2.0 and 2.0a, gives only the option to
choose Laser Labels when running Microsoft Windows version 3.0. The
template provides the Avery Product Code and a brief description of
each label. The template does not list the dimensions for each label,
which makes the template difficult to use if you do not have Avery
brand labels.

NOTE: In Word for Windows version 6.0, the dimensions of the Avery 
labels are included as part of the label feature.

MORE INFORMATION
================

Avery Dot Matrix Labels
-----------------------

Product Code   Label Size (HxW)   Number of Columns
------------   ----------------   -----------------

4010           15/16" x 3 1/2"         1
4011           1 7/16" x 4"            1
4013 (use 4145)
4065 (use OML 101)
4143           15/16" x 4"             2
4144           15/16" x 2 1/2"         3
4145           15/16" x 3 1/2"         1
4146           1 7/16" x 4"            1
4160           2 7/16" x 3 1/2"        1
4161           2 15/16" x 4"           1
4162           15/16" x 3 1/2"         1
4163           15/16" x 3 1/2"         1
4166           5" x 3"                 1
4167           6" x 3 1/2"             1
4168           4" x 2 1/6"             1
4169           5" x 3"                 1
4240           1 1/4" x 4 3/4"         1
4241           2 3/4" x 2 3/4"         1
4249           15/16" x 3 1/2"         1
4250           15/16" x 3 1/2"         1



4251           15/16" x 3 1/2"         1
4253           15/16" x 3 1/2"         1
4254           15/16" x 3 1/2"         1
4255           7/16" x 3 1/2"          1
4256           7/16" x 3 1/2"          1
4257           7/16" x 3 1/2"          1
4258           7/16" x 3 1/2"          1
4259           7/16" x 3 1/2"          1
4266           7/16" x 3 1/2"          1
4301 (use 4603)
4400 (use 4010)
4600           15/16" x 3 1/2"         1
4601           15/16" x 3 1/2"         1
4602           15/16" x 3 1/2"         2
4603           15/16" x 3 1/2"         3
4604           1 7/16" x 4"            1
4605           1 7/16" x 4"            2
4606           1 1/4" x 4 3/4"         1
4607           2 3/4" x 2 3/4"         1
4609           3/8" x 1 1/2"           5
4610           15/16" x 2 1/2"         3
4611           15/16" x 4"             2
4612           2 15/16" x 4"           2

International (UK) Labels in Millimeters & Inches
-------------------------------------------------

Product Code   Label Size (HxW)   Number of Columns
------------   ----------------   -----------------

OML 099        49mm x 70mm             1
               (1 15/16)" x (2 3/4")
OML 101        24mm x 102mm            1
               (15/16") x (4")
OML 102        37mm x 102mm            1
               (1 7/16") x (4")
OML 103        49mm x 102mm            1
               (1 15/16") x (4")
OML 104        37mm x 127mm            1
               (1 7/16") x (5")
OML 105        49mm x 127mm            1
               (1 15/16") x (5")
OML 202        37mm x 102mm            2
               (1 7/16") x (4")
OML 203        49mm x 102mm            2
               (1 15/16") x (4")
EAL 04         37mm x 89mm             2
               (1 7/16") x (3 1/2")
FAB 03         36.1mm x 69mm           2
               (1 7/16") x (2 3/4")

International (French) Labels in Millimeters & Inches
-----------------------------------------------------

Product Code   Label Size (HxW)   Number of Columns
------------   ----------------   -----------------



Tab1 89.23     23.40mm x 89.0mm        1
               (0.92") x (3 1/2")
Tab1 89.36     36.1mm  x 89mm          1
               (1.42") x (3.5")
Tab1 102.36    36.1mm  x 102mm         1
               (1.42") x (4.01")
Tab1 107.23    23.4mm  x 107mm         1
               (0.92") x (4.21")
Tab1 107.36    36.1mm  x 107mm         1
               (1.42") x (4.21")
Tab1 107.49    48.8mm  x 107mm         1
               (1.92") x (4.21")
EXPE 120.74    74.0mm  x 120           1
               (2.91") x (4.72")
Tab1 125.74    74.0mm  x 125mm         1
               (2.91") x (4.92")
Tab2 89.23     23.4mm  x 89mm          2
               (0.92") x (3.50")
Tab2 89.36     36.1mm  x 89mm          2
               (1.42") x (3.50")
Tab2 107.23    23.4mm  x 107mm         2
               (0.92") x (4.21")
Tab2 107.36    36.1mm  x 107mm         2
               (1.42") x (4.21")
Tab1 85.108    108mm   x 85mm          1
               (4.25") x (3.34")

Note: If the labels you use contain printed borders, you may need to
adjust the paragraph formatting of the information contained in the
table cells as follows:

1. Use the MAILLABL template to set up your labels as desired.

2. From the Table menu, choose Select Table.

3. From the Format menu, choose Paragraph. Use the Indentation From
   Left setting to move the text away from the left side of the labels.

If you need to move the text down in each cell, you must do this
individually for each cell. You can either simply add blank lines
above the first line in each cell, or use paragraph formatting to set
spacing above the first line in each cell.

REFERENCES
==========

Avery, Commercial Product Division: back of Avery Laser Label retail
box

Additional reference words: w4wlaserjet w4wmerge 2.00 2.00a 2.00a-cd 
2.00b 2.00c 2.00c-cd third party 3rdparty cross w4wtemplate



Description of SaveSmall and LoadSmall Macros in WinWord 2.0a
Article ID: Q82954
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows version 2.0a
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

Microsoft Word for Windows version 2.0a includes a template called
PSS.DOC that contains several macros. This document contains sample
macros. The SaveSmall and LoadSmall macros are designed to workaround
the problem of creating large file sizes when you insert graphics into
documents.

STATUS
======

This problem of large file sizes when inserting graphics into a 
document has been corrected in Word for Windows version 6.0.

MORE INFORMATION
================

To use these macros, you need to insert your graphics using the Link
to File option. Before saving your file, run the SaveSmall macro. When
you want to see your graphics again, run the LoadSmall macro.

To run the LoadSmall macro, you must display hidden text. To do this,
select Options from the Tools menu, select the View category, and
choose either the Hidden Text option or the All option in the
NonPrinting Characters box.

There is a problem with the SaveSmall macro. If you have a word
beginning with "import" (such as "important"), the macro finds these
words and generates an error. To work around this problem, use the
following steps:

1. From the View menu, clear the Field Codes command is it is chosen.

2. From the Edit menu, choose Replace. Replace words beginning with
   "import" with other text, such as "***."

3. Run the SaveSmall macro.

4. From the Edit menu, choose Replace. Replace the words again.

Additional reference words: 2.00a w4wmacro w4wtemplate 



WinWord: Macro to Enable Smart Paragraph Numbering
Article ID: Q83243
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

Summary:

The NEWMACRO.DOC file included with Microsoft Word for Windows version
2.0 contains a macro called SmartNumbering; this macro automatically
numbers paragraphs in sequence when you press ENTER.

NOTE: This is a built in feature in Word for Windows version 6.0

MORE INFORMATION
================

To install the SmartNumbering macro, use the following steps:

1. From the File menu, choose Open. Select the Word for Windows
   directory in the Directories box, select the file NEWMACRO.DOC in the
   File Name box, and choose the OK button.

2. From the list of macros under Macro Name, select SmartNumbering,
   and choose the Install button.

3. When prompted, select the template and menu to which you want to
   add the macro, and choose the OK button.

4. The Save dialog box appears and allows you to save changes to any
   open documents. Choose the OK button or the Cancel button. When 
you
   exit Word for Windows, be sure to choose the Yes button in response to
   the prompt "Do you want to save the global glossary and command
   changes?".

5. After you install the macro, the Macro Name box appears again.
   Choose the Cancel button. From the File menu, choose Close.

Using the SmartNumbering Macro
------------------------------

If you did not assign the SmartNumbering macro to a menu when you
installed it, choose Macro from the Tools menu, and select
AutoEnableSmartNumber to turn on SmartNumbering. Select
AutoDisableSmartNumber to turn the feature off. If you did assign the
SmartNumbering macro to a menu, the following menu items appear:

   EnableSmartNumbering
   DisableSmartNumbering



When you choose EnableSmartNumbering, Word adds a number and a tab
character to the beginning of each paragraph and formats the paragraph
for a hanging indent. Each time you press ENTER to begin a new
paragraph, Word adds a sequential number and a tab character to the
beginning of the paragraph. To turn off SmartNumbering, choose
DisableSmartNumbering.

When you install the SmartNumbering macro, the Numbered List button on
the tool bar becomes a toggle between EnableSmartNumbering and
DisableSmartNumbering. When SmartNumbering is enabled, the graphic on
the Numbered List button changes to a large letter N. When
SmartNumbering is disabled, the graphic on the button changes back to
its normal appearance. When you choose the Numbered List button, the
SmartNumbering macro numbers the selected paragraphs.

The SmartNumbering macro can also use alphabetic or Roman numbering.
To switch to alphabetic or Roman numbering, disable SmartNumbering,
position the insertion point at the beginning of the first paragraph
to be numbered, and type "a." or "I." (without the quotation marks),
and press the TAB key, as in the following example:

   a.<TAB>

Enable SmartNumbering. When you press ENTER to create subsequent
paragraphs, alphabetic numbering appears, as in the following example:

   b.<TAB>
   c.<TAB>

To restore numeric sequencing, disable SmartNumbering, type a number,
and press TAB, then re-enable SmartNumbering.

You can start your numbering sequence at any number by disabling
SmartNumbering, typing the desired starting number followed by a TAB
(for example, "12.<TAB>"), then re-enabling SmartNumbering. In this
example, the next paragraph would be numbered "13.<TAB>."

Note: If you select paragraphs with inconsistent sequencing (for
example, some have alphabetic sequences and some have numeric
sequences) and enable SmartNumbering, the series of paragraphs is
reformatted to the style of the first paragraph in the selection.

Notes About the SmartNumbering Macro
------------------------------------

 - The Undo command does not undo SmartNumbering macro actions.

 - As noted above, enabling the feature applies formatting to the
   selected paragraph immediately.

 - If you number some paragraphs with SmartNumbering enabled, then
   disable it, move the insertion point to another location in the
   document, and re-enable SmartNumbering, the previous numbering
   sequence is continued. (For example, if you disabled SmartNumbering 
   at paragraph 6, the first number after you re-enable SmartNumbering is
   7.) This happens regardless of where the insertion point is positioned
   in the document in relation to the first set of numbers. If you select



   a paragraph above the initial sequence and re-enable SmartNumbering,
   the numbering is out of order. If this happens, you can correct it by
   doing one of the following:

   a. Select the affected paragraphs. Choose the Numbered List button.

  -or-

   b. Select the affected paragraphs. From the Tools menu, choose Bullets
      and Numbering, select the Numbered List option and the Replace 
      Only Numbers check box, then choose the OK button.

 - Disable SmartNumbering before switching document windows or 
   opening a new document window. If you do not, your numbering may be
   out of order.

 - If you press ENTER to create blank lines between paragraphs,
   SmartNumbering numbers the lines. Newline characters are not 
   numbered by SmartNumbering.

 - If you delete the number and tab character to remove SmartNumbering
   from a paragraph, the hanging indent paragraph formatting is not
   removed. If you want to completely delete SmartNumbering formatting,
   use one of the following methods:

   a. From the Tools menu, choose Bullets and Numbering. Select the
      Numbered List option, and choose the Remove button.

  -or-

   b. Delete the number and tab character, and press CTRL+Q to restore
      the style's formatting.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 524-528

Additional reference words: 2.00a 2.0a 2.00 w4wmacro toolbar w4wtemplate



Word for Windows: Adding Line Spacing Button to the Tool Bar
Article ID: Q83843
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c, 6.0
 - Microsoft Windows versions 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

In Microsoft Word for Windows versions 2.0 and 6.0, line-spacing
buttons are not part of the default display. In Word for Windows 1.x,
line-spacing buttons are located on the ribbon. This modification is
by design. In Word version 6.0, you can add those buttons (and others)
to the formatting toolbar (or any other toolbar). In Word 2.0, you can
add those buttons (and others) to the tool bar.

MORE INFORMATION
================

To add a line-spacing button to the tool bar, follow the steps below:

Word for Windows version 6.0
----------------------------

1. From the View menu choose Toolbars.

2. Choose the desired toolbar on which to add the line-spacing button if
   it is not currently displayed.

3. Choose Customize.

4. From the list of Categories, choose All Commands.

5. From the Commands list, select the appropriate line-spacing command
   to attach to the button. (Use the table below to locate the
   appropriate command).
   b
6. Drag the appropriate command to the desired location on the toolbar
   and release the button.

7. Choose Close when all desired buttons have been added.

Word for Windows version 2.0
----------------------------

1. From the Tools menu, choose Options, and select the Toolbar
   category.

2. In the Tool to Change box, select a space or an existing button
   that you want to change. A space on the tool bar appears as "[space]"
   (without the quotation marks) in the Tool to Change box. Scan the



   current tool bar to locate an appropriate location.

3. From the Button list, select the appropriate line-spacing button.
   (The list is extensive; it may take a moment to locate the
   appropriate line-spacing button.)

4. In the Show box, select the Commands option button.

5. From the Commands list, select the appropriate line-spacing command
   to attach to the button. (Use the table below to locate the
   appropriate command).

6. Choose the Change button to record the tool bar modification.

7. When you exit Word, the message "Do you want to save the global
   glossary and command changes?" appears. Choose the Yes button to
   save your changes.

Note: If you are using a template other than NORMAL.DOT template,
select either Global or Template in the Context box to indicate where
the tool bar button modification(s) should be saved. If the Template
option button is unavailable, modifications are saved to the Global
template (NORMAL.DOT).

The following table describes line spacing and the various WordBasic
macro commands that control line spacing:

   Spacing Type                     Macro Command   Keyboard Shortcut
   ------------                     -------------   -----------------

   Single-spaced lines              SpacePara1      CTRL+1
   One-and-one-half-spaced lines    SpacePara15     CTRL+5
   Double-spaced lines              SpacePara2      CTRL+2

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 723-725,
back cover

"Using WordBasic," by WexTech Systems and Microsoft, page 289

Additional reference words: tool bar line spacing 2.00 2.00a 2.00a-cd
wm_word 2.00b 2.00c 2.00c-cd 6.00 w4wtemplate



Location of Macros Created in Word for Windows
Article ID: Q86078
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 2.0c-cd, 6.0
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

Microsoft Word for Windows macros can be defined with either global or
template context. Global macros are stored in a global template (only
the NORMAL.DOT file in versions 1.0 and 2.0) and are available from
any document window. Template macros are saved with the active
template and are available only when the active document is based on
that particular template. When you create a macro in a document based
on a template other than NORMAL.DOT, you can select either the
NORMAL.DOT global template or the template attached to the active
document (As Global option button or the In Template option button in
versions 1.0 and 2.0) to set the context of your macro. When you
create a macro in a document based on NORMAL.DOT, the macro is
automatically assigned global context.

If you have created a macro but cannot find it, open the document that
was open when you created the macro, and use the appropriate procedure
below.

Word for Windows version 6.0
----------------------------

1. From the Tools menu, choose Macro. Under Macros Available In: select the
   Normal.dot (Global Template) option.

2. Look for the macro name in the list of macros. If the macro appears in
   the list, the macro is a global macro stored in the NORMAL.DOT template.

3. If the desired macro does not appear in the list, select the template
   that is attached to the current document under the Macros Available In:
   list. (A non-global template will only be listed when the current
   document is based on a template other than NORMAL.DOT). If the macro
   appears in the list, the macro is a template macro stored in the
   template that the current document is attached to.

4. If the desired maro is not listed, select any global templates that may
   be available under the Macros Available In: list. If the desired macro
   is not listed, it may reside in a different template file.

Word for Windows version 2.x
----------------------------

1. From the Tools menu, choose Macro. Under Show, select the Global
   Macros option button.



2. Look for the macro name in the list of macros. If the macro appears
   in the list, the macro is a global macro stored in the NORMAL.DOT
   template.

3. If the desired macro does not appear in the list, select the
   Template Macros option button under Show. (This option button is
   available only when the current document is based on a template other
   than NORMAL.DOT). If the desired macro is not listed, it may reside in
   a different template file.

Word for Windows version 1.x
----------------------------

1. From the Macro menu, choose Edit. Under Context, select the Global
   option button. Select the Show All check box.

2. Look for the macro name in the list of macros. If the macro appears
   in the list, the macro is a global macro stored in the NORMAL.DOT
   template.

3. If the desired macro does not appear in the list, choose the
   Template option button under Context. (This option button is available
   only when the current document is based on a template other than
   NORMAL.DOT). If the desired macro is not listed, it may reside in
   another template file.

MORE INFORMATION
================

If the macro was created using the Word for Windows Macro Recorder, it
may be identified only by a number (Macro1, Macro2, Macro3, and so
forth) unless a specific name was typed in the Record Macro dialog
box. Macros created with the Macro Recorder are set to the context
selected in the Macro dialog box of Word 6.0, the context selected in the 
Template dialog box of Word 2.x or to the context selected in the Record 
Macro dialog box of Word 1.x.

In Word 2.x, you can set the default context for new macros and
glossary items by choosing Template from the File menu and selecting
one of the following option buttons:

 - Global (Available To All Documents)

 - With Document Template

 - Prompt For Each New

By selecting the appropriate option button, you can save new macros
and glossary items with a global or template context, or choose to
have Word prompt you for a location whenever a new macro is recorded.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 764-766



Additional reference words: w4wmacro w4wtemplate global template 1.00
wm_word 1.10 1.10a 2.00 2.00a 2.00a-CD 2.00b 2.00c 2.00c-cd 6.00



WinWord: Installing and Using the SmartQuotes Macro
Article ID: Q86621
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

This article describes how to install and use the SmartQuotes macro
that is provided in version 2.x of Microsoft Word for Windows.

MORE INFORMATION
================

SmartQuotes is a macro that substitutes a decorative "curly" quotation
mark when you type a single or double quotation mark. A total of four
types of smart quotes are made available by enabling the SmartQuotes
macro: Open Double Quote, Close Double Quote, Open Single Quote, and
Close Single Quote.

Note: This is a built-in feature in Word for Windows version 6.0.

Installing SmartQuotes
----------------------

To install the SmartQuotes macro for use in a Word for Windows
template, use the following steps:

1. From the File menu, choose Open.

2. In the Word for Windows program directory, select NEWMACRO.DOC.

3. From the list of macros, select SmartQuotes, then choose the
   Install button.

4. Select the template (for example, NORMAL) where you want
   smart quotes to be available.

5. Choose the Cancel button to close the list. From the File menu,
   choose Close to close NEWMACRO.DOC.

Using Smart Quotes
------------------

To use smart quotes in the template where you have installed the
SmartQuotes macro, use the following steps:

1. From the File menu, choose New. Select the template where you
   installed SmartQuotes, then choose the OK button.



2. From the Tools menu, choose Macro.

3. Under Show, select the Global Macros option button.

4. From the Macro Name list, select AutoEnableSmartQuotes, then 
   choose the Run button.

To disable smart quotes, select AutoDisableSmartQuotes, then choose
the Run button again.

When the SmartQuotes macro is active, the message "Smart quotes
enabled" appears briefly at the lower left corner of your screen.
After enabling smart quotes, single and double quotation marks that
you type are displayed and printed as curly quotation marks.

Note: The macros AutoInsertDoubleQuote and AutoInsertSingleQuote
selectively insert an open or close, double or single quotation mark.
When you run these macros, they insert the appropriate open or close,
double or single curly quotation mark.

Limitations
-----------

The decorative "curly" quotation marks may not be available with every
printer-resident font. They are available from the extended ANSI
character set, but some printers' resident fonts may not support all
these extended characters.

REFERENCES
==========

"Microsoft Windows User's Guide," version 3.0, pages 567-568, 570-571

"Word for Windows Companion," version 1.1, pages 835-841

Additional reference words: 2.00 2.00a 2.00a-cd 2.00b 2.00c 2.00c-cd 
3.00 3.00a 3.10 w4wfont w4wtemplate



Line Number Font and Size Different From Document Font or Size
Article ID: Q88750
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, sometimes the font and size character
formatting of text in the standard style Line Number is different from
the text in the rest of your document. This behavior occurs if you
change the character formatting in the document to a font or size that
is different from that of the Normal style. The Line Number style is
based on the Normal style; therefore, it formats the line number text
for the Normal font and size. The same behavior occurs with other Word
for Windows styles whose descriptions begin "Normal +" (such as Header
or Footer).

WORKAROUND
==========

 - To change the font or size character formatting in a document that
   uses styles whose definition begins with "Normal +", change the Normal
   style definition for that document.

 -or-

 - Change the style definition for the styles, such as Line Number or
   Header, whose definition begins with "Normal +" so the character
   formatting is the same as that of the rest of your document.

Note: In Word for Windows version 6.0, the Line Number style is still based 
on the Normal style, though the definition begins with "Default Paragraph 
Font +". The above information still applies.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 198-199,
213-214

"Microsoft Word for Windows User's Reference," version 1.x, pages
344-347

Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-CD wrong wm_word 
2.00b 2.00c 6.00 stylesheet sheet w4wtemplate



WinWord: Changing Templates Does Not Copy Styles or Margins
Article ID: Q89486
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b
   2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
--------------------------------------------------------------------

SUMMARY
=======

There is a documentation error in the Microsoft Word for Windows 
version 2.0 Help topic titled "Attaching a template to a document." This 
topic incorrectly states that if you use the File Template command to 
attach a different template to your document, margin settings and styles 
change to those of the new template.

This topic should state that when you attach a different template to
your document, the styles and margin settings remain the same as those
of the original template. The template working environment (including
the menu commands, keyboard assignments, and glossaries) changes 
when you change the template attached, but the document itself does 
not change.

The Word for Windows version 6.0 Help topic titled "Attaching a different 
template to a document" correctly does not indicate that margin settings 
change when a different template it attached, but does not completely 
explain how styles can be automatically updated from the template.

MORE INFORMATION
================

For correct information about changing the template attached to a 
document in version 2.0 of Word for Windows, refer to pages 700-701 of 
the "Microsoft Word for Windows User's Guide."

Workaround
----------

To change elements of the document such as margins, page size, headers 
or footers to those of another template, create a new document based on 
the desired template. From the Insert menu, choose File. Select the 
original filename and choose the OK button. Using this method, your 
new document contains these elements of the new template.

To change only the styles in a document to those of another template in 
Word for Windows version 6.0, choose Templates from the File menu, 
attach the desired template and select the "Automatically Update 
Document Styles" option.

To change only the styles in your document in Word for Windows version 
2.0 to those of another document or template, you must merge the new 
styles from a different template or document. For information on merging 



styles from a template into a document, refer to pages 205-208 of the 
"Microsoft Word for Windows User's Guide."

Use the following steps to view this documentation error:

1. From the Help menu, choose Help Index.

2. Choose the Search button.

3. Type "templates" (without the quotation marks), then select
   "templates: attaching to documents." Choose the Show Topics button.

4. Select the "Attaching a template to a document" topic and choose
   the Go To button. The documentation errors occur in the first two
   paragraphs of this topic.

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 205-208,
700-701

Additional reference words:   w4whelp w4wtemplate switch unavailable  wm_word 
docerr doc err 2.00 2.00a 2.00a-CD 2.00b 2.00c 6.
00



WinWord 2.0: Cannot Delete Shortcut Key Assigned to Style
Article ID: Q89706
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, and 2.0b
 - Microsoft Windows operating system versions 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

In Microsoft Word for Windows, if you assign a shortcut key to a
style, save the key assignment as part of a template, then delete the
key assignment, the deletion is saved with the open document, but it
is not saved with the template, even if you select the Add To Template
option in the Style dialog box. As a result, when you create a new
document based on that template, the key assignment is restored.

STATUS
======

Microsoft has confirmed this to be a problem in the versions of
Microsoft Word for Windows listed above. This problem was corrected
in Word version 6.0 for Windows.

To obtain new or updated Microsoft products, call the Microsoft Sales
Information Center at (800) 426-9400. If you are outside the United
States, contact the Microsoft subsidiary for your area. To locate
your subsidiary, call Microsoft International Customer Service at
(206) 936-8661.

WORKAROUND
==========

Rename the style. When you rename the style, Word for Windows deletes
the shortcut key assignment.

1. From the Format menu, choose Style. Choose the Define button.

2. Select the style in the Style Name box and check the Add to
   Template option.

3. Choose the Rename button. Type a new name and choose the OK button.
   Choose the Close button.

-or-

Open the template, delete the shortcut key assignment, then save the
template and close it.

1. Repeat steps 1 and 2 above.

2. Clear the Key box and choose the Change button. Choose the Close
   button.



REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 202-203

Additional reference words: 2.00 2.00a 2.00a-CD 2.00b w4wtemplate



WinWord: How to Create a Legal 'Pleading Document'
Article ID: Q90707
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

Some legal documents require "pleading format" (double-spaced text
with line numbers and vertical lines on each side of the text).

Word for Windows version 6.0 uses the Pleading Wizard to accomplish the 
following task.

Note: If you are using Word version 2.0 or 2.0a the following
procedure produces reversed borders under some circumstances.
For more information query:

   left and right and borders and reveresed

To create an 8.5-by-11-inch legal pleading document: 

 1. Create a new document in Word for Windows.

 2. From the View menu, choose Normal.

 3. From the Format menu, choose Page Setup.

 4. Select the Margins option, type a minus sign in front of the
    measurement in the Top box and choose the OK button.

 5. From the View menu, choose Header/Footer (make sure the Different
    First Page check box is clear), select Header, and choose the OK
    button.

 6. Select the blank line in the header and choose Frame from the
    Insert menu.

 7. With the frame selected, choose Frame from the Format menu.

 8. Set Width to Exactly .5". Set Height to Exactly 10" (the height of
    the pleading border). Set Horizontal Position to 0.5" Relative To
    Page. Choose the OK button.

 9. From the Format menu choose Border. To remove the box border,
    choose None for the Line option . Select the right edge of the
    border sample box, and choose the Line option desired. Choose the
    OK button.

10. If you want double-spaced lines, choose Paragraph from the Format
    menu.



11. Under Line Spacing, select Double and choose the OK button. Type
    the line numbers and press ENTER after each number.

To see the results of this procedure, change to page layout view or
print preview.

This document can be saved as a template in order to use the pleading
format in new documents. To save the new document as a template to
base new documents on, do the following:

1. From the File menu choose Save.

2. In the Save File as Type: box, choose Document Template (*.dot).

3. In the File Name: box type in a filename and choose OK.

MORE INFORMATION
================

The Microsoft Legal Resource Kit (LRK) was created for people in the
legal profession who use version 2.0 of Microsoft Word for Windows.
The LRK includes BRIEF.DOT, a legal template with the pleading format.
This template shipped with Word for Windows versions 1.0, 1.1, and
1.1a for Windows, but not with versions 2.0 and 2.0a. BRIEF.DOT has
been converted and improved for use with Word versions 2.0, 2.0a,
2.0a-CD, and 2.0b.

For more information on using BRIEF.DOT, query on the following
words in the Microsoft Knowledge Base:

   legal and brief.dot

For more information on the Legal Resource Kit, query on the following
words in the Microsoft Knowledge Base:

   legal and resource and kit

Additional reference words: 2.00 2.00a 2.00a-cd 2.00b 2.00c 2.00c-cd brief 
dot 3.00 w4wtemplate 3.10 paper



WinWord: Illegal Macro Name Cannot Be Deleted
Article ID: Q91145
----------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
----------------------------------------------------------------------

SYMPTOMS
========

You can use the WordBasic MacroCopy statement to assign an illegal
name to a Word for Windows macro. The Run, Edit, Rename, and Delete
buttons in the Macro dialog box are unavailable when you select a
macro with an illegal name. As a result, you cannot remove an
incorrectly named macro from your Word for Windows template.

STATUS
======

This has been corrected in Word for Windows version 6.0. It is not
possible to add an incorrectly named macro to a template.

Note: A macro name cannot contain any spaces, punctuation, or text
characters below decimal code 33 or above decimal code 124.

MORE INFORMATION
================

Steps to Reproduce Problem
--------------------------

Below is a macro that copies the macro "macroname" from TEMPL_1.DOT to
TEMPL_2.DOT as " macro name" (notice the two spaces). The name " macro
name" is illegal because of these two space characters.

   Sub MAIN
   MacroCopy "TEMPL_1":"macroname","TEMPL_2":" macro name"
   End Sub

When you run this macro, no error message is displayed and the new
macro name appears in the Macro dialog box. If you attempt to rename
or delete this macro using a WordBasic command such as the one shown
below, an "Illegal function call" WordBasic error message is
displayed.

   ToolsMacro .Name=" macro name", .Rename, .NewName="macroname"

Note: The macrocopy command listed above will produce an error when run in 
Word for Windows version 6.0 and will not allow the incorrect macroname to be 
copied to the template.

REFERENCES



==========

"Using WordBasic," by WexTech Systems and Microsoft, pages 97,
253-254, 308

Additional reference words:greyed w4wmacro w4wtemplate grayed gray
grey ghosted not available 2.00 2.00a 2.00a-CD 2.00b 2.00c



Word: Style List on Ribbon Shows Too Many Styles
Article ID: Q91654
--------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system version 3.0 and 3.1
--------------------------------------------------------------------

Summary:

Microsoft Word for Windows adds unused standard styles to the styles box 
on the ribbon when you copy information from one document and paste it 
in another. Word should add styles to the styles box only if they are 
used in your document; instead, Word sometimes displays styles that you 
have never used in any document. When this happens, Word requires more 
time to display the list of styles when you select the drop-down arrow. 
You cannot delete these extraneous styles from the styles box once Word 
for Windows has added them to a document.

Microsoft has confirmed this to be a problem in Word versions 2.0, 2.0a,
2.0a-CD, 2.0b, and 2.0c. This problem was corrected in Word version 6.0 
for Windows.

More Information:

This problem occurs after you modify a standard style and save the 
changes in your NORMAL.DOT template file. If you later copy text from a 
document based on the revised NORMAL.DOT file and paste it in a new 
document, Word sometimes adds a large number of never-used standard 
styles to the styles box on the ribbon.

Workaround
----------

From the Format menu, choose Style. In the Style dialog box, select
the style you want to delete and choose the Delete button.

Note: This workaround works only for custom styles. It does not work for
standard styles because you cannot delete standard styles.

Steps to Reproduce Problem
--------------------------

1. Create a new document based on the default NORMAL.DOT template.

2. From the Format menu, choose Styles. Press CTRL+Y to display the
   complete list of Word standard styles in the Style Name list. Choose
   the Define button and select the Add To Template check box.

3. Select Annotation Reference in the Style Name box. Choose the 
   Character button, then choose the OK button. (You do not need to   
   modify any settings in the Character dialog box.) In the Styles 
   dialog box, choose the Change button. Choose the Yes button when Word 



   asks if you want to change the properties of the standard style, then 
   choose the Close button.

4. From the File menu, choose Exit. Choose the Yes button when you are
   prompted to save the global command and glossary changes, then   
   restart Word for Windows.

5. In a new document based on the default NORMAL.DOT template, type six
   single-line paragraphs. Be sure to press ENTER at the end of each
   line.

6. Position the insertion point on the first line and apply the Heading   
   1 style.

7. From the Edit menu, choose Select All. From the Edit menu, choose 
   Copy. Press CTRL+END to position the insertion point at the end of 
   the document.

8. Press SHIFT+INS ten times to paste ten copies of the text.

9. From the Edit menu, choose Select All. From the Edit menu, choose 
   Copy. From the File menu, choose New and choose the OK button to 
   create a new document based on the NORMAL.DOT template.

10. From the Edit menu, choose Paste.

11. Open the styles box on the ribbon. Note that many standard styles 
    are displayed, even though you have not used them in either 
    document. The only styles that Word for Windows should display are 
    Normal, Heading 1, Heading 2, Heading 3, and Annotation Reference 
    (the latter style displays because you modified it in step 3 above).

Reference(s):

"Microsoft Word for Windows User's Guide," version 2.0, pages 198-199

"Microsoft Word User's Guide," Word for the Macintosh version 5.0, page 
184

Additional reference words: w4wformat
2.00 2.00a 2.00a-CD 2.00b 2.00c w4wtemplate



How to Add a Vertical Line to the Right Edge of a Pleading
Article ID: Q96208
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c 2.00c-cd
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======
 
The BRIEF.DOT template supplied with the Microsoft Legal Resource Kit
for Word for Windows is formatted with a vertical line and line
numbers at the left edge of the document to create pleading paper.
Below are steps to modify the BRIEF template to add a vertical line to
the right edge of the page.
 
NOTE: This functionality is included in the Word for Windows version 6.0 
Pleading Wizard.

MORE INFORMATION
================

NOTE: Microsoft does not support modification of templates that ship
with Word for Windows.
 
To add a vertical line to the right edge of a pleading
------------------------------------------------------
 
1. From the File menu, choose Open. In the List Files Of Type box,
   choose Document Templates and, if necessary, change the Drives and
   Directories boxes to the location where your templates are stored.
   Select BRIEF.DOT from the File Name list, then choose the OK
   button.
 
2. In normal view, choose Header/Footer from the View menu and
   choose the OK button to view the header. Scroll to the bottom of
   the header and, with paragraph marks showing, position the
   insertion point at the end of the header and press ENTER to insert
   a new blank paragraph.
 
3. From the Table menu, choose Insert Table. Set the number of
   columns to 1 and the number of rows to 1, then choose the OK
   button.
 
4. From the Table menu, choose Row Height and set the row height to
   Exactly 10.5" (or whatever length you want the line to be). Choose
   the OK button.
 
5. From the Table menu, choose Column Width and set the width to .2".
   Choose the OK button.
 
6. Select the table and choose Frame from the Insert menu.



 
7. From the Format menu, choose Frame and specify the following
   settings to move the table over within .5 inch of the right edge of
   the page:

      Horizontal Position             8.0"
                 Relative To          Page
      Vertical   Position             0"
                 Relative To       Page

   Choose the OK button.
 
8. From the Format menu, choose Border. Choose the left border in the
   Border box, select a line style, and choose the OK button.
 
9. Choose the Close button at the top of the Header pane, then choose
   Page Layout from the View menu, or Print Preview from the File menu
   to see if you need to make any adjustments.
 
REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 315-316,
334, 336, 363, 393, 395-396
 
Additional reference words: lrk law court w4wtemplate 2.00 2.00a
2.00a-CD 2.00b 2.00c 2.00c-CD 



How to Disable a Word 'Auto' Macro
Article ID: Q96565
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 2.0c-CD, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
SUMMARY
=======

To prevent a Microsoft Word for Windows auto macro from running, hold
down the SHIFT key when you perform the action that triggers the
macro. AutoExec, AutoNew, AutoOpen, AutoClose, and AutoExit are the
auto macros in Word for Windows.

MORE INFORMATION
================

When opening a Word for Windows document that is associated with a
template that contains an AutoOpen macro, hold down the SHIFT key
until the document is completely opened. Depressing the SHIFT key
prevents the action that triggers the macro.
 
When opening a new Word for Windows document based on a template that
contains an AutoNew macro, hold down the SHIFT key until the new
document is opened.
 
To prevent a Word for Windows AutoExec macro from executing, do one of
the following: 
 
 - At the command prompt, type "win winword /m" (without the
   quotations marks) and press ENTER.

 -or-

 - Select the Word for Windows program icon in Program Manager. From the
   File menu, choose Properties. Add the /m switch to the current command
   line parameter (for example, "C:\WINWORD\WINWORD.EXE /m").
 
 -or-
 
 - Press and hold down the SHIFT key while double-clicking the Word
   for Windows program icon.
 
In Word for Windows version 6.0, you can use the following command line to 
disable all auto macros, including AutoExec:

   C:\WINWORD\WINWORD.EXE /mDisableAutoMacros

REFERENCES
==========
 



"Microsoft Word for Windows User's Guide," version 2.0, page 786
 
"Microsoft Word for Windows User's Reference," page 189

Additional reference words: w4wmacro w4wtemplate 1.00 1.10 1.10a 2.00
wm_word 2.00a 2.00a-CD 2.00b 2.00c 2.00c-CD 6.00 AutoExec, AutoNew,
AutoOpen, AutoClose, AutoExit



Wrong Error Message Saving Template Using FileSaveAs Macro
Article ID: Q97115
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

If you save a template using the FileSaveAs macro command in a format
other than Document Template (*.dot), Word for Windows returns the
following error message in Word versions 2.0, 2.0a, 2.0a-cd, 2.0b, and
2.0c:

   You cannot save an open document in another format to the same
   location.

   and the following error message in Word versions 1.x:

   Cannot write foreign format over open document.

These are not the messages that should appear. The message that should
display instead is:

   Command not available.

After this message appears, the FileSaveAs macro should stop.

STATUS
======

Microsoft has confirmed this to be a problem in Word for Windows
versions 1.0, 1.1, 1.1a, 2.0, 2.0a, 2.0a-cd, 2.0b, and 2.0c. This 
problem  was corrected in Word for Windows version 6.0.

In Word for Windows version 6.0, the following error message appears:

Microsoft Word Err=1058
You cannot save a template file to non-template format.
(filename)

REFERENCES
==========

"Microsoft Word for Windows User's Guide," version 2.0, pages 702-703

"Microsoft Word for Windows User's Reference," version 1.x, page 410

Additional reference words: w4wmacro docerr 1.00 1.10 1.10a 2.00 2.00a
2.00a-cd 2.00b 2.00c w4wtemplate



File Save As Type List Box Unavailable for Template Files
Article ID: Q97134
-------------------------------------------------------------------
The information in this article applies to:

 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------

SUMMARY
=======

If you create a new Word for Windows template or open an existing
template file and then try to save it by choosing the Save As command
from the File menu, the Save File As Type list box (the File Format
list box in Word version 1.x) is unavailable (dimmed).

This occurs because you cannot change the file format of a Word
template. Once you save a file as a template, you cannot save
it as a document.

Workaround 1
------------

1. From the File menu, choose New.

2. Under New, select the Document option button.

3. From the Use Template list box, select the name of the template
   corresponding with the format in which you want to save your
   document.

4. Choose the OK button.

5. From the File menu, choose Save. The Save File As Type list box is
   now available, so you can select a different file format.

Workaround 2
------------

1. Open your template file and highlight the entire text to select it.

2. Press CTRL+C to copy the contents of the template to the Clipboard.

3. From the File menu, choose New.

4. Press CTRL+V to create a new document. You can save the new
   document in a different file format.

Additional reference words: 6.00 1.00 1.10 1.10a 2.00 2.00a 2.00a-cd
2.00b wm_word 2.00c w4wtemplate unavailable greyed dimmed gray grayed



Prompt to Save Changes to Document Template
Article ID: Q97906
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
SUMMARY
=======

In Microsoft Word for Windows, when you close or save a document after 
you have made style, autotext (version 6.0), glossary, macro, menu, 
toolbar, or keyboard assignment changes to the template attached to the 
document, Word asks you if you want to save the changes to the 
template file itself.
 
When you close a document or choose Save All from the File menu in 
Word, the following message may appear:

   Word Versions     Message
   -------------------------
 
   2.0 and later     Do you want to save changes to <templatename>?
   1.x               Save changes to <templatename>?
 
If you choose Yes, the changes you made will be saved to the template
file itself.
 
When you save a document in Word, the following message may appear:

   Word Versions     Message
   -------------------------
 
   2.0 and later     Do you want to save changes to the document
                     template?
   1.x               Save changes to document template too?
 
If you choose Yes, the changes you made will be saved to the template
file itself.
 
MORE INFORMATION
================

The results of choosing Yes to these prompts differ depending on what 
kind of changes you made.
 
Autotext (version 6.0), glossary, macro, menu, toolbar, and keyboard 
assignment changes are reflected in every document based on the 
template, even those documents that you have already created and
saved.
 
Style changes saved to the template are reflected only in new documents 



you create based on the template. Documents you created previously 
based on the template do not reflect the style changes in the template.
 
Additional reference words: 1.00 1.10 1.10a 2.00 2.00a 2.00a-cd 2.00b wm_word 
2.00c w4wtemplate



Accessing Menu Commands Not Visible on a Menu
Article ID: Q99682
--------------------------------------------------------------------
The information in this article applies to: 
 
 - Microsoft Word for Windows, versions 1.0, 1.1, 1.1a, 2.0, 2.0a,
   2.0a-CD, 2.0b, 2.0c, 6.0
 - Microsoft Windows operating system versions 3.0 and 3.1
--------------------------------------------------------------------
 
SUMMARY
=======

Some of the templates that are used in Microsoft Word for Windows may 
have customized or modified menus. You can add or remove menu items 
with the Macro Assign To Menu command.
 
Also, when you use Word 1.x templates such as BASIC.DOT or 
REPORT.DOT in Word 2.0, 2.0a, 2.0a-Cd, 2.0b, or 2.0c, some of the 
menu options (such as Style on the Format menu) may not be available.
 
MORE INFORMATION
================
 
Available menu options vary depending on which template is open. You
can use the following methods to access unavailable menu commands or
restore desired menu commands to the menus.
 
Running Macros in Word 6.0
--------------------------

To run a macro that is not on a menu in Word 6.0, follow these steps:
 
1. From the Tools menu, choose Macro.
 
2. Under Macros available in: select the template that contains the macro 
   you want to run.

3. Select the macro you want to run, and choose Run.

Adding Macros to Menus in Word 6.0
----------------------------------
 
To assign a macro command to a menu, do the following:
 
1. From the Tools menu, choose Customize.
 
2. Select the Menus tab.
 
3. In the Categories box, choose macros.
 
4. Under Save Changes In: select the template you want the menu item 
   added to.
 
5. Select the macro name to be added to the menu.



 
6. Choose the desired menu to add the macro to, the desired position on 
that menu and the desired name to appear on the menu.

7. Choose Add, and Close.

Running Macros in Word 2.0, 2.0a, 2.0a-CD, 2.0b, and 2.0c
---------------------------------------------------------
 
To run a macro that is not on a menu in Word 2.x, follow these steps:
 
1. From the Tools menu, choose Macro.
 
2. Under Show, select Global Macros if you want to access macros
   stored in the NORMAL template, or Template Macros if you want to
   access macros stored in a different template.
 
3. Select the macro you want to run, and choose Run.
 
Adding Macros to Menus in Word 2.0. 2.0a, 2.0a-Cd, 2.0b, and 2.0c
-----------------------------------------------------------------
 
To assign a macro command to a menu, do the following:
 
1. From the Tools menu, choose Options.
 
2. Under Category, select Menus.
 
3. In the Menu box, select the menu to which you want to add the
   macro command.
 
4. Under Show, select Macros.
 
5. Under Context, select either Global or Template.
 
6. Select the macro name to be added to the menu.
 
7. Choose Add, then choose Close.
 
8. When you exit Word, choose Yes to the prompt "Save global glossary
   and command changes?"
 
Using Word 1.x templates in Word 2.0, 2.0a, 2.0a-Cd, 2.0b, and 2.0c
-------------------------------------------------------------------
 
When you use Word 1.x templates (such as BASIC.DOT or REPORT.DOT)
in Word 2.x, some of the menu options (such as Style under the Format
menu) will not be available. Available menu options may vary depending
on which template is currently open. If you need to access other menu
options, use the following procedure to reset the menus:
 
1. Open the template.
 
2. From the Tools menu, choose Options.
 
3. Under Category, select Menus.
 



4. Choose Reset All.
 
This will allow you to access all the Word 2.x menu options when you
are using the Word 1.x template.
 
However, the drawback to this method is that it resets all menu items.
Therefore, any specially added menu items will also be reset.
 
Running Macros in Word 1.x
--------------------------
 
To run a macro command not available on a menu in Word 1.x, follow
these steps:
 
1. From the Macro menu, choose Run.
 
2. Select the macro name.
 
3. Choose OK.
 
   Note: If the macro command does not appear, select Show All.
 
Adding Macros to Menus in Word 1.x
----------------------------------
 
To assign a macro command to a menu, do the following:
 
1. From the Macro menu, choose Assign To Menu.
 
2. Select the macro or command you want to add to the menu.
 
3. Select the menu to which you want to add the command or macro.
 
4. Edit the menu text if necessary.
 
5. Choose the Assign button to add the command to the designated 
   menu.
 
Note: The short menu structure of Word 1.x is a shorter version of the
full Word menus. Check the View menu to verify that you are using Full
Menus. (Because this is a toggle command, you will know that the Full
Menus command is selected if the Short Menus option is listed in the
menu.)
 
Additional reference words: w4wtemplate 1.00 1.10 1.10a 2.00 2.00a wm_word 
2.00a-cd 2.00b 2.00c 6.00



How to Modify or Add a Template Description
Article ID: Q102500
-------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b,
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
-------------------------------------------------------------------
 
The text that appears in the Description box of the File New dialog
box comes from the Title setting in the Summary Info dialog box.

Therefore, to modify or add a description to your template:

1. Open the template.

2. From the File menu, choose Summary Info.

3. Type the new description in the Title box.

4. Choose OK.
 
REFERENCES
==========
 
Word for Windows "User's Guide," version 2.0, pages 488, 492
 
Additional reference words: 2.00 2.00a 2.00a-CD 2.00b 2.00c w4wtemplate



File Find Content Displays Incorrectly Formatted Text
Article ID: Q105642

--------------------------------------------------------------------
The information in this article applies to: 
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c
 - Microsoft Windows operating system versions 3.0 and 3.1
--------------------------------------------------------------------

SYMPTOMS
========

In Word versions 2.x for Windows, when you view the content of a
document with the Find File feature, the formatting of the text may
display differently than the actual formatting of the document.

STATUS
======

Microsoft has confirmed this to be a problem in Word for Windows,
versions 2.0, 2.0a, 2.0a-cd, 2.0b, and 2.0c. This problem was
corrected in Word 6.0 for Windows.

MORE INFORMATION
================

When you view the content of a document in the File Find dialog box,
the formatting displays as if the document is attached to the Normal
template. Any styles used in the document will display as defined in
the Normal template. Styles not defined in the Normal template will
display correctly.

Steps to Reproduce Problem
--------------------------

1. Start with a new document based on the Normal template in Word for
   Windows. From the Format menu, choose Character.

2. Change the font, points, and color options, and choose the Use As
   Default button. Answer Yes to change the format of the Normal style.

3. From the File menu, choose Find File.

4. Locate and select a file attached to a template other than the
   Normal template. Choose the Options button, choose Contents from the
   List File Names With option, and choose OK.

Result: The file based on a template other than Normal.dot displays
with the formatting of the styles in the Normal template.

Additional reference words: w4wtemplate 2.00 2.00a 2.00a-cd 2.00b
2.00c 



Template Not Listed in File Find Summary View
Article ID: Q105859
--------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Word for Windows, versions 2.0, 2.0a, 2.0a-CD, 2.0b, 
   2.0c, and 6.0
--------------------------------------------------------------------
 
SYMPTOMS
=========
 
In Word versions 2.0 and later, when you use the File Find command to
view a document's Summary (Statistics in version 2.0), the Template
field will be blank if that document is attached to NORMAL.DOT.
 
CAUSE
=====

This behavior is by design.

MORE INFORMATION
================
 
Document summary information includes the name and location of the
template attached to the active document. You can view this
information by choosing Summary Info from the File menu and choosing
the Statistics button, or by choosing Find File from the File menu,
choosing Summary from the Commands button, (the Summary button in
versions 2.x), and choosing the Statistics button.
 
In each case above, the template will be listed. However, when you
choose to display the document with its Summary Information using the
Find File command, the Template field will be blank if the document is
attached to the Normal template.
 
Additional reference words: w4wtemplate findfile 2.00 2.00a 2.00a-CD
2.00b 2.00c 6.00 wm_word




